Tabela

A tabela é um objeto da pasta que mostra vários campos simultaneamente. O conteúdo de todas as linhas é conectado logicamente. As colunas podem ser lidas em diferentes tabelas internas, permitindo que o usuário crie tabelas a partir de qualquer combinação possível campos.

Clique com o botão direito do mouse na tabela para exibir o menu Objeto.

Nota: Se você incluir em uma tabela grandes quantidades de dados do campo provenientes de tabelas de dados desvinculadas, o QlikView criará junções cartesianas para criar as vinculações necessárias, o que pode resultar em um alto consumo de memória e outros problemas de desempenho.

Usando a Tabela

Classificação

É possível classificar a tabela por qualquer coluna: clique na coluna com o botão direito do mouse e escolha Classificar no menu de contexto. Clique duas vezes no título da coluna para classificá-la. Se você escolher Classificar no menu de contexto, ou clicar duas vezes no mesmo título de coluna, a ordem de classificação será invertida.

Alterando a ordem das colunas

A ordem das colunas pode ser alterada com o método de arrastar e soltar. Aponte para o título da coluna e mantenha o botão do mouse pressionado enquanto arrasta a coluna para sua nova posição. Desabilite esse recurso desmarcando a caixa de seleção Permitir arrastar e soltar na página Propriedades da tabela: Apresentação.

Menu Objeto

O menu Objeto da tabela tem duas versões distintas. Se você clicar na área do título, o menu suspenso conterá comandos aplicáveis à tabela como um todo; se um campo individual estiver sob o ponteiro do mouse, o menu será ampliado para incluir comandos aplicáveis a esse campo. Os comandos combinados dos menus são:

Propriedades... Abre a caixa de diálogo Propriedades da Tabela, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ajustar Colunas aos Dados Ajusta a largura de todas as colunas das tabelas aos maiores dados de cada coluna. O cabeçalho está incluído no cálculo.
Igualar Largura das Colunas Define a largura das colunas da tabela como igual à da coluna na qual você clicou.
Classificar Classifica os registros pelo campo no qual você clicar.
Personalizar Formato da Célula Abre a caixa de diálogo Personalizar Formato da Célula, que lhe permite formatar as células da coluna e da listra em que você clicar. Esse menu em cascata só fica disponível quando o comando Grade de Design do menu Exibir está ativado.
Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Alterar Valor Disponível somente para colunas de tabela que exibem campos de entrada. Define a célula clicada no modo de entrada. Equivale a clicar no ícone de entrada na célula.
Restaurar Valores Disponível somente para colunas de tabela que exibem campos de entrada. Abre um menu em cascata com três opções.
Restaurar Valor Único
Restaura o valor no valor de campo clicado para o valor padrão do script.
Restaurar Valores Possíveis
Restaura os valores de todos os valores de campo possíveis para os valores padrão do script.
Restaurar Todos os Valores
Restaura os valores de todos os valores de campo para seus valores padrão do script.
Selecionar Valores Possíveis Todos os valores não-excluídos do campo são selecionados.
Selecionar Valores Excluídos São selecionados todos os valores excluídos do campo.
Selecionar Tudo São selecionados todos os valores do campo.
Limpar Todas as Seleções Limpa as seleções em todos os campos mostrados na tabela.
Limpar Limpa todas as seleções atuais do campo.
Limpar Outros Campos Seleciona todos os valores possíveis no campo atual e, em seguida, limpa as seleções em todos os outros campos.
Bloquear Trava o(s) valor(es) selecionado(s) do campo.
Destravar Destrava o(s) valor(es) travado(s) do campo.
Imprimir... Abre o diálogo Imprimir que permite especificar a configuração de impressão.
Imprimir como PDF...

Abre a caixa de diálogo Imprimir com a impressora PDF-XChange 3.0 pré-selecionada. Depois de pressionar o botão Imprimir, você deverá digitar um nome para o arquivo PDF a ser gerado. Esse comando só estará disponível se houver uma impressora PDF no sistema.

Enviar para Excel Exporta os valores possíveis (incluindo os selecionados) para o Microsoft Excel, que será acionado automaticamente se ainda não estiver sendo executado. Os valores exportados aparecerão em uma nova planilha do Excel. Para que esse recurso funcione, o Microsoft Excel 2007 ou versão posterior deve estar instalado no computador.
Exportar...

Exporta o conteúdo da tabela para um arquivo de sua escolha. O arquivo pode ser salvo com qualquer um dos seguintes formatos: Delimitado por Vírgula, Delimitado por Ponto e Vírgula, Delimitado por Tabulação, Hipertexto (HTML), XML e Excel (xls ou xlsx). O formato padrão é *.qvo (QlikViewOutput), um arquivo separado por tabulações.

As imagens de uma tabela não serão incluídas na exportação para o formato HTML.

Copiar para a Área de Transferência

Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Tabela Completa
Copia a tabela completa para a área de transferência, inclusive com o cabeçalho e o status de seleção.
Área de Dados da Tabela
Copia somente os valores da tabela para a área de transferência.
Valor da Célula
Copia o valor de texto da célula de lista clicada com o botão direito (ao invocar o menu Objeto) para a área de transferência.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou excluirá o título e a borda do objeto de pasta, de acordo com as configurações na página Preferências do Usuário: Exportar. As tabelas geradas pela parte oculta do script não serão representadas por um nome no campo de sistema $Table.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Caixa de diálogo Personalizar Formato da Célula

Esse diálogo permite aplicar formatos personalizados a um ou mais grupos de células da tabela. Ele pode ser chamado a partir dos menus de objeto de uma tabela, uma tabela estática ou uma tabela dinâmica, contanto que o comando Grade de design do menu Exibir esteja ativo, ou quando a opção Sempre mostrar itens do menu de design em Preferências do usuário: Design estiver marcada.

O grupo de células que será afetado pelo formato é determinado pelo local em que você clica com o botão direito do mouse na tabela para chamar o comando. O menor grupo de células a ser formatado como uma unidade é um campo (normalmente coluna) em uma tabela ou uma expressão/dimensão em um gráfico. Se forem usadas listras, cada uma delas será formatada separadamente.

Sempre que essa caixa de diálogo for usada para personalizar o formato de qualquer parte de uma tabela, o Estilo, como definido na página Estilo, da caixa de diálogo Propriedades, será definido como [Personalizar]. Se você alterar a configuração de Estilo novamente para um dos estilos predefinidos, a formatação personalizada será perdida.

Nota: Os estilos de tabela em geral serão substituídos por qualquer formato resultante das expressões de atributo.
Painel de Visualização de Tabela O painel de visualização mostra as alterações de formato feitas ao(s) grupo(s) de células da tabela. Diferente da visualização menor à direita, Amostra de Texto, ele mostra as alterações no contexto e posteriores à aplicação de efeitos visuais e/ou da formatação da expressão de atributo.
Neste painel você pode se movimentar livremente pela tabela e aplicar formatos a diferentes grupos de células. Basta clicar em uma célula para mudar o foco do formato.
Desfazer O botão Desfazer pode ser usado para desfazer as alterações feitas etapa por etapa na caixa de diálogo Personalizar Formato de Célula.
Depois de fechar a caixa de diálogo Personalizar Formato de Célula, todas as alterações feitas na caixa de diálogo poderão ser desfeitas, basta clicar no botão Desfazer, localizado na barra de ferramentas principal.
Refazer O botão Refazer pode ser usado para reaplicar as alterações desfeitas anteriormente pelo botão Desfazer, dentro da caixa de diálogo Personalizar Formato de Célula, etapa por etapa.
Amostra de Texto Essa é a célula de visualização que mostra as configurações feitas.
Cor de Fundo Define a cor de fundo da célula.
Cor do Texto Define a cor do texto da célula.
Borda antes da célula Aqui você define a borda que precede a célula. Há um menu suspenso para definição de estilo de borda e um botão para definir a cor da borda. Observe que as bordas da célula serão mescladas entre células, o que pode fazer com que a borda real da tabela tenha uma aparência diferente da visualização.
Borda depois da célula Aqui você define a borda que sucede a célula. Há um menu suspenso para definição de estilo de borda e um botão para definir a cor da borda. Observe que as bordas da célula serão mescladas entre células, o que pode fazer com que a borda real da tabela tenha uma aparência diferente da visualização.
Configurações do texto Nesse grupo, há vários modificadores de texto aplicáveis à célula.
Tamanho do texto
Use o menu suspenso para aplicar uma modificação de tamanho à fonte geral utilizada na tabela.
Negrito
Marque essa caixa de seleção para usar texto em negrito.
Itálico
Marque essa caixa de seleção para usar texto em itálico.
Sublinhado
Marque essa caixa de seleção para usar texto sublinhado.
Sombreado
Marque essa caixa de seleção para usar texto com sombreado.
Aplicar alterações a Normalmente, as alterações são aplicadas apenas à expressão, à dimensão ou ao campo (tabelas), no qual você clicou com o botão direito do mouse para acessar a caixa de diálogo. Com a ajuda desse menu suspenso, é possível aplicar o mesmo formato a outras expressões, dimensões ou campos.

Geral

A guia Propriedades da tabela: Geral será aberta se você clicar com o botão direito do mouse em uma tabela e escolher o comando Propriedades no menu suspenso ou selecionar Propriedades no menu Objeto quando uma tabela estiver ativa.

Título

Na janela Título, a tabela pode receber um nome que será exibido no título da janela.O título também pode ser definido como uma fórmula calculada para atualização dinâmica do texto do rótulo. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Campos Disponíveis Nesta coluna são mostrados os nomes dos campos de fonte de dados. Inicialmente, todos os campos (com exceção dos campos do sistema) aparecem nesta coluna. Para incluir os campos do sistema, marque a opção Mostrar Campos do Sistema. Selecione os itens a serem utilizados/excluídos clicando neles. Use os botões Incluir > ou < Remover para movê-los para a coluna desejada.
Campos Mostrados em Tabela Nesta coluna são mostrados os nomes dos campos selecionados na lista Campos Disponíveis para serem incluídos na tabela. Inicialmente, não há campos nesta coluna.
Ao selecionar um campo nessa lista, você pode atribuir a ele um Rótulo personalizado na janela de edição.
Mostrar Campos do Sistema Marque essa caixa para que os campos de sistema sejam exibidos na coluna Campos Disponíveis.
Mostrar Campos da Tabela Aqui, é possível controlar os campos que aparecerão na lista Campos Disponíveis. A lista suspensa mostra a alternativa Todas as Tabelas por padrão. Se desejar que a lista mostre os campos de uma tabela específica, selecione o nome da tabela na lista suspensa.
A alternativa Todas as Tabelas (Qualificados) mostra os campos qualificados pelo nome das tabelas em que eles ocorrem. Isso significa que campos chave (de conexão) serão listados mais de uma vez. (Essa alternativa é usada apenas para fins de exibição e não tem nada a ver com os campos Qualify no script de carregamento.)
Promover Move um campo para cima na ordem de exibição.
Rebaixar Move um campo para baixo na ordem de exibição.
Ordem de Contagem Classifica os campos na coluna Campos Mostrados em Tabela em ordem numérica.
Ordem de Carregamento Classifica os campos na coluna Campos Mostrados em Tabela em ordem de carga, ou seja, na ordem em que são lidos na base de dados.
Ordem Alfabética Classifica os campos na coluna Campos Mostrados em Tabela em ordem alfabética.
Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto

É utilizado para fins de macro. A cada objeto da pasta é atribuído um ID exclusivo. Recomendamos o uso de caracteres alfanuméricos apenas na ID. Para tabelas, a ID começa como TB01. Os objetos vinculados têm o mesmo ID de objeto. Você pode editar posteriormente esse número de ID.

Interpretador Interno de Macro

Condição de Cálculo Especifica uma Condição de Cálculo que deve ser preenchida para que a tabela seja exibida. Quando a condição não for satisfeita, será exibida a mensagem "Condição de cálculo não satisfeita".
Mensagens de Erro

As mensagens de erro padrão nas tabelas (e gráficos) podem ser personalizadas na caixa de diálogo Mensagens de Erro Personalizadas, que é aberta ao clicar no botão Mensagens de Erro.

Mensagens de Erro Personalizadas

Classificar

A guia Propriedades da tabela: Classificar será aberta se você clicar com o botão direito do mouse em uma tabela e escolher o comando Propriedades no menu suspenso.

Na lista Prioridade de Classificação, os campos da tabela são exibidos. A ordem dos campos determina a ordem de classificação aplicada quando o comando Classificar é executado. A ordem dos campos pode ser alterada usando os botões Promover e Rebaixar. É possível especificar para cada campo da lista os critérios a serem utilizados no procedimento de classificação. Os critérios de classificação são descritos a seguir.

Classificar por:

Expressão Os valores de campo serão classificados de acordo com uma expressão arbitrária digitada na caixa de edição de texto abaixo dessa opção de classificação.
Frequência Alterna entre os status de realização ou não do procedimento de classificação de valores por frequência.
Valor numérico Alterna entre os status de realização ou não do procedimento de classificação de valores por valor numérico.
Texto Alterna entre os status de realização ou não do procedimento de classificação de valores em ordem alfabética, de acordo com o padrão ASCII.
Ordem de Carregamento Alterna entre os status de realização ou não do procedimento de classificação de valores por ordem de carga.

Se mais de uma ordem de classificação for especificada, a classificação será por ordem de expressão, frequência, numérica, de texto e de carga.

Apresentação

A guia Propriedades da tabela: Apresentação será aberta se você clicar com o botão direito do mouse em uma tabela e escolher o comando Propriedades no menu suspenso.

Nesta caixa de diálogo é determinado o layout da tabela.

Alinhamento O alinhamento padrão de valores de campo pode ser definido separadamente para Texto e Números por meio da seleção do campo na lista Campos e da opção apropriada no grupo Alinhamento. Por padrão, os valores de texto são alinhados à esquerda e os valores numéricos são alinhados à direita.
Omitir Linhas Quando Campo for NULL Se estiver marcada, as linhas que contiverem um valor de campo NULL no campo selecionado serão removidas. NULL refere-se a "nenhum valor".
Seletor Suspenso Se essa opção estiver marcada, será incluído um ícone de seta dropdown no lado esquerdo do cabeçalho da coluna do campo selecionado. Clique no ícone para acessar os valores de campo em uma lista de campos dropdown. Funciona exatamente da mesma forma que fazer seleções em uma seleção múltipla.
Avançado... Esse botão abre a caixa de diálogo Configurações de Campo Avançadas, que oferece configurações para a representação por imagens de valores de campo e as opções de pesquisa de texto especiais.
Configuração Multi-Linha Este grupo permite configurar o cabeçalho da tabela e as células de dados para mostrar valores em várias linhas, o que pode ser útil para caracteres de texto longos.
Retorno do textoAltura do cabeçalhon Linhas
Com essa opção selecionada, o conteúdo do cabeçalho será mostrado em mais de uma linha. Aqui são especificados os limites desejados para o número de linhas do cabeçalho.
Retorno do textoAltura da célula n Linhas
Com esta opção selecionada, o conteúdo de uma célula será mostrado em mais de uma linha. Aqui são especificados os limites desejados para o número de linhas da célula.
Rótulos Verticais Se estiver marcada, todos os rótulos de campos serão girados para a posição vertical.
Permitir Arrastar e Soltar Se estiver marcada, será possível classificar os campos da tabela clicando e arrastando os cabeçalhos.
Indicador de Classificação Se estiver marcada, será incluído um indicador de classificação à direita do cabeçalho da coluna correspondente ao campo pelo qual a tabela está atualmente classificada. O ícone muda de orientação para refletir a ordem de classificação crescente ou decrescente.
Indicadores de Seleção Se estiver marcada, será incluído um indicador de classificação à direita do cabeçalho da coluna correspondente ao campo pelo qual a tabela está atualmente classificada. O ícone muda de orientação para refletir a ordem de classificação crescente ou decrescente.
Ocultar Linha de Cabeçalho Se estiver marcada, a tabela será mostrada sem a linha de cabeçalho (rótulo).

Estilo

Essa página de estilo aplica-se a todos os seguintes itens do QlikView : tabelas, caixas de texto, tabelas dinâmicas e tabelas estáticas. Aqui é possível definir configurações para o estilo do formato da tabela.

Estilo Atual Escolha um estilo de tabela apropriado na lista suspensa. Se o valor [Personalizar] aparecer no controle suspenso, significa que um estilo personalizado foi aplicado à tabela. Se você alterar a configuração novamente para um dos estilos predefinidos, o formato personalizado será perdido.
Listra a cada _ Linhas Aqui você especifica se devem aparecer listras sombreadas e, em caso afirmativo, o intervalo entre elas.
Modo de Recuo Esta configuração é válida apenas para tabelas dinâmicas. Com esta alternativa marcada, você pode obter um estilo de tabela ligeiramente diferente que é especialmente útil quando é preciso acomodar vários rótulos de dimensão em uma largura de tabela limitada.
Usar Somente Primeiro Rótulo de Dimensão
Essa configuração só está disponível para as tabelas dinâmicas que já estejam no Modo de Indentação e modifica ainda mais o estilo da tabela dinâmica.
Bordas da Célula da Dimensão Vertical Esta configuração determina se as bordas da célula vertical serão mostradas para colunas de dimensão.
Bordas da Célula da Expressão Vertical O mesmo se aplica a esta configuração, mas para colunas de expressão.
Espaçamento Acima da Borda

Contanto que um Espaçamento tenha sido determinado na caixa de diálogo Configurações de Campo Avançadas, o estilo da tabela poderá ser ligeiramente modificado se essa alternativa for marcada.

Advanced Field Settings

Plano de Fundo... Abre a caixa de diálogo Configurações de Plano de Fundo.
Transparência da Cor de Fundo da Célula Se uma cor ou imagem tiver sido aplicada em Configurações de Fundo, você poderá ajustar a transparência dessa cor ou imagem no fundo da célula aqui.
Transparência das Bordas da Célula Define a saliência das bordas da célula.

Fonte

Aqui é possível definir a Fonte, o estilo da Fonte e o Tamanho da fonte que serão usados.

A fonte pode ser definida para qualquer objeto único (Propriedades do Objeto: Fonte) ou todos os objetos de um documento (Aplicar a Objetos em Propriedades do Documento: Fonte).

Adicionalmente, as fontes padrão do documento para os novos objetos podem ser definidas em Propriedades do Documento: Fonte. Existem duas fontes padrão:

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.

Adicionalmente, as fontes padrão dos novos documentos podem ser definidas em Preferências do Usuário: Fonte.

Para gráficos, botões e objetos de texto (exceto objetos de pesquisa), também é possível especificar uma Cor de fonte. A cor pode ser Fixa ou Calculada dinamicamente em uma expressão. A expressão deve ser uma representação de cor válida, criada usando as funções de cor. Se o resultado da expressão não for uma representação de cor válida, a cor da fonte definirá a cor preta como padrão.

Funções de cor

Configurações adicionais:

Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Uma amostra da fonte selecionada é mostrada no painel de visualização.

Layout

Uma configuração de Layout será aplicada apenas ao objeto atual se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos dos tipos especificados no documento se for definida na página Propriedades do Documento.

Usar Bordas

Ative essa configuração para usar uma borda em torno do objeto de pasta. Especifique o tipo de borda, selecionando-o no menu suspenso.

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.

Quando você seleciona Simplificado como o Modo de Estilo em Propriedades de Documento: Geral, não há nenhuma opção de tipo de borda, existe somente o menu suspenso Intensidade de Sombra e a configuração Largura da Borda.

Cantos Arredondados

No grupo Cantos Arredondados, a forma geral do objeto de pasta é definida. Essa configuração permite variações na forma de desenho dos objetos da pasta, desde formas perfeitamente circulares/elípticas, passando para superelípticas até chegar a formas retangulares. A opção Cantos Arredondados ficará disponível somente se o Modo de Estilo Avançado estiver selecionado em Propriedades de Documento: Geral.

Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).

Camada

No grupo Camada, é possível definir um objeto como residente em uma das três camadas:

Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.

Editor de Tema...

Abre o assistente do Editor de Tema, onde é possível criar um novo tema de layout.

Aplicar Tema...

É possível aplicar um tema de layout ao objeto, pasta ou documento.

Temas de Layout

Mostrar

No grupo Mostrar, é possível especificar uma condição sob a qual o objeto de pasta será exibido:

Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Opções

No grupo Opções, é possível impedir a movimentação e o redimensionamento do objeto de pasta. As configurações desse grupo só serão relevantes se as caixas de seleção correspondentes forem marcadas em Propriedades do Documento: Layout e Propriedades da Pasta: Segurança.

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.

Barras de Rolagem

Vários controles para alterar o layout da barra de rolagem estão localizados no grupo Barras de Rolagem:

Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

A configuração do Título será aplicada apenas ao objeto atual, se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos do(s) tipo(s) especificado(s) no documento se for definida na página Propriedades do Documento.

Na página Título, especifique opções de layout completamente diferentes do layout geral do objeto.

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.

Defina as cores do título em seus diversos estados. As configurações das Cores Ativas e das Cores Inativas podem ser especificadas separadamente uma da outra.

Clique no botão Cor de Fundo ou Cor de Texto para abrir a caixa de diálogo Área de Cores. A Cor de Fundo pode ser definida como uma cor sólida ou gradiente na caixa de diálogo Área de Cores. A Cor do Texto pode ser definida como uma cor Fixa ou Calculada usando as funções de cor.

Funções de cor

Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.

O tamanho e a posição precisos do objeto do QlikView podem ser determinados e ajustados pelas configurações de tamanho/posição do objeto de pasta Normal ou Minimizado. Essas configurações são medidas em pixels:

X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.

A orientação de rótulo do título pode ser alterada com as opções de Alinhamento de Título:

Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.

Ícones especiais
Muitos dos comandos do menu de objeto dos objetos de pasta podem ser configurados como ícones de título. Selecione os comandos a serem mostrados como ícones de título, marcando a caixa de verificação à esquerda de cada comando na lista.

Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.