Objeto Controle Deslizante/Calendário

Os objetos deslizadores/calendário oferecem uma maneira alternativa para selecionar valores de campo no QlikView. Também podem ser usados para inserir valores nas variáveis do script do QlikView. Como o nome sugere, o objeto deslizador/calendário tem dois modos completamente diferentes. Ainda que pareçam diferentes, funcionam de forma muito parecida na interface visual do usuário.

Clique com o botão direito do mouse em um objeto de controle deslizante/calendário e no Objeto de controle deslizante/calendário: Menu Objeto será exibida. Isso também pode ser acessado no menu Objeto, quando o objeto deslizador/calendário for o objeto ativo.

Usando um Objeto Deslizador/Calendário

Modo Deslizador

Um único valor, dois valores ou um intervalo de valores (dependendo das propriedades do objeto) é selecionado em um campo ou inserido em uma ou duas variáveis arrastando um seletor ao longo do fundo do deslizador. O seletor pode também ser movido com as setas de rolagem. Alguns deslizadores podem incorporar uma escala e marcas para navegação.

Modo Calendário

Um objeto deslizador/calendário no modo calendário é exibido no layout como caixa suspensa com um ícone de calendário à direita. Quando você clicar no ícone de calendário, ele será expandido para um controle de calendário. É possível navegar entre meses e anos usando os botões de setas ou os controles suspensos de mês e ano. Após a seleção de uma data ou de um intervalo de datas (dependendo das propriedades do objeto) no controle de calendário, a seleção será aplicada ao campo ou à variável subjacente.

Se o objeto estiver conectado a um campo, as seleções no campo serão refletidas no controle de calendário expandido, com os mesmos códigos de cores de seleção contidos nas listas (por exemplo, verde para valores selecionados). Desde que o objeto esteja configurado para vários valores, será possível arrastar para selecionar vários valores, exatamente como na lista. Se você pressionar a tecla Ctrl, poderá até selecionar vários intervalos de valores, mesmo que eles apareçam em meses e anos diferentes. Depois que o controle de calendário for fechado após a seleção, a caixa suspensa funcionará basicamente como um menu suspenso de campos em uma seleção múltipla.

Menu Objeto

O menu Objeto do objeto controle deslizante/calendário é aberto quando você clica com o botão direito do mouse no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades do Objeto Controle Deslizante/Calendário, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Copiar para a Área de Transferência Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou excluirá o título e a borda do objeto de pasta, de acordo com as configurações na página Preferências do Usuário: Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Geral

A página Propriedades do objeto de controle deslizante/calendário: Geral será aberta se você clicar com o botão direito do mouse no objeto de controle deslizante/calendário e escolher o comando Propriedades no menu suspenso. Aqui é possível fazer várias configurações dos dados que serão manipulados pelo objeto deslizador/calendário. Também é possível obter essas informações na caixa de diálogo Novo Objeto Deslizador/Calendário.

Em Estilo de Entrada, selecione o modo básico do objeto deslizador/calendário. Use o menu suspenso para selecionar se o objeto deve ser representado por um controle Deslizador ou por um controle de entrada Calendário.

No grupo Dados, é possível definir a que objeto de dados o deslizador/calendário está conectado. Um deslizador/calendário pode estar conectado a um campo ou a uma ou um par de variáveis.

Campo Selecione esse botão de opção para conectar o objeto deslizador/calendário a um campo ou a uma expressão. Selecione o campo na caixa de seleção. Se Expressão for escolhida na caixa de seleção, a caixa de diálogo Editar Expressão será aberta.
Editar... Abre a caixa de diálogo Editar Expressão para a expressão escolhida na lista suspensa.
Variável(is) Marque o botão de opção e selecione a(s) variável(is) desejada(s) na(s) lista(s) suspensa(s). A segunda variável somente estará disponível se você selecionar Valor Múltiplo em Modo (veja abaixo).

No grupo Modo, é possível especificar se o deslizador/calendário deve ser usado para selecionar um Valor Único ou um intervalo de valores - Valor Múltiplo.

No grupo Modo de Valor é possível especificar se o deslizante/calendário deve selecionar valores Discretos (não disponível no modo Valor Múltiplo) ou definir um intervalo de valores Contínuo/Numérico (não disponível no modo Valor Único com dados Campo). Esse grupo não está disponível no modo Calendário. No modo Calendário, são sempre assumidos valores discretos.

Valor Mínimo Define o valor mínimo para o deslizador/calendário no modo de valor Contínuo/Numérico.
Valor Máximo Define o valor máximo para o deslizador/calendário no modo de valor Contínuo/Numérico.
Incremento Estático Marque a caixa de verificação e digite um valor na caixa de edição para especificar um incremento estático dos valores do deslizador/calendário no modo de valor Contínuo/Numérico.
Valor 1 Mostra o valor atual do deslizador no modo de valor Contínuo/Numérico, se o deslizador/calendário for Valor Único. No modo Valor Múltiplo, será mostrado o valor mais baixo.
Valor 2 Mostra o atual valor mais alto do objeto deslizador/calendário no modo de valor Contínuo/Numérico. Somente relevante para o modo Valor Múltiplo.
Sobrepor Campo Travado Se essa caixa de verificação for marcada, será possível fazer seleções em um campo a partir do deslizador/calendário, mesmo que o campo esteja travado. O campo continuará travado para alterações lógicas resultantes de seleções em outros campos. Essa opção é selecionada, por padrão, para objetos de deslizador/calendário.
Intervalo Fixo Quando esta alternativa estiver marcada, o usuário não poderá alargar ou estreitar o intervalo arrastando as bordas do seletor do deslizador.
Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto

É utilizado para fins de macro. A cada objeto da pasta é atribuído um ID exclusivo. Recomendamos o uso de caracteres alfanuméricos apenas na ID. Para objetos controle deslizante, a ID começa como SL01. Os objetos vinculados têm o mesmo ID de objeto. Você pode editar posteriormente esse número de ID.

Interpretador Interno de Macro

Configurações de Impressão Esse botão abre a caixa de diálogo Configuração de Impressão, onde é possível definir as margens e o formato do cabeçalho/rodapé.

Apresentação (Modo Deslizador)

A página Propriedades do objeto de controle deslizante/calendário: Apresentação será aberta se você clicar com o botão direito do mouse em um objeto Controle deslizante/calendário e escolher o comando Propriedades no menu suspenso. Aqui, é possível configurar as propriedades visuais do objeto controle deslizante/calendário.

O grupo Cores permite definir as cores para as diversas partes do controle deslizante/calendário, conforme mostrado nesta figura:

A Vistos
B Fundo em escala
C Fundo deslizante
D Alfinete
E Setas de rolagem

As cores do Plano de Fundo do Controle Deslizante e Plano de Fundo da Escala podem ser definidas como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão correspondente. O grau de transparência do fundo do deslizador pode ser definido por meio do controle de Transparência, à direita do botão. No nível 0%, o plano de fundo ficará totalmente opaco. Em 100%, o fundo ficará totalmente transparente.

A cor de Seletor, Setas de Rolagem e Marcas de Unidades pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores que é aberta quando você clica no botão correspondente.

No grupo Orientação de Rolagem, o deslizador pode ser exibido na direção Horizontal ou Vertical.

Em Orientação do Rótulo, você pode determinar se a direção do texto da escala deve ser Horizontal ou Vertical.

No grupo Escala, é possível definir a escala de um deslizador. Selecione Usar Escala Automática para que a escala seja gerada automaticamente com base no tamanho do deslizador e nos valores subjacentes. A alternativa Usar Escala Personalizada permite especificar diversas configurações de escala:

Unidades Principais O número define a quantidade de unidades principais na escala do deslizador.
Rótulos em Cada n Unidade Principal Define a densidade do texto do rótulo da escala.
Unidades Menores por Unidade Principal Define o número de unidades menores entre cada unidade principal na escala do deslizador.

As setas de rolagem podem ficar visíveis ou ocultas, com a alternativa Mostrar Setas de Rolagem.

Estilo do Deslizador pode ser definido como Sólido ou Brilho.

Nota: Existem limitações para as funções de escala automática e orientação de rótulos verticais em modo AJAX/Exibição Web.
Se for possível, recomendamos Utilizar Escala Personalizada para definir as configurações de escala.

Apresentação (Modo Calendário)

A página Propriedades do objeto de controle deslizante/calendário: Apresentação será aberta se você clicar com o botão direito do mouse em um objeto Controle deslizante/calendário e escolher o comando Propriedades no menu suspenso. Aqui, é possível configurar as propriedades visuais do objeto controle deslizante/calendário.

O grupo Cores permite que você defina a cor do fundo do controle do calendário. A cor de Fundo pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão correspondente. O grau de transparência do fundo do controle de calendário pode ser definido por meio do controle de Transparência, à direita do botão. No nível 0%, o plano de fundo ficará totalmente opaco. Em 100%, o fundo ficará totalmente transparente.

Classificar

Na guia Classificar, é possível definir a ordem de classificação dos dados do controle deslizante. Essa caixa de diálogo é muito semelhante à sua correspondente que se encontra em Propriedades do Documento.

See also:

 
  • NúmeroPropriedades do Documento
  • See also:

  • Fonteo estilo da FonteTamanho
  • Propriedades do Objeto: FonteAplicar a ObjetosPropriedades do Documento: Fonte
  • Propriedades do Documento: Fonte
  • Preferências do Usuário: Fonte
  • CorFixaCalculada
  • Funções de cor

  • Usar Bordas
  • SimplificadoModo de EstiloPropriedades de Documento: GeralIntensidade de SombraLargura da Borda
  • Cantos Arredondados
  • Cantos ArredondadosCantos ArredondadosModo de EstiloAvançadoPropriedades de Documento: Geral
  • Camada
  • Camada
  • Editor de Tema...
  • Editor de Tema
  • Aplicar Tema...
  • Temas de Layout
  • Mostrar
  • Mostrar
  • Opções
  • OpçõesPropriedades do Documento: LayoutPropriedades da Pasta: Segurança
  • Barras de Rolagem
  • Barras de Rolagem
  • Propriedades do Objeto
    Propriedades do Documento
  • Título
  • Cores AtivasCores Inativas
  • Cor de FundoCor de TextoÁrea de CoresCor de FundosólidagradienteÁrea de CoresCor do TextoFixaCalculada
  • Funções de cor
  • NormalMinimizado
  • Alinhamento de Título
  • Ícones especiais

Número

Fonte

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.
Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Layout

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.
Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.
Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.
Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.
Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.
X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.
Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.
Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.