Objeto de Pesquisa

Os objetos de pesquisa podem ser usados para pesquisar informações em qualquer local do documento.

Para criar um novo Objeto de Pesquisa, selecione Layout – Novo Objeto de Pasta – Objeto de Pesquisa no Menu Principal, clique com o botão direito do mouse na área da pasta e selecione Novo Objeto de Pasta – Objeto de Pesquisa ou clique na ferramenta Criar Objeto de Pesquisa na barra de ferramentas (se a ferramenta tiver sido ativada).

Ao clicar com o botão direito do mouse em um objeto de pesquisa, a opção Objeto de Pesquisa: Menu Objeto será exibida. Isso também poderá ser acessado pelo menu Objeto, quando o objeto de pesquisa for o objeto ativo.

Menu Objeto

O menu Objeto do objeto de pesquisa é aberto quando você clica com o botão direito do mouse no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades do Objeto de Pesquisa, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Copiar para a Área de Transferência Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou não o título e a borda do objeto de pasta de acordo com as configurações na caixa de diálogo Preferências do Usuário da página Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Geral

Na aba Geral, é possível configurar as opções de pesquisa.

Todos os Campos

Marque este botão de opção para permitir que o objeto de pesquisa pesquise todos os campos no documento. Por padrão, os campos do sistema não são incluídos na opção Todos os campos. Para incluir o campo do sistema, especifique o nome do campo do sistema na Lista de campos.

Lista de Campos Marque este botão de opção e liste os campos no campo a seguir para definir os campos que devem ser pesquisáveis. Use ponto-e-vírgula (;) como separador entre campos. Os caracteres curingas * e ? são permitidos nos nomes de campo. A lista pode ser definida como uma fórmula calculada para atualização dinâmica.
Campos Selecionados Marque este botão de opção e escolha os campos que devem ser pesquisáveis.
Mostrar Campos da Tabela Este menu suspenso mostra o valor Todas as Tabelas que contém todos os campos do documento. Ao selecionar um nome de tabela específico no menu suspenso, você poderá limitar a lista Campos Selecionados somente para os campos dessa tabela interna.
Por fim, você pode selecionar o valor Todas as Tabelas (Qualificadas), o que mostrará todos os campos no documento qualificados com seus respectivos nomes de tabela. Um campo aparecerá uma vez para cada tabela na qual esteja incluído.
Modo de Pesquisa Padrão Especifica o modo de pesquisa padrão inicial a ser usado em pesquisas de texto. O modo pode ser alterado a qualquer momento, digitando * ou ~ como parte dos caracteres de pesquisa. As seguintes alternativas estão disponíveis:
<usar padrão>
O padrão especificado em Preferências do usuário será aplicado.
Usar Pesquisa com Curinga
Os caracteres de busca iniciais serão dois curingas com o cursor entre eles para facilitar a pesquisa com curinga.
Usar Pesquisa Avançada
O caractere de busca inicial será um til (~) para indicar uma pesquisa avançada.
Usar Pesquisa Normal
Nenhum caractere adicional será incluído nos caracteres de busca. Sem caracteres curinga, será realizada uma Pesquisa Normal.

ID do Objeto

A ID exclusiva do objeto de pesquisa atual. A cada objeto de pasta criado é atribuído um ID exclusivo para controle por meio de Automação. O ID consiste em uma combinação de letras que definem o tipo de objeto, além de um número. A ID SO01 será atribuída ao primeiro objeto de pesquisa de um documento. Os objetos de pasta vinculados compartilham o mesmo ID de objeto. O ID de um objeto pode ser alterado para qualquer outro caractere que não esteja sendo utilizado atualmente como ID por outro objeto de pasta, pasta ou marcador no documento.
Estados Alternativos Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.

Apresentação

Resultado de Pesquisa

Incluir Excluído(s) Marque esta caixa de seleção para incluir os valores na pesquisa que foram excluídos pelas seleções.
Pesquisa de realce de subcaractere A pesquisa de caracteres até agora será destacada nas correspondências.
Contrair quando o resultado nos campos exceder Limitar o número de correspondências exibido em cada campo.

Estilo Visual

Aparência Escolha entre uma aparência Arredondada e Quadrada.
Mostrar Reflexão Uma reflexão do objeto de pesquisa será mostrada no layout.
Texto no Campo de Pesquisa Digite o texto que deve ficar visível no objeto de pesquisa antes de inserir um caracter de pesquisa. Clicando no botão ..., será aberta a caixa de diálogo Editar Expressão completa, para facilitar a edição de fórmulas longas.

Classificar

No grupo Classificar Campos por, é possível definir a ordem de classificação dos campos no objeto de pesquisa.

Texto Classifica os campos dos resultados da pesquisa em ordem alfabética.
Número de resultados Classifica os campos dos resultados da pesquisa de acordo com o número de resultados em cada campo.
Conforme Listado na Guia Geral Classifica os campos dos resultados da pesquisa de acordo com a ordem na qual os campos estão relacionados na guia Geral.

Fonte

Aqui é possível definir a Fonte, o estilo da Fonte e o Tamanho da fonte que serão usados.

A fonte pode ser definida para qualquer objeto único (Propriedades do Objeto: Fonte) ou todos os objetos de um documento (Aplicar a Objetos em Propriedades do Documento: Fonte).

Adicionalmente, as fontes padrão do documento para os novos objetos podem ser definidas em Propriedades do Documento: Fonte. Existem duas fontes padrão:

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.

Adicionalmente, as fontes padrão dos novos documentos podem ser definidas em Preferências do Usuário: Fonte.

Para gráficos, botões e objetos de texto (exceto objetos de pesquisa), também é possível especificar uma Cor de fonte. A cor pode ser Fixa ou Calculada dinamicamente em uma expressão. A expressão deve ser uma representação de cor válida, criada usando as funções de cor. Se o resultado da expressão não for uma representação de cor válida, a cor da fonte definirá a cor preta como padrão.

Funções de cor

Configurações adicionais:

Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Uma amostra da fonte selecionada é mostrada no painel de visualização.

Layout

Uma configuração de Layout será aplicada apenas ao objeto atual se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos dos tipos especificados no documento se for definida na página Propriedades do Documento.

Usar Bordas

Ative essa configuração para usar uma borda em torno do objeto de pasta. Especifique o tipo de borda, selecionando-o no menu suspenso.

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.

Quando você seleciona Simplificado como o Modo de Estilo em Propriedades de Documento: Geral, não há nenhuma opção de tipo de borda, existe somente o menu suspenso Intensidade de Sombra e a configuração Largura da Borda.

Cantos Arredondados

No grupo Cantos Arredondados, a forma geral do objeto de pasta é definida. Essa configuração permite variações na forma de desenho dos objetos da pasta, desde formas perfeitamente circulares/elípticas, passando para superelípticas até chegar a formas retangulares. A opção Cantos Arredondados ficará disponível somente se o Modo de Estilo Avançado estiver selecionado em Propriedades de Documento: Geral.

Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).

Camada

No grupo Camada, é possível definir um objeto como residente em uma das três camadas:

Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.

Editor de Tema...

Abre o assistente do Editor de Tema, onde é possível criar um novo tema de layout.

Aplicar Tema...

É possível aplicar um tema de layout ao objeto, pasta ou documento.

Temas de Layout

Mostrar

No grupo Mostrar, é possível especificar uma condição sob a qual o objeto de pasta será exibido:

Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Opções

No grupo Opções, é possível impedir a movimentação e o redimensionamento do objeto de pasta. As configurações desse grupo só serão relevantes se as caixas de seleção correspondentes forem marcadas em Propriedades do Documento: Layout e Propriedades da Pasta: Segurança.

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.

Barras de Rolagem

Vários controles para alterar o layout da barra de rolagem estão localizados no grupo Barras de Rolagem:

Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

A configuração do Título será aplicada apenas ao objeto atual, se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos do(s) tipo(s) especificado(s) no documento se for definida na página Propriedades do Documento.

Na página Título, especifique opções de layout completamente diferentes do layout geral do objeto.

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.

Defina as cores do título em seus diversos estados. As configurações das Cores Ativas e das Cores Inativas podem ser especificadas separadamente uma da outra.

Clique no botão Cor de Fundo ou Cor de Texto para abrir a caixa de diálogo Área de Cores. A Cor de Fundo pode ser definida como uma cor sólida ou gradiente na caixa de diálogo Área de Cores. A Cor do Texto pode ser definida como uma cor Fixa ou Calculada usando as funções de cor.

Funções de cor

Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.

O tamanho e a posição precisos do objeto do QlikView podem ser determinados e ajustados pelas configurações de tamanho/posição do objeto de pasta Normal ou Minimizado. Essas configurações são medidas em pixels:

X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.

A orientação de rótulo do título pode ser alterada com as opções de Alinhamento de Título:

Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.

Ícones especiais
Muitos dos comandos do menu de objeto dos objetos de pasta podem ser configurados como ícones de título. Selecione os comandos a serem mostrados como ícones de título, marcando a caixa de verificação à esquerda de cada comando na lista.

Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.