Gráfico Mekko

Gráficos são representações visuais de dados numéricos. É possível alternar entre diferentes representações de um gráfico existente, alterando o Tipo de Gráfico na página Propriedades de Gráfico: Geral.

Os gráficos Mekko apresentam dados usando barras de largura variável. Eles podem exibir até três níveis de dados em um gráfico bidimensional. Os gráficos Mekko são úteis em áreas como a análise de mercado.

Clicando com o botão direito do mouse no gráfico, a opção Gráfico Mekko: Menu Objeto será exibida. Também será possível acessá-lo no menu Objeto, quando o gráfico for o objeto ativo.

Menu Objeto

Os gráficos Mekko apresentam dados usando barras de largura variável. Eles podem exibir até três níveis de dados em um gráfico bidimensional. Os gráficos Mekko são úteis em áreas como a análise de mercado.

O menu Objeto do gráfico mekko é aberto quando você clica com o botão direito do mouse no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades, que permite especificar os parâmetros que definem o gráfico. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Alt + Enter.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Desvincular O título do gráfico é anexado ao texto “(Desvinculado)” e o gráfico não é mais atualizado com seleções realizadas no documento (embora as seleções, na realidade, ainda possam ser feitas no gráfico). O comando só estará disponível se o gráfico estiver vinculado. Crie uma cópia do gráfico e desvincule-a para fazer comparações diretas entre cópia e original.
Vincular Vincula um gráfico desvinculado. O gráfico torna-se dinamicamente vinculado aos dados. O comando só estará disponível se o gráfico estiver desvinculado.
Clonar Cria uma cópia idêntica do gráfico. Se um gráfico desvinculado for clonado, o clone será vinculado.
Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Limpar Todas as Seleções Limpa todas as seleções nas dimensões e expressões do gráfico.
Imprimir... Abre o diálogo Imprimir que permite especificar a configuração de impressão.
Imprimir como PDF...

Abre a caixa de diálogo Imprimir com a impressora PDF-XChange 3.0 pré-selecionada. Depois de pressionar o botão Imprimir, você deverá digitar um nome para o arquivo PDF a ser gerado. Esse comando só estará disponível se houver uma impressora PDF no sistema.

Enviar Valores para o Excel Exporta os dados subjacentes (a tabela simples equivalente ao gráfico) para o Microsoft Excel, que será automaticamente acionado se ainda não estiver em execução. A tabela aparecerá em uma nova planilha do Excel. Para que esse recurso funcione, o Microsoft Excel 2007 ou versão posterior deve estar instalado no computador.
Exportar... Abre uma caixa de diálogo para salvar uma imagem do gráfico em um arquivo. A imagem pode ser salva como bmp, jpg, gif ou png.
Copiar para a Área de Transferência Esse menu contém as diversas opções de cópia para o gráfico.

Valores
Copia os valores para a área de transferência, em formato de tabela.
Imagem
Copia uma imagem do objeto gráfico para a área de transferência. A imagem incluirá ou excluirá o título e a borda do objeto de pasta, de acordo com as configurações na página Preferências do Usuário: Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Propriedades de Gráfico: Geral

Na página Geral, é possível definir essas propriedades como títulos e tipo de gráfico. É a primeira página do Assistente de Gráfico Rápido e da caixa de diálogo Propriedades do Gráfico.

Título da Janela

O título a ser exibido no cabeçalho da janela. O título também pode ser definido como uma fórmula calculada para atualização dinâmica do texto do rótulo. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Mostrar Título no Gráfico

Por padrão, o rótulo da primeira expressão definida é estabelecido como título do gráfico. Desmarque a caixa de seleção se não for necessário exibir nenhum título no gráfico. Para exibir o título original, basta desmarcar a caixa de seleção. O título também pode ser definido como uma fórmula calculada para atualização dinâmica do texto do rótulo. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas. O título do gráfico não é mostrado em tabelas dinâmicas ou tabelas simples.

Sintaxe da expressão para fórmulas calculadas

Configuração do Título Defina as configurações avançadas do título do gráfico clicando no botão Configuração do Título.
Configurações de Impressão

Ao clicar no botão Configuração de Impressão, você acessa a caixa de diálogo Configuração de Impressão, onde é possível definir margens e o formato do cabeçalho/rodapé. A caixa de diálogo Configurações de Impressão ocupa duas páginas, Layout de Impressão e Cabeçalho/Rodapé da Impressão.

Imprimir: Layout e Imprimir: Cabeçalho/Rodapé

Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto

É utilizado para fins de macro. A cada objeto da pasta é atribuído um ID exclusivo. Recomendamos o uso de caracteres alfanuméricos apenas na ID. Para gráficos, a ID começa como CH01. Os objetos vinculados têm o mesmo ID de objeto. Você pode editar posteriormente esse número de ID.

Interpretador Interno de Macro

Desvinculado Se ativado, o gráfico será desvinculado, ou seja, não será mais atualizado dinamicamente quando opções forem selecionadas.
Somente leitura Se ativado, o gráfico será apenas leitura, ou seja, não é possível fazer seleções clicando ou pintando com o mouse no gráfico.
Condição de Cálculo Digite uma expressão nessa caixa de texto para definir uma condição a ser satisfeita para que o gráfico seja exibido. Se a condição não for cumprida, será exibido no gráfico o texto “Condição de cálculo não satisfeita”. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.
Tipo de Gráfico No grupo Tipo de Gráfico, você seleciona o layout básico do gráfico. Para obter mais informações sobre cada tipo de gráfico, consulte Tipo de gráfico.
Mudança de Tipo Rápida Nesse grupo, é possível ativar um ícone no gráfico a partir do qual o usuário pode alterar o tipo de gráfico sem acessar a caixa de diálogo de propriedades do gráfico.
Tipos permitidos
Nessa lista, você pode selecionar os tipos de gráficos que devem aparecer no menu suspenso. É preciso selecionar dois ou mais tipos para habilitar a alteração de tipo rápida.
Posição preferencial do ícone
Nos gráficos de diagrama, o ícone de mudança de tipo rápida pode ser posicionado dentro do gráfico ou no título do objeto da pasta. Nos gráficos de tabela, o título é a única alternativa.
Restaurar Tamanho Pressione esse botão para que todos os dimensionamentos de legenda, título etc. feitos pelo usuário nos gráficos de diagrama sejam restaurados. O posicionamento de itens individuais não será afetado.
Restaurar Posição Pressione esse botão para que todos os posicionamentos de legenda, título etc. feitos pelo usuário nos gráficos de diagrama sejam restaurados.
Mensagens de Erro

Abre a caixa de diálogo Mensagens de Erro Personalizadas.

Mensagens de Erro Personalizadas

Modo Referência Configurações sobre como o fundo de referência deve ser desenhado ao usar a opção Definir Referência no menu de contexto do gráfico. Essa configuração só tem efeito em alguns gráficos.

Propriedades de Gráfico: Dimensões

A página Propriedades de Gráfico: A página Dimensões é acessada ao clicar com o botão direito do mouse em um gráfico e selecionar Propriedades ou selecionar Propriedades no menu Objeto quando o gráfico está ativo.

Quando criar um gráfico, primeiro leve em consideração estas duas questões:

  • O que desejo visualizar? A que devem corresponder os tamanhos das barras no gráfico de barras? A resposta deve ser a "soma de vendas" ou algo similar. Isso é definido na aba Expressões.
  • Com o que deseja agrupá-lo? Quais valores de campo você deseja usar como rótulos para as barras no gráfico de barras? A resposta pode ser “por país” ou algo similar. Isso é definido na aba Dimensões.

Um gráfico pode mostrar uma ou mais dimensões. O limite superior depende do tipo de gráfico, da complexidade dos dados e da memória disponível. Os gráficos de pizza, de linhas e de dispersão podem mostrar, no máximo, duas dimensões, mas os gráficos de barras, de blocos e de grade podem apresentar três dimensões. Os gráficos de radar e de funil só podem mostrar uma única dimensão, enquanto os gráficos de mostrador não usam dimensões. As dimensões adicionais serão ignoradas.

A dimensão de um gráfico obtém seus valores de um campo que é especificado na página Propriedades do Gráfico: Dimensões. Em vez de ser um único campo, uma dimensão também pode consistir em um grupo de campos (consulte Editar Grupos a seguir).

Uma dimensão pode ser um campo único, um grupo ou uma expressão (dimensão calculada). Também pode ser uma dimensão criada de modo sintético

Funções de dimensão sintética

Para mover os campos para frente e para trás, selecione (clique, Ctrl-clique) e use os botões Incluir> ou <Excluir ou clique duas vezes diretamente em suas opções.

As dimensões de gráfico podem também ser calculadas a partir de uma expressão.

Esta página de propriedades é usada para definir dimensões.

Campos/Grupos Disponíveis

Lista todos os campos/grupos de campos disponíveis para serem usados como dimensões (por exemplo, ao longo do eixo x em um gráfico de barras padrão). Os grupos de campos serão precedidos por uma seta vertical para os grupos hierárquicos ou por uma seta curva para os grupos cíclicos. Grupos são definidos na página Propriedades do Documento: Grupos. Selecione os itens a serem utilizados/excluídos clicando neles. Use os botões Incluir > ou < Remover para movê-los para a coluna desejada.
O número de dimensões que podem ser exibidas varia de acordo com o tipo de gráfico usado.
Todos os campos que aparecem em mais de uma tabela interna serão precedidos por um símbolo-chave. Os gráficos de pizza, de linhas e de dispersão não podem exibir mais do que duas dimensões. Nos gráficos de barras, podem ser mostrados até três dimensões.

Propriedades do Documento: Grupos

Mostrar Campos do Sistema Ao marcar esta opção, os campos de sistema da coluna Campos/Grupos Disponíveis serão exibidos.
Mostrar Campos da Tabela A partir daqui, é possível controlar os campos/grupos que aparecerão na lista Campos/Grupos Disponíveis. A lista suspensa mostra a alternativa Todas as Tabelas por padrão.
A alternativa Todas as tabelas (qualificadas) mostra os campos qualificados pelo nome das tabelas em que eles ocorrem. Isso significa que campos chave (de conexão) serão listados mais de uma vez. (Essa alternativa é usada apenas para fins de exibição e não tem nada a ver com os campos Qualify no script de carregamento.)
Também é possível exibir os campos de uma tabela por vez. Observe que os grupos disponíveis são sempre listados.
Editar Grupos... Esse botão abre diretamente a página Propriedades do Documento: Grupos, na qual grupos de campos a serem usados como dimensões podem ser definidos.
Animar... Abre a caixa de diálogo Animação, pela qual você pode fazer uso da primeira dimensão do gráfico para animação. A animação só está disponível para gráficos de bitmap exceto gráficos de pizza. Algumas limitações funcionais se aplicam ao uso de animações.
Treliça... Abre a caixa de diálogo Configurações da Treliça, onde é possível criar uma matriz de gráficos com base na primeira dimensão. Qualquer tipo de gráfico bitmap pode ser transformado em uma exibição de treliça.
Dimensões Usadas

Esta lista contém as dimensões selecionadas no momento a serem usadas como dimensões no gráfico. O número de dimensões que podem ser usadas varia de acordo com o tipo de gráfico. As dimensões supérfluas de qualquer tipo determinado serão desconsideradas. Quando são usadas nas tabelas, as células de dados da dimensão podem ser formatadas dinamicamente por meio de expressões de atributo. Sempre que uma expressão de atributo for inserida para uma dimensão, seu ícone mudará de escala de cinza para colorido ou, como no caso de Formato do Texto, de cinza para preto. Essas configurações terão precedência sobre as configurações do gráfico. Clique no ícone de expansão “+” diante de qualquer dimensão para que sejam exibidos os espaços reservados ou a expressão de atributo da dimensão.
Cor de Fundo
Clique duas vezes em Cor de Fundo a fim de inserir uma expressão de atributo para calcular a cor de fundo da célula dimensional. A expressão usada deve retornar uma representação de cor válida (um número que representa os componentes Vermelho, Verde e Azul conforme definido no Visual Basic). Isso é feito usando uma das funções especiais de cor de gráfico. Se o resultado da expressão não for uma representação de cor válida, o programa definirá a cor preta como padrão.
Cor do Texto
Clique duas vezes em Cor do Texto a fim de inserir uma expressão de atributo para calcular a cor do texto da célula dimensional. A expressão usada deve retornar uma representação de cor válida (um número que representa os componentes Vermelho, Verde e Azul conforme definido no Visual Basic). Isso é feito usando uma das funções especiais de cor de gráfico. Se o resultado da expressão não for uma representação de cor válida, o programa definirá a cor preta como padrão.

Funções de cor

Formato do Texto
Clique duas vezes em Formato de Texto a fim de inserir uma expressão de atributo para calcular o estilo de fonte do texto na célula da tabela para cada célula de dimensão. A expressão usada como expressão de formato de texto deve retornar um caractere contendo '<B>' para texto em negrito, '<I>' para texto em itálico e/ou '<U>' para texto sublinhado.

Com os botões Promover e Rebaixar, as dimensões da lista Dimensões usadas podem ser classificadas.

Adicionar dimensão calculada...

Adiciona uma nova dimensão e abre a mesma para edição na caixa de diálogo Editar Expressão. Uma dimensão de gráfico está, geralmente, em um campo único, mas também pode ser dinamicamente calculada. Uma dimensão dinamicamente calculada consiste em uma expressão envolvendo um ou mais campos. Todas as funções-padrão podem ser usadas. As funções de agregação não devem ser usadas, mas a função Aggr pode ser incluída para se obter uma agregação aninhada.

Sintaxe da expressão para fórmulas calculadas

Editar... Abre a dimensão para edição na caixa de diálogo Editar Expressão. Consulte Adicionar dimensão calculada... acima para obter detalhes sobre dimensões calculadas.
Configuração para a Dimensão Selecionada

Esse grupo apresenta configurações para dimensões individuais.
Permitir Condicional
Marcar essa caixa de seleção oculta ou mostra a dimensão dinamicamente, dependendo do valor de uma expressão de condição inserida, clicando no botão ... na caixa de edição abaixo.

Ocultar Quando o Valor for NULO
Se essa caixa de seleção estiver habilitada, a dimensão selecionada em Dimensões Usadas apresentada anteriormente não será mostrada no gráfico se o valor for NULO.
Mostrar Todos os Valores
Habilite essa caixa de seleção para mostrar todos os valores de dimensão, independentemente da seleção. Como o valor da expressão é zero para valores de dimensão excluída, a opção Ocultar Zeros na página Apresentação deve ser desmarcada para que Mostrar Todos os Valores funcione. A opção Mostrar Todos os Valores não se aplica se você utiliza uma expressão como dimensão.
Mostrar Legenda
Quando a opção Mostrar Legenda está marcada, os "nomes" dos valores de campo são mostrados ao longo do eixo x.
Rótulo
Com a opção Rótulo marcada, o nome do campo é mostrado. Os rótulos podem ser editados na caixa de texto abaixo. Um rótulo também pode ser definido como uma expressão de rótulo calculada para atualização dinâmica do texto do rótulo. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Avançado...
Esse botão abre a caixa de diálogo Configurações de Campo Avançadas, que oferece configurações para a representação por imagens de valores de campo e as opções de pesquisa de texto especiais.

Advanced Field Settings

Comentário
Um campo de comentário no qual a dimensão selecionada pode ser descrita. O comentário pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.
Quebras de Página
Essa configuração é aplicada somente para a inclusão de quebras de página na impressão de uma tabela dinâmica ou tabela estática. Estão disponíveis três modos, com os seguintes efeitos:

Sem Quebras
Só irá inserir quebras de página ao final de cada página, conforme necessário.
Quebras Condicionais
Insere uma quebra de página, a não ser que todas as linhas com o valor de dimensão seguinte caibam na página atual.
Quebras Forçadas
Insere uma quebra de página sempre que muda o valor da dimensão

Propriedades de Gráfico: Limites de Dimensão

Limites de Dimensão podem ser definidos para tipos de gráfico, exceto para Gráficos de Mostrador e Tabelas Dinâmicas.

A guia Limites de Dimensão controla o número de valores de dimensão que podem se vistos em um determinado gráfico.

É importante descrever o efeito produzidos pelas três opções no dropdown. O dropdown contém três valores: Primeiro, Maior e Menor. Esses valores controlam como os mecanismos de cálculo classificam os valores que retornam ao mecanismo de gráfico. Se a dimensão deve ser restrita, uma dessas opções deverá ser selecionada. A classificação ocorre apenas para a primeira expressão, exceto em tabelas dinâmicas quando a classificação principal pode substituir a primeira classificação de dimensão.

Esta página de propriedades é usada para definir limites de dimensão. Cada dimensão no gráfico é configurada separadamente.

Limites

Restrinja quais valores serão exibidos usando a primeira expressão
Essas propriedades são usadas para determinar quantos valores de dimensão serão exibidos no gráfico, de acordo com as configurações feitas abaixo.

Mostrar Somente
Selecione essa opção se desejar mostrar os x números Primeiro, Maior ou Menor de valores. Se essa opção for definida como 5, cinco valores serão mostrados. Se a dimensão tiver a opção Mostrar Outros ativada, o segmento Outros ocupará um dos cinco slots de exibição.

A opção Primeiro retornará as linhas com base nas opções selecionadas na abra Classificar do diálogo de propriedades. Se o gráfico for uma Tabela Estática, as linhas serão retornadas com base na classificação principal do momento. Em outras palavras, um usuário pode alterar a exibição de valores clicando duas vezes em qualquer header de coluna e tornando essa coluna a classificação principal.

A opção Maior retorna as linhas em ordem decrescente com base na primeira expressão no gráfico. Quando usados em uma Tabela Estática, os valores de dimensão permanecerão consistentes enquanto classificam interativamente as expressões. Os valores de dimensões serão (poderão ser) alterados quando a ordem das expressões for alterada.

A opção Menor retorna as linhas em ordem crescente com base na primeira expressão no gráfico. Quando usados em uma Tabela Estática, os valores de dimensão permanecerão consistentes enquanto classificam interativamente as expressões. Os valores de dimensões serão (poderão ser) alterados quando a ordem das expressões for alterada.

Insira o número de valores a serem exibidos. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.

Mostrar somente valores que são:
Selecione essa opção para mostrar todos os valores de dimensões que atendem à condição especificada para essa opção. Selecione para exibir valores baseados em uma porcentagem do total ou em um valor exato. A opção relação ao total habilita um modo relativo que é semelhante à opção Relativo na guia Expressões da caixa de diálogo de propriedades. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.

Mostrar somente valores que se acumulam em:
Quando essa opção é selecionada, todas as linhas até a linha atual são acumuladas e o resultado é comparado com o valor definido na opção. A opção relação ao total habilita um modo relativo que é semelhante à opção Relativo na guia Expressões da caixa de diálogo de propriedades e compara os valores acumulados (com base nos valores primeiro, maior ou menor) com o total geral. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão. Selecione Incluir Valores Limite para incluir o valor da dimensão que contém o valor de comparação.

Sintaxe da expressão para fórmulas calculadas

Nota: Valores negativos não serão incluídos durante o cálculo da soma de restrição acumulada. Recomendamos que você não use restrições relativas para campos que possam conter valores negativos.
Nota: Se você adicionar um limite a uma dimensão calculada e os dados forem classificados na mesma dimensão calculada, o limite de dimensão será aplicado antes de a ordem de classificação ser aplicada.
Opções Mostrar Outros
Habilitar essa opção gerará um segmento Outros no gráfico. Todos os valores de dimensão que não atendem aos critérios de comparação das restrições de exibição serão agrupados no segmento Outros. Se houver dimensões após a dimensão selecionada, Contrair Dimensões Internas controlará se os valores individuais para as dimensões subsequentes/internas serão exibidos no gráfico.

Rótulo
Digite o nome que deverá ser exibido no gráfico. Se nenhum texto for digitado, o rótulo será definido automaticamente como o texto da expressão. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.

Mostrar Total
O gráfico exibirá um total para a dimensão selecionada quando essa opção for habilitada. Esse total se comporta diferentemente do total da expressão, que ainda está configurado na aba Expressões da caixa de diálogo propriedade.

Rótulo
Digite o nome que deverá ser exibido no gráfico. Se nenhum texto for digitado, o rótulo será definido automaticamente como o texto da expressão. O valor pode ser inserido como uma fórmula calculada. Clique no botão ... para abrir a caixa de diálogo Editar Expressão.

Modo de Agrupamento Global
A opção se aplica apenas a dimensões internas. Quando essa opção for habilitada, as restrições serão calculadas somente na dimensão selecionada. Todas as dimensões anteriores serão ignoradas. Se essa opção for desabilitada, as restrições serão calculadas com base em todas as dimensões anteriores.

Totais de Expressão Comparados com os Totais de Dimensão

Os Totais de Dimensão são gerados pelo mecanismo de cálculo e são retornados ao mecanismo de gráfico como linhas separadas (ou valores de dimensão). Isso terá um impacto nas linhas Outros. A diferença entre usar Totais de Expressão e Totais de Dimensão pode ser vista abaixo.

Totais de Expressão e Totais de Dimensão

Quando a opção Totais de Dimensão é usada, é possível ter subtotais dentro de uma tabela estática.

Propriedades de Gráfico: Expressões

Para acessar a aba Propriedades do Gráfico: Expressões, clique com o botão direito em um gráfico ou uma tabela e selecione Propriedades no menu Objeto.

Ao criar um gráfico, duas perguntas devem ser feitas:

  • O que o tamanho das barras, etc., devem representar? Essas são as Expressões (por exemplo, a soma das Vendas Líquidas).
  • Como os dados devem ser agrupados? Essas são as Dimensões (por exemplo, por País).
Nota: A guia Expressões tem uma aparência diferente para cada tipo de gráfico e tabela. Se a opção estiver desabilitada, ela não estará disponível para esse tipo específico de gráfico ou tabela.
Lista de Expressões

A lista de expressões do painel superior esquerdo é um controle de árvore completo, com várias opções de controle.
Na frente de cada expressão (ou grupo de expressões), será exibido um ícone de expansão (uma caixa com um ' + '). Se você clicar no ícone, serão abertas subexpressões subjacentes ou expressões de atributo. O ícone será imediatamente substituído pelo ícone de contração ( ' - ' ). Certas opções de desenho utilizam subexpressões, como um conjunto de duas ou mais expressões que, juntas, definem o símbolo de desenho (por exemplo, Ações ou Box Plot, descritos abaixo).
Os dados da expressão também podem ser formatados dinamicamente por meio de expressões de atributo. Clique no ícone de expansão de uma expressão para que sejam exibidos os espaços reservados das expressões de atributo da dimensão. São elas:

Cor de Fundo
Edite a expressão padrão de Cor de Fundo para definir a expressão de atributo para calcular a cor de plotagem do ponto de dados. A cor calculada terá prioridade sobre a seleção de cor padrão do QlikView e deverá ser uma representação de cor válida, obtida por meio das funções de cor. Se o resultado da expressão não for uma representação de cor válida, o programa definirá a cor preta como padrão. É possível criar uma expressão auxiliar para a Cor do Texto usando o mesmo método.

Funções de cor

Cor do Texto
É possível criar uma expressão auxiliar para a Cor do Texto usando o mesmo método da cor de fundo (veja acima).

Formato do Texto
Edite a expressão de Formato do Texto para inserir uma expressão de atributo e calcular o estilo da fonte de texto associado ao ponto de dado (para tabelas: texto na célula da tabela para cada célula de dimensão. O formato de texto calculado terá precedência sobre o estilo de tabela definido em Propriedades do Gráfico: Estilo. A expressão usada como expressão de formato de texto deve retornar um caractere contendo '<B>' para texto em negrito, '<I>' para texto em itálico e/ou '<U>' para texto sublinhado. Observe que é necessário usar o sinal = antes do caractere.

Pop-out da pizza
Clique em Popout de Pizza para inserir uma expressão de atributo a fim de calcular se a fatia da pizza associada ao ponto de dados deve ser desenhada em uma posição de “popout” extraída. Esse tipo de expressão de atributo só tem efeito em gráficos de pizza.

Deslocamento de Barra
Clique em Deslocamento de Barra para inserir uma expressão de atributo a fim de calcular um deslocamento da barra ou do segmento de barras associado ao ponto de dados. O deslocamento pode ser positivo ou negativo e moverá a barra ou o segmento apropriadamente. Isso é útil, por exemplo, ao criar gráficos em cascata. Esse tipo de expressão de atributo só tem efeito em gráficos de barras.

Estilo de Linha
Clique em Estilo de Linha para informar uma expressão de atributo para o cálculo do estilo de linha ou do segmento de linha associado ao ponto de dados. Esse tipo de expressão de atributo só tem efeito em gráficos de linhas, combinados e de radar. A espessura relativa da linha pode ser controlada incluindo-se uma tag <Wn>, em que n é um fator multiplicador que será aplicado na espessura padrão de linha do gráfico. O número n deve ser um número real entre 0,5 e 8. Exemplo: <W2.5>. O estilo da linha pode ser controlado incluindo um rótulo <Sn> em que n é um inteiro entre 1 e 4, indicando o estilo que será usado (1=contínuo, 2= tracejado, 3=pontilhado, 4=tracejado/pontilhado). Exemplo: <S3>. As tags <Wn> e <Sn> podem ser livremente combinadas, mas somente a primeira ocorrência de cada uma é levada em consideração. As tags devem ser fechadas por aspas simples.

Mostrar Valor
Clique em Mostrar Valor para inserir uma expressão de atributo a fim de calcular se o desenho do ponto de dados deverá ser complementado por um valor de "valor sobre o ponto de dados", mesmo se a opção Valores nos Pontos de Dados não tiver sido selecionada para a expressão principal. Se a opção Valores nos Pontos de Dados estiver selecionada para a expressão principal, a expressão de atributo será ignorada. Esse tipo de expressão de atributo só tem efeito em gráficos de barras, de linhas, de pizza, de funil e combinados.

Adicionar Novas expressões e subexpressões são criadas através do botão Adicionar. A opção também está disponível no menu de contexto exibido ao clicar com o botão direito do mouse na lista de expressões.
Excluir O botão Excluir permite excluir da lista expressões criadas anteriormente da lista. A opção também está disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão da lista de expressões.
Copiar A opção Copiar só estará disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão ou uma subexpressão/expressão de atributo na lista de expressões. Ao usar este comando em uma expressão principal, todos os dados e configurações associados à impressão (incluindo o rótulo) serão copiados na área de transferência como um xml. A expressão pode então ser colada novamente no mesmo gráfico ou em qualquer outro gráfico do QlikView, no mesmo documento ou em outro. Caso use o comando em uma expressão de atributo, somente a definição da expressão de atributos será copiada. A expressão de atributo pode então ser colada em qualquer expressão principal do mesmo gráfico ou de outro.
Exportar... A opção Exportar... só estará disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão na lista de expressões. Ao usar este comando em uma expressão principal, todos os dados e configurações associados à expressão (incluindo o rótulo) podem ser exportados para um arquivo xml. A expressão pode então ser importada novamente no mesmo gráfico ou em qualquer outro gráfico do QlikView, no mesmo documento ou em outro. O comando abre a caixa de diálogo Exportar Expressão como, a partir da qual você pode selecionar o destino do arquivo de exportação. O arquivo receberá a extensão Ex.XML.
Colar A opção Colar só estará disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão ou uma subexpressão/expressão de atributo na lista de expressões. Se a expressão principal foi copiada anteriormente na área de transferência, é possível colá-la na área em branco da lista de expressões, criando uma nova expressão idêntica à copiada. Se uma expressão de atributo foi copiada, é possível colá-la em uma expressão principal.
Importar A opção Importar só estará disponível no menu de contexto exibido ao clicar com o botão direito na área em branco da lista de expressões. O comando abre uma caixa de diálogo em que você pode navegar até a expressão exportada anteriormente. A expressão importada será exibida como uma nova expressão no gráfico.
Promover
Rebaixar
Se várias expressões forem mostradas, poderão ser classificadas com os botões Promover e Rebaixar. Isso afeta a ordem na qual as colunas, etc. são mostradas no gráfico.
Grupo O botão Grupo pode ser usado para mesclar expressões em um ou mais grupos cíclicos, desde que estejam disponíveis duas ou mais expressões. No layout do QlikView, você pode circular pelas expressões pertencentes a um grupo clicando no ícone de ciclo mostrado no gráfico (= Grupo de Ciclo). Clique com o botão direito do mouse no mesmo ícone de ciclo para obter uma lista pop-up das expressões pertencentes ao grupo que não estão em uso no momento, para seleção direta.
Nota:

Não confunda Grupo de Ciclo com grupos cíclicos!

Grupos não hierárquicos (cíclicos)

Desagrupar Selecione uma expressão pertencente a um grupo e clique em Desagrupar para extraí-la do grupo. Se restar apenas uma expressão no grupo de ciclo após a extração, essa última expressão também será extraída e o grupo será excluído.
Habilitar Desmarque essa caixa de seleção para que a expressão seja omitida no gráfico.
Relativo Marque essa caixa de seleção para que o gráfico mostre o resultado em porcentagem, em vez de números absolutos. Essa opção não está disponível para tabelas dinâmicas.
Invisível Marque esta caixa de seleção para impedir o desenho dessa expressão e, ao mesmo tempo, manter o espaço alocado para ela.
Condicional A habilitação desta caixa permite definir uma condição com base na seleção atual, a qual determina se a expressão deve ser exibida ou não. Se a condição for avaliada como TRUE ou NULL, a expressão será exibida; se a condição for avaliada como FALSE, a expressão não será exibida.
Rótulo Há um ou vários ícones na frente do rótulo da expressão que indicam o tipo de gráfico usado e/ou as Opções de Exibição selecionadas para a expressão (veja abaixo).
Definição Mostra a composição da expressão selecionada. É possível editar a expressão diretamente nessa caixa. Clique no botão ... para abrir a caixa de diálogo Editar Expressão completa.
Comentário É um campo de comentários no qual o criador da expressão pode descrever a finalidade e a função da expressão.
Mostrar Opções Esse grupo é usado para modificar o modo como o dado é desenhado ou o que é inserido nas células de expressão das tabelas de gráfico. Observe que algumas opções só estão disponíveis para determinados tipos de gráfico, algumas não podem ser combinadas e outras usam uma ou mais expressões adicionais para criar desenhos complexos.

Barra
Mostra os valores da expressão selecionada como barras. Essa opção está disponível apenas para gráficos de barras ou combinados.

Símbolo
Mostra os valores da expressão selecionada como símbolos. Essa opção está disponível apenas para gráficos de linhas e combinados. Selecione entre diferentes símbolos no menu suspenso.