Lista

A lista é o objeto de pasta mais básico e contém todos os valores possíveis de um campo específico. Cada linha da lista pode representar vários registros na tabela carregada e todos com valores idênticos. A seleção de um valor pode ser equivalente à seleção de vários registros na tabela carregada.

Uma lista também pode conter um grupo cíclico ou hierárquico. Se for usado um grupo hierárquico, a seleção de um só valor na lista forçará sua hierarquia e alternará para o próximo campo subjacente do grupo. Para subir novamente, clique no ícone de subida, no título da lista.

Se um grupo cíclico está atribuído a uma lista, é possível fazer com que mostre o próximo campo do grupo clicando no ícone de ciclo exibido no título da lista. Também é possível ir diretamente para qualquer campo do grupo usando a opção Ciclo no menu objeto da lista.

Clique com o botão direito do mouse na lista para exibir o menu Objeto.

Menu Objeto

O menu Objeto da lista é aberto quando você clica com o botão direito do mouse no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades da Lista, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ciclo

Disponível apenas quando a lista está definida para exibir um grupo cíclico. Abre um menu em cascata com os campos do grupo para a seleção direta dos campos a serem mostrados na lista.

Grupos não hierárquicos (cíclicos)

Pesquisar

Abre a caixa de pesquisa.

Pesquisar

Pesquisa Avançada

Abre a caixa de pesquisa de texto no modo pesquisa avançada.

Pesquisa Avançada

Pesquisa Refinada

Abre o diálogo Pesquisa Refinada. Neste diálogo é possível inserir expressões de pesquisa refinadas. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Shift+F.

Caixa de diálogo Pesquisa Refinada

Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Alterar Valor Disponível somente para listas que exibem campos de entrada. Define a célula clicada no modo de edição de entrada. Equivale a clicar no ícone de entrada na célula.
Restaurar Valores Disponível somente para listas que exibem campos de entrada. Abre um menu em cascata com três opções:
Restaurar Valor Único
Restaura o valor no valor de campo clicado para o valor padrão do script.
Restaurar Valores Possíveis
Restaura os valores de todos os valores de campo possíveis para os valores padrão do script.
Restaurar Todos os Valores
Restaura os valores de todos os valores de campo para seus valores padrão do script.
Selecionar Valores Possíveis Todos os valores não-excluídos da lista são selecionados.
Selecionar Valores Excluídos Todos os valores excluídos da lista são selecionados.
Selecionar Tudo Todos os valores da lista são selecionados.
Limpar Limpa todas as seleções atuais na lista ativa.
Limpar outros campos Limpa as seleções em todos os outros objetos da pasta, mas mantém as seleções da lista atual.
Bloquear Trava o(s) valor(es) selecionado(s) na lista ativa. (Esta alternativa ficará acinzentada se não houver seleções).
Destravar Destrava o(s) valor(es) travado(s) na lista ativa. (Esta alternativa será exibida em lugar de Travar se as seleções estiverem travadas).
Criar Gráfico Rápido...

Abre o Assistente de Gráfico Rápido, que o ajuda a criar um gráfico de forma rápida e fácil.

Assistente de Gráfico Rápido

Criar Gráfico de Tempo...

Abre o Assistente de Gráfico de Tempo, que permite criar gráficos em que uma determinada medida (expressão) deve ser qualificada e, muitas vezes, comparada em períodos de tempo diferentes.

Assistente de Gráfico de Tempo

Criar Caixa de Estatísticas Efetua diversos cálculos estatísticos nos valores selecionados de um campo (amostra) e exibe os resultados em uma caixa de estatísticas.
Imprimir Possíveis...

Abre o diálogo Imprimir que permite especificar a configuração de impressão. Todos os valores não-excluídos da lista ativa são enviados para a impressora.

Imprimir: Geral

Imprimir Possíveis como PDF...

Abre a caixa de diálogo Imprimir com a impressora PDF-XChange 3.0 pré-selecionada. Depois de pressionar o botão Imprimir, você deverá digitar um nome para o arquivo PDF a ser gerado. Esse comando só estará disponível se houver uma impressora PDF no sistema.

Enviar para Excel

Exporta os valores possíveis (incluindo os selecionados) para o Microsoft Excel, que será acionado automaticamente se ainda não estiver sendo executado. Os valores exportados aparecerão em uma nova planilha do Excel. Para que esse recurso funcione, o Microsoft Excel 2007 ou versão posterior deve estar instalado no computador.

Nota: os minigráficos não serão exibidos quando forem exportados para o Excel.
Exportar... Abre a caixa de diálogo Salvar como, que permite especificar o caminho, o nome do arquivo e o tipo de arquivo (tabela) para o conteúdo de dados exportado.
Copiar para a Área de Transferência Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Valores possíveis
Copia os valores possíveis (selecionados e opcionais) para a área de transferência.
Valor da Célula
Copia o valor de texto da célula de lista clicada com o botão direito (ao invocar o menu Objeto) para a área de transferência.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou excluirá o título e a borda do objeto de pasta, de acordo com as configurações na página Preferências do Usuário: Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Geral

A guia Propriedades de lista: Geral será aberta se você clicar com o botão direito do mouse em uma lista e escolher o comando Propriedades no menu suspenso. Aqui é possível definir parâmetros gerais da lista.

Título

É o texto a ser exibido no título da lista. O texto padrão é o nome do campo selecionado. O título também pode ser definido como uma fórmula calculada para atualização dinâmica do texto do rótulo. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Campo Selecione um campo na lista. A lista conterá os valores do campo selecionado.
Uma lista poderá mostrar um grupo cíclico ou um grupo hierárquico. No entanto, será mostrado somente um campo de cada vez. Esses grupos são criados a partir do diálogo Propriedades do documento: Grupos e serão listados com os campos disponíveis.
Se for usado um grupo hierárquico, a seleção de um único valor na lista irá detalhar a hierarquia e alternar para o próximo campo subjacente do grupo. Para subir novamente, clique no ícone de subida exibido no título da lista.
Se um grupo cíclico é atribuído a uma lista, é possível fazer com que alterne para mostrar o próximo campo do grupo clicando no ícone de ciclo exibido no título da lista. Também é possível ir diretamente para qualquer campo do grupo usando a opção Ciclo-> no menu de objeto da lista.
Além disso, é possível mostrar um campo calculado em uma lista. Um campo calculado não é proveniente da execução do script, ele é definido em uma expressão. As mesmas regras se aplicam nas dimensões calculadas. Se desejar usar um campo calculado na lista, selecione <Expressão> no menu suspenso, o que abrirá a caixa de diálogo Editar Expressão onde é possível definir a expressão que descreve o campo calculado.
Usar como Título
Marque essa caixa de seleção para que o nome do campo seja usado como Título. O texto <usar nome de campo> aparecerá na caixa de edição do Título.
Editar...
Esse botão só fica disponível quando <Expressão> é selecionado como um nome de campo. O botão abre a caixa de diálogo Editar Expressão, onde você pode definir a expressão que descreve o campo calculado.
Nota: Quando um campo calculado for usado, algumas funcionalidades da lista serão diferentes das listas de campo comuns. Algumas opções de propriedade não estão disponíveis (veja a seguir). Além disso, as caixas de estatísticas não podem ser criadas a partir dessas listas.
Nota: Um campo calculado deve ser sempre uma transformação de um ou mais campos normais. Campos calculados puramente sintéticos criados através das funções valuelist e valueloop não são permitidos. Ao fazer seleções em um campo calculado, na verdade, você faz seleções no(s) campo(s) subjacente(s) normal(is). Ao usar mais de um campo como base para um campo calculado, as implicações lógicas das seleções nos campos base ou no campo calculado podem ser um tanto complexas.  
Nota: O uso de campos calculados nas listas pode gerar problemas de desempenho com conjuntos de dados muito grandes.
Nota: Não é possível usar campos MEASURE definidos com a função do Direct Discovery em uma lista.
Modo AND

Múltiplas seleções em um campo devem ser do tipo AND ou OR. Por padrão, a seleção é de tipo OR. Este comando alterna o modo lógico através do qual são feitas várias seleções de valor. Esta opção de menu é desabilitada se o campo não atender a determinadas condições. Esta opção não está disponível para campos calculados.

Mostrar Alternativas Alterna para definir se uma seleção direta na lista de campos ativa deverá excluir ou não os outros valores do campo. Se a opção Mostrar Alternativas estiver marcada, todos os valores, exceto o valor selecionado, serão mostrados como opções, mas poderão ser excluídos pela associação às seleções em outros campos. Caso contrário, todos os outros valores serão mostrados como excluídos, por padrão. Esta opção não está disponível para campos calculados.
Ocultar Excluídos Alterna para definir se os valores excluídos do campo devem ou não ser mostrados. Os valores excluídos também não podem mais ser selecionados.
Somente leitura Quando esta opção está marcada, não é possível fazer seleções na lista. Entretanto, continuará refletindo as seleções feitas em outra parte do documento.
Sempre Um Valor Selecionado

Ao marcar essa opção, você garante que um valor pode ser selecionado, o que é útil em documentos nos quais os dados só fazem sentido quando um valor já está selecionado, por exemplo, uma taxa de unidade monetária. Essa opção é ativada quando um valor já está selecionado na lista. Esta opção não está disponível para campos calculados.

Nota: Habilitar esta opção modifica o modelo de dados. Como resultado, os marcadores existentes podem deixar de funcionar, mesmo que os nomes de campo permaneçam os mesmos.
Sobrepor Campo Travado Marque esta opção para permitir seleções na lista, mesmo que ela esteja travada. A lista continuará travada para as seleções feitas em outra parte do documento.
Mostrar como Exibição em Árvore

Mostra a lista como uma exibição em árvore. Esse controle será relevante apenas se o campo contiver a representação do caminho dos nós em uma hierarquia. Use o parâmetro Path do prefixo Hierarchy para gerar tal campo.

Exibição em Árvore da Lista

Com Separador Defina o caractere que deve ser interpretado como um separador no caminho usado para a Exibição em Árvore.
Mostrar Frequência Alterna o status que define se a frequência de um valor de campo será mostrada ou não. O termo frequência significa o número de combinações selecionáveis nas quais ocorre o valor. Esta opção não está disponível para campos calculados.
Em Percentagem Alterna o status que define se a frequência deve ser mostrada em números absolutos ou como porcentagem do número total de entradas.
Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto

É utilizado para fins de macro. A cada objeto da pasta é atribuído um ID exclusivo. Recomendamos o uso de caracteres alfanuméricos apenas na ID. Para listas, a ID começa com LB01. Os objetos vinculados têm o mesmo ID de objeto. Você pode editar posteriormente esse número de ID.

Interpretador Interno de Macro

Incluir Valores Excluídos na Pesquisa A lista suspensa permite que você escolha entre Sim, Não ou <usar padrão>, que aplica a configuração padrão conforme especificado em Preferências do usuário: Geral.
Modo de Pesquisa Padrão Especifica o modo de pesquisa padrão inicial a ser usado em pesquisas de texto. O modo pode ser alterado a qualquer momento, digitando * ou ~ como parte dos caracteres de pesquisa. As seguintes alternativas estão disponíveis:
Use <padrão>
O padrão especificado em Preferências do usuário será aplicado.
Usar Pesquisa com Curinga
Os caracteres de busca iniciais serão dois curingas com o cursor entre eles para facilitar a pesquisa com curinga.
Usar Pesquisa Avançada
O caractere de busca inicial será um til (~) para indicar uma pesquisa avançada.
Usar Pesquisa Normal
Nenhum caractere adicional será incluído nos caracteres de busca. Sem caracteres curinga, será realizada uma Pesquisa Normal.
Usar pesquisa associativa
A pesquisa associativa será usada na caixa de pesquisa.

Pesquisar

Configurações de Impressão Aqui você define as configurações de impressão para o trabalho de impressão.
Imprimir Todos os Valores O comportamento de impressão normal para listas é imprimir somente valores possíveis. Assinalando esta caixa de verificação, todos os valores (até mesmo valores excluídos) serão impressos.
Impressão Dependente do Layout Assinalando essa caixa de verificação, a lista será impressa da forma como aparece na tela no que se refere ao número de colunas, à codificação da cor de seleção das células, etc. Esse recurso pode ser útil, por exemplo, na inclusão de listas em relatórios.

Expressões

Use a aba Expressões para definir as expressões a serem exibidas na lista. Cada expressão será colocada em uma nova coluna da lista. O canto superior esquerdo da caixa de diálogo contém uma lista de expressões.

Os dados da expressão também podem ser formatados dinamicamente por meio de expressões de atributo. Clique no ícone de expansão em frente a qualquer expressão para que sejam exibidas as expressões de atributo da expressão.

Você pode optar por usar quaisquer números e combinações de expressões de atributo em uma determinada expressão de base. O formato definido por meio da expressão de atributo substituiu o formato padrão dos desenhos de dados em termos de cor, etc.

Adicionar Clique nesse botão para que seja exibida a caixa de diálogo Editar Expressões, que permite criar novas expressões. Essa opção também está disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão da lista de expressões.
Excluir Exclui a expressão selecionada. A opção também está disponível no menu de contexto exibido ao clicar com o botão direito em uma expressão da lista de expressões.
Copiar A opção está disponível somente no menu de contexto exibido ao clicar com o botão direito em uma expressão da lista de expressões. Ao usar este comando em uma expressão principal, todos os dados e configurações associados à impressão (incluindo o rótulo) serão copiados na área de transferência como um xml. A expressão pode então ser colada novamente no mesmo objeto ou em qualquer outro objeto do QlikView, no mesmo documento ou em outro. Caso use o comando em uma expressão de atributo, somente a definição da expressão de atributos será copiada. A expressão de atributo pode então ser colada em qualquer expressão principal do mesmo objeto ou de outro.
Exportar... A opção está disponível somente no menu de contexto exibido ao clicar com o botão direito em uma expressão principal da lista de expressões. Ao usar este comando em uma expressão principal, todos os dados e configurações associados à expressão (incluindo o rótulo) podem ser exportados para um arquivo xml. A expressão pode então ser importada novamente no mesmo gráfico ou em qualquer outro gráfico do QlikView, no mesmo documento ou em outro. O comando abre a caixa de diálogo Exportar Expressão como, a partir da qual você pode selecionar o destino do arquivo de exportação. O arquivo receberá uma extensão, por exemplo, xml.
Colar A opção está disponível somente no menu de contexto exibido ao clicar com o botão direito na lista de expressões, e apenas se uma expressão tiver sido copiada anteriormente para a área de transferência. Se a expressão principal foi copiada anteriormente na área de transferência, é possível colá-la na área em branco da lista de expressões, criando uma nova expressão idêntica à copiada. Se uma expressão de atributo foi copiada, é possível colá-la em uma expressão principal.
Importar... A opção está disponível somente no menu de contexto exibido ao clicar com o botão direito na área em branco da lista de expressões. O comando abre uma caixa de diálogo em que você pode navegar até as expressões exportadas anteriormente. A expressão importada será exibida como uma nova expressão principal no gráfico.
Promover Promove a expressão selecionada um passo acima na lista. Use esse botão para alterar a ordem das expressões.
Rebaixar Rebaixa a expressão selecionada um passo abaixo na lista. Use esse botão para alterar a ordem das expressões.
Símbolo Null O símbolo inserido aqui será usado na exibição de valores NULL na tabela.
Símbolo Faltante O símbolo inserido aqui será usado na exibição de valores faltantes na tabela.
Habilitar Marque essa caixa de seleção para habilitar a expressão selecionada. Se a caixa não estiver marcada, a expressão não será usada.
Definição Mostra a composição da expressão selecionada. É possível editar a expressão diretamente nessa caixa. Clique no botão ... para abrir a caixa de diálogo Editar Expressões completa.
Mostrar Se for selecionada a opção Sempre, a expressão será exibida em uma coluna extra da lista. Se for selecionada a opção Condicional, a expressão poderá ser exibida ou ocultada dinamicamente, dependendo do valor de uma expressão de condição inserida na caixa de edição à direita.
Alinhamento Neste grupo, é possível definir o alinhamento padrão das expressões. Texto e números podem ser definidos individualmente, ajustados à esquerda, centralizados ou ajustados à direita.
Mostrar Opções Este grupo define o que será escrito nas células de expressão da lista.
Representação As seguintes alternativas são fornecidas:
Text
Ao selecionar essa opção, os valores da expressão serão sempre interpretados e exibidos como texto.
Imagem
Ao selecionar essa opção, o QlikView tentará interpretar cada valor da expressão como uma referência a uma imagem. A referência pode ser um caminho para um arquivo de imagem no disco (por exemplo, C:\Minha_imagem.jpg) ou dentro do próprio documento qvw (por exemplo, qmem:// <Nome>/<Pedro>). Se o QlikView não conseguir interpretar um valor de expressão como uma referência válida de imagem, o próprio valor será exibido.
Mostrador circular
Ao selecionar essa opção, o QlikView exibirá o valor da expressão em um mostrador de estilo circular. O gráfico de mostrador será inscrito na célula disponível da tabela. A configuração visual do mostrador pode ser modificada usando o botão Configuração do Mostrador....
Indicador linear
Ao selecionar essa opção, o QlikView exibirá o valor da expressão em um mostrador horizontal de estilo linear. O gráfico de mostrador será inscrito na célula disponível da tabela. A configuração visual do mostrador pode ser modificada usando o botão Configuração do Mostrador....
Mostrador de semáforo
Ao selecionar essa opção, o QlikView exibirá o valor da expressão em um mostrador horizontal de estilo de semáforo. O gráfico de mostrador será inscrito na célula disponível da tabela. A configuração visual do mostrador pode ser modificada usando o botão Configuração do Mostrador....
Mostrador LED
Ao selecionar essa opção, o QlikView exibirá o valor da expressão em um mostrador de estilo LED. O gráfico de mostrador será inscrito na célula disponível da tabela. A configuração visual do mostrador pode ser modificada usando o botão Configuração do Mostrador....
Minigráfico
Ao selecionar essa opção, o QlikView exibirá o valor da expressão em um gráfico em miniatura com a expressão agregada em uma dimensão extra. O gráfico será inscrito na célula disponível da tabela. A dimensão do minigráfico pode ser definida e as configurações visuais podem ser modificadas usando o botão Configurações do Minigráfico.
Nota: O minigráfico não será exibido quando for exportado para o Excel.
Configuração do Mostrador... Somente disponível quando uma das opções anteriores de mostrador for selecionada. Abre uma caixa de diálogo para configurar as propriedades do mostrador. Essa caixa de diálogo é basicamente igual à caixa de diálogo Propriedades de gráfico: Apresentação para gráficos de mostrador.
Configurações do Minigráfico Somente disponível quando Minigráfico tiver sido selecionado como Opção de Exibição para uma expressão na tabela. Abre uma caixa de diálogo para configurar as propriedades do minigráfico.
Formato de Imagem Somente disponível quando as opções de imagem apresentadas anteriormente tiverem sido selecionadas. Essa configuração descreve como o QlikView formata a imagem para ajustar-se à célula. Há quatro alternativas.
Sem Esticar
Se essa opção estiver selecionada, a imagem será mostrada como a original, sem ser esticada. Isso pode fazer com que partes da imagem fiquem invisíveis ou que apenas parte da célula seja preenchida.
Preencher
Se essa opção for selecionada, a imagem será esticada para que se ajuste à célula, sem a preocupação de manter a proporção da imagem.
Manter Proporção
Se essa opção for selecionada, a imagem será esticada o máximo possível, de forma a preencher a célula mantendo, ao mesmo tempo, a proporção da imagem. Isso normalmente resulta em áreas, em ambos os lados ou abaixo e acima, que não são preenchidas pela imagem.
Preencher com Proporção
Se essa opção for selecionada, a imagem será esticada em ambas as direções, de forma a preencher a célula mantendo, ao mesmo tempo, a proporção da imagem. Isso normalmente resulta no corte da imagem em uma direção.
Ocultar Texto Quando Faltar Imagem
Se essa opção for selecionada, o QlikView não exibirá o texto do valor de campo se, por alguma razão, houver falha na sua interpretação como referência a uma imagem. A célula será deixada em branco.

Configurações do minigráfico

Somente disponível quando a opção Minigráficos tiver sido selecionada na página Expressões da caixa de diálogo Propriedades de uma tabela estática. Abre uma caixa de diálogo para configurar as propriedades do minigráfico.

Dimensão Escolhe a dimensão para a qual a expressão deve ser plotada.

Aparência

Modo Defina o minigráfico como sparklines, linhas com pontos, pontos, barras ou caixas estreitas.
Cor Abre a caixa de diálogo Área de Cores, onde é possível definir a cor da plotagem do minigráfico.
Realçar Valor Máximo com Cor Marque a caixa de verificação e clique no botão colorido para abrir a caixa de diálogo Área de Cores, onde é possível definir a cor do valor máximo.
Realçar Valor Mínimo com Cor Marque a caixa de verificação e clique no botão colorido para abrir a caixa de diálogo Área de Cores, onde é possível definir a cor do valor mínimo.
Selecionar valores iniciais com cor Marque a caixa de verificação e clique no botão colorido para abrir a caixa de diálogo Área de Cores, onde é possível definir a cor dos valores iniciais. Não disponível para Barras e Margens Pequenas.
Realçar Valores Finais com Cor Marque a caixa de verificação e clique no botão colorido para abrir a caixa de diálogo Área de Cores, onde é possível definir a cor dos valores finais. Não disponível para Barras e Margens Pequenas.
Definir Cores Padrão Define as cores das configurações realçadas como cores padrão do QlikView.
Forçar Dimensionamento Baseado em Zero Fixa a extremidade inferior do gráfico em zero no eixo. Não disponível para Caixas Estreitas.
Forçar Escala Compartilhada para o Eixo Y Força todas as células da coluna a usar a mesma escala do eixo y.

Classificar

Acesse a guia Classificar clicando com o botão direito do mouse em um objeto da pasta (objeto Lista, Seleção Múltipla, Tabela, Gráfico ou Controle Deslizante/Calendário) e selecionando Propriedades no menu suspenso (ou Objeto, Propriedades no menu principal). Defina a ordem de classificação dos valores no objeto da pasta. Algumas opções de classificação podem não estar disponíveis para alguns objetos de pasta.

Classificar por:

Estado

Classifica os valores de campo de acordo com seu estado lógico (selecionado, opcional ou excluído).
A configuração Crescente Automático classificará a lista (ou, em uma seleção múltipla, a lista suspensa que contém os valores de campo) de acordo com o Estado somente se a lista tiver uma barra de rolagem vertical. No entanto, se você ampliar a lista para mostrar todos os valores, o Estado da ordem de classificação será completamente desativado.

Nota: Não use a ordem Crescente Automática em uma lista dentro de um objeto Contêiner.
Expressão Classifica os valores de campo de acordo com a expressão digitada na caixa de edição de texto abaixo dessa opção de classificação. Se a classificação for feita por expressão, um conjunto alternativo de registros deverá ser definido por uma expressão de conjunto, pois a expressão é calculada sobre os valores selecionados/possíveis na lista e a classificação só se aplica aos valores selecionados/possíveis na lista.
Nota: A opção de Classificar por Expressão só funciona com campos numéricos, e não com campos de texto.

Análise de conjunto e expressões de conjunto

Frequência Classifica os valores de campo por frequência (número de ocorrências na tabela).
Valor Numérico Classifica os valores de campo por valor numérico.
Texto Classifica os valores de campo em ordem alfabética.
Ordem de Carregamento Classifica os valores de campo pela ordem de carga inicial.

A ordem de classificação do botão Padrão define a ordem de classificação padrão.

A ordem de prioridade é Estado, Expressão, Frequência, Valor Numérico, Texto e Ordem de Carga. Cada um desses critérios de classificação pode ser definido como Crescente ou Decrescente.

Apresentação

A guia Propriedades de lista: Apresentação será aberta se você clicar com o botão direito do mouse em uma lista e selecionar o comando Propriedades no menu suspenso. Aqui é possível ajustar o layout das células da lista.

No grupo Opções de Imagem, você pode permitir que um valor de campo contendo uma referência a uma imagem na memória ou no disco seja interpretado como essa imagem:

Em Representação, escolha entre Texto (padrão), Imagem e Informação como Imagem.

Quando você selecionar Imagem, o QlikView tentará interpretar cada valor de campo como uma referência a uma imagem. A referência pode ser um caminho para um arquivo de imagem no disco (por exemplo, C:\Minha_imagem.jpg) ou dentro do próprio documento qvw (por exemplo, qmem://<Nome>/<Pedro>). Se o QlikView não puder interpretar um valor de campo como uma referência de imagem válida, o valor em si será exibido, a não ser que a caixa Ocultar Texto Quando Faltar Imagem esteja marcada.

Quando você selecionar Informação como Imagem, o QlikView exibirá informações de imagem vinculadas ao valor de campo por meio dos comandos info load/info select do script. Se nenhuma informação de mensagem estiver disponível para um valor de campo, o próprio valor será exibido, a não ser que a caixa Ocultar Texto Quando Faltar Imagem esteja marcada.

Contanto que uma opção de imagem seja selecionada, as configurações em Formato de Imagem podem ser usadas para ajustar a imagem à célula.

Sem Esticar A imagem é exibida em seu estado original, o que poderá causar problemas de mascaramento.
Preencher A imagem é esticada de forma a preencher a célula, independentemente da proporção da imagem.
Manter Proporção A imagem é esticada o máximo possível, mantendo a proporção da imagem correta.
Preencher com Proporção A imagem é esticada o máximo possível, mantendo a proporção da imagem correta. Áreas não cobertas são preenchidas com recortes da imagem.

Se imagens forem mostradas, em vez de texto, talvez seja necessário usar outro estilo de seleção diferente do padrão do documento, para que o estado lógico dos valores de campo permaneçam visíveis. Use a lista suspensa em Sobrepor Estilo de Seleção para escolher um estilo de seleção adequado; por exemplo, Indicador de Canto.

Coluna Única Quando esta opção estiver marcada, os valores de campo da lista serão sempre apresentados em uma coluna única.
Ocultar Barra de Rolagem Horizontal Marque esta opção para ocultar a barra de rolagem horizontal, normalmente exibida quando os valores de campo são muito grandes para a largura especificada da lista. Neste caso, os valores de campo serão truncados conforme necessário.
Número de Colunas Fixo Marque esta opção para definir um número fixo de colunas para a lista. A opção não estará disponível quando a opção Coluna Única estiver marcada.
Ordenar por Coluna Em listas com mais de uma coluna, os valores são mostrados em relação à linha na ordem de classificação especificada. A opção Ordenar por coluna alterna para a exibição em relação à coluna.
Bordas da Célula Os valores de campo serão separados por linhas horizontais, semelhantes às linhas de uma tabela. As Bordas da Célula serão ativadas automaticamente quando a opção Retorno do Texto da Célula for selecionada, mas podem ser desativadas posteriormente.
Destacar pesquisa
Substring
Os caracteres de busca inseridos no objeto de pesquisa até agora serão realçados nas correspondências.
Plano de Fundo... Abre a caixa de diálogo Configurações de Plano de Fundo.
Alinhamento Defina o alinhamento dos valores de campo da lista. O alinhamento do Texto e dos Números é definido separadamente.
Configuração Multi-Linha Neste grupo, as células da lista podem ser definidas para exibir valores em várias linhas, o que é útil para caracteres de texto longos.
Retorno do Texto da Célula
Com esta opção selecionada, o conteúdo de uma célula será mostrado em mais de uma linha.
Altura n Linhas
Aqui são especificados os limites desejados para o número de linhas da célula.

Configurações de Fundo

Cor Se esta configuração for habilitada, o fundo do objeto ficará colorido. Escolha uma cor clicando no botão Cor.
Transparência de Cor Apenas disponível quando a opção de cor estiver habilitada. Define a transparência da cor de fundo.
Imagem Se esta configuração for habilitada, o fundo do objeto será uma imagem. Clique em Pesquisar para escolher uma imagem. Clique em Remover para removê-la do plano de fundo.
Esticar Imagem Apenas disponível quando a opção de imagem estiver habilitada. A configuração descreve como o QlikView formata a imagem para ajustar seu tamanho.
Sem Esticar
A imagem será mostrada em sua forma original, sem ser esticada. Isso pode fazer com que partes da imagem não possam ser vistas ou apenas preencham parte do fundo.
Preencher
A imagem será esticada para ser ajustada ao plano de fundo, sem manter sua proporção entre altura e largura.
Manter Proporção
A imagem será esticada o máximo possível para preencher o plano de fundo e, ao mesmo tempo, manter sua proporção entre altura e largura.
Preencher com Proporção
Se essa opção for selecionada, a imagem será esticada em ambas as direções, de forma a preencher o plano de fundo mantendo, ao mesmo tempo, a proporção. Isso normalmente resulta no corte da imagem em uma direção.
Alinhamento Horizontal Apenas disponível quando a opção de imagem estiver habilitada. Alinha a imagem à Esquerda, ao Centro ou à Direita.
Alinhamento Vertical Apenas disponível quando a opção de imagem estiver habilitada. Alinha a imagem Acima, ao Centro ou Abaixo.
Transparência da Imagem Apenas disponível quando a opção de imagem estiver habilitada. Define a transparência da imagem de fundo.

Número

A página Propriedades: Número será aberta se você clicar com o botão direito do mouse em um objeto de pasta e escolher o comando Propriedades no menu suspenso.

Cada campo possui um formato numérico padrão que pode ser definido na página Propriedades do Documento: Número. É possível, no entanto, usar um formato numérico separado para um objeto de pasta individual. Para isso, marque a alternativa Sobrepor Configuração do Documento e especifique um formato numérico no controle de grupo a seguir. Essa página de propriedades aplica-se ao objeto ativo e contém os seguintes controles para formatação de valores:

Geral Tanto números quanto texto. Números mostrados no formato original.
Número Mostra valores numéricos com o número de dígitos definido na caixa de rotação Precisão.
Inteiro Mostra valores numéricos como inteiros.
Fixo com Mostra valores numéricos como valores decimais, com o número de dígitos decimais definido na caixa de rotação Decimais.
Moeda Mostra os valores no formato definido na caixa de edição Padrão de Formato. Um exemplo desse formato é mostrado na caixa de texto Visualizar. O formato padrão é a configuração de moeda do Windows.
Data Mostra valores que podem ser interpretados como datas, no formato definido na caixa de edição Padrão de Formato. Um exemplo desse formato é mostrado na caixa de texto Visualizar.
Hora Mostra valores que podem ser interpretados como horas, no formato definido na caixa de edição Padrão de Formato. Um exemplo desse formato é mostrado na caixa de texto Visualizar.
Carimbo de data/hora Mostra valores que podem ser interpretados como data e hora, no formato definido na caixa de edição Padrão de Formato. Um exemplo desse formato é mostrado na caixa de texto Visualizar.
Intervalo Mostra a hora em termos de incremento sequencial (por exemplo, o formato = mm mostra o valor correspondente ao número de minutos desde o início do calendário ( 1899:12:30:24:00).
Mostrar em Porcentagem (%) Essa caixa de verificação afeta os seguintes formatos: Número, Inteiro e Fixo.

Os separadores de Decimal e Milhar podem ser definidos nas caixas de edição do grupo Separadores.

O botão ISO usa o padrão ISO para o formato de data, hora e carimbo de data/hora.

O botão Sistema aplica as configurações do sistema ao formato.

O botão Alterar Formato do Documento abre a página Propriedades do Documento: Número, na qual o formato numérico padrão de qualquer campo pode ser editado.

Fonte

Aqui é possível definir a Fonte, o estilo da Fonte e o Tamanho da fonte que serão usados.

A fonte pode ser definida para qualquer objeto único (Propriedades do Objeto: Fonte) ou todos os objetos de um documento (Aplicar a Objetos em Propriedades do Documento: Fonte).

Adicionalmente, as fontes padrão do documento para os novos objetos podem ser definidas em Propriedades do Documento: Fonte. Existem duas fontes padrão:

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.

Adicionalmente, as fontes padrão dos novos documentos podem ser definidas em Preferências do Usuário: Fonte.

Para gráficos, botões e objetos de texto (exceto objetos de pesquisa), também é possível especificar uma Cor de fonte. A cor pode ser Fixa ou Calculada dinamicamente em uma expressão. A expressão deve ser uma representação de cor válida, criada usando as funções de cor. Se o resultado da expressão não for uma representação de cor válida, a cor da fonte definirá a cor preta como padrão.

Funções de cor

Configurações adicionais:

Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Uma amostra da fonte selecionada é mostrada no painel de visualização.

Layout

Uma configuração de Layout será aplicada apenas ao objeto atual se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos dos tipos especificados no documento se for definida na página Propriedades do Documento.

Usar Bordas

Ative essa configuração para usar uma borda em torno do objeto de pasta. Especifique o tipo de borda, selecionando-o no menu suspenso.

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.

Quando você seleciona Simplificado como o Modo de Estilo em Propriedades de Documento: Geral, não há nenhuma opção de tipo de borda, existe somente o menu suspenso Intensidade de Sombra e a configuração Largura da Borda.

Cantos Arredondados

No grupo Cantos Arredondados, a forma geral do objeto de pasta é definida. Essa configuração permite variações na forma de desenho dos objetos da pasta, desde formas perfeitamente circulares/elípticas, passando para superelípticas até chegar a formas retangulares. A opção Cantos Arredondados ficará disponível somente se o Modo de Estilo Avançado estiver selecionado em Propriedades de Documento: Geral.

Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).

Camada

No grupo Camada, é possível definir um objeto como residente em uma das três camadas:

Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.

Editor de Tema...

Abre o assistente do Editor de Tema, onde é possível criar um novo tema de layout.

Aplicar Tema...

É possível aplicar um tema de layout ao objeto, pasta ou documento.

Temas de Layout

Mostrar

No grupo Mostrar, é possível especificar uma condição sob a qual o objeto de pasta será exibido:

Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Opções

No grupo Opções, é possível impedir a movimentação e o redimensionamento do objeto de pasta. As configurações desse grupo só serão relevantes se as caixas de seleção correspondentes forem marcadas em Propriedades do Documento: Layout e Propriedades da Pasta: Segurança.

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.

Barras de Rolagem

Vários controles para alterar o layout da barra de rolagem estão localizados no grupo Barras de Rolagem:

Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

A configuração do Título será aplicada apenas ao objeto atual, se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos do(s) tipo(s) especificado(s) no documento se for definida na página Propriedades do Documento.

Na página Título, especifique opções de layout completamente diferentes do layout geral do objeto.

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.

Defina as cores do título em seus diversos estados. As configurações das Cores Ativas e das Cores Inativas podem ser especificadas separadamente uma da outra.

Clique no botão Cor de Fundo ou Cor de Texto para abrir a caixa de diálogo Área de Cores. A Cor de Fundo pode ser definida como uma cor sólida ou gradiente na caixa de diálogo Área de Cores. A Cor do Texto pode ser definida como uma cor Fixa ou Calculada usando as funções de cor.

Funções de cor

Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.

O tamanho e a posição precisos do objeto do QlikView podem ser determinados e ajustados pelas configurações de tamanho/posição do objeto de pasta Normal ou Minimizado. Essas configurações são medidas em pixels:

X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.

A orientação de rótulo do título pode ser alterada com as opções de Alinhamento de Título:

Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.

Ícones especiais
Muitos dos comandos do menu de objeto dos objetos de pasta podem ser configurados como ícones de título. Selecione os comandos a serem mostrados como ícones de título, marcando a caixa de verificação à esquerda de cada comando na lista.

Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.

Propriedades de Título e Borda

No diálogo Propriedades de Título e Borda, você define a quais objetos no documento devem ser aplicadas as propriedades de título e borda.

Aplicar propriedades a... Marque esta caixa de seleção para aplicar as configurações a outros objetos além do atual.
1. Escolha uma das opções:
Objetos nesta pasta
Aplica as configurações somente aos objetos da pasta atual. Disponível apenas quando essa caixa de diálogo for aberta a partir da página Layout de um objeto da pasta.
Objetos neste documento
Aplica as configurações aos objetos do documento inteiro.
2. Escolha uma das opções:
Somente este tipo de objeto
Aplica as configurações a todos os objetos deste tipo. Disponível apenas quando essa caixa de diálogo for aberta a partir da página Layout de um objeto da pasta.
Todos os tipos de objeto
Aplica as configurações a todos os objetos.
Configurar como padrão para novos objetos neste documento Marque essa caixa de seleção para usar as configurações como padrão para todos os novos objetos no documento atual. Disponível apenas quando essa caixa de diálogo for aberta a partir da página Layout de um objeto da pasta.

Exibição em Árvore da Lista

Se um campo contiver caminhos de nós em uma hierarquia, como Mundo/América do Norte/EUA/Califórnia/NapaValley, é possível exibir a lista em uma exibição em árvore. A exibição em árvore mostrará os nós com recuo para facilitar a navegação e permitir que o usuário recolha os nós, de forma que uma linha da caixa de lista represente um braço da hierarquia, e não um nó individual.

As seleções serão feitas da maneira usual, e seleções múltiplas por diferentes níveis da hierarquia serão suportadas, claro.

Para nós expandidos e folhas (nós inferiores), será utilizada a codificação por cores padrão do QlikView. Os nós recolhidos, no entanto, podem conter uma mistura de estados diferentes. Nesse caso, o nó só será exibido em verde se todos os valores tiverem sido selecionados, em cinza se todos os valores tiverem sido excluídos e em branco nos outros casos. Além disso, será exibido um pequeno indicador, mostrando o status dos nós ocultos.

Como Criar Caixas de Lista e Caixas de Tabela com Direct Discovery

Listas

Listas podem ser criadas com campos DIMENSION e MEASURE. Ao usar um campo MEASURE em uma expressão de Lista, a função aggr() deve ser usada para mostrar o valor agregado do campo MEASURE com um campo DIMENSION. As seleções feitas com os campos DIMENSION em uma Lista geram consultas SQL na origem de dados para criar a tabela associativa na memória.

Os campos DETAIL não estão disponíveis em Listas.

Nota:

Como as Listas exibem apenas os valores exclusivos de um campo DIMENSION, a consulta que o QlikView gera para exibir os dados da Lista usa a palavra-chave DISTINCT para recuperar dados do banco de dados. No entanto, alguns bancos de dados requerem que a consulta inclua uma classe GROUP BY, em vez da palavra-chave DISTINCT. Se a tabela Direct Discovery vier de um banco de dados que requeira GROUP BY, use a variável DirectDistinctSupport para alterar o comportamento padrão das consultas DIMENSION.

DirectDistinctSupport

Tabelas

Tabelas podem exibir todos os tipos de campo Direct Discovery e fornecem uma forma para buscar os detalhes de registros que contenham campos Direct Discovery. Tabelas são os únicos objetos do QlikView em que os campos designados como DETAIL na instrução de LOAD Direct Query podem ser usadas.

Quando os campos de Direct Discovery são usados em uma Tabela, um limite é definido para restringir o número de linhas exibidas. O limite padrão é de 1.000 registros. A configuração de limite padrão pode ser alterada definindo a variável DirectTableBoxListThreshold variável no script de carregamento. Por exemplo:

SET DirectTableBoxListThreshold=5000

A configuração de limite aplica-se apenas a Tabelas que contenham campos de Direct Discovery. Caixas de tabela que contêm apenas campos em memória não são limitados pela configuração DirectTableBoxListThreshold .

Nenhum campo é exibido na Tabela até que a seleção tenha menos registros que o limite.

Os campos de Direct Discovery podem ser misturados com os campos na memória em uma Tabela. Tabelas que contêm apenas campos de Direct Discovery devem incluir um campo DIMENSION.

Tabelas com dados de Direct Discovery mostram todas as linhas selecionadas, mesmo que contenham dados idênticos. Por outro lado, tabelas com dados na memória mostram apenas uma das linhas selecionadas quando contêm dados idênticos.