Menu Arquivo

O menu Arquivo é um menu suspenso localizado na parte superior da tela que contém os seguintes comandos:

Novo Abre uma nova janela do QlikView e permite criar um novo arquivo QlikView.
Abrir... Abre uma nova janela do QlikView e permite abrir um arquivo QlikView ou um arquivo de Tabela. Abrir um arquivo de tabela abre automaticamente o Assistente de Arquivo. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+O.
Abrir no Servidor... Abre uma caixa de diálogo, onde é possível conectar-se a um QlikView Server e procurar um documento para abrir em modo cliente.
Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Shift+O.
Nota: Ao abrir documentos como cliente no QlikView Server, as possibilidades ficam restritas em comparação às ações permitidas quando você abre documentos locais. Como um cliente, não é possível incluir ou excluir objetos de pasta, dependendo da possibilidade de o documento oferecer ou não suporte à colaboração. Pastas não podem ser adicionadas ou excluídas. Além disso, não será possível acessar as caixas de diálogo de propriedades, alterar as macros, acessar o script, recarregar os dados ou salvar o documento.
Atualizar Documento Este comando só fica disponível com documentos abertos no QlikView Server e quando há uma versão mais nova do documento disponível no servidor. Quando faz uma atualização, você obtém acesso aos últimos dados gravados enquanto mantém a sessão, incluindo seleções e layout.
Abrir URL... Abre a caixa de diálogo Abrir URL. Nesse diálogo, digite um URL válido para qualquer página da Web. A página da Web será aberta em uma janela separada dentro do QlikView. Essa funcionalidade pode ser usada, por exemplo, com o QlikView Publisher Accesspoint ou com páginas que exibem documentos do QlikView Server via clientes AJAX. As páginas da Web abertas podem ser acessadas por meio do menu Janelas exatamente como as janelas de documento QlikView padrão.
Abrir FTP... Abre uma nova janela do QlikView, permite abrir um arquivo QlikView ou um arquivo de tabela a partir de um servidor FTP. Abrir um arquivo de tabela abre automaticamente o Assistente de Arquivo.
Fechar Fecha o arquivo QlikView ativo.
Favoritos Esse menu em cascata controla uma lista de documentos favoritos definidos pelo usuário, gerenciados independentemente da lista de Documentos recentes (veja a seguir).
Salvar

Salva a configuração atual em um arquivo QlikView. Os dados, o script e o layout são salvos. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+S.

Se você desejar compartilhar um documento QlikView usando clientes AJAX, o nome do arquivo não deve conter caracteres hash (#).

Salvar Como...

Salva a configuração atual com um novo nome em um novo arquivo QlikView. Esse comando também pode ser chamado pelo seguinte atalho de teclado: F12.

Se você desejar compartilhar um documento QlikView usando clientes AJAX, o nome do arquivo não deve conter caracteres hash (#).

Salvar Link... Salva um link para um documento aberto no QlikView Server, como um arquivo de texto na máquina local. O arquivo terá a extensão .qvw, mas não conterá dados nem layout. Ao abrir esse documento do link, o QlikView tentará reconectar-se ao servidor e abrir o documento no QlikView Server. Esse comando não está disponível para documentos locais.
Encaminhar como Anexo... Disponível somente quando um documento local está sendo trabalhado. Cria uma correspondência com uma cópia do documento qvw atual anexada. O destinatário da correspondência poderá abrir o documento qvw desde que tenha acesso ao QlikView e tenha direitos de acesso ao documento (se a segurança da seção de acesso for usada). Para que esse comando funcione, um cliente de e-mail deve ser configurado no computador.
Encaminhar com Marcador como um Link... Disponível somente quando um documento do QlikView Server está sendo trabalhado. Cria uma correspondência com um link de URL para o documento atual do servidor. Um marcador de servidor temporário (incluindo a situação do layout) será criado e codificado na URL. O destinatário da correspondência poderá usar o link de URL para abrir o documento do servidor e ver o mesmo que você, desde que, naturalmente, tenha direitos de acesso ao documento e aos dados. Um cliente de e-mail deve ser configurado no computador para que esse comando funcione. O QlikView Server deve ser configurado para permitir marcadores de servidor
Imprimir... Abre a caixa de diálogo Imprimir padrão, que permite imprimir o objeto de pasta atual. Esse comando não está disponível para listas. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+P.
Imprimir como PDF... Abre a caixa de diálogo Imprimir com a impressora PDF-XChange 3.0 pré-selecionada. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Shift+P.
Imprimir Possíveis... Abre a caixa de diálogo Imprimir padrão, que permite imprimir os valores possíveis (selecionados e opcionais) da lista atual. Esse comando está disponível apenas para listas.
Imprimir Possíveis como PDF... Este comando deve ser usado ao imprimir listas e seleções múltiplas como PDF.
Imprimir Pasta... Abre a caixa de diálogo Imprimir, que permite imprimir uma imagem da pasta atual.
Visualizar Impressão... Mostra a visualização dos objetos de pasta imprimíveis.
Controle de Origem Configurações
Defina qual dll do provedor MSSCCI (Microsoft Source Code Control Interface) deve ser usada ao adicionar um projeto ou obter um projeto do controle de origem.

Adicionar projeto ao controle de fonte
Salva o documento QlikView aberto e cria automaticamente uma pasta e arquivos de projeto. Invoca o sistema de controle de origem para adicionar o projeto ao controle de origem.

Obter projeto no controle de origem
Recupera um projeto do controle de origem e recria o documento QlikView a partir dos arquivos de projeto. Os dados do QlikView não são armazenados no controle de origem. Para preencher o documento com os dados, o comando Recarregar deve ser executado durante a recriação do documento.

Obter última versão
Recupera a última versão do documento do sistema de controle de origem e recria o documento QlikView.

Check-in de alterações pendentes
Salva o documento QlikView e executa uma operação de check-in para o sistema de controle de origem. Isso pode incluir quatro operações diferentes de controle de origem com suas próprias caixas de diálogo:
  • Adicione arquivos recém-criados.
  • Desfaça os arquivos verificados que precisam ser excluídos do controle de origem.
  • Remova os arquivos que correspondem às pastas ou aos objetos de pasta removidos que fazem parte do controle de origem.
  • Verifique os arquivos modificados.

Se o documento não tiver sido atualizado antes da operação Check-in de Alterações Pendentes, abra novamente o documento para carregar as alterações do projeto que poderiam ser introduzidas durante a resolução de conflitos.

 

Desfazer alterações pendentes
Desfaz as alterações. Se existirem arquivos modificados localmente dos quais não tenha sido feito check-out no sistema de controle de origem, será feito o check-out desses arquivos antes da execução da operação de desfazer check-out. Essa operação recriará o documento QlikView excluindo os arquivos que foram adicionados e dos quais não foi feito check-in e restaurando as referências a arquivos com exclusão pendente.
Exportar Exportar Conteúdo...
Esta alternativa está disponível apenas quando um objeto de pasta exportável está ativo. Assim, executa a operação de exportação contida no menu Objeto.

Exportar Imagem de Pasta...
Abre uma caixa de diálogo para salvar uma imagem da pasta atual em um arquivo.

Exportar layout do documento
Abre um diálogo para salvar o layout do documento como um arquivo XML. Nenhum dado do documento é salvo no arquivo XML.

Exportar Layout de Pasta...
Abre um diálogo para salvar o layout da pasta atual como um arquivo XML. Nenhum dado do documento é salvo no arquivo XML.
Importar Importar layout do documento
Abre um diálogo para importar o layout do documento de outro documento salvo como XML. Nenhum dado é importado.

Importar layout da pasta
Abre um diálogo para importar o layout de outra pasta salva como XML. Nenhum dado é importado.
Editar Script... Abre a caixa de diálogo Editar Script. Nessa caixa de diálogo, é possível escrever e executar scripts que abrem e estabelecem conexão com as bases de dados.
Executar Script Executa o script carregado atualmente e recarrega os dados no documento QlikView ativo. Isso precisará ser feito se o conteúdo da base de dados tiver sido alterado desde a última vez em que foi realizada uma recarga. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+R.
Recarga Parcial Executa o script carregado atualmente, incluindo todos os comandos de script, como Drop table, e recarrega os dados no documento QlikView ativo. No entanto, serão recarregadas somente aquelas tabelas em que os comandos load e select forem precedidos pelo prefixo Replace ou Add. As tabelas de dados que não são afetadas por esse tipo de comando load ou select não serão afetadas pela recarga parcial. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Shift+R.
Reduzir Dados Abre um menu contendo estes dois comandos:

Manter Valores Possíveis
Reduz a base de dados do QlikView, removendo todos os valores excluídos.

Excluir Todos os Valores
Cria um modelo removendo todos os valores da base de dados do QlikView, mas mantendo a estrutura e o layout da base de dados.
Visualizador de Tabelas... Abre a caixa de diálogo Visualizador de Tabelas, que permite estudar a estrutura dos dados carregados em uma visão gráfica de tabelas, campos e associações. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+T.
Lista de documentos recentes Exibe uma listagem dos últimos documentos QlikView usados. O número de documentos mostrados pode ser definido na caixa de diálogo Configurações: Preferências de usuário. O número padrão é 8. Selecionar um desses é equivalente ao comando Abrir.
Exit Fecha os documentos abertos e sai do QlikView.