Botão

Os botões podem ser criados e definidos no QlikView para executarem comandos ou ações. Existem basicamente três tipos de botões: Iniciar/Exportar, o Botão de Atalho e o botão Macro.

Ao clicar com o botão direito do mouse no objeto, a opção Botão: Menu Objeto será exibida. Também será possível acessá-lo no menu Objeto, quando o botão for o objeto ativo.

Menu Objeto

O menu Objeto do botão é aberto quando você clica com o botão direito no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades de Botão, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Enviar para Excel Exporta o texto para o Microsoft Excel, que será acionado automaticamente caso não esteja em execução. O texto será exibido em uma única célula da nova planilha do Excel. Para que esse recurso funcione, o Microsoft Excel 2007 ou versão posterior deve estar instalado no computador.
Copiar para a Área de Transferência Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Text
Copia o texto mostrado no botão para a área de transferência.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou não o título e a borda do objeto de pasta de acordo com as configurações na caixa de diálogo Preferências do Usuário da página Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Geral

No grupo Texto, você pode definir as propriedades do texto a serem exibidas no botão.

Texto

Inserir um texto no campo de texto dá um rótulo ao botão. O texto pode ser definido como uma fórmula calculada. O texto pode consistir em várias linhas, divididas ao pressionar Enter.

Sintaxe da expressão para fórmulas calculadas

Alinhamento O texto do botão pode ser alinhado à esquerda, centralizado ou alinhado à direita.

No grupo Fundo , é possível especificar o fundo do botão. O menu suspenso fornece três estilos básicos de botão diferentes para seleção:

Aqua Padrão para novos botões. Fornece um botão arredondado com aparência vítrea tridimensional.
Plano Produz um botão QlikView tradicional simples.
Padrão do Sistema
Fornece um plano de fundo sólido na cor definida para botões no sistema operacional.
Imagem Produz um botão com imagem. A imagem pode ser uma única imagem estática ou com três partes combinadas, cada uma das quais para os três possíveis estados do botão (ativo, inativo ou pressionado).
Imagem Combinada
Marque esse botão de opção e pesquise um arquivo de imagem usando o botão Selecionar Imagem... para atribuir ao botão uma imagem combinada de três estados. O arquivo de imagem deve conter três imagens do botão lado a lado: a primeira do botão ativo, a segunda do botão pressionado e a terceira de um botão desativado (inativo).
Imagem Única
Marque esse botão de opção e pesquise um arquivo de imagem usando o botão Selecionar Imagem... para atribuir ao botão uma imagem de um só estado. Os tipos de imagens suportados são jpg, png, bmp, gif e gif animado.
Cor Selecione esse botão de opção para que o botão seja mostrado com um fundo colorido (não disponível com a configuração da Imagem). A cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão colorido.
Transparência Define o nível de transparência do fundo do botão. Em 100%, o fundo ficará totalmente transparente. A transparência será aplicada, independentemente do uso de uma cor ou de uma imagem como plano de fundo.
Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto O ID exclusivo do botão atual. A cada objeto de pasta criado é atribuído um ID exclusivo para controle por meio de Automação. O ID consiste em uma combinação de letras que definem o tipo de objeto, além de um número. Ao primeiro botão de um documento será atribuído o ID BU01. Os objetos compartilhados possuem o mesmo ID de objeto. O ID de um objeto pode ser alterado para qualquer outro caractere que não esteja sendo utilizado atualmente como ID por outro objeto de pasta, pasta ou marcador no documento.
Condição para Habilitar A expressão digitada aqui determina o status do botão. Se a expressão retornar 0, o botão será desabilitado; se a expressão retornar 1, o botão será habilitado. Se não for digitada nenhuma expressão, 1 será assumido. Os botões desabilitados devido ao status subjacente não podem ser habilitados por meio de uma condição.
Configuração de Impressão... Pressione esse botão para acessar a caixa de diálogo Configuração de Impressão, que permite definir margens e formato de cabeçalho/rodapé.

Ações

Nesta página, é possível definir ações para determinados objetos:

  • botões
  • objetos de texto
  • mostradores
  • objetos de linha/seta

As ações incluem a inicialização de um aplicativo externo ou a exportação de dados pelo QlikView.

Adicionar Abre o diálogo Adicionar Ação, no qual são escolhidas as ações para o objeto. Selecione o tipo de ação nas listas. Dependendo da ação, serão exibidos diferentes parâmetros para ela na página Ações. As ações serão executadas na ordem em que aparecem na lista.
Excluir Remove a ação do objeto.
Promover Move a ação selecionada para cima na lista de ações.
Estado Alternativo Define o estado ao qual a ação se refere. Essa configuração é relevante apenas para ações relacionadas a seleções ou marcadores.

Caixa de diálogo Adicionar Ação

As seguintes ações podem ser incluídas com o uso da caixa de diálogo Adicionar Ação. Em todos os campos com o botão ..., é possível inserir uma fórmula calculada.

Sintaxe da expressão para fórmulas calculadas

Seleção

Selecionar no Campo Seleciona os valores e campos especificados. Em Caracteres de Busca, você pode especificar uma máscara de pesquisa. Por exemplo, (A|B) selecionará tanto A quanto B.
Selecionar Valores Excluídos Seleciona os valores excluídos no campo especificado.
Selecionar Valores Possíveis Seleciona os possíveis valores no campo especificado.
Alternar Seleção Alterna entre a seleção atual e a especificada Campo e Caracteres de Busca. Em Caracteres de Busca, você pode especificar uma máscara de pesquisa. Por exemplo, (A|B) selecionará tanto A quanto B.
Adiante Avança um passo na lista de seleções.
Voltar Retrocede um passo na lista de seleções.
Selecionar Pareto Faz uma seleção de pareto no campo especificado com base em uma expressão e porcentagem. Esse tipo de seleção é usado para selecionar os principais colaboradores para uma lista, geralmente na linha de uma regra 80/20 geral. Por exemplo, para localizar os principais clientes que contribuem com 80% do movimento das vendas, deve-se utilizar Cliente como campo, sum(Turnover) deve ser usado como a expressão e 80 deve ser usado como a porcentagem.
Bloquear Campo Trava as seleções no campo especificado.
Travar Tudo Trava todos os valores em todos os campos.
Destravar Campo Destrava as seleções no campo especificado.
Destravar Tudo Destrava todos os valores em todos os campos.
Destravar e Limpar Tudo Desbloqueia todos os valores e limpa todas as seleções em todos os campos.
Limpar Outros Campos Limpa todos os campos relacionados, exceto o especificado.
Limpar Tudo Limpa todas as seleções, exceto as bloqueadas.
Limpar Campo Limpa um campo específico.
Copiar Conteúdo de Estado Copia a seleção de Estado de Origem para Estado de Destino. Disponível apenas quando estados alternados forem definidos.
Alternar Conteúdo de Estado Alterna as seleções entre Estado 1 e Estado 2. Disponível apenas quando estados alternados forem definidos.

Layout

Ativar Objeto Ativa o objeto especificado pelo ID do Objeto. Esse recurso não funciona no cliente Ajax.
Ativar Pasta Ativa a pasta especificada pelo ID da Pasta.
Ativar Próxima Pasta Abre a próxima pasta no documento.
Ativar Pasta Anterior Abre a pasta anterior no documento.
Minimizar Objeto Minimiza o objeto especificado pelo ID do Objeto.
Maximizar Objeto Maximiza o objeto especificado pelo ID do Objeto.
Restaurar Objeto Restaura o objeto especificado pelo ID do Objeto.
Definir Nome de Estado Aplica o Estado especificado ao objeto especificado por ID do Objeto. Disponível apenas quando houver estados alternados definidos.

Marcador

Aplicar Marcador

Aplica o marcador especificado pelo ID do Marcador. Se dois marcadores tiverem o mesmo ID, o marcador do documento será aplicado. Para aplicar o marcador de servidor, especifique IDdoservidor/marcador. 

Criar Marcador

Cria um marcador a partir da seleção atual. Especifique o ID do Marcador e o Nome do Marcador. Selecione Oculto para criar um marcador oculto.

Substituir Marcador

Substitui o marcador especificado pelo ID do Marcador com a seleção atual.

Imprimir

Imprimir Objeto

Imprime o objeto especificado pelo ID do Objeto. Especifique o Nome da Impressora se o objeto tiver que ser enviado para outra impressora que não seja a padrão. (Não disponível como disparador de pasta e documento.)

Imprimir Pasta

Imprime a pasta especificada pelo ID da Pasta. (Não disponível como disparador de pasta e documento.) Esse recurso não funciona no cliente AJAX.

Imprimir Relatório

Imprime o relatório especificado pelo ID do Relatório. Especifique o Nome da Impressora se o relatório tiver que ser enviado para outra impressora que não seja a padrão. Marque a caixa de seleção Mostrar Caixa de Diálogo de Impressão se quiser que a caixa de impressão do Windows seja exibida. (Não disponível como disparador de pasta e documento.)

Externo

Exportar

Exporta uma tabela que contém um conjunto específico de campos, mas apenas os registros aplicáveis de acordo com as seleções efetuadas são exportados. Clique no botão Configuração da página Ações para abrir o diálogo Configuração da ação Exportar. (não disponível como disparador de documento e pasta)

Acionar

Aciona um programa externo. As seguintes configurações podem ser definidas no diálogo Ações:
Aplicativo
Clique em Pesquisar... para localizar o aplicativo que deve ser iniciado. (Não disponível como disparador de pasta e documento.)
Nome do Arquivo
Insira o caminho para o arquivo que deve ser aberto com o aplicativo especificado acima. (Não disponível como disparador de pasta e documento.)
Parâmetros
Especifique os parâmetros para a linha de comando na qual o aplicativo é iniciado. (Não disponível como disparador de pasta e documento.)
Diretório de Trabalho
Define o diretório de trabalho para que o aplicativo seja iniciado. (Não disponível como disparador de pasta e documento.)
Sair do aplicativo quando o QlikView é fechado
Força a saída do aplicativo quando o QlikView é fechado. (Não disponível como disparador de pasta e documento.)
Esse recurso não funciona no cliente AJAX.

Abrir URL

Abre a URL no navegador Web padrão. (Não disponível como disparador de pasta e documento.)

Abrir Documento QlikView

Abre o documento especificado. A extensão do arquivo deve ser incluída. (Não disponível como disparador de pasta e documento.)
Marque a caixa de seleção Estado da Transferência para transferir as seleções do documento original para o documento que deseja abrir. Primeiramente, as seleções serão apagadas do documento aberto.
Marque Aplicar estado sobre a seleção atual para manter as seleções do segundo documento e aplicar as seleções do documento original sobre elas.

Nota: Use Aplicar estado sobre a seleção atual com cautela, pois isso pode causar resultados imprevisíveis se as duas seleções de documentos estiverem em conflito. Na maioria dos casos, deve ser suficiente usar a opção Estado da Transferência.

Abrir na mesma Janela abre o novo documento na mesma aba do navegador durante o uso do cliente AJAX ZFC.

Nota: A ação Abrir Documento QlikView não é suportada por usuários que não são do domínio durante o uso do plug-in do Internet Explorer

Executar Macro

Insira o caminho e o nome da macro a ser executada. Digite qualquer nome para o qual é possível criar posteriormente uma macro na caixa de diálogo Editar Módulo, ou uma expressão calculada para atualização dinâmica.

Definir Variável

Atribui um valor à variável especificada.

Mostrar Informações

Mostra as informações associadas, como um arquivo de texto ou uma imagem para o campo especificado por Campo. Esse recurso não funciona no cliente AJAX.

Fechar Este Documento

Fecha o documento QlikView ativo.

Executar Script

Executa uma recarga no documento atual. Esse recurso não funciona no cliente do AJAX e no plug-in para IE.

Atualização Dinâmica

Realiza uma atualização dinâmica dos dados no documento carregado no momento. O comando para a atualização dinâmica deve ser inserido no campo Comando.

O uso desejado da Atualização Dinâmica permite que um administrador do QlikView alimente valores limitados de dados em um documento do QlikView a partir de uma única origem sem recarregar o documento. Assim, a análise pode ser realizada por vários clientes com conexão com o QlikView Server.

Observação: As informações carregadas são armazenadas apenas na RAM de forma que todos os dados adicionados ou atualizados usando a Atualização Dinâmica serão perdidos se o documento for recarregado.

A seguinte gramática descreve os comandos possíveis e seus componentes que podem ser usados com o recurso Atualização Dinâmica:

  • statements ::= statement { “;” statement }
  • statement ::= insert_statement | update_statement | delete_statement | begin_transaction_statement | commit_transaction_statement
  • insert_statement ::= "INSERT" "INTO" ("*" | table_name) field_list "VALUES" value_list {"," value_list} ["KEY" ["AUTO" | (" (" field_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  • update_statement ::= "UPDATE" ("*" | table_name) set_clause {"," | set_clause} "WHERE" condition ["AUTO" "INSERT"]
  • delete_statement ::= "DELETE" "FROM" ("*" | table_name] "WHERE" condition
  • begin_transaction_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans_name]
  • commit_transaction_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans_name]
  • table_name ::= identifier | quoted_name
  • field_list ::= "(" field_name {"," field_name} ")"
  • value_list ::= "("value {"," value} ")"
  • set_clause ::= "SET" field_name "=" any_valid_non_aggregated_qlikview_expression
  • field_name ::= identifier | quoted string
  • value ::= identifier | any_qlikview_number | quoted string
  • condition ::= any_valid_non_aggregated_qlikview_expression
  • identifier ::= any_qlikview_identifier
  • quoted_string ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Nota: Para usar esse recurso, a Atualização Dinâmica deve ser permitida tanto no Documento quanto no Servidor.
Nota: Ações que acionam outras ações, denominadas ações em cascata, podem causar consequências inesperadas e não são suportadas!
Nota:

Há limitações quanto ao comportamento de certos gatilho de macro ao trabalhar com documentos no QlikView Server.

Usando Macros em Documentos QV no QV-Server

Caixa de diálogo Configuração da Ação Exportar

Seleção

Neste grupo, você define os campos que devem ser selecionados para exportação.

Campos Na caixa Campos, há uma lista dos campos disponíveis.
Linhas para Exportação Nessa caixa, estarão os campos selecionados para exportação. Os campos para os quais você permitiu valores múltiplos estarão marcados com um asterisco.
Adicionar > Inclui campos na caixa Linhas para Exportação.
< Remover Remove os campos da caixa Linhas para Exportação.
Promover Move o campo selecionado um passo acima, ou seja, um passo para a esquerda na tabela de exportação.
Rebaixar Move o campo selecionado um passo para baixo, ou seja, um passo para a direita na tabela de exportação.
Valor Múltiplo (*) Marque um campo na caixa Linhas para Exportação e também esse controle para permitir que um campo tenha vários valores na listagem de exportação.

Exportar para

Nesse grupo, escolha se deseja exportar os valores para um arquivo ou para a área de transferência.

Arquivo

Se você exportar para um arquivo, será preciso marcar essa caixa de seleção e inserir o nome do arquivo. Se não for digitado nenhum nome de arquivo, os valores serão exportados para a área de transferência. O nome do arquivo pode ser inserido como uma fórmula calculada.

Sintaxe da expressão para fórmulas calculadas

Pesquisar Abre a caixa de diálogo Exportar Arquivo, que permite pesquisar um arquivo para o qual os valores devem ser exportados.
Área de Transferência Configuração padrão. Se nenhum arquivo for especificado acima, os valores serão exportados para a área de transferência.
Linha por Campo Se esse controle estiver marcado, o arquivo de exportação terá, para cada campo selecionado, todos os valores de campo possíveis em uma linha, separados por tabulações.
Incluir Rótulos Se esse controle estiver marcado, a primeira posição na linha (quando a opção Linha por Campo estiver definida) ou o primeiro registro (quando a opção Registros estiver definida) conterá os nomes de campos.
Registros Se esse controle estiver marcado, o arquivo de exportação terá uma coluna para cada campo selecionado, separadas por tabulações.
Anexar ao Arquivo Existente Se esse controle estiver marcado, a exportação será anexada ao arquivo de exportação, caso o arquivo já exista. Os rótulos não serão exportados quando for feita a anexação a um arquivo existente. Se o arquivo de exportação não existir, esse indicador não terá significado.

Formato Numérico

Alguns outros programas podem ter dificuldades para gerenciar corretamente números com formato numérico. O QlikView oferece três opções de formato numérico para os dados numéricos a serem exportados para arquivos ou para a área de transferência.

Novos botões de exportação herdarão a configuração padrão da página Preferências do Usuário: Exportar. No entanto, a configuração pode ser definida individualmente para cada botão de exportação.

Formato Completo Instrui o QlikView a exportar dados numéricos com seu formato numérico completo, exatamente como são mostrados nos objetos de pasta do documento.
Sem Separador de Milhar Retira dos dados numéricos qualquer separador de milhar.
Sem Formato Retira todo o formato numérico dos dados e exporta os números brutos. O separador decimal será aquele definido nas configurações do sistema (Painel de Controle).
Nota:

Há limitações quanto ao comportamento de certos gatilho de macro ao trabalhar com documentos no QlikView Server.

Usando Macros em Documentos QV no QV-Server

Fonte

Aqui é possível definir a Fonte, o estilo da Fonte e o Tamanho da fonte que serão usados.

A fonte pode ser definida para qualquer objeto único (Propriedades do Objeto: Fonte) ou todos os objetos de um documento (Aplicar a Objetos em Propriedades do Documento: Fonte).

Adicionalmente, as fontes padrão do documento para os novos objetos podem ser definidas em Propriedades do Documento: Fonte. Existem duas fontes padrão:

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.

Adicionalmente, as fontes padrão dos novos documentos podem ser definidas em Preferências do Usuário: Fonte.

Para gráficos, botões e objetos de texto (exceto objetos de pesquisa), também é possível especificar uma Cor de fonte. A cor pode ser Fixa ou Calculada dinamicamente em uma expressão. A expressão deve ser uma representação de cor válida, criada usando as funções de cor. Se o resultado da expressão não for uma representação de cor válida, a cor da fonte definirá a cor preta como padrão.

Funções de cor

Configurações adicionais:

Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Uma amostra da fonte selecionada é mostrada no painel de visualização.

Layout

Uma configuração de Layout será aplicada apenas ao objeto atual se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos dos tipos especificados no documento se for definida na página Propriedades do Documento.

Usar Bordas

Ative essa configuração para usar uma borda em torno do objeto de pasta. Especifique o tipo de borda, selecionando-o no menu suspenso.

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.

Quando você seleciona Simplificado como o Modo de Estilo em Propriedades de Documento: Geral, não há nenhuma opção de tipo de borda, existe somente o menu suspenso Intensidade de Sombra e a configuração Largura da Borda.

Cantos Arredondados

No grupo Cantos Arredondados, a forma geral do objeto de pasta é definida. Essa configuração permite variações na forma de desenho dos objetos da pasta, desde formas perfeitamente circulares/elípticas, passando para superelípticas até chegar a formas retangulares. A opção Cantos Arredondados ficará disponível somente se o Modo de Estilo Avançado estiver selecionado em Propriedades de Documento: Geral.

Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).

Camada

No grupo Camada, é possível definir um objeto como residente em uma das três camadas:

Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.

Editor de Tema...

Abre o assistente do Editor de Tema, onde é possível criar um novo tema de layout.

Aplicar Tema...

É possível aplicar um tema de layout ao objeto, pasta ou documento.

Temas de Layout

Mostrar

No grupo Mostrar, é possível especificar uma condição sob a qual o objeto de pasta será exibido:

Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Opções

No grupo Opções, é possível impedir a movimentação e o redimensionamento do objeto de pasta. As configurações desse grupo só serão relevantes se as caixas de seleção correspondentes forem marcadas em Propriedades do Documento: Layout e Propriedades da Pasta: Segurança.

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.

Barras de Rolagem

Vários controles para alterar o layout da barra de rolagem estão localizados no grupo Barras de Rolagem:

Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

A configuração do Título será aplicada apenas ao objeto atual, se for definida na página Propriedades do Objeto.
Essa configuração será aplicada a todos os objetos do(s) tipo(s) especificado(s) no documento se for definida na página Propriedades do Documento.

Na página Título, especifique opções de layout completamente diferentes do layout geral do objeto.

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.

Defina as cores do título em seus diversos estados. As configurações das Cores Ativas e das Cores Inativas podem ser especificadas separadamente uma da outra.

Clique no botão Cor de Fundo ou Cor de Texto para abrir a caixa de diálogo Área de Cores. A Cor de Fundo pode ser definida como uma cor sólida ou gradiente na caixa de diálogo Área de Cores. A Cor do Texto pode ser definida como uma cor Fixa ou Calculada usando as funções de cor.

Funções de cor

Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.

O tamanho e a posição precisos do objeto do QlikView podem ser determinados e ajustados pelas configurações de tamanho/posição do objeto de pasta Normal ou Minimizado. Essas configurações são medidas em pixels:

X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.

A orientação de rótulo do título pode ser alterada com as opções de Alinhamento de Título:

Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.

Ícones especiais
Muitos dos comandos do menu de objeto dos objetos de pasta podem ser configurados como ícones de título. Selecione os comandos a serem mostrados como ícones de título, marcando a caixa de verificação à esquerda de cada comando na lista.

Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.