Objeto de texto

Objetos de texto são utilizados para incluir informações no documento, como rótulos, etc. Eles podem ser movidos e posicionados em qualquer parte da área da pasta, até mesmo nas áreas cobertas por outros objetos da pasta.

Ao clicar com o botão direito do mouse em um objeto de texto, a opção Objeto de Texto: Menu Objeto será exibida. Também será possível acessá-lo pelo menu Objeto quando o objeto de texto for o objeto ativo.

Menu Objeto

O menu Objeto do objeto de texto é aberto quando você clica com o botão direito do mouse no objeto. Os comandos do menu são:

Propriedades... Abre a caixa de diálogo Propriedades do Objeto de Texto, onde é possível definir diversos parâmetros.
Notas

Permite criar e compartilhar notas sobre o objeto atual.

Notas e Comentários

Ordenar

Esse menu em cascata só ficará disponível quando o comando Grade de Desenho do menu Exibir estiver ativado ou quando a caixa de seleção Sempre Mostrar os itens do Menu Desenho em Preferências do Usuário: Design estiver marcada. Ele contém quatro comandos para definir a camada de layout dos objetos de pasta. Números de camada válidos vão de -128 a 127.

Trazer para Frente
Define a camada de layout do objeto de pasta como o maior valor usado no momento pelos objetos de pasta na pasta atual.

Enviar para Trás
Define a camada de layout do objeto de pasta como o menor valor usado no momento pelos objetos de pasta na pasta atual.

Trazer Adiante
Aumenta um no valor da camada de layout do objeto de pasta. O valor máximo é 127.

Enviar para Trás
Diminui uma unidade do valor da camada de layout do objeto da pasta. O valor mínimo é -128.


Imprimir... Abre o diálogo Imprimir que permite especificar a configuração de impressão.
Imprimir como PDF...

Abre a caixa de diálogo Imprimir com a impressora PDF-XChange 3.0 pré-selecionada. Depois de pressionar o botão Imprimir, você deverá digitar um nome para o arquivo PDF a ser gerado. Esse comando só estará disponível se houver uma impressora PDF no sistema.

Enviar para Excel... Exporta o texto para o Microsoft Excel, que será acionado automaticamente caso não esteja em execução. O texto será exibido em uma única célula da nova planilha do Excel. Para que esse recurso funcione, o Microsoft Excel 2007 ou versão posterior deve estar instalado no computador.
Copiar para a Área de Transferência Este menu em cascata contém as diversas opções de cópia para o objeto de pasta.
Text
Copia o texto mostrado no objeto de texto para a área de transferência.
Imagem
Copia uma imagem do objeto de pasta para a área de transferência. A imagem incluirá ou excluirá o título e a borda do objeto de pasta, de acordo com as configurações na página Preferências do Usuário: Exportar.
Objeto
Copia todo o objeto da pasta para a área de transferência, para colá-lo em outro local do layout ou em outro documento aberto dentro da instância atual do QlikView.
Objetos Vinculados

Abre um menu com os seguintes comandos para objetos vinculados.
Ajustar Posição dos Objetos Vinculados
Todos os objetos vinculados de todas as pastas são ajustados para a mesma posição e o mesmo tamanho dos objetos realçados.
Desvincular este Objeto/Desvincular Objetos
Elimina o link entre os objetos, tornando-os diferentes com IDs de objeto diferentes.

Minimizar Transforma o objeto em ícone. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a minimização estiver permitida no diálogo Propriedades do objeto, na página Título.
Maximizar Maximiza o objeto para preencher a pasta. Clicar no ícone no título do objeto (se mostrado) produzirá o mesmo resultado. Esse comando só estará disponível se a maximização estiver permitida no diálogo Propriedades do objeto, na página Título.
Restaurar Restaura um objeto minimizado ou maximizado a seu tamanho e localização anteriores. Clicar duas vezes no ícone de um objeto minimizado ou clicar no ícone da legenda do objeto (se exibida) de um objeto maximizado produz o mesmo resultado. Esse comando só está disponível para objetos minimizados ou maximizados.
Ajuda Abre a ajuda do QlikView.
Remover Remove o objeto da pasta.

Geral

A página Propriedades do Objeto de Texto: Geral será aberta se você clicar com o botão direito do mouse em um objeto de texto e escolher o comando Propriedades no menu suspenso ou selecionar Propriedades no menu Objeto quando um objeto de texto estiver ativo. É possível fazer as configurações de texto, seu fundo, alinhamento, etc.

Primeiro Plano

Aqui é possível especificar o primeiro plano do objeto de texto. O primeiro plano geralmente é o próprio texto, mas pode também ser uma imagem.

Text
Aqui, você pode inserir o texto a ser exibido. O texto pode ser definido como uma fórmula calculada para atualização dinâmica.

Sintaxe da expressão para fórmulas calculadas

Representação
O texto no objeto de texto pode ser interpretado como uma referência a uma imagem na memória ou no disco. Ao selecionar Texto, o conteúdo do objeto de texto será sempre interpretado e exibido como texto. Ao selecionar Imagem, o QlikView tentará interpretar o conteúdo de texto como uma referência a uma imagem. A referência pode ser um caminho para um arquivo de imagem em disco (por exemplo, C:\Minha_Imagem.jpg) ou dentro do próprio documento .qvw (por exemplo, qmem:// <Name>/<Peter>). Pode ser também uma função de informação vinculada a um campo que contém informações de imagem (por exemplo, =info(Meu_campo)). Se o QlikView não puder interpretar o conteúdo de texto como uma referência válida a uma imagem, o próprio texto será exibido.
Ocultar Texto Quando Faltar Imagem
Se essa opção for selecionada, o QlikView não exibirá nenhum texto no objeto de texto caso haja falha, por qualquer razão, na sua interpretação como referência a uma imagem. O objeto de texto será deixado em branco.
Barra de Rolagem Horizontal
Se essa caixa de seleção for marcada, uma barra de rolagem horizontal será incluída no objeto de texto quando seu conteúdo for grande demais, em termos de largura, para ser exibido na área estabelecida.
Barra de Rolagem Vertical
Se essa caixa de seleção for marcada, uma barra de rolagem vertical será incluída no objeto de texto quando seu conteúdo for grande demais, em termos de comprimento, para ser exibido na área estabelecida.

Layout Nesse grupo, defina como o QlikView deve mostrar o texto ou a imagem de primeiro plano na área do objeto de texto.
Alinhamento Horizontal
No sentido horizontal, o texto pode ser alinhado à esquerda, centralizado ou alinhado à direita no objeto de texto.
Alinhamento Vertical
No sentido vertical, o texto pode ser alinhado acima, centralizado ou alinhado abaixo no objeto de texto.
Esticar Imagem
Essa configuração descreve como o QlikView formata a imagem de primeiro plano para ajustar-se à área do objeto de texto. Há quatro alternativas.

Sem Esticar
Se essa opção estiver selecionada, a imagem será mostrada como a original, sem ser esticada. Isso pode fazer com que partes da imagem fiquem invisíveis ou com que apenas parte do objeto de texto seja preenchida.
Preencher
Se essa opção estiver selecionada, a imagem será esticada de forma a ajustar-se à área do objeto de texto, sem a preocupação de manter suas proporções originais.
Manter Proporção
Se essa opção estiver selecionada, a imagem será esticada o máximo possível a fim de preencher a área do objeto de texto, ao mesmo tempo mantendo suas proporções originais. Isso normalmente resulta em áreas, em ambos os lados ou abaixo e acima, que não são preenchidas pela imagem.
Preencher com Proporção
Se essa opção for selecionada, a imagem será esticada em ambas as direções, de forma a preencher a área do objeto de texto, ao mesmo tempo mantendo suas proporções originais. Isso normalmente resulta no corte da imagem em uma direção.

Margem do Texto
Com essa configuração, você pode criar uma margem entre as bordas externas do objeto de texto e o texto em si. A largura da margem pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Plano de Fundo No grupo Plano de Fundo é possível especificar o plano de fundo do objeto de texto. A configuração atual está refletida no painel de visualização à direita.
Cor
Selecione esse botão de opção para que o texto seja exibido sobre um plano de fundo colorido. A cor pode ser definida como uma cor sólida ou gradiente, através da caixa de diálogo Área de Cores, que é aberta ao clicar no botão.
Imagem
Selecione esse botão de opção para exibir uma imagem como plano de fundo. Para alterar a imagem atual, clique no botão Alterar. Se nenhum texto for digitado no campo Texto, o objeto de texto poderá ser usado para exibir uma imagem fixa como um objeto de pasta no layout. Os tipos de imagens suportados são jpg, png, bmp, gif e gif animado.
Transparência
Define o nível de transparência do fundo do objeto de texto. Em 100%, o fundo ficará totalmente transparente. A transparência será aplicada, independentemente do uso de uma cor ou de uma imagem como plano de fundo.
Esticar Imagem
Essa configuração descreve como o QlikView formata a imagem de fundo para ajustar-se à área do objeto de texto. Para obter detalhes sobre as diferentes opções, consulte a seção Esticar Imagem acima.
Alinhamento
O plano de fundo pode ser alinhado na horizontal ou na vertical.
Estado Alternativo Escolha um dos estados disponíveis na lista. Os Estados Alternados a seguir estão sempre disponíveis.
Herdado
As pastas e os objetos de pasta estão sempre no estado herdado, a não ser que sejam substituídos pelo desenvolvedor do QlikView. Essa configuração é herdada do objeto no nível acima. Um gráfico em uma pasta receberá as mesmas configurações da pasta se a opção herdada for selecionada.
Estado padrão
Esse é o estado em que ocorre a maior parte da utilização do QlikView. Ele é representado por $. O documento QlikView está sempre no estado padrão.
ID do Objeto

É utilizado para fins de macro. A cada objeto da pasta é atribuído um ID exclusivo. Recomendamos o uso de caracteres alfanuméricos apenas na ID. Para objetos de texto, a ID começa como TX01. Os objetos vinculados têm o mesmo ID de objeto. Você pode editar posteriormente esse número de ID.

Interpretador Interno de Macro

Configuração de Impressão...  Pressione esse botão para acessar a caixa de diálogo Configuração de Impressão, que permite definir margens e formato de cabeçalho/rodapé.

Ações

Na guia Ações, é possível especificar quais ações deverão ser executadas ao clicar no objeto. A página é idêntica à página Ações do objeto Botão.

See also:

 
  • Fonteo estilo da FonteTamanho
  • Propriedades do Objeto: FonteAplicar a ObjetosPropriedades do Documento: Fonte
  • Propriedades do Documento: Fonte
  • Preferências do Usuário: Fonte
  • CorFixaCalculada
  • Funções de cor

  • Usar Bordas
  • SimplificadoModo de EstiloPropriedades de Documento: GeralIntensidade de SombraLargura da Borda
  • Cantos Arredondados
  • Cantos ArredondadosCantos ArredondadosModo de EstiloAvançadoPropriedades de Documento: Geral
  • Camada
  • Camada
  • Editor de Tema...
  • Editor de Tema
  • Aplicar Tema...
  • Temas de Layout
  • Mostrar
  • Mostrar
  • Opções
  • OpçõesPropriedades do Documento: LayoutPropriedades da Pasta: Segurança
  • Barras de Rolagem
  • Barras de Rolagem
  • Propriedades do Objeto
    Propriedades do Documento
  • Título
  • Cores AtivasCores Inativas
  • Cor de FundoCor de TextoÁrea de CoresCor de FundosólidagradienteÁrea de CoresCor do TextoFixaCalculada
  • Funções de cor
  • NormalMinimizado
  • Alinhamento de Título
  • Ícones especiais

Fonte

  1. A primeira fonte padrão (Listas, Gráficos, etc) é usada para a maioria dos objetos, incluindo listas e gráficos.
  2. A segunda fonte padrão (Objetos de Texto e Botões) é usada para botões e caixas de texto, que são objetos que exigem normalmente uma fonte maior.
Sombreado Se esta opção estiver marcada, um sombreado será incluído no texto.
Sublinhado Se esta opção estiver marcada, o texto será sublinhado.

Layout

Intensidade da Sombra O menu suspenso Intensidade da Sombra possibilita a definição da intensidade da sombra que envolve os objetos de pasta. Também há a opção Sem Sombra.
Estilo da Borda Os seguintes tipos de borda predefinidos estão disponíveis:
Sólido
Borda sólida, de uma só cor.
Afundado
Borda que dá a impressão de que o objeto de pasta está afundado em relação ao plano de fundo.
Levantado
Borda que dá a impressão de que o objeto de pasta está elevado em relação ao plano de fundo.
Emoldurado
Borda que dá a impressão de que há uma parede ao redor do objeto de pasta.
Largura da Borda Essa opção está disponível para todos os tipos de borda. A largura pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Cor Clique nesse botão para abrir uma caixa de diálogo na qual é possível escolher, na paleta de cores, uma cor de base adequada para todos os tipos de borda.
Arco-Íris Cria uma borda com as cores do arco-íris para todos os tipos de borda. O arco-íris começará com a cor de base selecionada acima do objeto de pasta.
Cantos Arredondados Esta opção permite as alternativas referentes a formas com cantos arredondados.
Cantos Os cantos para os quais a caixa de seleção ficar desmarcada serão retangulares.
Inclinação É um número variável entre 2 e 100, sendo que 100 define um retângulo com cantos perfeitamente quadrados e 2 corresponde a uma elipse perfeita (um círculo para uma proporção de 1:1). Um valor de inclinação entre 2 e 5 é geralmente ideal para obter cantos arredondados.
Raio do Canto Esta configuração determina o raio dos cantos em distância fixa (Fixo) ou como uma porcentagem do quadrante total (Relativo (%)). Ela permite controlar até que ponto os cantos serão afetados pela forma geral subjacente definida em Inclinação. A distância pode ser especificada em mm, cm, polegadas (", pol.), pixels (px, pxl, pixel), pontos (pt, pts, point) ou docunits (du, docunit).
Inferior Um objeto de pasta com a propriedade de camada Inferior jamais poderá sobrepor objetos de pasta nas camadas Normal e Superior. Ele poderá somente ser posicionado na parte superior de outros objetos da pasta na camada Inferior.
Normal Ao serem criados, os objetos de pasta residem na camada Normal (intermediária). Um objeto de pasta na camada Normal nunca poderá ser sobreposto por objetos de pasta na camada Inferior e nunca poderá sobrepor objetos de pasta na camada Superior.
Superior Um objeto de pasta na camada Superior jamais poderá ser sobreposto por objetos de pasta nas camadas Normal e Inferior. Somente outros objetos da pasta na camada Superior podem ser posicionados na parte superior deste.
Personalizar As camadas Superior, Normal e Inferior correspondem às camadas numeradas internamente, 1, 0 e -1, respectivamente. Na verdade, todos os valores entre -128 e 127 são aceitos. Escolha essa opção para digitar um valor de sua preferência.
Sempre O objeto de pasta será sempre mostrado.
Condicional

O objeto de pasta será mostrado ou ocultado, de acordo com uma expressão condicional que será avaliada continuamente, dependendo, por exemplo, de seleções, etc. O objeto de pasta somente ficará oculto quando a condição retornar FALSE.

Funções condicionais

Nota:

Os usuários com privilégios de Administrador no documento podem substituir todas as condições de exibição selecionando Mostrar Todas as Pastas e Objetos de Pasta em Propriedades de Documento: Segurança. Essa funcionalidade pode ser alternada pressionando-se Ctrl+Shift+S.

Propriedades do Documento: Segurança

Permitir Mover/Ajustar Se a seleção desta opção tiver sido cancelada, será impossível mover ou ajustar o objeto de pasta.
Permitir Copiar/Clonar Se esta opção tiver sido desmarcada, será impossível criar uma cópia do objeto de pasta.
Permitir Informação

Quando a função Info estiver sendo usada, um ícone de informação será mostrado no título da janela sempre que um valor de campo tiver informações associadas. Se não desejar exibir esse ícone no título, desmarque esta opção.

Info

Ajustar tamanho aos dados Geralmente, as bordas em torno de todos os objetos de pasta de tabela no QlikView se ajustarão quando as seleções fizerem com que o tamanho da tabela seja menor do que o tamanho alocado para o objeto de pasta. Se essa caixa de seleção for desmarcada, o ajuste automático de tamanho será desativado, deixando qualquer espaço excedente em branco.
Preservar Posição de Rolagem

Com essa configuração habilitada, o QlikView tentará conservar a posição de rolagem das tabelas e gráficos com uma barra de rolagem quando for feita uma seleção em outro objeto. Essa configuração também deve ser ativada em Preferências de Usuário: Objetos.

A posição de rolagem não será preservada quando o documento for fechado.

Botões de Rolagem Define a cor dos botões de rolagem. Selecione a cor clicando no botão. Observe que os tons de cinza intermediários geralmente apresentam os melhores resultados para barras de rolagem. Qualquer cor pode ser definida como uma cor sólida ou um gradiente na caixa de diálogo Área de Cores, aberta ao clicar no botão apropriado.
Fundo da Barra de Rolagem

Define a cor de fundo da barra de rolagem. Selecione a cor clicando no botão.

Largura da Barra de Rolagem Esse controle afeta a largura e o tamanho relativo dos símbolos da barra de rolagem.
Estilo de Rolagem

Define o estilo da barra de rolagem. Selecione um estilo no controle suspenso. O estilo Clássico de barra de rolagem corresponde às barras de rolagem do QlikView 4/5. O estilo Padrão de barra de rolagem resulta em uma aparência mais moderna. O terceiro estilo é Claro, que é uma barra mais fina e clara.

O Modo de Estilo deve ser definido como Avançado para que o estilo da barra de rolagem seja visível. Essa configuração pode ser encontrada na guia Geral, abrindo o menu suspenso Configurações e selecionando Propriedades do Documento.

Aplicar A... Abre a caixa de diálogo Propriedades de Título e Borda, em que você pode aplicar as propriedades definidas na página Layout.

Título

Mostrar Título Quando esta opção estiver marcada, um título será desenhado na parte superior do objeto de pasta. As listas e outros "objetos da caixa" terão a opção ativada, por padrão, ao contrário de botões, objetos de texto e objetos de linha/seta.
Texto do Título Na caixa de texto, é possível especificar um texto que será mostrado no título do objeto de pasta. Use o botão Fonte… para alterar a fonte do título.
Retorno do Texto Se esta opção estiver marcada, o título será mostrado em duas ou mais linhas.
Altura do Título (Linhas) Nessa caixa de edição, defina o número de linhas do título.
X-pos Define a posição horizontal do lado esquerdo do objeto da pasta em relação à borda esquerda da pasta.
Y-pos Define a posição vertical da parte superior do objeto da pasta em relação à borda superior da pasta.
Largura Define a largura do objeto da pasta do QlikView.
Altura Define a altura do objeto da pasta do QlikView.
Horizontal O rótulo pode ser alinhado horizontalmente: À Esquerda, Centralizado ou À Direita na área de título.
Vertical O rótulo pode ser alinhado verticalmente: Superior, Centralizado ou Inferior na área de título.
Nota: Use os ícones de título especiais com cuidado. Ícones em excesso apenas confundirão o usuário.
Permitir Minimizar Quando esta opção é marcada, um ícone de minimização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja minimizável. Além disso, você poderá minimizar o objeto clicando duas vezes no título.
Minimização Automática Essa opção estará disponível quando Permitir Minimizar for selecionado. Quando Minimização Automática for marcada para vários objetos na mesma pasta, todos, exceto um, serão minimizados automaticamente a qualquer momento. Isso é útil, por exemplo, para alternar a exibição de vários gráficos na mesma área de pasta.
Permitir Maximizar Quando esta opção é marcada, um ícone de maximização é mostrado no título da janela do objeto de pasta, contanto que o objeto seja maximizável. Além disso, você poderá maximizar o objeto clicando duas vezes no título. Se Permitir Minimizar e Permitir Maximizar estiverem marcadas, clicar duas vezes ocasionará a minimização do objeto.
Texto de Ajuda

Aqui você pode inserir um texto de ajuda a ser mostrado em uma janela pop-up. O texto de ajuda pode ser especificado como uma fórmula calculada. Essa opção não está disponível no nível de documento. Clique no botão ... para abrir a caixa de diálogo Editar Expressão, que facilita a edição de fórmulas longas.

Sintaxe da expressão para fórmulas calculadas

Insira, por exemplo, uma descrição do objeto de pasta. Um ícone de ajuda será incluído no título da janela do objeto. O texto será mostrado em uma janela pop-up quando o ponteiro do mouse estiver sobre o ícone.