Assistente para Dados Inline

A caixa de diálogo Assistente para Dados Inline é aberta no menu Inserir, Comando Load, Carga Inline. É usada para criar comandos load inline no script.

A caixa de diálogo tem características semelhantes a uma planilha e, de fato, funciona como uma em muitos aspectos. Note, entretanto, que as fórmulas de cálculo não serão avaliadas nessa planilha como seriam, por exemplo, no Microsoft Excel.

Cada coluna representa um campo a ser carregado no QlikView por meio de uma tabela inline. Cada linha é um registro na tabela. Para selecionar uma célula de dados, clique nela. Em seguida, você pode digitar um valor ou colá-lo a partir da área de transferência. Pressione Enter ou uma tecla de seta para aceitar o valor e ir para outra célula.

A linha (de rótulo) superior é reservada para rótulos de campo. Clique duas vezes em uma célula de rótulo para editá-la. Se nenhum valor for digitado na linha de rótulo, os nomes de campo F1, F2, etc. serão usados.

Menu Editar

O menu Editar contém alguns comandos de edição básicos.

Inserir Coluna Inserirá uma nova coluna em branco se uma ou mais colunas estiverem selecionadas.
Excluir Coluna Exclui a(s) coluna(s) selecionada(s).
Inserir Linha Insere uma nova linha em branco se uma ou mais linhas estiverem selecionadas.
Excluir Linha Exclui as linhas selecionadas.

Menu Ferramentas

O menu Ferramentas contém o comando Dados do Documento que abre o Assistente para Importação de Dados do Documento a partir do qual é possível colar os valores de campo de qualquer campo existente no documento. Na caixa de diálogo, é possível visualizar quantos valores de campo estão presentes em qualquer campo selecionado. Também é possível optar por inserir todos os valores, valores selecionados ou valores excluídos no assistente inline.

Clique em OK para fechar a caixa de diálogo e gerar um comando Carga Inline que reflita o conteúdo de grade da tabela da caixa de diálogo.