Ir para conteúdo principal

Publicando um relatório simples a partir de um documento do QlikView

Este tutorial mostrará como criar e publicar um relatório simples do Qlik NPrinting PowerPoint usando dados do QlikView.

O Qlik NPrinting tem vários recursos. Este tutorial tem como objetivo ajudar os usuários iniciantes a criar seu primeiro relatório. Ele não prevê cada tipo de relatório, elemento de design ou opção de publicação. Ao final deste tutorial, você terá criado, editado e publicado um relatório do PowerPoint que pode ser visualizado pelos seus usuários selecionados.

Outros tutoriais do Qlik NPrinting:

Nota: O Microsoft Office deve ser instalado para editar e criar relatórios em formatos de arquivo do Office.

Neste tutorial:

Acessando um documento do QlikView

Relatórios precisam de dados. Aprenda a baixar e importar um documento de amostra do QlikView.

Conectando o Qlik NPrinting a um documento do QlikView

O Qlik NPrinting precisa se conectar ao seu documento do QlikView. Aprenda a configurar o Qlik NPrinting para que ele possa acessar um documento de amostra ou seus dados existentes do QlikView.

Criando um novo modelo de relatório do Qlik NPrinting

Modelos de relatórios controlam os formatos de layout e de saída de relatórios. Esta seção mostrará como criar um novo.

Editando o modelo de relatório

Relatórios oferecem muitas opções de formatação diferentes. Nesta seção, você adicionará um título, imagens, uma tabela, um gráfico e páginas ao seu relatório.

Publicando no NewsStand e em e-mails

O NewsStand é um console da Web que seus usuários podem acessar para visualizar relatórios. Saiba como publicar seu relatório no NewsStand e por e-mail.

Acessando um documento do QlikView

Documentos do QlikView contêm os dados e as visualizações que o Qlik NPrinting utiliza para gerar relatórios. Existem algumas maneiras diferentes de acessar um documento do QlikView.

  • Você pode baixar um documento do QlikView do site de ajuda do Qlik e salvá-lo em uma pasta no seu computador.
  • Você pode usar seu próprio documento do QlikView e pular para Conectando o Qlik NPrinting a um documento do QlikView. Se estiver usando seu próprio documento para completar este tutorial, escolha um simples. Os tempos de carregamento no Qlik NPrinting são mais longos com documentos do QlikView complexos.

Baixando um documento do QlikView no site de ajuda do Qlik e salvando-o no seu computador

Faça o seguinte:

  1. No site de ajuda do Qlik NPrinting, acesse Arquivos de amostra e baixe o arquivo Examples.zip no seu local preferencial no computador em que o Qlik NPrinting está instalado.
  2. No Windows, descompacte Sales Demo.qvw e salve-o na pasta C:\Program Files\QlikView\Examples\. Você deverá criar a pasta se ela ainda não existir.

    Se você salvar os arquivos em um local diferente, esse local deverá ser substituído por C:\Program Files\QlikView\Examples\ onde quer que ele esteja especificado na ajuda do Qlik NPrinting.

Aviso: Unidades de rede mapeadas, como Z:\NPrintingServer\QlikViewDocuments, não têm suporte pelo Qlik NPrinting. Você deve usar caminhos UNC (Convenção de nomenclatura uniforme), como \\ServerName\NPrintingServer\QlikViewDocuments.

Conectando o Qlik NPrinting a um documento do QlikView

Agora, criaremos um aplicativo do Qlik NPrinting e o conectaremos ao seu documento do QlikView.

Os aplicativos do Qlik NPrinting contêm relatórios, filtros e conexões com aplicativos do Qlik Sense ou documentos do QlikView. Eles permitem o acesso do Qlik NPrinting Designer aos seus dados, para que eles possam ser usados em um relatório.

Faça o seguinte:

  1. Faça login no console da Web do Qlik NPrinting.
  2. No menu principal, clique no menu suspenso Aplicativos e selecione Aplicativos.
  3. Clique no botão Criar aplicativo.
    1. Digite um nome para esse novo aplicativo. Por exemplo: Beginner's Tutorial NP App - QV.
    2. Verifique se a caixa de seleção Habilitado está marcada. Caso contrário, seu aplicativo será ignorado pelo Qlik NPrinting Engine.
    3. Clique em Criar.

      Você agora poderá ver o aplicativo Beginner's Tutorial NP App - QV em Aplicativos.

  4. No menu principal, clique no menu suspenso Aplicativos e selecione Conexões.
    1. Clique no botão Criar conexão.
    2. Na caixa Nome, digite um nome para a conexão: Beginner's Tutorial Connection - QV.
    3. Na lista suspensa Aplicativo, selecione o aplicativo do Qlik NPrinting que você criou anteriormente: Beginner's Tutorial NP App - QV.
    4. Em Origem, selecione QlikView.
    5. Em Tipo, selecione Local.
    6. Em Caminho do documento, digite o local do documento do QlikView ao qual você deseja se conectar.

      Por exemplo: C:\Program Files\QlikView\Examples\Sales Demo.qvw

      Aviso: Unidades de rede mapeadas, como Z:\NPrintingServer\QlikViewDocuments, não têm suporte pelo Qlik NPrinting. Você deve usar caminhos UNC (Convenção de nomenclatura uniforme), como \\ServerName\NPrintingServer\QlikViewDocuments.
    7. Se o documento do QlikView exigir autenticação, verifique se a opção Conexão requer autenticação está marcada.

      Consulte: Section access.

    8. Clique no botão Executar verificação. Isso garante que sua conexão seja válida.

      Se a conexão for válida, você verá uma mensagem "Verificação bem sucedida". Caso contrário, você verá a seguinte mensagem: "Erros detectados. Verifique os detalhes abaixo."

    9. Quando suas configurações de conexão tiverem sido verificadas, clique em Criar. Você retornará automaticamente ao menu Conexões.
    10. Sua nova conexão terá um status de Status do cache - Gerando. Isso significa que o Qlik NPrinting está se conectando ao QlikView e importando metadados. Se você tiver um documento grande do QlikView, esse processo poderá demorar vários minutos.
      Nota:

      Sempre que você adicionar novos objetos ao seu documento do QlikView, precisará recarregar os metadados da conexão.

    11. Quando o status do cache indicar Gerado, você poderá criar um novo modelo de relatório. Se você receber um status de Erro, verifique suas informações de conexão.

Agora, você poderá ver sua nova conexão na tela Conexões.

Se tiver problemas para se conectar ao seu documento do QlikView, consulte:

Criando um novo modelo de relatório do Qlik NPrinting

Modelos de relatórios controlam os formatos de layout e saída de relatórios. Você pode organizar objetos e formatar páginas usando as opções padrão do tipo de relatório escolhido. Por exemplo, um relatório do PowerPoint terá as mesmas opções de formatação e a mesma interface que uma apresentação do PowerPoint.

Faça o seguinte:

  1. No console da Web do Qlik NPrinting, clique em Relatórios no menu principal.
  2. Clique no botão Criar relatório.
  3. Insira um título no campo Título. Por exemplo: Beginner's Tutorial NP PowerPoint.
  4. Na lista suspensa Tipo, selecione PowerPoint.
  5. Na lista suspensa Aplicativo, selecione Beginner's Tutorial NP App - QV.
  6. Nas opções de Modelo, clique em Arquivo vazio.
  7. Verifique se a caixa de seleção Habilitado está marcada. Caso contrário, seu relatório será ignorado pelo Qlik NPrinting Engine.
  8. Clique em Criar.

Você agora poderá ver Beginner's Tutorial NP PowerPoint em Relatórios.

Editando o modelo de relatório

Existem várias maneiras de editar um modelo de relatório. Adicionaremos o seguinte:

  • Títulos: texto simples usado para organizar seu relatório. Eles podem ser alterados usando a formatação padrão do PowerPoint.
  • Tabelas: coletam seus dados do QlikView e os apresentam em formato tabular.
  • Imagens: coletam seus dados do QlikView e os apresentam como um arquivo .png.
  • Gráficos: coletam seus dados de tabelas do QlikView e os apresentam como um gráfico do PowerPoint.

  • Páginas: subdividem seus dados por uma dimensão. Eles podem ser aplicados a tabelas e imagens. Dividiremos Ano e Nome da categoria.

Esta seção não aborda tudo o que você pode fazer no Qlik NPrinting Designer. Se quiser saber mais a respeito de recursos de relatório avançados do PowerPoint, consulte: Relatórios do PowerPoint.

Nota: Sua visualização de relatório pode parecer diferente da imagem mostrada abaixo, dependendo de como você a formatou. Alguns dos objetos podem ter nomes ligeiramente diferentes, dependendo da ordem em que foram selecionados.

Faça o seguinte:

  1. No console da Web do Qlik NPrinting, clique em Relatórios no menu principal.
  2. Na tela Relatórios, clique no seu relatório.
  3. Clique no botão Editar modelo para abrir o editor de modelos do Qlik NPrinting Designer.

  4. O Qlik NPrinting Designer abrirá. Como está criando um relatório do PowerPoint, você verá a interface padrão do PowerPoint. A maioria dos recursos de formatação do PowerPoint pode ser aplicada ao seu relatório usando essa interface.
  5. Insira um título:
    1. No primeiro slide, digite um título: Por exemplo, "Sales Trends by Product Category".
    2. Insira um subtítulo ou exclua a caixa de texto de subtítulo.

      Dica: Você pode usar as opções de formatação do PowerPoint para alterar a aparência desses títulos. Por exemplo, você pode alterar o tamanho e a cor da fonte.
  6. Adicionar imagens:
    1. Na barra de ferramentas do PowerPoint, clique na guia Inserir.
    2. Clique no botão Novo slide.
    3. Digite um título: por exemplo, "Top Selling Products". Exclua a segunda caixa de texto vazia.
    4. No painel esquerdo, clique com o botão direito do mouse em Imagens e selecione Adicionar objetos.

    5. Uma nova janela será aberta. Selecione Products e Sales by Category for 2014 vs 2013 e clique em OK.

      Você pode selecionar várias opções, mantendo o botão CTRL pressionado.

    6. Arraste SH02 - Products até o slide.

    7. Na barra de ferramentas do PowerPoint, clique na guia Inserir.
    8. Clique no botão Novo slide.
    9. Digite um título: por exemplo, "Sales by Category: 2013 vs 2014". Exclua a segunda caixa de texto vazia.
    10. Arraste CH212 - Sales by Category for 2014 vs 2013 até o slide.

  7. Adicionar uma tabela:
    1. No painel esquerdo, clique com o botão direito do mouse em Tabelas e selecione Adicionar objetos.
    2. Uma nova janela será aberta. Selecione Vendas por categoria: 2013 vs 2014. Clique em OK.

    3. Arraste CH212_1 - Sales by Category for 2014 vs 2013 até o slide.

  8. Adicione um gráfico nativo do PowerPoint:
    1. Na barra de ferramentas do PowerPoint, clique na guia Inserir.
    2. Clique no botão Novo slide.
    3. Digite um título: por exemplo, "Sales Trends:". Exclua a segunda caixa de texto vazia.
    4. No painel esquerdo, clique com o botão direito do mouse em Tabelas e selecione Adicionar objetos.

    5. Uma nova janela será aberta. Selecione CH326 - Sales by YearMonthNum. Clique em OK.

    6. Na barra de ferramentas do PowerPoint, selecione a guia Inserir.
    7. Na seção Ilustrações, clique em Gráfico.
    8. Uma nova janela será aberta. Em Coluna, selecione o primeiro gráfico de barras e clique em OK.

    9. Uma planilha do Excel será aberta. Esta é a fonte de dados do seu gráfico.

      Precisaremos inserir tags do Qlik NPrinting nesta planilha e remover alguns dados desnecessários.

    10. No painel esquerdo da interface do PowerPoint, expanda o nó CH326 - Sales by YearMonthNum.
    11. Selecione as tags YearMonthNum e Sales.

      Você pode selecionar várias opções, mantendo o botão CTRL pressionado.

    12. Arraste a tag Year MonthNum e solte-a na planilha do Excel, na célula A1. Isso a transformará no eixo Y. Arraste as tags do Sales até a célula B1. Isso a transformará no eixo X.

    13. Selecione e exclua colunas C e D.

      Os números reais são desnecessários, pois o Qlik NPrinting usará as tags para construir o gráfico.

    14. Selecione e exclua as linhas 3, 4 e 5.

    15. Feche o Excel.

      Suas alterações serão salvas automaticamente.

    16. Talvez seja necessário ajustar o tamanho do gráfico para que ele caiba no slide. Você pode usar as setas de dimensionamento.

    17. No menu do editor de modelos do Qlik NPrinting, clique na guia Arquivo. Clique em Salvar.
    18. Clique na guia Modelo e clique no botão Visualizar para visualizar seu relatório.

      No momento, sua apresentação de slides tem quatro slides.

  9. Adicione páginas:
    1. Vá até o slide ao qual você deseja adicionar a página. Neste caso, o quarto slide.

      As páginas são aplicadas apenas ao slide atual.

    2. No painel esquerdo, clique com o botão direito do mouse em Página e selecione Adicionar página à pasta atual.
    3. Uma nova janela será aberta. Selecione CategoryName. Clique em OK.

      Nota: Nota: Se você adicionar uma segunda página a um slide, a página anterior será substituída.
    4. Expanda o nó CategoryName_Page - CategoryName. Arraste a tag CategoryName até o slide.

      Essa tag dividirá seus dados por categoria, com cada categoria em um slide separado. O texto <CategoryName> mudará para corresponder à categoria de cada slide. Em vez de um slide que diz "Sales Trends:", você terá vários slides com títulos exclusivos: "Sales Trends: Baby Clothes", "Sales Trends: Women's Shoes".

      A tag <CategoryName> aparecerá como uma nova caixa de texto. Se você recortar e colar esse novo texto na caixa de texto do título, poderá formatá-lo para que ele corresponda ao título com mais facilidade.

    5. Vá para o segundo slide, "Top Selling Products".
    6. No painel esquerdo, clique com o botão direito do mouse em Página e selecione Adicionar página à pasta atual.
    7. Uma nova janela será aberta. Selecione Year. Clique em OK.
    8. Expanda o nó Year_Page - Year. Arraste a tag Year até o slide.

      Ela aparecerá como uma nova caixa de texto. Se você recortar e colar esse novo texto na caixa de texto do título, poderá formatá-lo para que ele corresponda ao título com mais facilidade.

    9. Na barra de ferramentas do PowerPoint, clique na guia Inserir.
    10. Clique no botão Número do slide.
    11. Uma nova janela será aberta. Clique nas caixas de seleção Data e hora, Número do slide e Não mostrar no slide de título. Clique em Aplicar a todos.

  10. No menu do editor de modelos do Qlik NPrinting, clique na guia Arquivo. Clique em Salvar.
  11. Clique na guia Modelo e clique no botão Visualizar para visualizar seu relatório.

    Pode levar vários minutos para a visualização ser carregada, dependendo do tamanho do relatório.

    Agora, você tem um relatório com 13 slides. Os slides com páginas aplicadas foram expandidos para novas páginas com informações divididas com base nas categorias de página aplicadas.

    Neste exemplo, os slides 2 a 4 mostram os dados filtrados por Year, enquanto os slides 6 a 13 mostram os dados filtrados por CategoryName.

    Aviso: As edições feitas no modo de visualização não serão salvas.
  12. Se quiser continuar editando, feche a janela de visualização e formate seu relatório no editor de modelos.
  13. Quando terminar a edição, clique em Salvar e fechar.

O modelo de relatório agora está salvo e pronto para ser compartilhado com os usuários.

Publicando no NewsStand e em e-mails

Relatórios precisam ser publicados para que os usuários possam acessá-los. Publicaremos no NewsStand e por e-mail.

NewsStand é um portal da web que possibilita aos usuários visualizar e fazer o download de relatórios e se inscrever em atualizações automáticas. Consulte: Visão geral do NewsStand

E-mails contêm seus relatórios como anexos. Seu conteúdo pode ser personalizado adicionando texto e imagens. Consulte: Distribuindo relatórios por e-mail.

Nota: Você deve configurar seu servidor de e-mail SMTP para enviar e-mails do Qlik NPrinting. Consulte: Configurando o servidor SMTP.

Faça o seguinte:

  1. No console da Web do Qlik NPrinting, clique em Tarefas no menu principal e selecione Tarefa de publicação.
  2. Clique no botão Criar tarefa.

    1. Digite um nome. Por exemplo: Publish Beginner's Tutorial NP PowerPoint.
    2. Selecione seu aplicativo na lista suspensa: Beginner's Tutorial NP App - QV.
    3. Para as outras opções, deixe os valores padrão. Clique em Criar.
  3. Clique na guia Relatórios.
    1. Clique no botão Adicionar relatório.

    2. Selecione Beginner's Tutorial - NP PowerPoint na lista suspensa Escolher relatório.
    3. Selecione PPTX na lista suspensa Formato de saída.
    4. Verifique se as caixas de seleção Anexar ao e-mail e Habilitado estão marcadas.
    5. Clique em Incluir relatório.

  4. Clique na guia Usuários/grupos.
    1. Clique no botão Adicionar usuário ou grupo.
    2. Selecione um usuário ou grupo na lista suspensa Escolher destinatário.

      Se quiser aprender a criar novos usuários, consulte: Criando usuários.

    3. Marque as caixas de seleção Habilitado, Destino do NewsStand e Destino do e-mail.
    4. Clique em Incluir destinatário.
  5. Clique na guia Destinos.
    1. Na coluna NewsStand, clique na caixa de seleção Publicar para todos.
    2. Na coluna E-mail, clique na caixa de seleção Publicar para todos.
    3. Clique em Salvar.
  6. Você retornará à guia Visão geral.
  7. Clique no botão Executar agora.

    Quando a tarefa estiver concluída, uma mensagem de confirmação será exibida na parte superior da página.

Seus destinatários podem agora acessar o NewsStand em seus navegadores e visualizar seus relatórios. Eles também receberão uma cópia em seus e-mails.

Dica: Em instalações padrão, você pode alternar do console da Web do Qlik NPrinting para o seu NewsStand mudando da porta 4993 para a porta 4994 na barra do navegador. Por exemplo, se o seu console da Web é https://YourServerName:4993, seu NewsStand será https://YourServerName:4994.