# Przeglądarka tabel

Okno dialogowe Przeglądarka tabel jest otwierane po wybraniu polecenia Przeglądarka tabel z menu Plik lub naciśnięciu klawisza Ctrl T.

![The Table Viewer dialog](https://help.qlik.com/pl-PL/qlikview/September2025/Subsystems/Client/Content/Resources/Images/TableViewer.png)

To okno dialogowe służy do wyświetlania struktury tabeli danych bieżącego dokumentu QlikView. Tabele są wyświetlane jako okna z listą pól, jakie zawierają. Linie konektora między oknami przedstawiają skojarzenia. W miejscach, w których spotykają się co najmniej dwie linie konektora, widoczne są punkty konektora w postaci niewielkich kropek.

Tabele, punkty połączeń oraz wszystkie punkty, w których konektory się zaginają, można przesuwać poprzez przeciąganie i upuszczanie (zob. poniżej). Takie zmiany układu będą zapisywane z dokumentem, chyba że okno dialogowe zostanie zamknięte za pomocą przycisku Anuluj.

Dostępne są dwa widoki, a układy każdego z nich są przechowywane osobno. Te dwa widoki są następujące:

* Widokiem domyślnym jest Widok tabeli wewnętrznej. Przedstawia on tabele danych w postaci, w jakiej są przechowywane przez program QlikView W tabelach, które mają więcej niż jedno pole wspólne, formowane są złożone klucze syntetyczne. W celu ich łączenia używane są tabele syntetyczne. Ten widok najbardziej ułatwia zrozumienie logiki QlikView i udostępnia bardzo przejrzysty układ, w którym każda para tabel jest połączona maksymalnie jednym konektorem.

  ![The Internal Table View. Tables are connected at a single point by synthetic keys.](https://help.qlik.com/pl-PL/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_Internal_TableView.png)

* Widok tabeli źródłowej przedstawia tabele danych w takiej postaci, w jakiej odczytuje je program QlikView. W tym widoku nie ma pól składni ani tabel syntetycznych Klucze złożone są reprezentowane przez wiele konektorów między tabelami.

  ![The Source Table View. Tables are connected by multiple connectors.](https://help.qlik.com/pl-PL/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_Sourrce_Table_View.png)

Umieszczenie wskaźnika myszy nad jednym z pól tabeli spowoduje wyświetlenie podpowiedzi z informacjami na temat zawartości pola:

* Gęstość informacji to liczba wierszy, które zawierają wartości (tj. inne niż NULL) w tym polu, w porównaniu do łącznej liczby wierszy w tabeli.

* Stosunek podzbioru to liczba odrębnych wartości tego pola znalezionych w tej tabeli, w porównaniu do łącznej liczby odrębnych wartości tego pola (także w innych tabelach).

* Komentarze do tabeli są wyświetlane w podpowiedzi.

* Komentarze do pola są wyświetlane w podpowiedzi.

* Znaczniki, które zostały dodane w skrypcie albo na stronie Właściwości dokumentu: Tabele, w tym także znaczniki systemowe, które są wyświetlane w podpowiedzi.

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Table_Viewer.htm)

#### W układach tabel mogą być wykonywane następujące akcje:

* Kliknięcie nagłówka tabeli: Powoduje wyróżnienie tabeli, wszystkich tabel z bezpośrednimi powiązaniami logicznymi z tą tabelą, a także połączeń między nimi.
* Wskazanie nagłówka tabeli i przeciągnięcie: Powoduje przeniesienie tabeli w układzie.
* Umieszczenie wskaźnika myszy nad nagłówkiem tabeli: Powoduje wyświetlenie okienka wyskakującego z informacjami na temat tabeli.
* Kliknięcie pola w tabeli: Powoduje wyróżnienie tabeli, pola, wszystkich tabel zawierających to pole, a także połączeń między nimi.
* Umieszczenie wskaźnika myszy nad polem w tabeli: Powoduje wyświetlenie okienka wyskakującego z informacjami na temat pola.
* Kliknięcie prawym przyciskiem myszy w tabeli: W celu wyświetlenia okna dialogowego zawierającego przykładowe wiersze z załadowanych danych należy kliknąć opcję Podgląd.
* Wskazanie punktu albo zagięcia konektora, a następnie przeciągnięcie: Powoduje przeniesienie punktu konektora w układzie.
* Kliknięcie prawym przyciskiem myszy punktu albo zagięcia konektora: Powoduje przeniesienie punktu konektora z powrotem do pozycji ustalonej automatycznie.
* Kliknięcie tła układu: Powoduje wyłączenie wszystkie wyróżnień tabel, pól i konektorów.

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Table_Viewer.htm)

#### Następujące polecenia są dostępne za pośrednictwem przycisków oraz paska narzędzi w oknie dialogowym:

* Eksportuj grafikę: Otwiera okno dialogowe przeglądarki plików, w której można zapisać bieżący widok tabeli w postaci mapy bitowej albo grafiki png w pliku na dysku.
* Eksportuj strukturę: Naciśnięcie tego przycisku umożliwia wyeksportowanie struktury tabeli dokumentu do zestawu plików tekstowych.   
  Te pliki tekstowe — jeden dla tabel (nazwa\_pliku.Tables.tab), jeden dla pól (nazwa\_pliku.Fields.tab) i jeden na potrzeby mapowania pomiędzy (nazwa\_pliku.Mappings.tab) — można łatwo wczytać ponownie do programu QlikView w celu dalszej analizy z wykorzystaniem wszystkich funkcji logiki QlikView. Zostanie wyświetlone okno dialogowe, w którym można wybrać folder docelowy dla eksportu. Domyślnie pliki należy umieścić w tym samym folderze, w którym znajduje się dokument QlikView.
* Drukuj grafikę: Otwiera okno dialogowe Drukuj, z którego można wydrukować bieżący widok tabeli. Można w zamian nacisnąć kombinację klawiszy Ctrl+P.
* Kopiuj grafikę: Kopiuje bieżący widok tabeli jako grafikę do schowka. Można w zamian nacisnąć kombinację klawiszy Ctrl+C.
* Autom. układ: Powoduje zmianę układu tabel w bieżącym widoku.
* Powiększenie: W tym polu rozwijanym można ustawić współczynnik powiększenia bieżącego widoku.
* Widok: Do wyboru jest Widok tabeli wewnętrznej i Widok tabeli źródłowej (zob. powyżej).