# Kreator danych wbudowanych

Okno dialogowe Kreator danych wbudowanych można otworzyć z menu Wstaw, wybierając kolejno opcje Instrukcja load i Ładuj wbudowane. Służy ono do tworzenia w skrypcie instrukcji load inline.

Okno dialogowe zawiera kontrolkę przypominającą z wyglądu i działania arkusz kalkulacyjny. Należy jednak pamiętać, że w tym arkuszu nie ma możliwości obliczania wartości formuł, jak jest to możliwe np. w programie Microsoft Excel.

Każda kolumna reprezentuje pole ładowane do aplikacji QlikView za pomocą tabeli wbudowanej. Każdy wiersz odpowiada wierszowi tabeli. Kliknięcie komórki danych spowoduje jej wybranie. Następnie można w niej wpisać lub wkleić wartość. Naciśnij klawisz Enter lub jeden z klawiszy strzałek, aby zaakceptować wprowadzoną wartość i przejść do innej komórki.

Pierwszy wiersz jest zarezerwowany dla etykiet pól. Dwukrotne kliknięcie komórki etykiety umożliwia jej edytowanie. Brak wartości w wierszu etykiet spowoduje używanie nazw pól F1, F2 itd.

## Menu Edytuj

Menu Edytuj zawiera podstawowe polecenia edycyjne.

Polecenia menu Edytuj

| 1, 2, 3... | Opis |
| --- | --- |
| Wstaw kolumnę | Wstawia nową, pustą kolumnę, jeśli co najmniej jedna kolumna jest wybrana. |
| Usuń kolumnę | Usuwa wybrane kolumny. |
| Wstaw wiersz | Wstawia nowy, pusty wiersz, jeśli co najmniej jeden wiersz jest wybrany. |
| Usuń wiersz | Usuwa wybrane wiersze. |

## Menu Narzędzia

Menu Narzędzia zawiera polecenie Dane dokumentu, które otwiera okno Kreator importu danych dokumentu. Tutaj można wkleić wartości pól z dowolnego istniejącego pola dokumentu. W oknie dialogowym można zobaczyć, ile wartości pól występuje w dowolnym z wybranych pól. Można też wybrać opcję wstawienia wszystkich wartości, wybranych wartości lub wykluczonych wartości do kreatora instrukcji inline.

Kliknij przycisk OK, aby zamknąć okno dialogowe i wygenerować instrukcję Load inline odpowiadającą zawartości siatki tabeli w oknie dialogowym.