# Wdrażanie i instalowanie Qlik dodatków do programu Microsoft Office

Wdróż i zainstaluj Qlik dodatki do programu Microsoft Office, aby umożliwić użytkownikom w organizacji tworzenie szablonów raportów. Przesyłaj szablony raportów utworzone za pomocą dodatków do aplikacji Qlik Cloud, aby wygenerować raport wyjściowy z zadań raportowania.

[Deploying and installing the Qlik Add-in for Microsoft Office](https://play.vidyard.com/FM3Fc4mT9h1ouVMGHpT5qy)

Qlik dodatki do programu Microsoft Office można wdrożyć i zainstalować w zgodnych wersjach internetowych i stacjonarnych programu Excel, PowerPoint i Word w ramach pakietu Microsoft 365.

Dodatki są instalowane przy użyciu pliku manifestu. Ten plik manifestu jest wymagany, aby administrator Microsoft 365 (lub ewentualnie użytkownik w przypadku niektórych metod instalacji) mógł wdrożyć i zainstalować dodatki dla siebie albo użytkowników w swojej organizacji. Plik manifestu umożliwia instalację dodatków dla pojedynczej Qlik Cloud dzierżawy.

InformacjaDo wygenerowania pliku manifestu i łącza jest wymagana konfiguracja klienta OAuth. Instrukcje, patrz [Przygotuj i uzyskaj manifest dodatku](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Manifest).

## Czym są Qlik dodatki do Microsoft Office?

Qlik dodatki do Microsoft Office to:

* Dodatek Qlik do programu Microsoft Excel

* Dodatek Qlik do programu Microsoft PowerPoint

* Dodatek Qlik do programu Microsoft Word

Funkcjonalność jest podobna we wszystkich dodatkach. W oknie dodatku możesz dodawać zawartość aplikacji w postaci tabel, obrazów, zmiennych i wyrażeń. Po dodaniu zawartości za pomocą dodatków masz kilka opcji formatowania i stylizowania jej, korzystając z domyślnej Microsoft Office funkcjonalności.

## Wybierz przepływ pracy instalacji

Po uzyskaniu pliku manifestu lub adresu URL, wybierz przepływ pracy, który odpowiada sposobowi, w jaki chcesz wdrożyć dodatek:

* Przepływ pracy 1: Scentralizowane wdrożenie dla zarządzanej dystrybucji przez Microsoft 365 administratora. Zobacz [Przepływ pracy 1: Scentralizowane wdrożenie](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Centrali).

* Przepływ pracy 2: Ładowanie bezpośrednie w sieci do szybkiego testowania bez scentralizowanego wdrożenia. Zobacz [Przepływ pracy 2: Ładowanie dodatku bezpośrednio w sieci web](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Workflow2Web).

* Przepływ pracy 3: Instalacja na stacjonarnych Microsoft Office aplikacjach poprzez Windows udział sieciowy. Zobacz [Przepływ pracy 3: Zainstaluj dodatek w stacjonarnych Microsoft Office aplikacjach za pomocą Windows udziału sieciowego](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Workflow3Windows).

* Przepływ pracy 4: Ładowanie bezpośrednie w komputerowych macOS aplikacjach. Zobacz [Przepływ pracy 4: Ładowanie dodatku z boku w aplikacjach komputerowychmacOS](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Workflow4Mac).

Przepływ pracy 1 jest zalecaną opcją dla wdrożeń produkcyjnych. Przepływy pracy 2–4 są najlepsze do testowania, użytku próbnego lub konfiguracji dla pojedynczych użytkowników.

Przycisk dodatku Qlik w wersji internetowej programu Microsoft Excel

Przycisk dodatku Qlik w wersji internetowej programu Microsoft Excel

Przycisk dodatku QlikQlik w wersji internetowej programu Microsoft ExcelMicrosoft Excel ![Pasek wstążki w programie Microsoft Excel pokazujący ikonę dodatku Qlik, co oznacza, że dodatek został aktywowany](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_QlikIconInRibbon.png)

Więcej informacji zawiera temat [Projektowanie szablonów raportów z dodatkami Qlik dla Microsoft Office](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Design/OfficeCommon/reporting-add-ins.htm).

## Zanim rozpoczniesz

Te kroki mają zastosowanie do wszystkich przepływów pracy instalacji.

* Upewnij się, że Ty i Twoi użytkownicy spełniacie wymagania systemowe i programowe.

  [Wymagania systemowe i programowe](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#SystemReqsAddIns)

* Utwórz klienta OAuth w Qlik Cloud.

  [Utwórz klienta OAuth](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Creating)

* Pobierz plik manifestu lub link.

  [Przygotuj i uzyskaj manifest dodatku](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Manifest)

### Wymaganie 1: Spełnienie wymagań systemowych i programowych

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Wymagania systemowe i programowe

Uwaga dotycząca Qlik Cloud Government

Dodatki Qlik do Microsoft Office są obsługiwane przy tworzeniu szablonów raportów na podstawie aplikacji w dzierżawach Qlik Cloud Government lub Qlik Cloud Government - DoD.

Aby zainstalować i używać dodatków Qlik, użytkownicy muszą spełnić następujące wymagania.

#### Dodatek Qlik do programu Microsoft Excel

Dla Windows instalacji:

* Windows 10 v.1903 lub wyższa wersja

* Microsoft 365 v.16.0.11629 lub wyższa wersja

Dla macOS instalacji:

* macOS v.14 lub wyższa wersja

* Microsoft 365 v.16.83 lub wyższa wersja

Ponadto, do uruchamiania dodatku Qlik dla Microsoft Excel, jest wymagana instalacja Microsoft Excel z ExcelAPI 1.9 lub nowszą wersją. Aby sprawdzić, czy Twoja instalacja Excel jest zgodna, zapoznaj się z oficjalną dokumentacją firmy Microsoft na stronie [Excel JavaScript API requirement sets](https://learn.microsoft.com/en-us/javascript/api/requirement-sets/excel/excel-api-requirement-sets?view=common-js-preview).

Jeśli wersja ExcelAPI będzie niższa od minimalnej, zostanie wyświetlony błąd wskazujący, że dodatek Qlikwymaga nowszej wersji programu Microsoft Excel.

Przykład komunikatu o błędzie podczas instalacji dodatku

Przykład komunikatu o błędzie podczas instalacji dodatku

Przykład komunikatu o błędzie podczas instalacji dodatku ![Komunikat o błędzie podczas instalacji dodatku Qlik Excel informujący, że wersja programu Microsoft Excel użytkownika jest zbyt stara, aby obsługiwać dodatek](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_ExcelVersionError.png)

W celu wyświetlenia komunikatu o błędzie być może trzeba będzie kliknąć biały obszar po prawej stronie w programie Microsoft Excel i nacisnąć klawisz F5, aby zaktualizować stronę.

Jeśli widzisz ten błąd, zaktualizuj instalację programu Microsoft Excel.

#### Dodatek Qlik do programu Microsoft PowerPoint

Dla Windows instalacji:

* Windows 10 v.1903 lub wyższa wersja

* Microsoft 365 wersja 2504 (kompilacja 18730.20030) lub nowsza

Dla macOS instalacji:

* macOS v.14 lub wyższa wersja

* Microsoft 365 v.16.96 lub wyższa wersja

#### Dodatek Qlik do programu Microsoft Word

Dla Windows instalacji:

* Windows 10 v.1903 lub wyższa wersja

* Microsoft 365 w wersji 2208 (kompilacja 15601.20148) lub nowszej

Dla macOS instalacji:

* macOS v.14 lub wyższa wersja

* Microsoft 365 v.16.64 lub wyższa wersja

### Wymaganie 2: Utwórz klienta OAuth

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Utwórz klienta OAuth

Do zainstalowania dodatków Qlik do programu Microsoft Office wymagana jest konfiguracja klienta OAuth. Dodatki są używane przez twórców raportów do przygotowywania szablonów raportów do raportowania w aplikacji z Qlik Cloud.

Aby protokół OAuth działał w dodatkach, klient OAuth musi być skonfigurowany dokładnie tak, jak pokazano poniżej.

Wykonaj następujące czynności:

1. W Qlik Cloud, kliknij the Otwórz menu nawigacji icon w lewym górnym rogu.

2. Wybierz Administrowanie.

3. Przejdź do OAuth.

4. Kliknij Utwórz nowy.

5. Z menu rozwijanego Typ klienta wybierz opcję Aplikacja jednostronicowa. Pojawi się więcej pól.

6. Wstaw Nazwę. Opis jest opcjonalny.

7. Zaznacz co najmniej pole wyboru, aby uwzględnić zakres user\_default. Można też uwzględnić inne zakresy w konfiguracji, ale bez user\_default instalacja nie będzie działać.

   Pełny opis każdego dostępnego zakresu zawiera temat [Dostępne zakresy OAuth](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Admin/mc-create-oauth-client.htm#Availabl).

8. W polu Dodaj adresy URL przekierowania wstaw adres URL Qlik Cloud dzierżawy, a następnie ten stały ciąg znaków: /office-add-ins/oAuthLoginSuccess.html

   Rezultat powinien wyglądać następująco: https://&lt;tenant or alias hostname&gt;.&lt;region&gt;.qlikcloud.com/office-add-ins/oAuthLoginSuccess.html. Na przykład: http://example-company-123.us.qlikcloud.com/office-add-ins/oAuthLoginSuccess.html

9. Kliknij Dodaj.

10. W polu Dodaj dozwolone pochodzenia wpisz adres URL dzierżawy i kliknij przycisk Dodaj.

11. Kliknij Utwórz.

12. Pojawi się okno Skopiuj identyfikator klienta. Możesz skopiować identyfikator klienta do schowka lub kliknąć Gotowe, aby zamknąć okno.

Po utworzeniu klienta OAuth uzyskaj łącze do zaktualizowanego manifestu XML z centrum aktywności Administrowanie. Przejdź do strony Ustawienia i wybierz kartę E-mail i raporty. W sekcji Udostępnianie i raporty wybierz dodatki Qlik do programu Microsoft Office. Użyj podanego łącza, aby wdrożyć i zainstalować dodatek.

### Wymaganie 3: Przygotuj i uzyskaj manifest dodatku

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Przygotuj i uzyskaj manifest dodatku

Instalujesz Qlik dodatki dla Microsoft Office w środowisku Microsoft za pomocą pliku manifestu XML lub łącza do niego.

* Dla scentralizowanego wdrożenia, manifest często musi być dostarczony w formie adresu URL.

* W przypadku instalacji zarządzanych samodzielnie, manifest jest często dostarczany w postaci pliku.

Plik manifestu jest specyficzny dla pojedynczej dzierżawy Qlik Cloud. Używasz tego samego pliku manifestu do instalowania dodatków dla Excel, PowerPoint i Word.

Do instalacji dodatku jest wymagana konfiguracja klienta OAuth. Po skonfigurowaniu klienta OAuth, uzyskaj link do pliku manifestu, a także sam plik manifestu, z Administrowanie centrum aktywności.

Wykonaj następujące czynności:

1. Utwórz klienta OAuth w dzierżawie Qlik Cloud przy użyciu wymaganej konfiguracji. Pełne instrukcje, patrz [Utwórz klienta OAuth](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Creating).

2. W Qlik Cloud, kliknij the Otwórz menu nawigacji icon w lewym górnym rogu.

3. Wybierz Administrowanie.

4. Przejdź do Ustawienia.

5. W sekcji Udostępnianie i raporty przejdź do Dodatki Qlik dla Microsoft Office.

6. Z menu rozwijanego wybierz konfigurację klienta OAuth przygotowaną przez Ciebie do aktywacji OAuth w dodatku.

7. Kliknij Pobierz, aby pobrać manifest, lub Kopiuj, aby skopiować link do niego.

## Przepływ pracy 1: Scentralizowane wdrożenie

Zaleca się, aby dodatki Qlik dla Microsoft Office były udostępniane w ramach scentralizowanego wdrażania i instalacji. Scentralizowane wdrożenie wymaga działania administratora Microsoft 365 w Twojej organizacji.

W przypadku wdrożenia scentralizowanego manifest dodatku jest ładowany do centrum administracyjnego Microsoft 365 organizacji i rozpowszechniany wśród użytkowników w postaci wstępnie skonfigurowanej instalacji. Dystrybucję można ograniczyć do członków określonych grup zabezpieczeń.

InformacjaPrzy scentralizowanym wdrożeniu, dodatki są instalowane dla Excel, PowerPoint, i Word. Brak możliwości instalowania dodatków indywidualnie.

Użyj tego przepływu pracy, gdy:

* Chcesz, aby dodatki były zainstalowane na stałe dla członków Twojej organizacji

* Chcesz zarządzać dystrybucją wśród członków organizacji

OstrzeżenieWdrożenie dodatków Qlik dla Microsoft Office nie jest powiązane z dostępem do dzierżawy Qlik Cloud. Jeśli rozpowszechnisz dodatki wśród użytkowników, którzy nie mają dostępu do Qlik Cloud, będą oni mogli wyświetlać i uruchamiać te dodatki. Jednakże dodatki poproszą użytkownika o zalogowanie się do Qlik Cloud. Jeśli logowanie się nie powiedzie, funkcjonalność zostanie zablokowana.

Uzupełnij poniższe sekcje w kolejności.

### Wdrażaj i instaluj za pomocą centrum administracyjnego Microsoft 365

Wdrożenie scentralizowane przeprowadza administrator systemu Microsoft 365.

Wykonaj następujące czynności:

1. Uzyskaj plik manifestu dodatku lub adres URL manifestu po utworzeniu klienta OAuth. Zobacz [Przygotuj i uzyskaj manifest dodatku](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Manifest).

2. Rozpowszechnij dodatek zgodnie z oficjalną dokumentacją firmy Microsoft: [Deploy and publish Office Add-ins](https://learn.microsoft.com/en-us/office/dev/add-ins/publish/publish). Należy pamiętać, że dystrybucja za pośrednictwem wdrożenia scentralizowanego jest możliwa tylko przy użyciu Centrum administracyjnego Microsoft 365.

Przy użyciu powyższej procedury dodatki są instalowane dla użytkowników, którzy uzyskają do nich dostęp. Następnie użytkownicy aktywują dodatki w swojej wersji programu Excel, PowerPoint lub Word.

### Aktywuj dodatek po wdrożeniu scentralizowanym

Gdy administrator produktów Microsoft zainstaluje dodatek Qlik w Twojej organizacji, możesz aktywować ten dodatek i go używać, jeśli masz do niego dostęp.

W zależności od wersji Twojej Microsoft Office aplikacji, te kroki mogą się nieco różnić. Szczegółowe informacje zawiera oficjalna dokumentacja firmy Microsoft.

Wykonaj następujące czynności:

1. Otwórz wersję komputerową lub internetową programu Excel, PowerPoint lub Word.

2. Wybierz Strona główna &gt; Dodatki &gt; Pobierz dodatki.

3. Na karcie ZARZĄDZANE PRZEZ ADMINISTRATORA w oknie dialogowym wybierz dodatek Qlik.

Ikona dodatku Qlik zostanie dodana do paska wstążki.

[Wyświetlaj, zarządzaj i instaluj dodatki dla programów Excel, PowerPoint i Word](https://support.microsoft.com/en-gb/office/view-manage-and-install-add-ins-for-excel-powerpoint-and-word-16278816-1948-4028-91e5-76dca5380f8d)

### Usuwanie dodatku

Jeśli instalacji dokonano w ramach wdrożenia scentralizowanego, odinstalowanie dodatku może nie być możliwe. Zależy to od zasad stosowanych przez administratora Microsoft 365.

## Przepływy pracy 2-4: Opcje instalacji zarządzanej samodzielnie

Pobieranie lokalne i instalacja z udziału sieciowego to odpowiednie sposoby szybkiego uzyskania dostępu do dodatków w celach testowych lub próbnych. Nie są to odpowiednie metody wdrażania dodatków na skalę produkcyjną i korporacyjną.

OstrzeżenieAby samodzielnie zainstalować dodatki za pomocą ładowania bezpośredniego (sideloading) lub udziału sieciowego, możesz potrzebować uprawnień od swojej organizacji oraz na swojej maszynie lokalnej. Te uprawnienia mogą być zarządzane przez Twoją organizację lub Microsoft 365 administratora. Jeśli nie możesz samodzielnie zainstalować dodatku, zapoznaj się z [oficjalną dokumentacją firmy Microsoft dotyczącą dodatków pakietu Office](https://learn.microsoft.com/en-us/office/dev/add-ins/) lub skontaktuj się z administratorem systemu.

OstrzeżeniePobieranie manifestu i pobieranie lokalne dodatków jest możliwe bez ograniczeń. Manifest można zainstalować, nawet jeżeli nie masz dostępu do Qlik Cloud. Natychmiast pojawi się jednak monit o zalogowanie się do Qlik Cloud po instalacji. Dodatki nie będą działać bez zalogowania.

Uwaga dotycząca Qlik Cloud Government

W usłudze Office 365 Government Community Cloud High (GCCH) dodatki Qlik dla Microsoft Office można instalować wyłącznie przez [scentralizowane wdrożenie](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Centrali). Instalowanie przez sideloading lub udział sieciowy nie jest obsługiwane.

W zależności od wersji Excel, PowerPoint lub Word, a także innych czynników, dodatki załadowane tymi metodami mogą ostatecznie zostać usunięte z paska wstążki. W takim przypadku prześlij ponownie manifest do aplikacji Microsoft Office.

### Przepływ pracy 2: Ładowanie dodatku bezpośrednio w sieci web

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Przepływ pracy 2: Ładowanie dodatku z boku w sieci Web

Aby pobrać dodatek lokalnie za pomocą Excel, PowerPoint lub Word w Internecie, użytkownik przesyła plik manifestu do swojej przeglądarki.

Pobieranie lokalne jest obsługiwane przez internetowe wersje Excel, PowerPoint lub Word udostępniane przez Microsoft 365.

Użyj tego przepływu pracy, gdy:

* Musisz szybko uzyskać dostęp do dodatku.

* Chcesz przetestować funkcjonalność dodatku w izolacji.

* Chcesz przetestować dodatek bez konieczności interwencji ze strony administratora Microsoft 365.

Wykonaj następujące czynności:

1. Przygotuj i pobierz plik manifestu. Zobacz [Przygotuj i uzyskaj manifest dodatku](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Manifest).

2. Otwórz Microsoft Office w Internecie pod adresem https://office.live.com/.

3. Otwórz nowy dokument Excel, PowerPoint lub Word.

4. Na karcie Narzędzia główne kliknij Dodatki.

5. Kliknij Zaawansowane... lub Dodatki pakietu Office.

6. W oknie dialogowym Dodatki pakietu Office kliknij Przekaż mój dodatek.

7. Przeglądaj, aby przejść do pliku manifestu dodatku, a następnie wybierz Przekaż.

8. W razie potrzeby zaloguj się na swoje konto Qlik Cloud.

#### Usuwanie dodatku pobranego lokalnie

Aby usunąć dodatek pobrany lokalnie, wyczyść pamięć podręczną przeglądarki internetowej, w której używasz dodatku.

### Przepływ pracy 3: Zainstaluj dodatek w stacjonarnych Microsoft Office aplikacjach za pomocą Windows udziału sieciowego

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Przepływ pracy 3: Zainstaluj dodatek w aplikacjach komputerowych Microsoft Office przy użyciu Windows udziału sieciowego

Aby zainstalować dodatki w wersji komputerowej programu Excel, PowerPoint lub Word bez wdrażania scentralizowanego, możesz skonfigurować udział sieciowy i załadować do niego manifest. Można to zrobić tylko w systemie operacyjnym Windows.

Postępuj zgodnie z poniższymi wskazówkami, aby pobrać lokalnie dodatki za pośrednictwem udziału sieciowego. Instrukcje zostały zaczerpnięte z oficjalnej dokumentacji firmy Microsoft i adaptowane. Więcej informacji zawiera temat [Sideload Office Add-ins for testing from a network share](https://learn.microsoft.com/en-us/office/dev/add-ins/testing/create-a-network-shared-folder-catalog-for-task-pane-and-content-add-ins) lub inne zasoby firmy Microsoft.

#### Krok 1: tworzenie i udostępnianie folderu

Wykonaj następujące czynności:

1. Utwórz folder, w którym będzie hostowany dodatek Qlik. Na przykład: C:\Dodatki Qlik Office

2. W Eksploratorze plików Windows przejdź do folderu nadrzędnego lub litery dysku folderu, którego chcesz używać jako katalogu folderu udostępnionego. Na przykład: C:\

3. Kliknij folder prawym przyciskiem myszy i wybierz Właściwości.

4. Otwórz kartę Udostępnianie, a następnie kliknij przycisk Udostępnij.

   Przycisk Udostępnij...

   Przycisk Udostępnij...

   Przycisk Udostępnij...Udostępnij... ![Przycisk „Udostępnij” w oknie dialogowym podczas konfigurowania udziału sieciowego w systemie Windows](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_SideloadNetworkShare_Share.png)

5. W oknie dialogowym dodaj siebie oraz innych użytkowników lub grupy, którym chcesz udostępnić dodatek. Będziesz potrzebować co najmniej uprawnień do odczytu/zapisu do folderu. Po zakończeniu wybierania osób, którym chcesz udostępnić dodatek, kliknij Udostępnij.

6. Gdy zobaczysz potwierdzenie, że Twój folder został udostępniony, zanotuj pełną ścieżkę sieciową wyświetloną bezpośrednio po nazwie folderu. Kliknij przycisk Gotowe, aby zamknąć okno dialogowe.

   Potwierdzenie pomyślnego udostępnienia folderu z pełną ścieżką sieciową

   Potwierdzenie pomyślnego udostępnienia folderu z pełną ścieżką sieciową

   Potwierdzenie pomyślnego udostępnienia folderu z pełną ścieżką sieciową ![Okno dialogowe dostępu do sieci potwierdza pomyślnie udostępniony folder z pełną ścieżką sieciową](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_SideloadNetworkShare_ShareConfirmation.png)

7. Kliknij przycisk Zamknij, aby zamknąć okno dialogowe Właściwości.

#### Krok 2: ręczna konfiguracja folderu udostępnionego jako katalog zaufany

Wykonaj następujące czynności:

1. Otwórz nowy pusty skoroszyt w komputerowej wersji programu Excel, PowerPoint lub Word.

2. Kliknij kartę Plik, a następnie Opcje w lewym dolnym rogu.

3. Kliknij Centrum zaufania, a następnie kliknij przycisk Ustawienia Centrum zaufania.

   Przycisk Ustawienia Centrum zaufania

   Przycisk Ustawienia Centrum zaufania

   Przycisk Ustawienia Centrum zaufaniaUstawienia Centrum zaufania ![Przycisk „Ustawienia Centrum zaufania” w opcjach programu Microsoft Excel](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_SideloadNetworkShare_TrustCenterSettings.png)

4. Kliknij opcję Zaufane wykazy dodatków.

   Karta Zaufane wykazy dodatków

   Karta Zaufane wykazy dodatków

   Karta Zaufane wykazy dodatkówZaufane wykazy dodatków ![Przycisk „Zaufane wykazy dodatków” w Centrum zaufania programu Microsoft Excel](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_SideloadNetworkShare_TrustedCatalogs.png)

5. W polu Adres URL wykazu wprowadź pełną ścieżkę sieciową do udostępnionego wcześniej folderu.

6. Kliknij Dodaj katalog.

7. Zaznacz pole wyboru Pokaż w menu dla nowo dodanego elementu, a następnie kliknij OK, aby zamknąć okno dialogowe Centrum zaufania.

   Karta Zaufane wykazy dodatków w oknie dialogowym Centrum zaufania z nowo dodaną ścieżką wykazu

   Karta Zaufane wykazy dodatków w oknie dialogowym Centrum zaufania z nowo dodaną ścieżką wykazu

   Karta Zaufane wykazy dodatkówZaufane wykazy dodatków w oknie dialogowym Centrum zaufania z nowo dodaną ścieżką wykazu ![Karta „Zaufane wykazy dodatków” z nowo dodanym adresem URL katalogu](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_ExcelAddIn_SideloadNetworkShare_CatalogURL.png)

8. Kliknij przycisk OK, aby zamknąć okno dialogowe.

9. Zamknij i ponownie otwórz aplikację, aby zmiany zaczęły obowiązywać.

#### Krok 3: pobieranie lokalne dodatku

Wykonaj następujące czynności:

1. Dodaj plik XML manifestu dodatku do folderu udostępnionego.

2. W ExcelPowerPoint lub Word, kliknij Dodatki na karcie Narzędzia główne na wstążce.

3. Kliknij Więcej dodatków.

4. Kliknij FOLDER UDOSTĘPNIONY u góry okna dialogowego Dodatki pakietu Office.

5. Wybierz Qlik, aby wstawić dodatek.

6. Może zostać wyświetlone okno dialogowe z komunikatem podobnym do następującego: Qlik chce wyświetlić nowe okno. Kliknij Zezwól.

#### Usuwanie dodatku zainstalowanego z udziału sieciowego

Wykonaj następujące czynności:

1. Jeśli program Excel, PowerPoint lub Word jest otwarty, zamknij go.

2. Usuń zawartość tego folderu: %LOCALAPPDATA%\Microsoft\Office\16.0\Wef\

### Przepływ pracy 4: Ładowanie dodatku z boku w aplikacjach komputerowychmacOS

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Przepływ pracy 4: Ładowanie dodatku typu sideload w aplikacjach komputerowych macOS

W systemie macOS dodatki można zainstalować w Microsoft 365 wersjach klasycznych programów Excel, PowerPoint lub Word. Wymagania systemowe i programowe zawiera temat [Wymagania systemowe i programowe](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#SystemReqsAddIns).

Skorzystaj z poniższych wskazówek. Instrukcje zostały zaczerpnięte z oficjalnej dokumentacji firmy Microsoft i adaptowane. Pełne instrukcje znajdują się w oficjalnej dokumentacji firmy Microsoft: [Ładowanie dodatku typu sideload w Office na Mac](https://learn.microsoft.com/en-us/office/dev/add-ins/testing/sideload-an-office-add-in-on-mac#sideload-an-add-in-in-office-on-mac)

Wykonaj następujące czynności:

1. Otwórz aplikację Finder na komputerze.

2. Wprowadź następującą kombinację klawiszy: Command+Shift+G

   Zostanie otwarte menu Przejdź do folderu .

3. Wprowadź jedną z następujących ścieżek w zależności od Microsoft Office aplikacji:

   * Excel: /Users/&lt;username&gt;/Library/Containers/com.microsoft.Excel/Data/Documents/wef

   * PowerPoint: /Users/&lt;username&gt;/Library/Containers/com.microsoft.Powerpoint/Data/Documents/wef

   * Word: /Users/&lt;username&gt;/Library/Containers/com.microsoft.Word/Data/Documents/wef

   Folder wef może jeszcze nie istnieć na komputerze. W takim przypadku utwórz go w tej lokalizacji.

4. W folderze wef dodaj kopię pliku XML manifestu.

5. Otwórz Excel, PowerPoint, lub Word. Jeśli jest już otwarty, należy uruchomić go ponownie.

6. Na pasku wstążki przejdź do pozycji Strona główna &gt; Dodatki.

7. Wybierz dodatek Qlik.

Dodatek Qlik powinien być teraz dostępny na pasku wstążki.

#### Usuwanie pobranego lokalnie dodatku z komputerowych macOS aplikacji

Aby usunąć dodatek Qlik, należy wyczyścić pamięć podręczną pakietu Office na komputerze. Więcej informacji zawiera temat:

* [Usuwanie dodatku pobranego lokalnie](https://learn.microsoft.com/en-us/office/dev/add-ins/testing/sideload-an-office-add-in-on-mac#remove-a-sideloaded-add-in)

* [Wyczyść pamięć podręczną Office](https://learn.microsoft.com/en-us/office/dev/add-ins/testing/clear-cache)

## Dodawanie wielu Qlik dodatków do Excel, PowerPoint, lub Word

Każdy kolejny dodatek Qlik umożliwia korzystanie z dodatku dla jednej dzierżawy Qlik Cloud.

Zachowanie i ograniczenia są następujące:

* W Twojej Excel, PowerPoint, lub Word aplikacji, tylko jeden dodatek (połączony z jedną Qlik Cloud dzierżawą) jest obsługiwany do użytku jednocześnie.

* Jeśli musisz pracować z dodatkami dla wielu Qlik Cloud dzierżaw, musisz przełączać się między dzierżawami, wdrażając lub instalując dodatek, którego chcesz użyć, bezpośrednio przed rozpoczęciem jego użytkowania. Jeśli dodatek nadal łączy się z poprzednio wybraną dzierżawą, ponownie uruchom aplikację pakietu Office lub ponownie załaduj stronę przeglądarki.

* Posiadanie Qlik dodatku [wdrożonego centralnie](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Centrali) dla jednej Qlik Cloud dzierżawy może uniemożliwić ładowanie dodatku z boku dla innych dzierżaw.

* W zależności od wersji programu Microsoft Excel, PowerPoint lub Word i używanej przeglądarki, po załadowaniu wielu dodatków na pasku wstążki mogą być wyświetlane ikony każdego z nich lub tylko jedna ikona zawierająca najnowsze wdrożone wystąpienie. To pierwsze może się zdarzyć, na przykład, podczas używania starszych wersji Microsoft Excel, PowerPoint, lub Word.

* W usłudze Office 365 Government Community Cloud High (GCCH) dodatki Qlik dla Microsoft Office można instalować wyłącznie przez [scentralizowane wdrożenie](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm#Centrali). Instalowanie przez sideloading lub udział sieciowy nie jest obsługiwane. Office 365 GCC i GCCH obsługują pracę z pojedynczą Qlik Cloud Government lub Qlik Cloud Government - DoD dzierżawą jednocześnie.

## Rozwiązywanie problemów

W tej sekcji znajdują się wskazówki dotyczące rozwiązywania typowych problemów z wdrażaniem i instalacją.

Więcej wskazówek na temat rozwiązywania problemów zawiera temat [Rozwiązywanie problemów — raporty w aplikacji](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Troubleshooting/troubleshooting-reporting.htm).

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Puste okno dialogowe wyświetlane podczas uwierzytelniania po wdrożeniu Qlik dodatku dla Microsoft Office

Gdy użytkownik próbuje uwierzytelnić się w dodatku do raportowania dla Microsoft Excel, Microsoft PowerPoint lub Microsoft Word, wyskakujące okno dialogowe uwierzytelniania może być puste. Zamiast tego użytkownik może zobaczyć błąd w oknie dialogowym (w szczególności 12006).

Aby użytkownik mógł pracować z dodatkiem Qlik do Microsoft Office, przepływ uwierzytelniania wymaga przekierowania między Twoją dzierżawą a dostawcą tożsamości hostowanym w innej domenie. Twój dostawca tożsamości ustawia Cross-Origin-Opener-Policy z restrykcyjnymi ustawieniami. W rezultacie część przepływu uwierzytelniania obejmująca komunikację między domenami jest blokowana, co uniemożliwia prawidłowe zwrócenie danych logowania do dodatku.

Proponowane działanie

Poniższe rozwiązanie powinien wykonać administrator sieci odpowiedzialny za konfigurowanie dostawców tożsamości.

Wykonaj następujące czynności:

* Ustaw nagłówek odpowiedzi od swojego dostawcy tożsamości w oknie dialogowym na:

  Cross-Origin-Opener-Policy: unsafe-none

Aby uzyskać więcej informacji, zapoznaj się z oficjalną dokumentacją firmy Microsoft: [Best practices and rules for the Office Dialog API](https://learn.microsoft.com/en-us/office/dev/add-ins/develop/dialog-best-practices)

[](https://help.qlik.com/en-US/cloud-services/Subsystems/Hub/Content/Sense_Hub/Reporting/Install/reporting-install-add-ins.htm)

#### Wyskakujące okienka niedozwolone przy pierwszym otwarciu Qlik dodatku dla Microsoft Office

Możesz zobaczyć następujący komunikat o błędzie przy pierwszym otwarciu dodatku Qlik dla Microsoft Office po jego aktywacji:

Ustawienia zabezpieczeń Twojej przeglądarki uniemożliwiają nam utworzenie okna dialogowego.

Twoja przeglądarka internetowa blokuje otwarcie okna dialogowego uwierzytelniania dodatku jako wyskakującego okienka.

Jeśli używasz wersji internetowej Microsoft Office aplikacji, musisz zezwolić przeglądarce na otwieranie wyskakujących okien. Zależy to od przeglądarki i jej wersji, ale możliwe rozwiązania to:

* Wybranie opcji w słupku adresu internetowego, aby zezwolić na wyskakujące okienka.

* Otworzenie ustawień przeglądarki i wybranie opcji zezwalającej na wyskakujące okienka.

## Dowiedz się więcej

* [Tworzenie klientów OAuth i zarządzanie nimi](https://help.qlik.com/pl-PL/cloud-services/Subsystems/Hub/Content/Sense_Hub/Admin/mc-create-oauth-client.htm)