Lijngrafiek

Grafieken zijn een grafische weergave van numerieke gegevens. U kunt schakelen tussen verschillende weergaven van een bestaand diagram door het diagramtype te wijzigen op de pagina Diagrameigenschappen: Algemeen.

In een lijngrafiek worden gegevens gepresenteerd als lijnen tussen waardepunten, als alleen waardepunten of als zowel lijnen als waardepunten. Lijngrafieken zijn geschikt voor het aangeven van veranderingen of trends.

De snelste manier om een nieuwe lijngrafiek te maken is om Snelle grafiek in het menu Extra's te selecteren.

Als u met de rechtermuisknop op het lijndiagram klikt, wordt het menu Lijndiagram: Object weergegeven. Het menu kan ook worden geopend via het menu Object, als de lijngrafiek het actieve object is.

Nieuwe grafiek

U kunt een nieuwe grafiek maken door op de werkbalk op de knop Nieuwe grafiek te klikken, door met de rechtermuisknop op een leeg werkbladgebied te klikken en Nieuw object, Grafiek te selecteren in het menu Object of door in het menu Nieuw object, Grafiek in het menu Opmaak te klikken. Hiermee wordt een venster met eigenschappenpagina's geopend.

Op de eerste pagina die verschijnt, stelt u de naam, het type en de titel (optioneel) van het diagram in. Klik op de knop Volgende om naar de volgende pagina te gaan. Zodra voldoende gegevens zijn ingevoerd, wordt de knop Volgende en/of Voltooien geactiveerd en kan de gebruiker doorgaan naar de volgende pagina in de reeks of de reeks voltooien.

Zodra de grafiek op het werkblad wordt weergegeven, kan deze worden gewijzigd door er met de rechtermuisknop op te klikken en Eigenschappen te selecteren, of door de grafiek te activeren (door op het titelbalkgebied te klikken) en Eigenschappen te selecteren in het menu Object.

Menu Object

Klik met de rechtermuisknop op een grafiek en er verschijnt een zwevend menu. U vindt dit menu ook onder het menu Object als de grafiek actief is.

Het menu bevat de volgende opdrachten:

Eigenschappen... Hiermee wordt het dialoogvenster Eigenschappen geopend, waarin u de parameters voor de grafiek kunt instellen.
Opmerkingen

Hiermee kunt u opmerkingen maken en uitwisselen over het huidige object.

Zie: Notities en opmerkingen

Ontkoppelen Aan de grafiektitel wordt de tekst ''(ontkoppeld)'' toegevoegd. De grafiek wordt niet langer bijgewerkt als er selecties in het document worden opgegeven (maar er kunnen wel nog steeds selecties via de grafiek worden gemaakt). De opdracht is alleen beschikbaar als de grafiek is gekoppeld. Door een kopie te maken van een grafiek en deze te ontkoppelen, kunt u een directe vergelijking maken tussen de kopie en het origineel.
Bijvoegen Hiermee koppelt u een ontkoppelde grafiek. De grafiek wordt dynamisch gekoppeld aan de gegevens. De opdracht is alleen beschikbaar als de grafiek is ontkoppeld.
Referentie instellen Door deze optie te kiezen, stelt u een grafiekreferentie in. Dit betekent dat de grafiek wordt vastgelegd met de huidige selecties. Als u in het document nieuwe selecties opgeeft, blijft de referentieplot zichtbaar, gedimd op de achtergrond. Grafiekassen en dergelijke zullen worden aangepast, zodat ze altijd het maximum aantal achtergrondgegevens en de huidige gegevensset bevatten. De huidige gegevensset wordt altijd boven op de referentieplot getekend. Het is mogelijk dat enkele delen van de referentieplot minder goed zichtbaar zijn. De wijze waarop de achtergrond wordt gedimd, kan worden geregeld met de instelling Referentiemodus op de pagina Grafiekeigenschappen: Algemeen. De weergave van referentiegrafiekplots is alleen mogelijk voor sommige grafieksoorten, zoals staafgrafieken, lijngrafieken, combinatiegrafieken, radargrafieken, spreidingsgrafieken, rastergrafieken en metergrafieken met wijzers. Het is niet mogelijk is om een referentie in te stellen voor een grafiek die een drilldowngroep of cyclische groep bevat. De referentie gaat verloren als het document wordt gesloten en als gegevens opnieuw worden geladen. Het maximale aantal objecten dat kan worden opgenomen bij gebruik van de optie Referentie instellen is 500.
Referentie wissen Deze opdracht wordt vervangen door de opdracht Referentie instellen als een referentie is ingesteld. Als u deze opdracht kiest, wordt de eerder ingestelde referentie gewist en wordt de grafiek weer in de normale plotmodus weergegeven.
Klonen Hiermee maakt u een identieke kopie van de grafiek. Als een ontkoppelde grafiek wordt gekloond, wordt de kloon gekoppeld.
Volgorde

Dit submenu is alleen beschikbaar als de opdracht Ontwerpraster van het menu Beeld is geactiveerd of als de optie Altijd opmaakmenu-opdrachten tonen onder Gebruikersvoorkeuren: Ontwerp is ingeschakeld. Het menu bevat vier opdrachten voor het instellen van de opmaaklaag van de werkbladobjecten. Geldige laagnummers zijn -128 tot en met 127.

Naar bovenste laag
Hiermee stelt u de opmaaklaag van het object in op de hoogste waarde die momenteel wordt gebruikt door een object op het huidige werkblad.

Naar onderste laag
Hiermee stelt u de opmaaklaag van het object in op de laagste waarde die momenteel wordt gebruikt door een object op het huidige werkblad.

Een laag hoger
Hiermee verhoogt u het nummer van de opmaaklaag van het werkbladobject met één. De maximumwaarde is 127.

Een laag terug
Hiermee verlaagt u het nummer van de opmaaklaag van het werkbladobject met één. De laagste waarde is -128.


Alle selecties wissen Hiermee worden alle selecties in de dimensies en uitdrukkingen van de grafiek gewist.
Afdrukken... Hiermee opent u het dialoogvenster Afdrukken waarin u de afdrukinstellingen kunt opgeven.
Afdrukken als PDF...

Hiermee wordt het dialoogvenster Afdrukken geopend waarin de printer PDF-XChange 3.0 al is geselecteerd. Nadat u op de knop Afdrukken hebt geklikt, wordt om een bestandsnaam voor het PDF-uitvoerbestand gevraagd. Deze opdracht is alleen beschikbaar als er een PDF-printer beschikbaar is op het systeem.

Waarden naar Excel kopiëren De onderliggende gegevens (het equivalent van de standaard tabel van de grafiek) worden geëxporteerd naar Microsoft Excel, dat automatisch wordt gestart als het niet al geopend is. De tabel verschijnt in een nieuw Excel-werkblad. Voor deze functionaliteit moet Microsoft Excel 2007 of later op de computer zijn geïnstalleerd.
Exporteren... Hiermee opent u een dialoogvenster waarin u een afbeelding van de grafiek kunt opslaan naar een bestand. De afbeelding kan worden opgeslagen in jpg-, bmp- of gif-indeling.
Naar het Klembord kopiëren Dit trapsgewijze menu bevat de verschillende kopieeropties voor het werkbladobject.
Waarden
Hiermee kopieert u de waarden naar het Klembord in de vorm van een tabel.
Afbeelding
Hiermee kopieert u een afbeelding van het diagramobject naar het Klembord. In de afbeelding zijn de titelbalk en randen van het werkbladobject wel of niet opgenomen, afhankelijk van de instellingen op de pagina Gebruikersvoorkeuren: Exporteren.
Object
Hiermee wordt het gehele werkbladobject naar het Klembord gekopieerd, waarna u dit elders in de opmaak kunt plakken, of in een ander document dat binnen het huidige exemplaar van QlikView is geopend.
Gekoppelde objecten

Er wordt een menu geopend met de volgende opdrachten voor gekoppelde objecten.
Positie van gekoppelde objecten aanpassen
Alle gekoppelde objecten op alle werkbladen krijgen dezelfde positie en grootte als de gemarkeerde objecten.
Koppeling van dit object opheffen/Koppeling van objecten opheffen
De koppeling tussen de objecten wordt verbroken, waardoor er verschillende objecten met verschillende object-ID's ontstaan.

Minimaliseren Hiermee wordt het object verkleind tot een pictogram. Klikken op het pictogram op de titelbalk van het object (indien weergegeven) heeft hetzelfde effect. Deze opdracht is alleen beschikbaar als minimaliseren is toegestaan in het dialoogvenster Eigenschappen van het object op de pagina Titelbalk.
Maximaliseren Het object wordt vergroot om het werkblad op te vullen. Klikken op het pictogram op de titelbalk van het object (indien weergegeven) heeft hetzelfde effect. Deze opdracht is alleen beschikbaar als maximaliseren is toegestaan in het dialoogvenster Eigenschappen van het object op de pagina Titelbalk.
Herstellen Hiermee herstelt u het vorige formaat en de vorige locatie van een geminimaliseerd of gemaximaliseerd object. Dubbelklikken op het pictogram van een geminimaliseerd object of klikken op het pictogram op de titelbalk van het object (indien weergegeven) van een gemaximaliseerd object heeft hetzelfde effect. Deze opdracht is alleen beschikbaar voor geminimaliseerde of gemaximaliseerde objecten.
Help Hiermee wordt de QlikView Help geopend.
Verwijderen Hiermee wordt het geselecteerde werkbladobject van het werkblad verwijderd.

Grafiekeigenschappen: Algemeen

Op de pagina Algemeen kunt u eigenschappen instellen als titels en grafiektype. Het is de eerste pagina in de wizard Snelle grafiek en in het dialoogvenster Grafiekeigenschappen.

Vensternaam

De titel die moet worden weergegeven in de koptekst van het venster. De titel kan ook worden gedefinieerd als een berekende formule. De tekst van het label wordt dan dynamisch bijgewerkt. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen. Hierin kunt u lange formules eenvoudiger bewerken.

Zie: Uitdrukkingssyntaxis voor berekende formules

Titel in grafiek tonen

Standaard wordt het label van de eerste gedefinieerde uitdrukking ingesteld als grafiektitel. Schakel het selectievakje uit als u geen grafiektitel wilt weergeven. Als u de oorspronkelijke titel wilt weergeven, schakelt u het selectievakje gewoon in. De titel kan ook worden gedefinieerd als een berekende formule. De tekst van het label wordt dan dynamisch bijgewerkt. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen. Hierin kunt u lange formules eenvoudiger bewerken. De grafiektitel wordt niet weergegeven in draaitabellen of standaard tabellen.

Zie: Uitdrukkingssyntaxis voor berekende formules

Titelinstellingen Klik op de knop Titelinstellingen om geavanceerde instellingen voor de grafiektitel te definiëren.
Afdrukinstellingen

Als u op de knop Afdrukinstellingen klikt, wordt het dialoogvenster Afdrukinstellingen geopend waarin u marges en de opmaak van kop- en voetteksten kunt definiëren. Het dialoogvenster Afdrukinstellingen bevat twee pagina's: Afdrukken: Opmaak en Afdrukken: Koptekst/voettekst.

Zie: Afdrukken: Opmaak en Afdrukken: Koptekst/voettekst

Alternatieve status Kies een van de beschikbare statussen in de lijst. De volgende alternatieve statussen zijn altijd beschikbaar.
Overgenomen
De werkbladen en werkbladobjecten hebben altijd de status overgenomen, tenzij de QlikView-ontwikkelaar anders beslist. Deze instelling wordt overgenomen van het object op het bovenliggende niveau: een grafiek in een werkblad krijgt dezelfde instellingen als het werkblad als overgenomen wordt gekozen.
Standaardstatus
Dit is de status waarbij de meeste QlikView-activiteiten plaatsvinden. Deze wordt aangeduid met $. Het QlikView-document bevindt zich altijd in de standaardstatus.
Object-ID

Deze ID wordt gebruikt voor macrodoeleinden. Aan elk werkbladobject wordt een unieke ID toegewezen. Het is aan te bevelen in de ID alleen alfanumerieke tekens te gebruiken. Bij grafieken begint de ID met CH01. Gekoppelde objecten hebben dezelfde object-ID. U kunt dit ID-nummer later bewerken.

Zie: Interne Macro Interpreter

Ontkoppeld Als u deze optie inschakelt, wordt de grafiek ontkoppelt. De grafiek wordt dan niet meer dynamisch bijgewerkt als er selecties worden gemaakt.
Alleen-lezen Als deze optie is ingeschakeld, wordt de grafiek alleen-lezen. Dit betekent dat u geen selecties kunt maken door met de muis te klikken of te slepen in de grafiek.
Berekeningsvoorwaarde Door een uitdrukking in dit tekstvak te typen, stelt u een voorwaarde in. De grafiek wordt dan alleen weergegeven als hieraan is voldaan. Als niet aan de voorwaarde is voldaan, wordt de tekst "Niet voldaan aan berekeningsvoorwaarde" weergegeven in de grafiek. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.
Grafiektype In de groep Grafiektype selecteert u de basisopmaak van de grafiek. Zie Grafiektypen voor meer informatie over de afzonderlijke grafiektypen.
Snelle wijziging door typen In deze groep kunt u een pictogram in de grafiek activeren waarmee de gebruiker het grafiektype kan wijzigen zonder het eigenschappenvenster voor de grafiek te gebruiken.
Toegestane typen
In deze lijst kunt u selecteren welke grafiektypen moeten worden weergegeven in de keuzelijst. De functie Snelle typewijziging kan alleen worden ingeschakeld als er ten minste twee typen zijn geselecteerd.
Voorkeurspositie pictogram
In grafieken kan het pictogram voor snelle typewijziging worden geplaatst in de grafiek of in de titelbalk van het werkbladobject. In tabelgrafieken is de titelbalk de enige optie.
Gebruikersformaat opnieuw instellen Door op deze knop te klikken, herstelt u alle door de gebruiker aangepaste formaten van legenda's, titels, enzovoort in grafieken. De docking van afzonderlijke elementen wordt niet veranderd.
Gebruikersdocking opnieuw instellen Door op deze knop te klikken herstelt u de door de gebruiker aangepaste docking van legenda's, titels, enzovoort in grafieken.
Foutberichten

Het dialoogvenster Aangepaste foutberichten wordt geopend.

Zie: Aangepaste foutberichten

Referentiemodus Opties voor het tekenen van de referentie-achtergrond als u gebruikmaakt van de optie Referentie instellen in het contextmenu van de grafiek. Deze instelling is alleen zinvol voor bepaalde grafieken.

Grafiekeigenschappen: Dimensies

De pagina Grafiekeigenschappen: Dimensies kan worden geopend door met de rechtermuisknop op een grafiek te klikken en Eigenschappen te selecteren of door het pictogram Eigenschappen te selecteren in het menu Object als de grafiek actief is.

Bij het maken van een grafiek moet u zich twee vragen stellen:

  • Wat wilt u zien in de grafiek? Waar moet de grootte van de staven in een staafgrafiek naar verwijzen? Het antwoord is bijvoorbeeld de "totale omzet". Dit wordt ingesteld op het tabblad Uitdrukkingen.
  • Op welke waarde wilt u de gegevens groeperen? Welke veldwaarden wilt u gebruiken als label voor de staven in het staafgrafiek? Het antwoord is bijvoorbeeld "op land". Dit wordt ingesteld op het tabblad Dimensies.

In een grafiek kunnen een of meer dimensies worden weergegeven. Het maximumaantal dimensies is afhankelijk van het gebruikte grafiektype, de complexiteit van de gegevens en het beschikbare geheugen. In cirkel-, lijn- en spreidingsgrafieken kunnen maximaal twee dimensies worden weergegeven, in staafgrafieken en blok- en rastergrafieken drie. In radar- en trechtergrafieken kan maar een dimensie worden weergegeven en in metergrafieken worden helemaal geen dimensies gebruikt. Als er meer dimensies zijn gedefinieerd, worden deze genegeerd.

De waarden voor een grafiekdimensie zijn afkomstig uit een veld dat wordt gedefinieerd op de pagina Grafiekeigenschappen: Dimensies. Een dimensie kan niet alleen uit één veld bestaan, maar ook uit een groep velden (zie Groepen bewerken hieronder).

Een dimensie kan een veld, een groep velden of een uitdrukking (berekende dimensie) zijn. Het kan tevens een synthetisch gemaakte dimensie zijn

Zie: Functies voor synthetische dimensies

Verplaats velden heen en weer door deze te selecteren (via klikken of Ctrl-klikken) en de knoppen Toevoegen> of <Verwijderen te gebruiken, of door direct te dubbelklikken op uw selecties.

Grafiekdimensies kunnen ook worden berekend aan de hand van een uitdrukking.

Deze eigenschappenpagina wordt gebruikt voor het definiëren van dimensies.

Beschikbare velden/groepen

Lijst met alle velden/veldgroepen die kunnen worden gebruikt als dimensie, die dus in een standaard staafgrafiek kunnen worden aangegeven op de x-as. Veldengroepen worden voorafgegaan door een verticale pijl voor drill-down groepen of een kromme pijl voor cyclische groepen. Groepen worden gedefinieerd op de pagina Documenteigenschappen: Groepen. Selecteer de te gebruiken/verwijderen items door erop te klikken. Gebruik de knop Toevoegen > of de knop < Verwijderen om de items naar de gewenste kolom te verplaatsen.
Het aantal dimensies dat kan worden weergegeven, wisselt afhankelijk van het type grafiek.
Alle velden die voorkomen in meer dan één interne tabel worden voorafgegaan door een sleutelsymbool. In cirkel-, lijn- en spreidingsgrafieken kunnen niet meer dan twee dimensies worden weergegeven. In staafgrafieken kunnen tot drie dimensies worden getoond.

Zie: Documenteigenschappen: Groepen

Systeemvelden tonen Als deze optie wordt geselecteerd, worden de systeemvelden weergegeven in de kolom Beschikbare velden/groepen.
Velden van tabel tonen Hier bepaalt u welke velden/groepen in de lijst Beschikbare velden/groepen verschijnen. In de vervolgkeuzelijst wordt standaard de optie Alle tabellen weergegeven.
De optie Alle tabellen (gekwalificeerd) toont de velden die zijn gekwalificeerd via de naam van de tabel(len) waarin deze voorkomen. Dat betekent dat de sleutelvelden (de verbindende velden) meer dan één keer in de lijst voorkomen. (Deze optie wordt alleen gebruikt voor weergavedoeleinden en heeft niets te maken met het Qualify van velden in het load-script.)
Het is ook mogelijk de velden van één tabel per keer te bekijken. Beschikbare groepen worden altijd weergegeven in de lijst.
Groepen bewerken... Via deze knop gaat u rechtstreeks naar de pagina Documenteigenschappen: Groepen, waarop veldgroepen die u wilt gebruiken als dimensies, kunnen worden gedefinieerd.
Animatie toevoegen... Hiermee wordt het dialoogvenster Animatie geopend, waarmee u de eerste dimensie voor animatie van de grafiek kunt gebruiken. Animatie is alleen beschikbaar voor bitmapgrafieken, met uitzondering van cirkelgrafieken. Er zijn enkele functionele beperkingen van toepassing als u animatie gebruikt.
Trellis... Hiermee wordt het dialoogvenster Trellis instellingen geopend, waarin u een reeks grafieken kunt maken die zijn gebaseerd op de eerste dimensie. Elk type bitmapgrafiek kan worden omgezet in een Trellis-weergave.
Gebruikte dimensies

In deze lijst worden de dimensies weergegeven die momenteel zijn geselecteerd voor de grafiek. Het aantal dimensies dat kan worden gebruikt, is afhankelijk van het type grafiek. Als er meer dimensies worden geselecteerd dan is toegestaan voor het grafiektype, worden de overtollige dimensies genegeerd. Als dimensies worden gebruikt in tabellen, kunnen de gegevenscellen dynamisch worden opgemaakt met behulp van uitdrukkingen voor kenmerken. Als een kenmerkuitdrukking wordt ingevoerd voor een dimensie, verandert het bijbehorende pictogram van grijs in kleur, of van grijs in zwart zoals voor Tekstopmaak. Deze instellingen hebben prioriteit op de grafiekinstellingen. Klik op het uitvouwpictogram "+" voor een uitdrukking om de tijdelijke aanduidingen of de kenmerkuitdrukking van de dimensie weer te geven.
Achtergrondkleur
Dubbelklik op Achtergrondkleur om een kenmerkuitdrukking voor de berekening van de celachtergrondkleur van de dimensiecel in te voeren. De gebruikte uitdrukking moet een geldige kleurweergave retourneren (een getal dat de rood-, groen- en blauwwaarden weergeeft zoals gedefinieerd in Visual Basic), Dit wordt gedaan door een van de speciale kleurfuncties voor grafieken te gebruiken. Als het resultaat van de uitdrukking geen geldige kleurrepresentatie oplevert, wordt standaard zwart gebruikt als kleur.
Tekstkleur
Dubbelklik op Tekstkleur om een kenmerkuitdrukking voor de berekening van de tekstkleur van de dimensiecel in te voeren. De gebruikte uitdrukking moet een geldige kleurweergave retourneren (een getal dat de rood-, groen- en blauwwaarden weergeeft zoals gedefinieerd in Visual Basic), Dit wordt gedaan door een van de speciale kleurfuncties voor grafieken te gebruiken. Als het resultaat van de uitdrukking geen geldige kleurrepresentatie oplevert, wordt standaard zwart gebruikt als kleur.

Zie: Kleurfuncties

Tekstopmaak
Dubbelklik op Tekstopmaak om een kenmerkuitdrukking in te voeren voor de berekening van de tekenstijl van tekst in de tabelcel voor elke dimensiecel. De uitdrukking die wordt gebruikt voor de tekstopmaak moet een tekenreeks opleveren met '<B>' voor vette tekst, '<I>' voor cursieve tekst en/of '<U>' voor onderstreepte tekst.

Met de knoppen Naar boven en Naar beneden kunnen dimensies in de lijst Gebruikte dimensies worden gesorteerd.

Berekende dimensie toevoegen...

Hiermee wordt een nieuwe dimensie toegevoegd en geopend voor bewerking in het dialoogvenster Uitdrukking bewerken. Een dimensie van een grafiek is vaak een veld maar de dimensie kan ook dynamisch worden berekend. Een berekende dimensie bestaat uit een uitdrukking die betrekking heeft op een of meer velden. Alle standaardfuncties kunnen worden gebruikt. Aggregatiefuncties mogen niet worden gebruikt, maar de functie Aggr - grafiekfunctie kan worden opgenomen voor geneste aggregatie.

Zie: Uitdrukkingssyntaxis voor berekende formules

Bewerken... Hiermee wordt de dimensie geopend voor bewerking in het dialoogvenster Uitdrukking bewerken. Zie Berekende dimensie toevoegen... hierboven voor meer informatie over berekende dimensies.
Instellingen voor geselecteerde dimensie

In deze groep vindt u instellingen voor afzonderlijke dimensies.
Voorwaarde inschakelen
Als dit selectievakje wordt ingeschakeld wordt de dimensie dynamisch weergegeven of verborgen, afhankelijk van de waarde van een ingevoerde voorwaardelijke uitdrukking door op de knop ... in het onderstaande tekstvak te klikken.

Onderdrukken als waarde leeg is
Als deze optie is ingeschakeld, wordt het geselecteerde veld in de Gebruikte dimensies erboven niet weergegeven in de grafiek als de waarde leeg is.
Alle waarden tonen
Schakel deze optie in om alle dimensiewaarden weer te geven ongeacht de selectie. Aangezien de uitdrukkingswaarde nul is voor uitgesloten dimensiewaarden, moet de optie Null- (leeg-)waarden weglaten op de pagina Presentatie worden uitgeschakeld zodat Alle waarden tonen werkt. Alle waarden tonen is niet van toepassing als u een uitdrukking als een dimensie gebruikt.
Legenda tonen
Als Legenda tonen is ingeschakeld, worden de 'namen' van veldwaarden weergegeven langs de x-as.
Label
Als de optie Label is ingeschakeld, wordt de naam van het veld weergegeven. U kunt labels bewerken in het tekstvak eronder. De titel kan ook worden gedefinieerd als een berekende labeluitdrukking voor het dynamisch bijwerken van de labeltekst. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen. Hierin kunt u lange formules eenvoudiger bewerken.

Zie: Uitdrukkingssyntaxis voor berekende formules

Geavanceerd...
Met deze knop opent u het dialoogvenster Geavanceerde veldinstellingen met instellingen voor de afbeeldingsrepresentatie van veldwaarden en met speciale tekstzoekopties.

Zie: Geavanceerde veldinstellingen

Opmerking
Een commentaarveld waarin de geselecteerde dimensie kan worden beschreven. De opmerking kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.
Pagina-einden
Deze instelling is alleen van toepassing op het gebruik van pagina-einden in de afdruk van een draaitabel of standaard tabel. Er zijn drie modi beschikbaar, met de volgende effecten:

Geen breekpunten
Hierbij worden alleen pagina-einden ingevoerd aan het einde van elke pagina, indien vereist.
Voorwaardelijk afbreken
Hiermee wordt een pagina-einde ingevoegd, tenzij alle rijen met de volgende dimensiewaarde op de huidige pagina passen.
Geforceerde breekpunten
Hiermee wordt een pagina-einde ingevoegd telkens wanneer de dimensiewaarde verandert.

Grafiekeigenschappen: Dimensiegrenzen

Dimensiegrenzen kunnen worden ingesteld voor alle grafiektypen, behalve metergrafieken en draaitabellen.

Op het tabblad Dimensiegrenzen stelt u het aantal dimensiewaarden in dat wordt weergegeven in een specifieke grafiek.

Voordat u dit gaat doen, is het van belang om het effect te beschrijven dat de drie opties in de vervolgkeuzelijst opleveren. De vervolgkeuzelijst bevat drie waarden: Eerste, Grootste en Kleinste. De waarden bepalen hoe de rekenengine de waarden sorteert die worden geretourneerd aan de grafiekengine. Het is een vereiste om een van deze opties te selecteren als u de dimensie wilt beperken. De sortering vindt uitsluitend plaats voor de eerste uitdrukking, behalve bij draaitabellen waarbij de primaire sortering mogelijk prioriteit heeft boven de sortering van de eerste dimensie.

Deze eigenschappenpagina wordt gebruikt voor het definiëren van dimensiegrenzen. Elke dimensie in de grafiek wordt apart geconfigureerd.

Limieten

Hiermee beperkt u de waarden die worden weergegeven met de eerste uitdrukking
Deze eigenschappen worden gebruikt om te bepalen hoeveel dimensiewaarden worden weergegeven in de grafiek, op basis van instellingen die hieronder worden uitgevoerd.

Alleen tonen
Selecteer deze optie als u de het eerste, grootste of kleinste x aantal waarden wilt weergeven. Als deze optie is ingesteld op 5, worden er vijf waarden weergegeven. Als voor de dimensie Overige tonen is ingeschakeld, neemt het segment Overige één van de vijf weergaveposities in beslag.

Met de optie Eerste worden de rijen geretourneerd op basis van de opties die zijn geselecteerd op het tabblad Sorteren van het eigenschappenvenster. Als de grafiek een standaard tabel is, worden de rijen geretourneerd op basis van de primaire sortering op dat moment. Met andere woorden, een gebruiker kan de weergave van de waarden wijzigen door te dubbelklikken op een willekeurige koptekst en die kolom tot de primaire sortering te maken.

De optie Hoogste retourneert de rijen in aflopende volgorde gebaseerd op de eerste uitdrukking in de grafiek. Bij gebruik in een strakke tabel blijven de weergegeven dimensiewaarden consistent terwijl de uitdrukkingen op interactieve wijze worden gesorteerd. De dimensiewaarden veranderen (mogelijk) als de volgorde van de uitdrukkingen wordt gewijzigd.

De optie Laagste retourneert de rijen in oplopende volgorde gebaseerd op de eerste uitdrukking in de grafiek. Bij gebruik in een strakke tabel blijven de weergegeven dimensiewaarden consistent terwijl de uitdrukkingen op interactieve wijze worden gesorteerd. De dimensiewaarden veranderen (mogelijk) als de volgorde van de uitdrukkingen wordt gewijzigd.

Voer het aantal weer te geven waarden in. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.

Alleen waarden tonen die gelijk zijn aan:
Selecteer deze optie om alle dimensiewaarden weer te geven die voldoen aan de opgegeven voorwaarde voor deze optie. Selecteer om waarden weer te geven op basis van een percentage van het totaal of op basis van een exacte hoeveelheid. De optie relatief aan het totaal maakt een relatieve modus mogelijk die vergelijkbaar is met de optie Relatief op het tabblad Uitdrukkingen van het eigenschappenvenster. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.

Alleen waarden tonen die accumuleren tot:
Als deze optie is geselecteerd, worden alle rijen tot aan de huidige rij geaccumuleerd en wordt het resultaat vergeleken met de waarde die is ingesteld in de optie. De optie relatief aan het totaal maakt een relatieve modus mogelijk die vergelijkbaar is met de optie Relatief op het tabblad Uitdrukkingen van het eigenschappenvenster en vergelijkt de geaccumuleerde waarden (op basis van eerste, grootste of kleinste waarden) met het algehele totaal. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen. Selecteer Inclusief grenswaarden om de dimensiewaarde die de vergelijkingswaarde bevat op te nemen.

Zie: Uitdrukkingssyntaxis voor berekende formules

Opmerking: Negatieve waarden worden niet meegenomen bij het berekenen van het totaal van de geaccumuleerde beperkingen. Wij adviseren uw geen relatieve beperkingen te gebruiken voor velden die negatieve waarden kunnen bevatten.
Opmerking: Als u een grens toevoegt aan een berekende dimensie en de gegevens worden gesorteerd op dezelfde berekende dimensie, wordt de dimensiegrens toegepast vóór de sorteervolgorde.
Opties Overige tonen
Als deze optie wordt ingeschakeld, resulteert dit in een segment Overige in de grafiek. Alle dimensiewaarden die niet aan de vergelijkingscriteria voor de weergavebeperkingen voldoen, worden gegroepeerd in het segment Overige. Als er dimensies zijn na de geselecteerde dimensie, wordt met Inwendige dimensies samenvouwen bepaald of individuele waarden voor de daarop volgende/inwendige dimensies worden weergegeven in de grafiek.

Label
Voer de naam in die moet worden weergegeven in de grafiek. Als geen tekst wordt ingevoerd, wordt de tekst van de uitdrukking gebruikt als label. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.

Totaal tonen
In de grafiek wordt een totaal weergegeven voor de geselecteerde dimensie als deze optie is ingeschakeld. Dit totaal gedraagt zich anders dan het uitdrukkingstotaal, dat nog steeds wordt geconfigureerd op het tabblad Uitdrukkingen van het eigenschappenvenster.

Label
Voer de naam in die moet worden weergegeven in de grafiek. Als geen tekst wordt ingevoerd, wordt de tekst van de uitdrukking gebruikt als label. De waarde kan worden ingevoerd als berekende formule. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen.

Algemene groeperingsmodus
Deze optie is alleen van toepassing op inwendige dimensies. Als deze optie is ingeschakeld, worden de beperkingen uitsluitend berekend voor de geselecteerde dimensie. Alle eerdere dimensies worden genegeerd. Als deze optie is uitgeschakeld, worden de beperkingen berekend op basis van alle voorafgaande dimensies.

Uitdrukkingstotalen vergeleken met dimensietotalen

Dimensietotalen worden gegenereerd door de rekenengine en worden vervolgens als aparte rijen (of dimensiewaarden) geretourneerd aan de grafiekengine. Dit heeft gevolgen voor de rij Overige. Het verschil tussen Uitdrukkingstotalen en Dimensietotalen wordt hieronder weergegeven.

Uitdrukkingstotalen en Dimensietotalen

Als Dimensietotalen wordt gebruikt, is het mogelijk subtotalen te hebben binnen een standaard tabel.

Grafiekeigenschappen: Uitdrukkingen

U kunt het tabblad Grafiekeigenschappen: Uitdrukkingen openen door met de rechtermuisknop te klikken op een grafiek of tabel en vervolgens Eigenschappen te kiezen in het menu Object.

Bij het maken van een grafiek moet u zich twee vragen stellen:

  • Wat moet de grootte van de staven, etc. voorstellen? Dit zijn de Uitdrukking(en) (bijv. som van NettoVerkoop).
  • Hoe moeten de gegevens worden gegroepeerd? Dit zijn de Dimensie(s) (bijv. per Land).
Opmerking: Het tabblad Uitdrukkingen verschilt per grafiek- en tabeltype. Als een optie grijs is, is deze niet beschikbaar voor het grafiek- of tabeltype.
Lijst met uitdrukkingen

De lijst met uitdrukkingen in het linker deelvenster is een complete boomstructuur met diverse besturingsopties.
Voor elke uitdrukking (of uitdrukkingsgroep) staat een uitvouwpictogram (een vierkantje met een ' + '). Door te klikken op het pictogram opent u de onderliggende subuitdrukkingen of kenmerkuitdrukkingen. Het pictogram verandert tegelijkertijd in een samenvouwpictogram ( '-'). Bepaalde tekenopties werken met subuitdrukkingen. Dit zijn twee of meer uitdrukkingen die samen het tekensymbool vastleggen (bijv. Aandelen of Boxplot, zie beschrijving hieronder).
Gegevens van een uitdrukking kunnen ook dynamisch worden opgemaakt met behulp van kenmerkuitdrukkingen. Klik op het uitvouwpictogram voor een uitdrukking om de aanduidingen voor kenmerkuitdrukkingen van de dimensies weer te geven. Dit zijn:

Achtergrondkleur
Bewerk de standaarduitdrukking voor Achtergrondkleur om de kenmerkuitdrukking te definiëren voor de berekening van de tekenkleur van het gegevenspunt. De berekende kleur heeft prioriteit ten opzicht van de standaardkleurselectie van QlikView. Als u gebruikmaakt van de kleurfuncties weet u zeker dat de kleur een geldige kleurrepresentatie is. Als het resultaat van de uitdrukking geen geldige kleurrepresentatie oplevert, wordt standaard zwart gebruikt als kleur. Op dezelfde wijze kunt u een aanvullende uitdrukking voor de Tekstkleur maken.

Zie: Kleurfuncties

Tekstkleur
Op dezelfde wijze als voor de achtergrondkleur (zie hierboven) kunt u een aanvullende uitdrukking voor de Tekstkleur maken.

Tekstopmaak
Bewerk de uitdrukking voor Tekstopmaak om een kenmerkuitdrukking in te voeren voor de berekening van de tekenstijl van tekst die is gekoppeld aan het gegevenspunt. (Voor tabellen: tekst in de tabelcel voor elke dimensiecel. De berekende tekstopmaak heeft prioriteit ten opzichte van de stijl van de tabel die is gedefinieerd in Grafiekeigenschappen: Stijl. De uitdrukking die wordt gebruikt voor de tekstopmaak moet een tekenreeks opleveren met '<B>' voor vette tekst, '<I>' voor cursieve tekst en/of '<U>' voor onderstreepte tekst. Plaats = voor de tekenreeks.

Cirkelgrafiek-pop-out
Klik op Cirkelgrafiek-pop-out om een kenmerkuitdrukking in te voeren waarmee wordt berekend of het segment van de cirkelgrafiek dat is toegewezen aan het gegevenspunt, moet worden getekend in een benadrukte "pop-out"-positie. Een kenmerkuitdrukking van dit type heeft alleen effect op cirkelgrafieken.

Staafverschuiving
Klik op Staafverschuiving om een kenmerkuitdrukking in te voeren voor de berekening van een beginwaarde voor de staaf die of het staafsegment dat is toegewezen aan het gegevenspunt. De beginwaarde kan positief of negatief zijn. De staaf of het segment wordt met deze waarde verschoven. Dit is bijvoorbeeld nuttig als u zogenaamde watervalgrafieken maakt. Een kenmerkuitdrukking van dit type heeft alleen effect op staafgrafieken.

Lijnstijl
Klik op Lijnstijl om een kenmerkuitdrukking in te voeren voor de berekening van de lijnstijl voor de lijn of het lijnsegment die of dat is toegewezen aan het gegevenspunt. Een kenmerkuitdrukking van dit type heeft alleen effect op combinatiegrafieken en lijn- en radargrafieken. De relatieve breedte van de lijn kan worden ingesteld met de tag <Wn>, waarbij n een vermenigvuldigingsfactor is die wordt toegepast op de standaardlijnbreedte van de grafiek. De waarde n moet een reëel getal zijn tussen 0,5 en 8. Voorbeeld: <W2,5>. U kunt de stijl van de lijn instellen door de tag <Sn> in te voegen, waarbij n een geheel getal is tussen 1 en 4 dat de gewenste stijl aangeeft (1=ononderbroken, 2=streepjes, 3=gestippeld, 4=stippel/streep). Voorbeeld: <S3>. De tags <Wn> en <Sn> kunnen vrijelijk worden gecombineerd, maar alleen de tag die het eerst is opgegeven, wordt toegepast. De tags moeten tussen enkele aanhalingstekens staan.

Waarde tonen
Klik op Waarde tonen om een kenmerkuitdrukking in te voeren waarmee wordt berekend of het getekende gegevenspunt moet worden aangevuld met een "waarde op gegevenspunt", zelfs als Waarden op gegevenspunten niet is geselecteerd voor de primaire uitdrukking. Als Waarden voor gegevenspunten is geselecteerd voor de primaire uitdrukking, wordt de kenmerkuitdrukking genegeerd. Een kenmerkuitdrukking van dit type heeft alleen effect op combinatiegrafieken en lijn-, cirkel-, trechter- en radargrafieken.

Toevoegen Klik op de knop Toevoegen als u nieuwe uitdrukkingen en subuitdrukkingen wilt maken. De optie is ook beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop in de lijst met uitdrukkingen klikt.
Verwijderen Klik op de knop Verwijderen om eerder gemaakte uitdrukkingen te verwijderen uit de lijst. De optie is ook beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop op een uitdrukking in de lijst met uitdrukkingen klikt.
Kopiëren De optie Kopiëren is alleen beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop op een uitdrukking of een sub-/attribuutuitdrukking in de lijst met uitdrukkingen klikt. Als u deze opdracht in een hoofduitdrukking gebruikt, worden alle gegevens en instellingen voor de uitdrukking (inclusief label) als XML naar het Klembord gekopieerd. De uitdrukking kan vervolgens worden teruggeplakt in dezelfde grafiek, of in een andere QlikView-grafiek in het hetzelfde of een ander document. Als u de opdracht voor een kenmerkuitdrukking gebruikt, wordt alleen de definitie van de kenmerkuitdrukking gekopieerd. Een kenmerkuitdrukking kan vervolgens worden geplakt in een hoofduitdrukking in dezelfde of een andere grafiek.
Exporteren... De optie Exporteren... is alleen beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop op een uitdrukking in de lijst met uitdrukkingen klikt. Als u deze opdracht in een hoofduitdrukking gebruikt, kunt u alle gegevens en instellingen voor de uitdrukking (inclusief label) naar een XML-bestand exporteren. De uitdrukking kan vervolgens worden teruggeïmporteerd in dezelfde grafiek, of in een andere QlikView-grafiek in het hetzelfde of een ander document. Met deze opdracht opent u het dialoogvenster Uitdrukking exporteren als, waarin u het doel voor het exportbestand kunt kiezen. Het bestand krijgt de extensie Ex.xml.
Plakken De optie Plakken is alleen beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop op een uitdrukking of sub-/attribuutuitdrukkingen in de lijst met uitdrukkingen klikt. Als u een hoofduitdrukking eerder naar het Klembord hebt gekopieerd, kunt u deze in het lege gebied in de lijst met uitdrukkingen plakken. Hiermee maakt u een nieuwe uitdrukking die identiek is aan de gekopieerde uitdrukking. Als u een kenmerkuitdrukking hebt gekopieerd, kunt u deze in een hoofduitdrukking plakken.
Importeren De optie Importeren is alleen beschikbaar in het contextmenu dat verschijnt wanneer u met de rechtermuisknop in het lege gebied in de lijst met uitdrukkingen klikt. Met deze opdracht opent u een dialoogvenster waarin u kunt bladeren naar eerder geëxporteerde uitdrukkingen. De geïmporteerde uitdrukking wordt als een nieuwe uitdrukking in de grafiek weergegeven.
Naar boven
Naar beneden
Als meerdere uitdrukkingen worden weergegeven, kunt u deze sorteren met de knoppen Naar boven en Naar beneden. Hiermee past u de volgorde aan waarin kolommen en dergelijke worden weergegeven in de grafiek.
Groeperen Met de knop Groep kunt u uitdrukkingen groeperen in een of meer cyclische groepen. Dit is alleen mogelijk als er twee of meer uitdrukkingen beschikbaar zijn. In de QlikView-opmaak kunt u de uitdrukkingen doorlopen die bij één groep horen door te klikken op het cycluspictogram dat wordt weergegeven in de grafiek (= Cyclusgroep). Klik met de rechtermuisknop op dit cycluspictogram om een pop-up-lijst te openen met de uitdrukkingen die horen bij de groep en momenteel niet worden gebruikt. Selecteer een uitdrukking in de lijst.
Opmerking:

Verwar Cyclusgroep niet met cyclische groepen!

Zie: Niet-hiërarchische groepen (cyclisch)

Groep opheffen Door een uitdrukking te selecteren die hoort bij een groep, en op Groep opheffen te klikken, haalt u de uitdrukking op uit de groep. Als er na extractie maar één uitdrukking overblijft in de cyclusgroep, wordt deze laatste uitdrukking ook opgehaald en wordt de groep verwijderd.