Wizard Inline-gegevens

Het dialoogvenster wizard Inline-gegevens kan worden geopend via het menu Invoegen, Load-opdracht, Inline laden. Het dialoogvenster wordt gebruikt om opdrachten van het type Inline laden in het script te maken.

Het dialoogvenster lijkt op een spreadsheet en werkt ongeveer op dezelfde manier. Rekenformules worden in dit spreadsheet echter niet geëvalueerd zoals in bijvoorbeeld Microsoft Excel.

Elke kolom vertegenwoordigt een te laden veld in QlikView door middel van een inline-tabel. Elke rij is een record in de tabel. Een gegevenscel kan worden geselecteerd door erop te klikken. Vervolgens kunt u een waarde in de cel typen of plakken. Druk op Enter of een pijltoets om de waarde te accepteren en naar een andere cel te gaan.

De bovenste (label)rij is gereserveerd voor veldlabels. Dubbelklik in een labelcel om deze te bewerken. Als u geen waarden invoert in de labelrij, worden de veldnamen F1, F2 etc. gebruikt.

Menu Bewerken

Het menu Bewerken bevat enkele basisopdrachten voor bewerking.

Kolom invoegen Hiermee wordt een nieuwe lege kolom ingevoegd als een of meer kolommen zijn geselecteerd.
Kolom verwijderen Hiermee verwijdert u de geselecteerde kolommen.
Rij invoegen Hiermee wordt een nieuwe lege rij ingevoegd als een of meer rijen zijn geselecteerd.
Rij verwijderen Hiermee verwijdert u de geselecteerde rijen.

Menu Extra's

Het menu Extra bevat de opdracht Documentgegevens. Hiermee wordt de wizard Documentgegevens importeren geopend waarmee u veldwaarden kunt plakken vanuit alle bestaande velden in het document. In het dialoogvenster kunt u zien hoeveel veldwaarden een geselecteerd veld bevat. U kunt ook kiezen om alle waarden, geselecteerde waarden of uitgesloten waarden in te voegen in de wizard Inline.

Klik op OK om het dialoogvenster te sluiten en een opdracht Inline laden te genereren die de inhoud van het raster van het dialoogvenster weergeeft.