Menu Bestand

Het menu Bestand is een vervolgkeuzemenu aan de bovenkant van het scherm, dat de volgende opdrachten bevat:

Nieuw Hiermee wordt een nieuw QlikView-venster geopend waarin u een nieuw QlikView-bestand kunt maken.
Openen... Hiermee wordt een nieuw QlikView-venster geopend waarin u een QlikView-bestand of tabelbestand kunt openen. Bij het openen van een tabelbestand wordt automatisch de wizard Bestand gestart. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+O.
Openen in server... Hiermee wordt een dialoogvenster geopend waarin u verbinding kunt maken met een QlikView Server. U kunt vervolgens naar een document bladeren dat u wilt openen in de clientmodus.
Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+Shift+O.
Opmerking: Als u documenten opent als QlikView Server-client, zijn uw mogelijkheden voor het werken met het document beperkt, vergeleken met het openen van lokale documenten. Als client kunt u niet altijd werkbladobjecten toevoegen of verwijderen. Dit is alleen mogelijk als het document samenwerking ondersteunt. Werkbladen kunnen niet worden toegevoegd of verwijderd. U hebt bovendien geen toegang tot alle eigenschappenvensters en het script, en u kunt geen macro's wijzigen, gegevens opnieuw laden of het document opslaan.
Document vernieuwen Deze opdracht is alleen beschikbaar voor documenten die zijn geopend op een QlikView-server en alleen als er een nieuwe versie van het document beschikbaar is op de server. Als u Vernieuwen uitvoert, krijgt u toegang tot de nieuwste gegevens terwijl uw sessie behouden blijft, waaronder uw selecties en opmaakstatus.
URL openen... Hiermee wordt het dialoogvenster URL openen geopend. In dit dialoogvenster kunt u een geldige URL invoeren voor elke webpagina. De webpagina wordt geopend in een apart venster in QlikView. U kunt deze functie bijvoorbeeld gebruiken voor het QlikView Publisher Accesspoint of voor pagina's waarop QlikView Server-documenten worden getoond via de AJAX-clients. Net als bij gewone QlikView-documentvensters krijgt u toegang tot geopende webpagina's via het menu Venster.
FTP openen... Hiermee wordt een nieuw QlikView-venster geopend waarin u een QlikView-bestand of tabelbestand kunt openen vanaf een FTP-server. Bij het openen van een tabelbestand wordt automatisch de wizard Bestand gestart.
Sluiten Hiermee sluit u het actieve QlikView-bestand.
Favorieten Via dit trapsgewijze menu kunt u een lijst beheren van uw eigen favoriete documenten, onafhankelijk van de lijst Recente bestanden (zie hieronder).
Opslaan

Hiermee wordt de huidige configuratie van een QlikView-bestand opgeslagen. Gegevens, script en opmaak worden opgeslagen. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+S.

Als u een QlikView-document wilt delen met behulp van AJAX-clients, mag de bestandsnaam geen hekjes (#) bevatten.

Opslaan als...

Hiermee wordt de huidige configuratie opgeslagen in een nieuw QlikView-bestand onder een nieuwe naam. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: F12.

Als u een QlikView-document wilt delen met behulp van AJAX-clients, mag de bestandsnaam geen hekjes (#) bevatten.

Koppeling opslaan... Een koppeling naar een document op een QlikView-server wordt hiermee opgeslagen als een tekstbestand op een lokale computer. Het bestand heeft de extensie qvw, maar bevat geen gegevens of opmaak. Als u een dergelijk koppelingsdocument opent, wordt door QlikView geprobeerd opnieuw een verbinding te maken met de server en het document op de QlikView-server te openen. Deze opdracht is niet beschikbaar voor lokale documenten.
E-mail als bijlage... Alleen beschikbaar bij het werken met lokale documenten. Hiermee wordt een e-mailbericht gemaakt met een kopie van het huidige qvw-document als bijlage. De ontvanger van het e-mailbericht kan het qvw-document openen als hij of zij toegang heeft tot QlikView en voldoende toegangsrechten tot het document (als sectietoegangsbeveiliging wordt gebruikt). Als u deze opdracht wilt gebruiken, moet de e-mailclient op de computer worden geconfigureerd.
E-mail met bladwijzer als koppeling... Alleen beschikbaar bij het werken met QlikView Server-documenten. Hiermee wordt een e-mailbericht gemaakt met een URL-koppeling naar het huidige serverdocument. Een tijdelijke serverbladwijzer wordt gemaakt (inclusief opmaakstatus) en gecodeerd in de URL. De ontvanger van het e-mailbericht kan via de URL-koppeling het serverdocument openen en zien wat u ziet, als deze persoon beschikt over voldoende toegangsrechten voor het document en de gegevens daarin. Om deze opdracht te kunnen gebruiken moet de e-mailclient op de computer worden geconfigureerd. Serverbladwijzers zijn alleen beschikbaar als de QlikView Server hiervoor is geconfigureerd
Afdrukken... Hiermee wordt het standaarddialoogvenster Afdrukken geopend, waarmee u het huidige werkbladobject kunt afdrukken. Deze opdracht is niet beschikbaar bij keuzelijsten. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+P.
Afdrukken als PDF... Hiermee wordt het dialoogvenster Afdrukken geopend waarin de printer PDF-XChange 3.0 al is geselecteerd. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+Shift+P.
Mogelijke afdrukken... Hiermee wordt het standaarddialoogvenster Afdrukken geopend, waarmee u de mogelijke (geselecteerde en optionele) waarden van de huidige keuzelijst kunt afdrukken. Deze opdracht is alleen beschikbaar bij keuzelijsten.
Mogelijke waarden afdrukken als PDF... Deze opdracht moet u gebruiken voor het afdrukken van keuzelijsten en meervoudige keuzelijsten als PDF.
Werkblad afdrukken... Hiermee wordt het dialoogvenster Afdrukken geopend, waarmee u een afbeelding van het huidige werkblad kunt afdrukken.
Afdrukvoorbeeld... Hiermee wordt een voorbeeld van afdrukbare werkbladobjecten weergegeven
Bronbeheer Instellingen
Hiermee kan worden ingesteld welke MSSCCI-provider-dll (Microsoft Source Code Control Interface) moet worden gebruikt als er een project wordt toegevoegd of om een project van bronbeheer te verwerven.

Project toevoegen aan Bronbeheer
Hiermee wordt het geopende QlikView-document opgeslagen en worden automatisch een projectmap en projectbestanden gemaakt. Hiermee wordt het systeem voor bronbeheer gestart zodat het project aan Bronbeheer kan worden toegevoegd.

Project ophalen uit Bronbeheer
Hiermee wordt een project opgehaald uit Bronbeheer en wordt het QlikView-document opnieuw gemaakt met behulp van de projectbestanden. QlikView-gegevens worden niet opgeslagen in Bronbeheer. Om het document met de gegevens te vullen, moet de opdracht Opnieuw laden op het opnieuw gemaakte document worden uitgevoerd.

De nieuwste versie ophalen
Hiermee wordt de recentste versie uit het systeem voor bronbeheer opgehaald en het QlikView-document opnieuw gemaakt.

Inchecken
Hiermee wordt het QlikView-document opgeslagen en een incheckbewerking uitgevoerd voor het systeem voor bronbeheer. Deze kan bestaan uit vier verschillende bewerkingen voor bronbeheer elk met hun eigen dialoogvensters:
  • Nieuw gemaakte bestanden toevoegen.
  • De uitgecheckte status van bestanden opheffen die uit Bronbeheer verwijderd moeten worden.
  • De bestanden verwijderen die overeenkomen met de verwijderde werkbladen of werkbladobjecten die deel uitmaken van het bronbeheer.
  • Inchecken van gewijzigde bestanden.

Als het document niet was bijgewerkt voordat de incheckbewerking werd uitgevoerd, moet het document opnieuw worden geopend om de projectwijzigingen te kunnen laden die tijdens het oplossen van de conflicten eventueel worden geïntroduceerd.

 

Uitchecken ongedaan maken
Hiermee worden de wijzigingen ongedaan gemaakt. Als er lokaal gewijzigde bestanden zijn die niet zijn uitgecheckt in het systeem voor bronbeheer, worden deze bestanden uitgecheckt voordat de bewerking voor het ongedaan maken van het uitchecken wordt uitgevoerd. Met deze handeling wordt het QlikView-document opnieuw gemaakt door bestanden te verwijderen die zijn gemaakt maar niet ingecheckt en verwijzingen naar bestanden die wachten op verwijdering te herstellen.
Exporteren Inhoud exporteren...
Deze optie is alleen beschikbaar als een exporteerbaar werkbladobject actief is. Hiermee wordt de handeling Exporteren uitgevoerd in het menu Object van het werkbladobject.

Werkbladafbeelding exporteren...
Hiermee wordt een dialoogvenster geopend voor het opslaan van een afbeelding van het huidige werkblad naar een bestand.

Documentindeling exporteren
Hiermee opent u een dialoogvenster waarin u de indeling van het document kunt opslaan als XML-bestand. Er worden geen gegevens uit het document opgeslagen in het XML-bestand.
Script bewerken... Hiermee wordt het dialoogvenster Script bewerken geopend. Hierin kunt u scripts schrijven en uitvoeren waarmee databases kunnen worden geopend en waarmee er verbinding mee kan worden gemaakt.
Opnieuw laden Hiermee wordt het huidige laadscript uitgevoerd en worden gegevens opnieuw geladen naar het actieve QlikView-document. Dit is nodig als de inhoud van de database is gewijzigd sinds de laatste keer dat opnieuw laden is uitgevoerd. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+R.
Gedeeltelijk opnieuw laden Hiermee wordt het huidige load-script uitgevoerd, inclusief alle scriptopdrachten, zoals Drop table, en worden gegevens opnieuw geladen naar het actieve QlikView-document. Er worden echter alleen tabellen opnieuw geladen waarvan de load- en select-opdrachten worden voorafgegaan door de prefix Replace of Add. Gegevenstabellen waarop dit soort load- of select-opdrachten niet van invloed is, worden niet beïnvloed door het gedeeltelijk opnieuw laden. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+Shift+R.
Gegevens reduceren Opent een menu met de volgende twee opdrachten:

Mogelijke waarden behouden
Reduceert de QlikView-database door alle uitgesloten waarden te verwijderen.

Alle waarden verwijderen
Hiermee wordt een sjabloon gemaakt. Alle waarden worden uit de QlikView-database verwijderd, terwijl de databasestructuur en -opmaak behouden blijven.
Tabelweergave... Hiermee wordt het dialoogvenster Tabelweergave geopend waarin de structuur van de geladen gegevens kan worden bekeken in een grafische weergave van tabellen, velden en associaties. Deze opdracht kan ook worden aangeroepen met de volgende sneltoets: Ctrl+T.
Recente documenten Een lijst met de laatst gebruikte QlikView-documenten. Het aantal documenten dat wordt getoond, kan worden ingesteld in het dialoogvenster Instellingen: Gebruikersvoorkeuren. De standaardwaarde is 8. Het selecteren van een van deze staat gelijk aan de opdracht Openen.
Exit Hiermee worden de open documenten gesloten en wordt QlikView afgesloten.