Knop

In QlikView kunnen knoppen worden gemaakt en gedefinieerd om opdrachten of handelingen uit te voeren. Er zijn in principe drie typen knoppen: de start-/exportknop, de snelkoppelingsknop en de macroknop.

Als u met de rechtermuisknop op het object klikt, wordt het menu Knop: Object weergegeven. Het menu kan ook worden geopend via het menu Object als de knop het actieve object is.

Menu Object

Het menu Object voor knoppen wordt geopend door met de rechtermuisknop op het object te klikken. Dit menu bevat de volgende opdrachten:

Eigenschappen... Hiermee wordt het dialoogvenster Knopeigenschappen geopend, waarin een aantal parameters kan worden ingesteld.
Opmerkingen

Hiermee kunt u opmerkingen maken en uitwisselen over het huidige object.

Notities en opmerkingen

Volgorde

Dit submenu is alleen beschikbaar als de opdracht Ontwerpraster van het menu Beeld is geactiveerd of als de optie Altijd opmaakmenu-opdrachten tonen onder Gebruikersvoorkeuren: Ontwerp is ingeschakeld. Het menu bevat vier opdrachten voor het instellen van de opmaaklaag van de werkbladobjecten. Geldige laagnummers zijn -128 tot en met 127.

Naar bovenste laag
Hiermee stelt u de opmaaklaag van het object in op de hoogste waarde die momenteel wordt gebruikt door een werkbladobject op het huidige werkblad.

Naar onderste laag
Hiermee stelt u de opmaaklaag van het object in op de laagste waarde die momenteel wordt gebruikt door een werkbladobject op het huidige werkblad.

Een laag hoger
Hiermee verhoogt u het nummer van de opmaaklaag van het werkbladobject met één. De maximumwaarde is 127.

Een laag terug
Hiermee verlaagt u het nummer van de opmaaklaag van het werkbladobject met één. De laagste waarde is -128.


Verzenden naar Excel De tekst wordt geëxporteerd naar Microsoft Excel, dat automatisch wordt gestart als het programma nog niet geopend is. De tekst verschijnt in een enkele cel in een nieuw Excel-werkblad. Voor deze functionaliteit moet Microsoft Excel 2007 of later op de computer zijn geïnstalleerd.
Naar het Klembord kopiëren Dit trapsgewijze menu bevat de verschillende kopieeropties voor het werkbladobject.
Tekst
Hiermee kopieert u de tekst op de knop naar het Klembord.
Afbeelding
Hiermee kopieert u een afbeelding van het werkbladobject naar het Klembord. Op de afbeelding zijn de titelbalk en randen van het object wel of niet opgenomen, afhankelijk van de instellingen op de pagina Exporteren van het dialoogvenster Gebruikersvoorkeuren.
Object
Hiermee wordt het gehele werkbladobject naar het Klembord gekopieerd, waarna u dit elders in de opmaak kunt plakken, of in een ander document dat binnen het huidige exemplaar van QlikView is geopend.
Gekoppelde objecten

Er wordt een menu geopend met de volgende opdrachten voor gekoppelde objecten.
Positie van gekoppelde objecten aanpassen
Alle gekoppelde objecten op alle werkbladen krijgen dezelfde positie en grootte als de gemarkeerde objecten.
Koppeling van dit object opheffen/Koppeling van objecten opheffen
De koppeling tussen de objecten wordt verbroken, waardoor er verschillende objecten met verschillende object-ID's ontstaan.

Minimaliseren Hiermee wordt het object verkleind tot een pictogram. Klikken op het pictogram op de titelbalk van het object (indien weergegeven) heeft hetzelfde effect. Deze opdracht is alleen beschikbaar als minimaliseren is toegestaan in het dialoogvenster Eigenschappen van het object op de pagina Titelbalk.
Maximaliseren Het object wordt vergroot om het werkblad op te vullen. Klikken op het pictogram op de titelbalk van het object (indien weergegeven) heeft hetzelfde effect. Deze opdracht is alleen beschikbaar als maximaliseren is toegestaan in het dialoogvenster Eigenschappen van het object op de pagina Titelbalk.
Herstellen Hiermee herstelt u het vorige formaat en de vorige locatie van een geminimaliseerd of gemaximaliseerd object. Dubbelklikken op het pictogram van een geminimaliseerd object of klikken op het pictogram op de titelbalk van het object (indien weergegeven) heeft hetzelfde effect. Deze opdracht is alleen beschikbaar voor geminimaliseerde of gemaximaliseerde objecten.
Help Hiermee wordt de QlikView Help geopend.
Verwijderen Hiermee wordt het geselecteerde werkbladobject van het werkblad verwijderd.

Algemeen

In de groep Tekst kunt u de eigenschappen van de tekst op de knop opgeven.

Tekst

De tekst die u typt, wordt als label op de knop weergegeven. De tekst kan worden opgegeven als een berekende formule. U kunt de tekst op meerdere regels typen, die u van elkaar scheidt door op Enter te drukken.

Uitdrukkingssyntaxis voor berekende formules

Uitlijning De knoptekst kan links, gecentreerd of rechts worden uitgelijnd.

In de groep Achtergrond kunt u de achtergrond van de knop opgeven. In de vervolgkeuzelijst kunt u uit drie verschillende basisknopstijlen kiezen:

Lichtblauw Standaardinstelling voor nieuwe knoppen. Hiermee krijgt u een afgeronde knop met een driedimensionaal glazig uiterlijk.
Gewoon Hiermee krijgt u een traditionele QlikView-knop.
Systeemstandaard
Hiermee verkrijgt u een effen achtergrond in de kleur die in het besturingssysteem voor knoppen is gedefinieerd.
Afbeelding Hiermee maakt u een knop met een afbeelding. De afbeelding kan een statische afbeelding zijn of een gecombineerde afbeelding met een afbeelding voor de drie mogelijke toestanden van de knop (actief, inactief en ingedrukt).
Gecombineerde afbeelding
Selecteer dit keuzerondje en blader naar een afbeeldingsbestand door te klikken op de knop Afbeelding selecteren... om een bestand met een gecombineerde afbeelding voor de drie toestanden toe te wijzen aan de knop. Het afbeeldingsbestand moet uit drie afbeeldingen van de knop naast elkaar bestaan: de eerste voor de actieve knop, de tweede voor een ingedrukte knop en de derde voor een gedimde (inactieve) knop.
Enkele afbeelding
Selecteer dit keuzerondje en blader naar een afbeeldingsbestand door te klikken op de knop Afbeelding selecteren... om een bestand met één afbeelding toe te wijzen aan de knop. Ondersteunde afbeeldingtypen zijn onder meer jpg, png, bmp, gif en gif-animatie.
Kleur Schakel dit keuzerondje in als u de knop wilt weergeven met een gekleurde achtergrond (niet beschikbaar met de instelling Afbeelding). U kunt een kleur instellen als effen kleur of als kleurovergang in het dialoogvenster Kleurgebied. U opent dit door te klikken op de kleurknop.
Transparantie Hiermee stelt u de mate van transparantie van de achtergrond van een knop in. Bij 100% is de achtergrond volledig transparant. De transparantie wordt ook toegepast als er geen kleur of afbeelding wordt gebruikt voor de achtergrond.
Alternatieve status Kies een van de beschikbare statussen in de lijst. De volgende alternatieve statussen zijn altijd beschikbaar.
Overgenomen
De werkbladen en werkbladobjecten hebben altijd de status overgenomen, tenzij de QlikView-ontwikkelaar anders beslist. Deze instelling wordt overgenomen van het object op het bovenliggende niveau: een grafiek in een werkblad krijgt dezelfde instellingen als het werkblad als overgenomen wordt gekozen.
Standaardstatus
Dit is de status waarbij de meeste QlikView-activiteiten plaatsvinden. Deze wordt aangeduid met $. Het QlikView-document bevindt zich altijd in de standaardstatus.
Object-ID De unieke ID van de huidige knop. Bij aanmaak wordt aan elk object een unieke ID toegekend voor besturing via automatisering. De ID bestaat uit een combinatie van letters, waarmee het type object wordt aangegeven, en een nummer. Zo krijgt de eerste knop van een document altijd de ID BU01 toegekend. Gedeelde objecten hebben dezelfde object-ID. Een object-ID kan worden gewijzigd in een willekeurige andere tekenreeks die nog niet voor een ander werkbladobject, werkblad of bladwijzer in het document wordt gebruikt.
Voorwaarde inschakelen Aan de hand van de uitdrukking die u hier invoert, wordt de status van de knop bepaald. Als Uitdrukking 0 retourneert, wordt de knop uitgeschakeld; als de uitdrukking 1 retourneert, wordt de knop ingeschakeld. Als er geen uitdrukking wordt ingevoerd, wordt de waarde 1 verondersteld. Knoppen die zijn uitgeschakeld vanwege de onderliggende status kunnen niet door middel van een voorwaarde worden ingeschakeld.
Afdrukinstellingen... Als u op deze knop klikt, wordt het dialoogvenster Afdrukinstellingen geopend, waarin u de marges en de opmaak van koptekst/voettekst kunt opgeven.

Acties

Op deze pagina kunnen acties worden ingesteld voor bepaalde objecten:

  • knoppen
  • tekstobjecten
  • meters
  • lijn/pijl-objecten

Voorbeelden van acties zijn het starten van een externe toepassing of het exporteren van gegevens uit QlikView.

Toevoegen Hiermee wordt het dialoogvenster Actie toevoegen geopend waarin de acties voor het object worden gekozen. Kies het type actie in de lijsten. Welke parameters worden weergegeven op de pagina Acties, is afhankelijk van de gekozen actie. De acties worden uitgevoerd in de volgorde waarin ze in de lijst staan.
Verwijderen Hiermee verwijdert u de actie van het object.
Naar boven Hiermee wordt de geselecteerde actie naar boven verschoven in de lijst met acties.
Alternatieve status Hiermee wordt de status ingesteld waarnaar de actie verwijst. Deze instelling is alleen relevant voor acties die betrekking hebben op selecties of bladwijzers.

Dialoogvenster Actie toevoegen

De volgende acties kunnen worden toegevoegd vanuit het dialoogvenster Actie toevoegen. U kunt in alle velden met de knop ... een berekende formule invoeren.

Uitdrukkingssyntaxis voor berekende formules

Selectie

Selecteer in veld Hiermee selecteert u de waarden en velden die zijn opgegeven. In de Zoekreeks kunt u een zoekmasker opgeven. Met (A|B) selecteert u bijvoorbeeld zowel A als B. Aanhalingstekens zijn alleen vereist bij niet-numerieke waarden en kunnen bij numerieke waarden worden weggelaten.
Uitgesloten waarden selecteren Hiermee selecteert u de uitgesloten waarden in het opgegeven veld.
Selecteer mogelijke waarden Hiermee selecteert u de mogelijke waarden in het opgegeven veld.
Selectie wisselen Hiermee schakelt u tussen de huidige selectie en het opgegeven Veld en de Zoektekenreeks. In de Zoektekenreeks kunt u een zoekmasker opgeven. Met (A|B) selecteert u bijvoorbeeld zowel A als B.
Volgende Hiermee gaat u één stap vooruit in de lijst met selecties.
Vorige Hiermee gaat u één stap terug in de lijst met selecties.
Pareto-selectie Hiermee maakt u een Pareto-selectie in het opgegeven veld op basis van een uitdrukking en percentage. Met dit type selectie selecteert u de belangrijkste bijdragen aan een maat, in het algemeen in overeenstemming met een algemene 80/20-regel. Als u bijvoorbeeld wilt weten wie de belangrijkste klanten zijn die 80% van de omzet vertegenwoordigen, gebruikt u het volgende: Klant als veld, sum(Omzet) als uitdrukking en 80 als percentage.
Veld vergrendelen Hiermee vergrendelt u de selecties in het opgegeven veld.
Alles vergrendelen Hiermee vergrendelt u alle waarden in alle velden.
Ontgrendel veld Hiermee ontgrendelt u de selecties in het opgegeven veld.
Alles ontgrendelen Hiermee ontgrendelt u alle waarden in alle velden.
Alle selecties ontgrendelen en opheffen Hiermee ontgrendelt u alle waarden en wist u alle selecties in alle velden.
Selectie in andere velden opheffen Hiermee wist u de selecties in alle velden, met uitzondering van het opgegeven veld.
Alles wissen Hiermee wist u alle selecties, behalve vergrendelde selecties.
Veld wissen Hiermee wist u een specifiek veld.
Statusinhoud kopiëren Hiermee kopieert u de selectie van de Bronstatus naar de Doelstatus. Alleen beschikbaar als alternatieve statussen zijn gedefinieerd.
Statusinhoud wisselen Hiermee wisselt u de selecties om tussen Status 1 en Status 2. Alleen beschikbaar als alternatieve statussen zijn gedefinieerd.

Opmaak

Object activeren Hiermee activeert u het object dat wordt aangegeven door Object-ID. Deze functie werkt niet in AJAX-client.
Werkblad activeren Hiermee activeert u het werkblad dat wordt aangegeven door Werkblad-ID.
Het volgende werkblad activeren Hiermee opent u het volgende werkblad in het document.
Het vorige werkblad activeren Hiermee opent u het vorige werkblad in het document.
Object minimaliseren Hiermee minimaliseert u het object dat wordt aangegeven door Object-ID.
Object maximaliseren Hiermee maximaliseert u het object dat wordt aangegeven door Object-ID.
Object herstellen Hiermee herstelt u het object dat wordt aangegeven door Object-ID.
Statusnaam instellen Hiermee past u de opgegeven Status toe op het object dat wordt aangegeven door Object-ID. Alleen beschikbaar als er alternatieve statussen zijn gedefinieerd.

Bladwijzer

Bladwijzer oproepen

Hiermee past u een bladwijzer toe die wordt aangegeven door Bladwijzer-ID. Als twee bladwijzers dezelfde ID hebben, wordt de documentbladwijzer toegepast. U past de serverbladwijzer toe door Server\bladwijzer-ID op te geven. 

Bladwijzer maken

Hiermee maakt u een bladwijzer voor de huidige selectie. Geef Bladwijzer-ID en Bladwijzernaam op. Selecteer Verborgen om een verborgen bladwijzer te maken.

Bladwijzer vervangen

Hiermee vervangt u de bladwijzer die wordt aangegeven door Bladwijzer-ID door de huidige selectie.

Afdrukken

Object afdrukken

Hiermee drukt u het object af dat wordt aangegeven door Object-ID. Geef de Printer naam op als het object naar een andere printer dan de standaardprinter moet worden gezonden. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)

Werkblad afdrukken

Hiermee drukt u het werkblad af dat wordt aangegeven door Werkblad-ID. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.) Deze functie werkt niet in de AJAX-client.

Rapport afdrukken

Hiermee drukt u het rapport af dat wordt aangegeven door Rapport-ID. Geef de Printer naam op als het rapport naar een andere printer dan de standaardprinter moet worden gezonden. Schakel het selectievakje Toon dialoogvenster afdrukken in als u wilt dat het Windows-dialoogvenster Afdrukken wordt getoond. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)

Extern

Exporteren

Hiermee exporteert u een tabel die een specifieke set velden bevat. Alleen de records die van toepassing zijn op de gemaakte selectie, worden geëxporteerd. Klik op de knop Instellen op de pagina Acties om het dialoogvenster Actie instellingen exporteren. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)

Starten

Hiermee start u een extern programma. De volgende instellingen kunnen worden geconfigureerd in het dialoogvenster Acties:
Toepassing
Klik op Bladeren... om de toepassing te zoeken die moet worden gestart. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)
Bestandsnaam
Voer het pad in naar het bestand dat moet worden geopend met de hierboven opgegeven toepassing. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)
Parameters
Geef parameters op voor de opdrachtregel waarvan de toepassing wordt gestart. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)
Werkdirectory
Hiermee wordt de werkdirectory ingesteld voor de te starten toepassing. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)
Toepassing afsluiten als QlikView wordt gesloten
Hiermee wordt ervoor gezorgd dat de toepassing wordt afgesloten wanneer QlikView wordt gesloten. (Niet beschikbaar als reactieveroorzaker voor documenten en werkbladen.)
Deze functie werkt niet in AJAX-client.

URL openen

Met URL openen kunt u een URL naar een QlikView-document openen vanuit een ander QlikView-document (documentkoppeling). Met deze instelling wordt de URL in de standaard webbrowser geopend. Deze functie kan niet worden gebruikt als reactieveroorzaker voor documenten en werkbladen. Als u URL openen gebruikt, moet u de documentnaam met kleine letters in de actietekenreeks invoeren.

Gebruik waar mogelijk QlikView-document openen in plaats van URL openen.

QlikView-document openen

Met QlikView-document openen kunt u een QlikView-document openen vanuit een ander QlikView-document (documentkoppeling). De extensie van het doelbestand moet worden aangegeven. Deze functie kan niet worden gebruikt als reactieveroorzaker voor documenten en werkbladen. Relatieve paden voor het navigeren van het ene QlikView-document naar het andere worden in alle clients ondersteund, mits de gekoppelde documenten in dezelfde mapstructuur (mount) worden opgeslagen.

Voorbeelden

De volgende voorbeelden laten zien hoe u het bestandspad naar het doelbestand schrijft om de documentkoppeling in te stellen met QlikView-document openen.

Example: Bestand bevindt zich in dezelfde mapstructuur (dezelfde mount).

  • Als het doelbestand zich in dezelfde map bevindt:
    DestinationDoc.qvw
  • Als het doelbestand zich in een submap bevindt:
    SubFolder/DestinationDoc.qvw
  • Als het doelbestand zich in een bovenliggende map bevindt:
    ../DestinationDoc.qvw
  • Als het doelbestand zich in een bovenliggende en parallelle map bevindt:
    ../ParallelFolder/DestinationDoc.qvw

Example: Bestand bevindt zich in een andere mapstructuur (andere mount).

Het relatieve pad tussen verschillende mapstructuren wordt alleen in de Ajax-client ondersteund.

  • Als het doelbestand zich in een andere mapstructuur bevindt:
    ../DifferentMount/DestinationDoc.qvw

Example: Het koppelingspad gebruiken om een QlikView-document aan te wijzen

Het pad naar gekoppelde mappen instellen wordt alleen in de Ajax-client ondersteund.

  • Als het doelbestand zich in dezelfde gekoppelde map bevindt:
    \Mount\DestinationDoc.qvw
  • Als het doelbestand zich in een andere gekoppelde map bevindt:
    \DifferentMount\DestinationDoc.qvw
Opmerking: Documentkoppeling met gekoppelde mappen werkt niet met de Internet Explorer (IE)-plug-in.

Example: Het absolute pad gebruiken om een QlikView-document aan te wijzen

Het gebruik van absolute paden voor documentkoppeling wordt in de Ajax-client en in QlikView Desktop ondersteund.

  • Het absolute pad naar de lokale hoofdmap of mapstructuur:
    C:\...\DestinationDoc.qvw
  • Het absolute pad naar een netwerkshare:
    \\SharedStorage\...\DestinationDoc.qvw

Selecteer State overbrengen om de selecties van het oorspronkelijke document naar het doeldocument over te brengen. De selecties in het doeldocument worden eerst gewist.
Selecteer State op huidig toepassen om de selecties van het doeldocument te behouden en de selecties van het oorspronkelijke document daar bovenop toe te passen.

Opmerking: Gebruik van State op huidig toepassen kan onverwachte resultaten opleveren als de selecties in de twee documenten strijdig met elkaar zijn.

Selecteer In hetzelfde venster openen om het nieuwe document in hetzelfde browsertabblad te openen als bij het gebruik van de AJAX ZFC-client.

Opmerking: De actie QlikView-document openen wordt niet ondersteund voor niet-domeingebruikers bij gebruik van de Internet Explorer (IE)-plug-in.

Macro uitvoeren

Voer het pad en de naam in van de macro die moet worden uitgevoerd. Typ een willekeurige naam waarmee u later een macro kunt maken in het dialoogvenster Module bewerken, of een voer berekende uitdrukking in om dynamisch bij te werken.

Variabele instellen

Hiermee kent u een waarde toe aan de opgegeven variabele.

Toon info

Hiermee wordt de toegewezen informatie getoond, bijvoorbeeld een tekstbestand of een afbeelding voor het veld dat wordt aangegeven door Veld. Deze functie werkt niet in AJAX-client.

Dit document sluiten

Hiermee sluit u het actieve QlikView-document.

Opnieuw laden

Hiermee wordt het huidige document opnieuw geladen. Deze functie werkt niet in de AJAX-client en de plug-in IE.

Dynamisch bijwerken

Hiermee wordt een dynamische update uitgevoerd vand e gegevens in het momenteel geladen document. De opdracht voor de dynamische bijwerkactie moet worden ingevoerd in het veld Opdracht.

Het beoogde gebruik van Dynamisch bijwerken stelt een QlikView-beheerder in staat beperkte hoeveelheden gegevens in te voeren in een QlikView-document vanuit een enkele bron zonder het document opnieuw te laden. Vervolgens kan dan een analyse worden uitgevoerd door meerdere clients via een verbinding met QlikView Server.

Opmerking! De geüploade informatie wordt opgeslagen in RAM zodat alleen gegevens die worden toegevoegd of bijgewerkt met Dynamisch bijwerken verloren gaan als het document opnieuw wordt geladen.

In de volgende grammatica worden de mogelijke opdrachten en hun onderdelen beschreven die kunnen worden gebruikt met de functie Dynamisch bijwerken:

  • opdrachten ::= opdracht { “;” statement }
  • opdracht ::= insert-opdracht | update-opdracht| delete-opdracht | begin_transaction-opdracht | commit_transaction-opdracht
  • insert-opdracht ::= "INSERT" "INTO" ("*" | tabelnaam) veldenlijst "VALUES" waardenlijst {"," value_list} ["KEY" ["AUTO" | (" (" veldenlijst ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  • update-opdracht::= "UPDATE" ("*" | tabelnaam) set-clausule {"," | set_clause} "WHERE" voorwaarde ["AUTO" "INSERT"]
  • delete-opdracht ::= "DELETE" "FROM" ("*" | tabelnaam] "WHERE" voorwaarde
  • opdracht_begin-transactie ::= "BEGIN" ["TRANSACTION" | "TRAN"] [transactienaam]
  • opdracht_commit-transactie ::= "COMMIT" ["TRANSACTION" | "TRAN"] [transactienaam]
  • tabelnaam ::= ID | naam_tussen_aanhalingstekens
  • veldenlijst ::= "(" veldnaam {"," field_name} ")"
  • waardenlijst ::= "("waarde {"," value} ")"
  • set-clausule ::= "SET" veldnaam "=" willekeurige_geldige_niet-geaggregeerde_qlikview-uitdrukking
  • veldnaam ::= ID | tekenreeks tussen aanhalingstekens
  • waarde ::= ID | willekeurig_qlikview-getal | tekenreeks tussen aanhalingstekens
  • voowaarde ::= willekeurige_geldige_niet-geaggregeerde_qlikview-uitdrukking
  • ID ::= willekeurige_qlikview-ID
  • tekenreeks_tussen_aanhalingstekens ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Opmerking: Als u deze functie wilt gebruiken, moet Dynamisch bijwerken zowel zijn toegestaan in het document als op de server.
Opmerking: Acties die andere acties veroorzaken, zogeheten trapsgewijze acties, kunnen onvoorziene gevolgen hebben en worden niet ondersteund!
Opmerking:

Er zijn enkele beperkingen in het gedrag van bepaalde reactieveroorzakers voor macro's als u met documenten werkt op QlikView Server.

Macro's in QV-documenten op de QV-server

Dialoogvenster Actie instellingen exporteren

Selectie

In deze groep geeft u op welke velden moeten worden geëxporteerd.

Velden In het vak Velden wordt een lijst met beschikbare velden weergegeven.
Regels exporteren In dit vak worden de velden weergegeven die u hebt geselecteerd om te exporteren. De velden waarvoor u een meervoudige waarde hebt toegestaan, zijn aangegeven met een sterretje.
Toevoegen > Hiermee voegt u velden toe aan het vak Regels exporteren.
< Verwijderen Hiermee verwijdert u velden uit het vak Regels exporteren.
Naar boven Hiermee wordt het geselecteerde veld een plaats naar boven (naar links in de exporttabel) verschoven.
Naar beneden Hiermee wordt het geselecteerde veld een plaats naar beneden (naar rechts in de exporttabel) verschoven.
Meervoudige waarde (*) Als u een veld in het vak Regels exporteren selecteert en deze optie inschakelt, staat u toe dat het veld een meervoudige waarde heeft in de exportlijst.

Exporteren naar

In deze groep kiest u of u de waarden naar een bestand of naar het Klembord wilt kopiëren.

Bestand

Als u exporteert naar een bestand, moet u dit selectievakje inschakelen en de bestandsnaam invoeren. Als u geen bestandsnaam opgeeft, worden de waarden naar het Klembord geëxporteerd. De bestandsnaam kan ook worden ingevoerd als berekende formule.

Uitdrukkingssyntaxis voor berekende formules

Bladeren Hiermee opent u het dialoogvenster Bestand exporteren, waarin u kunt bladeren naar een bestand waarnaar u de waarden wilt exporteren.
Klembord Standaardinstelling. Als u boven geen bestandsnaam hebt opgegeven, worden de waarden naar het Klembord geëxporteerd.
Veldselecties Als deze optie is ingeschakeld, worden, voor elk geselecteerd veld, alle mogelijke veldwaarden in een rij in het exportbestand geplaatst, gescheiden door tabs.
Veldnamen meenemen Als deze optie is ingeschakeld, worden de veldnamen aan het begin van de regel geplaatst (als Veldselecties is geselecteerd), of in de eerste record (als Records is geselecteerd).
Records Als deze optie is ingeschakeld, wordt elk geselecteerd veld in een kolom in het exportbestand geplaatst, gescheiden door tabs.
Toevoegen aan bestaand bestand Als deze optie is ingeschakeld, worden de exportgegevens aan het exportbestand toegevoegd, als het bestand al bestaat. Bij het toevoegen aan een bestaand bestand worden labels niet geëxporteerd. Als het exportbestand niet bestaat, heeft deze optie geen betekenis.

Getalnotatie

Het is mogelijk dat bepaalde andere programma's moeite hebben met het correct verwerken van getallen met getalnotatie. QlikView biedt drie mogelijkheden voor getalnotatie van numerieke gegevens die worden geëxporteerd naar bestanden of het Klembord.

Nieuwe exportknoppen worden automatisch ingesteld volgens de standaardinstelling op de pagina Gebruikersvoorkeuren: Exporteren. Deze instelling kan echter voor elke exportknop afzonderlijk worden gewijzigd.

Volledige opmaak Hiermee wordt aan QlikView de opdracht gegeven numerieke gegevens te exporteren met volledige getalnotatie, precies zoals die worden getoond in de werkbladobjecten van het document.
Geen cijfergroeperingssymbool Het scheidingsteken voor duizendtallen wordt uit de numerieke gegevens verwijderd.
Geen opmaak Hiermee worden alle getalnotaties uit de gegevens verwijderd en de ruwe getallen geëxporteerd. Het decimaalscheidingsteken wordt gedefinieerd in de systeeminstellingen (Configuratiescherm).
Opmerking:

Er zijn enkele beperkingen in het gedrag van bepaalde reactieveroorzakers voor macro's als u met documenten werkt op QlikView Server.

Macro's in QV-documenten op de QV-server

Lettertype

Hier kunt u opties instellen voor Lettertype, Tekenstijl en Punten van het lettertype voor het object.

U kunt het lettertype instellen voor elk afzonderlijk object (Eigenschappen object: Lettertype), of alle objecten in een document (Toepassen op objecten op Documenteigenschappen: Lettertype).

Verder kunt u de standaard documentlettertypen voor nieuwe objecten instellen op Documenteigenschappen: Lettertype. Er zijn twee standaard lettertypen:

  1. Het eerste standaard lettertype (Keuzelijsten, Grafieken enz.) wordt gebruikt voor de meeste objecten, zoals keuzelijsten en grafieken.
  2. Het tweede standaard lettertype (Tekstobjecten en -knoppen) wordt gebruikt voor knoppen en tekstvakken, waarvoor meestal een groter lettertype nodig is.

Ten slotte kunt u de standaard lettertypen voor nieuwe documenten instellen op Gebruikersvoorkeuren: Lettertype.

Voor grafieken, knoppen en tekstobjecten (behalve zoekobjecten) kunt u ook een kleur opgeven. De kleur kan vast zijn of dynamisch worden berekend aan de hand van een uitdrukking. De uitdrukking moet een geldige kleurrepresentatie opleveren. Hiertoe kunt u de kleurfuncties gebruiken. Als het resultaat van de uitdrukking geen geldige kleurweergave oplevert, wordt standaard zwart gebruikt als kleur voor het lettertype.

Kleurfuncties

Aanvullende instellingen zijn:

Slagschaduw Als u deze optie inschakelt, wordt een slagschaduw aan de tekst toegevoegd.
Onderstrepen Als u deze optie inschakelt, wordt de tekst onderstreept.

Een voorbeeld van het geselecteerde lettertype is te zien in het voorbeeldvenster.

Opmaak

Een opmaakinstelling is alleen van toepassing op het huidige object als u werkt via de eigenschappenpagina voor een object.
Een opmaakinstelling is van toepassing op alle objecten van een of meer opgegeven typen in het document als u werkt via de eigenschappenpagina voor het document.

Randen gebruiken

Als u deze optie inschakelt, kunt u een rand om het object maken. U kunt het soort rand opgeven door een optie te kiezen in het vervolgkeuzemenu.

Schaduwintensiteit Met de vervolgkeuzelijst Schaduwintensiteit kunt u de intensiteit instellen van de schaduw rond de werkbladobjecten. Ook kunt u Geen schaduw kiezen.
Randstijl De volgende vooraf gedefinieerde randtypen zijn beschikbaar:
Ononderbroken
Een ononderbroken rand in één kleur.
Verlaagd
Met deze rand lijkt het werkbladobject te zijn verlaagd ten opzichte van de achtergrond.
Verhoogd
Met deze rand lijkt het werkbladobject te zijn verhoogd ten opzichte van de achtergrond.
Omrand
Met deze rand lijkt het werkbladobject te zijn ingelijst.
Randbreedte Deze optie is beschikbaar voor alle randtypen. De breedte kan worden opgegeven in mm, cm, inches (", inch), pixels (px, pxl, pixel), punten (pt, pts, point) of docunits (du, docunit).
Kleur Met deze knop opent u een dialoogvenster, waarin u voor alle randtypen een geschikte basiskleur uit het kleurenpalet kunt kiezen.
Regenboog Hiermee kunt u voor alle randtypen een regenboogeffect creëren. De regenboog wordt aan de bovenkant van het object vanuit de basiskleur opgebouwd.

Als u Vereenvoudigd hebt gekozen voor Opmaakmodus in Documenteigenschappen: Algemeen, kunt u geen randtype instellen. Dan worden alleen de vervolgkeuzelijst Schaduwintensiteit en de instelling Randbreedte aangeboden.

Afgeronde hoeken

In de groep Afgeronde hoeken kunt u instellingen opgeven voor de algemene vorm van het object. Met behulp van deze instellingen kunt u objecten weergeven met ronde of ellipsvormige hoeken tot superellipsvormig en rechthoekig. Afgeronde hoeken is alleen beschikbaar als u Geavanceerd als Opmaakmodus hebt geselecteerd in Documenteigenschappen: Algemeen.

Afgeronde hoeken Schakel deze optie in om de opties voor afgeronde hoeken beschikbaar te maken.
Hoeken Hoeken waarvoor de optie niet is ingeschakeld, krijgen een rechte hoek.
Kwadraatheid Een variabel nummer tussen 2 en 100, waarbij 100 een rechthoek definieert met perfect vierkante hoeken en 2 met een perfecte ellipsvorm (een cirkel met een aspectverhouding van 1:1). Een hoekigheid tussen 2 en 5 is doorgaans optimaal voor afgeronde hoeken.
Hoekradius Hier geeft u de radius van de hoeken op, als vaste afstand (Vast) of als percentage van het totale kwadrant (Relatief (%)). Met deze instelling bepaalt u de mate waarin de hoeken worden beïnvloed door de onderliggende algemene vorm die bij Hoekigheid is ingesteld. De afstand kan worden opgegeven in mm, cm, inches (", inch), pixels (px, pxl, pixel), punten (pt, pts, point) of docunits (du, docunit).

Laag

In de groep Laag kunt u aan het object één van de drie werkbladlagen toekennen:

Bottom Een object met de laageigenschap Onderste kan nooit objecten in de lagen Normaal en Bovenste bedekken. Het kan alleen boven andere objecten in de laag Onderste worden geplaatst.
Normaal Bij aanmaak worden objecten standaard in de normale (middelste) laag geplaatst. Een object met de laageigenschap Normaal kan nooit worden bedekt door objecten in de laag Onderste en kan zelf nooit objecten in de laag Bovenste bedekken.
Top Een object in de laag Bovenste kan nooit worden bedekt door objecten in de lagen Normaal en Onderste. Alleen andere objecten in de laag Bovenste kunnen erboven worden geplaatst.
Aangepast De lagen Bovenste, Normaal en Onderste komen overeen met respectievelijk de interne laagnummers 1, 0 en -1. Alle waarden tussen -128 en 127 worden echter geaccepteerd. Kies deze optie als u een zelfgekozen waarde binnen dit bereik wilt opgeven.

Thema-editor...

Hiermee opent u de wizard Thema's waarin u een nieuw opmaakthema kunt maken.

Thema toepassen...

U kunt een opmaakthema toepassen op het object, werkblad of document.

Opmaakthema's

Tonen

In de groep Tonen kunt u een voorwaarde aangeven waaronder het object wordt getoond:

Altijd Het werkbladobject wordt altijd getoond.
Voorwaardelijk

Het werkbladobject wordt getoond of verborgen, afhankelijk van een voorwaardelijke uitdrukking die voortdurend wordt geëvalueerd, bijvoorbeeld op basis van gemaakte selecties etc. Het werkbladobject wordt alleen verborgen als de voorwaarde FALSE retourneert.

Voorwaardenfuncties

Opmerking:

Gebruikers met beheerdersbevoegdheden voor het document kunnen alle voorwaarden voor tonen opheffen met behulp van de optie Alle werkbladen en objecten tonen in Documenteigenschappen: Beveiliging. Deze functionaliteit kan worden in- of uitgeschakeld door op Ctrl+Shift+S te drukken.

Documenteigenschappen: Beveiliging

Opties

In de groep Opties kunt u de mogelijkheid tot het wijziging van positie of grootte van het werkbladobject uitschakelen. De instellingen in deze groep zijn alleen van toepassing als de bijbehorende selectievakjes zijn ingeschakeld in Documenteigenschappen: Opmaak en Werkbladeigenschappen: Beveiliging.

Positie/grootte wijzigen toestaan Als deze optie is uitgeschakeld, kan niet langer de positie of de grootte van een werkbladobject worden gewijzigd.
Kopiëren/klonen toestaan Als deze optie is uitgeschakeld, kan niet langer een kopie van het werkbladobject worden gemaakt.
Info toestaan

Wanneer de functie info in gebruik is, wordt een infopictogram weergegeven in de venstertitelbalk wanneer aan een veldwaarde informatie is gekoppeld. Als u geen infopictogram wilt weergeven in de titelbalk, kunt u deze optie uitschakelen.

Info

Omvang in gegevens In principe worden de randen van alle tabelobjecten in QlikView verkleind als de tabel door bepaalde selecties kleiner wordt dan de ruimte die eraan toegewezen is. Als u deze optie uitschakelt, wordt deze automatische formaataanpassing uitgeschakeld en wordt de overtollige ruimte leeg gelaten.

Schuifbalken

Verschillende opties voor het wijzigen van de opmaak van schuifbalken vindt u in de groep Schuifbalken:

Schuifpositie behouden

Als deze instelling is ingeschakeld, behoudt QlikView zo mogelijk de schuifpositie van tabellen en grafieken met een schuifbalk wanneer een selectie wordt gemaakt in een ander object. De instelling moet ook worden ingeschakeld in Gebruikersvoorkeuren: Objecten.

De schuifpositie blijft niet bewaard als u het document sluit.

Schuifknoppen Hier stelt u de kleur van de schuifknoppen in. Selecteer een kleur door op de knop te klikken. Middelgrijze kleuren zijn overigens zeer geschikt voor schuifbalken. Beide kunt u instellen als effen kleur of als kleurovergang in het dialoogvenster Kleurgebied. U opent dit venster door te klikken op de betreffende knop.
Achtergrond schuiven

Hier stelt u de achtergrondkleur van de schuifbalken in. Selecteer een kleur door op de knop te klikken.

Schuifbalkbreedte Deze instelling wordt toegepast op de breedte en de relatieve grootte van de schuifbalksymbolen.
Schuifstijl

Hier stelt u de stijl van de schuifbalken in. Selecteer een stijl in de vervolgkeuzelijst. De schuifstijl Klassiek komt overeen met de schuifbalkstijl in QlikView 4/5. De schuifstijl Standaard is moderner. De derde stijl is Licht. Deze heeft een dunnere, lichtere balk.

De schuifbalkstijl is alleen zichtbaar als de Opmaakmodus is ingesteld op Geavanceerd. U vindt deze instelling door het vervolgkeuzemenu Instellingen te openen, Documenteigenschappen te selecteren en naar het tabblad Algemeen te gaan.

Toepassen op... Hiermee opent u het dialoogvenster Eigenschappen titelbalk en rand, waarin u kunt instellen waarop de eigenschappen moeten worden toegepast die u instelt op de pagina Opmaak.

Titelbalk

Een titelbalkinstelling is alleen van toepassing op het huidige object als u werkt via de pagina Objecteigenschappen.
Een titelbalkinstelling is van toepassing op alle objecten van een of meer opgegeven typen in het document als u werkt via de pagina Documenteigenschappen.

Geef op de pagina Titelbalk opmaakopties op die volledig afwijken van de algemene opmaak van het object.

Titelbalk tonen Als deze optie is ingeschakeld, wordt aan de bovenkant van elk object een titelbalk weergegeven. De titelbalk is standaard ingeschakeld bij keuzelijsten en andere objecten met een vak, en uitgeschakeld bij knoppen, tekstobjecten en lijnen/pijlen.
Titeltekst In het tekstvak kunt u een titel invoeren die op de titelbalk van het object wordt weergegeven. Gebruik de knop Lettertype... om het lettertype van de titelbalk te wijzigen.

U kunt voor elke status van de titelbalk een verschillende kleur instellen. De instellingen voor Actieve kleuren en Inactieve kleuren kunnen onafhankelijk van elkaar worden uitgevoerd.

Klik op de knop Achtergrondkleur of Tekstkleur om het dialoogvenster Kleurgebied te openen. De achtergrondkleur kan worden gedefinieerd als een effen kleur of een kleurovergang in het dialoogvenster Kleurgebied. Voor Tekstkleur kan een vaste of een berekende kleur worden gedefinieerd met behulp van kleurfuncties.

Kleurfuncties

Tekstterugloop Als deze optie is ingeschakeld, wordt de titel weergegeven op twee of meer regels.
Titelbalkhoogte (regels) U stelt het aantal titelbalkregels in dit tekstvak in.

U kunt de exacte grootte en positie van een normaal of geminimaliseerd QlikView-object bepalen en aanpassen met de instellingen voor grootte en positie. Deze instellingen worden gemeten in pixels:

X-pos. Hiermee stelt u de horizontale positie van de linkerzijde van het werkbladobject in ten opzichte van de linkerrand van het werkblad.
Y-pos. Hiermee stelt u de verticale positie van de bovenzijde van het werkbladobject in ten opzichte van de bovenrand van het werkblad.
Breedte Hiermee stelt u de breedte van het QlikView-werkbladobject in.
Hoogte Hiermee stelt u de hoogte van het QlikView-werkbladobject in.

U kunt de positie van de titelbalk wijzigen met de opties voor Titelbalkuitlijning:

Horizontaal Het label kan horizontaal worden uitgelijnd: Links, Centreren of Rechts binnen het titelbalkgebied.
Verticaal Het label kan verticaal worden uitgelijnd: Boven, Centreren of Onder binnen het titelbalkgebied.

Speciale pictogrammen
Veel opdrachten in het objectmenu van werkbladobjecten kunnen ook als pictogrammen op de titelbalk worden weergegeven. Selecteer de opdrachten die als pictogrammen moeten worden weergeven door de selectievakjes links van de betreffende opdrachten in de lijst in te schakelen.

Opmerking: Stel een beperkt aantal pictogrammen in voor de titelbalk. Te veel pictogrammen zijn verwarrend voor de gebruiker.
Minimaliseren toestaan Als deze optie is ingeschakeld, wordt een pictogram voor minimaliseren weergegeven in de venstertitelbalk van het werkbladobject, op voorwaarde dat het object geminimaliseerd kan worden. Ook kan het object worden geminimaliseerd door op de titelbalk te dubbelklikken.
Automatisch minimaliseren Deze optie is beschikbaar als Minimaliseren toestaan is ingeschakeld. Wanneer Automatisch minimaliseren is ingeschakeld voor diverse objecten op hetzelfde werkblad, worden ze telkens allemaal op één na automatisch geminimaliseerd. Dit is bijvoorbeeld nuttig als u verschillende grafieken in hetzelfde werkbladgebied afwisselend wilt weergeven.
Maximaliseren toestaan Als deze optie is ingeschakeld, wordt een pictogram voor maximaliseren weergegeven in de venstertitelbalk van het werkbladobject, op voorwaarde dat het object gemaximaliseerd kan worden. Ook kan het object worden gemaximaliseerd door op de titelbalk te dubbelklikken. Als zowel Minimaliseren toestaan als Maximaliseren toestaan zijn ingeschakeld, wordt bij dubbelklikken het object geminimaliseerd.
Help-tekst

Hier kunt u een Help-tekst invoeren voor weergave in een pop-upvenster. De Help-tekst kan worden opgegeven als berekende formule. Deze optie is niet beschikbaar op documentniveau. Klik op de knop ... om het dialoogvenster Uitdrukking bewerken te openen. Hierin kunt u lange formules eenvoudiger bewerken.

Uitdrukkingssyntaxis voor berekende formules

U kunt bijvoorbeeld een omschrijving invoeren van het werkbladobject. Een Help-pictogram wordt toegevoegd aan de venstertitelbalk van het object. Wanneer de muisaanwijzer over het pictogram beweegt, wordt de tekst in een pop-upvenster weergegeven.