표현식 편집 대화 상자

표현식 편집 대화 상자는 차트 속성: 표현식에서 표현식 목록 아래에 있는 추가 버튼을 선택하거나 기존 표현식을 마우스 오른쪽 버튼으로 클릭하고 표현식 추가 또는 표현식 편집을 선택하면 열립니다.

이는 주로 차트 표현식에 사용되지만 표현식이 필요할 때마다 다른 표현식을 작성 또는 편집하는 데에도 활용할 수 있습니다. 이 대화 상자는 프로그램 전체에서 어디서나 텍스트 편집 상자 옆의 점 3개 기호가 있는 버튼을 클릭하여 액세스할 수 있습니다.

이 대화 상자의 주요 부분은 긴 표현식이 들어갈 수 있게 크기를 조정할 수 있는 표현식 편집 영역과 그 아래에 있는 필드, 함수, 변수이미지의 네 가지 탭으로 구성된 탭 영역으로 이루어져 있습니다.

표현식 정상 선택한 표현식의 편집 영역입니다. 여기에 전체 표현식을 입력할 수도 있지만 대개 아래 설명된 탭 영역에서 표현식의 대부분을 작성하는 편이 더 편리합니다.
표현식 정상 레이블은 표현식 구문이 프로그램에서 허용되는 경우, 즉 표현식이 유효한 경우에만 표시됩니다. 그렇지 않으면 레이블에서 여러 오류 메시지(잘못된 필드 이름, 표현식 내 오류, 표현식 뒤 가비지) 중 하나를 표시합니다. 표현식이 유효한 경우를 제외하고 확인 버튼을 클릭하여 대화 상자를 닫는 것은 별로 의미가 없습니다.

필드

필드 탭에는 필드 데이터를 기준으로 통계 집계 함수를 만드는 데 사용되는 콘트롤이 있습니다.

집계 첫 번째 드롭다운에는 사용 가능한 통계 집계 함수의 목록이 나열됩니다. (예를 들어 첫 번째 문자열마지막 문자열 함수를 사용하여 피벗 테이블에 텍스트를 표시할 수 있습니다.)
테이블 이 드롭다운 목록은 아래 필드 목록에 표시되는 필드를 하나의 특정 내부 테이블로 제한하는 데 사용됩니다.
필드

이 드롭다운에는 사용 가능한 모든 필드 이름의 목록이 나열됩니다.

Direct Discovery 기능을 사용하여 MEASURE로 로딩된 필드는 [Measure]로 표시됩니다. MEASURE 필드는 기본 집계 함수 Sum, Avg, Count, Min, Max와 함께만 사용할 수 있습니다. 고급 활용 또는 데이터베이스 관련 함수가 필요할 경우 SQL 문을 사용하여 유효한 SQL 함수를 실행할 수 있지만 Direct Discovery를 통해 로드된 테이블 또는 보기만 참조할 수 있다는 제한이 있습니다.

시스템 필드 표시 필드 목록에 시스템 필드를 포함하려면 이 옵션을 선택합니다.
고유 통계 함수는 기본적으로 발견된 항목 수에 따라 계산됩니다. 고유 옵션을 선택하면 중복 값 없이 표현식이 계산됩니다.
붙여넣기 선택 내용을 표현식의 구성 요소로 입력하려면 이 버튼을 클릭합니다.

함수

함수 탭에는 표현식에 일반 QlikView 함수를 입력하는 데 사용되는 콘트롤이 있습니다.

함수 범주 이 드롭다운 목록은 아래 함수 이름 목록에 표시되는 함수를 한 번에 하나의 범주로 제한하는 데 사용됩니다.
함수 이름 이 드롭다운에는 사용 가능한 모든 QlikView 함수(제한적인 수의 전용 스크립트 함수 제외)의 목록이 나열됩니다.
함수 탭의 아래쪽 창에는 선택한 함수의 인수 구문이 표시됩니다.
붙여넣기 선택 내용을 표현식의 구성 요소로 입력하려면 이 버튼을 클릭합니다.

변수

변수 탭에는 표현식에 QlikView 변수를 입력하는 데 사용되는 콘트롤이 있습니다.

변수 이 드롭다운에는 문서에 대해 현재 정의된 모든 변수의 목록이 나열됩니다.
시스템 변수 표시 변수 목록에 시스템 변수를 포함하려면 이 옵션을 선택합니다.
붙여넣기 선택 내용을 표현식의 구성 요소로 입력하려면 이 버튼을 클릭합니다.

변수 탭의 아래쪽에는 변수 목록에서 선택한 변수의 현재 값이 표시되는 창이 있습니다.

이미지

이미지 탭에는 QlikView에서 사용 가능한 내부 파일에 액세스하는 데 사용되는 콘트롤이 있습니다. 또한 연결된 다른 이미지 파일에도 액세스할 수 있습니다. 이 기능은 레이아웃의 특정 부분으로 한정된다는 점에 유의하십시오.

이미지 폴더 이 드롭다운에는 사용 가능한 이미지 폴더의 목록이 나열됩니다.
이미지 이 드롭다운에는 선택한 폴더에서 사용 가능한 이미지의 목록이 나열됩니다.
고급... 이 버튼을 클릭하면 이미지 선택기 대화 상자에서 직접 그림을 선택할 수 있습니다.
붙여넣기 선택 내용을 표현식의 구성 요소로 입력하려면 이 버튼을 클릭합니다.

이미지 탭 오른쪽에는 현재 선택된 이미지를 표시하는 창이 있습니다.

또한 표현식 편집 대화 상자에는 다음과 같은 메뉴 명령과 버튼이 포함되어 있습니다.

파일 메뉴

표현식 파일로 내보내기... 표현식 파일로 내보내기 명령을 사용하여 표현식 편집 상자의 내용을 테이블 파일로 저장할 수 있습니다. 이 파일은 .qve 확장명으로 저장됩니다.
파일 삽입... 파일 삽입... 명령을 사용하여 이전에 만든 표현식 파일을 스크립트에 삽입할 수 있습니다.
컬러믹스 마법사... 컬러믹스 마법사를 사용하면 색 혼합 표현을 만들 수 있습니다.
인쇄 표현식을 인쇄할 수 있는 Windows 표준 인쇄 대화 상자가 열립니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+P.

편집 메뉴

실행 취소 가장 최근의 변경 내용을 실행 취소합니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+Z.
다시 실행 가장 최근의 실행 취소 내용을 다시 실행합니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+Y.
잘라내기 강조 표시된 텍스트를 클립보드로 내보냅니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+X.
복사 강조 표시된 텍스트를 클립보드로 복사합니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+C.
붙여넣기 클립보드의 내용을 대화 상자의 커서 위치에 붙여 넣습니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+V.
지우기 전체 표현식을 지웁니다.
모두 선택 전체 표현식을 선택합니다.
찾기/바꾸기... 표현식에서 숫자 또는 문자를 찾고 바꿀 수 있는 대화 상자를 엽니다. 이 명령은 다음 바로 가기 키로도 실행할 수 있습니다. Ctrl+F.

설정 메뉴

구성... 사용자 기본 설정: 편집기를 엽니다.