# ワード クラウド グラフ

ワード クラウド グラフ ([Word cloud]) で、テキスト データのビジュアルを作成することができます。テキスト値は、メジャー値に基づいたサイズで表示されます。測定対象となるものはすべてメジャーとして指定できます (例: 使用時間、アルファベット順、重要度別、またはコンテキスト別)。作成するグラフは、さまざまな形状、フォント、レイアウト、配色でカスタマイズできます。これは、Visualization bundle に含まれています。

食品アイテムを異なるサイズと色で表示したワード クラウド グラフ。

食品アイテムを異なるサイズと色で表示したワード クラウド グラフ。

食品アイテムを異なるサイズと色で表示したワード クラウド グラフ。 ![食品アイテムを異なるサイズと色で表示したワード クラウド グラフ。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/w3_629x440.png)

[Word Cloud Chart](https://play.vidyard.com/sSKNa6FvwbF25674c34vyV)

## 要件

ワード クラウド グラフには、1 つの軸と 1 つのメジャーが必要です。

## 使用に適しているケース

ワード クラウド グラフにより、メジャーに対する値の重要度を可視化して識別できます。メジャーに対する値の重要度が高いほど、クラウド内で大きく表示されます。

## ワード クラウド グラフの作成

編集中のシートにワード クラウドを作成できます。

次の手順を実行します。

1. アセット パネルから、[カスタム オブジェクト] &gt; Visualization bundle を開き、[ワード クラウド グラフ] オブジェクトをシートにドラッグします。
2. [軸を追加] ボタンをクリックし、軸を選択します。
3. [メジャーを追加] ボタンをクリックして、グラフのメジャーを選択します。

軸とメジャーを選択すると、ワード クラウド グラフが自動的に表示されます。

## ワード クラウドのスタイルの変更

ワード クラウドは 1 つ以上の機能を指定してカスタマイズできます。

### 方向の変更

方向の数は、プロパティ パネルにおいて [スタイル &gt; 設計 &gt; 方向] の順で設定できます。整数は、1 から 10 の間で設定できます。

* 1 はすべての字句を同じ方向に表示し、[スタイル &gt; 設計 &gt; 開始角] で設定します。
* 2 は字句を 2 方向に表示し、[スタイル &gt; 設計 &gt; 開始角] と [スタイル &gt; 設計 &gt; 終了角] で設定します。
* 3 から 10 は、字句を [スタイル &gt; 設計 &gt; 開始角] と [スタイル &gt; 設計 &gt; 終了角] の間の方向と同数で表示します。

食品アイテムを異なる方向で表示したワード クラウド グラフ。

食品アイテムを異なる方向で表示したワード クラウド グラフ。

食品アイテムを異なる方向で表示したワード クラウド グラフ。 ![食品アイテムを異なるサイズ、向き、色で表示したワード クラウド グラフ。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/w5_629x383.png)

### 開始角と終了角の調整

ワード クラウドの開始点 (角度) パラメータはプロパティ パネルの [スタイル] &gt; [Design] &gt; [Start angle] で、および終了点は [スタイル] &gt; [Design] &gt; [End angle] で調整できます。角度には、正の数と負の数を指定できます。

### フォント サイズの変更

最大ワード フォント サイズはプロパティ パネルの [スタイル] &gt; [Design] &gt; [Font max size] で、最小サイズは [スタイル] &gt; [Design] &gt; [Font min size] で設定できます。

フォント サイズを大きく設定すると、大きな字句がチャートに収まらず、表示されない可能性があります。

### スケールの変更

ワード クラウド グラフのスケールは、Linear または Log のいずれかのスケールにすることができます。プロパティ パネルの [スタイル] &gt; [Design] &gt; [スケール] で「Linear」または「Log」を選択します。Log スケールでは正の数のみを使用できます。0 または負の値を指定すると何も返されません。

### カスタム範囲の設定

色の範囲を指定するか、事前定義の配色から選択することもできます。

次の手順を実行します。

1. プロパティ パネルで [スタイル] &gt; [Design] をクリックします。
2. [色範囲を有効化] が「オン」(既定) に設定されていることを確認します。
3. [開始色] の横のカラー パレットをクリックし、色を選択します。
4. [終了色] の横のカラー パレットをクリックし、色を選択します。

カラー パレットのイーゼル記号をクリックし、色を選択することにより、独自の色範囲を設定できます。イーゼル記号の横の項目に色コード文字列を入力することもできます。色は有効な CSS 色にする必要があります。

次の手順を実行します。

1. プロパティ パネルで [スタイル] &gt; [Design] をクリックします。

2. [Enable custom range] スライド ボタンを左にスライドしてこのオプションをオフにします。

3. [Scale color] で配色を選択します。

   ![食品アイテムをカスタム色で表示したワード クラウド グラフ。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/w7_592x332.png)

食品アイテムを異なるサイズと色で表示したワード クラウド グラフ。

### 数字の書式設定

メジャー値は書式設定することが可能です。同じ値に、貨幣、日付、期間などの異なる書式設定を適用可能です。チャートが更新され、変更された数値型が反映されます。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックし、メジャーをクリックします。
2. [数値書式] メニューで、適切な数値書式を選択します。
3. パネルの項目に詳細を入力します。これらの項目は、グラフをさらに設定するときに「自動」以外のオプションを選択すると表示されます。

## スタイル パネルを使用してスタイルをさらにカスタマイズする

プロパティ パネルの [スタイル] には、さまざまなスタイル オプションが用意されています。

チャートのスタイル指定をさらにカスタマイズするには、[スタイル] &gt; [プレゼンテーション] で [the スタイル指定 icon] をクリックします。 各セクションの横にある ![リセット](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) をクリックすると、スタイルをリセットできます。![リセット](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) [すべてをリセット] をクリックすると、スタイル指定パネルで使用可能なすべてのタブのスタイルがリセットされます。

個々のビジュアライゼーションのスタイル指定に関する一般的な情報については、「 [ビジュアライゼーションへのカスタム スタイル指定の適用](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)」を参照してください。

### テキストのカスタマイズ

[スタイル] &gt; [基本設定] で、タイトル、サブタイトル、脚注のテキストを設定できます。これらの要素を非表示にするには、[タイトルを表示] をオフにします。

チャートの異なるラベルの可視性は、チャートごとの設定とラベル表示オプションによって異なります。これらはプロパティ パネルで構成できます。

チャートに表示されるテキストのスタイルを指定できます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. [基本設定] タブで、次のテキスト要素のフォント、強調スタイル、フォント サイズ、色を設定します。

   * タイトル

   * サブタイトル

   * 脚注

### 背景のカスタマイズ

チャートの背景をカスタマイズできます。背景は、色と画像で設定できます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル指定パネルの [一般] タブでは、背景色 (単一色または数式) を選択できます。メディア ライブラリまたは URL から画像を背景に設定することもできます。

   背景色を使用する場合は、スライダーを使用して背景の不透明度を調整します。

   背景画像を使用する際、画像のサイズや位置を調整できます。

### 境界線と影のカスタマイズ

チャートの境界線と影をカスタマイズできます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル パネルの [一般] タブの [境界線] で、 [枠線] のサイズを調整してチャートの周囲の境界線を増減します。

4. 境界線の色を選択します。

5. [角の半径] を調整して、境界線の丸みを制御します。

6. [一般] タブの [影] で、影のサイズと色を選択します。影を消す場合は、 [None] (なし) を選択します。

## 制限事項

全般的な制限事項については、「[制限事項](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati)」を参照してください。

* ワード クラウド グラフでは、1 エントリあたり最大 100 語を処理できます。
* チャートよりも広いスペースを占めるワードは表示されません。フォント サイズを調整して表示される値の数を増やすことができますが、長いテキスト値が格納されている項目を使用することはお勧めできません。
* Word cloud chart を Qlik NPrinting レポートで使用することはできません。

関連する学習:

* [Visualization Bundle ワード クラウド グラフを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Word_cloud_chart)

## 詳細を見る

* [Visualization Bundle ワード クラウド グラフを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Word_cloud_chart)