# KPI のカスタマイズ

マルチ KPI チャート (マルチ KPI) の値およびメジャーを使って、1 つ以上の条件付き設定を使用してカスタマイズできます。いくつかの KPI をまとめて追加し、それらをグループ化して、さまざまなシートにリンクできます。KPI 値は、テキストの色、フォント、サイズ、アイコン、ラベル、グラフィックなどの CSS プロパティを 1 つ以上使用して差別化し、個別にカスタマイズすることもできます。

情報メモ

マルチ KPI は、2025 年 4 月 5 日以降、Qlik Cloud および 2025 年 5 月版 Qlik Sense Client-Managed のアセット パネルで、新しいチャートの作成時に使用できなくなります。以前追加されたダッシュボードでは引き続き機能しますが、Qlik Cloud では 2026 年 5 月、Qlik Sense Client-Managed では 2026 年 5 月バージョンから完全に削除されます。

機能の置き換えに関する推奨事項については、「[マルチ KPI チャート](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/multi-KPI.htm)」を参照してください。

KPI 値は、テキストの色、背景色、フォント、サイズ、アイコン、ラベル、グラフィックなどの CSS プロパティを 1 つ以上使用して差別化し、個別にカスタマイズすることもできます。

アイコン、異なる色、フォント、マスター ビジュアライゼーションを使用する KPI 値

アイコン、異なる色、フォント、マスター ビジュアライゼーションを使用する KPI 値

アイコン、異なる色、フォント、マスター ビジュアライゼーションを使用する KPI 値 ![アイコン、異なる色、フォント、マスター ビジュアライゼーションを使用する KPI 値](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/info1_701x117.png)

## マルチ KPI の色分け

色オプションにより、すべての KPI 値 (メジャーおよびラベル) を色によって差別化することができます。テキスト、アイコン、背景の色を変更できます。色は有効な CSS 色にする必要があります。

次のオプションから選択できます。

* 事前定義の色セットによるカラー パレット。
* 色相環 (カラー パレットでイーゼル記号をクリックし、個別に選択します)。
* イーゼル記号の横のフィールドに色コード文字列を入力します。

### メジャー/ラベル色の変更

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックします。

2. 該当するメジャーをクリックして、値 ([値の色]) またはラベル ([ラベルの色]) の色を選択します。

3. 開かれるカラー パレットから色を選択します。

   ![KPI 色選択パネル](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/color50_680x243.png)

### 背景色の変更

次の手順を実行します。

1. カラー パレットでイーゼル記号をクリックし、色を選択するかまたはイーゼル記号の横の項目に色コードを入力することにより、独自の色を設定することもできます。色は有効な CSS 色にする必要があります。

2. プロパティ パネルで [外観] &gt; [スタイル] をクリックします。

3. [背景色] ボックスをクリックします。

4. 開かれるカラー パレットから色を選択します。チャートが更新されます。

## マルチ KPI のサイズの変更

軸、メジャー、ラベル、アイコンのサイズは、ドロップダウン メニューに含まれる定義済みのサイズを使用して設定できます。

* 軸ラベル: プロパティ パネルの [スタイル] &gt; [軸] &gt; [サイズ] で、ラベルのサイズを選択します。
* メジャー ラベル: すべてのメジャーには個々のサイズを設定できます。

次の手順を実行します。

1. プロパティ パネルの [データ] &gt; [メジャー] で、メジャーのサイズを選択します。
2. メジャーを選択し、[パラメータを上書き] ボックスをクリックします。
3. [ラベル] の下にラベル タイプを文字列または数式として入力するか、[サイズ] の下のドロップダウン メニューのオプションの中からサイズを選択します。

アイコン: すべてのアイコンは、さまざまな色を適用することによって差別化できます。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] の順に移動します。
2. メジャーを選択し、アイコン オプションからアイコンを選択します。
3. [アイコン] のドロップダウン メニューから [アイコン サイズ] を選択します。

## マルチ KPI のフォントの変更

プロパティ パネルで [データ] &gt; [メジャー] の順に移動し、対象のメジャーを選択することにより、すべてのラベルのフォントファミリを変更できます。[フォント スタイル] で、ラベル文字列を入力して Enter を押します。

数式エディタ (the 式 icon) で数式を使用して変更するか、プロパティ パネルの [外観] &gt; [スタイル] &gt; [スタイル (CSS)] で入力した個々のフォント CSS プロパティを適用することもできます。

## アイコンの変更

アイコン セットから選択することにより、事前定義アイコンを設定して値またはラベルを表すことができます。それらのアイコンは、色、フォント、ラベル、サイズの各オプションを使用して差別化することにより、さらにカスタマイズできます。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックします。

2. [アイコンを選択] ボックスをオンにし、開かれるアイコン セットから適切なアイコンをクリックします。

   ![アイコン設定パネル](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/icon3_665x258.png)

3. [OK] をクリックします。ポップアップが閉じられ、チャートが更新されます。

4. [アイコン位置] で [ラベル] または [値] を選択することにより、ラベルまたは値を設定するかどうかを選択します。

[アイコン] (プロパティ パネルで、[データ] &gt; [メジャー] &gt; 対象のメジャーの順に選択) でアイコン文字列を入力して Enter を押すことにより、値/ラベルをアイコンに変更することもできます。その後、設定対象に応じて、[アイコン位置] で [ラベル] または [値] をクリックします。数式エディタで、数式を使用してアイコンを変更することもできます (the 式 icon)。アイコンは有効な CSS アイコンである必要があります。

## 情報グラフィック モードの使用

情報グラフィック モードでは、各メジャーを適切な数のアイコンとしてグラフィカルに表示することができます。

次の手順を実行します。

1. プロパティ パネルの [データ] &gt; [メジャー] で適切なメジャーをクリックし、[アイコン] ボタンをクリックします。

2. 開かれる事前定義アイコン セット ([アイコン]) から、メジャーを表すアイコンを選択します。

3. [情報グラフィック モード] ボタンをクリックします。結果の KPI チャートが更新され、該当する数のアイコン (メジャーあたりの最大アイコン数 100) がメジャーとともにグラフィカルに表示されます。

   数式エディタで、数式を使用してアイコンを選択することもできます (the 式 icon)。

   ![タイプの異なる情報グラフィック図を使用するチャート。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/info2_715x163.png)

## マスター ビジュアライゼーションの埋め込み

KPI オブジェクトをグラフィカルに図示するため、マスター ビジュアライゼーションを埋め込むことができます。

次の手順を実行します。

1. プロパティ パネルで、[データ] &gt; [メジャー] の順に移動し、[追加] をクリックします。
2. [数式エディタ] (the 式 icon) ボタンをクリックします。
3. 文字列 ='Drag and Drop here' を数式エディタに入力し、[適用] をクリックします。
4. 各メジャー プレースホルダの値領域にマスター ビジュアライゼーション オブジェクトをドラッグ アンド ドロップします。

各メジャーの [ビジュアライゼーション] の下にある数式エディタ (the 式 icon) で、オブジェクト ID 文字列を数式に挿入することもできます (プロパティ パネルの [データ] &gt; [メジャー] &gt; [該当するメジャー])。

![各 KPI が対応するマスター ビジュアライゼーションと一緒に表示される KPI メジャー。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/info_684x157.png)

## スタイル (CSS) のプロパティの使用

各メジャーの事前定義されていないスタイル (CSS) プロパティを使用して、メジャーをさらに設定できます。たとえばアイコンの場合は、テキスト/アイコンの色、ラベル、フォント、背景色、サイズなどを変更します。スタイルをコピーし、[スタイル (CSS)] フィールド (プロパティ パネルの [外観] &gt; [スタイル]) に貼り付けます。

アイコンの場合は、プロパティ パネルの [データ] &gt; [メジャー] で、選択したメジャーの [アイコン] フィールドに適切なクラスを入力します。数式エディタで、数式を使用してアイコン文字列を入力することもできます (the 式 icon)。

![プロパティ パネルの CSS スタイル ボックス。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/css502_639x203.png)

## KPI の書式設定

表示されるチャート レイアウトはいくつかの方法で書式設定できます。

### 配置

プロパティ パネルの [データ] &gt; [メジャー] にある選択したメジャーの [配置] で該当するボックスをオンにすることにより、メイン チャートのテキストの配置を設定できます。

すべての KPI を垂直に配置することも可能です。この配置は、最上部、最下部、中央に配置するように調整したり、拡張したりすることが可能です。プロパティ パネルの [外観] &gt; [スタイル] にある [垂直配置] メニューから、適切な配置を選択します。ラベルは、プロパティ パネルの [外観] &gt; [軸] で [ラベルを中央揃え] をオンにすることにより、中央揃えにすることも可能です。

### [数値書式]

KPI 数値の書式はカスタマイズすることもできます。同じ値に異なる書式設定を適用可能です。チャートが更新され、変更された数値型が反映されます。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックし、対象のメジャーを選択します。

2. [数値書式] メニューから適切な数値書式を選択します。

   ![2 種類の異なる数値書式 (Auto、Money) を使用する同じ KPI オブジェクト。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/number3_600x347.png)

### [書式パターン]

特定のメジャーのテキストを変更または削除可能です。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックします。
2. [書式パターン] で該当するメジャーをクリックし、該当する書式文字列を入力/削除して、Enter を押します。

### セグメント/カード

軸と値がセグメントまたはカード レイアウトで表示される KPI チャートのレイアウトを設定することも可能です。

次の手順を実行します。

1. プロパティ パネルで [外観] &gt; [軸] をクリックします。

2. [表示の設定] メニューで、[セグメント] または [カード] レイアウトを選択します。チャートが更新されます。

   ![同じ KPI オブジェクトがセグメント レイアウト (上) とカード レイアウト (下) で表示されます。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/seg3_641x413.png)

セグメント レイアウトは、プロパティ パネルの [外観] &gt; [軸] &gt; [方向] で、水平または垂直の方向に設定可能です。[水平] と [垂直] のいずれかのボタンをクリックします。

### 行のアイテム数

プロパティ パネルの [外観] &gt; [メジャー] でチャートの行あたりのアイテム (KPI) 数を決めることも可能です。既定の [自動] を使用するか、[行のアイテム数] メニューで数 (1～8) を選択します。

### 境界線

チャートの外側と内側の境界線を非表示にすることができます。既定では、すべての境界線が表示されます。境界線を設定するには、プロパティ パネルで [外観] &gt; [軸] の順に移動し、必要に応じて [外側の境界線を非表示にする] または [内側の境界線を非表示にする] をオンにします。

### 値/ラベルのレイアウトと書式設定

軸とメジャーの両方の値の位置および順序は、変更して異なる方法で表示可能です。ラベルは、非表示にするか、垂直または水平に表示することが可能です。既定では、[水平] が選択されています。

#### 軸ラベル レイアウト

次の手順を実行します。

1. プロパティ パネルで [外観] &gt; [メジャー] をクリックします。
2. [ラベルの向き] で [水平] または [垂直] のいずれかをクリックして、ラベルの表示方法を選択します。

#### メジャー値レイアウト

メジャー値レイアウトは以下の 2 種類の方法で設定可能です。

次の手順を実行します。

1. 既存のパラメータ:
   1. プロパティ パネルで [外観] &gt; [メジャー] をクリックします。
   2. [ラベルの向き] で [水平] または [垂直] のいずれかをクリックして、ラベルの表示方法を選択します。
2. 新規のパラメータ:
   1. プロパティ パネルで [データ] &gt; [メジャー] をクリックします。
   2. 適切なメジャーをクリックし、[パラメータを上書き] ボックスをオンにします。
   3. [ラベル] にラベル文字列を入力し、Enter を押します。

#### ラベルの順序

メジャー値のラベルの表示順序を調整することもできます。

次の手順を実行します。

1. プロパティ パネルで [外観] &gt; [メジャー] をクリックします。
2. [ラベルの向き] で [ラベル、値] または [値、ラベル] のいずれかをクリックして、ラベルの表示方法を選択します。

#### アイコンの順序

アイコンの表示位置 (値の前または後) を指定できます。プロパティ パネルの [外観] &gt; [メジャー] で、[アイコンの順序] に移動し、[アイコン、値] または [値、アイコン] のいずれかのボタンをクリックして、チャートに最初に表示される順序を選択します。

#### ラベルを非表示にする

* メジャー ラベル: このオプションにより、各 KPI のメジャー ラベルを非表示にします。ラベルを非表示にするには、プロパティ パネルで [データ] &gt; [メジャー] をクリックし、対象のメジャーを選択します。次に、[ラベルを非表示] ボックスをオンにします。
* 軸ラベル: このオプションにより、各 KPI の軸ラベルを非表示にします。ラベルを非表示にするには、プロパティ パネルで [外観] &gt; [軸] をクリックします。次に、[ラベルを非表示] ボックスをオンにします。

#### 値を非表示

このオプションにより、各 KPI の値を非表示にします。値を非表示にするには、プロパティ パネルで [データ] &gt; [メジャー] をクリックします。次に、[値を非表示] ボックスをオンにします。

#### KPI 値をグループ化

すべての KPI 値は、グループ化するか、メジャーごとに個別に表示することができます。プロパティ パネルで [データ] &gt; [メジャー] の順に移動します。対象のメジャーを選択し、[軸別にグループ化] ボックスをオンにします。

もう 1 つ、[軸の値] で軸値文字列を入力して Enter を押すオプションがあります。チャートが更新されます。数式エディタで数式を使用して軸の値を入力することもできます (the 式 icon)。値は有効な CSS 値 にする必要があります。

#### 別個のシートへのリンク

各メジャーは別のシートにリンクできます。

次の手順を実行します。

1. プロパティ パネルで [データ] &gt; [メジャー] をクリックし、対象のメジャーを選択します。

2. [シートにリンク] スライダを右に動かしてオプションを有効にします。

3. [シートを選択] ボタンをクリックし、[シートを選択] ポップアップでリンク先のページをクリックします。シートが閉じられ、ページがリンクされます。

   ![プロパティ パネルで別のシートにリンクします。](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Resources/Images/sheet2_662x302.png)

## 制限事項

全般的な制限事項については、「[制限事項](https://help.qlik.com/ja-JP/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati)」を参照してください。

関連する学習:

* [Visualization Bundle マルチ KPI チャートを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)

## 詳細を見る

* [Visualization Bundle マルチ KPI チャートを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)