# ストレート テーブル

複数の項目を同時に表示しているストレート テーブル。各行の内容は論理的に結合している。テーブルは、必要な数の軸とメジャーで構成できます。ストレート テーブルは、Visualization bundle に含まれています。

アプリ作成者は、多数のフィールドを同時に追加、列レベルでテーブルをカスタマイズ、代替の軸やメジャーを追加、列幅を設定、ページネーションを適用、チャート探索を有効にすることができます。

チャート探索により、編集権限を持たないユーザーでも、分析モードのときに元のストレート テーブルをカスタマイズできます。これらのユーザーは、列の追加または削除、ソート順の変更、列の並べ替え、選択を実行できます。その後、新しいテーブル レイアウトを共有、ダウンロード、購読、またはブックマークできます。ユーザーがチャート探索モードで行った変更は、シートを分析している他のユーザーには表示されません。

情報メモこのページは、Visualization bundle ストレート テーブルについてのページです。ネイティブ テーブル オブジェクトの詳細については、「[テーブル](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/Table/table.htm)」を参照してください。

[Straight Table](https://play.vidyard.com/ywyRFWEi4qfvCa1ED1oj6B)

## 使用に適しているケース

値のビジュアライゼーションではなく詳細なデータと正確な値を表示する場合は、ストレート テーブルを使用します。テーブルは個々の値を比較したい場合に便利です。テーブルでは、ドリルダウン グループ軸を使用すると、非常に効果的です。限られたスペースで詳細を次のレベルにドリルダウンでき、更新されたメジャー値を分析できます。分析モードでユーザーがカスタム テーブルを作成できるようにする場合は、このテーブルを使用します。

### 長所

テーブルでは、さまざまな方法で絞り込みやソートができます。テーブルには、数多くの値が含まれています。テーブルでドリルダウンすると、シート上の限られたスペースを有効利用できます。動向やパターンよりも、正確な値を知りたい場合は、テーブルが最適です。テーブルを使用すると、データを他のプログラムに簡単にエクスポートできます。

### 短所

ストレート テーブルに非常に多くの値が含まれている場合、値の関係性の全体像の把握が難しくなります。また、テーブル内の不規則性を見つけるのも困難です。

## テーブルを最適化するためのベスト プラクティス

テーブルの軸とメジャーが多すぎると、ロードが遅くなる場合があります。ベスト プラクティスとして、項目と数式の大部分を代替列として追加します。これにより、ユーザーはチャート探索を使用して必要な項目のみを追加できます。

テーブルの列数を 10 列以下にすることでパフォーマンスを向上させることもできます。

単一のデータ ソースからフィールドを抽出するテーブルは、複数のデータ ソースからのフィールドを含むテーブルよりもパフォーマンスが高くなります。

## ストレート テーブルの作成

編集中のシートにストレート テーブルを作成できます。

次の手順を実行します。

1. アセット パネルから、[カスタム オブジェクト] &gt; Qlik Visualization bundle を開き、[ストレート テーブル] オブジェクトをシートにドラッグします。
2. [列を追加] をクリックしてテーブルに項目を追加します。次のドロップダウンが開きます。
   * 項目とマスター アイテム: すべての項目とマスター アイテムを表示する、検索可能なダイアログ ボックスを開きます。軸またはメジャーとして任意の項目を選択して追加できます。
   * カスタム数式: 数式を入力できるダイアログ ボックスを開くか、数式エディター the 数式エディターを開く icon を開きます。
3. プロパティ パネルの [データ] で the [データ アセットの追加] メニューを開く icon をクリックして、テーブルに軸またはメジャーを追加します。

テーブルを作成したら、プロパティ パネルでスタイルの調整や他の設定の変更ができます。スタイル指定の情報については、「[ストレートテーブルのスタイル指定](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Styling)」を参照してください。

ヒント メモ既定では、列幅はすべて 1 つの値に設定されており、その合計がチャートの幅と等しくなっています。列幅は、ヘッダーの区分線をドラッグすることで調整できます。ヘッダーの区切り線をダブルクリックして、コンテンツに合わせて幅を設定します。

## テーブル項目での作業

次の手順を実行します。

1. プロパティ パネルの [データ] タブの [列] と [代替列] で、任意のアイテムの横にあるチェックボックスをクリックします。the ツール icon をクリックして、切り取り、貼り付け、削除などのアクションを実行します。[列] または [代替列] の横にあるチェックボックスをクリックして、リスト内のすべての項目を選択します。矢印のアイコンを使用して、各セクション間で項目を移動できます。

   情報メモ代替列とは、[チャート探索の使用](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Chart) を使用するときに、ユーザーがテーブルへの追加を選択できる列のことです。

2. 列の順序を変更するには、項目または数式の横にある the ドラッグ可能な列 icon をクリックし、項目をドラッグします。

3. 項目名をクリックして、個別のプロパティを開きます。ここでは、ラベルの変更、列の背景色の設定、テキストの配置の制御、列幅の設定などができます。詳細については、以下のセクションを参照してください。

   情報メモ[テキストの配置] が [自動] に設定されている場合、列データはデータ タイプに応じて配置されます。テキスト値は左側に、値に関連する日付を含め数値は右側に揃えられます。これを [カスタム] に設定すると、データを左側、中央、または右側に配置できます。

ストレート テーブルが選択されている場合のプロパティ パネルのデータ タブ。[顧客] 項目がクリックされているため、関連する軸のプロパティが左側に表示されます。

ストレート テーブルが選択されている場合のプロパティ パネルのデータ タブ。[顧客] 項目がクリックされているため、関連する軸のプロパティが左側に表示されます。

ストレート テーブルが選択されている場合のプロパティ パネルのデータ タブ。[顧客] 項目がクリックされているため、関連する軸のプロパティが左側に表示されます。 ![ストレート テーブルが選択されている場合のプロパティ パネル。](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_vizbundle_straighttable_data.png)

### 数式を使用して列のテキスト スタイルを定義する

列ごとに個別の数式を設定して、列テキストのスタイルを定義できます。列のテキストを数式でスタイル設定すると、この数式によって、その列のアプリ テーマとビジュアライゼーションに適用されたカスタム スタイルが上書きされます。

数式で次の構文を使用してスタイルを定義できます (タグ内の文字は大文字と小文字が区別されません)。

* `<B>`: 太字

* `<I>`: 斜体

* `<U>`: 下線

* `<S>`: 取り消し線

上記のオプションは一度に複数適用できます。

例:

if(avg(Sales) &gt; 300, '&lt;B&gt;')

if(count(OrderID) = 0, '&lt;S&gt;')

if(sum(Sales) &gt; 100000, '&lt;B&gt;&lt;U&gt;', '&lt;I&gt;')

次の手順を実行します。

1. [データ] で列を選択し、プロパティで プレゼンテーションを開きます。

2. テキスト スタイルの数式の下に数式を入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

### 軸表現の書式設定

プロパティ パネルの [Representation] (表現) を使用して、値、リンク、または画像を表示するように軸列の書式を設定できます。次の表現を選択できます。

* テキスト: 軸の値をテキストとして表示します。これが既定値になっています。

* リンク: 値をクリック可能なリンクとして表示します。軸の値または URL が使用されるか、表示される軸の値に他の URL を追加できます。

#### リンクの書式設定

情報メモ

文字 ; は、URL のクエリ パラメータ セパレーターとしてサポートされていません。

次の手順を実行します。

1. [データ] で軸を選択し、プロパティで Presentation (表現) を開きます。

2. [Representation] (表現) で [リンク] を選択します。

3. [リンクの設定] で、次のいずれかを選択します。

   * ラベルを追加: 軸には、軸の数式またはデータ テーブルのいずれかに宛先 URL が含まれます。リンクは、宛先 URL の数式によって表示および順序付けされます。

     [リンク ラベル] に、宛先 URL の説明テキスト ラベルを入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

   * URL を追加: 軸の値は、URL のラベルである選択可能なテキスト リンクになります。

     [リンク URL] に、宛先 URL の数式を入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

#### 画像のフォーマット

警告メモ

ストレート テーブル内の画像には、セーフリストに登録されているサーバーとドメインからのみアクセスできます。管理者は、サーバーまたはドメインごとに [Content-Security-Policies (CSP)] を追加することにより、これらのリソースを Administration で使用できるようにします。CSP は、ブラウザーがサーバーに要求できるリソースを制御することにより、クロスサイト スクリプト作成攻撃を防ぐのに役立ちます。

情報メモ

文字 ; は、URL のクエリ パラメータ セパレーターとしてサポートされていません。

次の手順を実行します。

1. [データ] で軸を選択し、プロパティで Presentation (表現) を開きます。

2. [Representation] (表現) で [画像] を選択します。

3. [画像の設定] で、次のいずれかを選択します。

   * ラベルを追加: 軸には、軸の数式またはデータ テーブルのいずれかに画像への絶対 URL が含まれます。リンクは、URL の数式によって表示および順序付けされます。

     [画像ラベル] で、画像にカーソルを合わせると代替テキストと表示される画像の説明テキスト ラベルを入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

   * URL を追加: 軸の値は、画像にカーソルを合わせたときに表示される代替テキストのラベルになります。

     [画像 URL] に、宛先 URL の数式を入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

4. [サイズ変更] で、次のサイズ変更オプションのいずれかを選択します。

   * 常に適合

   * 幅に合わせる

   * 高さに合わせる

   * 縮小/拡大して合わせる

   * 元のサイズ

5. [位置] で、セル内の画像の位置を選択します。

### メジャー表現の書式設定

プロパティ パネルの [Representation] (表現) を使用して、メジャー列の書式を設定できます。次の表現を選択できます。

* テキスト: メジャーの値をテキストとして表示します。これが既定値になっています。

* 画像: メジャーの値を画像として表示します。

* インジケーター: メジャーのセルにカスタマイズ可能なインジケーター シンボルを表示します。設定に応じて、これらのインジケーターの横に、各値のテキスト表現を表示または非表示にできます。

* ミニチャート: 各メジャー値に対して小さなチャートを表示します。各ミニ チャートには、テーブル内の他の軸とは別に構成された特定の軸に沿ったメジャーの変化が表示されます。

表現オプションの詳細については、以下を参照してください。

#### 画像のフォーマット

警告メモ

ストレート テーブル内の画像には、セーフリストに登録されているサーバーとドメインからのみアクセスできます。管理者は、サーバーまたはドメインごとに [Content-Security-Policies (CSP)] を追加することにより、これらのリソースを Administration で使用できるようにします。CSP は、ブラウザーがサーバーに要求できるリソースを制御することにより、クロスサイト スクリプト作成攻撃を防ぐのに役立ちます。

情報メモ

文字 ; は、URL のクエリ パラメータ セパレーターとしてサポートされていません。

次の手順を実行します。

1. [データ] でメジャーを選択し、プロパティで [プレゼンテーション] を開きます。

2. [Representation] (表現) で [画像] を選択します。

3. [画像の設定] で、次のいずれかを選択します。

   * ラベルを追加: メジャーの値には、メジャーの数式またはデータ テーブルのいずれかに画像への絶対 URL が含まれます。リンクは、URL の数式によって表示および順序付けされます。

     [画像ラベル] で、画像にカーソルを合わせると代替テキストと表示される画像の説明テキスト ラベルを入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

   * URL を追加: メジャーの値は、画像にカーソルを合わせたときに表示される代替テキストのラベルになります。

     [画像 URL] に、宛先 URL の数式を入力します。the 数式エディターを開く icon をクリックして、数式エディターを開きます。

4. [サイズ変更] で、次のサイズ変更オプションのいずれかを選択します。

   * 常に適合

   * 幅に合わせる

   * 高さに合わせる

   * 縮小/拡大して合わせる

   * 元のサイズ

5. [位置] で、セル内の画像の位置を選択します。

#### メジャーにトレンド インジケーターを追加

メジャー列にトレンド インジケーターを追加できます。これにより、メジャー値の後にシンボルが表示されるようになります。表示するシンボルとシンボルの色を判断する範囲を定義できます。インジケーターを有効化するには、メジャー プロパティ内の [表現] を [インジケーター] に設定します。

次の手順を実行します。

1. プロパティ パネルで、 [データ] を展開し、メジャーをクリックします。

   メジャーのプロパティが開きます。

2. [プレゼンテーション] で、 [表記] を [インジケーター] に設定します。

3. [制限を追加] ボタンの下にある、色と記号を含む四角形をクリックします。インジケーターの色と記号を設定できます。

   1 つ以上の制限を追加する場合は、この四角形内の範囲をクリックして、各範囲の色と記号を調整できます。

4. インジケーターの追加プロパティを設定します。詳細については、以下のセクションで説明します。

インジケーターの限度を設定

インジケーターの表示を使用する範囲には、[限度の追加] を使用して限度を追加する必要があります。限度値を設定する方法は 3 通りです。

* スライダーを使用する。
* テキスト ボックス内に値を入力する。
* 限度値を返す数式を設定する。

限度を追加すると、各定義の範囲でインジケーターの色とシンボルが選択できます。

インジケーターのスタイル指定

インジケーターを表示するスタイルを指定できます。

* インジケーターとメジャー値の両方を表示するには、[値の表示] を選択します。

* 値の色にインジケーターの色と同じ色を設定するには、[色を値に適用] を使用します。

  情報メモこの設定をオンにすると、チャートの他のプロパティで定義されている場合、インジケーターの色が現在のセルの値の色を上書きします。

* インジケーターを値の右か左のどちらに表示するかは、[インジケーターの位置] で決めます。

* 1 つ以上の制限がある場合は、 [グラデーション] をオンに切り替えて、色間のグラデーションでインジケーターの色を設定します。

例

この例では、Sales メジャーにトレンド インジケーターを追加して、目標値を下回る値を表示します。インジケーターの制限は次の通りです。

* $1,000,000.00 未満の値の場合、赤いフラグが表示されます。
* $1,000,000.01 から $4,999,999.99 の範囲にある値の場合、黄色のフラグが表示されます。
* $5,000,000.00 を超える値の場合、緑色のチェックマークが表示されます。

トレンド インジケーターのテーブル

トレンド インジケーターのテーブル

トレンド インジケーターのテーブル![トレンド インジケーターのテーブル](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_sn-table_trend_indicator.png)

#### メジャーの値をミニ チャートとしてフォーマットする

メジャーは、一連のテキスト値ではなく、一連のミニ チャートとして表現できます。ミニ チャートは、テーブル内のデータのコンテキスト内のメジャー値と、選択した追加の軸を視覚化します。

ミニ チャートを使用すると、重要な軸や関連する軸に関する詳細なコンテキストが提供されます。たとえば、Product の軸と Sum(Sales) のメジャーを含むテーブルでは、各製品の売上を月ごとに分類した一連のミニ チャートとしてメジャーを表現できます。

次の手順を実行します。

1. プロパティ パネルで、 [データ] を展開し、メジャーをクリックします。

   メジャーのプロパティが開きます。

2. [プレゼンテーション] で、 [表記] を [ミニ チャート] に設定します。

3. [軸の選択] で、各ミニ チャートのデータを視覚化するために使用する軸を選択します。

4. [タイプ] でチャートのタイプを選択します。[棒]、[点]、[スパークライン]、[正/負] が利用可能です。

5. ミニ チャートの追加プロパティを設定します。詳細については、以下のセクションで説明します。

ミニ チャートの外観の設定

使用する色や、ミニ チャートにポイントを表示するかどうかを設定できます。

ミニ チャートの色のすべてのオプションにアクセスするには、 [色] を展開します。ミニ チャートは、種類に応じて異なる設定があります。

[ドットを表示] 設定をオンまたはオフにすると、ミニ チャートのデータポイントを表示または非表示にできます。

ミニ チャートのデータの設定

次の設定を使用すると、ミニ チャートで使用されるデータをさらにカスタマイズできます。

* [NULL 値を含める] 設定を切り替えて、ミニ チャートに NULL 値を含めるかどうかを選択します。

* ミニ チャートには、選択したミニ チャートの軸の最大 100 個の一意の値のデータを表示できます。既定では、追加の軸値は表示されません。[その他を表示] をオンにすると、各ミニ チャートの最後に、すべての追加の軸値が 1 つの軸値に結合されて表示されます。

* [Y 軸] では、Y 軸に使用する値を調整できます。[ローカル] 設定を使用して、ミニ チャートに表示されるデータと比較して Y 軸の値を設定します。[グローバル] 設定を使用して、すべてのデータと比較した Y 軸の値を設定します。また、 [自動]、 [ゼロをベースラインとして]、 [ゼロを中心として] のいずれかを選択することで、正の値と負の値の表現方法を設定することもできます。

## テーブルのソート

テーブルのソートはいくつかの方法で調整できます。

* 列ソート: 軸およびメジャーの順序を左から右に調整します。
* 行ソート: 行のソート優先順位を調整します。
* 内部ソート: 軸およびメジャーの内部ソート順序を使用します。
* インタラクティブ ソート: 分析中は、列ヘッダーをクリックしてテーブルをソートできます。

### 列のソート

既定では、列のソート順は軸とメジャーがテーブルに追加された順序に設定されています。最初にメジャー Sales を追加した場合、これがテーブルに最初に表示されます (一番左)。後は、次に追加された軸やメジャーは 2 番目の列にといった具合に、順番に表示されます。列のソート順は、プロパティ パネルの [列] で変更できます。

### 行のソート

既定では、行のソート順は軸とメジャーがテーブルに追加された順序、数値降順、テキスト値昇順に設定されています。列見出しの下に表示されている小さな矢印は、どの列でテーブルがソートされているかを示しています。

行のソート順は、プロパティ パネルの [ソート] で変更できます。軸とメジャーをドラッグして、ソートの優先順位を変更します。多くの場合、ソート順は [ソート] にある最初の軸やメジャーのみならず、それに続く軸やメジャーの影響も受けます。

以下のスクリーンショットは、行がまず Customer でソートされ、次に Month、Product Type の順でソートされています。見ての通り、列 Customer と Month には同じ値を持つ複数の行があります (A-2-Z Solutions と Month)。Product Type にある行はアルファベット順ですが、January (1 月) に顧客 A-2-Z Solutions に販売されたものだけが表示されています。

![テーブルのソート順: Customer、Month、Product Type。](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_TableSorting.png)

ソート順の二次的なソートを Product Type、次を Month に変更すると、すべての Product Type のうち顧客 A-2-Z Solutions に販売されたアイテムがアルファベット順に表示されます。そして、販売が行われた月のみが Month に表示されます。

![テーブルのソート順: Customer、Product Type、Month。](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_TableSorting2.png)

### 内部ソート

各軸とメジャーには、既定で ([自動]) の内部ソート順があります。これは変更可能です。[ソート] にある変更したいアイテムをクリックし、[カスタム] ソートに切り替えるボタンをクリックします。アイテムの内部ソートに対する変更内容が、高い優先順位を持つアイテムと競合するソートであった場合、この変更は有効になりません。

### インタラクティブ ソート機能

分析中、列のヘッダーをクリックすることで、どの列でソートを行うかを設定できます。最初にクリックすると、テーブルは選択したアイテムの既定のソート順に応じてソートされます。2 回目のクリックで、ソート順が逆になります。インタラクティブ ソート機能は、セッションベースで保存されません。ソート順を恒久的に変更したい場合は、プロパティ パネルで変更を行う必要があります。

シートを編集できるユーザーは、チャート探索を使用してインタラクティブに並べ替え、 [シートを編集] をクリックして、その変更を元のテーブルに保存できます。

## ストレート テーブル内の循環軸からアクティブな項目を選択する

ストレート テーブルで循環軸が使用されている場合、ユーザーは循環軸からアクティブな項目を選択できます。

次の手順を実行します。

1. 循環軸の列で the メニュー icon をクリックします。

2. the 循環 icon &lt;軸の名前&gt; をクリックし、循環軸から軸を選択します。

## アドオンの使用

ストレート テーブルでは、プロパティ パネルの [アドオン] に次のオプションがあります。

データの処理:

* ゼロ値を含める: オフのままにすると、値「0」を持つメジャーはプレゼンテーションに含まれません。メジャー値が複数の場合、プレゼンテーションから除外されるには、すべてのメジャー値が値「0」である必要があります。

* 演算実行条件: このテキスト項目で数式を指定して、オブジェクトが表示されるために満たす必要がある条件 (真) を設定します。値は、計算式として入力できます。例: count(distinct Team)&lt;3。条件が満たされない場合は、[表示されたメッセージ] に入力されたメッセージまたは数式が表示されます。

  演算実行条件は、データ量が多いためにチャートまたはテーブルの応答が遅いときに役立ちます。演算実行条件を使用すると、ユーザーが選択を適用してデータを管理できるレベルにフィルタリングするまで、オブジェクトの表示/非表示を切り換えることができます。[表示されたメッセージ] プロパティを使用すると、ユーザーはデータをフィルタリングしやすくなります。

  [演算実行条件の使用](https://share.vidyard.com/watch/UDRXiPe6LFDgdePb4CuF3L)

## ストレート テーブルのスタイルを変更する

プロパティパネルの [スタイル] で、ストレート テーブルのスタイルを変更できます。

### ホバー メニューをオンにする

[スタイル] &gt; [基本] で、 [ホバー メニューを表示] のトグルを使用して、ビジュアライゼーションのホバー メニューを表示するかどうかを選択します。

### 詳細を表示する

説明、メジャー、軸などの詳細を表示することをユーザーが選択できるようにするには、 [スタイル] &gt; [基本] で、[詳細を表示] を [表示] に設定します。

### ユーザーがチャート内の数式を表示できるようにする

数式を表示することをユーザーが選択できるようにするには、 [スタイル] &gt; [基本] で、[数式を表示] を [表示] に設定します。

### 合計を表示する

[スタイル] &gt; [プレゼンテーション] で、チャートに合計を表示する行を表示するかどうかを設定できます。[合計] トグルを使用して、次のオプションを選択します。

* [自動]: 合計値 (数式の結果) がテーブルの上部に自動的に表示されます。
* [カスタム]: 合計値を表示するかどうか、どこに表示するか (上部または下部) を選択します。

合計を表示するように選択した場合は、 [合計ラベル] に値または数式を入力して、合計行のラベルを設定できます。

### ページネーションを使用する

[スタイル] &gt; [プレゼンテーション] で、 [ページネーションを使用] の設定をオンにして、チャートに表示される行数を変更します。ページネーションを使用すると、すべての行を一度に表示するのではなく、一定量の行のみを表示します。ユーザーは、テーブルの下にある矢印ボタンを使用して移動できます。

### テキストの折り返しを使用する

ストレート テーブル内のテキストが長すぎて提供されたスペースでは表示できない場合は、一部のテキストは表示されず、代わりに省略記号が表示されます。[スタイル] &gt; [プレゼンテーション] で、 [複数行のテキストの折り返し] の設定を使用すると、テーブル内のテキストを複数行に折り返すことができます。この設定は、ヘッダー レベルとセル レベルで個別に制御できます。

* ヘッダーのテキストを折り返す (テーブル ヘッダーのみ)

* セル内のテキストを折り返す (テーブル セルのみ)

ヒント メモこれらの設定を使用すると、最大 3 行のテキストを折り返すことができます。テキストが長い場合は、the スタイル指定 icon [] パネルで [行の高さ] の制限を高く設定します。「[グリッドのカスタマイズ](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#GridSettings)」を参照してください。

### Null 値の表現のカスタマイズ

ストレート テーブル内のメジャーの NULL 値の表示方法を変更できます。Null 値を置き換えるために使用する静的テキストを入力します。数値を使用すると、これらの値はテキストではなく数値として解釈されます。これにより、不足している計算を 0 などの実際の値で埋めることができます。

次の手順を実行します。

1. プロパティ パネルで [スタイル] &gt; [プレゼンテーション] をクリックします。

2. [Null 値のテキスト] に、Null メジャー値を置き換えるテキストを入力します。

### 列ヘッダーを非表示にする

列タイトルを表示し、ユーザーが並べ替えを変更できるようにするストレート テーブルの上部にあるヘッダーを非表示にできます。[スタイル] &gt; [プレゼンテーション] で、 [ヘッダーを非表示]の設定をアクティブにします。

## ストレートテーブルのスタイル指定

プロパティ パネルの [スタイル] には、さまざまなスタイル オプションが用意されています。

チャートのスタイル指定をさらにカスタマイズするには、[スタイル] &gt; [プレゼンテーション] で [the スタイル指定 icon] をクリックします。スタイル指定パネルの [基本設定] および [チャート] タブには、さまざまなセクションがあります。

各セクションの横にある ![リセット](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) をクリックすると、スタイルをリセットできます。![リセット](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) [すべてをリセット] をクリックすると、スタイル指定パネルで使用可能なすべてのタブのスタイルがリセットされます。

個々のビジュアライゼーションのスタイル指定に関する一般的な情報については、「 [ビジュアライゼーションへのカスタム スタイル指定の適用](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)」を参照してください。

### テキストのスタイル指定

ストレート テーブルはテキストベースのビジュアライゼーションであるため、テキストのスタイルをさまざまな方法で設定できます。次のレベルでスタイルを適用できます。

* チャートレベル

  * 軸およびメジャーの値とヘッダー

  * メジャーの合計

  * NULL 値

* 列レベルのスタイル指定

* 行レベルのスタイル指定

  * ホバー動作

  * 縞模様 (1 行おきに色を設定)

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. [基本設定] タブで、次のテキスト要素のフォント、強調スタイル、フォント サイズ、色を設定します。

   * タイトル

   * サブタイトル

   * 脚注

4. [チャート] タブで、次のテキスト要素のフォント、強調スタイル、フォント サイズ、色を設定します。

   * ヘッダー: 軸とメジャーのヘッダーのテキストのスタイルを指定します。

   * 軸の値: テキストの軸の値のスタイルを指定します。

   * メジャー値: メジャー値のテキストのスタイルを指定します。

   * 合計: [スタイル] &gt; [プレゼンテーション] で [合計] 行を表示するように選択した場合は、合計のテキストのスタイルを指定します。

   * NULL 値: NULL 値のテキストのスタイルを指定します。強調スタイルと色を変更できます。

   * 縞模様: この設定をオンにすると、行の文字色を交互に設定できます。「[縞模様の適用](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#ZebraStripes)」を参照してください。

表内の各列のテキストにスタイルを適用することもできます。テキストの色、スタイル、配置を構成できます。これらの設定は、プロパティ パネルの [データ] タブで構成されます。 列を個別にスタイル設定した場合、このスタイル設定はチャート レベルで適用されたテキスト スタイル設定よりも優先されます。詳細は、[テーブル項目での作業](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Working)をご覧ください。

さらに、ユーザーが行の上にカーソルを合わせたときにテキストが表示される方法をカスタマイズできます。「[ホバー動作のカスタマイズ](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Customiz)」を参照してください。

### 背景のカスタマイズ

チャートの背景をカスタマイズできます。背景は、色と画像で設定できます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル指定パネルの [一般] タブでは、背景色 (単一色または数式) を選択できます。メディア ライブラリまたは URL から画像を背景に設定することもできます。

   背景色を使用する場合は、スライダーを使用して背景の不透明度を調整します。チャートのヘッダーは常に 100% の不透明度で表示されます。

   背景画像を使用する際、画像のサイズや位置を調整できます。

4. [チャート] タブで、次の要素の背景色をカスタマイズします。

   * ヘッダー (不透明度 100% を使用)

   * 軸の値

   * メジャーの値

   * メジャー ラベル

   * 合計 (不透明度 100% を使用)

   * NULL 値

   * 縞模様 (「[縞模様の適用](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#ZebraStripes)」を参照)

### グリッドのカスタマイズ

テーブルのグリッドをカスタマイズできます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. [チャート] タブで、次の要素のグリッドをカスタマイズします。

   * 行の高さ: 行の高さを行単位で設定します。

   * 境界: セルの境界線の色を設定します。

   * 区切り線: テーブルのヘッダーと本文を分ける区切り線の色を設定します。

### ホバー動作のカスタマイズ

ユーザーがテーブルの行の上にカーソルを合わせたときの表示オプションを設定できます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル パネルの [チャート] タブの [行にカーソルを置く] で、次の設定を調整します。

   * ユーザーがテーブルの行の上にカーソルを合わせたときにその行を強調表示するには、 [オン] に設定します。必要に応じてオフに切り替えることができます。

   * 行にカーソルを置いたときの色: ユーザーが行にカーソルを置いたときに、強調表示する色を設定します。

   * 行にカーソルを置いたときの文字色: ユーザーが強調表示された行のテキストにカーソルを置いたときの文字色を設定します。

### 境界線と影のカスタマイズ

チャートの境界線と影をカスタマイズできます。

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル パネルの [一般] タブの [境界線] で、 [枠線] のサイズを調整してチャートの周囲の境界線を増減します。

4. 境界線の色を選択します。

5. [角の半径] を調整して、境界線の丸みを制御します。

6. [一般] タブの [影] で、影のサイズと色を選択します。影を消す場合は、 [None] (なし) を選択します。

### 縞模様の適用

縞模様をしようすると、直線的なテーブルに色を交互に設定できます。縞模様は、奇数行と偶数行の間のコントラストを高めることで読みやすさを向上させます。

奇数行と偶数行のテキストと背景色を設定できます。

[Zebra stripes](https://play.vidyard.com/TdruWyqDrG9nqXj7VTnHL4)

次の手順を実行します。

1. プロパティ パネルで、 [スタイル] セクションを展開します。

2. [スタイル] &gt; [プレゼンテーション] で、the スタイル指定 icon [] をクリックします。

3. スタイル パネルの [チャート] タブで、 [縞模様] を [オン] に設定します。

4. 次の設定を調整します。

   * 色 (奇数行): 奇数行のテキストの色を設定します。

   * 背景 (奇数行): 奇数行の背景色を設定します。

   * 色 (偶数行): 偶数行のテキストの色を設定します。

   * 背景 (偶数行): 偶数行の背景色を設定します。

## チャート探索の使用

チャート探索により、編集権限を持たないアプリ利用者やその他のユーザーでも、分析モードのときに元のストレート テーブルをカスタマイズできます。これは、the チャート探索 icon [] の the 詳細 icon メニューで使用できます。

アプリの利用者と閲覧者は、チャート探索を使用して、テーブルの列の追加または削除、列の再ソート、列幅の変更、選択の適用を実行できます。チャート探索モードでは、シート上のテーブル全体のサイズまたはレイアウトを変更することはできません。

チャート探索モードは、データをすばやく削除または追加し、データの共有およびダウンロード、または新しいテーブル状態をブックマークするのに最適な方法です。チャート探索モードは、ニーズの異なる多数の視聴者がいるアプリでは非常に役立ちます。チャート探索パネルは、共有またはダウンロードした結果のテーブルには表示されません。

チャート探索モードを使用してテーブルをカスタマイズした場合、公開ブックマークとして保存しない限り、他のユーザーは変更内容を閲覧できません。つまり、複数のユーザーが同じテーブルを同時に変更できるということです。ブラウザ ページを更新しても変更内容は表示されたままですが、ログアウトまたはセッションがタイム アウトすると失われます。この場合、テーブルはストレート テーブルの作成者が設定した既定の状態に戻ります。テーブル レイアウトを保存する場合は、ブックマークを作成します。詳細については、「[ブックマークの作成](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Bookmarks/create-bookmark.htm)」を参照してください。

シートを編集できるユーザーは、チャート探索を使用してテーブルに変更を加え、 [シートを編集] をクリックして、その変更を元のテーブルに保存できます。

アプリ開発者は、プロパティ パネルで [チャート探索] をオンにできます。

* チャート探索を有効にする: オンにすると、チャート探索を使用できます。

* 可視化オプション:

  * 自動: ユーザーがシートを開くと、チャート探索パネルが表示されます。

  * 最小化: チャート探索はオンになっていますが、ユーザーがシートを開いたときに表示されません。the 詳細 icon をクリックしてから the チャート探索 icon [] をクリックすることにより、ホバー メニューで開くことができます。

テーブル項目をチャート探索モードで使用できるようにするには、テーブルの作成者 (またはシートを編集できるユーザー) が、それらの項目、マスター アイテム、または数式を、列または代替列としてテーブルに追加する必要があります。詳細については、「[テーブル項目での作業](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Working)」を参照してください。

ストレート テーブルでのチャート探索。テーブルには、Customer、Region、City の 3 つの列があります。

ストレート テーブルでのチャート探索。テーブルには、Customer、Region、City の 3 つの列があります。

ストレート テーブルでのチャート探索。テーブルには、Customer、Region、City の 3 つの列があります。the チャート探索がオンになっているビュー モードのストレート テーブル。 icon

上記と同じテーブルのチャート探索ですが、テーブルに Sales と Cost の 2 つのメジャーが追加されています。背景色は数式の結果です。

上記と同じテーブルのチャート探索ですが、テーブルに Sales と Cost の 2 つのメジャーが追加されています。背景色は数式の結果です。

上記と同じテーブルのチャート探索ですが、テーブルに Sales と Cost の 2 つのメジャーが追加されています。背景色は数式の結果です。the チャート探索がオンになっているビュー モードのストレート テーブル。 icon

## 制限事項

### 特定のチャートにテーブルが埋め込まれている場合、チャート探索は使用できません

テーブルが次のいずれかのオブジェクト内に埋め込まれている場合、チャート探索は使用できません。

* タブ コンテナに置き換えられていない既存のコンテナ オブジェクト。タブ コンテナは、Qlik Sense Enterprise on Windows および Qlik Sense Desktop の 2024 年 11 月のリリースでネイティブ コンテナ オブジェクトになりました。

  チャート探索は、非推奨の [ShowHide コンテナ] および [タブ付きコンテナ] オブジェクトの既存のインスタンスでも使用できません。ただし、これらのオブジェクトをタブ コンテナに変換することは推奨されていません。代わりに、ストレート テーブルでチャート探索にアクセスするには、新しいタブ コンテナを最初から作成します。

* 格子コンテナ

  [Trellis container エクステンション](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/trellis-container.htm)

### 表示される行数

ページネーションがオンになっている場合、一度に100 行のみ表示できます。ページネーションがオフになっている場合、一度に 250,000 行まで表示できます。テーブルの行数が 250,000 行を超える場合は、ページネーションが適用されます。

大きなテーブルは実用的でなく、管理も難しいため、実際の行と列の数は論理的な最大値よりもはるかに少なくなります。通常、水平方向にスクロールすることなくすべての列が表示できるサイズが理想的です。

### アクセス性

ページネーションがオンになっている場合にのみ、ストレート テーブルのすべてにアクセスできます。キーボード ナビゲーションの詳細については、「[キーボード ナビゲーションとショートカット](https://help.qlik.com/ja-JP/sense/May2025/Subsystems/Hub/Content/Sense_Hub/UserInterface/keyboard-navigation-and-shortcuts.htm)」を参照してください。

関連する学習:

* [Visualization Bundle ストレート テーブルを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Straight_table)

## 詳細を見る

* [Visualization Bundle ストレート テーブルを構成する方法](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Straight_table)