Radar chart エクステンション

レーダー チャート (Radar chart) には、複数の変数について 1 つ以上の数値グループをグラフ化する半径方向軸を使用して、2 次元グラフが表示されます。レーダー チャートを使用して、パフォーマンスを視覚化し、設定された基準またはグループのパフォーマンスと比較することができます。レーダー チャートは Visualization bundle に含まれています。

レーダー チャートには、軸が 2 つとメジャーが 1 つ必要です。y 軸は中心から円周方向に向かい、x 軸はチャートの円周です。それぞれの値はチャート中心からの距離を表し、中心を始点とする軸上に表示されます。チャートの中心は最小値を表し、チャートの端は最大値を表します。

レーダー チャートでは、複数のシリーズを表すことができ、それぞれのシリーズが別々にそれぞれの値と結び付けられています。データはチャートを一回りだけします。値を追加しても、チャートの粒度が上がるだけです。

レーダー チャートの理解

レーダー チャートは、1 点を中心に放射状に配置された等間隔のセグメント (軸) で構成されています。2 番目の軸のデータ値ごとに 1 つのセグメントがあります。各メジャーの値は、該当する軸のノードによって現れます。1 本の線によって同じシリーズに属する値を結ぶことにより、チャートの星形が形成されます。

Example:  


A radar chart with one axis for each month of the Date.Month dimension.

Date.Month 軸の月ごとに軸が 1 つのレーダー チャート。

使用に適しているケース

レーダー チャートにより、任意の数の変数のデータを比較および測定できます。このチャートは、複数のメトリックについて何かの特徴や性能を比較する場合に役立ちます。例: コンピューターを購入する前に、いくつかの特徴について (メモリ容量、処理速度、画面サイズなど) 異なるコンピューターを比較することができます。レーダー チャートは、次の場合にも役立ちます。

  • 品質の改善と性能を測定する。
  • 組織における割り当て量と実際の消費量を比較する。
  • 類似の値や特徴については、データの外れ値、共通点、塊を特定する。
  • アスリートの強さと弱点をグラフ化する。
  • サイズが小中程度の多変量データ セットを比較する。

レーダー チャートの作成

レーダー チャートは、編集中のシートで作成できます。

次の手順を実行します。

  1. アセット パネルで [カスタム オブジェクトVisualization bundle] を開き、[Radar chart] オブジェクトをシートにドラッグします。
  2. 一番上の [軸を追加] ボタンをクリックして、測定される最初の軸カテゴリ (x 軸) を選択します。
  3. 2 つ目の [軸を追加] ボタンをクリックして、2 つ目の軸 (y 軸) を選択します。
  4. [メジャーを追加] ボタンをクリックして、チャートのメジャーを選択します。

軸とメジャーを選択すると、チャート項目にレーダー チャートが自動的に (色付きで) 表示されます。

Example:  


A radar chart with two dimensions, and one measure.

2 つの軸と 1 つのメジャーによるレーダー チャート。

チャートの外観の変更

レーダー チャートは 1 つ以上の特徴を指定してカスタマイズできます。

配色の変更

チャートの配色方法は、4 つの定義済みのオプションから選択することによって変更できます。

次の手順を実行します。

  1. プロパティ パネルで [スタイル] > [Design] をクリックします。
  2. [] で配色を選択します。

    Radar chart color schemes.
レーダー チャートの配色。

ストローク タイプの変更

プロパティ パネルの [スタイル] > [Design] > [Stroke type] で、各ノードを繋いでいる形状線をカスタマイズすることもできます。メニューから形状を選択します。

凡例の切り替え

凡例は、チャートの各ノードについての短い説明です。凡例には、拡張するとそのテキストが表示され、凡例を表示するためチャートが収縮します。凡例を切り替えるには、プロパティ パネルの [スタイル] > [Design] > [凡例] でスライド ボタンをスライドします。

軸の制限

軸の値に制限値を設定することができます。制限値と条件を変更するには、プロパティ パネルの [データ] > [軸] に移動します。軸をクリックし、[制限] でメニューから制限項目を選択します。

タイトルの切り替え

このオプションにより、レーダー チャートの名前を非表示にすることができます。名前を切り替えるには、プロパティ パネルで [スタイル] > [基本設定] の順にクリックします。[タイトルの表示] スライド ボタンをスライドします。

数値書式

メジャー値は書式設定することが可能です。同じ値に異なる書式設定を適用可能です。通貨、日付、期間などのオプションの変更を反映してチャートが更新されます。

次の手順を実行します。

  1. プロパティ パネルで [データ] > [メジャー] をクリックし、メジャーをクリックします。
  2. [数値書式] メニューからオプションを選択します。
  3. パネルの項目に詳細を入力します。これらの項目は、グラフを設定するときに「自動」以外のオプションを選択すると表示されます。

制限事項

全般的な制限事項については、「Qlik が提供するエクステンション バンドルの 制限」を参照してください。