# ブロック チャート

![ブロック チャートの例。](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_IntroBlock.png)

チャートは、数値データをグラフィカルに表現したものです。[チャート プロパティ：[基本設定] ページの チャート タイプ を変更することで、既存のチャートの種類を切り替えることができます。

ブロック チャートは、数式の値と値の関係を大きさが異なる領域ブロックで表示します。最大 3 軸を表示でき、各軸がサブブロックに細分化されます。各ブロックの色を計算するために追加の数式が使用されることがあり、その場合、このチャート タイプはヒート チャートとも呼ばれます。

ツールバーの チャートの追加 the チャートの追加 iconボタン をクリックすると、新しいブロック チャートを簡単に作成することができます。

ブロック チャートを右クリックすると、ブロック チャート：[オブジェクト] メニューが表示されます。ブロック チャートがアクティブなオブジェクトの場合は、[オブジェクト] メニューからもアクセスできます。

次も参照してください。

[クイック チャート ウィザード](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Quick_Chart_Wizard.htm)

[チャートの種類](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_types.htm)

## オブジェクト メニュー

ブロック チャートの [オブジェクト] メニューは、ボタンを右クリックして開きます。メニュー コマンドは次の通りです。

メニューには以下のコマンドがあります。

オブジェクト メニュー コマンド

| コマンド | 説明 |
| --- | --- |
| プロパティ | プロパティ ダイアログを開きます。ここから、チャートを定義する要素を設定できます。 |
| ノート | 現在のオブジェクトに関するノートの作成および共有ができます。 |
| 分離設定 | チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。 |
| 分離解除 | 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。 |
| 参照設定 | このオプションを選択して、チャートの参照 (現在の選択を使用したチャートの固定プロット) を設定します。ドキュメントでさらに選択を行っても、参照プロットは残り、背景に淡色表示されます。チャートの軸等は、常に背景のデータ セットと現在のデータ セットの最大値に調整されます。現在のデータ セットは、常に参照プロットの前面にプロットされます。つまり、参照プロットの一部は、現在のデータ セットのプロットによって隠される場合があります。背景を淡色表示する方法は、[参照モード] 設定 ([チャート プロパティ: 基本設定] ページ内) で制御できます。参照チャート プロットの表示は、一部のチャートの種類 (棒グラフ、折れ線グラフ、コンボ チャート、レーダー チャート、散布図、グリッド チャート、および針を使用するゲージ チャートなど) でのみ可能です。ドリルダウンやサイクリック グループを含むチャートでは [参照設定] は利用できません。ドキュメントを閉じるか、データをリロードすると、参照は失われます。[参照設定] オプションの使用時に含めることができるオブジェクトの最大数は 500 です。 |
| 参照解除 | 参照が設定されると、参照設定 コマンドがこのコマンドに置き換えられます。これを選択すると、以前に設定した参照がクリアされ、チャートが通常のプロット モードに戻ります。 |
| 複製 | チャートの全く同じコピーを作成します。分離設定されたチャートの複製を作成すると、その複製の分離設定は解除されます。 |
| 順序 | このカスケード メニューは [表示] メニューの [デザイン グリッド] コマンドが有効なときと、[デザイン メニュー項目を常に表示] チェック ボックス ([ユーザー プロパティ: デザイン] 内) をオンにした場合、テーブル ボックス、ストレート テーブル、またはピボット テーブルのオブジェクト メニューからこのダイアログを呼び出すことができます。シート オブジェクトのレイアウト レイヤーを設定するためのコマンドが 4 つ含まれています。有効なレイヤー番号は -128 から 127 です。<br><br><ul> <li><span>最前面へ移動</span>: シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最大値に設定します。 </li> <li><span>最背面へ移動</span>: オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最小値に設定します。 </li> <li><span>前面へ移動</span>: シート オブジェクトのレイアウト レイヤーを 1 つ増やします。最大値は 127 です。</li> <li><span>背面へ移動</span>: シート オブジェクトのレイアウト レイヤーを 1 つ減らします。最小値は -128 です。 <br></li> </ul> |
| すべての選択をクリア | チャートの軸と数式での選択をすべてクリアします。 |
| 印刷 | プリンタ設定を指定できる [印刷] ダイアログを開きます。 |
| PDF として印刷 | Microsoft Print to PDF プリンタがあらかじめ選択されている状態で [印刷] ダイアログを開きます。印刷 ボタンをクリックすると、PDF 出力ファイルのファイル名を指定するように要求されます。このコマンドは、PDF プリンタがシステムで使用可能な場合のみ使用できます。 |
| Excel 出力 | 基底のデータ (チャートに相当するストレート テーブル) を Microsoft Excel にエクスポートします。Microsoft Excel が実行されていない場合は、自動的に起動されます。テーブルは、新しい Excel ワークシートに表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 |
| エクスポート | チャートのイメージをファイルに保存するためのダイアログを開きます。イメージは、bmp、jpg、gif、または png 形式で保存できます。 |
| クリップボードにコピー | このカスケード メニューには、シート オブジェクトのためのさまざまなコピー オプションが含まれています。<br>値<br>値をテーブル形式でクリップボードにコピーします。<br>画像<br>チャート オブジェクトの画像をクリップボードにコピーします。画像がシート オブジェクトのキャプションおよび枠線を含むか除外するかは、ユーザー プロパティ：エクスポート ページの設定に従います。<br>オブジェクト<br>シート オブジェクト全体をクリップボードにコピーし、レイアウトの別の場所や、QlikView の現在のインスタンス内で開いている他のドキュメントの別の場所に貼り付けることができます。 |
| リンク オブジェクト | リンク オブジェクト用の次のコマンド メニューを開きます。<br><br><ul> <li><span>リンク オブジェクトを整列する</span>: すべてのシート上にある他のリンク オブジェクトはすべて、選択されたオブジェクトと同じ位置、同じ大きさに整列されます。 <br></li> <li><span>オブジェクトのリンクを解除する</span>: オブジェクト間のリンクを外し、異なるオブジェクトとしてそれぞれに異なるオブジェクト ID を付与します。 </li> </ul> |
| 最小化 | オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) で the Minimize icon アイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 最大化 | オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) で the Maximize icon アイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 元のサイズに戻す | 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) で the Restore icon アイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。 |
| ヘルプ | QlikView ヘルプを開きます。 |
| 削除 | シート オブジェクトをシートから削除します。 |

## チャート プロパティ: 基本設定

基本設定ページでは、タイトルやチャートの種類といった属性を変更できます。これは、クイック チャート ウィザード または チャート プロパティ ダイアログの最初のページです。

チャート プロパティ基本設定

| Property | 説明 |
| --- | --- |
| ウィンドウ タイトル | ウィンドウ ヘッダーに表示されるタイトルです。 タイトルは、ラベルのテキストの動的に更新される計算式としても定義できます。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。<br><br>[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| チャートにタイトルを表示する | デフォルトでは、定義する最初の数式のラベルがチャート タイトルとして設定されます。チャート タイトルを表示しない場合は、チェック ボックスをオフにします。元のタイトルを表示するには、チェック ボックスをオンにするだけです。タイトルは、ラベルのテキストの動的に更新される計算式としても定義できます。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。 ピボット テーブルやストレート テーブルでは、チャート タイトルは表示されません。<br><br>[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| タイトル設定 | タイトル 設定 ボタンをクリックして、チャート タイトルに詳細設定を定義します。 |
| 印刷設定 | 印刷設定 ボタンをクリックすると 印刷設定 ダイアログが開き、余白やヘッダー/フッターを定義できます。[印刷設定] ダイアログは、[印刷：レイアウト] と [印刷：ヘッダー/フッター] の 2 ページで構成されます。<br><br>[印刷: レイアウト](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_Layout.htm) また、[印刷: ヘッダー/フッター](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_Header_Footer.htm) |
| 並列ステート | ドロップダウンの選択肢の中から種類をひとつ選択します。次の並列ステートはいつでも使用できます。<br><br><ul> <li><span>継承済み</span>: シートとシート オブジェクトは、QlikView の開発者が無効にしない限り、常に<span>継承済み</span>ステートになります。この設定はひとつ上のレベルにあるオブジェクトから継承され、これを選択するとシート内のチャートにはシートと同様の設定が適用されます。 </li> <li><span>初期ステート</span>: QlikView で最も使用されるステートで $ で表現されます。QlikView ドキュメントは常に <span>[初期ステート]</span> にあります。 </li> </ul> |
| オブジェクト ID | これは、マクロで使用されます。各シート オブジェクトには一意の ID が割り当てられます。英数字は ID のみに使用することをお勧めします。 リンク オブジェクトは、同じオブジェクト ID を共有します。この ID は後で編集できます。<br><br>チャートの場合、ID は CH01 から始まります。<br><br>[内部マクロ インタープリタ](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm) |
| 分離設定 | 有効にするとチャートは分離されます。これにより、選択されても動的に更新されなくなります。 |
| 読み取り専用 | 有効にするとチャートは読み取り専用になります。これにより、チャート内でマウスを使用してクリックまたはペイントしても選択できなくなります。 |
| 演算実行条件 | このテキスト ボックスに数式を入力して、チャートが表示されるために満たす必要がある条件を設定します。条件が満たされない場合は、「演算実行条件が満たされていません」というテキストがチャートに表示されます。 値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。 |
| チャートの種類 | チャートの種類 グループでは、チャートの基本レイアウトを選択します。各チャートの種類に関しては、[チャートの種類](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_types.htm) を参照してください。 |
| クイック切替 | このグループでは、チャート内のアイコンを有効にして、チャート プロパティ ダイアログを使用せずにチャートの種類を変更できます。<br><br><ul> <li><span>表示する種類</span>: このリストでは、ドロップダウンに表示するチャートの種類を選択します。クイック切替を有効にするために、2 つ以上の種類を選択する必要があります。 </li> <li><span>アイコンの表示位置の指定</span>: グラフィカル チャートでは、クイック切替アイコンをチャート内部とシート オブジェクト キャプション内のいずれかに配置できます。テーブル チャートでは、キャプションが唯一の選択肢です。 </li> </ul> |
| サイズ変更のリセット | このボタンを押すと、グラフィカル チャート内の凡例、タイトルなどのサイズ変更がリセットされます。個々の項目のドッキングは、影響を受けません。 |
| ドッキング位置のリセット | このボタンを押すと、グラフィカル チャート内の凡例、タイトルなどのドッキング位置がリセットされます。 |
| エラー メッセージ | [カスタム エラー メッセージ] ダイアログが開きます。<br><br>[カスタム エラー メッセージ](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Custom_Error_Messages.htm) |
| 参照機能のスタイル | チャートのコンテキスト メニューから 参照設定 オプションを使用したときの参照の背景の描画方法。この設定は、いくつかのチャートでのみ有効に働きます。 |

次も参照してください。

[チャート コンポーネントのサイズ変更と移動](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sizing_and_moving_chart_components.htm)

[チャートとテーブル内での選択](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Selections_in_charts_and_tables.htm)

## チャート プロパティ: 軸

[チャート プロパティ: 軸] ページは、チャートを右クリックして [プロパティ] を選択するか、チャートがアクティブな場合は [オブジェクト] メニューから [プロパティ] を選択して開きます。

チャートを作成する場合は、まず次の 2 つの事項を確認します。

* 表示する対象は? 棒グラフの棒のサイズに対応する対象は? 答えは、sum of sales (売り上げの合計) やそれと同類のものです。これは、数式 ページで設定します。
* チャートをグループ化する基準は? 棒グラフの棒のラベルとして使用する項目値は? 答えは、country (国) 別やそれと同類のものです。これは、軸 ページで設定します。

1 つのチャートは、1 つ以上の軸を表示することができます。上限は、チャート タイプ、データの複雑さ、およびメモリ使用量によって異なります。円グラフ、折れ線グラフ、および散布図は、最大 2 つ、棒グラフ、ブロック、およびグリッド チャートは 3 つの軸を表示できます。レーダー チャートとファネル チャートは軸を 1 つだけ表示でき、ゲージ チャートは軸を表示できません。それ以上の軸は無視されます。

チャート軸は、 [チャート プロパティ: 軸] ページに指定された項目からその値を取得します。1 つの軸は、1 つの項目ではなく項目のグループで構成されることもあります (下の「グループ」を参照)。

項目、グループ、数式 (計算軸) を軸にできます。作成した合成軸も使用できます。

[追加&gt;] や [&lt;削除] ボタンを使用して、(クリックや CTRL+ クリックで) 選択した項目を移動するか、ダブルクリックして移動します。

チャート軸は数式から計算することもできます。

軸プロパティ

| Property | 説明 |
| --- | --- |
| 項目/グループ | 軸として使用できる項目と項目グループのリスト (標準的な棒グラフの x- 軸など)。項目グループは、[ドリルダウン グループ] には垂直矢印が、[サイクリック グループ] にはカーブした矢印が前に表示されます。<br><br>グループは、[ドキュメント プロパティ: グループ] ページで定義されます。 使用/削除する項目をクリックして選択します。[追加 &gt;] ボタンまたは [&lt; 削除] ボタンを使用して、目的の列に移動します。<br><br>使用できる軸の数は、チャートの種類によって異なります。<br><br>複数の内部テーブルに存在する項目にはすべて、キー シンボルが付けられます。円グラフ、折れ線グラフ、および散布図は、3 つ以上の軸を表示できません。棒グラフでは、最大 3 つの軸を表示できます。<br><br>[ドキュメント プロパティ：グループ (Groups)](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Groups.htm) |
| システム項目の表示 | このオプションをオンにすると、システム フィールドが [利用可能な項目/グループ] に表示されます。 |
| テーブルの項目を表示 | ここで、 [項目/グループ] リストにどの項目とグループを表示するかを制御します。ドロップダウン リストは、デフォルトで [すべてのテーブル] を表示します。<br><br>[すべてのテーブル (テーブル名表示)] は、項目をテーブル名とともに表示します。このため、キー項目は一度以上リスト表示されます。(これは表示目的にのみ使用できます。ロード スクリプトの [Qualify](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Qualify.htm) とは関係ありません。)<br><br>一度に 1 つのテーブルの項目を見ることもできます。利用できるグループは常にリストされます。 |
| グループの編集 | このボタンを押すと直接 [ドキュメント プロパティ: グループ] ページに移動し、軸として使用できる項目グループを定義できます。 |
| アニメーション | [アニメーション] ダイアログを開きます。ここでは、チャートの第 1 軸をアニメーションに使用できます。アニメーションは、円グラフ以外のビットマップ チャートでのみ使用できます。アニメーションを使用する場合は、一部の機能が制限されます。 |
| トレリス | [トレリス設定] ダイアログを開きます。ここでは、第 1 軸を基準としたチャートの配列表示を設定できます。どの種類のビットマップ チャートもトレリス表示にできます。 |
| 軸項目 | このリストには、チャートで軸として使用するために現在選択されている項目が含まれます。使用できる軸の数は、チャートの種類によって異なります。指定した種類に不要な軸は無視されます。<br><br>軸データ セルは、テーブルで使用する場合は、属性式で動的に書式設定できます。軸に属性式を入力すると、アイコンの色が灰色からカラーに変わり、テキスト書式 の場合は灰色から黒に変わります。これらの設定は、チャートの設定に優先します。プレースホルダまたは軸の属性式を表示するには、軸の前にある「+」展開アイコンをクリックします。<br><br><ul> <li><span>背景色</span>: [<span>背景色</span>] をダブルクリックして、軸項目のセルの背景色を計算する属性式を入力します。使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。これには、特別な色関数のいずれかを使用します。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。 </li> <li><span>テキストの色</span>: [<span>テキストの色</span>] をダブルクリックして、軸項目のセルのテキスト色を計算する属性式を入力します。使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。これには、特別な色関数のいずれかを使用します。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。 <p><a href="https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm">カラー関数</a></p></li> <li><span>テキストの書式</span>: [<span>テキストの書式</span>] をダブルクリックして、各軸項目のテーブル セル内のテキストのフォント スタイルを計算する属性式を入力します。テキスト書式の数式として使用される数式は、太字を表す '&lt;B&gt;'、斜体を表す '&lt;I&gt;'、下線付きテキストを表す '&lt;U&gt;' を含む文字列を返します。 <br></li> </ul><br><br>[上へ] と [下へ] ボタンで、 [軸項目] リストの軸をソートできます。 |
| [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Block_Chart.htm) [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Block_Chart.htm)計算軸の追加 | 新しい軸を追加し、[数式の編集] ダイアログで編集用に開きます。チャート軸は 1 つの項目であることが多いですが、動的に計算することもできます。計算軸は、1 つまたは複数の項目を含む数式で構成されています。標準的な関数はすべて使用できます。集計関数は使用できませんが、ネストされた集計を行うために Aggr 関数を含めることができます。<br><br>[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 編集 | [数式の編集] ダイアログで編集するために軸を開きます。計算軸の詳細については、上の [計算軸の追加] を参照してください。 |
| 選択軸項目の設定 | このグループには、個々の軸の設定が表示されます。<br><br>有効条件: このチェック ボックスを使って軸を動的に表示/非表示にするには、入力した条件式の値に応じて下の編集ボックスの [...] ボタンをクリックします。<br><br>NULL値を隠す: このチェック ボックスをオンにすると、上の [軸項目] で選択した軸項目の値が NULL の場合、チャートにその項目は表示されません。<br><br>すべての値の表示: 選択条件に関係なくすべての軸項目値を表示するには、このチェック ボックスをオンにします。数式の値は 0 の場合に除外される軸値となるため、すべての値を表示 を機能させるには プレゼンテーション ページの 0 値を隠す オプションをオフにする必要があります。軸として数式を使用する場合、[すべての値を表示] は適用されません。<br><br>凡例の表示: [凡例の表示] チェックボックスをオンにすると、項目値の「名前」が x-軸の隣に表示されます。<br><br>ラベル: [ラベル] チェックボックスをオンにすると、項目の名前が表示されます。ラベルは、下のテキスト ボックスで編集できます。ラベルは、ラベルのテキストの動的に更新される計算ラベル数式として定義することもできます。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。詳細については 、[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) を参照してください<br><br>詳細: このボタンは、[項目詳細設定] ダイアログを開きます。ここでは、項目値の画像表現の設定と特別なテキスト検索オプションを提供します。詳細については 、[Advanced Field Settings](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Advanced_Field_Settings.htm) を参照してください<br><br>コメント: コメント フィールドでは、選択した軸についての説明を入力できます。コメントは、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。<br><br>改ページ: この設定は、ピボット テーブルやストレート テーブルからの印刷時の改ページの使用にのみ適用します。3 つのモードが以下の効果で利用できます。<br><br><ul> <li><span>改ページなし</span>: 必要な場合にのみ、各ページの終わりに改ページを挿入します。 </li> <li><span>条件付き改ページ</span>: 軸の次の値を持つすべての行が現在のページにすべて印刷できる場合以外、改ページを挿入します。 </li> <li><span>強制改ページ</span>: 軸の値が変更されるたびに改ページを挿入します。</li> </ul> |

## チャート プロパティ: 軸の制限

軸の制限はゲージ チャートとピボット テーブルを除くあらゆる種類のチャートで設定できます。

[軸の制限] タブではチャートに表示される軸の値の数を管理します。

まずはじめに、これら 3 つのオプションがドロップダウンの作成時にどのように機能するかについて説明します。ドロップダウンには、[最初]、[最大]、[最小] の 3 つの値があります。計算エンジンはこれらの値に基づいてソートを実行し、チャート エンジンに値を返します。軸の制限を設定する場合、これらのオプションのいずれかを選択する必要があります。ソートは、最優先されるソートが第 1 軸のソートを上書きする可能性がある場合、ピボットテーブルを除いて最初の数式においてのみ実行されます。

このプロパティ ページは、軸の制限の定義に使用されます。チャートの軸は個別に設定されます。

### 制限

#### 最初の数式を使った表示値の制限

これらのプロパティは、下で行った設定に応じて、チャートに表示される軸値の数を決定するために使用します。

#### 表示のみ

このオプションは、[最初] あるいは [最大]、[最小] の値をいくつ (x 個) 表示させたいかによって選択します。このオプションを 5 に設定すると、5 つの値が表示されます。軸の [「その他」の表示] が有効になっている場合、[その他] セグメントには 5 つの値のいずれかひとつが表示されます。 [最初] オプションは、プロパティ ダイアログの [ソート] タブで選択したオプションに基づき、行を返します。チャートがストレート テーブルの場合は、列はその時の第 1 ソート順に基づいて返されます。つまり、列見出しをダブルクリックしてその列を第 1 軸ソートにすると、値の表示を変更できます。[最大] オプションは、チャートの最初の数式に基づいて降順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。[最小] オプションは、チャートの最初の数式に基づいて昇順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。表示する値の数を入力します。 値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。

#### 次の値のみ表示

このオプションを選択すると、このオプションで指定した条件に合うすべての軸の値を表示します。合計値のパーセンテージ、または正確な値に基づいて値を表示するのに使用します。[合計に対する相対値] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にします。 値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。

#### 次に累積する値のみ表示

このオプションを選択すると、現在の行まですべての行を累積し、その値をオプションで設定した値と比較します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にし、累積値 (最初の値または最大値、最小値に基づく) と全体の合計値を比較します。値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。 [境界値を含める] を選択すると、比較値を含有する軸の値が含まれます。

[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

情報メモ累積制限の合計を計算する際、負の値は含まれません。負の値を含む可能性がある項目の相対制限は使用しないようお勧めします。

情報メモ計算軸に制限を加え、データが同じ計算軸でソートされる場合は、ソート順の適用前に軸の制限が適用されます。

### オプション

#### 「その他」の表示

このオプションを有効にすると、チャートに [その他] セグメントを作成できます。表示を制限する比較基準を満たさない軸の値は、すべて [その他] セグメントにまとめられます。選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。[ラベル] 項目で、チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。  
値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。

#### 「合計」の表示

このオプションを有効にすると、チャートには選択した軸の合計が表示されます。この合計値は [プロパティ] ダイアログの **[数式]** タブで設定されますが、数式の合計とは異なります。 **ラベル**: チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。[...] ボタンをクリックすると、数式の編集 ダイアログが開かれます。

#### グローバル グループ モード

このオプションは内部軸にのみ適用されます。このオプションを有効にすると、制限は選択した軸に基づいてのみ計算されます。前の軸はすべて無視されます。このオプションを無効にすると、制限は前のすべての軸に基づいて計算されます。

## 軸の合計値と数式の合計値

計算エンジンで計算された軸の合計値は、個別の行 (または軸項目値) としてチャート エンジンに返されます。これにより [その他] の行の値も変化します。数式の合計値を使用した場合と軸項目値の合計を使用した場合の相違点は以下のとおりです。

![Example comparison between expression totals and dimension totals, which are separated by dimension](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_Totals.png)

数式の合計値と軸の合計値

軸の合計値を使用すると、ストレート テーブルに小計を表示できます。

## チャート プロパティ: 数式

[チャート プロパティ: 数式] タブは、チャートまたはテーブルを右クリックし、[オブジェクト] メニューの [プロパティ] を選択して開きます。

チャートを作成する場合は、次の 2 つの事項を確認します。

* 棒グラフの棒の大きさを表すのは何か。これらは、数式 (売上高の合計 など) です。
* データをどのようにグループ化するのか。これらは、軸 (国 別など)です。

情報メモ[数式] タブはチャートやテーブルの種類によって異なります。特定のチャートやテーブルでオプションが利用できない場合、それらのオプションはグレー表示されています。

### 数式リスト

左上のパネルの式リストは、実際は完全なツリー コントロールで多数のコントロール オプションを含みます。

各数式 (または数式グループ) の前には展開アイコン (「+」の付いた箱) が表示されます。展開アイコンをクリックすると、下にある補助数式または属性式が開きます。アイコンは同時に折りたたみアイコン (「-」) に置き換えられます。特定のプロット オプションは、組み合わせてプロット マーカーを定義する 2 つ以上の数式のセットといったサブ数式を使用します (例：以下に説明する株価や箱ひげ図)。

数式データは、属性式を使用して動的に書式も設定できます。軸の属性式のプレースホルダを表示するには、数式の前にある展開アイコンをクリックします。有効な属性式の種類を次に示します。

#### 背景色

データ点のプロットの色を計算する属性式を作成するには、デフォルトの [背景色] 数式を編集します。計算された色は、デフォルトの QlikView の色の選択に優先します。そして、有効な色表現でなければなりません。これは、カラー関数を使用して行います。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。[テキストの色] の補助数式は同じ方法を使用して作成できます。

[カラー関数](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

#### テキストの色

[テキストの色] の補助数式は、背景色と同じ方法を使用して作成できます (上記を参照してください)。

#### テキストの書式

データ点に関連付けられたテキストのフォント スタイルを計算するには、属性式を入力して [テキストの書式] 数式を編集します (テーブル: 各軸項目のテーブル セル内のテキスト)。計算されたテキスト書式は、[チャート プロパティ: スタイル。

テキスト書式の数式として使用される数式は、太字を表す '&lt;B&gt;'、斜体を表す '&lt;I&gt;'、下線付きテキストを表す '&lt;U&gt;' を含む文字列を返します。文字列の前に = が必要ですので注意してください。

#### 円ポップアウト

属性式を入力して、データ点に関連付けられたスライスを、抽出された「分割」位置に描画するかどうかを計算するには、[分割円] をクリックします。この種類の属性式は、円グラフにのみ有効です。

#### 補正

属性式を入力して、データ ポイントに関連付けられた棒グラフまたは棒グラフのセグメントの間隔を適切に計算するには、[補正] をクリックします。補正は正にも負にも設定でき、棒やセグメントに応じて動かされます。これは、ウォーターフォール グラフと呼ばれるチャートの作成時に便利です。この種類の属性式は、棒グラフにのみ有効です。

#### 線のスタイル

データ ポイントに関連付けられた線または線分の線のスタイルを計算するための属性式を入力するには、線のスタイル をクリックします。この種類の属性式は、折れ線グラフ、コンボ チャート、およびレーダー チャートにのみ有効です。線の相対的な幅は、&lt;Wn&gt; タグを含めることで制御できます。ここで、n はチャートのデフォルトの線の幅に適用される倍率です。数値 n は、0.5 ～ 8 の実数でなければなりません。

&lt;W2.5&gt;

線のスタイルは、&lt;Sn&gt; タグを含めることで制御できます。ここで、n は、使用するスタイルを示す 1 ～ 4 の整数 (1 = 実線、2 = 破線、3 = 点線、4 = 破線/点線) です。例：&lt;S3&gt;。&lt;Wn&gt; および &lt;Sn&gt; タグは自由に組み合わせることができますが、それぞれ最初に出現するもののみが有効と見なされます。タグは単一引用符で囲む必要があります。

#### 値の表示

メイン数式で [データ点の値] をオンにしていなくても、属性式を入力して、データ点のプロットを「データ点の値」の値で補足するかどうかを計算するには、[値の表示] をクリックします。メイン数式で データ点の値 をオンにした場合、属性式は無視されます。この種類の属性式は、棒グラフ、折れ線グラフ、円グラフ、ファネル チャート、およびコンボ チャートにのみ有効です。

### 追加

新しい数式と補助数式は、[追加] ボタンで作成します。このオプションは、数式のリスト内で右クリックしたときに表示されるコンテキスト メニューでも有効です。

### 削除

削除ボタンで、リストから前に作成した数式を削除できます。このオプションは、数式のリスト内で数式を右クリックしたときに表示されるコンテキスト メニューでも有効です。

### コピー

コピー オプションは、数式のリスト内で数式またはサブ/属性式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式でこのコマンドを使用すると、その数式に関連付けられたすべてのデータと設定 (ラベルを含む) が xml としてクリップボードにコピーされます。

その後、この数式を同じチャートや、同じドキュメントまたは別のドキュメントのその他の QlikView チャートに貼り付け直すことができます。このコマンドを属性式で使用する場合は、属性式定義だけがコピーされます。属性式はその後、同じチャートまたは別のチャートの任意のメイン数式に貼り付けることができます。

### エクスポート

エクスポート オプションは、数式のリスト内で数式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式でこのコマンドを使用すると、その数式に関連付けられたすべてのデータと設定 (ラベルを含む) が xml ファイルにエクスポートされます。

その後、この数式を同じチャートや、同じドキュメントまたは別のドキュメントのその他の QlikView チャートにインポートし直すことができます。このコマンドにより、数式をエクスポート ダイアログが開きます。ここでは、エクスポート ファイルの保存先を選択できます。ファイルには、拡張子 Ex.xml が付きます。

### 貼り付け

貼り付け オプションは、数式のリスト内で数式またはサブ/属性式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式がクリップボードにコピーされている場合は、数式のリスト内の空白領域にそれを貼り付けて、コピー元と同一の新しい数式を作成できます。属性式がコピーされている場合は、メイン数式にそれを貼り付けることができます。

### インポート

インポート オプションは、数式のリスト内で空白領域を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。このコマンドにより、以前にエクスポートした数式を参照できるダイアログが開きます。インポートされた数式は、新しい数式としてチャートに表示されます。

### 上下移動

複数の数式が表示される場合、 上へ と 下へ ボタンを使用して順番を変更できます。これは、チャートに表示される列などの順番に影響します。

### グループ

グループ ボタンは、有効な数式が 2 つ以上ある場合に、数式を併せてサイクル グループにするのに使用できます。QlikView のレイアウトでは、チャートに表示されるサイクル アイコンをクリックすると、グループに属する数式を切り替えることができます。 (サイクル グループ)。サイクル アイコンを右クリックすると、そのグループに属する有効な数式を直接選択できるポップアップ リストが表示されます。

情報メモ

[サイクル グループ] と [サイクリック グループ] は同じではありません!

[非階層グループ (サイクリック)](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Nonhierarchic_groups_cyclic.htm)

### グループ解除

グループに属する数式を選択し、 グループ解除 ボタンをクリックすると、数式をグループから解除できます。解除後のサイクル グループに数式が 1 つしか残らない場合、その数式も解除されて、サイクル グループは存在しなくなります。

### 有効化

このチェック ボックスをオフにすると、チャートからその数式が省略されるよう設定されます。

### 相対値表示

このチェック ボックスをオンにすると、絶対数ではなくパーセントで結果を表示するようにチャートを設定します。このオプションは、ピボット テーブルでは使用できません。

### 表示しない

このチェックボックスをオンにすると、この数式に割り当てられたスペースを残しつつ非表示にします。

### 条件付き表示

このチェックボックスを有効にすると、現在の選択に基づいて条件を定義できます。これによって、数式を表示するかどうかが決まります。条件の評価が TRUE または NULL の場合、数式は表示されます。条件の評価が FALSE の場合、数式は表示されません。

### ラベル

数式のラベルの前のアイコンは、使用する チャートの種類 および 数式に設定された表示オプションを示すために使用されます (以下を参照してください)。

### 定義

選択された数式の構成内容を表示します。このボックスで数式を直接編集できます。[...] ボタンをクリックすると、完全な 数式の編集 ダイアログが開きます。

### コメント

この項目は、数式の作成者が数式の機能や目的を説明できるコメント項目です。

### 表示オプション

このグループは、データ点の表示方法やチャート テーブルの数式セルに何を表示するかを修正するために使用されます。一部のオプションは、特定のチャートの種類でのみ有効ですのでご注意ください。また、組み合わせることができないオプションや、複雑なプロットを作成するために 1 つ以上の数式を追加して使用するオプションなどもあります。

#### 棒

選択された数式の値を棒グラフで表示します。このオプションは、棒グラフおよびコンボ チャートでのみ有効です。

#### シンボル

選択された数式の値をマーカーで表示します。このオプションは、線グラフおよびコンボ チャートでのみ有効です。ドロップダウン メニューにあるいくつかの異なるマーカーから選択します。

#### 線

選択された数式の値を線グラフで表示します。このオプションは、線グラフおよびコンボ チャートでのみ有効です。ドロップダウン メニューの [標準]、[なめらか]、または 3 種の [水平] から選択します。

#### ストック

数式を株価マーカーとしてプロットするには、このチェック ボックスをオンにします。[数式] リスト内の数式は、前にアイコンが置かれ、4 つのサブ数式を含む空のプレースホルダとして表示されます。

最初のサブ数式は、株価マーカーの高値ポイントをプロットするために使用されます。2 つ目のサブ数式は、安値ポイントをプロットするために使用されます。株価マーカーが描画されるには、この 2 つのサブ数式に有効な定義が含まれている必要があります。

3 つ目のサブ数式はオプションですが、使用する場合は株価マーカーの終値ポイントのために使用されます。4 つ目のサブ数式もオプションですが、使用する場合は株価マーカーの始値ポイントのために使用されます。

数式で 株価 チェック ボックスをオンにすると、新しい空のサブ数式が自動的に作成されます。数式で 株価 チェック ボックスをオンにしている場合は、同じ数式で 棒、線、マーカー、箱ひげ図、または エラー バー チェック ボックスをオンにできません。数式でそれらのオプションのいずれかが既にオンになっている場合は、その数式で 株価 チェック ボックスをオンにできません。このオプションは、コンボ チャートでのみ有効です。

#### ボックス プロット

数式をボックス プロット (統計データの表示に使用されることが多い) としてプロットするには、このチェック ボックスをオンにします。数式リスト内の数式は、前にアイコンが置かれ、5 つのサブ数式を含む空のプレースホルダとして表示されます。

最初のサブ数式は、箱ひげ図の「箱 (上)」ポイントをプロットするために使用されます。2 つ目のサブ数式は、「箱 (下)」ポイントをプロットするために使用されます。箱ひげ図が描画されるには、この 2 つの数式に有効な定義が含まれている必要があります。

3 ～ 5 つ目のサブ数式は、オプションです。これらの数式は、それぞれ「箱 (中)」、「上ひげ」および「下ひげ」を定義します。

箱ひげ図 の拡張部分は、いわゆる極値のアウトライナーです。これらは、個別の数式をマーカーとしてプロットすることで実現できます。メイン数式で 箱ひげ図 をオンにすると、新しい空のサブ数式が自動的に作成されます。数式で 箱ひげ図 チェック ボックスをオンにしている場合は、同じ数式で 棒、線、マーカー、株価、または エラー バー チェック ボックスをオンにできません。数式でそれらのオプションのいずれかが既にオンになっている場合は、その数式で 箱ひげ図 をオンにできません。このオプションは、コンボ チャートでのみ有効です。

#### エラー バー

メイン式のデータ点の上にプロットされるエラー バーのために補助数式として選択した数式に続いて、1 つまたは 2 つの数式を使用するには、このチェック ボックスをオンにします。両方向を選択する場合は、補助数式が 1 つだけ使用され、データ点の周囲に対称にプロットされます。非対称を選択する場合は、補助数式が 2 つ使用され、それぞれデータ点の上側と下側にプロットされます。

エラー バー数式は、正の数を返します。エラー バーに使用される補助数式には、数式リストでそれぞれ「両方向」、「正方向」または「負方向」アイコンが前に置かれます。補助数式は、チャートのそれ以外のものには使用できません。選択された数式の後に定義済みの数式がない場合は、新しいダミーの補助数式が自動的に作成されます。このオプションは、棒グラフ、折れ線グラフ、およびコンボ チャートでのみ有効です。

#### データ点の値

数式の結果をデータ点の上側にテキストとしてプロットするには、このチェック ボックスをオンにします。このオプションは、棒グラフ、折れ線グラフ、コンボ チャート、および円グラフでのみ有効です。円グラフで使用する場合は、スライスの横に値が表示されます。

#### 軸上のテキスト

数式の結果を各 x- 軸値、軸、および軸ラベルにテキストとしてプロットするには、このチェック ボックスをオンにします。このオプションは、棒グラフ、折れ線グラフ、およびコンボ チャートでのみ有効です。

#### 数式値のポップアップ

レイアウトでチャート内のデータ点にポインタを置いたときに表示されるポップアップ バルーン メッセージに数式の結果を表示するには、このチェック ボックスをオンにします。このオプションは、他の表示オプションの使用に関係なく使用できます。このため、数式をチャート自体には表示せず、ポインタを置いたときに表示されるポップアップにのみ表示することができます。

#### 意味

このオプションは、ストレート テーブルとピボット テーブルでのみ有効です。

#### テキスト

数式値は常にテキストとして解釈および表示されます。

#### 画像

このオプションでは、QlikView は各数式値を画像への参照として解釈しようとします。参照は、ディスク上の画像ファイルへのパス (例: C:\Mypic.jpg) または QlikView ドキュメント内の画像ファイルへのパス (例: qmem://&lt;Name&gt;/&lt;Peter&gt;) になります。QlikView が数式を有効な画像参照として解釈できない場合は、[画像がない場合にテキストを隠す] チェックボックスがオンでない限り、値自体が表示されます。

#### 円形ゲージ、線形ゲージ、信号機ゲージ、LED ゲージ

いずれかのゲージ オプションで、ゲージ チャートは画像として使用可能なテーブル セルに内接して表示されます。ゲージのレイアウトは [チャート プロパティ: プレゼンテーション] ダイアログで変更できます。このダイアログにアクセスするには、[ゲージの設定] ボタンを使用します。

#### ミニ チャート

このオプションでは、数式の値を棒グラフや折れ線グラフで表示します。チャートは使用可能なテーブル セルに内接して表示されます。チャートの視覚的な設定は [ミニ チャートの設定] ボタンで変更できます。このオプションは、ストレート テーブルでのみ有効です。

[Mini chart settings](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sparkline_Settings.htm)

情報メモExcel に出力する場合、ミニ チャートは表示されません。

#### リンク

テーブル セルにクリック可能なリンクを作成する数式を、[定義] 項目に入力するにはこのオプションを選択します。数式は、DisplayText&lt;url&gt;LinkText と解釈されるテキストを返します。DisplayText は、テーブル セルに表示されるテキストで、LinkText は、新しいブラウザ ウィンドウを開くリンクです。

リンクが定義されると、テーブル セルの値に下線が引かれます。リンクが定義されない場合は、値に下線は引かれません。表示モードでは、リンクを表示するセルでの選択は行えませんのでご注意下さい。[...] ボタンをクリックすると、完全な 数式の編集 ダイアログが開きます。

情報メモURL リンクは、セキュリティ上の制限により、Ajax クライアントでのみ機能します。

=Name & '&lt;url&gt;' & Link

=Name & '&lt;url&gt;www.qlikview.com'

ここで Name と Link はロード スクリプトでロードされたテーブル項目です。

#### 画像形式

上記で [画像] オプションを選択した場合のみ使用できます。このオプションは、ストレート テーブルとピボット テーブルでのみ有効です。この設定は、画像をセルに合わせるための QlikView の書式設定方法を表します。次の 4 つの選択肢があります。

* 縮小/拡大なし: このオプションを選択した場合、画像は拡大縮小されずにそのままのサイズで表示されます。したがって、画像の一部が表示されない場合や、セルの一部が画像で覆われない場合があります。
* 全体を覆う: このオプションを選択した場合、画像は、画像の縦横比の維持を考慮せずに、セル全体を覆うように拡大されます。
* 縦横比を固定する: このオプションを選択した場合、画像は、縦横比を維持したまま、セルをできるだけ広く覆うように拡大されます。
* 縦横比を固定して全体を覆う: このオプションを選択した場合、画像は、縦横比を維持したまま、セル全体 (上下/左右とも) を覆うように拡大されます。したがって、通常は、どちらかの方向で画像が切り詰められます。

### 累積

このグループの設定から選択して、チャートの値を累積するかどうかを決定します。累積チャートでは、各 y 値が後続する x 値の y 値に加算されます。累積棒チャートには、年ごとの売上の合計が表示されます。たとえば、1996 年の値は 1997 年の値に追加されます。

チャートに複数の数式が含まれている場合、累積する値のある数式を [数式] リストで選択します。累積は、ピボット テーブルでは使用できません。

#### 累計なし

このオプションを選択すると、選択したチャート式の y 値は累積されません。

#### 全累計

このオプションを選択すると、各 y 値が数式の前の y 値をすべて累積します。上記の「累積」を参照してください。すべて累積表示は Null 値や 0 値を含む複数軸では機能しません。

情報メモトレリス チャートを有効にした場合、すべて累積表示は機能しません。

#### 累積表示 n 段階後退

ボックスに数値を入力して、数式の y 値の累積される回数を設定します。上記の「累積」を参照してください。

### 合計モード

このグループは、ストレート テーブルのチャート オブジェクトにのみ選択した数式に有効です。以下の 3 つの設定があります。

* 合計なし: 選択した数式で合計は計算されません。
* 数式の合計: 次のレベルで評価される数式の合計。例えば、数式が社員の月収の平均値を生成する場合、 数式の合計 はすべてのサラリーの全体の平均を生成します。
* 行の (集計関数): このオプションを選択すると、選択した数式の各データ点の個々の値 (棒グラフの各棒、ストレート テーブルの各行など) が、ドロップダウン リストから選択した集計関数 (通常は合計) を使用して合計されます。

情報メモ[最初の文字列] または [最後の文字列] は最も高い値か低い値で、テーブルでは英数字順に表示されます。英数字の順序は 0 から 9、その後 A から Z へと続きます。

### 枠線の幅

棒グラフとコンボ チャートで、数式によって表示される棒の周囲の枠線の幅を指定します。値は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。

### 数式を凡例として表示

複数の数式を使用する場合、数式と対応する色を表示する凡例をチャートの隣に表示できます。

### すう勢線

選択した QlikView チャートの数式では、プロットが統計すう勢線で補完されたり、置き換えられます。

すう勢線は、散布図、折れ線グラフ、および棒として最大 1 つの軸と 1 つの数式だけを持つ棒グラフとコンボ チャートにのみ表示できます。他の種類のチャートでは、すう勢線 グループの設定は無効で効果がありません。散布図では、データ点が y=f(x) のように扱われます。棒グラフ、折れ線グラフ、およびコンボ チャートでは、表示オプション のすべてのオプションをオフにした場合でも、すう勢線を追加できます。これにより、すう勢線は基底のデータ点なしで表示されます。棒グラフ、折れ線グラフ、およびコンボ チャートのすう勢線は、フォーキャストまたはバックキャストを指定 ([目盛線] ページ) して外挿することができます。外挿線は点線で表示されます。不連続な x- 軸を含むチャートのすう勢線は、マーカー付きの線で表示されます。連続軸では、線のみが表示されます。

* 平均: 平均が直線で描画されます。
* 線形: 直線回帰線が描画されます。
* 2 番目の角度の多項式近似: 2 次元多項式のすう勢線が描画されます。
* 3 番目の角度の多項式近似: 3 次元多項式のすう勢線が描画されます。
* 4 番目の角度の多項式近似: 4 次元多項式のすう勢線が描画されます。
* 指数: 指数関数のすう勢線が描画されます。
* 方程式の表示: 特定の数式でこのチェック ボックスをオンにすると、その数式のすう勢線はチャートにテキストで表示されるすう勢線の方程式で補完されます。
* R2 を表示: 特定の数式でこのチェック ボックスをオンにすると、その数式のすう勢線はチャートにテキストで表示される決定係数で補完されます。

[テーブル チャートの直線回帰](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/NestedAggregations/linear-regression-table-charts.htm)

## チャート プロパティ: スタイル

このページでは、チャートの基本的なスタイルを選択します。リスとされた機能はすべて、すべてのチャートの種類で有効です。

* スタイル: 有効なスタイルの 1 つを選択します。これは、いくつかの場合には、チャートの外観だけではなくその機能性にも影響するかもしれません。

* 方向: チャートの方向を水平または垂直に設定します。

* 下位の種類: このグループで、モードを [グループ] または [積み上げ] (レーダー チャートでは [オーバーレイ] または [積み上げ]) に設定できます。この設定はチャートが 2 つの軸を表示する、もしくは 1 つの軸と 2 つ以上の数式を表示する場合にのみ機能します。積み上げ棒グラフの負の値は、個別に x- 軸の下側で下方向に積み上げられます。棒グラフでは、連続軸目盛を使用する場合、積み上げレイアウトのみがレイアウトとして許可されます。  
    
  複数の軸と数式をもつ棒グラフの表示には、次の原則が適用されます。

  * X-軸に表示できるのは最大 2 軸です。
  * 第 3 軸は、要素を塗り分けた積み上げ棒として表示されます。
  * テーブル チャートのみ 3 つ以上の軸を表示することができます。
  * 2 つ以上の数式が有効な場合、最初の 2 つの軸が X-軸として表示され、数式は要素を塗り分けた積み上げ棒として表示されます。
  * 2 つ以上の数式が有効で、サブグループが積み上げに設定されている場合、1 つの積み上げ内にあるすべての数式は、1 つの軸に応じて計算されます (デフォルトでは左)。これは、左の軸に応じて 1 つの数式を計算し、別の数式を右の軸に応じて計算するように設定する場合にもあてはまります。

  以下のリストに、下位の種類を使用した複数の軸および数式の表示状態を示します。

  * 1 軸
    * 数式 1 つ: 単一の棒
    * 数式 2 つ以上: 数式はグループもしくは積み上げ
  * 2 軸
    * 数式 1 つ: 軸はグループもしくは積み上げ
    * 数式 2 つ以上: 軸はグループ
  * 3 軸
    * 数式 1 つ: 第 1 、第 2 軸はグループ、第 3 軸は積み上げ
    * 数式 2 つ以上: 第 1 、第 2 軸はグループ、数式は積み上げ
  * 4 軸
    * 数式 1 つ: 第 1 、第 2 軸はグループ、第 3 軸は積み上げ
    * 数式 2 つ以上: 第 1 、第 2 軸はグループ、数式は積み上げ

* 3 次元ビュー: このグループの設定では、チャートを 3 次元モードで表示する角度を定義します。

  * 回転角度 (縦): 3 次元ビューの縦の角度を定義します。値は 5 ～ 45 の整数です。
  * 回転角度 (横): 3 次元ビューの横の角度を定義します。値は 5 ～ 45 の整数です。

* プロット エリア色のスタイル: このコントロールは、チャートのすべてのプロットの色に色のスタイルを適用する場合に使用できます。ドロップダウン リストでスタイルを選択すると、[色] ページの [カラー マップ] のすべての色が選択したスタイルに変更されます。スタイルは即座に変更されますが、設定自体は、ダイアログのこのページを次に表示するまで保存されません。カラー マップの実際の基本色は、影響を受けません。[プロット エリア色のスタイル] 設定は、すべてのチャートの種類で有用な訳ではありません。次のオプションを使用できます。

  * 単色: カラー マップのすべての色を単色に設定します。
  * 暗いグラデーション: マップのすべての色を黒へ移行するグラデーションに設定します。
  * 明るいグラデーション: カラー マップのすべての色を明るい色調へ移行するグラデーションに設定します。
  * 光沢: すべての棒を光沢ある色調に設定します。

* プロット エリア背景のスタイル: このコントロールは、プロット エリアの背景の表示を変更するのに使用できます。この設定は、プロット エリアのあるチャートでのみ使用できます。次のオプションを使用できます。

  * フレーム: フレームがプロット エリアの周囲に描かれます。
  * 影: このオプションは、プロット エリアの背景に影の効果を追加します。
  * 最小: このオプションは、プロット エリアの背景を削除します。

* プレビュー: チャートの基本的な視覚プロパティのプレビューを提供します。

## チャート プロパティ：プレゼンテーション (ブロック チャート)

このダイアログでは、データ ブロックの表示方法を設定できます。

初期値は次のとおりです。

デフォルト値

| 構成 | 値 |
| --- | --- |
| 表示レベル | ブロック チャートは、最高 3 レベルのブロック (軸を 3 つ設定するのと同じ) で表示できます。1、 2 または 3 を選択し、実際に表示するレベル数を設定します。 |

[ポップアップ] グループの次のオプションを選択し、データにマウス ポインターを近づけたときに表示されるポップアップでどの情報を表示するかを設定します。

ポップアップの設定

| 構成 | 説明 |
| --- | --- |
| 表示 | マウス ポインターが値に触れたときに、ポップアップ ウィンドウに軸と数式の値を表示するかどうかを選択します。[設定...] をクリックして、ポップアップ ラベルを表示する軸と数式をカスタマイズします。 |
| 第 1 軸の比率値 | 指定された第 1 軸の値を合計と比較したパーセンテージをポップアップに表示します。 |
| 第 2 軸の比率値 | 指定された第 1 軸の値を定義したように、指定された第 2 軸の値を合計と比較したパーセンテージ。 |
| 第 3 軸の比率値 | 第 3 軸のレベルで上記と同じ。 |
| 第 1 軸の実数値 | 指定されたブロックを指定された第 1 軸の値の合計と比較したパーセンテージ。 |
| 第 2 軸の実数値 | 指定されたブロックを指定された第 2 軸の値の合計と比較したパーセンテージ。 |

軸ラベルの設定

| 構成 | 説明 |
| --- | --- |
| 軸ラベルの表示 | チャートにラベルを表示するにはこのチェックボックスをオンにします (デフォルトでオン)。対応するボタンをクリックし、設定を変更することもできます。<br>ラベルに数値を表示チェックボックスをオンにすると、ラベルに数値が表示されます。 |

[チャートのテキスト] グループは、自由に移動できるテキストをチャートに追加するために使用します。

チャートのテキスト コマンド

| コマンド | 説明 |
| --- | --- |
| AllowAlternateAdmin=1 | 新しいチャート テキストを作成するための [チャート テキスト] ダイアログが開きます。 |
| 編集 | [チャート テキスト] ダイアログで既存のテキストのプロパティを編集するには、リスト内で強調表示してこのボタンをクリックします。 |
| 削除 | 既存のテキストを削除するには、リスト内で強調表示してこのボタンをクリックします。 |

[チャート テキスト](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_texts.htm)

自由に移動できるテキストがチャートの左上に表示されますが、チャートがチャート レイアウト編集モードの場合、配置し直すことができます。

[チャート コンポーネントのサイズ変更と移動](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sizing_and_moving_chart_components.htm)

凡例グループでは、チャートの軸データ ラベルの表示を制御できます。データ ラベルを表示するには、このチェック ボックスをオンにします。データ ラベルは、チャートの現在の最上位レベルについてのみ表示されます。

凡例の設定

| 構成 | 説明 |
| --- | --- |
| 凡例の表示 | チャートにラベルを表示するにはこのチェックボックスをオンにします (デフォルトでオン)。設定ボタンをクリックし、[凡例の書式](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Legend_Settings.htm)を変更できます。チャートに軸の設定が無くても数式がいくつかある場合、このチェックボックスをオフにすると代わりに数式を X- 軸に表示します。 |
| 凡例に表示する文字数 | 軸およびチャートの凡例に表示する軸の値の文字列長を制限するには、このチェック ボックスをオンにします。チャートでは、切り捨てられた値の後に、... が置かれます。 |

[ブロックの枠線] グループでは、3 つの異なる軸レベルのブロックの周りに描画される枠線の幅と色を設定できます。ブロックの枠線は、ブロック チャートのキャプション スタイルを使用する場合、適用できません。

いずれの軸も、スピナー コントロールで枠線の幅を変更し、[色] ボタンで枠に違う色を選択できます。

[キャプションの設定] グループでは、最上位および中間の軸レベルで使用するキャプションのフォントと色を設定できます。これらの設定は、ブロック チャートのキャプション スタイルを使用する場合のみ適用できます。

キャプションの設定

| 構成 | 説明 |
| --- | --- |
| フォント... | キャプションのフォントを設定するための [フォント] ダイアログを開きます。 |
| 色 | キャプションの基本色を設定するための [色の設定] ダイアログを開きます。 |
| 中間レベル キャプション | 3 軸のブロック チャートで中間軸レベルのキャプションを描画する場合は、このチェック ボックスをオンにします。 |

## 目盛線

目盛線 ページでは、X- 軸と Y- 軸の表示プロパティを設定できます。

## チャート プロパティ: 色

[チャート プロパティ: 色] ページは、チャート ウィンドウを右クリックし、[オブジェクト] メニューの [プロパティ] を選択して開きます。

データの書式グループでは、チャートの軸項目値に 18 の異なる色を配置することができます。

外観の設定

| 構成 | 説明 |
| --- | --- |
| 色 1 - 18 | 色は、単色またはグラデーションとして定義できます。色をカスタマイズするには、ボタンをクリックして [色の設定] ダイアログを開きます。<br><br>初期設定色を取得ボタンは、カラー マップを QlikView のデフォルトの設定にリセットします。<br><br>色の変更を元に戻す ボタンは、このダイアログを開いたときに適用されていた色の設定に戻します。<br><br>[詳細設定...] ボタンは、[カラー マップ 詳細設定] ダイアログを開きます。ここでは、カラー マップを設定し、シート、ドキュメント、ユーザー、QlikView の初期設定を取得できます。 |
| 要素を塗り分ける | このチェックボックスをオフにすると、すべての要素が同じ色になります。 |
| 固定色 | このチェックボックスをオンにすると、カラー マップがロックされ、永久に同じ色をそれぞれの値に適用します。 |
| 最後の色を繰り返す | このチェックボックスをオンにすると、18 番目の以降の値にはすべてカラー マップ の 18 番目の色が適用されます。オフの場合、1 から 18 の色を順番に繰り返し使用します。 |

フレームの背景 グループでは、プロット エリアの背景とプロット エリアの周囲の領域の背景に色を設定します。

背景の設定

| 構成 | 説明 |
| --- | --- |
| 色 | 色付きの背景でチャートがプロットされます。プロット エリアと周囲の領域に異なる色を設定できます。<br><br>どちらのボタンもクリックすると [色の設定] ダイアログを開きます。<br><br>ヒント メモ背景色設定は、画像やプロット エリアのみと組み合わせることができます。 |
| 背景 | プロット エリアの周囲の背景またはチャートの場合はチャート全体の背景に使用される色。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。デフォルトの色は、白です。 |
| プロット エリア | チャートのプロット エリアに使用される色。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。デフォルトの色は、ライト グレーです。この設定は、円グラフとファネル チャート、レーダー チャートでは使用できません。 |
| 画像 | 画像を選択して 画像 ボタンをクリックすると 画像の挿入 ダイアログが開き、背景画像をインポートできます。<br><br>プロット エリアのみ チェックボックスをオンにすると、インポートした画像がプロット エリア のみに制限されます。 |
| 動的画像 | 計算式を入力し、選択によって動的に変化する画像を背景に表示します。棒グラフ、折れ線グラフ、コンボ チャート、散布図およびグリッド チャートで有効です。 |
| 透過性 | チャートの背景の透過性を設定します。0% を指定すると背景は完全に不透明になり、上の [背景色] で定義した色になります。100% の場合、背景は完全に透明になります。 |

プロット エリアの枠線 グループでは、プロット エリアの周囲に描画される四角形の枠線の 幅 と 色 を設定できます。

## チャート プロパティ: 数値

このページは、アクティブなチャートに適用されます。また、項目値を設定する次のコントロールが含まれます。

数値書式

| 書式 | 説明 |
| --- | --- |
| 初期設定値 | 初期設定値の数値書式を使用して数値を表示します。 |
| 数値 | 有効桁数 ボックスで設定した桁数で数値を表示します。 |
| 整数 | 数値を整数で表示します。 |
| 実数 | 小数点以下の桁数 ボックスで設定した桁数の小数点値で数値を表示します。 |
| 通貨 | プレビュー テキスト ボックスに表示される書式で数値を表示します。デフォルトの書式は Windows の通貨設定です。 |
| 日付 | 書式パターン 編集ボックスに設定される書式で日付として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。 |
| 時刻 | 書式パターン 編集ボックスに設定される書式で時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。 |
| 日付と時刻 | 書式パターン 編集ボックスに設定される書式で日付 + 時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。 |
| 時間間隔 | シーケンシャルな時間増分で時間を表示します (例：書式 = mm では、値をカレンダーが始まってからの分の数で表示します (1899:12:30:24:00)。 |

[パーセント表示 (%)] ボタンは次の書式で機能します: [数値]、[整数]、および [実数]。

小数点 と 桁区切り 区切り記号は、 区切り記号 グループの編集ボックスで設定できます。

単位 では、編集ボックスに単位、千の単位、百万の単位、十億の単位を入力できます。

ISO ボタンは、日付、時刻、タイムスタンプの書式に標準 ISO を使用します。

システム ボタンは、書式設定をシステム設定に設定します。

## フォント

ここでは、フォント、スタイルおよびフォント サイズを設定します。

フォントの設定は、1 つのオブジェクト用には [オブジェクト プロパティ: フォント] を使用して、ドキュメント上のすべてのオブジェクト用には [オブジェクトに適用] ボタン ([ドキュメント プロパティ: フォント] ページ上) を使用して行うことができます。

さらに、新しいオブジェクト用のドキュメントのフォント初期設定は、[ドキュメント プロパティ: フォント] ページで設定できます。2 つの初期フォントがあります。

1. 最初のデフォルト フォント (リスト ボックス、チャートなど) は、リスト ボックスやチャートなどのほとんどのオブジェクトで使用されます。
2. 次のデフォルト フォント (テキスト オブジェクトとボタン) は、一般的に大きなフォントを必要とするボタンやテキスト ボックスに使用されます。

最後に、新しいドキュメントのフォント初期設定は、[ユーザー プロパティ: フォント] で設定できます。

チャート、ボタンおよびテキスト オブジェクト (検索オブジェクト以外) には、フォントの色も指定できます。色は、[固定] もしくは [計算] (数式で動的に計算します) を選択します。数式は有効な色表現でなければなりません。カラー関数を使用して作成します。数式の結果が有効な色表現でない場合は、フォントの色はデフォルトで黒になります。

[カラー関数](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

その他の設定は次のとおりです。

* ドロップシャドウ: このチェック ボックスをオンにすると、テキストにドロップ シャドウが追加されます。
* 下線: このチェック ボックスをオンにすると、テキストに下線が引かれます。

選択したフォントのサンプルが、プレビュー パネルに表示されます。

## レイアウト

レイアウトの設定をオブジェクトのプロパティ ページから行うと、そのオブジェクトにのみ適用されます。   
レイアウトの設定をドキュメントのプロパティ ページから行うと、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

### 枠線の使用

シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。ドロップダウン メニューから選択して、枠線の種類を指定します。

* 影の強度:影の強度ドロップダウン メニューで、シート オブジェクトの周りの影の強度を設定できます。影なしの選択肢もあります。
* 枠線のスタイル: 既定の枠線は次のとおりです。
  * 単色: 単色の固定の枠線。
  * くぼみ: シート オブジェクトが背景からくぼんでいるように見える枠線。
  * 浮き彫り: シート オブジェクトが背景から浮き上がっているように見える枠線。
  * 壁: シート オブジェクトの周囲に壁があるように見える枠線。
* 枠線の幅: このオプションは、すべての種類の枠線で有効です。幅は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
* 色: このボタンをクリックするとダイアログが開き、すべての種類の枠線に適用される基本色をカラー パレットから選択できます。
* 虹色: すべての種類の枠線を虹色の枠線にします。虹は、シート オブジェクトの上部で選択した基本色で始まります。

[簡易設定が] が [スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) として選択されている場合、枠線の種類は選択できません。設定できるのは [影の強度] のドロップダウン メニューと [枠線の幅] のみとなります。

### 角を丸くする

角を丸くする グループでは、シート オブジェクトの基本の形を設定できます。これらの設定により、シート オブジェクトを円形/楕円形から長方形までの範囲で描くことができます。[角を丸くする] を使用できるのは、[詳細設定]、[スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) が選択されている場合のみです。

* 角を丸くする: このチェックボックスをオンにすると、角の形を丸くするオプションを設定できるようになります。
* 角: チェック ボックスをオフにした角は直角に描画されます。
* 鋭度: 2 から 100 の間の数値を設定でき、数値 100 を定義すると直角、数値 2 は完全な楕円 (縦横比が 1:1 の場合は円) に相当します。丸い角には、鋭度 2 から 5 が通常最適な数値です。
* 角の丸み: この設定は、固定の距離 (固定)または四分円全体に対するパーセンテージ (相対値(%)) で、角の半径を決定します。この設定により、鋭度で設定した基になる基本図形が角に影響を与える程度を制御できます。距離は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。

### レイヤー

レイヤー グループでは、オブジェクトを 3 つのレイヤーのいずれかを割り当てることができます。

* 背面:背面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと前面レイヤーにあるシート オブジェクトを覆うことはできません。背面レイヤーにある他のシート オブジェクトの上にのみ配置できます。
* 標準: シート オブジェクトは、作成されると、標準位置 (中央) のレイヤーに置かれます。標準位置レイヤーにあるシート オブジェクトは、背面レイヤーのシート オブジェクトで覆われることはありませんし、前面レイヤーのシート オブジェクトを覆うこともできません。
* 前面:前面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと背面レイヤーにあるシート オブジェクトによって覆われることはありません。その上に配置できるのは、前面レイヤーにある他のシート オブジェクトだけです。
* カスタム:前面、標準位置、および背面レイヤーは、内部的に番号が振られたレイヤー 1、0、-1 にそれぞれ対応しています。実際には、-128 ～ 127 の間のすべての値が使用できます。選択した値を入力する場合は、このオプションを選択します。

### テーマの作成

テーマ作成 ウィザードを開くと、レイアウト テーマを作成できます。

### テーマの適用

オブジェクト、シート、ドキュメントにレイアウト テーマを適用できます。

[レイアウト テーマ](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 表示

表示 グループでは、シート オブジェクトを表示する条件を指定できます。

* 常時: シート オブジェクトは常に表示されます。

* 条件付き表示: シート オブジェクトは、選択などで継続的に評価される条件付き関数に基づいて表示/非表示にされます。シート オブジェクトは、その条件が FALSE を返す場合にのみ非表示になります。

  [条件分岐関数](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

情報メモ

ドキュメントの管理権限を持つユーザーは、[すべてのシートとシート オブジェクト] を [ドキュメント プロパティ: セキュリティ] で該当のチェック ボックスをオンにしてある場合のみ有効です。CTRL+SHIFT+S を押して、この機能を切り替えることができます。

[ドキュメント プロパティ：セキュリティ](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### オプション

オプション グループでは、シート オブジェクトの移動/サイズ変更を禁止できます。このグループの設定は、対応するチェック ボックスが [ドキュメント プロパティ: レイアウト] と [シート プロパティ: セキュリティ] で該当のチェック ボックスをオンにしてある場合のみ有効です。

* 移動/サイズ変更を許可する: このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
* コピー/複製を許可する: このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。
* INFO を許可する:info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。  
    
  [Info](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* データにサイズを合わせる: 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。

### スクロール バー

スクロール バー グループには、スクロール バーのレイアウトを変更するコントロールがあります。

* スクロール バーの位置を保持する: この設定が有効の場合、QlikView は、他のオブジェクトで選択が行われたときに、スクロール バーが設定されているテーブルやチャートのスクロールの位置を保持しようとします。この設定は [ユーザー プロパティ: オブジェクト] でも有効にする必要があります。ドキュメントを閉じると、スクロールの位置は保持されません。
* スクロール ボタン: スクロール ボタンの色を設定します。ボタンをクリックして色を選択します。スクロール バーは、薄い灰色で描画するとよい結果が得られます。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。
* スクロールの背景: スクロール バーの背景色を設定します。ボタンをクリックして色を選択します。
* スクロール バーの幅: このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。
* スクロールのスタイル: スクロール バーのスタイルを設定します。ドロップダウン コントロールでスタイルを選択します。クラシック スクロール バー スタイルは、QlikView の 4/5 スクロール バーに対応します。標準スクロール バー スタイルは、最新の外観になります。3 つ目のスタイル、ライトは細く、ライトなスクロールバーです。  
  スクロール バー スタイルを表示するには、[スタイルのモード] を [詳細設定] に設定する必要があります。この設定は、[基本設定] タブで [設定] ドロップダウン メニューを開き、[ドキュメント プロパティ] を選択すると見つかります。

* 適用対象:キャプションと枠線のプロパティ ダイアログを開きます。ここでは、レイアウト ページで設定されたプロパティを適用する場所を設定できます。

## キャプション

キャプションの設定が [オブジェクト プロパティ] ページで行われた場合は、そのオブジェクトにのみ適用されます。   
キャプションの設定が [ドキュメント プロパティ] ページで行われた場合は、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

キャプション ページでは、オブジェクトの基本的なレイアウトとは全く違うレイアウト オプションを指定できます。

* キャプションの表示: このオプションをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
* タイトル テキスト: テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。キャプションのフォントを変更するには フォント ボタンを使用します。

異なる状態のキャプションの色を設定します。アクティブ時の色 と 非アクティブ時の色 は別々に設定できます。

[背景色] や [テキストの色] ボタンをクリックすると [色の設定] ダイアログを開きます。背景色は、色の設定ダイアログで、単色またはグラデーションとして定義できます。テキストの色は、固定または計算色として色関数を使用して定義できます。

[カラー関数](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 折り返して表示: このオプションを選択した場合、キャプションは、 2 行以上で表示されます。
* キャプションの高さ (行): 編集ボックスで、キャプションの行数を設定します。

QlikView のシート オブジェクトの正確なサイズと位置を設定できます。標準 もしくは 最小化 時のサイズ/位置設定で調整します。これらの設定は、ピクセル単位で行います。

* X- 位置: シートの左端に対するシート オブジェクトの左辺の水平方向の位置を設定します。
* Y- 位置: シートの上端に対するシート オブジェクトの上辺の垂直方向の位置を設定します。
* 幅: QlikView シート オブジェクトの幅を設定します。
* 高さ: QlikView シート オブジェクトの高さを設定します。

キャプションのラベルの方向は、[キャプションの配置] オプションで変更できます。

* 水平: キャプションのラベルは水平方向に整列できます: [左揃え]、[中央揃え]、または [右揃え]。
* 垂直: キャプションのラベルは垂直方向に整列できます: [上揃え]、[上下中央揃え]、または [下揃え]。

キャプション アイコン   
シート オブジェクトのオブジェクト メニュー コマンドの多くをキャプション アイコンとして設定できます。キャプション アイコンとして表示するコマンドを選択するには、リスト内の各コマンドの左にあるチェック ボックスをオンにします。

情報メモキャプション アイコンは注意して使用してください。アイコンが多すぎると邪魔になる可能性があります。

* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。

* 自動最小化: このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。

* 最大化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する] と [最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。

* ヘルプ テキスト: ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。ヘルプ テキストは、計算式として指定できます。このオプションはドキュメント レベルでは使用できません。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

    
  [計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  シート オブジェクトの説明などを入力します。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。