# ボタン

![Example clear selections button](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_Button.png)

ボタンを作成し、 QlikView でコマンドやアクションの実行を定義できます。ボタンには、 起動/エクスポート ボタン、ショートカット ボタン、マクロ ボタンの 3 つの種類があります。

オブジェクトを右クリックすると、[ボタン: オブジェクト メニュー] が表示されます。ボタンがアクティブなオブジェクトの場合、[オブジェクト] メニューからもアクセスできます。

## オブジェクト メニュー

ボタンのオブジェクト メニューは、ボタンを右クリックして開きます。メニュー コマンドは次の通りです。

オブジェクト メニュー コマンド

| コマンド | 説明 |
| --- | --- |
| プロパティ | パラメータを設定する [ボタン プロパティ] ダイアログを開きます。 |
| ノート | 現在のオブジェクトに関するノートの作成および共有ができます。 |
| 順序 | このカスケード メニューは [表示] メニューの [デザイン グリッド] コマンドが有効なときと、[デザイン メニュー項目を常に表示] チェック ボックス ([ユーザー プロパティ: デザイン] 内) をオンにした場合、テーブル ボックス、ストレート テーブル、またはピボット テーブルのオブジェクト メニューからこのダイアログを呼び出すことができます。シート オブジェクトのレイアウト レイヤーを設定するためのコマンドが 4 つ含まれています。有効なレイヤー番号は -128 から 127 です。<br><br><ul> <li><span>最前面へ移動</span>: シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最大値に設定します。 </li> <li><span>最背面へ移動</span>: オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最小値に設定します。 </li> <li><span>前面へ移動</span>: シート オブジェクトのレイアウト レイヤーを 1 つ増やします。最大値は 127 です。</li> <li><span>背面へ移動</span>: シート オブジェクトのレイアウト レイヤーを 1 つ減らします。最小値は -128 です。 <br></li> </ul> |
| Excel 出力 | テキストを Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。テキストは、新しい Excel ワークシートの 1 つのセルに表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 |
| クリップボードにコピー | このカスケード メニューには、シート オブジェクトのためのさまざまなコピー オプションが含まれています。<br><br><ul> <li><span>テキスト</span>: ボタンに表示されているテキストをクリップボードにコピーします。 <br></li> <li><span>画像</span>: シート オブジェクトの画像をクリップボードにコピーします。画像がシート オブジェクトのキャプションおよび枠線を含むか除外するかは、<span>ユーザー プロパティ</span> ダイアログの <span>エクスポート</span> ページの設定に従います。 <br></li> <li><span>オブジェクト</span>: シート オブジェクト全体をクリップボードにコピーし、レイアウトの別の場所や、QlikView の現在のインスタンス内で開いている他のドキュメントの別の場所に貼り付けることができます。 </li> </ul> |
| リンク オブジェクト | リンク オブジェクト用の次のコマンド メニューを開きます。<br><br><ul> <li><span>リンク オブジェクトを整列する</span>: すべてのシート上にある他のリンク オブジェクトはすべて、選択されたオブジェクトと同じ位置、同じ大きさに整列されます。 <br></li> <li><span>オブジェクトのリンクを解除する</span>: オブジェクト間のリンクを外し、異なるオブジェクトとしてそれぞれに異なるオブジェクト ID を付与します。 </li> </ul> |
| 最小化 | オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) で the Minimize icon アイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 最大化 | オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) で the Maximize icon アイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 元のサイズに戻す | 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) で the Restore icon アイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。 |
| ヘルプ | QlikView ヘルプを開きます。 |
| 削除 | シート オブジェクトをシートから削除します。 |

## (基本設定)

[テキスト] グループでは、ボタンに表示されるテキストのプロパティを設定できます。

テキスト プロパティ

| Property | 説明 |
| --- | --- |
| テキスト | テキスト項目に入力されたテキストが、ラベルとしてボタンに表示されます。テキストを計算式として定義できます。テキストは、複数行にわたることができ、Enter を押すと改行されます。<br><br>[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 配置 | ボタン テキストを左揃え、中央揃え、右揃えで配置できます。 |

[背景] グループでは、ボタンの背景を指定できます。ドロップダウンでは、3 つの基本的なボタン スタイルと追加の設定を選択できます。

背景のスタイルとプロパティ

| オプション | 説明 |
| --- | --- |
| アクア | 新しいボタンの初期設定です。透き通った 3D の丸いボタンを生成します。 |
| 無地 | 従来の無地の QlikView ボタンを生成します。<br><br><ul> <li><span>システムの既定</span>: オペレーティング システムでボタン用に定義されている単色の背景を提供します。 </li> </ul> |
| 画像 | 画像ボタンを生成します。この画像は、単一の固定画像または結合された画像 (ボタンのアクティブ、非アクティブ、くぼみ状態を示す 3 つの部分で構成される画像) のいずれかを使用できます。<br><br><ul> <li><span>結合された画像</span>: 3 つの状態が結合された画像をボタンに割り当てるには、このラジオ ボタンを選択し、[<span>画像の挿入</span>] ボタンを使用して画像ファイルを参照します。この画像ファイルは、横並びの 3 つの画像で構成される必要があります。最初の画像はアクティブ ボタン、2 番目の画像はくぼみボタン、3 番目の画像は淡色 (非アクティブ) ボタンになります。 <br></li> <li><span>単一画像</span>: 1 つの状態の画像をボタンに割り当てるには、このラジオ ボタンを選択し、[<span>画像の挿入</span>] ボタンを使用して画像ファイルを参照します。サポートされる画像タイプには、jpg、png、bmp、gif、およびアニメーション gif があります。 </li> </ul> |
| 色 | ボタンを色付きの背景で表示する場合は、このラジオ ボタンを選択します (画像を設定する場合は利用できません)。色は、[色] ボタンをクリックすると表示される [色の設定] ダイアログで、単色またはグラデーションとして定義できます。 |
| 透過性 | ボタンの背景の透過性を設定します。100% の場合、背景は完全に透明になります。透過性は、背景で色または画像が使用されているかどうかに関係なく適用されます。 |
| 並列ステート | ドロップダウンの選択肢の中から種類をひとつ選択します。次の並列ステートはいつでも使用できます。<br><br><ul> <li><span>継承済み</span>: シートとシート オブジェクトは、QlikView の開発者が無効にしない限り、常に<span>継承済み</span>ステートになります。この設定はひとつ上のレベルにあるオブジェクトから継承され、これを選択するとシート内のチャートにはシートと同様の設定が適用されます。 </li> <li><span>初期ステート</span>: QlikView で最も使用されるステートで $ で表現されます。QlikView ドキュメントは常に <span>[初期ステート]</span> にあります。 </li> </ul> |

追加ボタンのプロパティ

| オプション | 説明 |
| --- | --- |
| オブジェクト ID | 現在のボタンの一意の ID。作成時に、各シート オブジェクトには、制御用にオートメーションから一意の ID が割り当てられます。ID は、数値と、オブジェクトのタイプを定義する文字の組み合わせで構成されます。ドキュメントの最初のボタンは、ID BU01 に割り当てられます。共有オブジェクトは、同じオブジェクト ID を共有します。オブジェクト ID は、ドキュメント内の他のシート オブジェクト、シート、またはブックマークで現在使用されていない他の文字列に変更できます。 |
| 有効条件 | ここに入力された数式は、ボタンの状態を決定します。数式が 0 を返す場合、ボタンは無効にされます。数式が 1 を返す場合、ボタンは有効にされます。数式が入力されない場合は、1 が使用されます。基底の状態のために無効にされているボタンは、条件を使用して有効にすることはできません。 |
| 印刷設定 | このボタンを押すと 印刷設定 ダイアログにアクセスし、余白やヘッダー/フッターの書式を定義できます。 |

## アクション

このページでは、特定のオブジェクトにアクション設定を行うことができます。

* ボタン
* テキスト オブジェクト
* ゲージ
* 線/矢印オブジェクト

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Button2.htm)アクションには、外部アプリケーションの起動や QlikView データのエクスポートが含まれます。

* 追加:[アクションの追加] ダイアログを開き、そのオブジェクトへのアクションを選択します。アクションの種類をリストから選択します。アクションに応じて異なるパラメータが アクション ページに表示されます。リストされたアクションの入力パラメーターは、最初のアクションが実行される前に計算されます。実行の開始後にパラメーターが変更された場合 (例えば、アクションが前のアクションによって変更された場合)、変更はアクションのチェーンに登録されません。
* 削除: オブジェクトからアクションを削除します。
* 上へ: 選択したアクションをリストの上に移動します。
* 並列ステート: アクションが参照するステートを設定します。この設定は、選択またはブックマークに関係のあるアクションにのみ関連します。

## [アクションの追加] ダイアログ

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Button2.htm)[アクションの追加] ダイアログから次のアクションを追加できます。[...] ボタンの付いているすべての項目で、計算式を入力できます。

[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

### 選択

選択アクション

| アクション | 説明 |
| --- | --- |
| 項目値の選択 | 指定された項目の指定された値を選択します。[検索文字列] では、検索マスクを指定できます (例、 (A\|B) と指定すると A と B の両方が選択されます)。引用符は数値以外の値の場合にのみ必要とされ、数値の場合には省略できます。 |
| 除外値の選択 | 指定された項目の除外値を選択します。 |
| 絞込値の選択 | 指定された項目の絞込値を選択します。 |
| 選択の切り替え | 現在の選択値と指定した 項目 と 検索文字列 で選択を切り替えます。検索文字列 では、検索マスクを指定できます。例：(A\|B) は A と B の両方を選択します。 |
| やり直し | 選択条件のリストを 1 つ次に進めます。 |
| 元に戻す | 選択条件のリストを 1 つ前に戻します。 |
| パレート選択 | 数式とパーセントを基準に指定した項目でパレートの選択を行います。この種類の選択は、一般的に 80/20 ルール上での評価基準で主要な要因を選択するために使用されます。たとえば、売上高の 80% に貢献したトップの顧客を見つけるためには、顧客を項目として使用して sum(売上高) を数式と使用し、また 80 をパーセントとして使用します。 |
| 項目のロック | 指定した項目の選択をロックします。 |
| すべてロック | すべての項目のすべての値をロックします。 |
| 項目のアンロック | 指定した項目の選択のロックを解除します。 |
| すべてをアンロック | すべての項目のすべての値のロックを解除します。 |
| アンロックとクリア | すべての項目のすべての選択のロックと選択を解除します。 |
| 他項目の選択のクリア | 指定した項目以外のすべての関連項目の選択を解除します。 |
| すべての選択をクリア | ロックされていないすべての選択を解除します。 |
| 検索項目の選択をクリア | 特定の項目をクリアします。 |
| ステート内容のコピー | ソース ステート から ターゲット ステート へ選択条件をコピーします。別のステートが定義されている場合にのみ利用できます。 |
| ステート内容の切り替え | ステート 1 と ステート 2 の選択を切り替えます。別のステートが定義されている場合にのみ利用できます。 |

### レイアウト

レイアウト アクション

| アクション | 説明 |
| --- | --- |
| オブジェクトを選択する | 指定した オブジェクト ID のオブジェクトをアクティブにします。この機能は Ajax クライアントでは利用できません。 |
| シートを選択する | 指定した シート ID のシートをアクティブにします。 |
| 次のシートに進む | ドキュメントの次のシートを開きます。 |
| 前のシートに戻る | ドキュメントの前のシートを開きます。 |
| オブジェクトを最小化する | 指定した オブジェクト ID のオブジェクトを最小化します。 |
| オブジェクトを最大化する | 指定した オブジェクト ID のオブジェクトを最大化します。 |
| オブジェクトを元のサイズに戻す | 指定した オブジェクト ID のオブジェクトを元のサイズに戻します。 |
| ステート名の設定 | 指定した オブジェクト ID のオブジェクトに指定した ステート を適用します。定義された並列ステートが存在する場合にのみ有効です。 |

### ブックマーク

* ブックマークの適用: 指定した ブックマーク ID のブックマークを適用します。2 つのブックマークが同じ ID を持つ場合、ドキュメント ブックマークが適用されます。サーバー ブックマークを適用するには、サーバー\ブックマーク ID を指定します。
* ブックマークの作成: 現在の選択でブックマークを作成します。ブックマーク ID と ブックマーク名 を指定します。選択 **非表示**非表示のブックマークを作成します。
* ブックマークの上書き: 指定した ブックマーク ID のブックマークを現在の選択に置き換えます。

### 印刷

* オブジェクトの印刷: 指定した オブジェクト ID のオブジェクトを印刷します。既定に設定されたプリンタ以外でオブジェクトを印刷する場合、プリンタ名 を指定します。(ドキュメント トリガーとシート トリガーでは無効です)
* シートの印刷: 指定した シート ID のシートを印刷します。(ドキュメント トリガーとシート トリガーでは無効です。) この機能は AJAX クライアントでは利用できません。
* レポートの印刷: 指定した レポート ID のレポートを印刷します。既定に設定されたプリンタ以外でレポートを印刷する場合、プリンタ名 を指定します。ウィンドウズの [印刷] ダイアログを表示する場合、[印刷] ダイアログを表示する チェックボックスをオンにします。(ドキュメント トリガーとシート トリガーでは無効です)

### その他

* エクスポート: 特定の項目セットを含むテーブルをエクスポートします。選択条件に当てはまるレコードのみがエクスポートされます。設定 ボタンを アクション ページでクリックすると、エクスポート アクションの設定 ダイアログが開きます。ドキュメント トリガーまたはシート トリガーとしては使用できません。

  情報メモこの機能は AJAX クライアントでは利用できません。

* 起動: 外部プログラムを起動します。以下の設定は、[アクション] ダイアログで設定できます。

  * アプリケーション: [参照] をクリックして、起動するアプリケーションを探します。(ドキュメント トリガーとシート トリガーでは無効です)
  * ファイル名: 上で指定したアプリケーションで開くファイルへのパスを入力します。(ドキュメント トリガーとシート トリガーでは無効です)
  * パラメータ: アプリケーションを起動するコマンド ラインのパラメータを指定します。(ドキュメント トリガーとシート トリガーでは無効です)
  * 作業ディレクトリ: 起動するアプリケーションの作業ディレクトリを設定します。(ドキュメント トリガーとシート トリガーでは無効です)
  * QlikView 終了時にアプリケーションを終了する: QlikView 終了時にアプリケーションを強制的に終了します。(ドキュメント トリガーとシート トリガーでは無効です)

    情報メモこの機能は AJAX クライアントでは利用できません。

* URL から開く: [URL から開く] を使用して、別の QlikView ドキュメント内から QlikView ドキュメントへの URL を開くことができます (ドキュメント チェーン)。この設定により既定の WEB ブラウザで URL が開きます。この機能をドキュメントおよびシートのトリガーとして使用することはできません。[URL から開く] を使用する場合は、ドキュメント名を必ず小文字でアクション文字列に入力してください。  
  可能であれば、[URL から開く] ではなく [QlikView ドキュメントを開く] を使用してください。

  情報メモ既定では、URL で Javascript を使用できないようになっています。

  custom.config ファイルで `PreventJavascriptInObjectActions` パラメーターを変更することにより、URL で JavaScript を使用できるようになります。

* QlikView ドキュメントを開く: [QlikView ドキュメントを開く] を使用して、別の QlikView ドキュメント内から QlikView ドキュメントを開くことができます (ドキュメント チェーン)。この機能は、ドキュメント トリガーまたはシート トリガーとしては使用できません。詳細については、「[ドキュメント チェーンの例](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Button2.htm#Document)」を参照してください。

* マクロの実行: 実行するマクロのパスとマクロ名を入力します。任意の名前を入力して後で モジュールの編集 ダイアログでマクロを作成する、もしくは動的に更新される 計算式 を入力できます。

* 変数の設定: 指定した変数に値を適用します。

* 情報の表示: 指定された 項目 に関連付けられたテキストファイルや画像といった情報を表示します。この機能は AJAX クライアントでは利用できません。

* このドキュメントを閉じる: QlikView ドキュメントを閉じます

* リロード: 現在のドキュメントのリロードを行います。この機能は AJAX クライアントと IE プラグインでは利用できません。

* ダイナミック更新: 現在ロードされているドキュメントでデータを動的に更新します。ダイナミック更新へのステートメントはステートメント フィールドに入力してください。  
  ダイナミック更新の用途では、QlikView 管理者はドキュメントのリロードを実行しなくても、単一のソースから限定的な量のデータを QlikView ドキュメントにフィードすることができます。その後、QlikView Server に接続している複数のクライアントが分析を実行できます。

  情報メモアップロードされた情報は RAM のみで保存されるため、ドキュメントのリロードを行うと、ダイナミック更新を使用して追加または更新されたデータは失われます。

  以下の規則は、ダイナミック更新機能で使用できるステートメントとそのコンポーネントについて説明したものです。

  * statements ::= statement { “;” statement } { “;” statement }
  * statement ::= insert\_statement | update\_statement | delete\_statement | begin\_transaction\_statement | commit\_transaction\_statement
  * insert\_statement ::= "INSERT" "INTO" ("\*" | table\_name) field\_list "VALUES" value\_list {"," value\_list} ["KEY" ["AUTO" | (" (" field\_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  * update\_statement ::= "UPDATE" ("\*" | table\_name) set\_clause {"," | set\_clause} "WHERE" condition ["AUTO" "INSERT"]
  * delete\_statement ::= "DELETE" "FROM" ("\*" | table\_name] "WHERE" condition
  * begin\_transaction\_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans\_name]
  * commit\_transaction\_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans\_name]
  * table\_name ::= identifier | quoted\_name
  * field\_list ::= "(" field\_name {"," field\_name} ")"
  * value\_list ::= "("value {"," value} ")"
  * set\_clause ::= "SET" field\_name "=" any\_valid\_non\_aggregated\_qlikview\_expression
  * field\_name ::= identifier | quoted string
  * value ::= identifier | any\_qlikview\_number | quoted string
  * condition ::= any\_valid\_non\_aggregated\_qlikview\_expression
  * identifier ::= any\_qlikview\_identifier
  * quoted\_string ::= "[" [^]]+ "]"

  `  UPDATE AbcTable SET Discount = 123 WHERE AbcField=1 `

  情報メモ この機能を使用するには、ドキュメントとサーバーの双方でダイナミック更新を許可しておかなくてはなりません。

#### ドキュメント チェーンの例

[QlikView ドキュメントを開く] を使用して、ドキュメント チェーンを作成できます。

次の設定を適用できます。

* ステートの転送: 元のドキュメントから転送先のドキュメントに選択内容を転送します。転送先ドキュメントでは、まず選択内容がクリアされます。

* 現在の選択条件にステートを追加: 転送先ドキュメントの選択内容を維持し、元のドキュメントの選択内容を追加適用します。

  情報メモ [現在の選択条件を追加適用する] を使用すると、2 つのドキュメントでの選択内容が競合している場合に予期せぬ結果が返されることがあります。

* 同じウィンドウで開く: AJAX ZFC クライアントを使用している場合に、同じブラウザ タブで新しいドキュメントを開きます。

  情報メモQlikView Plug-In を使用している場合、ドメイン ユーザー以外のユーザーは [QlikView ドキュメントを開く] アクションを使用できません。

QlikView ドキュメント: 対象ファイルの拡張子を入力する必要があります。1 つの QlikView ドキュメントから別のドキュメントに移動するための相対パスは、連結されたドキュメントが同じフォルダー構造 (マウント) 内に保存されている限り、すべてのクライアントでサポートされます。

次の例は、対象ファイルへのファイル パスを書き込む方法を示しています。

例: 同じフォルダー構造 (同じマウント) 内に格納されたファイル。

* 対象ファイルが同じフォルダー内に格納されている場合:  
  DestinationDoc.qvw

* 対象ファイルがサブ フォルダー内に格納されている場合:  
  SubFolder/DestinationDoc.qvw

* 対象ファイルが上位フォルダー内に格納されている場合:  
  ../DestinationDoc.qvw

* 対象ファイルが上位の並列フォルダーに格納されている場合:  
  ../ParallelFolder/DestinationDoc.qvw

例: 別のフォルダー構造 (別のマウント) 内に格納されているファイル。異なるマウント間の相対パスに対応しているのは Ajax クライアントのみです。

* 対象ファイルが別のマウント内に格納されている場合:  
  ../DifferentMount/DestinationDoc.qvw

例: QlikView ドキュメントを指すマウント パスの使用。マウントされたフォルダーへのパスの設定に対応しているのは、Ajax クライアントのみです。

* 対象ファイルが同じマウントされたフォルダー内に格納されている場合:  
  \Mount\DestinationDoc.qvw

* 対象ファイルが別のマウントされたフォルダー内に格納されている場合:  
  \DifferentMount\DestinationDoc.qvw

  情報メモマウントされたフォルダーでのドキュメント チェーンは、QlikView Plug-In では機能しません。

例: QlikView ドキュメントを指す絶対パスの使用。ドキュメント チェーンでの絶対パスの使用に対応しているのは Ajax クライアントと QlikView Desktop のみです。

* Local Root フォルダーまたはマウントへの絶対パス:  
  C:\...\DestinationDoc.qvw

* ネットワーク共有への絶対パス:  
  \\SharedStorage\...\DestinationDoc.qvw

Qlik Sense Cloud ハブ内での QlikView アプリ: パスではなく、アプリ ID が必要です。アプリは QlikView Desktop 内で準備し、更新する必要があります。アプリ ID は、アプリがハブ内で開かれる時の URL にあります。

例

URL が https://qcs.us.qlikcloud.com/qv/opendoc.htm?document=1cc71b323f172f93a8121ce1456cdg の場合、アプリ ID は、1cc71b323f172f93a8121ce1456cdg です。

情報メモ他のアクションのトリガーとなるアクションは、連鎖アクションと呼ばれ、不測の結果を引き起こす可能性があるためサポートされていません。

情報メモ

QlikView Server でドキュメントを操作している場合、一部のマクロ トリガーは動作が制限されます。

[QV サーバー上の QV ドキュメントでのマクロの使用](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/UsingMacrosonQVS.htm)

## [エクスポート アクションの設定] ダイアログ

### 選択

このグループでは、エクスポートで選択される項目を設定します。

選択のオプション

| オプション | 説明 |
| --- | --- |
| 項目 | [項目] ボックスでは、有効な項目のリストが表示されます。 |
| 出力項目 | このボックスでは、エクスポート用に選択した項目が表示されます。複数値を許可した項目にはアスタリスクが表示されます。 |
| 追加 &gt; | 項目を 出力項目 ボックスに追加します。 |
| &lt; 削除 | 出力項目 ボックスから項目を削除します。 |
| 上へ | 選択した項目を 1 つ上に移動します。つまり、エクスポート テーブルでは 1 つ左に移動します。 |
| 下へ | 選択した項目を 1 つ下に移動します。つまり、エクスポート テーブルでは 1 つ右に移動します。 |
| 複数値 (\*) | 出力項目 ボックスの項目を選択し、このコントロールをオンにすることで、項目のエクスポート リストに複数値を追加できます。 |

### エクスポート先

このグループでは、値をファイルにエクスポートするか、クリップボードにエクスポートするかを選択できます。

エクスポートのオプション

| オプション | 説明 |
| --- | --- |
| ファイル | ファイルへエクスポートする場合は、このチェックボックスをオンにして、ファイル名を入力します。ファイル名を入力しないと、値はクリップボードにエクスポートされます。ファイル名は、計算式として入力できます。<br><br>[計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 参照 | ファイルのエクスポート ダイアログを開きます。このダイアログでは、値をエクスポートするファイルを参照できます。 |
| クリップボード | デフォルト設定です。上のボックスでファイルを指定しないと、値はクリップボードにエクスポートされます。 |
| データを横持ちする | このコントロールをオンにすると、エクスポート ファイルは、選択した各項目のすべての絞込値がタブで区切られて 1 行に表示されます。 |
| ラベルを含める | このコントロールをオンにすると、行の最初の位置 ([データを横持ちする] が設定されている場合)、または最初のレコード ([データを縦持ちする] が設定されている場合) に、項目名が含まれます。 |
| データを縦持ちする | このコントロールをオンにすると、エクスポート ファイルは、選択した各項目がタブで区切られて 1 列に表示されます。 |
| 既存のファイルに追加する | このコントロールをオンにすると、エクスポート ファイルは、既存のエクスポート ファイル (存在する場合) に追加されます。既存のファイルに追加する場合、ラベルはエクスポートされません。エクスポート ファイルが存在しない場合、このフラグは意味がありません。 |

### 数値書式

プログラムによっては、書式設定付きの数字を適切に処理することが困難な場合があります。QlikView は、ファイルまたはクリップボードにエクスポートする数値データの数字書式設定に関して 3 つのオプションを提供します。

新しいエクスポート ボタンは、[ユーザー プロパティ: エクスポート] ページから既定の設定を継承します。ただし設定は、エクスポート ボタンごとに個別に設定可能です。

* 書式すべてあり: QlikView ドキュメントのシート オブジェクトに表示されるとおりの数字書式を保持したまま数値データをエクスポートします。
* 桁区切りなし: 数値データから桁区切りを削除します。
* 書式なし: データからすべての数字書式設定を削除し、未処理の数値データとしてエクスポートします。小数点記号は、システム設定 (コントロール パネル) で定義されたとおりになります。

情報メモ

QlikView Server でドキュメントを操作している場合、一部のマクロ トリガーは動作が制限されます。

[QV サーバー上の QV ドキュメントでのマクロの使用](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/UsingMacrosonQVS.htm)

## フォント

ここでは、フォント、スタイルおよびフォント サイズを設定します。

フォントの設定は、1 つのオブジェクト用には [オブジェクト プロパティ: フォント] を使用して、ドキュメント上のすべてのオブジェクト用には [オブジェクトに適用] ボタン ([ドキュメント プロパティ: フォント] ページ上) を使用して行うことができます。

さらに、新しいオブジェクト用のドキュメントのフォント初期設定は、[ドキュメント プロパティ: フォント] ページで設定できます。2 つの初期フォントがあります。

1. 最初のデフォルト フォント (リスト ボックス、チャートなど) は、リスト ボックスやチャートなどのほとんどのオブジェクトで使用されます。
2. 次のデフォルト フォント (テキスト オブジェクトとボタン) は、一般的に大きなフォントを必要とするボタンやテキスト ボックスに使用されます。

最後に、新しいドキュメントのフォント初期設定は、[ユーザー プロパティ: フォント] で設定できます。

チャート、ボタンおよびテキスト オブジェクト (検索オブジェクト以外) には、フォントの色も指定できます。色は、[固定] もしくは [計算] (数式で動的に計算します) を選択します。数式は有効な色表現でなければなりません。カラー関数を使用して作成します。数式の結果が有効な色表現でない場合は、フォントの色はデフォルトで黒になります。

[カラー関数](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

その他の設定は次のとおりです。

* ドロップシャドウ: このチェック ボックスをオンにすると、テキストにドロップ シャドウが追加されます。
* 下線: このチェック ボックスをオンにすると、テキストに下線が引かれます。

選択したフォントのサンプルが、プレビュー パネルに表示されます。

## レイアウト

レイアウトの設定をオブジェクトのプロパティ ページから行うと、そのオブジェクトにのみ適用されます。   
レイアウトの設定をドキュメントのプロパティ ページから行うと、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

### 枠線の使用

シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。ドロップダウン メニューから選択して、枠線の種類を指定します。

* 影の強度:影の強度ドロップダウン メニューで、シート オブジェクトの周りの影の強度を設定できます。影なしの選択肢もあります。
* 枠線のスタイル: 既定の枠線は次のとおりです。
  * 単色: 単色の固定の枠線。
  * くぼみ: シート オブジェクトが背景からくぼんでいるように見える枠線。
  * 浮き彫り: シート オブジェクトが背景から浮き上がっているように見える枠線。
  * 壁: シート オブジェクトの周囲に壁があるように見える枠線。
* 枠線の幅: このオプションは、すべての種類の枠線で有効です。幅は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
* 色: このボタンをクリックするとダイアログが開き、すべての種類の枠線に適用される基本色をカラー パレットから選択できます。
* 虹色: すべての種類の枠線を虹色の枠線にします。虹は、シート オブジェクトの上部で選択した基本色で始まります。

[簡易設定が] が [スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) として選択されている場合、枠線の種類は選択できません。設定できるのは [影の強度] のドロップダウン メニューと [枠線の幅] のみとなります。

### 角を丸くする

角を丸くする グループでは、シート オブジェクトの基本の形を設定できます。これらの設定により、シート オブジェクトを円形/楕円形から長方形までの範囲で描くことができます。[角を丸くする] を使用できるのは、[詳細設定]、[スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) が選択されている場合のみです。

* 角を丸くする: このチェックボックスをオンにすると、角の形を丸くするオプションを設定できるようになります。
* 角: チェック ボックスをオフにした角は直角に描画されます。
* 鋭度: 2 から 100 の間の数値を設定でき、数値 100 を定義すると直角、数値 2 は完全な楕円 (縦横比が 1:1 の場合は円) に相当します。丸い角には、鋭度 2 から 5 が通常最適な数値です。
* 角の丸み: この設定は、固定の距離 (固定)または四分円全体に対するパーセンテージ (相対値(%)) で、角の半径を決定します。この設定により、鋭度で設定した基になる基本図形が角に影響を与える程度を制御できます。距離は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。

### レイヤー

レイヤー グループでは、オブジェクトを 3 つのレイヤーのいずれかを割り当てることができます。

* 背面:背面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと前面レイヤーにあるシート オブジェクトを覆うことはできません。背面レイヤーにある他のシート オブジェクトの上にのみ配置できます。
* 標準: シート オブジェクトは、作成されると、標準位置 (中央) のレイヤーに置かれます。標準位置レイヤーにあるシート オブジェクトは、背面レイヤーのシート オブジェクトで覆われることはありませんし、前面レイヤーのシート オブジェクトを覆うこともできません。
* 前面:前面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと背面レイヤーにあるシート オブジェクトによって覆われることはありません。その上に配置できるのは、前面レイヤーにある他のシート オブジェクトだけです。
* カスタム:前面、標準位置、および背面レイヤーは、内部的に番号が振られたレイヤー 1、0、-1 にそれぞれ対応しています。実際には、-128 ～ 127 の間のすべての値が使用できます。選択した値を入力する場合は、このオプションを選択します。

### テーマの作成

テーマ作成 ウィザードを開くと、レイアウト テーマを作成できます。

### テーマの適用

オブジェクト、シート、ドキュメントにレイアウト テーマを適用できます。

[レイアウト テーマ](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 表示

表示 グループでは、シート オブジェクトを表示する条件を指定できます。

* 常時: シート オブジェクトは常に表示されます。

* 条件付き表示: シート オブジェクトは、選択などで継続的に評価される条件付き関数に基づいて表示/非表示にされます。シート オブジェクトは、その条件が FALSE を返す場合にのみ非表示になります。

  [条件分岐関数](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

情報メモ

ドキュメントの管理権限を持つユーザーは、[すべてのシートとシート オブジェクト] を [ドキュメント プロパティ: セキュリティ] で該当のチェック ボックスをオンにしてある場合のみ有効です。CTRL+SHIFT+S を押して、この機能を切り替えることができます。

[ドキュメント プロパティ：セキュリティ](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### オプション

オプション グループでは、シート オブジェクトの移動/サイズ変更を禁止できます。このグループの設定は、対応するチェック ボックスが [ドキュメント プロパティ: レイアウト] と [シート プロパティ: セキュリティ] で該当のチェック ボックスをオンにしてある場合のみ有効です。

* 移動/サイズ変更を許可する: このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
* コピー/複製を許可する: このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。
* INFO を許可する:info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。  
    
  [Info](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* データにサイズを合わせる: 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。

### スクロール バー

スクロール バー グループには、スクロール バーのレイアウトを変更するコントロールがあります。

* スクロール バーの位置を保持する: この設定が有効の場合、QlikView は、他のオブジェクトで選択が行われたときに、スクロール バーが設定されているテーブルやチャートのスクロールの位置を保持しようとします。この設定は [ユーザー プロパティ: オブジェクト] でも有効にする必要があります。ドキュメントを閉じると、スクロールの位置は保持されません。
* スクロール ボタン: スクロール ボタンの色を設定します。ボタンをクリックして色を選択します。スクロール バーは、薄い灰色で描画するとよい結果が得られます。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。
* スクロールの背景: スクロール バーの背景色を設定します。ボタンをクリックして色を選択します。
* スクロール バーの幅: このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。
* スクロールのスタイル: スクロール バーのスタイルを設定します。ドロップダウン コントロールでスタイルを選択します。クラシック スクロール バー スタイルは、QlikView の 4/5 スクロール バーに対応します。標準スクロール バー スタイルは、最新の外観になります。3 つ目のスタイル、ライトは細く、ライトなスクロールバーです。  
  スクロール バー スタイルを表示するには、[スタイルのモード] を [詳細設定] に設定する必要があります。この設定は、[基本設定] タブで [設定] ドロップダウン メニューを開き、[ドキュメント プロパティ] を選択すると見つかります。

* 適用対象:キャプションと枠線のプロパティ ダイアログを開きます。ここでは、レイアウト ページで設定されたプロパティを適用する場所を設定できます。

## キャプション

キャプションの設定が [オブジェクト プロパティ] ページで行われた場合は、そのオブジェクトにのみ適用されます。   
キャプションの設定が [ドキュメント プロパティ] ページで行われた場合は、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

キャプション ページでは、オブジェクトの基本的なレイアウトとは全く違うレイアウト オプションを指定できます。

* キャプションの表示: このオプションをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
* タイトル テキスト: テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。キャプションのフォントを変更するには フォント ボタンを使用します。

異なる状態のキャプションの色を設定します。アクティブ時の色 と 非アクティブ時の色 は別々に設定できます。

[背景色] や [テキストの色] ボタンをクリックすると [色の設定] ダイアログを開きます。背景色は、色の設定ダイアログで、単色またはグラデーションとして定義できます。テキストの色は、固定または計算色として色関数を使用して定義できます。

[カラー関数](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 折り返して表示: このオプションを選択した場合、キャプションは、 2 行以上で表示されます。
* キャプションの高さ (行): 編集ボックスで、キャプションの行数を設定します。

QlikView のシート オブジェクトの正確なサイズと位置を設定できます。標準 もしくは 最小化 時のサイズ/位置設定で調整します。これらの設定は、ピクセル単位で行います。

* X- 位置: シートの左端に対するシート オブジェクトの左辺の水平方向の位置を設定します。
* Y- 位置: シートの上端に対するシート オブジェクトの上辺の垂直方向の位置を設定します。
* 幅: QlikView シート オブジェクトの幅を設定します。
* 高さ: QlikView シート オブジェクトの高さを設定します。

キャプションのラベルの方向は、[キャプションの配置] オプションで変更できます。

* 水平: キャプションのラベルは水平方向に整列できます: [左揃え]、[中央揃え]、または [右揃え]。
* 垂直: キャプションのラベルは垂直方向に整列できます: [上揃え]、[上下中央揃え]、または [下揃え]。

キャプション アイコン   
シート オブジェクトのオブジェクト メニュー コマンドの多くをキャプション アイコンとして設定できます。キャプション アイコンとして表示するコマンドを選択するには、リスト内の各コマンドの左にあるチェック ボックスをオンにします。

情報メモキャプション アイコンは注意して使用してください。アイコンが多すぎると邪魔になる可能性があります。

* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。

* 自動最小化: このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。

* 最大化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する] と [最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。

* ヘルプ テキスト: ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。ヘルプ テキストは、計算式として指定できます。このオプションはドキュメント レベルでは使用できません。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

    
  [計算式の数式構文](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  シート オブジェクトの説明などを入力します。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。