# ピボット テーブル - AJAX/Webview

ピボット テーブルは、最も強力なデータ分析ツールの 1 つです。多くの機能が備えられていますが、簡単に使用できます。ピボット テーブルは、クロス テーブルのように、軸と数式を行と列に表示します。ピボット テーブルのデータは、グループ化できます。ピボット テーブルでは小計を表示できます。

情報メモ

リロードすると、ピボット テーブルで展開されていた列は折りたたまれます。

## ピボット テーブル：オブジェクト メニュー

シート オブジェクト上で右クリックするか、オブジェクトのキャプション (表示されている場合) で the Menu icon アイコンをクリックすると、コンテンツ メニューとしてオブジェクト メニューが開きます。

メニューに含まれるコマンドは、QlikView ローカル クライアントで WebView を開いているか、Web ブラウザでドキュメントにアクセスして開いているかによって異なります。メニューには以下のコマンドがあります。

ピボット テーブル：オブジェクト メニュー コマンド

| コマンド | [Details] (詳細) |
| --- | --- |
| プロパティ | アクティブなシート オブジェクトの **プロパティ**ダイアログが開きます。 |
| ノート | 現在のオブジェクトに関するノートの作成および共有ができます。 |
| 分離設定 | チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。 |
| 分離解除 | 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。 |
| すべてを展開する | 展開できるセルをすべて展開します。 |
| すべてを折りたたむ | 折りたためるセルをすべて折りたたみます。 |
| 軸 (行) を折りたたむ | すべての軸(行)を折りたたみます。 |
| 軸 (列) を折りたたむ | すべての軸(列)を折りたたみます。 |
| すべての選択をクリア | アクティブなリスト ボックスの現在の選択をすべてクリアします。オブジェクトのキャプション (表示されている場合) で the Eraser icon アイコンをクリックしても同じ結果になります。 |
| コピー | 選択したシート オブジェクトをクリップボードにコピーします。この関数はデータや画像ではなく、シート オブジェクトのみをコピーします。 |
| セルの値をクリップボードにコピー | 選択されたセルの値をクリップボードにコピーします。 |
| 最小化 | オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) で the Minimize icon アイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 元のサイズに戻す | 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) で the Restore icon アイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。 |
| 最大化 | オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) で the Maximize icon アイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 削除 | 選択されたオブジェクトをシートから削除します。 |

## ピボット テーブル プロパティ

[プロパティ] ダイアログを開くには、[ **プロパティ**] を [ **オブジェクト**] メニューから選択します。 [ **プロパティ**] コマンドが淡色表示されている場合は、プロパティの変更を行うために必要な権限がない可能性があります。

### 軸

ドロップダウン リストで軸を選択します。軸を追加するには the Add icon をクリックします。ドロップダウンで軸を選択します。the Move icon アイコンでリスト内の項目を移動します。the Remove icon アイコンでリストから項目を削除します。詳細については、[詳細] ボタンをクリックしてください。

#### 軸

* 有効条件: このチェック ボックスを使って軸を動的に表示/非表示にするには、入力した条件式の値に応じて下の編集ボックスの the Function icon ボタンをクリックします。
* 軸: 現在選択されている軸を削除します。
* ラベル: 軸のラベル。チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* NULL 値を抑える: このチェック ボックスをオンにすると、上の [軸] で選択した項目の値が NULL の場合、チャートにその項目は表示されません。
* すべての値の表示: すべての軸項目値 (論理的な除外値も含む) をチャートに表示するには、このチェック ボックスをオンにします。
* ドロップダウン選択: 項目列に対してこのチェック ボックスをオンにすると、ドロップダウン アイコンが列ヘッダーの左に表示されます。このアイコンをクリックすると、項目のすべての項目値を表示するリスト ボックスがテーブル上に開かれます。これで、項目がマルチ ボックスの行であるように選択と検索を行うことができます。
* 小計の表示: シート オブジェクトに小計を表示します。
* 列の配置: ポップアップを開くには the Engine icon をクリックします。
  * 列の配置ポップアップ:
    * ラベル: ラベルの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
    * データ (数値): 水平ラベルの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
    * データ (テキスト): テキスト データの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
* 属性式のスタイル:
  * 背景色: 軸項目のセルの背景色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。
  * テキストの色: 軸項目のセルのテキストの色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。
  * テキストの書式: 各軸項目のテーブル セル内のテキストのフォント スタイルを計算する属性式を定義します。テキスト書式の数式として使用される数式は、太字を表す '&lt;B&gt;'、斜体を表す '&lt;I&gt;'、下線付きテキストを表す '&lt;U&gt;' を含む文字列を返します。

#### ソート

シート オブジェクトの値のソート順を設定します。シート オブジェクトによっては、ソートのオプションが無いものもあります。   
複数のソート順が指定されている場合の優先順位は、選択状態、数式、レコード数、数値、テキスト、ロード順となります。ステートは論理状態 (選択値、連結値、または除外値) を参照します。

* 第 1 ソート順: Y 軸値: Y- 軸の数値に基づいて軸の値をソートするかどうかを設定します。このオプションは計算軸には使用できません。 レコード数: 項目値をレコード数 (テーブル内に現れる同時レコード数) でソートします。数値: 項目値を数値順にソートします。テキスト: 項目値をアルファベット順にソートします。ロード順 : 項目値を最初のロード順でソートします。
* 第 2 ソート順: レコード数: 項目値をレコード数 (テーブル内に現れる同時レコード数) でソートします。   
  数値: 項目値を数値順にソートします。  
  テキスト: 項目値をアルファベット順にソートします。  
  ロード順 : 項目値を最初のロード順でソートします。
* 数式によるソート: 入力された数式によって項目値をソートします。値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 選択値を上部に配置: 選択値を上部に配置するには、これを有効にします。

### [数式]

ドロップダウン リストから数式を選択します。数式を追加するには the Add icon をクリックします。ドロップダウンから数式を選択します。the Move icon アイコンでリスト内の項目を移動します。the Remove icon アイコンでリストから項目を削除します。詳細については、詳細 ボタンをクリックしてください。

#### 数式

* 有効化: このチェック ボックスをオンにすると、選択した数式が有効になります。ボックスがオンにされていない場合は、数式を使用できません。
* 条件付き表示: このチェック ボックスをオンにすると、編集ボックスの下にある the Function icon ボタンをクリックして入力した条件式の値に応じて、レポートが動的に表示または非表示にされます。
* ラベル: 数式のラベル。チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 数式: 現在選択されている式を削除します。
* コメント: 数式の目的と機能を説明するコメントを入力します。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 意味:

  ドロップダウン リストでプレゼンテーションを選択します。選択したプレゼンテーションによって、表示される設定は異なります。
  * テキスト: その他の設定はありません
  * 画像: ポップアップを開くには the Engine icon をクリックします。
    * 画像の設定ポップアップ:
      * 画像拡大/縮小:縮小/拡大なし: 画像を縮小/拡大せずに表示します。画像を縮小/拡大せずに表示します。 したがって、画像の一部が表示されない場合や、オブジェクトの一部が画像で覆われない場合があります。  
        全体を覆う: 画像を、画像の縦横比を考慮せずに、オブジェクト領域全体を覆うように拡大します。   
        縦横比を固定する: 画像を、縦横比を維持したまま、オブジェクト領域全体をできるだけ広く覆うように拡大します。   
        縦横比を固定して全体を覆う: 画像を、縦横比を維持したまま、オブジェクト領域全体を両方向とも覆うように拡大します。   
        画像がない場合にテキストを隠す: QlikView が画像参照として解釈できない場合は、テキストは表示されません。

      * ゲージ: ゲージの異なる代替値を設定します。

        * ゲージの最小値: ゲージの最小値を指定します。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
        * ゲージの最大値: ゲージの最大値を指定します。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。

      * ミニ チャート項目: 数式を描画するための項目を選択します。ポップアップを開くには the Engine icon をクリックします。

      * ミニ チャートのモード設定ポップアップ: ミニ チャート のモード設定ポップアップには、変更できるいくつかの設定があります。

      * モード: スパークライン、線、点、棒、またはひげ図としてミニ チャートを設定します。

      * 色: [色] ダイアログを開きます。ここから、ミニ チャートを描画する色を設定できます。

      * 最大値の色: [色] ダイアログを開くには、このチェック ボックスをオンにし、the Caption color icon をクリックします。最大値のための色を設定できます。

      * 最小値の色: [色] ダイアログを開くには、このチェック ボックスをオンにし、the Caption color icon をクリックします。最小値のための色を設定できます。

        情報メモこの設定は、[モード] が [折れ線] に設定されている場合にのみ有効です。

      * 開始値の色: [色] ダイアログを開くには、このチェック ボックスをオンにし、the Caption color icon をクリックします。開始値のための色を設定できます。

        情報メモこの設定は、[棒] と [ひげ図] モードでは無効です。

      * 終了値の色: [色] ダイアログを開くには、このチェック ボックスをオンにし、the Caption color icon をクリックします。終了値のための色を設定できます。

        情報メモこの設定は、[棒] と [ひげ図] モードでは無効です。

      * 目盛の 0 設定: チャートの下端を軸の 0 に固定します。

        情報メモ勝敗モードでは無効となります。

      * 共有 Y- 軸目盛: 列の全てのセルに同じ Y 軸目盛を使用します。

      * リンク: その他の設定はありません。
* 列の配置: ポップアップを開くには the Gen Settings icon をクリックします。
  * ポップアップには次のアイテムが含まれています。
    * ラベル: ラベルの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
    * データ (数値): 水平ラベルの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
    * データ (テキスト): テキスト データの配置を [左揃え]、[中央揃え]、または [右揃え] に設定します。
* 条件付き書式: ポップアップを開くには the Gen Settings icon をクリックします。
  * 条件付き書式ポップアップ:
    * 上限値: 上数値区間値カテゴリの設定です。数値の上区間が始まる位置になる数値を編集ボックスに指定します。このボックスを空白のままにすると、上区間は定義されません。
    * 標準: 標準数値区間値カテゴリの設定です。この区間は、上下の境界値にはさまれたすべての値として定義されます。デフォルトでは、すべての数値は標準区間内に含まれます。
    * 下限値: 下数値区間値カテゴリの設定です。数値の下区間が始まる位置になる数値を編集ボックスに指定します。このボックスを空白のままにすると、下区間は定義されません。
* 属性式のスタイル:
  * 背景色: 軸項目のセルの背景色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。
  * テキストの色: 軸項目のセルのテキストの色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。
  * テキストの書式: 各軸項目のテーブル セル内のテキストのフォント スタイルを計算する属性式を定義します。テキスト書式の数式として使用される数式は、太字を表す '&lt;B&gt;'、斜体を表す '&lt;I&gt;'、下線付きテキストを表す '&lt;U&gt;' を含む文字列を返します。
    * 数値書式タブ: 各項目には、デフォルトの数値書式があり、[] ドキュメント プロパティ: 数値] ページで設定できます。ただし、シート オブジェクトごとに別の数値書式を使用することもできます。このページは、アクティブなオブジェクトに適用されます。また、項目値を設定する次のコントロールが含まれます。
      * 数値書式: 以下のオプションから数値書式を選択します。
      * 既定: 数値とテキストの両方。数値は元の書式で表示されます。
      * 数値:有効桁数 ボックスで設定した桁数で数値を表示します。
      * 整数: 数値を整数で表示します。
      * 桁数固定:小数点以下の桁数 ボックスで設定した桁数の小数点値で数値を表示します。
      * 通貨:書式パターン ボックスで設定した書式で値を表示します。デフォルトの書式は Windows の通貨設定です。
      * 日付: [書式パターン] 項目で設定した書式で日付として変換された値を表示します。
      * 時刻:書式パターン ボックスで設定した書式で時刻として変換された値を表示します。
      * 日付と時刻:書式パターン ボックスで設定した書式で日付+時刻として変換された値を表示します。
      * 時間間隔: シーケンシャルな時間増分で時間を表示します。例：書式 = mm では、値をカレンダーが始まってからの分の数で表示します ( 1899:12:30:24:00)。
      * 書式パターン: 項目の表示書式を詳細に指定する書式コード。[ISO] は、書式を ISO 標準に設定します。[日付]、[時刻]、[日時]、[時間間隔] でのみ有効です。[Sys] は、書式をシステム設定に設定します。
      * 有効桁数: 表示される桁数です。
      * 小数点以下の桁数: 表示される小数点以下の桁数を設定します。
      * 小数点の記号: 小数点を示す記号を設定します。
      * 桁区切り: 桁区切りを示す記号を設定します。
      * パーセント表示: 実数の代わりにパーセント形式で表示します。設定は、[数値]、[整数]、および [実数] でのみ使用できます。
      * プレビュー: 上で指定した数値書式に基づいてプレビューを表示します。
  * 詳細/簡略: 隠された補助タブを展開/折りたたみするには、このボタンをクリックします。アクティブな項目が [軸] または [数式] かによって表示されるタブは異なります。

## ピボット テーブル プロパティ: プレゼンテーション

このセクションでは、[ピボット テーブル] プロパティを説明します。

### インデント モード

このチェック ボックスをオンにすると、ピボット テーブルの左の軸 (列) がインデント モードで表示されます。つまり、"Total (合計)" ラベルが軸の値に置き換わるため、軸と軸の間のインデントを小さいコンパクトな表示にできます。

### 第 1 軸のラベルのみを使用

この設定は、ピボット テーブルがインデント モードの場合のみ意味があります。このチェック ボックスをオンにすると、第 1 軸の軸ラベルがラベル行全体に表示されます。後続の軸の軸ラベルは表示されません。

### 常にすべて展開

このチェック ボックスをオンにすると、すべての軸が常に完全に展開され、展開/折りたたみ機能がオフになります。

### グループ化アイコンを印刷しない

ピボット テーブルを印刷する際に、部分的に展開または折りたたみを行うための [+] アイコンと [-] アイコンが印刷されないようにする場合は、このチェック ボックスをオンにします。

### 選択アイコンの表示

選択されている項目を含むテーブルの列に選択アイコン (ビーコン) を表示します。

### 欠損値セルを表示する

このチェック ボックスをオンにすると、クロス テーブルで、軸の組み合わせが見つからないことを示すセルが通常の null 値にマップされます。これにより、null 値があるかどうか、または適用される属性式やスタイル書式に関して、数式をテストできます。

### 合計の表示位置

ピボット テーブルで合計を表示するための設定です。

### 列の移動とピボットを許可する

このチェック ボックスをオフにすると、ドラッグ アンド ドロップによるピボットが無効になります。

### 背景色

背景色を単色、またはグラデーションに設定します。the Caption color icon をクリックして色を選択してください。

### 背景画像

背景として画像を設定します。the Add image icon アイコンをクリックして画像を参照します。the Settings icon をクリックして [画像の設定] ポップアップを開きます。

#### [画像] ポップアップ

縮小/拡大なし: 画像を縮小/拡大せずに表示します。画像を縮小/拡大せずに表示します。 したがって、画像の一部が表示されない場合や、オブジェクトの一部が画像で覆われない場合があります。全体を覆う: 画像を、画像の縦横比を考慮せずに、オブジェクト領域全体を覆うように拡大します。縦横比を固定する: 画像を、縦横比を維持したまま、オブジェクト領域全体をできるだけ広く覆うように拡大します。縦横比を固定して全体を覆う: 画像を、縦横比を維持したまま、オブジェクト領域全体を両方向とも覆うように拡大します。水平: [左]、[中央]、または [右] 揃え。垂直: [上]、[中央]、または [下] 揃え。透過性: 値を入力、またはスライダーをドラッグして透過性レベルを設定します。100% の場合、背景は完全に透明になります。

### 詳細/簡略

このセクションでは、[基本設定] プロパティを含んでいる、[詳細/簡略] プロパティを説明します。

#### (基本設定)

このセクションでは、[基本設定] にあるプロパティを説明します。

* スタイル: ドロップダウン リストから適切なスタイルを選択します。
* セルの枠線: ポップアップを開くには the Engine icon をクリックします。
  * セルの枠線の設定ポップアップ:
    * 軸項目に縦の罫線を表示: このチェック ボックスをオフにすると、現在のスタイルの軸項目のすべての縦の罫線が削除されます。

    * 行間に罫線を表示: このチェック ボックスをオンにすると、軸の行間の上側に、行間の下側と同じ横の枠線が引かれます。また、行間の領域内では、すべての縦の罫線は削除されます。

    * 数式項目に縦の罫線を表示: このチェック ボックスをオフにすると、現在のスタイルの数式項目のすべての縦の罫線が削除されます。
* 0 値を隠す: このチェック ボックスをオンにすると、すべての数式から 0 または NULL を返す軸項目のすべての組み合わせが計算で無視されます。このオプションは、デフォルトでオンになっています。
* 欠損値を隠す: このチェック ボックスをオンにすると、すべての数式のすべての項目の NULL 値にのみ関連付けられた軸項目のすべての組み合わせが計算で無視されます。このオプションは、デフォルトでオンになっています。これをオフにすると、チャートで NULL 値をカウントするなど、特別な場合にのみ役立ちます。
* 選択アイコンの表示: 選択されている項目を含むテーブルの列に選択アイコン (ビーコン) を表示します。
* 縦書きラベル: 列のタイトルを縦に表示します。
* NULL マーク: ここに入力されたマークは、テーブルで NULL 値を表示する際に使用されます。
* 欠損値マーク: ここに入力されたマークは、テーブルで欠損値を表示する際に使用されます。
* ヘッダーを折り返して表示: ヘッダーの内容は 2 行以上に折り返されます。
* セルのテキストを折り返して表示: データ セルの内容は 2 行以上に折り返されます。
* 演算実行条件: ここに入力された数式には、チャートが計算されるために満たす必要がある条件を設定します。条件が満たされない場合は、「演算実行条件が満たされていません」というテキストがチャートに表示されます。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。

#### スタイル

* フォント: フォントの種類を設定するには the Font icon をクリックします。

* キャプションのフォント: キャプションのフォントの種類を設定するには the Font icon をクリックします。

* アクティブ時のキャプション: アクティブ時のキャプションの背景色を設定するには the Caption color icon をクリックします。テキストの色を設定するには the Font color icon をクリックします。

* 非アクティブ時のキャプション: 非アクティブ時のキャプションの背景色を設定するには the Caption color icon をクリックします。テキストの色を設定するには the Font color icon をクリックします。

* 枠線の使用: シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。枠線の色を設定するには、the Caption color icon をクリックします。

* 枠線の幅: 枠線の幅を設定するには、値を指定するかスライダーをドラッグします。幅は、ピクセル単位で指定します。

* 角を丸くする: the Settings icon をクリックして [角を丸くする] ポップアップを開きます。

  情報メモ

  [角を丸くする] を使用できるのは、[詳細設定]、[スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) が選択されている場合のみです。

  * 角を丸くするポップアップ:
    * 角の丸みには [固定] または [相対値] を選択し、丸くしたい角を選択します。
    * 値を入力して [鋭度] を選択します。

* スクロール バーの幅: スクロール バーの幅を設定するには、値を指定するかスライダーをドラッグします。このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。

## ピボット テーブル プロパティ: キャプション

このセクションでは、[ピボット テーブル] プロパティを説明します。

* ラベル: テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。

  値は、計算式として入力できます。

  the Function icon をクリックして [数式の編集] ダイアログを開きます。

* キャプションの表示: このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。

* キャプションの配置: 左揃え、中央揃え、または右揃えに配置できます。

* 複数行のキャプション (文章の折り返し): このオプションを選択した場合、テキストは 2 行以上で表示されます。

* 行数: キャプションで複数行がオンの場合に、入力項目で行数を指定、またはスライダを希望する数値までドラッグします。

* キャプションの配置: 上揃え、中央揃え、または下揃えに配置できます。

###

### 詳細/簡略

[詳細/簡略] には、[キャプション内のアイコン] というプロパティが 1 つあります。

### キャプション内のアイコン プロパティ

このセクションでは、[キャプション内のアイコン] にあるプロパティを説明します。

* メニュー: オブジェクト メニューを開きます。
* クリア: アクティブなリスト ボックスの現在の選択をすべてクリアします。
* 印刷: 選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* データのコピー: シート オブジェクトの項目値をコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* 画像をクリップボードにコピー: シート オブジェクトを画像としてクリップボードにコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* Excel にエクスポート: 絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。
* 自動最小化: このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。
* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する] と [最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。
* ヘルプ テキスト: ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。このオプションはドキュメント レベルでは使用できません。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。   
  シート オブジェクトの説明などを入力できます。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。
* クイック切替: ここではチャートの種類の切り替えを有効にできます。チャートの種類によっては、このオプションは無効です。ポップアップを開くには the Settings icon をクリックします。
* クイック切替の設定ポップアップ: クイック切替を使用して切り替えたいチャートの種類のチェック ボックスをオンにします。

## ピボット テーブル プロパティ: オプション

### オプション

オプションはすべてのオブジェクトで使用できるわけではありません。

* 読み取り専用: チャートを読み取り専用にします。これにより、チャート内でマウスを使用してクリックまたはペイントしても選択できなくなります。
* 移動/サイズ変更を許可する: このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
* コピー/複製を許可する: このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。すべてのクライアントでこの設定を処理できるとは限りません。
* オブジェクトのサイズをデータに合わせる: 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。
* INFO アイコンをキャプションに表示する: Info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。リスト ボックス、統計ボックス、マルチ ボックス、入力ボックスでのみ利用できます。
* スクロール バーの位置を保持する: このチェックボックスおよび ユーザー プロパティ、オブジェクト ダイアログにある付随するチェック ボックスをオンにすると、テーブル オブジェクトで選択されたときに、QlikView が垂直スクロールの位置を保持します。
* 条件付き表示の使用: シート オブジェクトは、選択などで断続的に評価される条件式に基づいて表示/非表示にされます。シート オブジェクトは、その条件が false を返す場合にのみ非表示になります。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 標準: シート オブジェクトの 左、上、幅、高さ を設定し、その位置を指定します。
* 最小化: 最小化されたシート オブジェクトの 左、上、幅、高さ を設定し、その位置を指定します。
* 詳細/簡略: 次のオプションを使用できます。
  * 所有者: 所有者のドメインとユーザー ID。

  * オブジェクトの共有: 他のユーザーとのオブジェクトの共有を有効にします。この選択を有効にすると、以下の設定が有効になります。

  * 共有先:[共有する] か [ユーザーを指定して共有する] のいずれかを選択します。

  * ユーザー (Domain\UserID):[ユーザーを指定して共有する] を選択すると、追加されたユーザーのリストが表示されます。

    ユーザーを追加するには the Add icon をクリックします。行が追加されますのでその行を強調表示してロックを解除し、ユーザー情報を編集します。ユーザーを削除するには、削除する各ユーザーの後ろにある the Remove icon をクリックします。