# ゲージ チャート - AJAX/Webview

ゲージ チャートは、軸のない単一の数式の値を表示するために使用されます。

## ゲージ チャート：[オブジェクト] メニュー

シート オブジェクト上で右クリックするか、オブジェクトのキャプション (表示されている場合) で the Menu icon アイコンをクリックすると、コンテンツ メニューとしてオブジェクト メニューが開きます。

メニューに含まれるコマンドは、QlikView ローカル クライアントで WebView を開いているか、Web ブラウザでドキュメントにアクセスして開いているかによって異なります。メニューには以下のコマンドがあります。

メニュー コマンド

| コマンド | [Details] (詳細) |
| --- | --- |
| プロパティ | アクティブなシート オブジェクトの **プロパティ**ダイアログが開きます。 |
| ノート | 現在のオブジェクトに関するノートの作成および共有ができます。 |
| 分離設定 | チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。 |
| 分離解除 | 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。 |
| 参照設定 | このオプションは、チャートの参照 (現在の選択を使用したチャートの固定プロットなど) を設定します。ドキュメントでさらに選択を行っても、参照プロットは残り、背景に淡色表示されます。チャートの軸は、常に背景のデータ セットと現在のデータ セットの最大値に調整されます。現在のデータ セットは、常に参照プロットの上にプロットされます。参照プロットの一部が、現在のデータ セットで覆われる可能性があります。 参照チャート プロットの表示は、一部のチャートの種類 (棒グラフ、折れ線グラフ、コンボ チャート、レーダー チャート、散布図、グリッド チャート、および針を使用するゲージ チャートなど) でのみ可能です。ドリルダウンやサイクリック グループを含むチャートでは [参照設定] は利用できません。ドキュメントを閉じるか、データをリロードすると、参照は失われます。[参照設定] オプションの使用時に含めることができるオブジェクトの最大数は 500 です。 |
| 参照解除 | 参照が設定されると、参照設定 コマンドがこのコマンドに置き換えられます。これを選択すると、以前に設定した参照がクリアされ、チャートが通常のプロット モードに戻ります。 |
| すべての選択をクリア | アクティブなリスト ボックスの現在の選択をすべてクリアします。オブジェクトのキャプション (表示されている場合) で the Eraser icon アイコンをクリックしても同じ結果になります。 |
| コピー | 選択したシート オブジェクトをクリップボードにコピーします。この関数はデータや画像ではなく、シート オブジェクトのみをコピーします。 |
| 印刷 | 選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。オブジェクトのキャプション (表示されている場合) で the Printer icon アイコンをクリックしても同じ結果になります。 |
| Excel 出力 | 絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。オブジェクトのキャプション (表示されている場合) で the Spreadsheet icon アイコンをクリックしても同じ結果になります。 |
| エクスポート | 名前を付けて保存 ダイアログが開き、出力されたデータを保存する場所、ファイル名、ファイルの種類を指定できます。 |
| クイック切替 | 現在のチャートを別の種類のチャートに変更することができます。オブジェクトのキャプション (表示されている場合) で the Fast forward icon アイコンをクリックしても同じ結果になります。[チャートのクイック切替] が [プロパティ] ダイアログの [キャプション] タブで有効になっている場合にのみ利用できます。 |
| 最小化 | オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) で the Minimize icon アイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 元のサイズに戻す | 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) で the Restore icon アイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。 |
| 最大化 | オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) で the Maximize icon アイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。 |
| 削除 | 選択されたオブジェクトをシートから削除します。 |

## ゲージ チャート プロパティ

[プロパティ] ダイアログを開くには、[ **プロパティ**] を [ **オブジェクト**] メニューから選択します。 [ **プロパティ**] コマンドが淡色表示されている場合は、プロパティの変更を行うために必要な権限がない可能性があります。

### 数式

ドロップダウン リストから数式を選択します。数式を追加するには the Add icon をクリックします。ドロップダウンから数式を選択します。the Move icon アイコンでリスト内の項目を移動します。the Remove icon アイコンでリストから項目を削除します。詳細については、詳細 ボタンをクリックしてください。

#### 数式

* 有効化: このチェック ボックスをオンにすると、選択した数式が有効になります。ボックスがオンにされていない場合は、数式を使用できません。
* 条件付き表示: このチェック ボックスをオンにすると、編集ボックスの下にある the Function icon ボタンをクリックして入力した条件式の値に応じて、レポートが動的に表示または非表示にされます。
* ラベル:
  * 数式のラベル。チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。
  * 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 数式: 現在選択されている式を削除します。
* コメント: 数式の目的と機能を説明するコメントを入力します。
  * 数値書式タブ: 各項目には、デフォルトの数値書式があり、[] ドキュメント プロパティ: 数値] ページで設定できます。ただし、シート オブジェクトごとに別の数値書式を使用することもできます。このページは、アクティブなオブジェクトに適用されます。また、項目値を設定する次のコントロールが含まれます。
    * 数値書式: 以下のオプションから数値書式を選択します。
    * 既定: 数値とテキストの両方。数値は元の書式で表示されます。
    * 数値:有効桁数 ボックスで設定した桁数で数値を表示します。
    * 整数: 数値を整数で表示します。
    * 桁数固定:小数点以下の桁数 ボックスで設定した桁数の小数点値で数値を表示します。
    * 通貨:書式パターン ボックスで設定した書式で値を表示します。デフォルトの書式は Windows の通貨設定です。
    * 日付: [書式パターン] 項目で設定した書式で日付として変換された値を表示します。
    * 時刻:書式パターン ボックスで設定した書式で時刻として変換された値を表示します。
    * 日付と時刻:書式パターン ボックスで設定した書式で日付+時刻として変換された値を表示します。
    * 時間間隔: シーケンシャルな時間増分で時間を表示します。例：書式 = mm では、値をカレンダーが始まってからの分の数で表示します ( 1899:12:30:24:00)。
    * 書式パターン: 項目の表示書式を詳細に指定する書式コード。[ISO] は、書式を ISO 標準に設定します。[日付]、[時刻]、[日時]、[時間間隔] でのみ有効です。[Sys] は、書式をシステム設定に設定します。
    * 有効桁数: 表示される桁数です。
    * 小数点以下の桁数: 表示される小数点以下の桁数を設定します。
    * 小数点の記号: 小数点を示す記号を設定します。
    * 桁区切り: 桁区切りを示す記号を設定します。
    * パーセント表示: 実数の代わりにパーセント形式で表示します。設定は、[数値]、[整数]、および [実数] でのみ使用できます。
    * プレビュー: 上で指定した数値書式に基づいてプレビューを表示します。

#### アクション

ドロップダウン リストからアクションを選択します。アクションを追加するには the Add icon をクリックします。ドロップダウン リストからアクションを選択します。the Move icon アイコンでリスト内の項目を移動します。the Remove icon アイコンでリストから項目を削除します。the Engine icon をクリックして [アクションの設定] ポップアップを開きます。

* アクションの設定ポップアップ: アクションの [種類] と [下位の種類] をドロップダウン リストから選択します。
  * 選択:
    * 項目値の選択: 指定された項目の指定された値を選択します。検索文字列 では、検索マスクを指定できます。例：(A|B) は A と B の両方を選択します。
    * 除外値の選択: 指定された項目の除外値を選択します。
    * 絞込値の選択: 指定された項目の絞込値を選択します。
    * 選択の切り替え: 現在の選択値と指定した 項目 と 検索文字列 で選択を切り替えます。検索文字列 では、検索マスクを指定できます。例：(A|B) は A と B の両方を選択します。
    * やり直し: 選択条件のリストを 1 つ次に進めます。
    * 戻る: 選択条件のリストを 1 つ前に戻します。
    * パレート選択: 数式とパーセントを基準に指定した項目でパレートの選択を行います。この種類の選択は、一般的に 80/20 ルール上での評価基準で主要な要因を選択するために使用されます。たとえば、売上高の 80% に貢献したトップの顧客を見つけるためには、顧客を項目として使用して sum(売上高) を数式と使用し、また 80 をパーセントとして使用します。
    * 項目のロック: 指定した項目の選択をロックします。
    * すべてロック: すべての項目のすべての値をロックします。
    * 項目のアンロック: 指定した項目の選択のロックを解除します。
    * すべてアンロック: すべての項目のすべての値のロックを解除します。
    * すべてをアンロックしてクリア: すべての項目のすべての選択のロックと選択を解除します。
    * 他項目のクリア: 指定した項目以外のすべての関連項目の選択を解除します。
    * すべての選択をクリア: ロックされていないすべての選択を解除します。
    * 項目のクリア: 特定の項目をクリアします。
  * レイアウト:
    * オブジェクトをアクティブにする: 指定した オブジェクト ID のオブジェクトをアクティブにします。この機能は Ajax クライアントでは利用できません。
    * シートをアクティブにする: 指定した シート ID のシートをアクティブにします。
    * 次のシートをアクティブにする: ドキュメントの次のシートを開きます。
    * 前のシートをアクティブにする: ドキュメントの前のシートを開きます。
    * オブジェクトを最小化する: 指定した オブジェクト ID のオブジェクトを最小化します。
    * オブジェクトを最大化する: 指定した オブジェクト ID のオブジェクトを最大化します。
    * オブジェクトを元のサイズに戻す: 指定した オブジェクト ID のオブジェクトを元のサイズに戻します。
  * ブックマーク:
    * ブックマークの適用: 指定した ブックマーク ID のブックマークを適用します。2 つのブックマークが同じ ID を持つ場合、ドキュメント ブックマークが適用されます。サーバー ブックマークを適用するには、サーバー\ブックマーク ID を指定します。
    * ブックマークの作成: 現在の選択でブックマークを作成します。ブックマーク ID と ブックマーク名 を指定します。選択 **非表示**非表示のブックマークを作成します。
    * ブックマークの上書き: 指定した ブックマーク ID のブックマークを現在の選択に置き換えます。
  * 印刷:
    * オブジェクトの印刷: 指定した オブジェクト ID のオブジェクトを印刷します。既定に設定されたプリンタ以外でオブジェクトを印刷する場合、プリンタ名 を指定します。(ドキュメント トリガーとシート トリガーでは無効です)
    * シートの印刷: 指定した シート ID のシートを印刷します。(ドキュメント トリガーとシート トリガーでは無効です。) この機能は AJAX クライアントでは利用できません。
    * レポートの印刷: 指定した レポート ID のレポートを印刷します。既定に設定されたプリンタ以外でレポートを印刷する場合、プリンタ名 を指定します。ウィンドウズの [印刷] ダイアログを表示する場合、[印刷] ダイアログを表示する チェックボックスをオンにします。(ドキュメント トリガーとシート トリガーでは無効です)
  * 外部:
    * この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
      * エクスポート: 特定の項目セットを含むテーブルをエクスポートします。選択条件に当てはまるレコードのみがエクスポートされます。設定 ボタンを アクション ページでクリックすると、エクスポート アクションの設定 ダイアログが開きます。ドキュメント トリガーまたはシート トリガーとしては使用できません。

        情報メモこの機能は AJAX クライアントでは利用できません。

      * 起動: 外部プログラムを起動します。以下の設定は、[アクション] ダイアログで設定できます。

        * アプリケーション: [参照] をクリックして、起動するアプリケーションを探します。(ドキュメント トリガーとシート トリガーでは無効です)
        * ファイル名: 上で指定したアプリケーションで開くファイルへのパスを入力します。(ドキュメント トリガーとシート トリガーでは無効です)
        * パラメータ: アプリケーションを起動するコマンド ラインのパラメータを指定します。(ドキュメント トリガーとシート トリガーでは無効です)
        * 作業ディレクトリ: 起動するアプリケーションの作業ディレクトリを設定します。(ドキュメント トリガーとシート トリガーでは無効です)
        * QlikView 終了時にアプリケーションを終了する: QlikView 終了時にアプリケーションを強制的に終了します。(ドキュメント トリガーとシート トリガーでは無効です)

          情報メモこの機能は AJAX クライアントでは利用できません。

      * URL から開く: [URL から開く] を使用して、別の QlikView ドキュメント内から QlikView ドキュメントへの URL を開くことができます (ドキュメント チェーン)。この設定により既定の WEB ブラウザで URL が開きます。この機能をドキュメントおよびシートのトリガーとして使用することはできません。[URL から開く] を使用する場合は、ドキュメント名を必ず小文字でアクション文字列に入力してください。  
        可能であれば、[URL から開く] ではなく [QlikView ドキュメントを開く] を使用してください。

        情報メモ既定では、URL で Javascript を使用できないようになっています。

        custom.config ファイルで `PreventJavascriptInObjectActions` パラメーターを変更することにより、URL で JavaScript を使用できるようになります。

      * QlikView ドキュメントを開く: [QlikView ドキュメントを開く] を使用して、別の QlikView ドキュメント内から QlikView ドキュメントを開くことができます (ドキュメント チェーン)。この機能は、ドキュメント トリガーまたはシート トリガーとしては使用できません。詳細については、「[ドキュメント チェーンの例](https://help.qlik.com/ja-JP/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Ajax/WebView_GaugeChart.htm#Document)」を参照してください。

      * マクロの実行: 実行するマクロのパスとマクロ名を入力します。任意の名前を入力して後で モジュールの編集 ダイアログでマクロを作成する、もしくは動的に更新される 計算式 を入力できます。

      * 変数の設定: 指定した変数に値を適用します。

      * 情報の表示: 指定された 項目 に関連付けられたテキストファイルや画像といった情報を表示します。この機能は AJAX クライアントでは利用できません。

      * このドキュメントを閉じる: QlikView ドキュメントを閉じます

      * リロード: 現在のドキュメントのリロードを行います。この機能は AJAX クライアントと IE プラグインでは利用できません。

      * ダイナミック更新: 現在ロードされているドキュメントでデータを動的に更新します。ダイナミック更新へのステートメントはステートメント フィールドに入力してください。  
        ダイナミック更新の用途では、QlikView 管理者はドキュメントのリロードを実行しなくても、単一のソースから限定的な量のデータを QlikView ドキュメントにフィードすることができます。その後、QlikView Server に接続している複数のクライアントが分析を実行できます。

        情報メモアップロードされた情報は RAM のみで保存されるため、ドキュメントのリロードを行うと、ダイナミック更新を使用して追加または更新されたデータは失われます。

        以下の規則は、ダイナミック更新機能で使用できるステートメントとそのコンポーネントについて説明したものです。

        * statements ::= statement { “;” statement } { “;” statement }
        * statement ::= insert\_statement | update\_statement | delete\_statement | begin\_transaction\_statement | commit\_transaction\_statement
        * insert\_statement ::= "INSERT" "INTO" ("\*" | table\_name) field\_list "VALUES" value\_list {"," value\_list} ["KEY" ["AUTO" | (" (" field\_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
        * update\_statement ::= "UPDATE" ("\*" | table\_name) set\_clause {"," | set\_clause} "WHERE" condition ["AUTO" "INSERT"]
        * delete\_statement ::= "DELETE" "FROM" ("\*" | table\_name] "WHERE" condition
        * begin\_transaction\_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans\_name]
        * commit\_transaction\_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans\_name]
        * table\_name ::= identifier | quoted\_name
        * field\_list ::= "(" field\_name {"," field\_name} ")"
        * value\_list ::= "("value {"," value} ")"
        * set\_clause ::= "SET" field\_name "=" any\_valid\_non\_aggregated\_qlikview\_expression
        * field\_name ::= identifier | quoted string
        * value ::= identifier | any\_qlikview\_number | quoted string
        * condition ::= any\_valid\_non\_aggregated\_qlikview\_expression
        * identifier ::= any\_qlikview\_identifier
        * quoted\_string ::= "[" [^]]+ "]"

        `  UPDATE AbcTable SET Discount = 123 WHERE AbcField=1 `

        情報メモ この機能を使用するには、ドキュメントとサーバーの双方でダイナミック更新を許可しておかなくてはなりません。
      #### ドキュメント チェーンの例

      [QlikView ドキュメントを開く] を使用して、ドキュメント チェーンを作成できます。

      次の設定を適用できます。
      * ステートの転送: 元のドキュメントから転送先のドキュメントに選択内容を転送します。転送先ドキュメントでは、まず選択内容がクリアされます。

      * 現在の選択条件にステートを追加: 転送先ドキュメントの選択内容を維持し、元のドキュメントの選択内容を追加適用します。

        情報メモ [現在の選択条件を追加適用する] を使用すると、2 つのドキュメントでの選択内容が競合している場合に予期せぬ結果が返されることがあります。

      * 同じウィンドウで開く: AJAX ZFC クライアントを使用している場合に、同じブラウザ タブで新しいドキュメントを開きます。

        情報メモQlikView Plug-In を使用している場合、ドメイン ユーザー以外のユーザーは [QlikView ドキュメントを開く] アクションを使用できません。

      QlikView ドキュメント: 対象ファイルの拡張子を入力する必要があります。1 つの QlikView ドキュメントから別のドキュメントに移動するための相対パスは、連結されたドキュメントが同じフォルダー構造 (マウント) 内に保存されている限り、すべてのクライアントでサポートされます。

      次の例は、対象ファイルへのファイル パスを書き込む方法を示しています。

      例: 同じフォルダー構造 (同じマウント) 内に格納されたファイル。
      * 対象ファイルが同じフォルダー内に格納されている場合:  
        DestinationDoc.qvw

      * 対象ファイルがサブ フォルダー内に格納されている場合:  
        SubFolder/DestinationDoc.qvw

      * 対象ファイルが上位フォルダー内に格納されている場合:  
        ../DestinationDoc.qvw

      * 対象ファイルが上位の並列フォルダーに格納されている場合:  
        ../ParallelFolder/DestinationDoc.qvw

      例: 別のフォルダー構造 (別のマウント) 内に格納されているファイル。異なるマウント間の相対パスに対応しているのは Ajax クライアントのみです。
      * 対象ファイルが別のマウント内に格納されている場合:  
        ../DifferentMount/DestinationDoc.qvw

      例: QlikView ドキュメントを指すマウント パスの使用。マウントされたフォルダーへのパスの設定に対応しているのは、Ajax クライアントのみです。
      * 対象ファイルが同じマウントされたフォルダー内に格納されている場合:  
        \Mount\DestinationDoc.qvw

      * 対象ファイルが別のマウントされたフォルダー内に格納されている場合:  
        \DifferentMount\DestinationDoc.qvw

        情報メモマウントされたフォルダーでのドキュメント チェーンは、QlikView Plug-In では機能しません。

      例: QlikView ドキュメントを指す絶対パスの使用。ドキュメント チェーンでの絶対パスの使用に対応しているのは Ajax クライアントと QlikView Desktop のみです。
      * Local Root フォルダーまたはマウントへの絶対パス:  
        C:\...\DestinationDoc.qvw

      * ネットワーク共有への絶対パス:  
        \\SharedStorage\...\DestinationDoc.qvw

      Qlik Sense Cloud ハブ内での QlikView アプリ: パスではなく、アプリ ID が必要です。アプリは QlikView Desktop 内で準備し、更新する必要があります。アプリ ID は、アプリがハブ内で開かれる時の URL にあります。

      例

      URL が https://qcs.us.qlikcloud.com/qv/opendoc.htm?document=1cc71b323f172f93a8121ce1456cdg の場合、アプリ ID は、1cc71b323f172f93a8121ce1456cdg です。

#### タイトルの表示

デフォルトでは、定義する最初の数式のラベルがチャート タイトルとして設定されます。チャート タイトルを表示しない場合は、チェック ボックスをオフにします。動的に更新する計算式としてタイトルを指定することもできます。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。

#### 詳細/簡略

隠された補助タブを展開/折りたたみするには、このボタンをクリックします。

## ゲージ チャート プロパティ: プレゼンテーション

### プレゼンテーション

* スタイル: ドロップダウンの選択肢の中から種類をひとつ選択します。

* ゲージの最小値: ゲージの最小値を指定します。この値は、ゲージのインジケータの最下部の位置に対応します。

* ゲージの最大値: ゲージの最大値を指定します。この値は、ゲージのインジケータの最上部の位置に対応します。

* ゲージ セグメントの設定: このグループでは、ゲージを構成するセグメントを定義します。LED スタイルのゲージを除くすべてのゲージには、セグメントが少なくとも 1 つ必要です。円形および線形ゲージでは、セグメントは背景の色が異なる領域を構成します。信号機ゲージでは、各セグメントは 1 つのライトに対応します。表示されているセグメントのリストで、プロパティを変更するセグメントを 1 つ選択します。ドロップダウンでセグメントを選択し、the Add icon をクリックしてセグメントを追加します。領域の色を選択するには、the Caption color icon をクリックします。the Remove icon をクリックして、リストから項目を削除します。ポップアップを開くには the Engine icon をクリックします。

* セグメント領域の自動調整: このチェック ボックスをオンにすると、ゲージの [最小値]、[最大値]、および定義されているセグメント数に基づいてセグメントの領域が自動的に計算されます。

* Log スケール: このチェック ボックスをオンにすると、ゲージの目盛が対数になります。

* セグメント領域の相対表示: このオプションをオンにすると、セグメント領域を 0 ～ 1 の数値で入力できます。この数値は、最小値から最大値までの値の範囲全体に対する割合を示します。

* セグメントの輪郭の表示: ゲージのセグメントの輪郭を表示します。

* セグメントの境界の表示: このチェック ボックスをオンにすると、円形および線形ゲージのセグメントの境界で輪郭を描画します。

* セグメント: ゲージにセグメントを追加するには the Add icon をクリックします。

  * 背景: チャートの背景を設定します。次のオプションを使用できます。

  * 色:the Caption color icon をクリックして色を選択します。

  * 画像: 画像を変更するには the Add image icon をクリックします。

* 動的画像: 計算式を入力し、選択によって動的に変化する画像を背景に表示します。

* 背景の透過性: チャートの透過性を設定するには、ボックスに値を入力するかスライダーをドラッグします。

#### 詳細/簡略

* 基本設定: 基本設定タブ スピードメーターと円形スタイル。

* ゲージ インジケータの表示: ゲージ値を針のインジケータで表示します。

* インジケータの種類: ハリのスタイルを指定します。

* 値のみゲージ塗りつぶし: 定義されたセグメントの色でゲージ背景を現在の値まで塗りつぶして、ゲージ値を示します。残りの [最大値] までの部分は、空白のままになります。

* ゲージの目盛の表示: 目盛を表示する場合は、このチェック ボックスをオンにします。

* 目盛: ゲージの目盛の数を定義します。

* 補助目盛: ゲージの目盛間の補助目盛の数を定義します。

* ゲージのラベル: ゲージの目盛にテキスト ラベルを表示するには、このチェック ボックスをオンにします。

* ラベルの頻度: 編集ボックスには、ラベルの間隔を入力します。

* 円筒の厚さ: 円形ゲージは、通常、塗りつぶされた円または円のセグメントとして描画されます。大きい番号ほど円筒が太くなります。穴でくり抜かれる領域の半径のパーセンテージを示す値を、0 ～ 99 の範囲で指定します。

* 角度の範囲: ゲージの [最小値] から [最大値] までの角度。45 ～ 360 の値を指定します。

* 中心の角度: ゲージの中央値を時計に当てはめたときの角度。0 ～ 360 の値を指定します。0 はゲージの上部の中心 (12 時) を示します。

* ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ ポイント上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* 基本設定タブ直線ゲージ スタイル:

  * ゲージ インジケータの表示: ゲージ値を針のインジケータで表示します。

  * インジケータの種類: 針のスタイルを指定します。

  * 値のみゲージ塗りつぶし: 定義されたセグメントの色でゲージ背景を現在の値まで塗りつぶして、ゲージ値を示します。残りの [最大値] までの部分は、空白のままになります。

  * ゲージの目盛の表示: 目盛を表示する場合は、このチェック ボックスをオンにします。

  * 目盛: ゲージの目盛の数を定義します。

  * 補助目盛: ゲージの目盛間の補助目盛の数を定義します。

  * ゲージのラベル: ゲージの目盛にテキスト ラベルを表示するには、このチェック ボックスをオンにします。

  * ラベルの頻度: 編集ボックスには、ラベルの間隔を入力します。

  * ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ ポイント上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* 基本設定タブ信号機ゲージ スタイル:

  * ライトひとつ: このボックスをオンにすると、ライトがひとつだけ表示されます。

  * インジケータの種類: ライト周囲の領域のスタイルを指定します。

  * 値のみゲージ塗りつぶし: 定義されたセグメントの色でゲージ背景を現在の値まで塗りつぶして、ゲージ値を示します。残りの [最大値] までの部分は、空白のままになります。

  * 反転: このボックスをオンにすると、ライトがソート順を反転した状態で表示されます。

  * ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ ポイント上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* 基本設定タブLED スタイル:

  * 桁: 何桁表示するを選択します。

  * 数字の色: 色を設定するには the Caption color icon をクリックします。

  * ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ ポイント上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* 基本設定タブ試験管スタイル:

  * 試験管の色: 色を設定するには the Caption color icon をクリックします。

  * ゲージの目盛の表示: 目盛を表示する場合は、このチェック ボックスをオンにします。

  * 目盛: ゲージの目盛の数を定義します。

  * 補助目盛: ゲージの目盛間の補助目盛の数を定義します。

  * ゲージのラベル: ゲージの目盛にテキスト ラベルを表示するには、このチェック ボックスをオンにします。

  * ラベルの頻度: 編集ボックスには、ラベルの間隔を入力します。

  * ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ点上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* 基本設定タブ影付きチューブ:

  * ゲージの目盛の表示: 目盛を表示する場合は、このチェック ボックスをオンにします。

  * 目盛: ゲージの目盛の数を定義します。

  * 補助目盛: ゲージの目盛間の補助目盛の数を定義します。

  * ゲージのラベル: ゲージの目盛にテキスト ラベルを表示するには、このチェック ボックスをオンにします。

  * ラベルの頻度: 編集ボックスには、ラベルの間隔を入力します。

  * ポップアップ ラベル: このチェック ボックスをオンにすると、チャートのデータ点上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

* スタイル:

  * チャート タイトルのスタイル: チャート タイトルの色を設定するには the Font color icon をクリックします。フォントの種類を設定するには the Font icon をクリックします。

  * 目盛ラベル: フォントの種類を設定するには the Font icon をクリックします。

  * キャプションのフォント: キャプションのフォントの種類を設定するには the Font icon をクリックします。

  * アクティブ時のキャプション: アクティブ時のキャプションの背景色を設定するには the Caption color icon をクリックします。テキストの色を設定するには the Font color icon をクリックします。

  * 非アクティブ時のキャプション: 非アクティブ時のキャプションの背景色を設定するには the Caption color icon をクリックします。テキストの色を設定するには the Font color icon をクリックします。

  * 枠線の使用: シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。枠線の色を設定するには、the Caption color icon をクリックします。

  * 枠線の幅: 枠線の幅を設定するには、値を指定するかスライダーをドラッグします。幅は、ピクセル単位で指定します。

  * 角を丸くする: the Settings icon をクリックして [角を丸くする] ポップアップを開きます。

  * [角を丸くする] を使用できるのは、[詳細設定]、[スタイルのモード] ([ドキュメント プロパティ: 基本設定] 内) が選択されている場合のみです。

  * 角を丸くするポップアップ: 角の丸みには [固定] または [相対値] を選択し、丸くしたい角を選択します。また、値を入力して [鋭度] を選択します。

* 基準線:
  * 基準線: 基準線を追加するには the Add icon をクリックします。
  * チャートにラベルを表示: 基準線の隣にラベルを表示します。
  * ラベル: テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
  * X- 軸: 基準線の起源を x- 軸にする場合は、このオプションを選択します。
  * 数式: 基準線を引く対象の値です。開始点として使用する数式を入力します。
  * 線の太さ: 基準線の太さを指定します。
  * 線のスタイル: 基準線のスタイルを指定します。
  * 線の色: 基準線の色を指定します。
  * 条件付き表示の使用: 基準線は、チャートが描画されるたびに評価される条件式に基づいて表示/非表示にされます。基準線は、数式が FALSE を返す場合にのみ非表示となります。
  * 条件: 条件式を入力します。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。

* テキスト:
  * チャートのテキスト: チャートにテキストを追加するには the Add icon をクリックします。
  * テキスト:チャートのテキスト に追加されたテキストはここに表示されます。
  * 角度: テキストの角度を 0 ～ 360 度に指定できます。デフォルトは 0 です。
  * 水平位置: 水平方向の配置を設定します。
  * 常に手前に表示: チャートの描画時に、リストで現在選択されているテキストが前面に表示されます。
  * テキストのスタイル:
    * テキストの背景色を設定するには the Caption color icon をクリックします。
    * フォントの色を設定するには the Font color icon をクリックします。フォントの種類を設定するには the Font icon をクリックします。
  * サイズと位置: オブジェクト上のテキストのサイズと位置を設定します。

### キャプション

* ラベル: テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。

  値は、計算式として入力できます。

  the Function icon をクリックして [数式の編集] ダイアログを開きます。

* キャプションの表示: このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。

* キャプションの配置: 左揃え、中央揃え、または右揃えに配置できます。

* 複数行のキャプション (文章の折り返し): このオプションを選択した場合、テキストは 2 行以上で表示されます。

* 行数: キャプションで複数行がオンの場合に、入力項目で行数を指定、またはスライダを希望する数値までドラッグします。

* キャプションの配置: 上揃え、中央揃え、または下揃えに配置できます。

### 詳細/簡略

このセクションでは、[詳細/簡略] の [アイコン キャプション] プロパティを説明します。

* メニュー: オブジェクト メニューを開きます。
* クリア: アクティブなリスト ボックスの現在の選択をすべてクリアします。
* 印刷: 選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* データのコピー: シート オブジェクトの項目値をコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* 画像をクリップボードにコピー: シート オブジェクトを画像としてクリップボードにコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* Excel にエクスポート: 絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。
* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。
* 自動最小化: このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。
* 最小化を許可する: このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する] と [最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。
* ヘルプ テキスト: ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。このオプションはドキュメント レベルでは使用できません。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。   
  シート オブジェクトの説明などを入力できます。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。
* クイック切替: ここではチャートの種類の切り替えを有効にできます。チャートの種類によっては、このオプションは無効です。ポップアップを開くには the Settings icon をクリックします。
* クイック切替の設定ポップアップ: クイック切替を使用して切り替えたいチャートの種類のチェック ボックスをオンにします。

## ゲージ チャート プロパティ: オプション

### オプション

オプションはすべてのオブジェクトで使用できるわけではありません。

* 読み取り専用: チャートを読み取り専用にします。これにより、チャート内でマウスを使用してクリックまたはペイントしても選択できなくなります。
* 移動/サイズ変更を許可する: このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
* コピー/複製を許可する: このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。すべてのクライアントでこの設定を処理できるとは限りません。
* オブジェクトのサイズをデータに合わせる: 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。
* INFO アイコンをキャプションに表示する: Info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。リスト ボックス、統計ボックス、マルチ ボックス、入力ボックスでのみ利用できます。
* スクロール バーの位置を保持する: このチェックボックスおよび ユーザー プロパティ、オブジェクト ダイアログにある付随するチェック ボックスをオンにすると、テーブル オブジェクトで選択されたときに、QlikView が垂直スクロールの位置を保持します。
* 条件付き表示の使用: シート オブジェクトは、選択などで断続的に評価される条件式に基づいて表示/非表示にされます。シート オブジェクトは、その条件が false を返す場合にのみ非表示になります。 値は、計算式として入力できます。 the Function icon をクリックして [数式の編集] ダイアログを開きます。
* 標準: シート オブジェクトの 左、上、幅、高さ を設定し、その位置を指定します。
* 最小化: 最小化されたシート オブジェクトの 左、上、幅、高さ を設定し、その位置を指定します。
* 詳細/簡略: 次のオプションを使用できます。
  * 所有者: 所有者のドメインとユーザー ID。

  * オブジェクトの共有: 他のユーザーとのオブジェクトの共有を有効にします。この選択を有効にすると、以下の設定が有効になります。

  * 共有先:[共有する] か [ユーザーを指定して共有する] のいずれかを選択します。

  * ユーザー (Domain\UserID):[ユーザーを指定して共有する] を選択すると、追加されたユーザーのリストが表示されます。

    ユーザーを追加するには the Add icon をクリックします。行が追加されますのでその行を強調表示してロックを解除し、ユーザー情報を編集します。ユーザーを削除するには、削除する各ユーザーの後ろにある the Remove icon をクリックします。