マルチ ボックス

適用性によって表示項目をソートするそのユニークなオプションによって、マルチ ボックスは、同じシート上にたくさんのリスト ボックスを表示することの問題点を根本的に解決します。この 適用順にソート オプションは、マルチ ボックス プロパティ: 基本設定 ページにあります。

マルチ ボックスを右クリックすると、[オブジェクト] メニューが表示されます。

[オブジェクト] メニュー

マルチ ボックスのオブジェクト メニューには 3 つのバージョンがあります。キャプション領域をクリックして表示されるフロート メニューには、ボックス全体に適用できるコマンドが含まれ、特定の項目がポインターの下にあった場合、その項目に適用されるコマンドもメニューに含まれます。最後に、初めにファイルを開けると、フロート メニューにはさらにもう 1 つのレイアウトが含まれます。すべてを含めたメニュー コマンド:

プロパティ パラメータを設定する [マルチ ボックス プロパティ] ダイアログを開きます。
ノート

現在のオブジェクトに関するノートの作成および共有ができます。

参照項目: ノートとコメント

順序

このカスケード メニューは [表示] メニューの [デザイン グリッド] コマンドが有効なときと、[ユーザー プロパティ:デザイン][デザイン メニュー項目を常に表示] チェックボックスがオンになっているときのみ使用できます。シート オブジェクトのレイアウト レイヤーを設定するためのコマンドが 4 つ含まれています。有効なレイヤー番号は -128 から 127 です。

最前面へ移動
シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最大値に設定します。

最背面へ移動
シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最小値に設定します。

前面へ移動
シート オブジェクトのレイアウト レイヤーを 1 つ増やします。最大値は 127 です。

背面へ移動
シート オブジェクトのレイアウト レイヤーを 1 つ減らします。最小値は -128 です。


検索

検索ボックスを開きます。

参照項目: 検索

あいまい検索

テキスト検索 ボックスをあいまい検索モードで開きます。

参照項目: あいまい検索

高度な検索

[高度な検索] ダイアログを開きます。このダイアログで、詳細な検索式を入力できます。 このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+SHIFT+F。

参照項目: [高度な検索] ダイアログ

絞込値の選択 その項目の除外値以外の値をすべて選択します。
除外値の選択 その項目の除外値をすべて選択します。
すべて選択 その項目のすべての値を選択します。
すべての選択をクリア マルチ ボックスの現在の選択をすべてクリアします。
クリア 項目の現在の選択をすべてクリアします。
他項目の選択のクリア マルチ ボックスの指定項目の選択を保持しながら、マルチ ボックスの他の項目の選択も含めて、他のシートオブジェクトの選択をすべてクリアします。
ロック その項目の選択値をロックします。
選択値をすべてロックする そのマルチ ボックスの選択値をロックします。
アンロック その項目のロックされた値を解除します。
すべてをアンロック マルチ ボックスのロックされた値を解除します。
印刷

プリンタ設定を指定できる [印刷] ダイアログを開きます。 マルチ ボックスの印刷は、各項目が 1 つの値を表示する場合にのみ意味を持ちます。これは、それが唯一の選択値であり、唯一の連結値だからです。

参照項目: 印刷: 基本設定

PDF として印刷

PDF-XChange 3.0 プリンタがあらかじめ選択されている状態で印刷ダイアログを開きます。印刷 ボタンをクリックすると、PDF 出力ファイルのファイル名を指定するように要求されます。このコマンドは、PDF プリンタがシステムで使用可能な場合のみ使用できます。

Excel 出力 絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 この操作は、各項目が 1 つの値を表示する場合にのみ意味を持ちます。なぜなら、それが唯一の選択値であり、唯一の連結値だからです。
エクスポート

ダイアログが開かれ、マルチ ボックスをテーブルとして、選択したファイルにエクスポートできます。ファイルは、コンマ区切りファイル、セミコロン区切りファイル、タブ区切りファイル、ハイパーテキスト (HTML)、XML、Excel (xls または xlsx) のいずれの形式でも保存できます。 デフォルトの形式は、タブ区切りファイル *.qvo (QlikViewOutput) です。

クリップボードにコピー このカスケード メニューには、シート オブジェクトのためのさまざまなコピー オプションが含まれています。
データ
マルチ ボックスのデータ行をクリップボードにコピーします。
セルの値
([オブジェクト] メニューを呼び出すときに) 右クリックしたマルチ ボックスのセルのテキスト値をクリップボードにコピーします。
画像
シート オブジェクトの画像をクリップボードにコピーします。画像がシート オブジェクトのキャプションおよび枠線を含むか除外するかは、ユーザー プロパティ ダイアログの エクスポート ページの設定に従います。
オブジェクト
シート オブジェクト全体をクリップボードにコピーし、レイアウトの別の場所や、QlikView の現在のインスタンス内で開いている他のドキュメントの別の場所に貼り付けることができます。
リンク オブジェクト

リンク オブジェクト用の次のコマンド メニューを開きます。
リンク オブジェクトを整列する
すべてのシート上にある他のリンク オブジェクトはすべて、選択されたオブジェクトと同じ位置、同じ大きさに整列されます。
オブジェクトのリンクを解除する
オブジェクト間のリンクを外し、異なるオブジェクトとしてそれぞれに異なるオブジェクト ID を付与します。

最小化 オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。
最大化 オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。
元のサイズに戻す 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。
ヘルプ QlikView ヘルプを開きます。
削除 シート オブジェクトをシートから削除します。

基本設定

タイトル

マルチ ボックスの タイトル ウィンドウには、ウィンドウ キャプションに表示される名前を入力します。タイトルは、ラベルのテキストの動的に更新される計算式としても定義できます。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

参照項目: 計算式の数式構文

並列ステート ドロップダウンの選択肢の中から種類をひとつ選択します。次の並列ステートはいつでも使用できます。
継承済み
シートとシート オブジェクトは、QlikView 開発者が無効にしない限り、常に 継承済み ステートにあります。この設定はひとつ上のレベルにあるオブジェクトから継承され、これを選択するとシート内のチャートにはシートと同様の設定が適用されます。
初期ステート
QlikView で最も使用されるステートで $ で表現されます。QlikView ドキュメントは常に [初期ステート] にあります。

項目

この列にはデータ ソース項目の名前が表示されます。初めは、すべての項目 (システム項目以外) がこの列に表示されます。システム項目を表示するには、[システム項目の表示] チェックボックスをオンにします。

参照項目: システム項目

キー項目は、キー シンボルで示されます。 使用/削除する項目をクリックして選択します。[追加 >] ボタンまたは [< 削除] ボタンを使用して、目的の列に移動します。

マルチ ボックス表示項目 この列には、マルチ ボックスに表示するために 項目 リストから選択された項目名が表示されます。初めは、この列に表示される項目はありません。
このリストで項目を選択すると、編集ボックスで ラベル を付けることができます。
テーブルの項目を表示 ここで、 項目 リストにどの項目を表示するかを制御します。ドロップダウン リストは、デフォルトで すべてのテーブル を表示します。
すべてのテーブル (テーブル名表示) は、項目をテーブル名とともに表示します。このため、キー項目は一度以上リスト表示されます。(これは表示目的にのみ使用できます。ロード スクリプトの Qualify とは関係ありません。)
一度に 1 つのテーブルの項目を見ることもできます。
数式 [数式の編集] ダイアログを開き、マルチ ボックスに表示項目として使用する数式を作成できます。
編集 [マルチ ボックス表示項目] 列で選択した項目を [数式の編集] ダイアログで開きます。
上へ 項目の表示される順番を 1 つ上に移動します。
下へ 項目の表示される順番を 1 つ下に移動します。
カウント順 マルチ ボックス表示項目 列の項目を番号順にソートします。
ロード順 マルチ ボックス表示項目 列をロード順 (データベースから読み込まれた順) にソートします。
テキスト順 マルチ ボックス表示項目 列の項目をアルファベット順にソートします。
ソート順に絞込値の有無を適用する このチェックボックスをオンにすると、マルチ ボックス表示項目 のソート順は選択時に動的に更新され、除外値でない値を含む項目がリストの上方へ移動し、絞込値のない項目が下方へ移動します。このオプションにより、ひとつのマルチ ボックスで文字通り 100 項目でも使用できるようになります。
オブジェクト ID

これは、マクロで使用されます。各シート オブジェクトには一意の ID が割り当てられます。英数字は ID のみに使用することをお勧めします。 マルチ ボックスの場合、ID は MB01 から始まります。 リンク オブジェクトは、同じオブジェクト ID を共有します。この ID は後で編集できます。

参照項目: 内部マクロ インタープリタ

ソート

[ソート] タブは、シート オブジェクト (リスト ボックス、マルチ ボックス、テーブル ボックス、チャートまたはスライダー/カレンダー オブジェクト) を右クリックし、フロート メニューから [プロパティ] を選択するか、メイン メニューの [オブジェクト] > [プロパティ] を選択して開きます。シート オブジェクトの値のソート順を設定します。シート オブジェクトによっては、ソートのオプションが無いものもあります。

ソート順:

状態 項目値を論理状態 (選択値、連結値、または除外値) に従ってソートします。
昇順自動並べ替え 設定は、リスト ボックスが垂直スクロール バーを表示するときにのみ、リスト ボックス (または、マルチ ボックスの項目値を含むドロップダウン リスト) を 選択状態 に従ってソートします。リスト ボックスを拡大してすべての値を表示させると、選択状態によるソート順は解除されます。
数式

このソート オプションの下にあるテキスト編集ボックスに入力した数式に基づいて項目値をソートします。しかし、ソート順に数式を使用する場合、SET 数式でレコードのセットを定義する必要があります。ここでの数式によるソートは、数値項目でのみ機能し、テキスト項目では機能しないので、注意してください。

参照項目: set 分析および set 数式

レコード数 項目値をレコード数 (テーブル内に現れる数) でソートします。
数値 項目値を数値順にソートします。
テキスト 項目値をアルファベット順にソートします。
ロード順 項目値を最初のロード順でソートします。

初期設定 ボタンは、ソート順を初期設定値に設定します。

優先順位は、選択状態数式レコード数数値テキストロード順 の順です。これらのソート条件はそれぞれ、昇順または降順に設定できます。

プレゼンテーション

[マルチ ボックス プロパティ: プレゼンテーション] タブは、マルチ ボックスを右クリックし、[オブジェクト] メニューから [プロパティ] コマンドを選択して開きます。 ここでは、マルチ ボックスのセルのレイアウトを調整できます。マルチ ボックスの項目ごとにそれぞれ配置を設定します。- 閉じたマルチ ボックス - のレイアウトも調整できます。

配置 項目値の配置を設定します。[テキスト] と [数値] の配置は別々に設定します。
折り返し設定 このグループでは、マルチ ボックスの項目セルで複数行に値を表示する設定ができます。これは、長いテキスト文字列などの表示に役立ちます。
セルを折り返して表示
このオプションを選択すると、セルの内容を複数行で表示します。
セルの高さ (行)
ここでは、セルの行数を指定できます。
レコード数 表示
選択された項目値のレコード数を表示するかどうかについてのステータスを切り替えます。レコード数は、選択可能な値の組合わせの数を意味します。
パーセント表示
レコード数を絶対数で表示するか、合計入力数に対するパーセンテージで表示するかについてのステータスを切り替えます。
詳細設定 このボタンは、[項目詳細設定] ダイアログを開きます。ここでは、項目値の画像表現の設定と特別なテキスト検索オプションを提供します。
1 列 このチェックボックスをオンにすると、マルチ ボックスの項目値は常に 1 列に表示されます。
水平スクロール バーを隠す このチェック ボックスをオンにすると、指定した幅が広すぎるときに通常表示されるマルチ ボックスの水平スクロール バーが非表示になります。代わりに、項目値は必要に応じて省略されます。
列でソート マルチ ボックスが 2 列以上のとき、値は行型に指定されたソート順で表示されます。列でソートは列型の表示に切替えます。
セルの枠線 項目値は、テーブルの行のように水平の線で区切られます。セルの枠線 は、セルを折り返して表示 チェックボックスをオンにすると自動的にオンになりますが、後で選択を解除できます。
除外値を隠す 項目の除外値を表示するかどうかを切り替えます。除外値は選択もできなくなります。
読み取り専用 このチェックボックスをオンにすると、マルチ ボックスのこの項目での選択が無効にされ、表示する機能のみとなります。
NULL を無視する NULL 値は、指定した項目の絞込値として表示されません。
注: このオプションを正しく使用しない場合は、相関関係のないデータがマルチ ボックスに表示されることがあります。
ロック項目の上書き このチェック ボックスをオンにすると、項目がロックされている場合でも、マルチ ボックスのその項目で選択を行うことができます。選択がドキュメントの他の場所で行われると、リスト ボックスはロック状態のままとなります。
グリッドのスタイル このチェックボックスはマルチ ボックスのレイアウトを変更し、ラベルがそれに対応する項目の上にそれぞれ配置されます。
読み取り専用 このチェックボックスをオンにすると、このマルチ ボックスでの選択が無効にされ、表示する機能のみとなります。
リストを閉じているときの色 閉じたマルチ ボックスのデータ列セルの色を設定します。色は、ボタンをクリックすると表示される [色の設定] ダイアログで、単色またはグラデーションとして定義できます。
ドロップダウン リスト表示行数 n マルチ ボックスに表示されるドロップダウン リスト ボックスの長さを制限できます。編集ボックスに表示する値の最大数を入力します。
スタイル VBScript および JScript から選択できます。
背景 [背景の設定] ダイアログを開きます。

項目詳細設定

項目詳細設定 ダイアログは、マルチ ボックス プロパティ: プレゼンテーションテーブル ボックス プロパティ: プレゼンテーション、および チャート プロパティ: 軸 からアクセスできます。以下に説明する画像オプションはビットマップ チャートでは使用できません。

画像オプション

意味 次のオプションがあります。
テキスト
このオプションを選択すると、数式値は常にテキストとして解釈および表示されます。
画像
このオプションを選択すると、QlikView は各数式値を画像への参照として解釈しようとします。参照は、ディスク上の画像ファイルへのパス (たとえば、C:\Mypic.jpg) または qvw ドキュメント内の画像ファイルへのパス (たとえば、qmem://<Name>/<Peter>) になります。QlikView が数式値を有効な画像参照として解釈できない場合は、値自体が表示されます。
画像 Info
このオプションを選択すると、QlikView は、項目値にリンクした画像情報を info load/select を使用してスクリプトに表示します。項目値に対する有効な画像がない場合は、[画像がない場合にテキストを隠す] チェックボックスがオンでない限り、値自体が表示されます。ビットマップ チャートに、このオプションはありません。
画像形式 上記で [画像] オプションを選択した場合のみ使用できます。この設定は、画像をセルに合わせるための QlikView の書式設定方法を表します。次の 4 つの選択肢があります。
縮小/拡大なし
このオプションを選択した場合、画像は拡大縮小されずにそのままのサイズで表示されます。したがって、画像の一部が表示されない場合や、セルの一部が画像で覆われない場合があります。
塗りつぶし
このオプションを選択した場合、画像は、画像の縦横比の維持を考慮せずに、セル全体を覆うように拡大されます。
縦横比を固定する
このオプションを選択した場合、画像は、縦横比を維持したまま、セルをできるだけ広く覆うように拡大されます。したがって、通常は、画像の左右または上下に画像で覆われない領域ができます。
縦横比を固定して塗りつぶし
このオプションを選択した場合、画像は、縦横比を維持したまま、セル全体 (上下/左右とも) を覆うように拡大されます。したがって、通常は、どちらかの方向で画像が切り詰められます。
画像がない場合にテキストを隠す このオプションをオンにすると、画像参照としての解釈に何らかの理由で失敗した場合、QlikView は項目値テキストを表示しません。この場合、セルは空白のままです。
選択スタイルの上書き テキストの代わりに画像を表示する場合、項目値の論理状態を表示するためには、ドキュメントのデフォルトではなく別の選択スタイルを使用する必要があるかもしれません。選択スタイルの上書き のドロップダウン リストを使用して、コーナー タグ などの適切な選択スタイルを選択します。

検索オプション

このグループを使用すると、開かれているマルチ ボックスとテーブルのドロップダウン リストに適用できるテキスト検索の特定の操作を制御できます。

検索対象に除外値を含める テキスト検索に除外値を含めるかどうかを指定します。次の選択肢を使用できます。
<既定値を使用>
ユーザー プロパティ で指定されている既定値が適用されます。
はい
除外値をテキスト検索に常に含みます。
いいえ
連結値は通常通り含みますが、除外値をテキスト検索に含みません。
検索モードの設定 テキスト検索で使用するデフォルトの検索モードを指定します。モードは常に、検索文字列の一部として * や ~ を入力することによってその場で変更できます。次の選択肢を使用できます。
<既定値を使用>
ユーザー プロパティ で指定されている既定値が適用されます。
ワイルドカード検索
2 つのワイルドカードの間にカーソルが入った状態で表示されるため、ワイルドカード検索を容易に実行できます。
あいまい検索
あいまい検索を意味するチルダ (~) が最初に表示されます。
標準検索
最初に表示される検索文字列には特に何も追加されていません。ワイルドカードなしに通常の検索が行われます。

数値

マルチ ボックス プロパティ: 数値 タブは、マルチ ボックスを右クリックし、フロート メニューから プロパティ を選択して開きます。

このプロパティ ページは、マルチ ボックスのすべての項目の書式設定を提供します。数値書式は、[項目] リストからひとつ選択する、または複数選択することにより (Shift もしくは Ctrl キーを押しなたままクリック) 個々に設定できます。

各項目には既定の数値書式があります。数値書式は ドキュメント プロパティ: 数値 ページから設定できます。 ただし、シート オブジェクトごとに別の数値書式を使用することもできます。このためには、この ドキュメント初期設定を上書きする チェック ボックスをオンにし、下のグループ コントロールで数値書式を指定します。このページは、アクティブなオブジェクトに適用されます。また、項目値を設定する次のコントロールが含まれます。

混合 数値とテキストの両方。数値は元の書式で表示されます。
数値 有効桁数 ボックスで設定した桁数で数値を表示します。
整数 数値を整数で表示します。
実数 小数点以下の桁数 ボックスで設定した桁数の小数点値で数値を表示します。
通貨 書式パターン 編集ボックスに設定された書式で値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。デフォルトの書式は Windows の通貨設定です。
日付 書式パターン 編集ボックスに設定される書式で日付として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
時刻 書式パターン 編集ボックスに設定される書式で時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
日付と時刻 書式パターン 編集ボックスに設定される書式で日付 + 時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
時間間隔 シーケンシャルな時間増分で時間を表示します (例:書式 = mm では、値をカレンダーが始まってからの分の数で表示します (1899:12:30:24:00)。

パーセント表示 (%) ボタンは次の書式で機能します:数値整数実数

小数点桁区切り 区切り記号は、 区切り記号 グループの編集ボックスで設定できます。

ISO ボタンは、日付、時刻、タイムスタンプの書式に標準 ISO を使用します。

システム ボタンは、書式設定にシステム設定を適用します。

ドキュメント初期設定の変更 ボタンで、ドキュメント プロパティ: 数値ページ にアクセスできます。このページではあらゆる項目の既定の数値形式を編集できます。

参照項目:

 
  • フォントスタイルサイズ
  • オブジェクト プロパティ:フォントドキュメント プロパティ:フォントオブジェクトに適用する
  • ドキュメント プロパティ:フォント
  • ユーザー プロパティ:フォント
  • [固定][計算]
  • 参照項目: カラー関数

  • 枠線の使用
  • ドキュメント プロパティ: 基本設定スタイルのモード簡易設定影の強度枠線
  • 角を丸くする
  • 角を丸くする角を丸くするドキュメント プロパティ: 基本設定スタイルのモード詳細設定
  • レイヤー
  • レイヤー
  • テーマの作成
  • テーマ作成
  • テーマの適用
  • 参照項目: レイアウト テーマ
  • 表示
  • 表示
  • オプション
  • オプションドキュメント プロパティ: レイアウトシート プロパティ: セキュリティ
  • スクロール バー
  • スクロール バー
  • [オブジェクト プロパティ]
    [ドキュメント プロパティ]
  • キャプション
  • アクティブ時の色非アクティブ時の色
  • [背景色][テキストの色][色の設定]背景色色の設定単色グラデーションテキストの色固定計算
  • 参照項目: カラー関数
  • 標準最小化
  • [キャプションの配置]
  • キャプション アイコン

フォント

  1. 最初のデフォルト フォント (リスト ボックス、チャートなど) は、リスト ボックスやチャートなどのほとんどのオブジェクトで使用されます。
  2. 次のデフォルト フォント (テキスト オブジェクトとボタン) は、一般的に大きなフォントを必要とするボタンやテキスト ボックスに使用されます。
ドロップシャドウ このチェック ボックスをオンにすると、テキストにドロップ シャドウが追加されます。
下線 このチェック ボックスをオンにすると、テキストに下線が引かれます。

レイアウト

影の強度 影の強度ドロップダウン メニューで、シート オブジェクトの周りの影の強度を設定できます。影なしの選択肢もあります。
枠線のスタイル 既定の枠線は次のとおりです。
固定
単色の固定の枠線。
くぼみ
シート オブジェクトが背景からくぼんでいるように見える枠線。
浮き彫り
シート オブジェクトが背景から浮き上がっているように見える枠線。

シート オブジェクトの周囲に壁があるように見える枠線。
枠線の幅 このオプションは、すべての種類の枠線で有効です。幅は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
このボタンをクリックするとダイアログが開き、すべての種類の枠線に適用される基本色をカラー パレットから選択できます。
カラフル すべての種類の枠線を虹色の枠線にします。虹は、シート オブジェクトの上部で選択した基本色で始まります。
角を丸くする このチェックボックスをオンにすると、角の形を丸くするオプションを設定できるようになります。
角の位置 チェック ボックスをオフにした角は直角に描画されます。
鋭度 2 から 100 の間の数値を設定でき、数値 100 を定義すると直角、数値 2 は完全な楕円 (縦横比が 1:1 の場合は円) に相当します。丸い角には、鋭度 2 から 5 が通常最適な数値です。
角の丸み この設定は、固定の距離 (固定)または四分円全体に対するパーセンテージ (相対値(%)) で、角の半径を決定します。この設定により、鋭度で設定した基になる基本図形が角に影響を与える程度を制御できます。距離は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
背面 背面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと前面レイヤーにあるシート オブジェクトを覆うことはできません。背面レイヤーにある他のシート オブジェクトの上にのみ配置できます。
標準 シート オブジェクトは、作成されると、標準位置 (中央) のレイヤーに置かれます。標準位置レイヤーにあるシート オブジェクトは、背面レイヤーのシート オブジェクトで覆われることはありませんし、前面レイヤーのシート オブジェクトを覆うこともできません。
Top 前面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと背面レイヤーにあるシート オブジェクトによって覆われることはありません。その上に配置できるのは、前面レイヤーにある他のシート オブジェクトだけです。
カスタム 前面標準位置、および背面レイヤーは、内部的に番号が振られたレイヤー 1、0、-1 にそれぞれ対応しています。実際には、-128 ~ 127 の間のすべての値が使用できます。選択した値を入力する場合は、このオプションを選択します。
常に表示 シート オブジェクトは常に表示されます。
条件付き表示

シート オブジェクトは、選択などで継続的に評価される条件付き関数に基づいて表示/非表示にされます。シート オブジェクトは、その条件が TRUE を返す場合にのみ表示されます。

参照項目: 条件分岐関数

注:

ドキュメントの管理権限を持つユーザーは、ドキュメント プロパティ: セキュリティすべてのシートとシート オブジェクトを表示 を選択すると、すべての表示条件を無視してこの設定を適用できます。 CTRL+SHIFT+S を押して、この機能を切り替えることができます。

参照項目: ドキュメント プロパティ:セキュリティ

移動/サイズ変更を許可する このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
コピー/複製を許可する このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。
INFO を許可する

info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。

参照項目: Info

データにサイズを合わす 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。
スクロール バーの位置を保持する

この設定が有効の場合、QlikView は、他のオブジェクトで選択が行われたときに、スクロール バーが設定されているテーブルやチャートのスクロールの位置を保持しようとします。この設定は ユーザー プロパティ: オブジェクト でも有効にする必要があります。

ドキュメントを閉じると、スクロールの位置は保持されません。

スクロール ボタン スクロール ボタンの色を設定します。ボタンをクリックして色を選択します。スクロール バーは、薄い灰色で描画するとよい結果が得られます。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。
スクロールの背景

スクロール バーの背景色を設定します。ボタンをクリックして色を選択します。

スクロール バーの幅 このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。
スクロールのスタイル

スクロール バーのスタイルを設定します。ドロップダウン コントロールでスタイルを選択します。クラシック スクロール バー スタイルは、QlikView の 4/5 スクロール バーに対応します。標準スクロール バー スタイルは、最新の外観になります。3 つ目のスタイル、ライトは細く、ライトなスクロールバーです。

スクロール バー スタイルを表示するには、[スタイルのモード] を [詳細設定] に設定する必要があります。この設定は、[基本設定] タブで [設定] ドロップダウン メニューを開き、[ドキュメント プロパティ] を選択すると見つかります。

適用するオブジェクト キャプションと枠線のプロパティ ダイアログを開きます。ここでは、レイアウト ページで設定されたプロパティを適用する場所を設定できます。

キャプション

キャプションの表示 このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
タイトル テキスト テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。キャプションのフォントを変更するには フォント ボタンを使用します。
折り返し このオプションを選択した場合、キャプションは、 2 行以上で表示されます。
キャプションの高さ (行) 編集ボックスで、キャプションの行数を設定します。
X- 位置 シートの左端に対するシート オブジェクトの左辺の水平方向の位置を設定します。
Y- 位置 シートの上端に対するシート オブジェクトの上辺の垂直方向の位置を設定します。
QlikView シート オブジェクトの幅を設定します。
高さ QlikView シート オブジェクトの高さを設定します。
水平 キャプションのラベルは水平方向に整列できます:左揃え中央揃え、または 右揃え
垂直 キャプションのラベルは垂直方向に整列できます: [上揃え][上下中央揃え]、または [下揃え]
注: キャプション アイコンは注意して使用してください。アイコンが多すぎると邪魔になる可能性があります。
最小化を許可する このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。
自動最小化 このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。
最大化を許可する このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する][最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。
ヘルプ テキスト

ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。ヘルプ テキストは、計算式として指定できます。このオプションはドキュメント レベルでは使用できません。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

参照項目: 計算式の数式構文

シート オブジェクトの説明などを入力します。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。