QlikWorld 2020 Global Conference. Join us to discover how to get the most from your data. Act fast. Register now and save.

インライン データ ウィザード

インライン データ ウィザード ダイアログは、挿入 メニューの Load ステートメント > インライン ロード から開きます。これを使用して、スクリプトに load inlineステートメントを作成します。

ダイアログにはスプレッドシートに似たものが含まれており、多くの点でスプレッドシートと同じように機能します。ただし、このスプレッドシートでの計算式は、Microsoft Excelなどでの計算式のようには評価されないため注意してください。

インライン テーブルで、各列はQlikViewにロードされる項目を表します。各行はテーブルのレコードです。データ セルを選択するには、それをクリックします。値を入力、もしくはクリップボードからコピします。Enter キーまたは矢印キーを押すと値が確定し、別のセルに移動します。

最上行 (ラベル) は、項目ラベル用です。ラベル用のセルをダブルクリックし、編集します。ラベル行に値を入力しない場合、項目名は F1、 F2 などが使用されます。

[編集] メニュー

編集 メニューには基本の編集コマンドがあります。

列の挿入 1 つまたは複数の列が選択されている場合、新しい空白の列を挿入します。
列の削除 選択されている列を削除します。
行の挿入 1 つまたは複数の行が選択されている場合、新しい空白の行を挿入します。
行の削除 選択されている行を削除します。

[ツール] メニュー

ツール メニューには、 ドキュメントのデータ が含まれます。ここから ドキュメント データ インポート ウィザード を開き、ドキュメントに存在項目から項目値を貼り付けることができます。ダイアログでは、選択した項目に項目値がいくつ存在するかを確認できます。また、すべての値、選択値、または除外値をインライン ウィザードに挿入するように選択することもできます。

OK ボタンをクリックするとダイアログが閉じ、ダイアログのテーブル グリッドの内容を反映した Load inline ステートメントが生成されます。