グリッド チャート

チャートは、数値データをグラフィカルに表現したものです。[チャート プロパティ: 基本設定] ページの [チャートの種類] を変更することで、既存のチャートの種類を切り替えることができます。

グリッド チャートは散布図に似ていますが、軸に軸の値をプロットし、プロット マーカーを決定する数式を使用します。特別なモードでは、第 3 軸をプロット マーカーとして小さい円グラフ形式で表示できます。

ツールバーの [チャートの作成]ボタンをクリックすると、新しい散布図を簡単に作成することができます。

グリッド チャートを右クリックすると、[グリッド チャート: オブジェクト メニュー] が表示されます。 グリッド チャートがアクティブなオブジェクトの場合、オブジェクト メニューからもアクセスできます。

[オブジェクト] メニュー

チャートを右クリックするとフロート メニューが表示されます。このメニューは、チャートがアクティブな場合に、オブジェクト メニューでも表示されます。

メニューには以下のコマンドがあります。

プロパティ プロパティ ダイアログを開きます。ここから、チャートを定義する要素を設定できます。
ノート

現在のオブジェクトに関するノートの作成および共有ができます。

参照項目: ノートとコメント

分離設定 チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。
分離解除 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。
参照設定 このオプションを選択して、チャートの参照 (現在の選択を使用したチャートの固定プロット) を設定します。ドキュメントでさらに選択を行っても、参照プロットは残り、背景に淡色表示されます。チャートの軸等は、常に背景のデータ セットと現在のデータ セットの最大値に調整されます。現在のデータ セットは、常に参照プロットの前面にプロットされます。つまり、参照プロットの一部は、現在のデータ セットのプロットによって隠される場合があります。背景を淡色表示する方法は、チャート プロパティ:基本設定 ページにある 参照機能のスタイル 設定で制御できます。参照チャート プロットの表示は、一部のチャートの種類 (棒グラフ、折れ線グラフ、コンボ チャート、レーダー チャート、散布図、グリッド チャート、および針を使用するゲージ チャートなど) でのみ可能です。ドリルダウンやサイクリック グループを含むチャートでは [参照設定] は利用できません。ドキュメントを閉じるか、データをリロードすると、参照は失われます。[参照設定] オプションの使用時に含めることができるオブジェクトの最大数は 500 です。
参照解除 参照が設定されると、参照設定 コマンドがこのコマンドに置き換えられます。これを選択すると、以前に設定した参照がクリアされ、チャートが通常のプロット モードに戻ります。
複製 チャートの全く同じコピーを作成します。分離設定されたチャートの複製を作成すると、その複製の分離設定は解除されます。
順序

このカスケード メニューは [表示] メニューの [デザイン グリッド] コマンドが有効なときと、[ユーザー プロパティ:デザイン][デザイン メニュー項目を常に表示] チェックボックスがオンになっているときのみ使用できます。シート オブジェクトのレイアウト レイヤーを設定するためのコマンドが 4 つ含まれています。有効なレイヤー番号は -128 から 127 です。

最前面へ移動
シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最大値に設定します。

最背面へ移動
シート オブジェクトのレイアウト レイヤーを、現在のシートの任意のシート オブジェクトで使用されている値の最小値に設定します。

前面へ移動
シート オブジェクトのレイアウト レイヤーを 1 つ増やします。最大値は 127 です。

背面へ移動
シート オブジェクトのレイアウト レイヤーを 1 つ減らします。最小値は -128 です。


すべての選択をクリア チャートの軸と数式での選択をすべてクリアします。
印刷 プリンタ設定を指定できる [印刷] ダイアログを開きます。
PDF として印刷

PDF-XChange 3.0 プリンタがあらかじめ選択されている状態で印刷ダイアログを開きます。印刷 ボタンをクリックすると、PDF 出力ファイルのファイル名を指定するように要求されます。このコマンドは、PDF プリンタがシステムで使用可能な場合のみ使用できます。

Excel 出力 基底のデータ (チャートに相当するストレート テーブル) を Microsoft Excel にエクスポートします。Microsoft Excel が実行されていない場合は、自動的に起動されます。テーブルは、新しい Excel ワークシートに表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。
エクスポート チャートのイメージをファイルに保存するためのダイアログを開きます。イメージは、bmp、jpg、gif、または png 形式で保存できます。
クリップボードにコピー このカスケード メニューには、シート オブジェクトのためのさまざまなコピー オプションが含まれています。

値をテーブル形式でクリップボードにコピーします。
画像
チャート オブジェクトの画像をクリップボードにコピーします。画像にシート オブジェクトのキャプションおよび枠線が含まれるか除外されるかは、[ユーザー プロパティ: エクスポート] ページの設定により異なります。
オブジェクト
シート オブジェクト全体をクリップボードにコピーし、レイアウトの別の場所や、QlikView の現在のインスタンス内で開いている他のドキュメントの別の場所に貼り付けることができます。
リンク オブジェクト

リンク オブジェクト用の次のコマンド メニューを開きます。
リンク オブジェクトを整列する
すべてのシート上にある他のリンク オブジェクトはすべて、選択されたオブジェクトと同じ位置、同じ大きさに整列されます。
オブジェクトのリンクを解除する
オブジェクト間のリンクを外し、異なるオブジェクトとしてそれぞれに異なるオブジェクト ID を付与します。

最小化 オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。
最大化 オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。
元のサイズに戻す 最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。
ヘルプ QlikView ヘルプを開きます。
削除 シート オブジェクトをシートから削除します。

チャート プロパティ:軸

[チャート プロパティ:軸] ページは、チャートを右クリックして [プロパティ] を選択するか、チャートがアクティブな場合は [オブジェクト] メニューから [プロパティ] を選択して開きます。

チャートを作成する場合は、まず次の 2 つの事項を確認します。

  • 表示する対象は? 棒グラフの棒のサイズに対応する対象は? 答えは、sum of sales (売り上げの合計) やそれと同類のものです。これは、数式 ページで設定します。
  • チャートをグループ化する基準は? 棒グラフの棒のラベルとして使用する項目値は? 答えは、country (国) 別やそれと同類のものです。これは、 ページで設定します。

1 つのチャートは、1 つ以上の軸を表示することができます。上限は、チャート タイプ、データの複雑さ、およびメモリ使用量によって異なります。円グラフ、折れ線グラフ、および散布図は、最大 2 つ、棒グラフ、ブロック、およびグリッド チャートは 3 つの軸を表示できます。レーダー チャートとファネル チャートは軸を 1 つだけ表示でき、ゲージ チャートは軸を表示できません。それ以上の軸は無視されます。

チャート軸は、チャート プロパティ:軸ページに指定された項目からその値を取得します。1 つの軸は、1 つの項目ではなく項目のグループで構成されることもあります (下の「グループ」を参照)。

項目、グループ、数式 (計算軸) を軸にできます。作成した合成軸も使用できます。

参照項目: 合成軸関数

[追加>][<削除] ボタンを使用して、(クリックや CTRL+ クリックで) 選択した項目を移動するか、ダブルクリックして移動します。

チャート軸は数式から計算することもできます。

このプロパティ ページは、軸の定義に使用されます。

項目/グループ

軸として使用できる項目と項目グループのリスト (標準的な棒グラフの x- 軸など)。項目グループは、[ドリルダウン グループ] には垂直矢印が、[サイクリック グループ] にはカーブした矢印が前に表示されます。グループは、ドキュメント プロパティ:[グループ] ページで定義されます。 使用/削除する項目をクリックして選択します。[追加 >] ボタンまたは [< 削除] ボタンを使用して、目的の列に移動します。
使用できる軸の数は、チャートの種類によって異なります。
複数の内部テーブルに存在する項目にはすべて、キー シンボルが付けられます。円グラフ、折れ線グラフ、および散布図は、3 つ以上の軸を表示できません。棒グラフでは、最大 3 つの軸を表示できます。

参照項目: ドキュメント プロパティ:グループ

システム項目の表示 このオプションをオンにすると、システム フィールドが [利用可能な項目/グループ] に表示されます。
テーブルの項目を表示 ここで、 [項目/グループ] リストにどの項目とグループを表示するかを制御します。ドロップダウン リストは、デフォルトで すべてのテーブル を表示します。
すべてのテーブル (テーブル名表示) は、項目をテーブル名とともに表示します。このため、キー項目は、1 度以上リスト表示されます。(これは表示目的にのみ使用できます。ロード スクリプトのQualifyとは関係ありません。)
一度に 1 つのテーブルの項目を見ることもできます。利用できるグループは常にリストされます。
グループの編集 このボタンを押すと直接 [ドキュメント プロパティ:グループ] ページに移動し、軸として使用できる項目グループを定義できます。
アニメーション [アニメーション] ダイアログを開きます。ここでは、チャートの第 1 軸をアニメーションに使用できます。アニメーションは、円グラフ以外のビットマップ チャートでのみ使用できます。アニメーションを使用する場合は、一部の機能が制限されます。
トレリス [トレリス設定] ダイアログを開きます。ここでは、第 1 軸を基準としたチャートの配列表示を設定できます。どの種類のビットマップ チャートもトレリス表示にできます。
軸項目

このリストには、チャートで軸として使用するために現在選択されている項目が含まれます。使用できる軸の数は、チャートの種類によって異なります。指定した種類に不要な軸は無視されます。軸データ セルは、テーブルで使用する場合は、属性式で動的に書式設定できます。軸に属性式を入力すると、アイコンの色が灰色からカラーに変わり、テキスト書式 の場合は灰色から黒に変わります。これらの設定は、チャートの設定に優先します。プレースホルダまたは軸の属性式を表示するには、軸の前にある「+」展開アイコンをクリックします。
背景色
属性式を入力して、軸項目のセルの背景色を計算するには、[背景色] をダブルクリックします。使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。これには、特別な色関数のいずれかを使用します。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。
テキストの色
属性式を入力して、軸項目のセルのテキスト色を計算するには、[テキストの色] をダブルクリックします。使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。これには、特別な色関数のいずれかを使用します。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。

参照項目: カラー関数

テキスト書式
属性式を入力して、各軸項目のテーブル セル内のテキストのフォント スタイルを計算するには、[テキスト書式] をダブルクリックします。テキスト書式の数式として使用される数式は、太字を表す '<B>'、斜体を表す '<I>'、下線付きテキストを表す '<U>' を含む文字列を返します。

[上へ][下へ] ボタンで、 [軸項目] リストの軸をソートできます。

計算軸の追加

新しい軸を追加し、[数式の編集] ダイアログで編集用に開きます。チャート軸は 1 つの項目であることが多いですが、動的に計算することもできます。計算軸は、1 つまたは複数の項目を含む数式で構成されています。標準的な関数はすべて使用できます。集計関数は使用できませんが、ネストされた集計を行うために Aggr - チャート関数関数を含めることができます。

参照項目: 計算式の数式構文

編集 [数式の編集] ダイアログで編集するために軸を開きます。計算軸の詳細については、上の [計算軸の追加] を参照してください。
選択軸項目の設定

このグループには、個々の軸の設定が表示されます。
有効条件
このチェック ボックスを使って軸を動的に表示/非表示にするには、入力した条件式の値に応じて下の編集ボックスの ... ボタンをクリックします。

NULL値を隠す
このチェック ボックスをオンにすると、上の 軸項目 で選択した軸項目の値が NULL の場合、チャートにその項目は表示されません。
すべての値を表示
選択条件に関係なくすべての軸項目値を表示するには、このチェック ボックスをオンにします。数式の値は 0 の場合に除外される軸値となるため、すべての値を表示 を機能させるには プレゼンテーション ページの 0 値を隠す オプションをオフにする必要があります。軸として数式を使用する場合、[すべての値を表示] は適用されません。
凡例の表示
[凡例の表示] チェックボックスをオンにすると、項目値の「名前」が x-軸の隣に表示されます。
ラベル
ラベル チェックボックスをオンにすると、項目の名前が表示されます。ラベルは、下のテキスト ボックスで編集できます。ラベルは、ラベルのテキストの動的に更新される計算ラベル数式として定義することもできます。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

参照項目: 計算式の数式構文

詳細設定...
このボタンは、[項目詳細設定] ダイアログを開きます。ここでは、項目値の画像表現の設定と特別なテキスト検索オプションを提供します。

参照項目: 項目詳細設定

コメント
コメント フィールドでは、選択した軸についての説明を入力できます。コメントは、計算式として入力できます。[...] ボタンをクリックすると、数式の編集ダイアログが開きます。
改ページ
この設定は、ピボット テーブルやストレート テーブルからの印刷時の改ページの使用にのみ適用します。3 つのモードが以下の効果で利用できます。

改ページなし
必要な場合にのみ、各ページの終わりに改ページを挿入します。
条件付き改ページ
軸の次の値を持つすべての行が現在のページにすべて印刷できる場合以外、改ページを挿入します。
軸の値による改ページ
軸の値が変更する度に改ページを挿入します。

チャート プロパティ: 軸の制限

軸の制限はゲージ チャートとピボット テーブルを除くあらゆる種類のチャートで設定できます。

[軸の制限] タブではチャートに表示される軸の値の数を管理します。

まずはじめに、これら 3 つのオプションがドロップダウンの作成時にどのように機能するかについて説明します。ドロップダウンには [最初][最大][最小] の 3 つの値があります。計算エンジンはこれらの値に基づいてソートを実行し、チャート エンジンに値を返します。軸の制限を設定する場合、これらのオプションのいずれかを選択する必要があります。ソートは、最優先されるソートが第 1 軸のソートを上書きする可能性がある場合、ピボットテーブルを除いて最初の数式においてのみ実行されます。

このプロパティ ページは、軸の制限の定義に使用されます。チャートの軸は個別に設定されます。

制限

最初の数式を使った表示値の制限
これらのプロパティは、下で行った設定に応じて、チャートに表示される軸値の数を決定するために使用します。

表示のみ
このオプションは、[最初] あるいは [最大][最小] の値をいくつ (x 個) 表示させたいかによって選択します。このオプションを 5 に設定すると、5 つの値が表示されます。軸の [「その他」の表示] が有効になっている場合、[その他] セグメントには 5 つの値のいずれかひとつが表示されます。

[最初] オプションは、プロパティ ダイアログの [ソート] タブで選択したオプションに基づき、行を返します。チャートがストレート テーブルの場合は、列はその時の第 1 ソート順に基づいて返されます。つまり、列見出しをダブルクリックしてその列を第 1 軸ソートにすると、値の表示を変更できます。

[最大] オプションは、チャートの最初の数式に基づいて降順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

[最小] オプションは、チャートの最初の数式に基づいて昇順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

表示する値の数を入力します。 値は、計算式として入力できます。[...] ボタンをクリックすると、[数式の編集] ダイアログが開かれます。

次の値のみ表示
このオプションを選択すると、このオプションで指定した条件に合うすべての軸の値を表示します。合計値のパーセンテージ、または正確な値に基づいて値を表示するのに使用します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にします。 値は、計算式として入力できます。[...] ボタンをクリックすると、[数式の編集] ダイアログが開かれます。

次に累積する値のみ表示
このオプションを選択すると、現在の行まですべての行を累積し、その値をオプションで設定した値と比較します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にし、累積値 (最初の値または最大値、最小値に基づく) と全体の合計値を比較します。 値は、計算式として入力できます。[...] ボタンをクリックすると、[数式の編集] ダイアログが開かれます。 [境界値を含める] を選択すると、比較値を含有する軸の値が含まれます。

参照項目: 計算式の数式構文

注: 累積制限の合計を計算する際、負の値は含まれません。負の値を含む可能性がある項目の相対制限は使用しないようお勧めします。
注: 計算軸に制限を加え、データが同じ計算軸でソートされる場合は、ソート順の適用前に軸の制限が適用されます。
オプション 「その他」の表示
このオプションを有効にすると、チャートに [その他] セグメントを作成できます。表示を制限する比較基準を満たさない軸の値は、すべて [その他] セグメントにまとめられます。選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。[...] ボタンをクリックすると、[数式の編集] ダイアログが開かれます。

「合計」の表示
このオプションを有効にすると、チャートには選択した軸の合計が表示されます。この合計値は [プロパティ] ダイアログの [数式] タブで設定されますが、数式の合計とは異なります。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。[...] ボタンをクリックすると、[数式の編集] ダイアログが開かれます。

グローバル グループ モード
このオプションは内部軸にのみ適用されます。このオプションを有効にすると、制限は選択した軸に基づいてのみ計算されます。前の軸はすべて無視されます。このオプションを無効にすると、制限は前のすべての軸に基づいて計算されます。

軸の合計値と数式の合計値

計算エンジンで計算された軸の合計値は、個別の行 (または軸項目値) としてチャート エンジンに返されます。これにより [その他] の行の値も変化します。数式の合計値を使用した場合と軸項目値の合計を使用した場合の相違点は以下のとおりです。

数式の合計値と軸の合計値

軸の合計値を使用すると、ストレート テーブルに小計を表示できます。

チャート プロパティ: 数式

チャート プロパティ:数式 ページは、チャートまたはテーブルを右クリックし、オブジェクト メニューの プロパティ を選択して開きます。

チャートを作成する場合は、次の 2 つの事項を確認します。

  • 棒グラフの棒の大きさを表すのは何か。これらは、数式 (売上高の合計 など) です。
  • データをどのようにグループ化するのか。これらは、 ( 別など)です。
注: [数式] タブはチャートやテーブルの種類によって異なります。特定のチャートやテーブルでオプションが利用できない場合、それらのオプションはグレー表示されています。
数式リスト

左上のパネルの式リストは、実際は完全なツリー コントロールで多数のコントロール オプションを含みます。
各数式 (または数式グループ) の前には展開アイコン (「+」の付いた箱) が表示されます。展開アイコンをクリックすると、下にある補助数式または属性式が開きます。アイコンは同時に折りたたみアイコン (「-」) に置き換えられます。特定のプロット オプションは、組み合わせてプロット マーカーを定義する 2 つ以上の数式のセットといったサブ数式を使用します (例:以下に説明する株価箱ひげ図)。
数式データは、属性式を使用して動的に書式も設定できます。軸の属性式のプレースホルダを表示するには、数式の前にある展開アイコンをクリックします。有効な属性式の種類を次に示します。

背景色
データ点のプロットの色を計算する属性式を作成するには、デフォルトの 背景色 数式を編集します。計算された色は、デフォルトの QlikView の色の選択に優先します。そして、有効な色表現でなければなりません。これは、カラー関数を使用して行います。数式の結果が有効な色表現でない場合は、プログラムはデフォルトで黒を使用します。テキストの色 の補助数式は同じ方法を使用して作成できます。

参照項目: カラー関数

テキストの色
テキストの色 の補助数式は、背景色と同じ方法を使用して作成できます (上記を参照してください)。

テキスト書式
データ点に関連付けられたテキストのフォント スタイルを計算するには、属性式を入力してテキスト書式数式を編集します (テーブル: 各軸項目のテーブル セル内のテキスト)。計算されたテキスト書式は、チャート プロパティ:スタイルで定義されたテーブル スタイルに優先します。テキスト書式の数式として使用される数式は、太字を表す '<B>'、斜体を表す '<I>'、下線付きテキストを表す '<U>' を含む文字列を返します。文字列の前に = が必要ですので注意してください。

分割円
属性式を入力して、データ点に関連付けられたスライスを、抽出された "分割" 位置に描画するかどうかを計算するには、分割円 をクリックします。この種類の属性式は、円グラフにのみ有効です。

補正
属性式を入力して、データ ポイントに関連付けられた棒または棒のセグメントの間隔を適切に計算するには、補正 をクリックします。補正は正にも負にも設定でき、棒やセグメントに応じて動かされます。これは、ウォーターフォール グラフと呼ばれるチャートの作成時に便利です。この種類の属性式は、棒グラフにのみ有効です。

線のスタイル
属性式を入力して、データ点に関連付けられた線または線分の線のスタイルを計算するには、線のスタイル をクリックします。この種類の属性式は、折れ線グラフ、コンボ チャート、およびレーダー チャートにのみ有効です。線の相対的な幅は、<Wn> タグを含めることで制御できます。ここで、n はチャートのデフォルトの線の幅に適用される倍率です。数値 n は、0.5 ~ 8 の実数でなければなりません。例:<W2.5>。線のスタイルは、<Sn> タグを含めることで制御できます。ここで、n は、使用するスタイルを示す 1 ~ 4 の整数 (1 = 実線、2 = 破線、3 = 点線、4 = 破線/点線) です。例:<S3>。<Wn> および <Sn> タグは自由に組み合わせることができますが、それぞれ最初に出現するもののみが有効と見なされます。タグは単一引用符で囲む必要があります。

値の表示
メイン数式で データ点の値 をオンにしていなくても、属性式を入力して、データ点のプロットを "データ点の値" の値で補足するかどうかを計算するには、値の表示 をクリックします。メイン数式で データ点の値 をオンにした場合、属性式は無視されます。この種類の属性式は、棒グラフ、折れ線グラフ、円グラフ、ファネル チャート、およびコンボ チャートにのみ有効です。

追加 新しい数式と補助数式は、[追加] ボタンで作成します。このオプションは、数式のリスト内で右クリックしたときに表示されるコンテキスト メニューでも有効です。
削除 削除ボタンで、リストから前に作成した数式を削除できます。このオプションは、数式のリスト内で数式を右クリックしたときに表示されるコンテキスト メニューでも有効です。
コピー コピー オプションは、数式のリスト内で数式またはサブ/属性式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式でこのコマンドを使用すると、その数式に関連付けられたすべてのデータと設定 (ラベルを含む) が xml としてクリップボードにコピーされます。その後、この数式を同じチャートや、同じドキュメントまたは別のドキュメントのその他の QlikView チャートに貼り付け直すことができます。このコマンドを属性式で使用する場合は、属性式定義だけがコピーされます。属性式はその後、同じチャートまたは別のチャートの任意のメイン数式に貼り付けることができます。
エクスポート エクスポート オプションは、数式のリスト内で数式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式でこのコマンドを使用すると、その数式に関連付けられたすべてのデータと設定 (ラベルを含む) が xml ファイルにエクスポートされます。その後、この数式を同じチャートや、同じドキュメントまたは別のドキュメントのその他の QlikView チャートにインポートし直すことができます。このコマンドにより、数式をエクスポート ダイアログが開きます。ここでは、エクスポート ファイルの保存先を選択できます。ファイルには、拡張子 Ex.xml が付きます。
貼り付け 貼り付け オプションは、数式のリスト内で数式またはサブ/属性式を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。メイン式がクリップボードにコピーされている場合は、数式のリスト内の空白領域にそれを貼り付けて、コピー元と同一の新しい数式を作成できます。属性式がコピーされている場合は、メイン数式にそれを貼り付けることができます。
インポート インポート オプションは、数式のリスト内で空白領域を右クリックしたときに表示されるコンテキスト メニューでのみ有効です。このコマンドにより、以前にエクスポートした数式を参照できるダイアログが開きます。インポートされた数式は、新しい数式としてチャートに表示されます。
上へ
下へ
複数の数式が表示される場合、 上へ下へ ボタンを使用して順番を変更できます。これは、チャートに表示される列などの順番に影響します。
グループ グループ ボタンは、有効な数式が 2 つ以上ある場合に、数式を併せてサイクル グループにするのに使用できます。QlikView のレイアウトでは、チャートに表示されるサイクル アイコンをクリックすると、グループに属する数式を切り替えることができます。 (サイクル グループ)。サイクル アイコンを右クリックすると、そのグループに属する有効な数式を直接選択できるポップアップ リストが表示されます。
注:

[サイクル グループ] と [サイクリック グループ] は同じではありません!

参照項目: 非階層グループ (サイクリック)

グループ解除 グループに属する数式を選択し、 グループ解除 ボタンをクリックすると、数式をグループから解除できます。解除後のサイクル グループに数式が 1 つしか残らない場合、その数式も解除されて、サイクル グループは存在しなくなります。
有効化 このチェック ボックスをオフにすると、チャートからその数式が省略されるよう設定されます。
相対値表示 このチェック ボックスをオンにすると、絶対数ではなくパーセントで結果を表示するようにチャートを設定します。このオプションは、ピボット テーブルでは使用できません。
表示しない このチェックボックスをオンにすると、この数式に割り当てられたスペースを残しつつ非表示にします。
条件付き表示 このチェックボックスを有効にすると、現在の選択に基づいて条件を定義できます。これによって、数式を表示するかどうかが決まります。条件の評価が TRUE の場合、数式は表示されます。条件の評価が FALSE の場合、数式は表示されません。
ラベル 数式のラベルの前のアイコンは、使用する チャートの種類 および 数式に設定された表示オプションを示すために使用されます (以下を参照してください)。
定義 選択された数式の構成内容を表示します。このボックスで数式を直接編集できます。[...] ボタンをクリックすると、完全な 数式の編集 ダイアログが開きます。
コメント この項目は、数式の作成者が数式の機能や目的を説明できるコメント項目です。
表示オプション このグループは、データ点の表示方法やチャート テーブルの数式セルに何を表示するかを修正するために使用されます。一部のオプションは、特定のチャートの種類でのみ有効ですのでご注意ください。また、組み合わせることができないオプションや、複雑なプロットを作成するために 1 つ以上の数式を追加して使用するオプションなどもあります。


選択された数式の値を棒で表示します。このオプションは、棒グラフおよびコンボ チャートでのみ有効です。

マーカー
選択された数式の値をマーカーで表示します。このオプションは、線グラフおよびコンボ チャートでのみ有効です。ドロップダウン メニューにあるいくつかの異なるマーカーから選択します。


選択された数式の値を線で表示します。このオプションは、線グラフおよびコンボ チャートでのみ有効です。ドロップダウン メニューの [標準][なめらか]、または 3 種の [水平] から選択します。

株価
数式を株価マーカーとしてプロットするには、このチェック ボックスをオンにします。[数式] リスト内の数式は、前にアイコンが置かれ、4 つのサブ数式を含む空のプレースホルダとして表示されます。最初のサブ数式は、株価マーカーの高値ポイントをプロットするために使用されます。2 つ目のサブ数式は、安値ポイントをプロットするために使用されます。株価マーカーが描画されるには、この 2 つのサブ数式に有効な定義が含まれている必要があります。3 つ目のサブ数式はオプションですが、使用する場合は株価マーカーの終値ポイントのために使用されます。4 つ目のサブ数式もオプションですが、使用する場合は株価マーカーの始値ポイントのために使用されます。数式で 株価 チェック ボックスをオンにすると、新しい空のサブ数式が自動的に作成されます。数式で 株価 チェック ボックスをオンにしている場合は、同じ数式で マーカー箱ひげ図、または エラー バー チェック ボックスをオンにできません。数式でそれらのオプションのいずれかが既にオンになっている場合は、その数式で 株価 チェック ボックスをオンにできません。このオプションは、コンボ チャートでのみ有効です。

箱ひげ図
数式を箱ひげ図 (統計データの表示に使用されることが多い) としてプロットするには、このチェック ボックスをオンにします。数式リスト内の数式は、前にアイコンが置かれ、5 つのサブ数式を含む空のプレースホルダとして表示されます。最初のサブ数式は、箱ひげ図の「箱 (上)」ポイントをプロットするために使用されます。2 つ目のサブ数式は、「箱 (下)」ポイントをプロットするために使用されます。箱ひげ図が描画されるには、この 2 つの数式に有効な定義が含まれている必要があります。3 ~ 5 つ目のサブ数式は、オプションです。これらの数式は、それぞれ「箱 (中)」、「上ひげ」および「下ひげ」を定義します。箱ひげ図 の拡張部分は、いわゆる極値のアウトライナーです。これらは、個別の数式をマーカーとしてプロットすることで実現できます。メイン数式で 箱ひげ図 をオンにすると、新しい空のサブ数式が自動的に作成されます。数式で 箱ひげ図 チェック ボックスをオンにしている場合は、同じ数式で マーカー株価、または エラー バー チェック ボックスをオンにできません。数式でそれらのオプションのいずれかが既にオンになっている場合は、その数式で 箱ひげ図 をオンにできません。このオプションは、コンボ チャートでのみ有効です。

エラー バー
メイン式のデータ点の上にプロットされるエラー バーのために補助数式として選択した数式に続いて、1 つまたは 2 つの数式を使用するには、このチェック ボックスをオンにします。両方向を選択する場合は、補助数式が 1 つだけ使用され、データ点の周囲に対称にプロットされます。非対称を選択する場合は、補助数式が 2 つ使用され、それぞれデータ点の上側と下側にプロットされます。エラー バー数式は、正の数を返します。エラー バーに使用される補助数式には、数式リストでそれぞれ「両方向」、「正方向」または「負方向」アイコンが前に置かれます。補助数式は、チャートのそれ以外のものには使用できません。選択された数式の後に定義済みの数式がない場合は、新しいダミーの補助数式が自動的に作成されます。このオプションは、棒グラフ、折れ線グラフ、およびコンボ チャートでのみ有効です。

データ点の値
数式の結果をデータ点の上側にテキストとしてプロットするには、このチェック ボックスをオンにします。このオプションは、棒グラフ、折れ線グラフ、コンボ チャート、および円グラフでのみ有効です。円グラフで使用する場合は、スライスの横に値が表示されます。

軸上の数式値
数式の結果を各 x- 軸値、軸、および軸ラベルにテキストとしてプロットするには、このチェック ボックスをオンにします。このオプションは、棒グラフ、折れ線グラフ、およびコンボ チャートでのみ有効です。

数式値のポップアップ
レイアウトでチャート内のデータ点にポインタを置いたときに表示されるポップアップ バルーン メッセージに数式の結果を表示するには、このチェック ボックスをオンにします。このオプションは、他の表示オプションの使用に関係なく使用できます。このため、数式をチャート自体には表示せず、ポインタを置いたときに表示されるポップアップにのみ表示することができます。
表示オプション

プレゼンテーション
このオプションは、ストレート テーブルとピボット テーブルでのみ有効です。

テキスト
数式値は常にテキストとして解釈および表示されます。

画像
このオプションでは、QlikView は各数式値を画像への参照として解釈しようとします。参照は、ディスク上の画像ファイルへのパス (たとえば、C:\Mypic.jpg) または qvw ドキュメント内の画像ファイルへのパス (たとえば、qmem://<Name>/<Peter>) になります。QlikView が数式を有効な画像参照として解釈できない場合は、[画像がない場合にテキストを隠す] チェックボックスがオンでない限り、値自体が表示されます。

円形ゲージ、線形ゲージ、信号機ゲージ、LED ゲージ
いずれかのゲージ オプションで、ゲージ チャートは画像として使用可能なテーブル セルに表示されます。ゲージのレイアウトは、[チャート プロパティ: プレゼンテーション] ダイアログで修正できます。 [ゲージの設定] ボタンから開きます。

ミニ チャート
このオプションでは、数式の値を棒グラフや折れ線グラフで表示します。チャートは使用可能なテーブル セルに内接して表示されます。チャートの視覚的な設定は [ミニ チャートの設定] ボタンで変更できます。このオプションは、ストレート テーブルでのみ有効です。

参照項目: ミニ チャートの設定

注: Excel に出力する場合、ミニ チャートは表示されません。

リンク
テーブル セルにクリック可能なリンクを作成する数式を、定義項目に入力するにはこのオプションを選択します。数式は、DisplayText<url>LinkText と解釈されるテキストを返します。DisplayText は、テーブル セルに表示されるテキストで、LinkText は、新しいブラウザ ウィンドウを開くリンクです。リンクが定義されると、テーブル セルの値に下線が引かれます。リンクが定義されない場合は、値に下線は引かれません。表示モードでは、リンクを表示するセルでの選択は行えませんのでご注意下さい。[...] ボタンをクリックすると、完全な 数式の編集 ダイアログが開きます。
例:
=Name & '<url>' & Link
=Name & '<url>www.qlikview.com'
ここで NameLink はロード スクリプトでロードされたテーブル項目です。

画像形式
上記の画像オプションが選択されている場合にのみ使用できます。このオプションは、ストレート テーブルとピボット テーブルでのみ有効です。この設定は、画像をセルに合わせるための QlikView の書式設定方法を表します。次の 4 つの選択肢があります。

縮小/拡大なし
このオプションを選択した場合、画像は、拡大縮小されずにそのままのサイズで表示されます。したがって、画像の一部が表示されない場合や、セルの一部が画像で覆われない場合があります。
塗りつぶし
このオプションを選択した場合、画像は、画像の縦横比の維持を考慮せずに、セル全体を覆うように拡大されます。
縦横比を固定する
このオプションを選択した場合、画像は、縦横比を維持したまま、セルをできるだけ広く覆うように拡大されます。
縦横比を固定して塗りつぶし
このオプションを選択した場合、画像は、縦横比を維持したまま、セル全体 (上下/左右とも) を覆うように拡大されます。したがって、通常は、どちらかの方向で画像が切り詰められます。
累積

このグループの設定から選択して、チャートの値を累積するかどうかを決定します。累積チャートでは、各 y 値が後続する x 値の y 値に加算されます。累積棒チャートには、年ごとの売上の合計が表示されます。たとえば、1996 年の値は 1997 年の値に追加されます。チャートに複数の数式が含まれている場合、累積する値のある数式を [数式] リストで選択します。累積は、ピボット テーブルでは使用できません。

累積なし
このオプションを選択すると、選択したチャート式の y 値は累積されません。

すべて累積表示
このオプションを選択すると、各 y 値が数式の前の y 値をすべて累積します。上記の「累積」を参照してください。すべて累積表示は Null 値や 0 値を含む複数軸では機能しません。

注: チャートのトレリスが有効になっている場合、[すべて累積表示] は機能しません。

累積表示 n 段階
ボックスに数値を入力して、数式の y 値の累積される回数を設定します。上記の「累積」を参照してください。

合計モード

このグループは、ストレート テーブルのチャート オブジェクトにのみ選択した数式に有効です。3 つの設定があります。

合計なし
選択した数式で合計は計算されません。
数式の合計
次のレベルで評価される数式の合計。例えば、数式が社員の月収の平均値を生成する場合、 数式の合計 はすべてのサラリーの全体の平均を生成します。
行の (集計関数)
このオプションを選択すると、選択した数式の各データ点の個々の値 (棒グラフの各棒、ストレート テーブルの各行など) が、ドロップダウン リストから選択した集計関数 (通常は合計) を使用して合計されます。

注: [最初の文字列] または [最後の文字列] は最も高い値か低い値で、テーブルでは英数字順に表示されます。英数字の順序は 0 から 9、その後 A から Z へと続きます。
枠線の幅 棒グラフとコンボ チャートで、数式によって表示される棒の周囲の枠線の幅を指定します。値は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
数式を凡例として表示 複数の数式を使用する場合、数式と対応する色を表示する凡例をチャートの隣に表示できます。
すう勢線

選択した QlikView チャートの数式では、プロットが統計すう勢線で補完されたり、置き換えられます。すう勢線は、散布図、折れ線グラフ、および棒として最大 1 つの軸と 1 つの数式だけを持つ棒グラフとコンボ チャートにのみ表示できます。他の種類のチャートでは、すう勢線 グループの設定は無効で効果がありません。散布図では、データ点が y=f(x) のように扱われます。棒グラフ、折れ線グラフ、およびコンボ チャートでは、表示オプション のすべてのオプションをオフにした場合でも、すう勢線を追加できます。これにより、すう勢線は基底のデータ点なしで表示されます。棒グラフ、折れ線グラフ、およびコンボ チャートのすう勢線は、フォーキャストまたはバックキャストを指定 ([目盛線] ページ) して外挿することができます。外挿線は点線で表示されます。不連続な x- 軸を含むチャートのすう勢線は、マーカー付きの線で表示されます。連続軸では、線のみが表示されます。

平均値
平均は、直線で描画されます。
線形トレンド
直線回帰線が描画されます。
2次元多項式
2 次元多項式のすう勢線が描画されます。
3次元多項式
3 次元多項式のすう勢線が描画されます。
4次元多項式
4 次元多項式のすう勢線が描画されます。
指数関数
指数関数のすう勢線が描画されます。
式の表示
特定の数式でこのチェック ボックスをオンにすると、その数式のすう勢線はチャートにテキストで表示されるすう勢線の方程式で補完されます。
R² を表示
特定の数式でこのチェック ボックスをオンにすると、その数式のすう勢線はチャートにテキストで表示される決定係数で補完されます。

参照項目: テーブル チャートの直線回帰

参照項目:

 

チャート プロパティ: ソート

[チャート プロパティ:ソート] ページは、チャートを右クリックし、[オブジェクト] メニューの [プロパティ] を選択して開きます。

ここでは、利用できるソート順からチャートの軸のソート順を決めます。

ストレート テーブルの [チャート プロパティ:ソート] ページには、少し異なるオプションが含まれます。

参照項目: チャート プロパティ: ソート (ストレート テーブル)

リストにはチャートの軸が含まれます。ソート順を適用するには、軸を強調表示して右側にあるソート順を選択します。

Y 軸値 軸の値は、y 軸の数値でソートされます。このオプションは計算軸には使用できません。
状態 軸の値を選択値、連結値、除外値の順にその論理状態に従ってソートします。
数式 軸の値は、このソート オプションの下にあるテキスト編集ボックスに入力した数式に基づいてソートされます。
レコード数 軸の値をレコード数 (テーブル内に現れる数) でソートします。
数値 軸の値をその数値でソートします。
テキスト 軸の値をそのアルファベット順でソートします。
ロード順 軸の値をその最初のロード順でソートします。

グループ内での優先順位は上から下になり、矛盾するソート順が選択されると、最初に出くわしたものが優先されます。選択したソート順は、昇順降順または A -> ZZ -> A を切替えて反転できます。

[初期設定] ボタンをクリックすると、軸の値は ドキュメント プロパティ:ソート] ページで定義された初期値に設定されます。

グループのソート順を上書きするチェック ボックスは、リストでグループ軸を選択した場合にのみ有効です。通常、グループ軸のソート順は、グループ プロパティを使用してグループの各項目に対して決定されます。このチェック ボックスをオンにすると、グループ レベルのこのような設定を上書きし、グループのアクティブな項目に関係なく、軸に 1 つのソート順を適用できます。

チャート プロパティ: スタイル

このページでは、チャートの基本的なスタイルを選択します。リスとされた機能はすべて、すべてのチャートの種類で有効です。

種類 有効なスタイルの 1 つを選択します。これは、いくつかの場合には、チャートの外観だけではなくその機能性にも影響するかもしれません。
方向 チャートの方向を水平または垂直に設定します。
形式 このグループでは、棒のモードを グループ または 積み上げ (レーダー チャートでは オーバーレイ または 積み上げ) に設定できます。この設定はチャートが 2 つの軸を表示する、もしくは 1 つの軸と 2 つ以上の数式を表示する場合にのみ機能します。積み上げ棒グラフの負の値は、個別に x- 軸の下側で下方向に積み上げられます。

複数の軸と数式をもつ棒グラフの表示には、次の原則が適用されます。
  • X-軸に表示できるのは最大 2 軸です。
  • 第 3 軸は、要素を塗り分けた積み上げ棒として表示されます。
  • テーブル チャートのみ 3 つ以上の軸を表示することができます。
  • 2 つ以上の数式が有効な場合、最初の 2 つの軸が X-軸として表示され、数式は要素を塗り分けた積み上げ棒として表示されます。
  • 2 つ以上の数式が有効で、サブグループが積み上げに設定されている場合、1 つの積み上げ内にあるすべての数式は、1 つの軸に応じて計算されます (デフォルトでは左)。これは、左の軸に応じて 1 つの数式を計算し、別の数式を右の軸に応じて計算するように設定する場合にもあてはまります。
 

以下の表に、複数の軸および数式での形式の表示状態を示します。

数式 形式
1 1 単一の棒
1 2 つ以上 数式はグループもしくは積み上げ
2 1 軸はグループもしくは積み上げ
2 2 つ以上 軸はグループ
3 1 第 1 、第 2 軸はグループ、第 3 軸は積み上げ
3 2 つ以上 第 1 、第 2 軸はグループ、数式は積み上げ
4 1 第 1 、第 2 軸はグループ、第 3 軸は積み上げ
4 2 つ以上 第 1 、第 2 軸はグループ、数式は積み上げ
3 次元ビュー このグループの設定では、チャートを 3 次元モードで表示する角度を定義します。
上部の角度
3 次元ビューの縦の角度を定義します。値は 5 ~ 45 の整数です。
側面の角度
3 次元ビューの横の角度を定義します。値は 5 ~ 45 の整数です。
プロット エリア 色のスタイル このコントロールは、チャートのすべてのプロットの色に色のスタイルを適用する場合に使用できます。ドロップダウン リストでスタイルを選択すると、[色] ページの [カラー マップ] のすべての色が選択したスタイルに変更されます。スタイルは即座に変更されますが、設定自体は、ダイアログのこのページを次に表示するまで保存されません。カラー マップの実際の基本色は、影響を受けません。[プロット エリア 色のスタイル] 設定は、すべてのチャートの種類で有用な訳ではありません。次のオプションを使用できます。
単色
カラー マップのすべての色を単色に設定します。
暗いグラデーション
マップのすべての色を黒へ移行するグラデーションに設定します。
明るいグラデーション
カラー マップのすべての色を明るい色調へ移行するグラデーションに設定します。
光沢
すべての棒を光沢ある色調に設定します。
プロット エリア 背景のスタイル このコントロールは、プロット エリアの背景の表示を変更するのに使用できます。この設定は、プロット エリアのあるチャートでのみ使用できます。次のオプションを使用できます。
フレーム
フレームがプロット エリアの周囲に描かれます。

このオプションは、プロット エリアの背景に影の効果を追加します。
最小
このオプションは、プロット エリアの背景を削除します。
プレビュー チャートの基本的な視覚プロパティのプレビューを提供します。

チャート プロパティ: プレゼンテーション (散布図 - グリッド チャート)

このプロパティ ページでは、散布図とグリッド チャートを総合的に使用できます。いくつかのオプションはいずれか 1 つに対してのみ使用できます。 ページで散布図に 1 つではなく 2 つの軸を定義した場合、第 1 軸の各値と、第 2 軸の関連付けられている各値から 1 つの散布データ ポイントが生成されます。生成されたデータ ポイントは、線で接続することができます。次の表示オプションが、プレゼンテーション グループで使用できます。

線のみ データは、データ点を線で表示します。
マーカーのみ データは、データ点をマーカーで表示します。
線とマーカ 上記オプションの組み合わせ
マーカーの自動サイズ調節 最大バブル サイズを散布図のサイズ/グリッド チャートの値の数に合わせます。
線の幅 線の表示を指定した場合は、線の幅を決定します。値は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
すう勢線の幅 ここでは、すう勢線の幅を決定します。
マーカーのサイズ マーカーの表示を指定した場合は、マーカーのサイズを決定します。
最大バブル サイズ チャートで使用する、最大のバブルのサイズを設定します。[表示] グループの [マーカーのみ] または [線とマーカー] との組み合わせにより一部 ([スタイル] タブで選択した) の表示、ならびに [マーカーの自動サイズ調節] の選択が解除されている場合のみ使用できます。
矢印の表示 接続線に矢印の表示オプションを設定します (上記の プレゼンテーション グループを参照してください)。矢印は、第 2 軸のソート順で定義された順序で、次の散布点の方向を向きます。チェックボックスをオンにすると、接続線に矢印を表示します。
矢印のサイズ 矢印のサイズをここで編集できます。
スタイル ドロップダウン リストにあるスタイルから選択します。
バブル スケール

グリッド チャートのバブルを次のどの方法に基づいて拡大縮小するかを選択します。

  • 半径
    バブルは半径に基づいて拡大縮小されます。
  • エリア
    バブルは領域に基づいて拡大縮小されます。これがグリッド チャートのデフォルトのオプションです。ほとんどの場合、このオプションでデータが最適に表示されます。

ラベル グループでは、ラベルとデータ ポイントの表示オプションを設定できます。プロットされるラベルは、凡例と同じです。

ラベルの最大表示数 表示するラベルの数を制限します。設定した数値が大きすぎると、チャートが分かりにくくなります。
データ ラベル チェックボックスをオンにすると、ラベルを表示します。
ポップアップ ラベル チャートでマウス ポインタを値に近づけたときに対応する軸の値をポップアップ ウィンドウに表示するには、このオプションをオンにします。
ハイライト このオプションをオンにすると、マウス ポインタを近づけたときにマーカーや線をハイライト表示します。凡例がチャートに含まれている場合、複数の重なり合う値から 1 つの値を同様にハイライト表示できます。
水平位置 ドロップダウンリストから水平方向 左揃え中央揃え、または 右揃え を選択します。
垂直位置 ドロップダウン リストから垂直方向 上下中央揃え、または を選択します。

0 値を隠す チェック ボックスと 欠損値を隠す チェック ボックスをオンにすると、空値や 0 値の軸がテーブルから排除されます。

X- 軸ラベルの表示 チャート プロパティ: 数式 ページの X グループで指定した X 軸のラベルを X 軸の終端に表示します。
Y- 軸ラベルの表示 チャート プロパティ: 数式 ページの Y グループで指定した Y 軸のラベルを Y 軸の終端に表示します。

参照項目: チャート プロパティ: 数式 (散布図)

凡例グループでは、チャートの軸データ ラベルの表示を制御できます。データ ラベルを表示するには、このチェック ボックスをオンにします。データ ラベルは、チャートの現在の最上位レベルについてのみ表示されます。

凡例の表示 チャートにラベルを表示するにはこのチェックボックスをオンにします (デフォルトでオン)。[設定...] ボタンをクリックし、凡例を変更できますチャートに軸の設定が無くても数式がいくつかある場合、このチェックボックスをオフにすると代わりに数式を X- 軸に表示します。
凡例に表示する文字数 軸およびチャートの凡例に表示する軸の値の文字列長を制限するには、このチェック ボックスをオンにします。チャートでは、切り捨てられた値の後に、... が置かれます。

参照項目: 凡例の書式

[チャートのスクロール] グループでは、チャート内でのスクロールについての設定を行えます。

X- 軸スクロール バーの有効化 X 軸の場所にスクロール コントロールを表示するには、このチェック ボックスをオンにします。スクロール バーを使用して、表示された X- 軸値の選択をスクロールできます。一度に表示される値の数は、[アイテム数が次を越える場合:] で設定した数になります。

基準線 グループでは、数値目盛の x- 軸または y- 軸の特定のポイントからチャートのプロット エリアを横断する基準線を定義できます。既存の基準線がウィンドウにリストされます。

追加 チャートに新しい基準線を作成するための [基準線] ダイアログを開きます。
編集 [基準線] ダイアログで既存の基準線のプロパティを編集するには、リスト内で強調表示してこのボタンをクリックします。
削除 既存の基準線を削除するには、リスト内で強調表示してこのボタンをクリックします。

参照項目: 基準線

チャートのテキスト グループは、自由に移動できるテキストをチャートに追加するために使用します。

追加 チャートに新しいチャート テキストを作成するための [チャート テキスト] ダイアログを開きます。
編集 [チャート テキスト] ダイアログで既存のテキストのプロパティを編集するには、リスト内で強調表示してこのボタンをクリックします。
削除 既存のテキストを削除するには、リスト内で強調表示してこのボタンをクリックします。

参照項目: チャート テキスト

自由に移動できるテキストがチャートの左上に表示されますが、チャートがチャート レイアウト編集モードの場合、配置し直すことができます。

参照項目: チャート コンポーネントのサイズ変更と移動

目盛線

目盛線 ページでは、X- 軸と Y- 軸の表示プロパティを設定できます。ページは、棒グラフと一部の他のオブジェクトの [目盛線] ページと同じです。

チャート プロパティ:色

チャート プロパティ:色 ページは、チャート ウィンドウを右クリックし、オブジェクト メニューの プロパティ を選択して開きます。

データの書式グループでは、チャートの軸項目値に 18 の異なる色を配置することができます。

色 1 - 18 色は、単色またはグラデーションとして定義できます。色をカスタマイズするには、ボタンをクリックして [色の設定] ダイアログを開きます。
初期設定色を取得ボタンは、カラー マップを QlikView のデフォルトの設定にリセットします。
色の変更を元に戻す ボタンは、このダイアログを開いたときに適用されていた色の設定に戻します。
[詳細設定...] ボタンは、[カラー マップ 詳細設定] ダイアログを開きます。ここでは、カラー マップを設定し、シート、ドキュメント、ユーザー、QlikView の初期設定を取得できます。
要素を塗り分ける このチェックボックスをオフにすると、すべての要素が同じ色になります。
固定色 このチェックボックスをオンにすると、カラー マップがロックされ、永久に同じ色をそれぞれの値に適用します。
最後の色を繰り返す このチェックボックスをオンにすると、18 番目の以降の値にはすべてカラー マップ の 18 番目の色が適用されます。オフの場合、1 から 18 の色を順番に繰り返し使用します。
色の代わりにパターンを使用する 印刷時
チャートは、白黒の塗りつぶしパターンで印刷されます。オフの場合、白黒プリンターがグレー スケールを使用します。
スクリーン上
チャートは塗りつぶしパターンで表示されます。

フレームの背景 グループでは、プロット エリアの背景とプロット エリアの周囲の領域の背景に色を設定します。

色付きの背景でチャートがプロットされます。プロット エリアと周囲の領域に異なる色を設定できます。

どちらのボタンもクリックすると [色の設定] ダイアログを開きます。

ヒント: 背景色設定は、画像プロット エリアのみと組み合わせることができます。
背景 プロット エリアの周囲の背景またはチャートの場合はチャート全体の背景に使用される色。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。デフォルトの色は、白です。
プロット エリア チャートのプロット エリアに使用される色。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。デフォルトの色は、ライト グレーです。この設定は、円グラフとファネル チャート、レーダー チャートでは使用できません。
画像 画像を選択して 画像 ボタンをクリックすると 画像の挿入 ダイアログが開き、背景画像をインポートできます。
プロット エリアのみ チェックボックスをオンにすると、インポートした画像がプロット エリア のみに制限されます。
動的画像 計算式を入力し、選択によって動的に変化する画像を背景に表示します。棒グラフ、折れ線グラフ、コンボ チャート、散布図およびグリッド チャートで有効です。
透過性 チャートの背景の透過性を設定します。0% を指定すると背景は完全に不透明になり、上の [背景色] で定義した色になります。100% の場合、背景は完全に透明になります。

プロット エリアの枠線 グループでは、プロット エリアの周囲に描画される四角形の枠線の を設定できます。

参照項目:

 

チャート プロパティ:数値書式

このページは、アクティブなチャートに適用されます。また、項目値を設定する次のコントロールが含まれます。

初期設定値 初期設定値の数値書式を使用して数値を表示します。
数値 有効桁数 ボックスで設定した桁数で数値を表示します。
整数 数値を整数で表示します。
実数 小数点以下の桁数 ボックスで設定した桁数の小数点値で数値を表示します。
通貨 プレビュー テキスト ボックスに表示される書式で数値を表示します。デフォルトの書式は Windows の通貨設定です。
日付 書式パターン 編集ボックスに設定される書式で日付として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
時刻 書式パターン 編集ボックスに設定される書式で時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
タイムスタンプ 書式パターン 編集ボックスに設定される書式で日付 + 時刻として変換した値を表示します。この書式のサンプルは、プレビュー テキスト ボックスに表示されます。
時間間隔 シーケンシャルな時間増分で時間を表示します (例:書式 = mm では、値をカレンダーが始まってからの分の数で表示します (1899:12:30:24:00)。

パーセント表示 (%) チェックボックスは、次の書式で機能します: 数値整数実数

小数点桁区切り 区切り記号は、 区切り記号 グループの編集ボックスで設定できます。

単位 では、編集ボックスに単位、千の単位、百万の単位、十億の単位を入力できます。

ISO ボタンは、日付、時刻、タイムスタンプの書式に標準 ISO を使用します。

システム ボタンは、書式設定をシステム設定に設定します。

フォント

ここでは、フォントスタイルおよびフォント サイズを設定します。

フォントの設定は、ひとつのオブジェクト用にはオブジェクト プロパティ:フォント ページ、ドキュメント上のすべてのオブジェクト用にはドキュメント プロパティ:フォント ページのオブジェクトに適用するボタンで行うことができます。

さらに、新しいオブジェクト用のドキュメントのフォント初期設定は、ドキュメント プロパティ:フォント ページで設定できます。2 つの初期フォントがあります。

  1. 最初のデフォルト フォント (リスト ボックス、チャートなど) は、リスト ボックスやチャートなどのほとんどのオブジェクトで使用されます。
  2. 次のデフォルト フォント (テキスト オブジェクトとボタン) は、一般的に大きなフォントを必要とするボタンやテキスト ボックスに使用されます。

最後に、新しいドキュメントのフォント初期設定は、ユーザー プロパティ:フォント ページで設定できます。

チャート、ボタンおよびテキスト オブジェクト (検索オブジェクト以外) には、フォントのも指定できます。色は、[固定] もしくは [計算] (数式で動的に計算します) を選択します。数式は有効な色表現でなければなりません。カラー関数を使用して作成します。数式の結果が有効な色表現でない場合は、フォントの色はデフォルトで黒になります。

参照項目: カラー関数

その他の設定は次のとおりです。

ドロップシャドウ このチェック ボックスをオンにすると、テキストにドロップ シャドウが追加されます。
下線 このチェック ボックスをオンにすると、テキストに下線が引かれます。

選択したフォントのサンプルが、プレビュー パネルに表示されます。

レイアウト

レイアウトの設定をオブジェクトのプロパティ ページから行うと、そのオブジェクトにのみ適用されます。
レイアウトの設定をドキュメントのプロパティ ページから行うと、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

枠線の使用

シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。ドロップダウン メニューから選択して、枠線の種類を指定します。

影の強度 影の強度ドロップダウン メニューで、シート オブジェクトの周りの影の強度を設定できます。影なしの選択肢もあります。
枠線のスタイル 既定の枠線は次のとおりです。
固定
単色の固定の枠線。
くぼみ
シート オブジェクトが背景からくぼんでいるように見える枠線。
浮き彫り
シート オブジェクトが背景から浮き上がっているように見える枠線。

シート オブジェクトの周囲に壁があるように見える枠線。
枠線の幅 このオプションは、すべての種類の枠線で有効です。幅は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。
このボタンをクリックするとダイアログが開き、すべての種類の枠線に適用される基本色をカラー パレットから選択できます。
カラフル すべての種類の枠線を虹色の枠線にします。虹は、シート オブジェクトの上部で選択した基本色で始まります。

ドキュメント プロパティ: 基本設定スタイルのモード簡易設定 が選択されている場合、枠線の種類は選択できません。設定できるのは 影の強度 のドロップダウン メニューと 枠線の幅のみとなります。

角を丸くする

角を丸くする グループでは、シート オブジェクトの基本の形を設定できます。これらの設定により、シート オブジェクトを円形/楕円形から長方形までの範囲で描くことができます。角を丸くする を使用できるのは、ドキュメント プロパティ: 基本設定スタイルのモード詳細設定 が選択されている場合のみです。

角を丸くする このチェックボックスをオンにすると、角の形を丸くするオプションを設定できるようになります。
角の位置 チェック ボックスをオフにした角は直角に描画されます。
鋭度 2 から 100 の間の数値を設定でき、数値 100 を定義すると直角、数値 2 は完全な楕円 (縦横比が 1:1 の場合は円) に相当します。丸い角には、鋭度 2 から 5 が通常最適な数値です。
角の丸み この設定は、固定の距離 (固定)または四分円全体に対するパーセンテージ (相対値(%)) で、角の半径を決定します。この設定により、鋭度で設定した基になる基本図形が角に影響を与える程度を制御できます。距離は、mm、cm、インチ ("、inch)、ピクセル (px、pxl、pixel)、ポイント (pt、pts、point)、または docunits (du、docunit) で指定できます。

レイヤー

レイヤー グループでは、オブジェクトを 3 つのレイヤーのいずれかを割り当てることができます。

背面 背面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと前面レイヤーにあるシート オブジェクトを覆うことはできません。背面レイヤーにある他のシート オブジェクトの上にのみ配置できます。
標準 シート オブジェクトは、作成されると、標準位置 (中央) のレイヤーに置かれます。標準位置レイヤーにあるシート オブジェクトは、背面レイヤーのシート オブジェクトで覆われることはありませんし、前面レイヤーのシート オブジェクトを覆うこともできません。
Top 前面レイヤー プロパティのシート オブジェクトは、標準位置レイヤーと背面レイヤーにあるシート オブジェクトによって覆われることはありません。その上に配置できるのは、前面レイヤーにある他のシート オブジェクトだけです。
カスタム 前面標準位置、および背面レイヤーは、内部的に番号が振られたレイヤー 1、0、-1 にそれぞれ対応しています。実際には、-128 ~ 127 の間のすべての値が使用できます。選択した値を入力する場合は、このオプションを選択します。

テーマの作成

テーマ作成 ウィザードを開くと、レイアウト テーマを作成できます。

テーマの適用

オブジェクト、シート、ドキュメントにレイアウト テーマを適用できます。

参照項目: レイアウト テーマ

表示

表示 グループでは、シート オブジェクトを表示する条件を指定できます。

常に表示 シート オブジェクトは常に表示されます。
条件付き表示

シート オブジェクトは、選択などで継続的に評価される条件付き関数に基づいて表示/非表示にされます。シート オブジェクトは、その条件が TRUE を返す場合にのみ表示されます。

参照項目: 条件分岐関数

注:

ドキュメントの管理権限を持つユーザーは、ドキュメント プロパティ: セキュリティすべてのシートとシート オブジェクトを表示 を選択すると、すべての表示条件を無視してこの設定を適用できます。 CTRL+SHIFT+S を押して、この機能を切り替えることができます。

参照項目: ドキュメント プロパティ:セキュリティ

オプション

オプション グループでは、シート オブジェクトの移動/サイズ変更を禁止できます。このグループの設定は、ドキュメント プロパティ: レイアウトシート プロパティ: セキュリティ で該当のチェック ボックスをオンにしてある場合のみ有効です。

移動/サイズ変更を許可する このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
コピー/複製を許可する このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。
INFO を許可する

info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。

参照項目: Info

データにサイズを合わす 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。

スクロール バー

スクロール バー グループには、スクロール バーのレイアウトを変更するコントロールがあります。

スクロール バーの位置を保持する

この設定が有効の場合、QlikView は、他のオブジェクトで選択が行われたときに、スクロール バーが設定されているテーブルやチャートのスクロールの位置を保持しようとします。この設定は ユーザー プロパティ: オブジェクト でも有効にする必要があります。

ドキュメントを閉じると、スクロールの位置は保持されません。

スクロール ボタン スクロール ボタンの色を設定します。ボタンをクリックして色を選択します。スクロール バーは、薄い灰色で描画するとよい結果が得られます。色は、ボタンをクリックすると表示される 色の設定 ダイアログで、単色またはグラデーションとして定義できます。
スクロールの背景

スクロール バーの背景色を設定します。ボタンをクリックして色を選択します。

スクロール バーの幅 このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。
スクロールのスタイル

スクロール バーのスタイルを設定します。ドロップダウン コントロールでスタイルを選択します。クラシック スクロール バー スタイルは、QlikView の 4/5 スクロール バーに対応します。標準スクロール バー スタイルは、最新の外観になります。3 つ目のスタイル、ライトは細く、ライトなスクロールバーです。

スクロール バー スタイルを表示するには、[スタイルのモード] を [詳細設定] に設定する必要があります。この設定は、[基本設定] タブで [設定] ドロップダウン メニューを開き、[ドキュメント プロパティ] を選択すると見つかります。

適用するオブジェクト キャプションと枠線のプロパティ ダイアログを開きます。ここでは、レイアウト ページで設定されたプロパティを適用する場所を設定できます。

キャプション

キャプションの設定が [オブジェクト プロパティ] ページで行われた場合は、そのオブジェクトにのみ適用されます。
キャプションの設定が [ドキュメント プロパティ] ページで行われた場合は、ドキュメントで指定された種類のオブジェクトすべてに適用されます。

キャプション ページでは、オブジェクトの基本的なレイアウトとは全く違うレイアウト オプションを指定できます。

キャプションの表示 このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
タイトル テキスト テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。キャプションのフォントを変更するには フォント ボタンを使用します。

異なる状態のキャプションの色を設定します。アクティブ時の色非アクティブ時の色 は別々に設定できます。

[背景色][テキストの色] ボタンをクリックすると [色の設定] ダイアログを開きます。背景色は、色の設定ダイアログで、単色またはグラデーションとして定義できます。テキストの色は、固定または計算色として色関数を使用して定義できます。

参照項目: カラー関数

折り返し このオプションを選択した場合、キャプションは、 2 行以上で表示されます。
キャプションの高さ (行) 編集ボックスで、キャプションの行数を設定します。

QlikView のシート オブジェクトの正確なサイズと位置を設定できます。標準 もしくは 最小化 時のサイズ/位置設定で調整します。これらの設定は、ピクセル単位で行います。

X- 位置 シートの左端に対するシート オブジェクトの左辺の水平方向の位置を設定します。
Y- 位置 シートの上端に対するシート オブジェクトの上辺の垂直方向の位置を設定します。
QlikView シート オブジェクトの幅を設定します。
高さ QlikView シート オブジェクトの高さを設定します。

キャプションのラベルの方向は、[キャプションの配置] オプションで変更できます。

水平 キャプションのラベルは水平方向に整列できます:左揃え中央揃え、または 右揃え
垂直 キャプションのラベルは垂直方向に整列できます: [上揃え][上下中央揃え]、または [下揃え]

キャプション アイコン
シート オブジェクトのオブジェクト メニュー コマンドの多くをキャプション アイコンとして設定できます。キャプション アイコンとして表示するコマンドを選択するには、リスト内の各コマンドの左にあるチェック ボックスをオンにします。

注: キャプション アイコンは注意して使用してください。アイコンが多すぎると邪魔になる可能性があります。
最小化を許可する このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。
自動最小化 このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。
最大化を許可する このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する][最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。
ヘルプ テキスト

ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。ヘルプ テキストは、計算式として指定できます。このオプションはドキュメント レベルでは使用できません。[...] ボタンをクリックすると、完全な [数式の編集] ダイアログが開かれ、長い数式を簡単に編集できます。

参照項目: 計算式の数式構文

シート オブジェクトの説明などを入力します。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。