折れ線グラフ - AJAX/Webview

折れ線グラフは、値ポイント間の線、値ポイントのみ、または線と値ポイントの両方でデータを表します。折れ線グラフは、変更や傾向を表示する場合に便利です。

折れ線グラフ:オブジェクト メニュー

シート オブジェクト上で右クリックするか、オブジェクトのキャプション (表示されている場合) で アイコンをクリックすると、コンテンツ メニューとしてオブジェクト メニューが開きます。

メニューに含まれるコマンドは、QlikView ローカル クライアントで WebView を開いているか、Web ブラウザでドキュメントにアクセスして開いているかによって異なります。メニューには以下のコマンドがあります。

プロパティ

アクティブなシート オブジェクトの プロパティ ダイアログが開きます。

ノート

現在のオブジェクトに関するノートの作成および共有ができます。

参照項目: ノートとコメント

分離設定 チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。
分離解除 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。
参照設定 このオプションを選択して、チャートの参照 (現在の選択を使用したチャートの固定プロット) を設定します。ドキュメントでさらに選択を行っても、参照プロットは残り、背景に淡色表示されます。チャートの軸等は、常に背景のデータ セットと現在のデータ セットの最大値に調整されます。現在のデータ セットは、常に参照プロットの前面にプロットされます。つまり、参照プロットの一部は、現在のデータ セットのプロットによって隠される場合があります。参照チャート プロットの表示は、一部のチャートの種類 (棒グラフ、折れ線グラフ、コンボ チャート、レーダー チャート、散布図、グリッド チャート、および針を使用するゲージ チャートなど) でのみ可能です。ドリルダウンやサイクリック グループを含むチャートでは [参照設定] は利用できません。ドキュメントを閉じるか、データをリロードすると、参照は失われます。[参照設定] オプションの使用時に含めることができるオブジェクトの最大数は 500 です。
参照解除 参照が設定されると、参照設定 コマンドがこのコマンドに置き換えられます。これを選択すると、以前に設定した参照がクリアされ、チャートが通常のプロット モードに戻ります。
すべての選択をクリア

アクティブなリスト ボックスの現在の選択をすべてクリアします。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

コピー

選択したシート オブジェクトをクリップボードにコピーします。この関数はデータや画像ではなく、シート オブジェクトのみをコピーします。

印刷

選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

Excel 出力

絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

エクスポート

名前を付けて保存 ダイアログが開き、出力されたデータを保存する場所、ファイル名、ファイルの種類を指定できます。

クイック切替

現在のチャートを別の種類のチャートに変更することができます。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。[チャートのクイック切替][プロパティ] ダイアログの [キャプション] タブで有効になっている場合にのみ利用できます。

最小化

オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。

元のサイズに戻す

最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。

最大化

オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。

削除

選択されたオブジェクトをシートから削除します。

折れ線グラフ プロパティ

プロパティ ダイアログを開くには、オブジェクト メニューから プロパティ を選択します。 プロパティ コマンドが淡色表示されている場合、プロパティの変更を行うために必要な権限がありません。

ドロップダウン リストで軸を選択します。軸を追加するにはをクリックします。ドロップダウンで軸を選択します。アイコンでリスト内の項目を移動します。アイコンでリストから項目を削除します。詳細については、[詳細] ボタンをクリックしてください。

有効条件

このチェック ボックスを使って軸を動的に表示/非表示にするには、入力した条件式の値に応じて下の編集ボックスの ボタンをクリックします。

現在選択されている軸を削除します。

ラベルの表示

x- 軸に軸ラベル (項目名) を表示するには、このチェック ボックスをオンにします。

NULL 値を隠す

このチェック ボックスをオンにすると、上の [軸] で選択した項目の値が NULL の場合、チャートにその項目は表示されません。

すべての値を表示

すべての軸項目値 (論理的な除外値も含む) をチャートに表示するには、このチェック ボックスをオンにします。

軸ラベルの表示 (Show Axis Labels)

選択した軸項目の x- 軸に凡例 (項目値の名前) を表示するには、このチェック ボックスをオンにします。

軸ラベルの文字制限

軸およびチャートの凡例に表示する軸の値の文字列長を制限するには、このチェック ボックスをオンにします。入力項目で文字数を指定、またはスライダを希望する数値までドラッグします。チャートでは、切り捨てられた値の後に、... が置かれます。このオプションは、このグループの他のオプションに関係なく使用できます。

トレリス設定の第 1 軸

このチェック ボックスをオンにすると、トレリス チャートが有効になり、第 1 軸を基準にチャートが配列表示されます。

固定列数

トレリス チャートに表示する列数を入力します。入力フィールドで列数を指定するか、スライダを希望する数値までドラッグします。

固定行数

トレリス チャートに表示する行数を入力します。入力項目で行数を指定、またはスライダを希望する数値までドラッグします。

第 2 軸

トレリス チャートの第 2 軸を有効にします。第 2 軸を使用する場合、第 1 軸の値はマトリックス内の列として表示され、第 2 軸はマトリックス内の行として表示されます。

ソート


シート オブジェクトの値のソート順を設定します。シート オブジェクトによっては、ソートのオプションが無いものもあります。
複数のソート順が指定されている場合の優先順位は、選択状態、数式、レコード数、数値、テキスト、ロード順となります。ステートは論理状態 (選択値、連結値、または除外値) を参照します。

第 1 ソート順

Y-軸値
Y- 軸の数値に基づいて軸の値をソートするかどうかを設定します。このオプションは計算軸には使用できません。
レコード数
項目値をレコード数 (テーブル内に現れる数) でソートします。
数値
値を数値順にソートします。
テキスト
項目値をアルファベット順にソートします。
ロード順
項目値を最初のロード順でソートします。

第 2 ソート順

レコード数
項目値をレコード数 (テーブル内に現れる数) でソートします。
数値
値を数値順にソートします。
テキスト
項目値をアルファベット順にソートします。
ロード順
項目値を最初のロード順でソートします。

数式によるソート

入力された数式によって項目値をソートします。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

選択値を上部に配置

選択値を上部に配置するには、これを有効にします。

制限

最初の数式を使った表示値の制限

これらのプロパティは、下で行った設定に応じて、チャートに表示される軸値の数を決定するために使用します。

表示のみ

このオプションは、[最初] あるいは [最大][最小] の値をいくつ (x 個) 表示させたいかによって選択します。このオプションを 5 に設定すると、5 つの値が表示されます。軸の [「その他」の表示] が有効になっている場合、[その他] セグメントには 5 つの値のいずれかひとつが表示されます。

[最初] オプションは、プロパティ ダイアログの [ソート] タブで選択したオプションに基づき、行を返します。チャートがストレート テーブルの場合は、列はその時の第 1 ソート順に基づいて返されます。つまり、列見出しをダブルクリックしてその列を第 1 軸ソートにすると、値の表示を変更できます。

[最大] オプションは、チャートの最初の数式に基づいて降順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

[最小] オプションは、チャートの最初の数式に基づいて昇順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

表示する値の数を入力します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
[境界値を含める] を選択すると、比較値を含有する軸の値が含まれます。

次の値のみ表示

このオプションを選択すると、このオプションで指定した条件に合うすべての軸の値を表示します。合計値のパーセンテージ、または正確な値に基づいて値を表示するのに使用します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にします。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

次に累積する値のみ表示

このオプションを選択すると、現在の行まですべての行を累積し、その値をオプションで設定した値と比較します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にし、累積値 (最初の値または最大値、最小値に基づく) と全体の合計値を比較します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

「その他」の表示

このオプションを有効にすると、チャートに [その他] セグメントを作成できます。表示を制限する比較基準を満たさない軸の値は、すべて [その他] セグメントにまとめられます。選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。

「合計」の表示

このオプションを有効にすると、チャートには選択した軸の合計が表示されます。この合計値は [プロパティ] ダイアログの [数式] タブで設定されますが、数式の合計とは異なります。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

グローバル グループ化モードの使用

このオプションは内部軸にのみ適用されます。このオプションを有効にすると、制限は選択した軸に基づいてのみ計算されます。前の軸はすべて無視されます。このオプションを無効にすると、制限は前のすべての軸に基づいて計算されます。

目盛線

目盛線の表示

目盛線を表示するにはこのチェック ボックスをオンにします。

目盛線の幅

目盛および目盛マークの幅を入力、またはスライダを希望する値までドラッグします。

第 1 軸ラベル

第 1 軸ラベルの表示を水平垂直斜めから選択します。

第 2 軸ラベル

第 2 軸ラベルの表示を水平垂直斜めから選択します。

グリッドの表示

x- 軸の目盛マークから始まるグリッドをチャートに表示するにはこのボックスをオンにします。グリッド線は、グリッド スタイルグリッド色 設定を使用して書式設定できます。

補助グリッドの表示

グリッド線の間に補助線を表示するには、このボックスをオンにします。[グリッドの表示] がオンの場合にのみ有効です。グリッド線は、グリッド スタイルグリッド色 設定を使用して書式設定できます。

段組みラベル

x- 軸ラベルが多くて横並びにできない場合に段組みにするには、このオプションをオンにします。

段組み表示の反転

通常、x- 軸ラベルは下から上、左から右に段組みにされます。このチェック ボックスをオンにすると、段組が上から下に反転します。

数値目盛の X- 軸

x- 軸を数値目盛表示に設定します。つまり、x- 軸は数値と解釈され、数値的に適切な間隔で表示されます。

目盛りの 0 設定

チャートの下端を y- 軸の 0 に固定します。このオプションは、Log スケールが使用されている場合は使用できません。

最小値

目盛線の最小値を固定値として設定できます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

最大値

目盛線の最大値を固定値として設定できます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

目盛間隔

目盛線の目盛マークの間隔を固定値として設定できます。この設定によって目盛マークが 100 個より多くなる場合は、使用される値が変更されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

バックキャスト

編集項目に整数を入力すると、x- 軸が、プロットされている実際のデータ ポイントの左に拡張されます。これは、すう勢線を使用する場合に便利です。バックキャスト線は点線で表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

フォーキャスト

編集項目に整数を入力すると、x- 軸が、プロットされている実際のデータ ポイントの右に拡張されます。これは、すう勢線を使用する場合に便利です。フォーキャスト線は点線で表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

数式

ドロップダウン リストから数式を選択します。数式を追加するにはをクリックします。ドロップダウンから数式を選択します。アイコンでリスト内の項目を移動します。アイコンでリストから項目を削除します。詳細については、詳細 ボタンをクリックしてください。

数式

有効化

このチェック ボックスをオンにすると、選択した数式が有効になります。ボックスがオンにされていない場合は、数式を使用できません。

条件付き表示

このチェック ボックスをオンにすると、編集ボックスの下にある ボタンをクリックして入力した条件式の値に応じて、レポートが動的に表示または非表示にされます。

ラベル

数式のラベル。チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

数式

現在選択されている式を削除します。

コメント

数式の目的と機能を説明するコメントを入力します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

表示しない

式を非表示にします。

パーセント表示 (相対)

チャートの結果表示を絶対数ではなくパーセントにします。

累積

累積を使用するにはこのチェック ボックスをオンにします。ポップアップを開くには をクリックします。

すう勢線の使用

すう勢線を使用するにはこのチェック ボックスをオンにします。ポップアップを開くには をクリックします。

凡例の表示

複数の数式を使用する場合、数式と対応する色を表示する凡例をチャートの隣に表示できます。

線記号の設定

このボックスをチェックすると、棒や線記号のレイアウト設定ができます。ポップアップを開くには をクリックします。

[線記号の設定] ポップアップ


線のレイアウトを設定します。


シンボル

マーカーのレイアウトを設定します。

値表示の設定

値の表示形式を定義するには、このチェック ボックスをオンにします。ポップアップを開くには をクリックします。

属性式のスタイル

背景色
データ ポイントの基本的な描画色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。

線のスタイル
データ ポイントに関連付けられた線または線分の線のスタイルを計算するための属性式を入力するには、線のスタイル をクリックします。この種類の属性式は、折れ線グラフ、コンボ チャート、およびレーダー チャートにのみ有効です。

線の相対的な幅は、<Wn> タグを含めることで制御できます。ここで、n はチャートのデフォルトの線の幅に適用される倍率です。 n は、0.5 ~ 8 の実数でなければなりません (例: <W2.5>)。線のスタイルは、<Sn> タグを含めることで制御できます。ここで、n は、使用するスタイルを示す 1 ~ 4 の整数 (1 = 実線、2 = 破線、3 = 点線、4 = 破線/点線) です。例:<S3>。<Wn> および <Sn> タグは自由に組み合わせることができますが、それぞれ最初に出現するもののみが有効と見なされます。タグは単一引用符で囲む必要があります。


値の表示
メイン数式で [データ ポイントの値] をオンにしていない場合に、データ ポイントのプロットを「データ ポイント値の数値」で補足するかどうかを計算する属性式を定義します。メイン数式で データ点の値 をオンにした場合、属性式は無視されます。

目盛線

目盛線の表示

目盛線を表示するにはこのチェック ボックスをオンにします。

目盛線の幅

目盛および目盛マークの幅を入力、またはスライダを希望する値までドラッグします。

軸の分割

このボックスをチェックすると、y-軸が 2 か所に分けられ、x-軸を共有する 2 つのチャートを作成します。

位置

またはの位置を選択します。

グリッドの表示

x- 軸の目盛マークから始まるグリッドをチャートに表示するにはこのボックスをオンにします。グリッド線は、グリッド スタイルグリッド色 設定を使用して書式設定できます。

補助グリッドの表示

グリッド線の間に補助線を表示するには、このボックスをオンにします。[グリッドの表示] がオンの場合にのみ有効です。グリッド線は、グリッド スタイルグリッド色 設定を使用して書式設定できます。

Log スケール

このボックスをオンにすると、目盛が対数になります。

目盛りの 0 設定

チャートの下端を y- 軸の 0 に固定します。このオプションは、Log スケールが使用されている場合は使用できません。

最小値

目盛線の最小値を固定値として設定できます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

最大値

目盛線の最大値を固定値として設定できます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

目盛間隔

目盛線の目盛マークの間隔を固定値として設定できます。この設定によって目盛マークが 100 個より多くなる場合は、使用される値が変更されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

中間値

その位置がプロット エリアの中心になる目盛線の値を固定値として設定します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

 
タイトルの表示 デフォルトでは、定義する最初の数式のラベルがチャート タイトルとして設定されます。チャート タイトルを表示しない場合は、チェック ボックスをオフにします。動的に更新する計算式としてタイトルを指定することもできます。をクリックして [数式の編集] ダイアログを開きます。
詳細/簡略 隠された補助タブを展開/折りたたみするには、このボタンをクリックします。アクティブな項目が [軸] または [数式] かによって表示されるタブは異なります。

折れ線グラフ プロパティ: プレゼンテーション

プレゼンテーション

オプションはすべてのオブジェクトで使用できるわけではありません。

種類 ドロップダウンの選択肢の中から種類をひとつ選択します。
ポップアップを開くには をクリックします。
方向 チャートの方向を設定します。
色のスタイル チャートのすべてのプロットの色に、色のスタイルを定義できます。ポップアップを開くには をクリックします。
凡例の表示 チャートに凡例を表示します。ポップアップを開くには をクリックします。
積み上げ このオプションをオンにすると、棒がグループ表示ではなく積み上げ表示されます。
要素の間隔 クラスターの棒と棒の間の距離を設定するには、数値を入力するかスライダーをドラッグします。
グループの間隔 チャートのクラスターとクラスターの間の距離を設定するには、数値を入力するかスライダーをドラッグします
背景 チャートの背景を設定します。次のオプションを使用できます。

色を選択するには をクリックします。
画像
画像を変更するには をクリックします。
動的画像
計算式を入力し、選択によって動的に変化する画像を背景に表示します。
プロット エリアの背景 プロット エリアの背景を設定します。次のオプションを使用できます。

プロット エリアに背景色を付けます。色を選択するには をクリックします。
画像
プロット エリアの背景に画像を表示します。画像を変更するには をクリックします。
動的画像
計算式を入力し、選択によって動的に変化する画像を背景に表示します。
プロット エリアのスタイル このコントロールは、プロット エリアの背景の表示を変更するのに使用できます。次のオプションを使用できます。
フレーム
フレームがプロット エリアの周囲に描かれます。

このオプションは、プロット エリアの背景に影の効果を追加します。
最小
プロット エリアの背景は削除されます。
背景の透過性 チャートの透過性を設定するには、ボックスに値を入力するかスライダーをドラッグします。
詳細/簡略

基本設定

反転

このチェックボックスがオンの場合、チャートに表示される値が反転されます。 10 の最高値を表示するチャートの場合、このチェックボックスをオンにすると 10 の最低値を表示します。

最大表示数

このボックスでは、チャートに値を表示するデータ点の数の上限値を指定します。制限を指定しない場合は、すべてのデータ点の値が表示されます。このため、チャートの読みやすさに影響することがあります。

0 値を隠す

このチェック ボックスをオンにすると、すべての数式から 0 または NULL を返す軸項目のすべての組み合わせが計算で無視されます。このオプションは、デフォルトでオンになっています。

欠損値を隠す

このチェック ボックスをオンにすると、すべての数式のすべての項目の NULL 値にのみ関連付けられた軸項目のすべての組み合わせが計算で無視されます。このオプションは、デフォルトでオンになっています。これをオフにすると、チャートで NULL 値をカウントするなど、特別な場合にのみ役立ちます。

数式の目盛線を 0 レベルに揃える

Y- 軸の 0 レベルに合わせます (左/右または上/下)。

マーカー セットを使用する

このチェックボックスをオンにすると、マーカーの表示の種類 (リング、三角など) が増えます。

半透明

線を半透明に表示したい場合は、このボックスをチェックします。

値を縦書きにする

値を縦に表示します。

要素の中に数値を表示

このチェックボックスをオンにすると、要素の上に表示する代わりに、要素の中にデータ点の値を表示します。

ポップアップ ラベル

このチェック ボックスをオンにすると、チャートのデータ点上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

ハイライト

このチェック ボックスをオンにすると、マウス ポインタを線またはマーカー上に置いたときに、線またはマーカーが強調表示され、全体像を把握しやすくなります。強調表示は、凡例にも適用されます (適用可能な場合)。

チャートのスクロール

ポップアップを開くには をクリックします。

[チャートのスクロール] ポップアップ

棒の表示数が定義済みの数値を超えている場合、X- 軸の場所にスクロール コントロールを表示するには、このチェック ボックスをオンにします。スクロール バーを使用して、表示された X- 軸値の選択をスクロールできます。

演算実行条件

ここに入力された数式には、チャートが計算されるために満たす必要がある条件を設定します。条件が満たされない場合は、"演算実行条件が満たされていません" というテキストがチャートに表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

スタイル

凡例

凡例の色を設定するには をクリックします。凡例のフォントの色を設定するには をクリックします。フォントの種類を設定するには をクリックします。

チャート タイトルのスタイル

チャート タイトルのフォントの色を設定するには をクリックします。フォントの種類を設定するには をクリックします。

キャプションのフォント

キャプションのフォントの種類を設定するには をクリックします。

アクティブ時のキャプション

アクティブ時のキャプションの背景色を設定するにはをクリックします。テキストの色を設定するには をクリックします。。

非アクティブ時のキャプション

非アクティブ時のキャプションの背景色を設定するにはをクリックします。テキストの色を設定するには をクリックします。

枠線の使用

シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。枠線の色を設定するには をクリックします。

枠線の幅

枠線の幅を設定するには、値を指定するかスライダーをドラッグします。幅は、ピクセル単位で指定します。

角を丸くする

をクリックして [角を丸くする] ポップアップを開きます。

注:

角を丸くする を使用できるのは、ドキュメント プロパティ: 基本設定スタイルのモード詳細設定 が選択されている場合のみです。

[角を丸くする] ポップアップ

選択

[固定]

または

[相対値]

を選択し、丸くしたい角を選択します。また、値を入力して

[鋭度]

を選択します。 

スクロールの背景

スクロール バーの背景色を設定するには をクリックします。

スクロール ボタン

スクロール バーのボタンの色を設定するには をクリックします。

スクロール バーの幅

スクロール バーの幅を設定するには、値を指定するかスライダーをドラッグします。このコントロールは、スクロール バーのシンボルの幅と相対的なサイズの両方に影響します。

すう勢線の幅

すう勢線の幅を指定します。

基準線

基準線

基準線を追加するには をクリックします。

基準線のラベルを表示

基準線の隣にラベルを表示します。

ラベル

テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

X- 軸

基準線の起源を x- 軸にする場合は、このオプションを選択します。

数式

基準線を引く対象の値です。開始点として使用する数式を入力します。

線の太さ

基準線の太さを指定します。

線のスタイル

基準線のスタイルを指定します。

線の色

基準線の色を指定します。

条件付き表示の使用

基準線は、チャートが描画されるたびに評価される条件式に基づいて表示/非表示にされます。基準線は、数式が true を返す場合にのみ表示されます。

条件

条件式を入力します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

テキスト

チャートのテキスト

チャートにテキストを追加するには をクリックします。

テキスト

チャートのテキスト に追加されたテキストはここに表示されます。

角度

テキストの角度を 0 ~ 360 度に指定できます。デフォルトは 0 です。

水平位置

水平方向の配置を設定します。

常に手前に表示

チャートの描画時に、リストで現在選択されているテキストが前面に表示されます。

テキストのスタイル

テキストの背景色を設定するにはをクリックします。
フォントの色を設定するにはをクリックします。フォントの種類を設定するには をクリックします。

サイズと位置

オブジェクト上のテキストのサイズと位置を設定します。

折れ線グラフ プロパティ: キャプション

キャプション

ラベル テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
キャプションの表示 このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
キャプションの配置 左/中央/右
複数行のキャプション (文章の折り返し) このオプションを選択した場合、テキストは 2 行以上で表示されます。
行数 キャプションで複数行がオンの場合に、入力項目で行数を指定、またはスライダを希望する数値までドラッグします。
キャプションの配置 上/中央/下
詳細/簡略

キャプション アイコン

オプションはすべてのオブジェクトで使用できるわけではありません。

メニュー

オブジェクト メニューを開きます。

クリア

アクティブなリスト ボックスの現在の選択をすべてクリアします。

印刷

選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

データ コピー

シート オブジェクトの項目値をコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

画像をクリップボードにコピー

シート オブジェクトを画像としてクリップボードにコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

Excel 出力

絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

最小化を許可する

このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。

自動最小化

このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。

最大化を許可する

このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する][最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。

ヘルプ テキスト

ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。このオプションはドキュメント レベルでは使用できません。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
シート オブジェクトの説明などを入力できます。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。

クイック切替

ここではチャートの種類の切り替えを有効にできます。チャートの種類によっては、このオプションは無効です。ポップアップを開くには をクリックします。

[クイック切替の設定] ポップアップ

クイック切替を使用して切り替えたいチャートの種類のチェック ボックスをオンにします。

折れ線グラフ プロパティ: オプション

オプション

オプションはすべてのオブジェクトで使用できるわけではありません。

読み取り専用 チャートを読み取り専用にします。これにより、チャート内でマウスを使用してクリックまたはペイントしても選択できなくなります。
移動/サイズ変更を許可する このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
コピー/複製を許可する このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。すべてのクライアントでこの設定を処理できるとは限りません。
データにサイズを合わせる 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。
INFO アイコンをキャプションに表示する Info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。リスト ボックス、統計ボックス、マルチ ボックス、入力ボックスでのみ利用できます。
スクロール バーの位置を保持する このチェックボックスおよび ユーザー プロパティオブジェクト ダイアログにある付随するチェック ボックスをオンにすると、テーブル オブジェクトで選択されたときに、QlikView が垂直スクロールの位置を保持します。
条件付き表示の使用 シート オブジェクトは、選択などで断続的に評価される条件式に基づいて表示/非表示にされます。シート オブジェクトはその条件がを返したときにだけ表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
標準 シート オブジェクトの 高さ を設定し、その位置を指定します。
最小化 最小化されたシート オブジェクトの 高さ を設定し、その位置を指定します。
詳細/簡略

オプション

所有者 所有者のドメインとユーザー ID。
オブジェクトの共有 他のユーザーとのオブジェクトの共有を有効にします。この選択を有効にすると、以下の設定が有効になります。
共有者 [共有する][ユーザーを指定して共有する] のいずれかを選択します。
ユーザー (Domain\UserID) [ユーザーを指定して共有する] を選択すると、追加されたユーザーのリストが表示されます。ユーザーを追加するにはをクリックします。行が追加されますのでその行を強調表示してロックを解除し、ユーザー情報を編集します。ユーザーを削除するには、削除する各ユーザーの後ろにある をクリックします。