ファネル チャート - AJAX/Webview

ファネル チャートは通常、データをフローおよびプロセスで表示するために使用します。表示の観点から見ると、このチャートは円グラフと関連しています。チャートは、データに比例したセグメントの高さ/幅またはセグメントの領域で表示されます。また、データ点を無視して、セグメントの高さ/幅が均一なチャートを描画することもできます。

ファネル チャート:[オブジェクト] メニュー

シート オブジェクト上で右クリックするか、オブジェクトのキャプション (表示されている場合) で アイコンをクリックすると、コンテンツ メニューとしてオブジェクト メニューが開きます。

メニューに含まれるコマンドは、QlikView ローカル クライアントで WebView を開いているか、Web ブラウザでドキュメントにアクセスして開いているかによって異なります。メニューには以下のコマンドがあります。

プロパティ

アクティブなシート オブジェクトの プロパティ ダイアログが開きます。

ノート

現在のオブジェクトに関するノートの作成および共有ができます。

参照項目: ノートとコメント

分離設定 チャートのタイトルに "(分離)" と表示され、ドキュメントで選択が行われてもチャートは更新されません (チャートで選択を行うことは可能です)。コマンドはチャートが分離されていない場合にのみ有効です。チャートのコピーを作成して分離すると、コピーとオリジナルで直接的な比較を行えます。
分離解除 分離設定されたチャートを解除します。チャートは同時にデータにリンクされます。コマンドはチャートが分離されている場合にのみ有効です。
参照設定 このオプションを選択して、チャートの参照 (現在の選択を使用したチャートの固定プロット) を設定します。ドキュメントでさらに選択を行っても、参照プロットは残り、背景に淡色表示されます。チャートの軸等は、常に背景のデータ セットと現在のデータ セットの最大値に調整されます。現在のデータ セットは、常に参照プロットの前面にプロットされます。つまり、参照プロットの一部は、現在のデータ セットのプロットによって隠される場合があります。参照チャート プロットの表示は、一部のチャートの種類 (棒グラフ、折れ線グラフ、コンボ チャート、レーダー チャート、散布図、グリッド チャート、および針を使用するゲージ チャートなど) でのみ可能です。ドリルダウンやサイクリック グループを含むチャートでは [参照設定] は利用できません。ドキュメントを閉じるか、データをリロードすると、参照は失われます。[参照設定] オプションの使用時に含めることができるオブジェクトの最大数は 500 です。
参照解除 参照が設定されると、参照設定 コマンドがこのコマンドに置き換えられます。これを選択すると、以前に設定した参照がクリアされ、チャートが通常のプロット モードに戻ります。
すべての選択をクリア

アクティブなリスト ボックスの現在の選択をすべてクリアします。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

コピー

選択したシート オブジェクトをクリップボードにコピーします。この関数はデータや画像ではなく、シート オブジェクトのみをコピーします。

印刷

選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

Excel 出力

絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。オブジェクトのキャプション (表示されている場合) で アイコンをクリックしても同じ結果になります。

エクスポート

名前を付けて保存 ダイアログが開き、出力されたデータを保存する場所、ファイル名、ファイルの種類を指定できます。

クイック切替

現在のチャートを別の種類のチャートに変更することができます。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。[チャートのクイック切替][プロパティ] ダイアログの [キャプション] タブで有効になっている場合にのみ利用できます。

最小化

オブジェクトをアイコン化します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最小化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。

元のサイズに戻す

最小化または最大化したオブジェクトを直前のサイズと場所に戻します。最小化オブジェクトのアイコンをダブルクリックする、または最大化オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは最小化または最大化オブジェクトでのみ使用できます。

最大化

オブジェクトをシート全体に拡大します。オブジェクトのキャプション (表示されている場合) でアイコンをクリックしても同じ結果になります。このコマンドは、最大化が [オブジェクト プロパティ] ダイアログの [キャプション] ページで許可されている場合にのみ使用できます。

削除

選択されたオブジェクトをシートから削除します。

ファネル チャート プロパティ

プロパティ ダイアログを開くには、オブジェクト メニューから プロパティ を選択します。 プロパティ コマンドが淡色表示されている場合、プロパティの変更を行うために必要な権限がありません。

ドロップダウン リストで軸を選択します。軸を追加するにはをクリックします。ドロップダウンで軸を選択します。アイコンでリスト内の項目を移動します。アイコンでリストから項目を削除します。詳細については、[詳細] ボタンをクリックしてください。

有効条件

このチェック ボックスを使って軸を動的に表示/非表示にするには、入力した条件式の値に応じて下の編集ボックスの ボタンをクリックします。

現在選択されている軸を削除します。

ラベルの表示

x- 軸に軸ラベル (項目名) を表示するには、このチェック ボックスをオンにします。

NULL 値を隠す

このチェック ボックスをオンにすると、上の [軸] で選択した項目の値が NULL の場合、チャートにその項目は表示されません。

すべての値を表示

すべての軸項目値 (論理的な除外値も含む) をチャートに表示するには、このチェック ボックスをオンにします。

軸ラベルの表示 (Show Axis Labels)

選択した軸項目の x- 軸に凡例 (項目値の名前) を表示するには、このチェック ボックスをオンにします。

軸ラベルの文字制限

軸およびチャートの凡例に表示する軸の値の文字列長を制限するには、このチェック ボックスをオンにします。入力項目で文字数を指定、またはスライダを希望する数値までドラッグします。チャートでは、切り捨てられた値の後に、... が置かれます。このオプションは、このグループの他のオプションに関係なく使用できます。

トレリス設定の第 1 軸

このチェック ボックスをオンにすると、トレリス チャートが有効になり、第 1 軸を基準にチャートが配列表示されます。

固定列数

トレリス チャートに表示する列数を入力します。入力フィールドで列数を指定するか、スライダを希望する数値までドラッグします。

固定行数

トレリス チャートに表示する行数を入力します。入力項目で行数を指定、またはスライダを希望する数値までドラッグします。

第 2 軸

トレリス チャートの第 2 軸を有効にします。第 2 軸を使用する場合、第 1 軸の値はマトリックス内の列として表示され、第 2 軸はマトリックス内の行として表示されます。

ソート


シート オブジェクトの値のソート順を設定します。シート オブジェクトによっては、ソートのオプションが無いものもあります。
複数のソート順が指定されている場合の優先順位は、選択状態、数式、レコード数、数値、テキスト、ロード順となります。ステートは論理状態 (選択値、連結値、または除外値) を参照します。

第 1 ソート順

Y-軸値
Y- 軸の数値に基づいて軸の値をソートするかどうかを設定します。このオプションは計算軸には使用できません。
レコード数
項目値をレコード数 (テーブル内に現れる数) でソートします。
数値
値を数値順にソートします。
テキスト
項目値をアルファベット順にソートします。
ロード順
項目値を最初のロード順でソートします。

第 2 ソート順

レコード数
項目値をレコード数 (テーブル内に現れる数) でソートします。
数値
値を数値順にソートします。
テキスト
項目値をアルファベット順にソートします。
ロード順
項目値を最初のロード順でソートします。

数式によるソート

入力された数式によって項目値をソートします。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

選択値を上部に配置

選択値を上部に配置するには、これを有効にします。

制限

最初の数式を使った表示値の制限

これらのプロパティは、下で行った設定に応じて、チャートに表示される軸値の数を決定するために使用します。

表示のみ

このオプションは、[最初] あるいは [最大][最小] の値をいくつ (x 個) 表示させたいかによって選択します。このオプションを 5 に設定すると、5 つの値が表示されます。軸の [「その他」の表示] が有効になっている場合、[その他] セグメントには 5 つの値のいずれかひとつが表示されます。

[最初] オプションは、プロパティ ダイアログの [ソート] タブで選択したオプションに基づき、行を返します。チャートがストレート テーブルの場合は、列はその時の第 1 ソート順に基づいて返されます。つまり、列見出しをダブルクリックしてその列を第 1 軸ソートにすると、値の表示を変更できます。

[最大] オプションは、チャートの最初の数式に基づいて降順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

[最小] オプションは、チャートの最初の数式に基づいて昇順で行を返します。チャートがストレート テーブルの場合は、数式をソートしながらも、表示される軸の値は一貫しています。数式の順序が変更されると、軸の値も変更されます (変更される可能性があります)。

表示する値の数を入力します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
[境界値を含める] を選択すると、比較値を含有する軸の値が含まれます。

次の値のみ表示

このオプションを選択すると、このオプションで指定した条件に合うすべての軸の値を表示します。合計値のパーセンテージ、または正確な値に基づいて値を表示するのに使用します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にします。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

次に累積する値のみ表示

このオプションを選択すると、現在の行まですべての行を累積し、その値をオプションで設定した値と比較します。[合計と比較] オプションは、[プロパティ] ダイアログの [数式] タブにある [相対] オプションに類似した相対モードを有効にし、累積値 (最初の値または最大値、最小値に基づく) と全体の合計値を比較します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

「その他」の表示

このオプションを有効にすると、チャートに [その他] セグメントを作成できます。表示を制限する比較基準を満たさない軸の値は、すべて [その他] セグメントにまとめられます。選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

選択した軸の後に軸がある場合は、[内部軸の折りたたみ] によりチャートに後続の軸や内部の軸の個別の値を表示するか決定します。

「合計」の表示

このオプションを有効にすると、チャートには選択した軸の合計が表示されます。この合計値は [プロパティ] ダイアログの [数式] タブで設定されますが、数式の合計とは異なります。

ラベル
チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

グローバル グループ化モードの使用

このオプションは内部軸にのみ適用されます。このオプションを有効にすると、制限は選択した軸に基づいてのみ計算されます。前の軸はすべて無視されます。このオプションを無効にすると、制限は前のすべての軸に基づいて計算されます。

数式

ドロップダウン リストから数式を選択します。数式を追加するにはをクリックします。ドロップダウンから数式を選択します。アイコンでリスト内の項目を移動します。アイコンでリストから項目を削除します。詳細については、詳細 ボタンをクリックしてください。

数式

 

[数式] タブ

数式

有効化

このチェック ボックスをオンにすると、選択した数式が有効になります。ボックスがオンにされていない場合は、数式を使用できません。

条件付き表示

このチェック ボックスをオンにすると、編集ボックスの下にある ボタンをクリックして入力した条件式の値に応じて、レポートが動的に表示または非表示にされます。

ラベル

数式のラベル。チャートに表示する名前を入力します。テキストを入力しない場合は、自動的にラベルが数式のテキストに設定されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

数式

現在選択されている式を削除します。

コメント

数式の目的と機能を説明するコメントを入力します。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

表示しない

式を非表示にします。

パーセント表示 (相対)

チャートの結果表示を絶対数ではなくパーセントにします。

値表示の設定

値の表示形式を定義するには、このチェック ボックスをオンにします。クリック をクリックします。

[値の表示設定] ポップアップ

データ点の値の表示

数式の結果をデータ点の上側にテキストとして表示するには、このチェック ボックスをオンにします。


数式値のポップアップ

レイアウトでチャート内のデータ点にポインタを置いたときに表示されるポップアップ バルーン メッセージに数式の結果を表示するには、このチェック ボックスをオンにします。このオプションは、他の表示オプションの使用に関係なく使用できます。このため、数式をチャート自体には表示せず、ポインタを置いたときに表示されるポップアップにのみ表示することができます。


属性式のスタイル

背景色
データ ポイントの基本的な描画色を計算する属性式を定義します。 使用される数式は、有効な色表現 (Visual Basic で定義された赤、緑、青の色要素を表す数値) を返します。色表現は、通常、特別な チャート カラー関数 のいずれかを使用して作成します。数式の結果が有効な色表現でない場合は、黒が使用されます。

 
タイトルの表示 デフォルトでは、定義する最初の数式のラベルがチャート タイトルとして設定されます。チャート タイトルを表示しない場合は、チェック ボックスをオフにします。動的に更新する計算式としてタイトルを指定することもできます。をクリックして [数式の編集] ダイアログを開きます。
詳細/簡略 隠された補助タブを展開/折りたたみするには、このボタンをクリックします。アクティブな項目が [軸] または [数式] かによって表示されるタブは異なります。

ファネル チャート プロパティ: プレゼンテーション

プレゼンテーション

色のスタイル チャートの色のスタイルを設定します。
方向 チャートの方向を設定します。
先端の幅 (%) ファネルの先端の幅を入り口の幅に対するパーセンテージで定義します。
方向の反転 ファネルの先端を左または上向きにする場合は、このチェック ボックスをオンにします。
凡例の表示 チャートに凡例を表示します。ポップアップを開くには をクリックします。
背景 チャートの背景を設定します。次のオプションを使用できます。

プロット エリアに背景色を付けます。色を選択するには をクリックします。
画像
プロット エリアの背景に画像を表示します。画像を変更するには をクリックします。
動的画像
計算式を入力し、選択によって動的に変化する画像を背景に表示します。
背景の透過性 チャートの透過性を設定するには、ボックスに値を入力するかスライダーをドラッグします。
詳細/簡略

基本設定

ポップアップ ラベル

このチェック ボックスをオンにすると、チャートのデータ点上にカーソルを置いたときに、軸の値と数式がポップアップ バルーンとして表示されます。

データの均整表示

この設定は、基底のデータにセグメントが比例する程度を制御します。
セグメントの高さを同じにする
データの均整表示を行いません。各セグメントは、他のすべてのセグメントと同じ高さ (水平のファネルの場合は、同じ幅) で描画されます。通常、チャートに数値が表示される場合のみ意味があります。
セグメントの高さをデータに比例させる
各セグメントは、基底のデータに比例した高さ (水平のファネルの場合は、幅) で描画されます。
セグメントの領域をデータに比例させる
各セグメントは、基底のデータに比例した合計面積で描画されます。

演算実行条件

ここに入力された数式には、チャートが計算されるために満たす必要がある条件を設定します。条件が満たされない場合は、"演算実行条件が満たされていません" というテキストがチャートに表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。

スタイル

凡例

凡例の色を設定するには をクリックします。フォントの色を設定するには をクリックします。フォントの種類を設定するには をクリックします。

チャート タイトルのスタイル

チャート タイトルのフォントの色を設定するには をクリックします。フォントの種類を設定するには をクリックします。

キャプションのフォント

キャプションのフォントの種類を設定するには をクリックします。

アクティブ時のキャプション

アクティブ時のキャプションの背景色を設定するにはをクリックします。テキストの色を設定するには をクリックします。

非アクティブ時のキャプション

非アクティブ時のキャプションの背景色を設定するにはをクリックします。テキストの色を設定するには をクリックします。

枠線の使用

シート オブジェクトの周囲に枠線を表示するには、このチェック ボックスをオンにします。枠線の色を設定するには をクリックします。

枠線の幅

枠線の幅を設定するには、値を指定するかスライダーをドラッグします。幅は、ピクセル単位で指定します。

角を丸くする

をクリックして [角を丸くする] ポップアップを開きます。

注:

角を丸くする を使用できるのは、ドキュメント プロパティ: 基本設定スタイルのモード詳細設定 が選択されている場合のみです。

[角を丸くする] ポップアップ

選択

[固定]

または

[相対値]

を選択し、丸くしたい角を選択します。また、値を入力して

[鋭度]

を選択します。 

テキスト

チャートのテキスト

チャートにテキストを追加するには をクリックします。

テキスト

チャートのテキスト に追加されたテキストはここに表示されます。

角度

テキストの角度を 0 ~ 360 度に指定できます。デフォルトは 0 です。

水平位置

水平方向の配置を設定します。

常に手前に表示

チャートの描画時に、リストで現在選択されているテキストが前面に表示されます。

テキストのスタイル

テキストの背景色を設定するには をクリックします。
フォントの色を設定するには をクリックします。フォントの種類を設定するには をクリックします。

サイズと位置

オブジェクト上のテキストのサイズと位置を設定します。

 ファネル チャート プロパティ: キャプション

キャプション

ラベル テキスト ボックスで、シート オブジェクトのキャプションに表示するタイトルを入力します。ラベル を設定しない場合、キャプションの表示 が選択されていると、項目の名前が使用されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
キャプションの表示 このチェック ボックスをオンにすると、シート オブジェクトの最上部にキャプションが表示されます。リスト ボックスなどの「ボックス オブジェクト」は、デフォルトでキャプションの表示がオンになっていますが、ボタン、テキスト オブジェクト、線/矢印オブジェクトはオフになっています。
キャプションの配置 左/中央/右
複数行のキャプション (文章の折り返し) このオプションを選択した場合、テキストは 2 行以上で表示されます。
行数 キャプションで複数行がオンの場合に、入力項目で行数を指定、またはスライダを希望する数値までドラッグします。
キャプションの配置 上/中央/下
詳細/簡略

キャプション アイコン

オプションはすべてのオブジェクトで使用できるわけではありません。

メニュー

オブジェクト メニューを開きます。

クリア

アクティブなリスト ボックスの現在の選択をすべてクリアします。

印刷

選択したシート オブジェクトを別のブラウザ ウィンドウに表形式で開きます。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

データ コピー

シート オブジェクトの項目値をコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

画像をクリップボードにコピー

シート オブジェクトを画像としてクリップボードにコピーします。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

Excel 出力

絞込値 (選択値を含む) を Microsoft Excel にエクスポートします。このとき Excel が実行していなければ自動的に起動されます。出力された値は、新しい Excel ワークシートに 1 つの列として表示されます。この機能が動作するには、コンピューターに Microsoft Excel 2007 以降がインストールされている必要があります。 この設定はすべてのクライアントに有効という訳ではありませんのでご注意ください。

最小化を許可する

このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最小化アイコンが表示され、オブジェクトを最小化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最小化することができるようになります。

自動最小化

このオプションは、[最小化を許可する] をオンにしている場合にのみ有効です。同じシート上にある複数のシート オブジェクトで [自動最小化] がオンにされている場合、1 つを除くすべてが自動的に最小化されるようになります。これは、同じシート上に複数のグラフを交互に表示するのに便利です。

最大化を許可する

このチェック ボックスをオンにすると、シート オブジェクトのキャプション ウィンドウに最大化アイコンが表示され、オブジェクトを最大化することができます。さらに、キャプションをダブルクリックしてもオブジェクトを最大化することができるようになります。[最小化を許可する][最大化を許可する] の両方がオンの場合、ダブルクリックするとオブジェクトは最小化されます。

ヘルプ テキスト

ここには、ポップアップ ウィンドウに表示するヘルプ テキストを入力できます。このオプションはドキュメント レベルでは使用できません。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
シート オブジェクトの説明などを入力できます。オブジェクトのウィンドウ キャプションにヘルプ アイコンが追加されます。マウス ポインターをアイコンに移動させると、ポップアップ ウィンドウにテキストが表示されます。

クイック切替

ここではチャートの種類の切り替えを有効にできます。チャートの種類によっては、このオプションは無効です。ポップアップを開くには をクリックします。

[クイック切替の設定] ポップアップ

クイック切替を使用して切り替えたいチャートの種類のチェック ボックスをオンにします。

ファネル チャート プロパティ: オプション

オプション

オプションはすべてのオブジェクトで使用できるわけではありません。

読み取り専用 チャートを読み取り専用にします。これにより、チャート内でマウスを使用してクリックまたはペイントしても選択できなくなります。
移動/サイズ変更を許可する このチェック ボックスをオフにすると、シート オブジェクトを移動またはサイズ変更できなくなります。
コピー/複製を許可する このチェック ボックスをオフにすると、シート オブジェクトのコピーを作成できなくなります。すべてのクライアントでこの設定を処理できるとは限りません。
データにサイズを合わせる 通常、選択によってテーブルのサイズがシート オブジェクトに割り当てられたサイズより小さくなった場合は、QlikView のすべてのテーブル シート オブジェクトを囲む枠線が縮小します。このチェック ボックスをオフにすると、このサイズの自動調整はオフになり、余分な領域は空白のままになります。
INFO アイコンをキャプションに表示する Info 関数が使用されると、項目値がそれに連結する情報を持っている場合に INFO アイコンがウィンドウのキャプションに表示されます。キャプションに INFO アイコン を表示したくない場合は、このチェックボックスをオフにします。リスト ボックス、統計ボックス、マルチ ボックス、入力ボックスでのみ利用できます。
スクロール バーの位置を保持する このチェックボックスおよび ユーザー プロパティオブジェクト ダイアログにある付随するチェック ボックスをオンにすると、テーブル オブジェクトで選択されたときに、QlikView が垂直スクロールの位置を保持します。
条件付き表示の使用 シート オブジェクトは、選択などで断続的に評価される条件式に基づいて表示/非表示にされます。シート オブジェクトはその条件がを返したときにだけ表示されます。 値は、計算式として入力できます。をクリックして [数式の編集] ダイアログを開きます。
標準 シート オブジェクトの 高さ を設定し、その位置を指定します。
最小化 最小化されたシート オブジェクトの 高さ を設定し、その位置を指定します。
詳細/簡略

オプション

所有者 所有者のドメインとユーザー ID。
オブジェクトの共有 他のユーザーとのオブジェクトの共有を有効にします。この選択を有効にすると、以下の設定が有効になります。
共有者 [共有する][ユーザーを指定して共有する] のいずれかを選択します。
ユーザー (Domain\UserID) [ユーザーを指定して共有する] を選択すると、追加されたユーザーのリストが表示されます。ユーザーを追加するにはをクリックします。行が追加されますのでその行を強調表示してロックを解除し、ユーザー情報を編集します。ユーザーを削除するには、削除する各ユーザーの後ろにある をクリックします。