# Excel ピボット テーブルの作成

Excel テーブルの列またはレベルを使用して Excel ピボット テーブルを作成できます。

Qlik Sense ピボットテーブルは、Qlik NPrinting で画像としてのみ追加できます。QlikView ピボットテーブルは、画像およびストレート テーブルとして追加できます。どちらもレポートで Excel ピボット テーブルに変換できません。Excel レポートにピボット テーブルを再現する場合、次の 2 つの方法のうち 1 つを実行できます:

* 元のピボット テーブルをストレート テーブルに変換します。
* ピボット テーブルのクローンを作成し、クローンをストレート テーブルに変換します。

情報メモこのヘルプ トピックでは、ネイティブ Excel ピボット テーブルの作成においてサポートされている唯一の方法について説明します。

## Excel テーブルの列を使用したピボット テーブルの作成

Excel レポートでピボット テーブルを作成するには、Excel テーブルの列を使用することをお勧めします。レベルを使用するよりも簡単で、レポートの生成速度が低下することはありません。

情報メモ

ピボット テーブルをソース データ テーブルの横に配置することはできません。データ テーブルの上、下、または別のシートに配置してください。

### 要件

Qlik NPrinting Designer でピボット テーブルを作成するには、次のものが必要です。

* Excel 2007 以降
* Qlik Sense または QlikView ストレート テーブル

### 内容

次を行います:

1. QlikView ストレート テーブルをテーブル オブジェクトとして Excel レポートに追加します。
2. 列ごとのテーブルの構築
3. そのテーブルをピボット テーブルに変換します。

このチュートリアルでは、[サンプル ファイル](https://help.qlik.com/ja-JP/nprinting/May2026/Content/NPrinting/Examples/Examples.htm) にある QlikView データを使用します。独自の Qlik Sense または QlikView データを使用することもできます。

### 新規 Excel レポートの作成

以下を実行します。

1. Qlik NPrinting メイン メニューで [レポート] を選択してから、[レポートの作成] をクリックします。
2. レポートに [タイトル] を入力します。
3. [タイプ] ドロップダウン リストから [Excel] を選択します。
4. [アプリ] ドロップダウン リストからアプリを選択します。
5. [作成] をクリックしてレポートを作成します。
6. [テンプレートの編集] をクリックして [テンプレート エディター] を開きます。

### 列ごとにテーブルとしてチャート オブジェクトを追加

以下を実行します。

1. [表] ノードを右クリックし、[オブジェクトの追加] を選択します。

2. ストレート テーブルを含む [接続] を選択します。

3. テーブル オブジェクトを選択します。例: Straight Country - Salesman - Year。[OK] をクリックします。

4. [テーブル] ノードで、Straight Country - Salesman - Year を選択します。

5. [プロパティ] ペインで、Keep Source Formats をクリアします。

6. Straight Country - Salesman - Year の横にある + をクリックします。

   これによりテーブル ノードが展開され、すべてのテーブル列が表示されます。

7. Shift キーまたは Ctrl キーを押しながら、追加する列を選択します。この例では、4 つのテーブル フィールドをすべて選択します。

8. 列をテンプレートにドラッグします。

   ![レベルがテーブルとして追加された Excel レポート テンプレート。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_1AddTable.png)

9. 列見出し、テーブル タグ、および下の 1 つの空の行を強調表示します。

10. [Excel] リボンの [挿入] タブをクリックします。

11. [テーブル] グループで、[テーブル] をクリックします。

12. [先頭行をテーブルの見出しとして使用する] ボックスがオンになっていることを確認します。[OK] をクリックします。

    ![レベルがテーブルとして追加された Excel レポート テンプレート。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_2ConTable.png)

13. 左側のペインで、[Extras] をクリックします。テーブルの下の空の行のセルに deleterow タグをドラッグします。

    これにより、最終レポートから空の行が削除されます。

    ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_3DeleteRow.png)

### ピボット テーブルへの変換

以下を実行します。

1. 見出しとテーブル フィールドのセルを強調表示します。

2. Excel リボンの [テーブル ツール] の下で [デザイン] タブをクリックします。

3. [ツール] グループで、[ピボット テーブルで要約]をクリックします。

4. [ピボットテーブルの作成] ウィンドウで、[OK] をクリックします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot1.png)

   新しいワークシートにピボット テーブルが作成されます。同じワークシートにピボット テーブルを追加して、データで列を非表示にすることもできます。

5. [Year] フィールドを[列] ボックスにドラッグします。

6. [Salesman] および [Country] フィールドを [行ラベル] ボックスにドラッグします。

7. [Sales] フィールドを [値] ボックスにドラッグします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot2.png)

8. [Count of Total sales] をクリックしてドロップ ダウン メニューを開きます。[値フィールドの設定] を選択します。

   ![レベルがテーブルとして追加された Excel レポート テンプレート。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot3.png)

9. [集計方法] タブで、[合計] を選択します。[OK] をクリックします。

10. テーブルで、売上値を含むセルを選択します。それらを通貨として書式設定します。

    ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_6FormatCurren.png)

### レポートを開いたときにデータが更新されるようにする

これらの手順を実行しない場合、生成されたレポートに空のピボット テーブルが表示されます。

以下を実行します。

1. ピボット テーブル ツール - [分析] タブ。左側の [オプション] ドロップ ダウン メニューをクリックします。

2. [データ] タブを選択します。

3. [ファイルを開くときにデータを更新する] チェック ボックスをクリックします。

4. [1 フィールドに保持するアイテム数] が [None] に設定されていることを確認します。

5. [OK] をクリックします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot4.png)

### レポートのプレビュー

以下を実行します。

1. [プレビュー] をクリックします。

   Excel が起動してレポートを表示します。

2. ピボット テーブルを含むレポートが作成されます。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_5Preview.png)

3. [保存して閉じる] をクリックしてテンプレートを保存し、[テンプレート エディター] を閉じます。

## レベルを使用したピボット テーブルの作成

レベルを使用してピボット テーブルを作成できますが、これによりレポートの生成時間が遅くなります。この方法は、テーブル列の追加をサポートしていない Excel のバージョン（2003 以前）を使用している場合にのみ使用してください。

### 内容

1. QlikView ストレート テーブルをレベル オブジェクトとして Excel レポートに追加します。
2. レベルを使用してテーブルを構築します。
3. そのテーブルをピボット テーブルに変換します。

このチュートリアルでは、[サンプル ファイル](https://help.qlik.com/ja-JP/nprinting/May2026/Content/NPrinting/Examples/Examples.htm) にある QlikView データを使用します。独自の Qlik Sense または QlikView データを使用することもできます。

### テンプレートへのレベルの追加

以下を実行します。

1. 既存の Excel レポートを開くか、新しいレポートを作成します。

   参照: [作成](https://help.qlik.com/ja-JP/nprinting/May2026/Content/NPrinting/ExcelReports/Pivot-table-Excel.htm#Creating)

2. [レベル] ノードを右クリックし、[レベルの追加] をクリックします。

3. レベル リストで [Straight Country - Salesman - Year] を選択します。[OK] をクリックします。

4. [CH205\_Level - Straight Country-Salesman-Year] ノードを空のテンプレート セルにドラッグします。これによりレベルの開始タグと終了タグが作成されます。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev.png)

5. CH205\_Level - Straight Country-Salesman-Year ノードの横にある + をクリックします。

6. &lt;CH205\_Level&gt; タグおよび &lt;/CH205\_Level&gt; タグの間の行にある空のセルに [Country]、[Salesman]、[Year]、[Sales] ノードをドラッグします。

   [プロパティ] パネルで、これらのオブジェクト 4 つすべてに対して [Keep Sources Formats] (ソース形式を保持) がオフになっていることを確認します。

   ![](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev2.png)

7. &lt;CH205\_Level&gt; タグの上の行の列の見出しを入力します。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev3.png)

情報メモ

計算軸または NULL 値を含む QlikView オブジェクトは、レベルとして使用できます。ただし、シート オブジェクトのフィールドを除いて、他のオブジェクトをその中にネストすることはできません。Qlik Sense 計算軸を含むビジュアライゼーションをレベルとして使用することはできません。

### ピボット テーブルの作成

以下を実行します。

1. 次を含むセルの範囲を選択します。

   * 見出し
   * &lt;CH205\_Level&gt; 開始タグ
   * 列タグ
   * &lt;/CH205\_Level&gt; 終了タグ

2. Excel のリボンで、[挿入] タブを選択します。[テーブル] グループで [ピボットテーブル] を選択します。

3. [ピボットテーブルの作成] ウィンドウで、[OK] をクリックします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot1.png)

   新しいワークシートにピボット テーブルが作成されます。同じワークシートにピボット テーブルを追加して、データで列を非表示にすることもできます。

4. [Country] および [Salesman] フィールドを [行ラベル] ボックスにドラッグします。

5. [Year] フィールドを [列ラベル] ボックスにドラッグします。

6. [Sales] フィールドを [値] ボックスにドラッグします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot2.png)

7. [アクティブなフィールド] グループの [フィールドの設定] ボタンをクリックします。

8. [集計方法] タブの値を [合計] に変更します。[OK] をクリックします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot2.png)

9. テーブルで、売上値を含むセルを選択します。それらを通貨として書式設定します。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot3.png)

### レポートを開いたときにデータが更新されるようにする

これらの手順を実行しない場合、生成されたレポートに空のピボット テーブルが表示されます。

以下を実行します。

1. ピボット テーブル ツール - [分析] タブ。左側の [オプション] ドロップ ダウン メニューをクリックします。

2. [データ] タブを選択します。

3. [ファイルを開くときにデータを更新する] チェック ボックスをクリックします。

4. [1 フィールドに保持するアイテム数] が [None] に設定されていることを確認します。

5. [OK] をクリックします。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot4.png)

### レポートのプレビュー

以下を実行します。

1. [プレビュー] をクリックします。

   Excel が起動してレポートを表示します。

2. ピボット テーブルを含むレポートが作成されます。

   ![ピボット テーブルを使用した Excel レポート テンプレートの作成。](https://help.qlik.com/ja-JP/nprinting/May2026/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_5Preview.png)

3. [保存して閉じる] をクリックしてテンプレートを保存し、[テンプレート エディター] を閉じます。