メイン コンテンツをスキップする

のシステム要件Qlik NPrinting Engine

このページ上

のシステム要件Qlik NPrinting Engine

このセクションでは、Qlik NPrinting Engine の最小ハードウェア要件および最小ソフトウェア要件を示します。

Qlik NPrinting Engine は物理マシンと仮想マシンの両方にインストールできます。いずれの設定でも、仮想化アプリケーションは対応していません。たとえば、QlikView Desktop とは異なるコンピューターにインストールされている場合、Qlik NPrinting Engine は機能せず、仮想化アプリケーションとして配布されます。

既定の設定では、それぞれの Qlik NPrinting Server ライセンスで利用できるのは単一の Qlik NPrinting Engine のみです。Qlik NPrinting 環境にエンジンをさらに追加したい場合には、該当のエンジンを購入する必要があります。

要件

これらの Qlik NPrinting Engine 要件は、各 Qlik NPrinting コンポーネントを個別のコンピューターにインストールする構成のためのものです。同一のコンピューターに複数のコンポーネント (サーバーとエンジンなど) をインストールする場合は最小要件が上がります。

  • プラットフォーム:
    • Microsoft Windows Server 2012
    • Microsoft Windows Server 2012 R2
    • Microsoft Windows Server 2016
    • Microsoft Windows Server 2019
  • プロセッサー (CPU): 少なくとも 2 コアを搭載したマルチコア x64 互換のプロセッサー。
  • メモリー: 各コアあたり 2 GB、合計で最低 4 GB の RAM が必要です。
    • QlikView Desktop には、レポート データ ソースとして使用する QlikView 文書の管理に十分なメモリが必要です。
    • 1 つの MultiDoc レポートは、多くの QlikView 文書のデータを使用したレポートです。MultiDoc レポートを作成すると、データ ソースとして使用されているすべての QlikView 文書が同時に開きます。

    • 追加の Qlik Sense サーバーを接続すると、Qlik NPrinting Server システム リソースに影響があります。複数の Qlik Sense に接続する場合は、Qlik Qlik NPrinting Engine および Qlik NPrinting Server コンピューターの RAM と CPU の使用率を上げる必要がある場合があります。

  • ディスク容量: 300 MB 以上
  • ストレージ:Windows ストレージ (ローカルまたは共有) のみがサポートされています。
  • サーバー クロック:

    Qlik NPrinting Server サーバーのクロックと Qlik NPrinting EngineWindows サーバーのクロックは、2 秒の許容範囲で同期化する必要があります。Windows サーバーのクロックは、ドメイン コントローラーのクロックと同期します。そのため、Qlik NPrinting ServerQlik NPrinting Engine が同じドメイン内にあれば、クロックが同期されます。このオプションは手動で削除しないでください。Qlik NPrinting Server および Qlik NPrinting Engine を異なる Windows サーバーのドメインにインストールしている場合、クロックが 2 秒の許容範囲で同期化されるようにしてください。

  • プラットフォーム セキュリティ:TLS 1.2 を有効化する必要があります。
  • 注: ライセンス認証は Qlik Licensing Service へのアクセスを要求します。ポート 443 を開き、license.qlikcloud.com への発信を許可します。

    プロキシの使用がサポートされています。Windows でのプロキシ サービスの設定の詳細については、ライセンス サービス プロキシのセットアップ を参照してください

QlikViewQlik NPrinting との互換性

QlikView DesktopQlikViewQlik NPrinting との接続に必要で、Qlik NPrinting Engine コンピューターにそれぞれインストールされている必要があります。

サーバーあるいはクラスター接続を使用する場合、QlikView ServerQlikView Desktop は同じバージョンである必要があります。

次に示すバージョンの QlikViewQlik NPrinting との接続に対応しています。

  • QlikView November 2017 (12.20) 以降

  • QlikView November 2018 (12.30) SR1 以降

  • QlikView April 2019 (12.40) 以降

  • QlikView April 2020 SR2 (12.50 SR2) 以降
  • QlikView May 2021 (12.60) 以降
  • 警告: QlikView Desktop Personal Edition はサポートされていません。
    警告: Qlik Sense の SaaS エディションの QlikView はサポートされていません。

QlikView NPrinting 16 から Qlik NPrinting November 2019 以降へ移行する際に、QlikView のバージョンをアップグレードする必要がある場合があります。参照先:移行前の QlikView NPrinting 16 のアップグレード

Qlik SenseQlik NPrinting との互換性

Qlik NPrinting に接続すると、次の Qlik Sense バージョンがサポートされます。Qlik NPrinting のバージョンは、Windows バージョンの Qlik Sense と同じかそれより新しくなければならないことに注意してください:

  • Qlik Sense Enterprise on Windows November 2017 以降。
  • Qlik Sense 3.1.2 以降に接続するには、Qlik NPrinting 17.2.1 以降が必要です。

  • Qlik Sense アプリへの接続を作成する場合は Qlik Sense 2.3 以降が必要です。

  • Qlik Sense ハブにレポートを配信するには、Qlik Sense 3.0.1 以降が必要です。

  • 複数の Qlik Sense サーバーに接続している場合は、Qlik Sense 3.1 以降が必要です。

Qlik SenseQlik NPrinting に接続する際、クライアント ソフトウェアは必要ありません。

注: SaaS editions of Qlik SenseQlik Sense Enterprise on KubernetesQlik NPrinting への接続にはサポートされていません。

インストールされるその他のソフトウェア

次のソフトウェアは、既にインストールされている場合を除き、Qlik NPrinting Engine のセットアップ時にインストールされます。以下を削除しないでください:

  • PDF X-CHANGE 5.0.269
  • .NET フレームワーク: 4.7.2 以降

    Qlik NPrinting ServerQlik NPrinting Engine または Qlik NPrinting Designer をインストールすると、.NET フレームワーク バージョン 4.7.2 がインストールされます。 .NET フレームワーク バージョン 4.7.2 のインストールにはアクティブなインターネット接続が必要です。インターネット接続がないコンピューターに既に .NET フレームワーク バージョン 4.7.2 以降がインストールされていない場合、インストールは失敗します。Qlik NPrinting ServerQlik NPrinting Engine または Qlik NPrinting Designer をインストールする前に、.NET フレームワーク バージョン 4.7.2 以降をインターネット接続のないコンピューターにインストールする必要があります。.NET フレームワーク バージョン 4.7.2 以降が既にインストールされているコンピューター上にインターネット接続がない場合、インストーラーはインストールのこの部分をスキップします。