# QlikView ドキュメントへの接続

QlikView サーバーへのアクセス権があれば、サーバー上の任意の QlikView ドキュメントに接続できます。

情報メモこのページでは特定の QlikView ドキュメントを Qlik NPrinting に接続する方法を説明します。Qlik NPrinting をインストールするために QlikView サーバーに接続しようとしている、または証明書をインストールしようとしている場合には、次の項を参照してください:[Qlik NPrinting と QlikView との接続](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/DeployingQVNprinting/NPrinting-with-QlikView.htm) (英語のみ)。

## サポートされていない QlikView オブジェクト

次のオブジェクトは Qlik NPrinting でサポートされていません:

* 代替ステート

* トリガー: シート、ドキュメント、オブジェクト内

* [Always one selected] リスト ボックスとマルチ ボックス プロパティ

* フィルター、サイクル、レベル、ページの AND モード（計算済み）フィールド

* 「アクション」を含むボタンはトリガーとして機能します

* コンテナ内のコンテナ

* サード パーティのエクステンション オブジェクト

* 代替 ID: qvp://&lt;servername&gt;/qwvs/salesdemo.qvw など

* バンドルされた qmem パッケージ

* WebView モード

  参照先:[AJAX/WebView](https://help.qlik.com/ja-JP/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Ajax/WebView_Introduction%20to%20WebView.htm)

これらのオブジェクトを含む QlikView ドキュメントへの接続を作成すると、接続は機能しません。

サポートされていないオブジェクトの詳細については、[対応していない Qlik オブジェクト](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/ReportsDevelopment/Qlik-objects-supported-NP.htm#objects) (英語のみ) を参照してください。

### On-Demand レポート

On-Demand レポートは複数の QlikView ドキュメントに接続できません。

On-Demand レポートを生成している場合、次のものを使用する QlikView ドキュメントへの接続を作成することはできません。

* データを選択するためのトリガーとして入力ボタンから使用される変数選択
* 入力ボックス
* 計算軸
* 非表示のタブ

### トラブルシューティング

Qlik NPrinting はこれらのオプションを変更または削除できません。その結果、Qlik NPrinting はキャッシュ生成およびレポートの生成の際に、接続された QlikView ドキュメントのデータ セット全体にアクセスできない場合があります。

サポートされていない機能を持つ QlikView ドキュメントを使用する場合は、機能を削除したコピーを作成します。

以下を実行します。

1. QlikView ドキュメントのコピーを作成する。
2. 新しい QlikView ドキュメントから対応していない機能をすべて削除する。WebView モードがオフになっていることを確認する。
3. レポート用にはコピーされた QlikView ドキュメントを使用する。

## 要件

Qlik NPrinting Server と少なくとも 1 つの Qlik NPrinting Engine がインストールされ、有効化されている必要があります。

Qlik NPrinting QlikView 接続には、「QlikView 管理者」グループ オプションを使用してインストールされた QlikView サーバー展開が必要です。

## QlikView ドキュメントの接続ルール

QlikView ドキュメントへの接続には以下のルールが適用されます。

* 1 つの Qlik NPrinting アプリから複数の QlikView ドキュメントへの接続を作成できます。

* 接続は Qlik NPrinting アプリの間では共有できません。同じ QlikView ドキュメントを複数の Qlik NPrinting アプリに接続したい場合は、各アプリに対してそれぞれの接続を作成する必要があります。

* 接続を作成するには、該当の QlikView ドキュメントが以下のいずれかの場所に保存されていなければなりません。

  * お使いのローカル コンピューター
  * 共有ネットワーク フォルダー
  * ユーザーがアクセスする権限をもっている QlikView サーバー
  * QlikView クラスター

警告メモローカル QlikView ドキュメントではセクション アクセスに十分に対応していません。セクション アクセスを使用してローカル QlikView ドキュメントに接続しても、セクション アクセスが適用されていなかったかのように、使用可能なすべてのデータがレポート受信者に表示されます。ユーザーが許可されたデータのみを受信するようにするには、Qlik NPrinting フィルターを使用するか、QlikView Server を介してドキュメントに接続する必要があります。

## 接続ステータスの種類

[キャッシュ ステータス] 列には設定されている各接続に対して次のいずれかの値が表示されます:

* Never generated (未生成): 接続は一度も開かれていません。
* Pending (ペンディング):Qlik NPrinting は現在接続を試行中です。
* Generating (生成中):Qlik NPrinting の接続が確立されており、現在メタデータをインポート中です。
* Generated (生成済み): すべての Qlik NPrinting エンジンの接続に成功しました。
* Error (エラー): すべての利用可能なエンジンで接続エラーが発生しています。Qlik NPrinting スケジューラー サービス はエラーが発生してから 2 分後に再度接続を試みます。

[接続の状態] 列には設定されている各接続に対して次の値のいずれかが表示されます:

* すべての NPrinting エンジンの接続に成功しました。
* 警告: 1 つ以上のエンジンが動作していません。
* すべての NPrinting エンジンの接続に失敗しました。

接続ステータスおよび接続メタデータのリロードの詳しい情報については、次の項を参照してください: 「[接続メタデータのリロード](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/GettingStarted/HowCreateConnections/Reloading-connection-metadata.htm)」を参照してください。

## テストおよびトラブルシューティング

接続のテストには QlikView のサンプル ファイルである Sales Demo.qvw と Budget.qvw を使用できます。これらのファイルは [サンプル ファイル](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/Examples/Examples.htm) (英語のみ) からダウンロードできます。

警告、エラー、接続エラー のステータスはいくつかの方法で解消できます。まず、トラブルシューティングする接続を開き、[確認の実行] ボタンをクリックします。これにより当てはまる可能性のある問題の一覧が表示されます。これは、[ドキュメントのパス] が間違っているいないために承認エラーとなった場合の例です:

![確認ウィンドウ](https://help.qlik.com/ja-JP/nprinting/February2025/Content/Resources/Images/ex_ConnectionScreenVerificationFailureQV.png)

また確認事項として以下も挙げられます:

* 接続プロパティ: たとえば、QlikView ドキュメント パス、ユーザー名、およびパスワードを確認します。
* Qlik NPrinting Engine のインストールと設定: たとえば、QlikView Desktop 12 のエンジンは QlikView 11.2 サーバー上のドキュメントを開けません。また、サービスを実行している Windows ユーザーに対する有効なライセンスが QlikView Desktop にあることを確認してください。

問題を解決した後には必ず、キャッシュ生成を再実行するか、タスクを実行してください。

以下は接続エラーの一般的な原因です:

* [QlikView ドキュメントへの接続の設定時に接続エラーを確認する](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/Troubleshooting/Verify-connection-to-QlikView-errors.htm) (英語のみ)
* [接続ステータスのエラー](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/Troubleshooting/Connection-status-error.htm) (英語のみ)
* [に接続のステータスが表示されないQlik NPrinting ウェブ コンソール](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/Troubleshooting/Connection-status-not-shown-in-Qlik-NPrinting-Web-Console.htm) (英語のみ)
* [接続のタイムアウトと実行に長い時間がかかるタスク](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/Troubleshooting/Connection-timeouts-long-running-tasks.htm) (英語のみ)

## ローカル QlikView ドキュメントへの接続

以下を実行します。

1. [アプリ] メニューから [接続] をクリックします。

   [接続] ページが表示されます。

2. [接続の作成] をクリックして新しい接続ウィンドウを開きます。

3. [名前] フィールドに接続の名前を入力します。

   たとえば、｢Sales Demo｣と入力します。

4. [アプリ] ドロップダウン リストから、接続元となる Qlik NPrinting アプリを選択します。

5. [ドキュメントパス] フィールドに、接続先の QlikView ドキュメントへのパスを入力します。

   例: 「C:\NPrintingServer\QlikViewDocuments\Samples\Sales Demo.qvw」

   コンピューター上の Qlik NPrinting がインストールされているパスを使用します。

   警告メモマッピングされたネットワーク ドライブ (例: Z:\NPrintingServer\QlikViewDocuments) は Qlik NPrinting ではサポートされていません。代わりに、汎用名前付け規則 (UNC) パス (\\ServerName\NPrintingServer\QlikViewDocuments など) を使用する必要があります。

6. [タイプ] が [ローカル] に設定されていることを確認します。

7. プロンプトが表示されたら、QlikView ドキュメントのユーザー名とパスワードを入力します。

   Section Access でローカルの QlikView ドキュメントに接続する場合は、ADMIN ロールをもつユーザーの認証情報を入力する必要があります。入力されていない場合、キャッシュの生成はエラーで終了します。Windows ドメイン ユーザーはサポートされていません。Section Access ユーザーはスクリプトで定義されている必要があります。キャッシュが完了するよう、フィルターを適用せずにユーザーを使用することをお勧めします。

8. [確認の実行] ボタンをクリックします。これにより、接続の有効性が保証されます。

   接続が有効の場合、「確認が正常に完了しました」というメッセージが表示されます。表示されない場合は、次のメッセージが表示されます: 「エラーが検出されました。下記の詳細を確認してください。」

9. [通知] で、[メタデータのリロード終了時にメールを送信] を選択できます。[設定] &gt; [タスク] で指定されたアドレスにメールが送信されます。参照先: 「[タスク実行通知](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/AdministeringQVNprinting/Tasks/Task-executions.htm#Sending) (英語のみ)」を参照してください。

10. 接続設定を確認したら、[作成] をクリックします。[接続] メニューに自動的に戻されます。

11. 新しい接続をクリックします。ステータス「キャッシュ ステータス - 生成中」が表示されます。つまり、Qlik NPrinting が QlikView に接続し、メタデータをインポートします。QlikView ドキュメントの容量が大きい場合、これには数分かかる場合があります。

    ![接続キャッシュの生成ステータス](https://help.qlik.com/ja-JP/nprinting/February2025/Content/Resources/Images/PublishSimpleReportSenseTutorial/ex_PublishSimpleReportSenseTutorial_MetaPend.png)

12. キャッシュ ステータスが [生成済み] になったら、新しいレポート テンプレートを作成できます。ステータスが [エラー] になった場合は接続情報を確認します。

    ![接続キャッシュが生成されました](https://help.qlik.com/ja-JP/nprinting/February2025/Content/Resources/Images/PublishSimpleReportSenseTutorial/ex_PublishSimpleReportSenseTutorial_MetaGen.png)

これで、[接続] 画面に新しい接続が表示されます。

![接続キャッシュが生成されました](https://help.qlik.com/ja-JP/nprinting/February2025/Content/Resources/Images/PublishSimpleReportSenseTutorial/ex_PublishSimpleReportSenseTutorial_Connections.png)

### QlikView Server および QlikView クラスター の接続の前提条件

QlikView Server または QlikView クラスター の接続を使用してレポートを生成するには、以下が必要です:

* 1 台以上の QlikView Server へのアクセス。
* Qlik NPrinting Engine Windows サービスを実行する Windows ユーザーは、QlikView Server コンピューターの QlikView Administrators Windows グループに属している必要があります。
* Qlik NPrinting で [NTFS 認証] を用いるようにするには、Qlik 管理コンソール で設定する必要があります。つまり、Windows オペレーティング システムは NTFS セキュリティ設定を介してユーザーおよびグループのファイル (ドキュメント) アクセスをコントロールすることになります。
* DMS 認証を介する QlikView でファイル アクセスをコントロールするよう Qlik NPrinting を構成する場合は、「[DMS for Qlik NPrinting](https://help.qlik.com/ja-JP/nprinting/February2025/Content/NPrinting/DeployingQVNprinting/DMS-for-NP.htm) (英語のみ)」を参照してください。

section access も使用している場合は、以下も必要になります:

* サーバー認証を使用するよう接続を設定する必要がある。
* ドメイン アカウントは、Qlik NPrinting 全般設定で有効化された認証タイプと独立し、ユーザー設定で構成する必要があります。

## QlikView Server で QlikView ドキュメントに接続する

情報メモ .qvw ファイルを開くには、ライセンス許諾を受けた QlikView Server ならびにターゲットの QlikView ドキュメントへのアクセス権限が必要です。

情報メモQlik NPrinting を QlikView サーバー クラスターに接続するには、QlikView インストールでの認証を QlikView 管理者グループを使用して管理する必要があります。

以下を実行します。

1. [アプリ] メニューから [接続] をクリックします。

   [接続] ページが表示されます。

2. [接続の作成] をクリックします。

3. [名前] フィールドに接続の名前を入力します。

   たとえば、｢Sales Demo from Server｣と入力します。

4. [アプリ] ドロップダウン リストから、接続元となる Qlik NPrinting アプリを選択します。

   たとえば、Sales Demo を選択します。

5. [タイプ] として [サーバー] をクリックして指定します。

   [qvp://] フォームが表示されます。

6. [qvp://] フォームに、QlikView Server アドレス、続けて .qvw ファイル名を入力します。

   例: ServerAddress/DocumentName.qvw。

7. 必要に応じて、[接続には認証情報が必要] チェック ボックスを選択してから、[サーバー認証] または [ドキュメント認証] のいずれかを選択します。

   * サーバー認証: サーバーの接続に使用したドメイン ユーザーの資格情報を入力します。次の書式設定を使用します。

     ドメイン\ ユーザー名

     特定のユーザーのレポートを作成するときにユーザーの section access を適用するには、フラグ [レポートのユーザー section access を適用] を有効にします。

   * ドキュメント認証: ドキュメントに対する管理者権限をもつユーザーの [ユーザー名] と [パスワード] を入力します。

8. [確認の実行] ボタンをクリックします。これにより、接続の有効性が保証されます。

   接続が有効の場合、「確認が正常に完了しました」というメッセージが表示されます。表示されない場合は、次のメッセージが表示されます: 「エラーが検出されました。下記の詳細を確認してください。」

9. 接続設定を確認したら、[作成] をクリックします。[接続] メニューに自動的に戻されます。

10. 新しい接続をクリックします。ステータス「キャッシュ ステータス - ペンディング」が表示されます。つまり、Qlik NPrinting が QlikView に接続し、メタデータをインポートします。QlikView ドキュメントの容量が大きい場合、これには数分かかる場合があります。

11. キャッシュ ステータスが [生成済み] になったら、新しいレポート テンプレートを作成できます。ステータスが [エラー] になった場合は接続情報を確認します。

これで、[接続] 画面に新しい接続が表示されます。

### QlikView Server 接続のトラブルシューティング

1. QlikView Desktop および QlikView Server が、SR も含めて同じバージョンであることを確認します。
2. QlikView 管理コンソール で、マウントされたフォルダーが閲覧可能であることを確認します。
3. Qlik NPrinting 接続では、qvp://[[ユーザー名][@]]hostname[:ポート|;プロトコル]/docname の形式での疑似 URL の使用には対応していません。
4. 資格情報を確認します:
   1. Qlik NPrinting Engine サービスの実行に使用されたサービス アカウントをメモします。
   2. Qlik NPrinting Engine を実行しているマシンで、QlikView フォルダーを参照します。
   3. Shift キーを押しながら Qv.exe を右クリックします。
   4. [Run as different user] (別のユーザーとして実行) を選択します。
   5. 上記でメモしたサービス アカウントの資格情報を入力します。
   6. QlikView Desktop を Personal Edition として開いていないことを確認します。
   7. QlikView Server で [ファイル] &gt; [開く] をクリックします。QlikView ドキュメントを開きます。
   8. QlikView Desktop ヘッダーにあるパスとファイル名をメモし、Qlik NPrinting の接続設定で使用します。

## QlikView クラスター で QlikView ドキュメントに接続する

Qlik NPrinting が QlikView Server のクラスターに接続できます。これによって Qlik NPrinting Engine と QlikView Server のクラスターの間で負荷が分散され、レポート生成が最適化されます。

情報メモQlik NPrinting を QlikView サーバー クラスターに接続するには、QlikView インストールでの認証を QlikView 管理者グループを使用して管理する必要があります。

要件

QlikView Server クラスターへの接続を作成するには以下が必要です:

* 少なくとも 1 つのアクティブな QlikView Server のクラスター。

  複数のクラスターがある場合は、使用するクラスターを選択することができます。

* Qlik NPrinting Engine からアクセス可能な QMS および QVS コンピューター。

* 以下のユーザーで実行されている Qlik NPrinting Engine サービス:

  * ドメイン ユーザー

  * クラスターのすべてのノードにおける QlikView 管理者セキュリティー グループの一員。

  * QMS が実行されているコンピューターにおける QlikView 管理 API セキュリティ グループの一員。

    警告メモQlikView Management API のセキュリティ グループはインストール中には作成されないため、手動で作成して設定する必要があります。

QlikView クラスター 接続を設定するには、Qlik 管理コンソール で入手可能な次の情報が必要です:

* クラスター アドレスと ID は [システム] &gt; [セットアップ] にあります。

  * クラスター アドレスは [管理サービス] &gt; [サマリー] タブにあります。
  * クラスター ID は [QlikView Web Servers] の中にある QVWS サーバーを選択することで見つけられます。クラスター ID は [General] (一般) タブの [Name] (名前) フィールドにあります。

完全なドキュメントのパスも必要です。これは、QlikView Desktop にあります。

警告メモ [完全なドキュメントのパス] では大文字と小文字を区別する必要があります。

以下を実行します。

1. QlikView Desktop を起動し、[ファイル] &gt; [サーバーで開く] を選択してドキュメントを開きます。ローカル パスを使用してドキュメントを開かないでください。

2. [ヘルプ] &gt; [ドキュメント サポート情報] を選択します。

3. [ドキュメント情報] で、[ドキュメント] を見つけます。qvp:// で始まるテキストがあります。

4. 「qvp://」とサーバー名を削除して完全なドキュメントのパスを取得します。

   * qvp://&lt;servername&gt;/SalesDemo2017.qvw の場合、完全なドキュメントのパス は「SalesDemo2017.qvw」です。
   * ドキュメントがサブフォルダー内にある場合は、完全なドキュメントのパス の一部になっていなければなりません。例えば、qvp://&lt;servername&gt;/AppDemo/Sales/SalesDemo2017.qvw の場合、完全なドキュメントのパス は AppDemo/Sales/SalesDemo2017.qvw です。

以下を実行します。

1. [アプリ] メニューから [接続] をクリックします。

   [接続] ページが表示されます。

2. [接続の作成] をクリックします。

3. [名前] フィールドに接続の名前を入力します。

4. [説明] を入力します (任意)。

5. [アプリ] ドロップダウン リストから、接続元となる Qlik NPrinting アプリを選択します。

6. [タイプ] 行の [クラスター] ボタンをクリックして指定します。

   関連するフォームが表示されます。

7. [アドレス] フィールドに QMS のアドレスを挿入します。

8. 接続先クラスターの名前を [クラスターID] に入力します。

9. 大文字と小文字を区別して [完全なドキュメントのパス] を入力します。

10. 必要に応じて、[接続には認証情報が必要] フラグを有効し、[ID] を入力します。

11. 特定のユーザーのレポートを作成するときにユーザーの section access を適用するには、フラグ [レポートのユーザー section access を適用] を有効にします。

12. [確認の実行] ボタンをクリックします。これにより、接続の有効性が保証されます。

    接続が有効の場合、「確認が正常に完了しました」というメッセージが表示されます。表示されない場合は、次のメッセージが表示されます: 「エラーが検出されました。下記の詳細を確認してください。」

13. 接続設定を確認したら、[作成] をクリックします。[接続] メニューに自動的に戻されます。

14. 新しい接続をクリックします。ステータス「キャッシュ ステータス - ペンディング」が表示されます。つまり、Qlik NPrinting が QlikView に接続し、メタデータをインポートします。QlikView ドキュメントの容量が大きい場合、これには数分かかる場合があります。

15. キャッシュ ステータスが [生成済み] になったら、新しいレポート テンプレートを作成できます。ステータスが [エラー] になった場合は接続情報を確認します。

これで、[接続] 画面に新しい接続が表示されます。

## 接続の変更と削除

警告メモレポートまたはフィルターに関連付けられている接続を削除しようとすると、削除した場合には無効となる要素を列挙した、警告のためのポップアップ メッセージが表示されます。

以下を実行します。

1. [アプリ] メニューから [接続] をクリックします。

2. 変更または削除する接続をクリックします。

3. 1. 変更するには: 目的の変更を加え、[保存] をクリックします。

   2. 削除するには、the Delete icon をクリックします。

      警告メモこの操作を元に戻すことはできません。