Qlik Sense アプリからの複雑なレポートの公開

このチュートリアルでは、Qlik Sense データを使用して複雑な Qlik NPrinting Excel レポートを作成し公開する方法を説明します。

Qlik NPrinting には多くの機能があります。このチュートリアルの説明は、熟達したユーザーがレポートを作成できるようにするためのものであるため、すべてのレポート タイプ、デザイン要素、または公開オプションを概説しているわけではありません。このチュートリアルの終わりには、Excel レポートの作成、編集、および特定のユーザーに対する公開方法が理解できているはずです。

他の Qlik NPrinting チュートリアル:

注: Office ファイル形式でレポートの編集および作成を行うには、Microsoft Office をインストールしておく必要があります。

このチュートリアルでは以下の項目を学習します。

Qlik Sense アプリへのアクセス

レポートにはデータが必要です。Qlik Sense サンプル アプリをダウンロードしてインポートする方法を学習します。

Qlik NPrinting の Qlik Sense アプリへの接続 

Qlik NPrinting は該当の Qlik Sense アプリに接続できなければなりません。Qlik NPrinting をサンプル アプリまたは既存の Qlik Sense データにアクセスできるように構成する方法を学習します。

新規フィルターの作成

フィルターを使用するとデータを絞り込めます。ユーザーが閲覧できるデータを管理するためのフィルターを作成します。

新しい Qlik NPrinting レポート テンプレートの作成

レポート テンプレートはレポートのレイアウトとアウトプットを管理します。このセクションでは、新しく作成する方法を説明します。

レポート テンプレートの編集

レポートには、多くの異なる書式設定オプションがあります。タイトル、Excel テーブル、小計を含むテーブル、およびレベルをレポートに追加する操作を行います。

NewsStand への公開と電子メール

NewsStand は、ユーザーがアクセスしてレポートを表示できるウェブ コンソールです。NewsStand へのレポートの公開およびメールでの配信を自動化する方法を学習します。

Qlik Sense アプリへのアクセス

Qlik Sense アプリには、Qlik NPrinting でレポート構築に使用されるデータとビジュアライゼーションが含まれます。Qlik Sense アプリにはいくつかの方法でアクセスできます。

  • Qlik ヘルプ サイトから Qlik Sense アプリをダウンロードし、自分の Qlik Sense Apps フォルダーにアップロードできます。このチュートリアルではこのサンプル アプリにある多くの値や項目を参照します。このチュートリアルで説明する操作を初めて実行する場合には、カスタム アプリではなく提供されているアプリを使用した方が理解しやすくなります。
  • 独自の Qlik Sense アプリ を使用して Qlik NPrinting の Qlik Sense アプリへの接続  にスキップします。独自のアプリを使用してこのチュートリアルを完了する場合は、シンプルなものを選択します。Qlik Sense アプリが複雑な場合、Qlik NPrinting のロード時間は長くなります。

Qlik ヘルプ サイトからの Qlik Sense アプリのダウンロードと Qlik Sense へのインポート

以下を実行します。

  1. Qlik NPrinting ヘルプ サイトで サンプル ファイル に移動し、Sample file - Beginning with the Basics の .zip ファイルをコンピューター上の任意の場所にダウンロードします。
  2. Windows でフォルダーを解凍します。Beginner's tutorial.qvf が目的の Qlik Sense ファイルです。
  3. システム管理者にアプリを送信し、Beginner’s tutorial.qvfQMC にインポートするよう要求します。
  4. アクセスできるストリームにアプリを公開するようにシステム管理者に要求します。既定のストリーム (Everyone) に公開できます。

これで Qlik Sense ハブに Beginner's tutorial アプリが表示されるようになります。

Qlik NPrintingQlik Sense アプリへの接続 

ここでは、Qlik NPrinting アプリを作成して、Qlik Sense アプリに接続します。

Qlik Sense アプリと Qlik NPrinting アプリは大きく異なっています:

  • Qlik Sense アプリ: データが含まれており、ビジュアライゼーションを使用してそのデータを調査します。
  • Qlik NPrinting アプリ: レポート、フィルター、および Qlik Sense アプリまたは QlikView ドキュメントへの接続が含まれています。

Qlik NPrinting アプリは、Qlik NPrinting DesignerQlik Sense データにアクセスさせ、その情報をレポートで使用できるようにします。

注: Qlik NPrintingQlik Sense アプリに接続するには、Qlik Sense 証明書をすべての Qlik NPrinting Engine コンピューターにインストールする必要があります。参照:証明書のインストール

以下を実行します。

  1. Qlik NPrinting ウェブ コンソールにログインします。
  2. メイン メニューで [アプリ] ドロップダウン リストをクリックし、[アプリ] をクリックします。
  3. [アプリの作成] ボタンをクリックします。
    1. この新しいアプリの名前を入力します。例:Advanced Tutorial NP App
    2. [有効化] チェック ボックスがオンになっていることを確認します。そうしない場合、アプリは Qlik NPrinting Engine によって無視されます。
    3. [作成] をクリックします。

      これで、アプリ として Advanced Tutorial NP App が表示されるようになるはずです。

      Apps screen

  4. メイン メニューで [アプリ] ドロップダウン リストをクリックし、[接続] をクリックします。
    1. [接続の作成] ボタンをクリックします。
    2. [名前] ボックスに次の接続名を入力します。Advanced Tutorial Connection
    3. [アプリ] ドロップダウン リストから、以前に作成した次の Qlik NPrinting アプリを選択します。Advanced Tutorial NP App
    4. [ソース] として [Qlik Sense] を選択します。
    5. 次の情報を入力します。
      • プロキシ アドレス: Qlik Sense サーバーのフル コンピューター名。これは、ブラウザーのアドレス バーの Qlik Sense ハブにあります。https://sense_プロキシ_コンピューター_名.ドメイン_名 の形式です。
      • Qlik Sense アプリ ID: この情報は、アプリの概要ページでブラウザーのアドレス バーの Qlik Sense ハブにあります。

      • ID: アプリへのアクセス権を持つ Qlik Sense ユーザーの <Windows ドメイン名>\<ユーザー名>

    6. [確認の実行] ボタンをクリックします。これにより、接続の有効性が保証されます。

      接続が有効の場合、「確認が正常に完了しました」というメッセージが表示されます。表示されない場合は、次のメッセージが表示されます: 「エラーが検出されました。下記の詳細を確認してください。」

      Successful Qlik Sense connection verification screen.

    7. 接続設定を確認したら、[作成] をクリックします。[接続] メニューに自動的に戻されます。
    8. 新しい接続をクリックします。ステータス「キャッシュ ステータス - ペンディング」が表示されます。つまり、Qlik NPrintingQlik Sense に接続し、メタデータをインポートします。Qlik Sense アプリが大きい場合、これには数分かかる場合があります。
      注:

      Qlik Sense アプリに新しいオブジェクトを追加するたびに接続メタデータをリロードする必要があります。

    9. キャッシュ ステータスが [生成済み] になったら、新しいレポート テンプレートを作成できます。ステータスが [エラー] になった場合は接続情報を確認します。

これで、[接続] 画面に新しい接続が表示されます。

Successful generated Qlik Sense connection.

Qlik Sense アプリへの接続で問題が生じた場合は、次を参照してください:

新規フィルターの作成

静的フィルターでは Qlik Sense アプリからの項目に基づいてデータを絞り込むことができます。ここでは Product Group 項目から「Wine & Beer」という名前のフィルターを作成します。このフィルターを適用したテーブルや画像には、ワインとビールに関連する結果のみが表示され、他の製品タイプはすべて無視されます。

以下を実行します。

  1. メイン メニューで [アプリ] ドロップダウン リストをクリックし、[フィルター] を選択します。
  2. [フィルターの作成] をクリックします。
  3. フィルターの [名前] を入力します。例:Wine & Beer
  4. [アプリ] から [Advanced Tutorial NP App] を選択します。
  5. [作成] をクリックします。

    Filter creation screen.

  6. フィルター メニューで [フィールド] をクリックします。
  7. [フィールドの追加] をクリックします。
  8. [接続] から該当の接続を選択します。
  9. [名前] の下の [製品グループ] を選択します。

    [ 値の上書き] はオフのままにします。

  10. [] エリアに [] を残します。このオプションを選択すると、指定した値のリストを選択するよう Qlik NPrinting を強制します。
  11. 該当の値を入力し始めます。一致する可能性のある値の一覧が表示されます。ここでは「Alcoholic Beverages」を選びます。
  12. [作成] をクリックします。

    Adding a field to a filter.

新しい Qlik NPrinting レポート テンプレートの作成

レポート テンプレートはレポートのレイアウトとアウトプット形式を管理します。選択したレポート タイプの標準のオプションを使用して、オブジェクトを配置したり、ページの書式を設定したりできます。例えば、Excel レポートの書式設定オプションとインターフェースは、Excel ワークシートの場合と同じです。

以下を実行します。

  1. Qlik NPrinting ウェブ コンソールのメイン メニューで [レポート] をクリックします。
  2. [レポートの作成] ボタンをクリックします。
  3. [タイトル] フィールドにタイトルを入力します。例:Advanced Tutorial Excel
  4. [タイプ] ドロップダウン リストから、[Excel] を選択します。
  5. [アプリ] ドロップダウン リストから [Advanced Tutorial NP App] を選択します。
  6. [テンプレート] オプションで、[空のファイル] をクリックします。
  7. [有効化] チェックボックスがオンになっていることを確認します。そうしない場合、レポートは Qlik NPrinting Engine によって無視されます。
  8. [動的命名を有効にする] チェック ボックスをクリックします。これによりレポート名に変数値を追加できるようになります。

    これらのフィールド要素は、右にあるソート ハンドルを使用して順序を変更できます。

  9. 変数値が少なくともひとつ必要です。[レポート名] を選択します。
  10. [変数値の追加] をクリックします。[ユーザーの部署] を選択します。
  11. [変数値の追加] をクリックします。[カスタム] を選択します。表示されるテキスト ボックスにハイフンまたはアンダースコアを追加します。
  12. [変数値の追加] をクリックします。[日付] を選択します。日付の形式を選択します。
  13. [プレビュー] ペインに動的なレポート名が表示されます。
  14. [作成] をクリックします。

    Creating a report template with dynamic naming.

これで、レポート として [Advanced Tutorial Excel] が表示されるようになるはずです。

レポート テンプレートの編集

レポート テンプレートを編集する方法は数多くあります。ここでは、次のものを追加します:

  • タイトル: レポートを整理するために使用するシンプルなテキスト。Excel の標準書式を使用して変更することができます。
  • レベル: データを軸で細分します。テーブルと画像に適用できます。
  • テーブル: Qlik Sense データを取得してテーブル形式で表示します。Excel テーブルの作成、および Qlik Sense テーブルのインポートが可能です。
  • オブジェクト フィルター: オブジェクト内に表示されるデータ (チャートやテーブルなど) を絞り込みます。

このセクションでは、Qlik NPrinting Designer でできるすべてのことを説明してはいません。Excel の他のレポート機能については、「Excel レポート」を参照してください。

注: レポートのプレビューは、適用されている書式設定によってはここで示されている画像と異なる場合があります。一部のオブジェクト名が、選択した順に応じてわずかに異なる場合があります。

以下を実行します。

  1. Qlik NPrinting web console のメイン メニューで [レポート] をクリックします。
  2. [レポート] 画面でレポートをクリックします。
  3. [テンプレートの編集] ボタンをクリックして Qlik NPrinting Designer テンプレート エディターを開きます。

    Edit report template button.

  4. セル A1 に、タイトルを入力します: 例: Quarterly trends and customer sales by region

    ヒント: これらのタイトルの外観は Excel の書式設定オプションで変更できます。たとえば、フォントのサイズや色を変更できます。いくつかのセルをマージして統合し、タイトルがレポートの中心に来るようにすることもできます。
  5. レベルの追加:
    1. 左側のパネルで [Levels] (レベル) を右クリックし、[Add levels] (レベルの追加) を選択します。
    2. 新しいウィンドウが開きます。[Region] を選択します。[OK] をクリックします。

    3. Region_Level をセル A2 にドラッグします。
    4. </Region_Level> タグを切り取ってセル A17 に貼り付けます。

      これらのタグ内にあるオブジェクトは領域別に分けられます。

    5. 左側のパネルで Region_Level を展開します。
    6. セル A4 に [Region] をドラッグ アンド ドロップします。

      これにより、各レベルに見出しがあることが保証されます。

  6. Excel テーブルの追加:
    1. セル A6 に次のサブタイトルを追加します:Quarterly trends
    2. 左側のパネルで [Tables] (テーブル) を右クリックし、[Add objects] (オブジェクトの追加) を選択します。
    3. 新しいウィンドウが開きます。[Quarterly Trend] を選択します。[OK] をクリックします。
    4. 左側のパネルで [TFWPC - Quarterly Trend] を選択します。これにより、下の [プロパティ] パネルが開きます。
    5. [Keep Source Formats] チェック ボックスのチェックを外します。

      これにより Qlik Sense の書式設定がテーブルから削除されるため、カスタマイズ可能になります。

    6. [Show Headers] を [タグ セルの上に表示] に設定します。
    7. 列ヘッダーがタグ セルに挿入され、データが下の行から始まるようになります。元の Qlik Sense ヘッダーの数式と変数は置き換えられません。

    8. [TFWPC - Quarterly Trend] をセル A8 にドラッグします。まだ選択されていない場合には、[TFWPC] タグを含むセルを選択します。
    9. [Excel] ツール バーの [挿入] タブをクリックします。
    10. [テーブル] グループの [テーブル] アイコンを選択します。[OK] をクリックします。

    11. [テーブル ツール] > [デザイン] の順に選択し、テーブルの書式設定を適用します。
      • ヘッダー セルに適用されたフォントと配置の書式設定は、ヘッダー行のすべてのテーブル セルに適用されます。
      • コンテンツ セルに適用されたフォントと配置の書式設定は、コンテンツ行のすべてのテーブル セルに適用されます。
      • 数値の書式設定は影響しません。
    12. Qlik NPrinting Designer ツール バーの [プレビュー] をクリックし、テーブルのプレビューを表示します。

      Excel テーブルは並べ替えおよびフィルター処理が可能になっています。ただし、数字は書式設定できません。

  7. 小計を含むテーブルの追加:
    1. セル A11 に次のサブタイトルを追加します:Customer sales
    2. 左側のパネルで [Tables] (テーブル) を右クリックし、[Add objects] (オブジェクトの追加) を選択します。
    3. 新しいウィンドウが開きます。[Customer Sales and Quantity] を選択します。[OK] をクリックします。
    4. 左側のパネルの [Customer Sales and Quantity] を選択します。これにより、下の [プロパティ] パネルが開きます。
    5. [Keep Source Formats] チェック ボックスのチェックを外します。
    6. 新しい [Customer Sales and Quantity] ノードを展開します。
    7. [Customer - Customer ] をセル A13 に、そして [JWaPFv - Sales] をセル B13 にドラッグします。
    8. セル A15 に次のように入力します:Region total。セル B15 に次の数式を追加します: =SUM(B14)

      セル B15 を通貨として表示されるように書式設定します。

      Designer, edit template screen.

  8. 小計およびフィルターを含むテーブルの追加:
    1. Excel ワークブックに新しいシートを追加します。
    2. 新しいシートに移動します。セル A1 に次のサブタイトルを追加します:Wine and beer sales by region
    3. 左側のパネルで [Levels] (レベル) を右クリックし、[Add levels] (レベルの追加) を選択します。
    4. 新しいウィンドウが開きます。[Region] を選択します。[OK] をクリックします。
    5. Region_Level をセル A2 にドラッグします。
    6. </Region_Level> タグを切り取ってセル A17 に貼り付けます。
    7. 左側のパネルで Region_Level を展開します。
    8. セル A4 に [Region] をドラッグ アンド ドロップします。

      これにより、各レベルに見出しがあることが保証されます。

    9. 左側のパネルで [Tables] (テーブル) を右クリックし、[Add objects] (オブジェクトの追加) を選択します。
    10. 新しいウィンドウが開きます。[Product Treemap] を選択します。[OK] をクリックします。
    11. [Product Treemap] ノードをクリックします。[プロパティ] > [フィルター] の下の [¥] をクリックします。[Beer and Wine] フィルターを選択します。

      これにより、この新しいテーブルにはビールとワインに関連する製品のみが表示されるようになります。

      [Keep Source Formats] チェック ボックスのチェックを外します。

    12. [Product Treemap] ノードを展開します。
    13. [Product Type] をセル B5 に、[Item Desc] をセル C5 に、そして [Sales] をセル D5 にドラッグします。
    14. セル C7 に次のように入力します:Region total。セル D7 に次の数式を追加します: =SUM(D6)
    15. セル C10 に次のように入力します:Total sales。セル D10 に次の数式を追加します: =SUM(D6:D8)/2
    16. セル D7 と D10 の両方を選び、通貨として表示されるように書式設定します。

      Designer, report template edit screen

  9. Qlik NPrinting テンプレート エディター メニューで、[ファイル] タブをクリックします。[保存] をクリックします。
  10. [テンプレート] タブをクリックし、[プレビュー] ボタンをクリックすると、レポートをプレビューできます。

    レポートのサイズによっては、プレビューにロードされるのに数分かかる場合があります。[中止] ボタンをクリックすると、プレビューの生成をストップできます。

    Report preview screen

    Report preview screen, second sheet.

    警告: プレビュー モードで行った編集は保存されません。
  11. 編集を続行する場合は、プレビュー ウィンドウを閉じ、レポートの書式をテンプレート エディターで設定します。
  12. 編集が終わったら、[保存して閉じる] をクリックします。

これでレポート テンプレートを保存できるようになり、ユーザーと共有する準備ができました。

NewsStand への公開と電子メール

レポートにユーザーがアクセスするには、レポートを公開する必要があります。ここでは NewsStand にメールで公開します。

NewsStand はユーザーがレポートをプレビューおよびダウンロードしたり、自動更新をサブスクライブできるウェブ ポータルです。参照先: NewsStand の概要

メールにはレポートが添付ファイルとして含まれます。その内容は、テキストや画像を追加してカスタマイズできます。参照先: 「メールでのレポートの配信」を参照してください。

ここではトリガーの作成も行います。トリガーを設定することで、スケジュールに基づいてレポートを自動的に公開できるようになります。

注: Qlik NPrinting からメールを送信するには、SMTP メール サーバーを設定する必要があります。参照先: 「SMTP サーバーの設定」を参照してください。

以下を実行します。

  1. Qlik NPrinting ウェブ コンソールのメイン メニューで [タスク] をクリックし、[タスクの公開] を選択します。
  2. [タスクの作成] ボタンをクリックします。

    1. 名前を入力します。例:Publish Advanced Tutorial
    2. ドロップダウン リストからアプリを選択します。Advanced Tutorial NP App
    3. 他のオプションは既定値のままにします。[作成] をクリックします。

      Publish task overview screen.

  3. [レポート] タブをクリックします。
    1. [レポートの追加] ボタンをクリックします。
    2. [レポートの選択] ドロップダウン リストから Advanced Tutorial Excel を選択します。
    3. [出力形式] ドロップダウン リストから [XLS] を選択します。
    4. [メールに添付] および [有効] チェック ボックスが選択されていることを確認します。
    5. [レポートの追加] をクリックします。

      Adding a report to a publish task.

  4. [ユーザー/グループ] タブをクリックします。
    1. [ユーザーまたはグループの追加] ボタンをクリックします。
    2. [受信者の選択] ドロップダウン リストからユーザーまたはグループを選択します。

      新しいユーザーの作成する方法を学習する場合は、次を参照してください: 「ユーザーの作成」を参照してください。

    3. [有効]、[NewsStand 展開先]、および [メール展開先] チェック ボックスを選択します。
    4. [受信者の追加] をクリックします。
  5. [展開先] タブをクリックします。
    1. NewsStand 列で、[すべてに公開] チェック ボックスをクリックします。
    2. [メール] 列で、[すべてに公開] チェック ボックスをクリックします。
    3. [保存] をクリックします。
  6. メール テンプレートのカスタマイズ:
    1. メイン タスク メニューで [メール メッセージ] をクリックします。
    2. [差出人] で次のいずれかを選択します:
      • ユーザー: ドロップダウン リストから差出人メールを選択します。検索フォームを使用してリストをフィルターすることもできます。
      • [カスタム]: 有効なメール アドレスを入力します。

    3. [受信者] ドロップダウン リストから [Selected users] (指定されたユーザー) を選択します。
    4. [件名] を入力します。
    5. [HTML] (書式設定および動的テキストをサポートする形式) をクリックし、メールの [形式] を HTML に設定します。

    6. メールの本文となる文字列を入力します。本文は書式設定用の一連のボタンでカスタマイズできます。
    7. [ユーザー] をクリックし、リストからタグを選択します。これらのタグはメール作成時に適切な値で置き換えられます。

      たとえば、%%User_Company%% は受信者の会社名で置き換えられます。この例では %%User_FullName%%%%User_Department%%、および %%User_Company%% が追加されています。

      ユーザー プロファイルにこの情報が含まれていない場合、メッセージには空のコンテンツが含まれることになります。参照先: 「ユーザーの作成」。

    8. [添付ファイル] ドロップダウン リストから [すべてのレポートを添付] を選択します。
    9. [保存] をクリックします。

      Email customization screen.

  7. トリガーの作成:
    1. メイン タスク メニューで [トリガー] をクリックします。
    2. [トリガーの作成] をクリックします。
    3. [名前] を次のように入力します:Tutorial Trigger
    4. [スケジュール] セクションで [スケジュールの種類] を選択します。このチュートリアルでは、[週次] を選びます。

      これにより、タスクは毎週、指定された曜日に自動的に実行されるようになります。

    5. [1 日のうちの頻度] の [1 回] をクリックします。既定の時刻はそのままにしておいてください。
    6. [開始] セクションでは [開始日] とトリガーで指定された時刻の [タイムゾーン] を設定できます。[既定の開始日] はトリガーが作成された日です。
    7. [作成] をクリックして新しいトリガーをリポジトリに保存します。

      Trigger creation interface

  8. [概要] ページに戻ります。
  9. [今すぐ実行] ボタンをクリックします。

    ページの一番上に確認メッセージが表示されます。

受信者がブラウザーで NewsStand に移動し、レポートを表示できるようになりました。また、そのコピーもメールで届きます。トリガーを作成したことによって、設定したスケジュールに従いユーザーも更新されたレポートを週に一度受信できるようになります。

ヒント: 標準のインストールでは、ブラウザーのアドレス バーで 4993 番ポートを 4994 番ポートに変更することで、Qlik NPrinting Web Console から NewsStand に切り替えることができます。例えば、Web Console へのパスが https://YourServerName:4993 の場合なら、 NewsStand へのパスは https://YourServerName:4994 です。

NewsStand