# Finestra di dialogo Modifica espressione

Per aprire la finestra di dialogo Modifica espressione, fare clic sul pulsante Aggiungi visualizzato sotto l'elenco delle espressioni in Proprietà grafico: Espressioni, oppure fare clic con il pulsante destro del mouse su un'espressione esistente e scegliere Aggiungi espressione o Modifica espressione.

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Define_Expression.htm)Sebbene sia utilizzata prevalentemente nelle espressioni grafiche, questa finestra di dialogo viene utilizzata anche per la creazione o la modifica di altre espressioni, ovunque le espressioni siano richieste. È possibile accedervi da qualsiasi finestra o scheda del programma semplicemente facendo clic sul pulsante con i tre punti di sospensione visibile accanto a qualsiasi casella di modifica.

La finestra si compone principalmente di un'area di modifica delle espressioni, le cui dimensioni possono essere adattate in base alla lunghezza delle espressioni, e al di sotto di questa, di un'area suddivisa in quattro schede: Campi, Funzioni, Variabili e Immagini.

## Espressioni di scrittura

Nell'area di modifica per l'espressione selezionata, è possibile digitare l'intera espressione, tuttavia è più pratico creare gran parte dell'espressione nell'area delle schede descritta in basso. L'espressione deve iniziare con =.

L'etichetta Espressione OK viene visualizzata solo se la sintassi dell'espressione è accettata dal programma, ovvero quando l'espressione è valida. In caso contrario, verrà visualizzato uno dei diversi messaggi di errore (Nome campo errato, Errore nell'espressione, Dati indesiderati dopo l'espressione). Chiudere la finestra di dialogo facendo clic sul pulsante OK è di scarsa utilità a meno che l'espressione non sia valida.

## Opzioni scheda Espressione

La finestra di dialogo Modifica espressione contiene le seguenti opzioni per la creazione di espressioni.

### Campi

La scheda Campi contiene i controlli utilizzati per creare funzioni di aggregazione statistica basate su campi di dati.

Opzioni Campi

| Opzione | Descrizione |
| --- | --- |
| Aggregazione | La prima casella di riepilogo contiene un elenco delle funzioni di aggregazione statistica disponibili. Le funzioni Prima Stringa e Ultima Stringa, ad esempio, possono essere utilizzate per visualizzare testo in una tabella pivot. |
| Tabella | Questa casella di riepilogo consente di limitare a una sola tabella interna specifica i campi visualizzati nell'elenco Campo descritto di seguito. |
| Campo | Questa casella di riepilogo contiene un elenco di nomi di campo disponibili.<br><br>I campi MEASURE possono essere utilizzati solo con le funzioni di aggregazione di base Sum, Avg, Count, Min e Max. |
| Mostra campi di sistema | Selezionare questa casella per includere nell'elenco Campo i campi di sistema. |
| Distinto | Per impostazione predefinita, le funzioni statistiche sono calcolate in base al numero di ricorrenze. Se si seleziona l'opzione Distinto, l'espressione verrà calcolata senza valori duplicati. |
| Incolla | Fare clic su questo pulsante per immettere le proprie selezioni come componenti dell'espressione. |

### Funzioni

La scheda Funzioni contiene i controlli utilizzati per immettere funzioni generali di QlikView nell'espressione.

Opzioni Funzioni

| Opzione | Descrizione |
| --- | --- |
| Categoria Funzione | Questa casella di riepilogo consente di limitare a una sola categoria alla volta le funzioni visualizzate nell'elenco Nome Funzione descritto di seguito. |
| Nome funzione | Questa casella di riepilogo contiene un elenco di tutte le funzioni di QlikView disponibili (ad eccezione di un numero limitato di funzioni di script dedicate).<br>Il riquadro nella parte inferiore della scheda Funzioni mostra la sintassi degli argomenti della funzione selezionata. |
| Incolla | Fare clic su questo pulsante per immettere le proprie selezioni come componenti dell'espressione. |

### Variabili

La scheda Variabili contiene i controlli utilizzati per immettere variabili generali di QlikView nell'espressione.

Opzioni Variabili

| Opzione | Descrizione |
| --- | --- |
| Variabili | Questa casella di riepilogo contiene un elenco di tutte le variabili attualmente definite per il documento. |
| Mostra variabili di sistema | Selezionare questa casella per includere nell'elenco Variabili le variabili di sistema. |
| Incolla | Fare clic su questo pulsante per immettere le proprie selezioni come componenti dell'espressione. |

Nella parte inferiore della scheda Variabili è disponibile un riquadro in cui è visualizzato il valore corrente di qualsiasi variabile selezionata nell'elenco Variabili.

### Immagini

La scheda Immagini contiene i controlli utilizzati per accedere ai file interni disponibili in QlikView. È inoltre possibile accedere ad altri file di immagine associati. Tenere presente che questa funzionalità è limitata ad alcune parti della presentazione. A destra della scheda Immagini, un riquadro mostra l'immagine attualmente selezionata.

Opzioni Immagini

| Opzione | Descrizione |
| --- | --- |
| Cartella delle Immagini | Questa casella di riepilogo contiene un elenco di cartelle delle immagini disponibili. |
| Immagine | Questa casella di riepilogo contiene un elenco delle immagini disponibili nella cartella selezionata. |
| Avanzato... | Fare clic su questo pulsante per effettuare una selezione diretta tra le immagini della finestra di dialogo Selettore di Immagine. |
| Incolla | Fare clic su questo pulsante per immettere le proprie selezioni come componenti dell'espressione. |

## Opzioni menu Modifica espressione

La finestra di dialogo Modifica espressione contiene inoltre i seguenti comandi di menu e pulsanti.

### Menu File

Opzioni Menu File

| Opzione | Descrizione |
| --- | --- |
| Esporta su File di Espressione... | È possibile salvare il contenuto della casella di modifica Espressione come file di tabella selezionando il comando Esporta su File di Espressione. Il file verrà salvato con l'estensione .qve. |
| Inserisci File... | È possibile inserire nello script un'espressione precedentemente creata selezionando il comando Inserisci File... |
| Wizard Colori | È possibile creare un'espressione mista di colori utilizzando Wizard Colori. |
| Stampa | Consente di visualizzare la finestra di dialogo standard Stampa di Windows per stampare le espressioni. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+P. |

### Menu Modifica

Opzioni Menu Modifica

| Opzione | Descrizione |
| --- | --- |
| Annulla | Consente di annullare le ultime modifiche. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+Z. |
| Ripeti | Consente di ripetere le ultime azioni Annulla. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+Y. |
| Taglia | Consente di esportare il testo evidenziato negli Appunti. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+X. |
| Copia | Consente di copiare il testo evidenziato negli Appunti. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+C. |
| Incolla | Incolla il contenuto degli Appunti all'interno della finestra di dialogo, nella posizione indicata dal cursore. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+V. |
| Cancella | Consente di cancellare l'intera espressione. |
| Seleziona Tutto | Consente di selezionare l'intera espressione. |
| Trova/Sostituisci... | Consente di visualizzare una finestra di dialogo che consente di trovare e sostituire numeri o caratteri all'interno dell'espressione. È inoltre possibile richiamare questo comando utilizzando la combinazione di tasti di scelta rapida seguente: CTRL+F. |

### Menu Impostazioni

Opzioni menu Impostazioni

| Opzione | Descrizione |
| --- | --- |
| Configura... | Viene visualizzata Preferenze dell'utente: Editor. |

## Ulteriori informazioni

* [Espressioni grafiche](https://help.qlik.com/it-IT/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/chart-expressions.htm)
* [Sintassi di espressione per le formule calcolate](https://help.qlik.com/it-IT/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)