Wizard immissione dati

La finestra di dialogo Wizard immissione dati viene visualizzata dal menu Inserisci, Istruzione Load, Load Inline. In questa finestra è possibile creare istruzioni load inline nello script.

L'aspetto e il funzionamento della finestra sono per molti aspetti simili a quelli di un foglio di calcolo. Tuttavia, tenere presente che a differenza di Microsoft Excel, ad esempio, le formule di calcolo inserite in questo foglio di calcolo non vengono valutate.

Ogni colonna rappresenta un campo da caricare in QlikView tramite una tabella inline. Ogni riga è un record nella tabella. È possibile fare clic su una cella di dati per selezionarla. I valori possono quindi essere digitati o incollati dagli Appunti. Tramite INVIO o uno dei tasti freccia è possibile accettare il valore e passare alla cella successiva.

La riga più alta (etichetta) viene riservata alle etichette del campo. È possibile fare doppio clic su una cella di etichetta per modificarla. Se non vengono immessi valori nella riga dell'etichetta, verranno utilizzati i nomi di campo F1, F2 e così via.

Menu Modifica

Il menu Modifica contiene alcuni comandi di modifica.

Inserisci colonna Se si selezionano una o più colonne, consente di inserire una nuova colonna vuota.
Cancella colonna Consente di eliminare le colonne selezionate.
Inserisci riga Inserisci Colonna Se si selezionano una o più righe, consente di inserire una nuova riga vuota.
Cancella riga Consente di eliminare le righe selezionate.

Menu Strumenti

Il menu Strumenti contiene il comando Dati Documento grazie al quale è possibile visualizzare il Wizard per l'importazione di dati dal Documento per incollare i valori di campo da qualsiasi campo esistente nel documento. Nella finestra di dialogo vengono visualizzati i valori di campo disponibili in ciascun campo selezionato. Se si desidera, nella procedura guidata Autocomposizione di immissione, è possibile selezionare l'inserimento di tutti i valori, di quelli selezionati o di quelli esclusi.

Fare clic su OK per chiudere la finestra di dialogo e generare un'istruzione Load inline corrispondente ai contenuti della griglia della tabella relativa alla finestra di dialogo.