Pubblicazione di un report complesso da un'app Qlik Sense

Questo tutorial mostra come creare e pubblicare un report Excel di Qlik NPrinting complesso utilizzando dati di Qlik Sense.

Qlik NPrinting offre molte funzioni. Questo tutorial intende aiutare gli utenti esperti a creare un report. Il tutorial non descrive ogni tipo di report, elemento di progettazione o opzione di pubblicazione. Alla fine del tutorial si sarà creato, modificato e pubblicato un report Excel visualizzabile dagli utenti selezionati.

Altri tutorial di Qlik NPrinting:

Nota: Per creare e modificare report nei formati di file Office, è necessario che Microsoft Office sia installato.

In questo tutorial si eseguiranno le operazioni seguenti:

Accesso a un'app Qlik Sense

Per generare report sono necessari dati. Si vedrà come scaricare e importare un'app Qlik Sense di esempio.

Connessione di Qlik NPrinting a un'app Qlik Sense 

Qlik NPrinting deve connettersi a un'app Qlik Sense. Si vedrà come configurare Qlik NPrinting in modo che possa accedere a un'app di esempio o ai dati di Qlik Sense esistenti.

Creazione di un nuovo filtro

I filtri permettono di limitare i dati. Creare un filtro in modo da controllare i dati visti dagli utenti.

Creazione di un nuovo modello di report di Qlik NPrinting

I modelli di report controllano la presentazione e i formati di output dei report. Questa sezione mostrerà come creare un nuovo modello.

Modifica del modello di report

I report offrono molte opzioni di formattazione diverse. Si aggiungeranno titoli, tabelle Excel, tabelle con subtotali e livelli al report.

Pubblicazione in NewsStand e tramite email

NewsStand è una console Web alla quale gli utenti possono accedere per visualizzare i report. Si vedrà come automatizzare la pubblicazione del report in NewsStand e tramite email.

Accesso a un'app Qlik Sense

Le app Qlik Sense contengono i dati e le visualizzazioni utilizzati da Qlik NPrinting per creare i report. Esistono diversi modi per accedere a un'app Qlik Sense:

  • È possibile scaricare un'app Qlik Sense dal sito della guida di Qlik e caricarla nella cartella Apps dell'installazione di Qlik Sense in uso. Questo tutorial fa riferimento a diversi valori e campi presenti in quest'app di esempio. Se è la prima volta che si esegue questo tutorial, è consigliabile utilizzare l'app fornita, non una personalizzata.
  • È possibile utilizzare la propria app Qlik Sense e passare direttamente a Connessione di Qlik NPrinting a un'app Qlik Sense . Se si utilizza una propria app per completare questo tutorial, scegliere un'app semplice. Con le app Qlik Sense complesse i tempi di caricamento di Qlik NPrinting sono più lunghi.

Download di un'app Qlik Sense dal sito della guida di Qlik e importazione in Qlik Sense

Procedere come segue:

  1. Nel sito della guida di Qlik NPrinting selezionare File di esempio e scaricare il file ZIP Sample file - Beginning with the Basics nella posizione desiderata del computer in uso.
  2. Decomprimere la cartella in Windows. Beginner's tutorial.qvf è il file di Qlik Sense da utilizzare.
  3. Inviare l'app all'amministratore di sistema chiedendogli di importare Beginner's tutorial.qvf in QMC.
  4. Chiedere all'amministratore di sistema di pubblicare l'app in un flusso al quale si è in grado di accedere. L'app può essere pubblicata nel flusso predefinito, Everyone (Tutti).

L'app Beginner's tutorial sarà visualizzata nell'hub di Qlik Sense.

Connessione di Qlik NPrinting a un'app Qlik Sense 

A questo punto si creerà un'app Qlik NPrinting e la si collegherà all'app Qlik Sense.

Le app Qlik Sense sono molto diverse dalle app Qlik NPrinting:

  • App Qlik Sense: contiene dati e utilizza visualizzazioni per esplorarli.
  • App Qlik NPrinting: contiene report, filtri e la connessione a un'app Qlik Sense o a un documento QlikView.

Le app Qlik NPrinting permettono a Qlik NPrinting Designer di accedere ai dati di Qlik Sense in modo che le informazioni possano essere utilizzate in un report.

Nota: Per connettere Qlik NPrinting alle app Qlik Sense è necessario installare i certificati Qlik Sense in tutti i computer degli Engine di Qlik NPrinting. Vedere: Installazione dei certificati.

Procedere come segue:

  1. Accedere alla console Web di Qlik NPrinting.
  2. Nel menu principale fare clic sull'elenco a discesa App, quindi su App.
  3. Fare clic sul pulsante Crea app.
    1. Immettere un nome per questa nuova app. Ad esempio: Advanced Tutorial NP App.
    2. Verificare che la casella di controllo Abilitato sia selezionata. In caso contrario, l'app sarà ignorata da Qlik NPrinting Engine.
    3. Fare clic su Crea.

      L'app Advanced Tutorial NP App sarà visualizzata sotto App.

      Apps screen

  4. Nel menu principale fare clic sull'elenco a discesa App, quindi su Connessioni.
    1. Fare clic sul pulsante Crea connessione.
    2. Nella casella Nome immettere un nome per la connessione: Advanced Tutorial Connection.
    3. Nell'elenco a discesa App selezionare l'app Qlik NPrinting creata in precedenza: Advanced Tutorial NP App.
    4. Selezionare Qlik Sense come Sorgente.
    5. Immettere le seguenti informazioni:
      • Indirizzo proxy: nome completo del server Qlik Sense. Il nome è reperibile nell'hub di Qlik Sense, nella barra degli indirizzi del browser. Il formato è: https://nome_computer_proxy_sense.nome_dominio.
      • ID dell'app Qlik Sense: Questa informazione è reperibile nell'hub di Qlik Sense, nella barra degli indirizzi del browser o nella pagina riepilogativa dell'app.

      • Identità: <nome dominio Windows>\<nome utente> dell'utente di Qlik Sense che ha accesso all'app.

    6. Fare clic sul pulsante Esegui verifica per verificare che la connessione sia valida.

      Se la connessione è valida, verrà visualizzato il messaggio “Verifica riuscita”. In caso contrario verrà visualizzato il messaggio seguente: “Errori rilevati. Verificare i dettagli di seguito.”

      Successful Qlik Sense connection verification screen.

    7. Una volta verificate le impostazioni della connessione, fare clic su Crea. Si ritornerà automaticamente al menu Connessioni.
    8. Fare clic sulla nuova connessione. Verrà visualizzato lo stato: Stato cache - Generazione in corso. Ciò significa che Qlik NPrinting si sta connettendo a Qlik Sense e sta importando metadati. Se l'app Qlik Sense è di grandi dimensioni, l'operazione potrebbe richiedere alcuni minuti.
      Nota:

      Ogni volta che si aggiungono nuovi oggetti all'app Qlik Sense, è necessario ricaricare i metadati della connessione.

    9. Quando lo stato della cache diventa Generata, è possibile creare un nuovo modello di report. Se lo stato visualizzato è Errore, verificare le informazioni della connessione.

La nuova connessione sarà ora visibile nella schermata Connessioni.

Successful generated Qlik Sense connection.

In caso di difficoltà nella connessione all'app Qlik Sense, vedere:

Creazione di un nuovo filtro

I filtri statici permettono di limitare i dati in base a campi dell'app Qlik Sense. In questo caso si creerà un filtro denominato Wine & Beer dal campo Product Group. Una tabella o un'immagine con questo filtro applicato visualizzerà soltanto risultati relativi a vino e birra e ignorerà tutti gli altri tipi di prodotto.

Procedere come segue:

  1. Nel menu principale fare clic sull'elenco a discesa App, quindi selezionare Filtri.
  2. Fare clic su Crea filtro.
  3. Immettere un nome per il filtro. Ad esempio: Wine & Beer.
  4. Sotto App selezionare Advanced Tutorial NP App.
  5. Fare clic su Crea.

    Filter creation screen.

  6. Fare clic su Campi nel menu dei filtri.
  7. Fare clic su Aggiungi campo.
  8. Sotto Connessione selezionare la connessione creata.
  9. Sotto Nome selezionare Product Group.

    Lasciare Sostituisci valori deselezionato.

  10. Lasciare Il valore è nell'area Valori. Questa opzione fa sì che Qlik NPrinting selezioni l'elenco di valori specificato.
  11. Iniziare a digitare il valore desiderato. Sarà visualizzato un elenco di possibili valori. In questo caso scegliere Alcoholic Beverages.
  12. Fare clic su Crea.

    Adding a field to a filter.

Creazione di un nuovo modello di report di Qlik NPrinting

I modelli di report controllano la presentazione e i formati di output dei report. È possibile disporre gli oggetti e formattare le pagine utilizzando le opzioni standard del tipo di report scelto. Ad esempio, un report Excel avrà le stesse opzioni di formattazione e la stessa interfaccia di un foglio di calcolo Excel.

Procedere come segue:

  1. Nel menu principale della console Web di Qlik NPrinting fare clic su Report.
  2. Fare clic sul pulsante Crea report.
  3. Immettere un titolo nel campo Titolo. Ad esempio: Advanced Tutorial Excel.
  4. Nell'elenco a discesa Tipo selezionare Excel.
  5. Nell'elenco a discesa App selezionare Advanced Tutorial NP App.
  6. Nelle opzioni Modello fare clic su File vuoto.
  7. Verificare che la casella di controllo Abilitato sia selezionata. In caso contrario, il report sarà ignorato da Qlik NPrinting Engine.
  8. Fare clic sulla casella di controllo Abilita nome dinamico. Questo consente di aggiungere variabili ai nomi dei report.

    Questi elementi sono visualizzati come campi che possono essere riordinati utilizzando i cursori di ordinamento a destra.

  9. Deve essere presente almeno una variabile. Scegliere Nome report.
  10. Fare clic su Aggiungi variabile. Scegliere Reparto utente.
  11. Fare clic su Aggiungi variabile. Scegliere Personalizzato. Aggiungere un trattino o un carattere di sottolineatura nella casella di testo visualizzata.
  12. Fare clic su Aggiungi variabile. Scegliere Data. Selezionare un formato di data.
  13. Il riquadro Anteprima mostra il nome report dinamico.
  14. Fare clic su Crea.

    Creating a report template with dynamic naming.

Il report Advanced Tutorial Excel sarà visualizzato sotto Report.

Modifica del modello di report

Esistono molti modi per modificare un modello di report. In questo tutorial si aggiungeranno:

  • Titoli: semplice testo utilizzato per organizzare il report. I titoli possono essere modificati con le opzioni standard di Excel.
  • Livelli: consentono di suddividere i dati in base a una dimensione. Possono essere applicati a tabelle e immagini.
  • Tabelle: consentono di presentare i dati di Qlik Sense in formato tabellare. È possibile creare tabelle Excel o importare tabelle Qlik Sense.
  • Filtri degli oggetti: consentono di limitare i dati visualizzati in un oggetto, ad esempio un grafico o una tabella.

Questa sezione non tratta tutte le operazioni possibili in Qlik NPrinting Designer. Per informazioni su ulteriori funzionalità dei report Excel, vedere: Report Excel.

Nota: L'anteprima del report potrebbe risultare diversa dalle immagini riportate di seguito, a seconda della formattazione scelta. Alcuni oggetti potrebbero avere nomi leggermente diversi, a seconda dell'ordine nel quale sono stati selezionati.

Procedere come segue:

  1. Nel menu principale di Qlik NPrinting web console fare clic su Report.
  2. Fare clic sul report nella schermata Report.
  3. Fare clic su Modifica modello per aprire l'Editor modelli di Qlik NPrinting Designer.

    Edit report template button.

  4. Nella cella A1 digitare un titolo, Ad esempio, Quarterly trends and customer sales by region.

    Suggerimento: Per modificare l'aspetto dei titoli è possibile utilizzare le opzioni di formattazione di Excel. Ad esempio, è possibile modificare la dimensione e il colore dei caratteri. È anche possibile unire diverse celle in modo che il titolo sia centrato rispetto al resto del report.
  5. Aggiungere un livello:
    1. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Levels (Livelli), quindi selezionare Add levels (Aggiungi livelli).
    2. Si aprirà una nuova finestra. Selezionare Region. Fare clic su OK.

    3. Trascinare Region_Level sulla cella A2.
    4. Tagliare e incollare il tag </Region_Level> sulla cella A17.

      Gli oggetti inseriti in questi tag verranno organizzati per regione.

    5. Espandere Region_Level nel riquadro a sinistra.
    6. Trascinare e rilasciare Region sulla cella A4.

      In questo modo ogni livello avrà un'intestazione.

  6. Aggiungere una tabella Excel:
    1. Nella cella A6 aggiungere un sottotitolo: Quarterly trends.
    2. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Tables (Tabelle), quindi selezionare Add objects (Aggiungi oggetti).
    3. Si aprirà una nuova finestra. Selezionare Quarterly Trend. Fare clic su OK.
    4. Nel riquadro a sinistra selezionare TFWPC - Quarterly Trend. Si aprirà il riquadro Proprietà sottostante.
    5. Deselezionare la casella di controllo Keep Source Formats.

      La formattazione di Qlik Sense verrà rimossa dalla tabella, che potrà quindi essere personalizzata.

    6. Impostare Show Headers su Mostra in cella tag.
    7. Nelle celle dei tag verranno inserite le intestazioni di colonna e i dati inizieranno a partire dalla riga sottostante. Le formule e le variabili nelle intestazioni originali di Qlik Sense non verranno sostituite.

    8. Trascinare TFWPC - Quarterly Trend nella cella A8. Selezionare la cella contenente il tag TFWPC, se non è già selezionata.
    9. Fare clic sulla scheda Inserisci nella barra degli strumenti di Excel.
    10. Fare clic sull'icona Tabella nel gruppo Tabelle. Fare clic su OK.

    11. Selezionare Strumenti tabella > Progettazione per applicare la formattazione della tabella.
      • La formattazione del carattere e dell'allineamento applicata alla cella dell'intestazione verrà estesa a tutte le celle della tabella nella riga dell'intestazione.
      • La formattazione del carattere e dell'allineamento applicata alla cella del contenuto verrà estesa a tutte le celle della tabella nelle righe del contenuto.
      • La formattazione dei numeri non produrrà alcun effetto.
    12. Fare clic su Anteprima nella barra degli strumenti di Qlik NPrinting Designer per visualizzare l'anteprima della tabella.

      Si è così ottenuta una tabella Excel che può essere ordinata e filtrata. Tuttavia, non è possibile formattare i numeri.

  7. Aggiungere una tabella con subtotali:
    1. Nella cella A11 aggiungere un sottotitolo: Customer sales.
    2. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Tables (Tabelle), quindi selezionare Add objects (Aggiungi oggetti).
    3. Si aprirà una nuova finestra. Selezionare Customer Sales and Quantity. Fare clic su OK.
    4. Nel riquadro a sinistra selezionare Customer Sales and Quantity. Si aprirà il riquadro Proprietà sottostante.
    5. Deselezionare la casella di controllo Keep Source Formats.
    6. Espandere il nuovo nodo Customer Sales and Quantity.
    7. Trascinare Customer - Customer nella cella A13 e JWaPFv - Sales nella cella B13.
    8. Nella cella A15 digitare: Region total. Nella cella B15 aggiungere una formula: =SOMMA(B14).

      Formattare B15 in modo che venga visualizzato come valuta.

      Designer, edit template screen.

  8. Aggiungere una tabella con subtotali e un filtro:
    1. Aggiungere un nuovo foglio alla cartella di lavoro Excel.
    2. Accedere al nuovo foglio. Nella cella A1 aggiungere un sottotitolo: Wine and beer sales by region.
    3. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Levels (Livelli), quindi selezionare Add levels (Aggiungi livelli).
    4. Si aprirà una nuova finestra. Selezionare Region. Fare clic su OK.
    5. Trascinare Region_Level sulla cella A2.
    6. Tagliare e incollare il tag </Region_Level> sulla cella A17.
    7. Espandere Region_Level nel riquadro a sinistra.
    8. Trascinare e rilasciare Region sulla cella A4.

      In questo modo ogni livello avrà un'intestazione.

    9. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Tables (Tabelle), quindi selezionare Add objects (Aggiungi oggetti).
    10. Si aprirà una nuova finestra. Selezionare Product Treemap. Fare clic su OK.
    11. Fare clic sul nodo Product Treemap. Sotto Proprietà > Filtro fare clic su ¥. Selezionare il filtro Beer and Wine.

      In questo modo la nuova tabella mostrerà solo dati relativi a birra e vino.

      Deselezionare la casella di controllo Keep Source Formats.

    12. Espandere il nodo Product Treemap.
    13. Trascinare Product Type in B5 , Item Desc in C5 e Sales in D5.
    14. Nella cella C7 digitare: Region total. Nella cella D7 aggiungere una formula: =SOMMA(D6).
    15. Nella cella C10 digitare: Total sales. Nella cella D10 aggiungere una formula: =SOMMA(D6:D8)/2.
    16. Selezionare le celle D7 e D10 e formattarle per visualizzarle come valuta.

      Designer, report template edit screen

  9. Nel menu dell'editor di modelli di Qlik NPrinting fare clic sulla scheda File. Fare clic su Salva.
  10. Fare clic sulla scheda Modello, quindi sul pulsante Anteprima per visualizzare l'anteprima del report.

    Il caricamento dell'anteprima potrebbe richiedere diversi minuti, a seconda delle dimensioni del report. È possibile interrompere la generazione dell'anteprima facendo clic sul pulsante Interrompi.

    Report preview screen

    Report preview screen, second sheet.

    Avviso: Le modifiche eseguite in modalità anteprima non saranno salvate.
  11. Per proseguire le modifiche, chiudere la finestra di anteprima e formattare il report nell'editor di modelli.
  12. Terminate le modifiche, fare clic su Salva e chiudi.

Il modello verrà salvato e sarà pronto per essere condiviso con altri utenti.

Pubblicazione in NewsStand e tramite email

I report devono essere pubblicati affinché gli utenti possano accedervi. Si procederà ora con la pubblicazione in NewsStand e tramite email.

NewsStand è un portale Web che consente agli utenti di visualizzare in anteprima e scaricare report, nonché di sottoscrivere ad aggiornamenti automatici. Vedere: Panoramica di NewsStand

Le email contengono i report come allegati. Il contenuto può essere personalizzato con l'aggiunta di testo e immagini. Vedere: Distribuzione di report tramite email.

Si creerà inoltre un trigger che pubblicherà automaticamente i report in base a una pianificazione.

Nota: È necessario configurare il server di posta SMTP per l'invio di email da Qlik NPrinting. Vedere: Configurare il server SMTP.

Procedere come segue:

  1. Nel menu principale della console Web di Qlik NPrinting fare clic su Attività, quindi selezionare Attività di pubblicazione.
  2. Fare clic sul pulsante Crea attività.

    1. Immettere un nome. Ad esempio: Publish Advanced Tutorial.
    2. Selezionare l'app dall'elenco a discesa: Advanced Tutorial NP App.
    3. Mantenere i valori predefiniti per le altre opzioni. Fare clic su Crea.

      Publish task overview screen.

  3. Fare clic sulla scheda Report.
    1. Fare clic sul pulsante Aggiungi report.
    2. Selezionare Advanced Tutorial Excel dall'elenco a discesa Scegli report.
    3. Selezionare XLS nell'elenco a discesa Formato di output.
    4. Verificare che le caselle di controllo Allega all'email e Abilitata siano selezionate.
    5. Fare clic su Aggiungi report.

      Adding a report to a publish task.

  4. Fare clic sulla scheda Utenti/gruppi.
    1. Fare clic sul pulsante Aggiungi utente o gruppo.
    2. Selezionare un utente o un gruppo dall'elenco a discesa Scegli destinatario.

      Per apprendere come creare nuovi utenti, vedere: Creazione di utenti.

    3. Selezionare le caselle di controllo Abilitato, Destinazione NewsStand e Destinazione email.
    4. Fare clic su Aggiungi destinatario.
  5. Fare clic sulla scheda Destinazioni.
    1. Nella colonna NewsStand fare clic sulla casella di controllo Pubblica per tutti.
    2. Nella colonna Email fare clic sulla casella di controllo Pubblica per tutti.
    3. Fare clic su Salva.
  6. Personalizzare il modello e-mail:
    1. Fare clic su Messaggio email nel menu principale dell'attività.
    2. In Da, selezionare una delle seguenti opzioni:
      • Utente: selezionare l'email del mittente dall'elenco a discesa. È inoltre possibile utilizzare il modulo di ricerca per filtrare l'elenco.
      • Personalizzato: inserire un indirizzo email valido.

    3. Nell'elenco a discesa A scegliere Utenti selezionati.
    4. Inserire un Oggetto.
    5. Selezionare il Formato dell'e-mail facendo clic su HTML, che supporta testo formattato e dinamico.

    6. Aggiungere il testo al corpo dell'e-mail. È possibile personalizzarlo utilizzando i pulsanti di formattazione.
    7. Fare clic su Utenti , quindi selezionare dall'elenco i tag, che verranno sostituiti dal relativo valore durante la generazione dell'e-mail.

      Ad esempio, %%User_Company%% sarà sostituito dal nome dell'azienda del destinatario. In questo esempio sono stati aggiunti %%User_FullName%%, %%User_Department%% e %%User_Company%%.

      Se il profilo degli utenti destinatari non contiene queste informazioni, il messaggio conterrà stringhe vuote. Vedere: Creazione di utenti.

    8. Nell'elenco a discesa Allegati selezionare Tutti i report allegati.
    9. Fare clic su Salva.

      Email customization screen.

  7. Creare un trigger:
    1. Fare clic su Trigger nel menu principale dell'attività.
    2. Fare clic su Crea trigger.
    3. Immettere un nome: Tutorial Trigger.
    4. Nella sezione Pianificazione selezionare il Tipo di pianificazione. Per questo tutorial scegliere: Settimanale.

      L'attività verrà eseguita automaticamente nei giorni della settimana specificati.

    5. Sotto Frequenza giornaliera fare clic su Una volta. Lasciare l'ora predefinita.
    6. Nella sezione Inizio è possibile impostare Data di inizio e Fuso orario per le ore specificate nel trigger. La data di inizio predefinita è il giorno di creazione del trigger.
    7. Fare clic su Crea per salvare il nuovo trigger nel repository.

      Trigger creation interface

  8. Tornare alla pagina Panoramica.
  9. Fare clic sul pulsante Esegui ora.

    Nella parte superiore della pagina verrà visualizzato un messaggio di conferma.

I destinatari potranno ora accedere a NewsStand nel browser e visualizzare il report. Riceveranno inoltre una copia via email. Poiché è stato creato un trigger, gli utenti riceveranno inoltre un report aggiornato una volta la settimana, in base alla pianificazione impostata.

Suggerimento: Nelle installazioni standard è possibile passare da Qlik NPrinting Web Console a NewsStand cambiando il numero di porta da 4993 a 4994 nella barra degli indirizzi del browser. Ad esempio, se Web Console è https://YourServerName:4993, NewsStand sarà https://YourServerName:4994.

NewsStand