Vai al contenuto principale

Requisiti di sistema per Qlik NPrinting Engine

IN QUESTA PAGINA

Requisiti di sistema per Qlik NPrinting Engine

In questa sezione sono elencati i requisiti hardware e software minimi di Qlik NPrinting Engine.

Qlik NPrinting Engine può essere installato su computer fisici e virtuali. In entrambe le configurazioni, le applicazioni virtualizzate non sono supportate. Ad esempio, Qlik NPrinting Engine non funzionerà se è installato in un computer diverso da quello in cui è installato QlikView Desktop e se è distribuito come applicazione virtualizzata.

Per impostazione predefinita, è disponibile un solo Qlik NPrinting Engine per ogni licenza di Qlik NPrinting Server. Se si desidera aggiungere altri engine all'ambiente di Qlik NPrinting, è necessario acquistarli.

Requisiti

Questi requisiti di Qlik NPrinting Engine riguardano le configurazioni in cui ciascun componente di Qlik NPrinting viene installato in un computer diverso. Se si installano più componenti (ad esempio il server e l'engine) nello stesso computer, i requisti hardware minimi aumentano.

  • Piattaforme:
    • Microsoft Windows Server 2012
    • Microsoft Windows Server 2012 R2
    • Microsoft Windows Server 2016
    • Microsoft Windows Server 2019
  • Processori (CPU): processori compatibili x64 multi-core con un minimo di due core.
  • Memoria: sono necessari 2 GB per ciascun core, per un totale di almeno 4 GB di RAM.
    • QlikView Desktop deve disporre di uno spazio di memoria sufficiente per gestire i documenti di QlikView che verranno utilizzati come origini dati per la creazione di report.
    • Un report MultiDoc è un report con dati provenienti da molti documenti di QlikView. Se si creano report MultiDoc, tutti i documenti QlikView usati come origini dati verranno aperti contemporaneamente.

    • La connessione a ulteriori server Qlik Sense avrà un impatto sulle risorse del sistema Qlik NPrinting Server. Potrebbe essere necessario aumentare l'utilizzo di RAM e CPU sui computer Qlik Qlik NPrinting Engine e Qlik NPrinting Server se ci si collega a più Qlik Sense.

  • Spazio su disco: almeno 300 MB
  • Archiviazione: È supportata soltanto la memorizzazione locale o condivisa di Windows.
  • Orologi dei server:

    Gli orologi dei server Windows di Qlik NPrinting Server e di Qlik NPrinting Engine devono essere sincronizzati, con una tolleranza di 2 secondi. Un server Windows sincronizza il proprio orologio con il controller di dominio. Pertanto, se Qlik NPrinting Server e Qlik NPrinting Engine sono inclusi nello stesso dominio, gli orologi saranno sincronizzati. Non rimuovere questa opzione manualmente. Se si installa Qlik NPrinting Server e Qlik NPrinting Engine in server Windows di domini diversi, è necessario assicurarsi che gli orologi siano sincronizzati con una tolleranza di 2 secondi.

  • Sicurezza della piattaforma: TLS 1.2 deve essere abilitato.
  • Nota: Le attivazioni delle licenze richiedono l'accesso a Qlik Licensing Service. Aprire la porta 443 e consentire le chiamate in uscita a license.qlikcloud.com.

    L'uso di un proxy è supportato. Per ulteriori informazioni sulla configurazione di un servizio proxy in Windows, vedere Installazione proxy del servizio di licenza

Compatibilità di QlikView con Qlik NPrinting

Per la connessione tra QlikView e Qlik NPrinting, QlikView Desktop deve essere installato su ogni computer di Qlik NPrinting Engine.

Se si utilizzano connessioni server o cluster, le versioni di QlikView Server e QlikView Desktop devono essere le stesse.

Per la connessione a Qlik NPrinting sono supportate le versioni seguenti di QlikView:

  • QlikView November 2017 (12.20) o versioni successive

  • QlikView November 2018 (12.30) SR1 o versioni successive

  • QlikView April 2019 (12.40) o versioni successive

  • QlikView April 2020 SR2 (12.50 SR2) o versioni successive
  • QlikView May 2021 (12.60) o versioni successive
  • Avviso: QlikView Desktop Personal Edition non è supportato.
    Avviso: Nelle edizioni SaaS di Qlik Sense, QlikView non è supportato.

In caso di migrazione da QlikView NPrinting 16 a Qlik NPrinting November 2019 o versioni successive, può essere necessario aggiornare la versione di QlikView in uso. Vedere: Aggiornamento di QlikView NPrinting 16 prima della migrazione.

Compatibilità di Qlik Sense con Qlik NPrinting

Per la connessione a Qlik NPrinting sono supportate le seguenti versioni di Qlik Sense. Tenere presente che la propria versione di Qlik NPrinting deve essere uguale o più recente alla propria versione di Qlik Sense su Windows:

  • Qlik Sense Enterprise on Windows November 2017 o versione successiva.
  • È necessario Qlik NPrinting 17.2.1 o versione successiva per connettersi a Qlik Sense 3.1.2 o versione successiva.

  • Per creare connessioni alle app di Qlik Sense, è necessario Qlik Sense 2.3 o versione successiva.

  • È necessario Qlik Sense 3.0.1 o versione successiva per distribuire report a un hub di Qlik Sense.

  • È necessario Qlik Sense 3.1 o versione successiva se ci si connette a più server Qlik Sense.

Non è necessario alcun software client per la connessione di Qlik Sense a Qlik NPrinting.

Nota: SaaS editions of Qlik Sense e Qlik Sense Enterprise on Kubernetes non sono supportati per la connessione a Qlik NPrinting.

Ulteriore software installato

Durante l'installazione di Qlik NPrinting Engine, viene installato il software riportato di seguito, se non è già installato. Non deve essere rimosso:

  • PDF X-CHANGE 5.0.269
  • Framework .NET: 4.7.2 o versione successiva

    Quando si installa Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer, viene installato .NET Framework versione 4.7.2. L'installazione di .NET Framework versione 4.7.2 richiede una connessione Internet attiva. Se .NET Framework versione 4.7.2 o successiva non è già installato in un computer privo di connessione Internet, l'installazione non riuscirà. È necessario installare .NET Framework versione 4.7.2 o successiva sui computer privi di connessione Internet prima di installare Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer.Se non è disponibile una connessione Internet in un computer con .NET Framework versione 4.7.2 o successiva già installato, il programma di installazione salterà questa parte dell'installazione.