Formattazione dei report Word

Durante la creazione di modelli per generare report di Word, l'impostazione di formattazione predefinita è la formattazione di QlikView o di Qlik Sense. Tuttavia, è possibile utilizzare anche gli strumenti di formattazione di Word.

Nota: La formattazione delle tabelle con gli strumenti Word funziona solo se si salva il modello in formato .docx e non .doc. Salvare i modelli Word in formato .doc solo se necessario per la retrocompatibilità.

Consentire all'applicazione la formattazione Word per tutto il grafico

Dopo aver aggiunto un oggetto QlikView come tabella, ad esempio CH184 in Creazione di report Word, effettuare le seguenti operazioni:

  1. Nell'editor modelli, fare clic sul nodo CH184 dell'oggetto appena aggiunto.
  2. Nella finestra Proprietà, deselezionare la casella di controllo Keep Source Formats.

    Questo farà sì che il contenuto di tutte le celle di tutte le colonne della tabella vengano esportate da QlikView senza formattazione.

  3. Fare clic sul pulsante della barra degli strumenti.

Funzione Testo a capo

Selezionando Wrap Text, Qlik NPrinting crea automaticamente due righe se la cella è troppo piccola. Questa opzione ha effetto solo se Keep Source Formats non è selezionato. Wrap Text è una proprietà di tabella che interessa tutte le colonne della tabella.

Applicare la formattazione Word a tutta la tabella

Prima di aggiungere la tabella al modello, effettuare le seguenti operazioni:

  1. Selezionare la scheda Inserisci nella barra degli strumenti.
  2. Selezionare Tabella.
  3. Selezionare la cella più in alto a sinistra per inserire una tabella 1x1 nel modello.

Aggiungere la tabella al modello

Procedere come segue:

  1. Espandere il nodo CH184.

  2. Trascinarlo nella cella della tabella nel modello. È possibile selezionare più valori, tenendo premuto Ctrl o Maiusc durante la selezione delle colonne.

    In questo modo, verranno creati tutti i tag che verranno inseriti in una serie orizzontale di celle. Le celle possono superare la presentazione della pagina, ma questo sarà gestito nella sottosezione seguente.

Impostare la tabella in modo da adattare le colonne

Procedere come segue:

  1. Selezionare la scheda Layout nella sezione Strumenti tabella della barra degli strumenti.
  2. Fare clic su Adatta nella sezione Dimensioni celle della barra degli strumenti.
  3. Selezionare Adatta al contenuto.

Applicare lo stile tabella

Dopo aver selezionato la tabella, effettuare le seguenti operazioni:

  1. Selezionare la scheda Progettazione nella sezione Strumenti tabella della barra degli strumenti.
  2. Selezionare uno stile generale nella sezione Stili tabella della barra degli strumenti.

Anteprima e salvataggio

Procedere come segue:

  1. Fare clic su Anteprima.
  2. Controllare il report, chiuderlo, quindi modificare nuovamente il modello, se necessario.
  3. Fare clic su Salva e chiudi per salvare il modello e chiudere l'editor modelli.