Requisiti di sistema per Qlik NPrinting Engine

Questi requisiti di Qlik NPrinting Engine riguardano le configurazioni in cui ciascun componente di Qlik NPrinting viene installato in un computer diverso.

Se si installano più componenti (ad esempio il server e l'engine) nello stesso computer, i requisti hardware minimi aumentano.

Qlik NPrinting Engine può essere installato su computer fisici e virtuali. In entrambe le configurazioni, le applicazioni virtualizzate non sono supportate. Ad esempio, Qlik NPrinting Engine non funzionerà se è installato in un computer diverso da quello in cui è installato QlikView Desktop e se è distribuito come applicazione virtualizzata.

Per impostazione predefinita, è disponibile un solo Qlik NPrinting Engine per ogni licenza di Qlik NPrinting Server. Se si desidera aggiungere altri engine all'ambiente di Qlik NPrinting, è necessario acquistarli.

Requisiti di sistema
Componente Richiesto
Piattaforme
  • Microsoft Windows Server 2008 R2 è supportato solo se non ci si deve connettere a Qlik Sense.
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016

È supportata soltanto l'architettura a 64 bit.

Processori (CPU) Processori compatibili x64 multi-core con un minimo di due core.
Memoria

Sono necessari 2 GB per ciascun core, per un totale di almeno 4 GB di RAM.

QlikView Desktop deve disporre di uno spazio di memoria sufficiente per gestire i documenti di QlikView che verranno utilizzati come origini dati per la creazione di report. Se si creano report MultiDoc, tutti i documenti di QlikView usati come sorgenti dati verranno aperti contemporaneamente. Un report MultiDoc è un report con dati provenienti da molti documenti di QlikView.

Spazio su disco Almeno 300 MB
Archiviazione È supportata soltanto la memorizzazione locale o condivisa di Windows.
QlikView Desktop
  • Sono supportati sia QlikView Desktop 11.20 SR15 o versioni successive sia 12.00 SR5.
  • QlikView Desktop 12.10 SR1 o versioni successive è supportato a partire dalla versione Qlik NPrinting 17.2.2 e include i report On-Demand.
  • QlikView Desktop November 2017 o versioni successive è supportato per l'utilizzo con Qlik NPrinting 17.3.1 o versioni successive.
  • QlikView Desktop Personal Edition non è supportato.

Nel computer di Qlik NPrinting Engine deve essere installato QlikView Desktop. QlikView Server e QlikView Desktop devono essere della stessa versione, incluso il numero di release. QlikView Desktop deve essere installato localmente sullo stesso computer fisico o virtuale su cui è installato Qlik NPrinting Engine. QlikView Desktop non è richiesto se ci si connette solo alle app Qlik Sense.

Orologi dei server

Gli orologi dei server Windows di Qlik NPrinting Server e di Qlik NPrinting Engine devono essere sincronizzati, con una tolleranza di 2 secondi.

Un server Windows sincronizza il proprio orologio con il controller di dominio. Pertanto, se Qlik NPrinting Server e Qlik NPrinting Engine sono inclusi nello stesso dominio, non dovrebbero verificarsi problemi di sincronizzazione degli orologi. Si consiglia di non rimuovere manualmente questa opzione. Se si installa Qlik NPrinting Server e Qlik NPrinting Engine in server Windows di domini differenti, è necessario assicurarsi che gli orologi siano sincronizzati con una tolleranza di 2 secondi.

Sicurezza della piattaforma TLS 1.2 deve essere abilitato.

Ulteriore software installato

Durante l'installazione di Qlik NPrinting Engine, viene installato il software riportato di seguito, se non è già installato. Non deve essere rimosso:

  • PDF X-CHANGE 5.0.269
  • .NET Framework: 4.6.2 o superiore.

    Quando si installa Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer, viene installato .NET Framework versione 4.6.2. L'installazione di .NET Framework versione 4.6.2 richiede una connessione Internet attiva. Se .NET Framework versione 4.6.2 o successiva non è già installato in un computer senza connessione Internet, l'installazione avrà esito negativo. Nei computer senza connessione Internet è necessario installare .NET Framework versione 4.6.2 prima di installare Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer.Se non è disponibile una connessione Internet in un computer con .NET Framework versione 4.6.2 o successiva già installato, il programma di installazione salterà questa parte dell'installazione.