QlikWorld 2020 Global Conference. Join us to discover how to get the most from your data. Act fast. Register now and save.

Creazione di tabelle pivot utilizzando colonne di tabelle Excel

È possibile creare tabelle pivot Excel utilizzando livelli. Consigliamo tuttavia il metodo che segue, più semplice e rapido.

Per portare a termine le procedure seguenti, è necessario Excel 2007 o versioni successive.

Creare un nuovo report Excel

Procedere come segue:

  1. Selezionare Report nel menu principale di Qlik NPrinting, quindi fare clic su Crea report.
  2. Immettere un titolo per il report. Pivot table report using Excel table.
  3. Selezionare Excel nell'elenco a discesa Tipo.
  4. Selezionare un'app dall'elenco a discesa App.
  5. Fare clic su Crea per creare il report.
  6. Fare clic su Modifica modello per aprire l'Editor modelli.

Aggiungere oggetti come tabella e modificare la proprietà Keep Source Formats

Procedere come segue:

  1. Fare clic con il pulsante destro del mouse sul nodo Tabelle, quindi selezionare Aggiungi oggetti.
  2. Selezionare la Connessione al documento QlikView contenente l'oggetto desiderato.
  3. Aggiungere CH205 al modello come tabella.

    Per creare il modello, è possibile utilizzare solo tabelle QlikView normali. Per utilizzare una tabella pivot QlikView, è necessario convertirla in tabella normale oppure, per conservare l'originale, clonarla e convertire il clone. Sarà poi possibile aggiungere la tabella convertita al modello.

  4. Fare clic con il pulsante destro del mouse su CH205 nel nodo Tabelle, quindi selezionare Proprietà.
  5. Deselezionare la casella di controllo Keep Source Formats per CH205.

Costruire tabelle da colonne

Per costruire una tabella semplice, trascinare le colonne separatamente nel modello e rilasciarle in celle vuote. È possibile usare tutte le colonne o solo alcune di esse.

Procedere come segue:

  1. Espandere le colonne CH205.
  2. Premere il tasto MAIUSC e selezionare tutte le colonne.
  3. Trascinare le colonne e rilasciarle all'intero di celle vuote nel modello.
  4. Aprire la Excel barra multifunzione facendo clic sull'icona della barra degli strumenti nel gruppo Visualizza della barra degli strumenti Editor modelli.
  5. Regolare e formattare le intestazioni di colonna in base alle necessità.
  6. Evidenziare l'intestazione di colonna, il tag e una riga sotto alle celle per selezionarli.
  7. Selezionare la scheda Inserisci nella barra multifunzione.
  8. Fare clic su Tabella nel gruppo Tabelle della barra multifunzione.
  9. Accertarsi che la casella My table headers (Intestazioni di tabelle) sia selezionata.
  10. Fare clic su OK.
  11. Trascinare un tag deleterow nella colonna A della prima riga vuota sotto alla tabella per rimuoverla.

Convertire in tabella pivot

Procedere come segue:

  1. Evidenziare il tag di colonna e le celle di intestazione per selezionarli, se necessario.
  2. Selezionare la scheda Design (Progettazione) in Table Tools (Strumenti tabella) nella barra multifunzione.
  3. Fare clic su Summarize (Riepiloga) con PivotTable (Tabella pivot) nel gruppo Strumenti.
  4. Fare clic su OK.

    La nuova tabella pivot verrà creata in un nuovo foglio di lavoro. È inoltre possibile aggiungere la tabella pivot nello stesso foglio di lavoro dei dati originali e, ad esempio, nascondere la colonna con i dati.

  5. Trascinare il campo Year nella casella Colonne.
  6. Trascinare i campi Salesman e Country nella casella Etichette di riga.
  7. Trascinare il campo Sales nella casella Valori, quindi fare clic su di esso.
  8. Fare clic su Conteggio di Total sales per aprire il menu.
  9. Selezionare Impostazioni campo valore.
  10. Selezionare Somma nella scheda Riepiloga valori per nella finestra di dialogo Impostazioni campo valore.
  11. Fare clic su OK.

Impostare i dati da aggiornare

Procedere come segue:

  1. Fare clic sul menu a discesa Opzioni in PivotTable Tools (Strumenti tabella pivot) - scheda Analyze (Analizza).
  2. Selezionare la scheda Data (Dati).
  3. Selezionare la casella di controllo Aggiorna dati all'apertura del file.
  4. Impostare Numero di elementi da mantenere per campo su None.
  5. Fare clic su OK in fondo alla finestra di dialogo Opzioni tabella pivot.

Se questa procedura non viene eseguita, nel report generato verrà inserita una tabella pivot vuota.

Anteprima e salvataggio

Procedere come segue:

  1. Fare clic su Anteprima.
  2. Controllare il report, chiuderlo, quindi modificare nuovamente il modello, se necessario.
  3. Fare clic su Salva e chiudi per salvare il modello e chiudere l'editor modelli.