Pubblicazione di un report semplice da un documento QlikView

Questo tutorial mostra come creare e pubblicare un semplice report PowerPoint di Qlik NPrinting utilizzando dati di QlikView.

Qlik NPrinting offre molte funzioni. Questo tutorial intende aiutare i nuovi utenti a creare il loro primo report. Il tutorial non descrive ogni tipo di report, elemento di progettazione o opzione di pubblicazione. Alla fine del tutorial si sarà creato, modificato e pubblicato un report PowerPoint visualizzabile dagli utenti selezionati.

Altri tutorial di Qlik NPrinting:

Nota: Per creare e modificare report nei formati di file Office, è necessario che Microsoft Office sia installato.

In questo tutorial si eseguiranno le operazioni seguenti:

Accesso a un documento QlikView

Per generare report sono necessari dati. Si vedrà come scaricare e importare un documento QlikView di esempio.

Connessione di Qlik NPrinting a un documento QlikView

Qlik NPrinting deve connettersi al documento QlikView. Si vedrà come configurare Qlik NPrinting in modo che possa accedere a un documento di esempio o ai dati di QlikView esistenti.

Creazione di un nuovo modello di report di Qlik NPrinting

I modelli di report controllano la presentazione e i formati di output dei report. Questa sezione mostrerà come creare un nuovo modello.

Modifica del modello di report

I report offrono molte opzioni di formattazione diverse. In questa sezione si aggiungeranno un titolo, immagini, una tabella, un grafico e pagine al report.

Pubblicazione in NewsStand e tramite email

NewsStand è una console Web alla quale gli utenti possono accedere per visualizzare i report. Si vedrà come pubblicare il report in NewsStand e tramite email.

Accesso a un documento QlikView

I documenti QlikView contengono i dati e le visualizzazioni utilizzati da Qlik NPrinting per creare i report. Esistono diversi modi per accedere a un documento QlikView.

  • È possibile scaricare un documento QlikView dal sito della guida di Qlik e salvarlo in una cartella del computer in uso.
  • È possibile utilizzare un proprio documento QlikView e passare direttamente a Connessione di Qlik NPrinting a un documento QlikView. Se si utilizza un proprio documento per completare questo tutorial, scegliere un documento semplice. Con i documenti QlikView complessi i tempi di caricamento di Qlik NPrinting sono più lunghi.

Download di un documento QlikView dal sito della guida di Qlik e salvataggio nel computer

Procedere come segue:

  1. Nel sito della guida di Qlik NPrinting passare a File di esempio e scaricare il file Examples.zip nella posizione desiderata del computer dove è installato Qlik NPrinting.
  2. In Windows decomprimere Sales Demo.qvw e salvarlo nella cartella C:\Program Files\QlikView\Examples\. Creare la cartella se non esiste già.

    Se si salvano i file in una posizione diversa, sarà necessario sostituire tale posizione a C:\Program Files\QlikView\Examples\ ovunque questo percorso viene specificato nella guida di Qlik NPrinting.

Avviso: Le unità di rete mappate, come Z:\NPrintingServer\QlikViewDocuments, non sono supportate da Qlik NPrinting. È necessario utilizzare percorsi UNC (Universal Naming Convention), come \\NomeServer\NPrintingServer\QlikViewDocuments.

Connessione di Qlik NPrinting a un documento QlikView

A questo punto si creerà un'app Qlik NPrinting e la si collegherà al documento QlikView.

Le app Qlik NPrinting contengono report, filtri e connessioni ad app Qlik Sense o a documenti QlikView. Permettono a Qlik NPrinting Designer di accedere ai dati in modo che possano essere utilizzati in un report.

Procedere come segue:

  1. Accedere alla console Web di Qlik NPrinting.
  2. Nel menu principale fare clic sull'elenco a discesa App, quindi selezionare App.
  3. Fare clic sul pulsante Crea app.
    1. Immettere un nome per questa nuova app. Ad esempio: Beginner's Tutorial NP App - QV.
    2. Verificare che la casella di controllo Abilitato sia selezionata. In caso contrario, l'app sarà ignorata da Qlik NPrinting Engine.
    3. Fare clic su Crea.

      L'app Beginner's Tutorial NP App - QV sarà visualizzata sotto App.

  4. Nel menu principale fare clic sull'elenco a discesa App, quindi selezionare Connessioni.
    1. Fare clic sul pulsante Crea connessione.
    2. Nella casella Nome immettere un nome per la connessione: Beginner's Tutorial Connection - QV.
    3. Nell'elenco a discesa App selezionare l'app Qlik NPrinting creata in precedenza: Beginner's Tutorial NP App - QV.
    4. Sotto Sorgente selezionare QlikView.
    5. Sotto Tipo selezionare Locale.
    6. Sotto Percorso documento immettere la posizione del documento QlikView al quale si desidera effettuare la connessione.

      Ad esempio: C:\Program Files\QlikView\Examples\Sales Demo.qvw

      Avviso: Le unità di rete mappate, come Z:\NPrintingServer\QlikViewDocuments, non sono supportate da Qlik NPrinting. È necessario utilizzare percorsi UNC (Universal Naming Convention), come \\NomeServer\NPrintingServer\QlikViewDocuments.
    7. Se il documento QlikView richiede l'autenticazione, assicurarsi che sia selezionata l'opzione La connessione richiede autenticazione.

      Vedere: Section access.

    8. Fare clic sul pulsante Esegui verifica per verificare che la connessione sia valida.

      Se la connessione è valida, verrà visualizzato il messaggio “Verifica riuscita”. In caso contrario verrà visualizzato il messaggio seguente: “Errori rilevati. Verificare i dettagli di seguito.”

    9. Una volta verificate le impostazioni della connessione, fare clic su Crea. Si ritornerà automaticamente al menu Connessioni.
    10. La nuova connessione avrà lo stato Stato cache - Generazione in corso. Ciò significa che Qlik NPrinting si sta connettendo a QlikView e sta importando metadati. Se il documento QlikView è di grandi dimensioni, l'operazione potrebbe richiedere alcuni minuti.
      Nota:

      Ogni volta che si aggiungono nuovi oggetti al documento QlikView, è necessario ricaricare i metadati della connessione.

    11. Quando lo stato della cache diventa Generata, è possibile creare un nuovo modello di report. Se lo stato visualizzato è Errore, verificare le informazioni della connessione.

La nuova connessione sarà ora visibile nella schermata Connessioni.

In caso di difficoltà nella connessione al documento QlikView, vedere:

Creazione di un nuovo modello di report di Qlik NPrinting

I modelli di report controllano la presentazione e i formati di output dei report. È possibile disporre gli oggetti e formattare le pagine utilizzando le opzioni standard del tipo di report scelto. Ad esempio, un report PowerPoint avrà le stesse opzioni di formattazione e la stessa interfaccia di una presentazione PowerPoint.

Procedere come segue:

  1. Nel menu principale della console Web di Qlik NPrinting fare clic su Report.
  2. Fare clic sul pulsante Crea report.
  3. Immettere un titolo nel campo Titolo. Ad esempio: Beginner's Tutorial NP PowerPoint.
  4. Nell'elenco a discesa Tipo selezionare PowerPoint.
  5. Nell'elenco a discesa App selezionare Beginner's Tutorial NP App - QV.
  6. Nelle opzioni Modello fare clic su File vuoto.
  7. Verificare che la casella di controllo Abilitato sia selezionata. In caso contrario, il report sarà ignorato da Qlik NPrinting Engine.
  8. Fare clic su Crea.

Il report Beginner's Tutorial NP PowerPoint sarà visualizzato sotto Report.

Modifica del modello di report

Esistono molti modi per modificare un modello di report. In questo tutorial si aggiungeranno:

  • Titoli: semplice testo utilizzato per organizzare il report. I titoli possono essere modificati con le opzioni standard di PowerPoint.
  • Tabelle: consentono di presentare i dati di QlikView in formato tabellare.
  • Immagini: consentono di presentare i dati di QlikView in formato PNG.
  • Grafici: consentono di presentare i dati della tabella QlikView come grafico PowerPoint.

  • Pagine: consentono di suddividere i dati in base a una dimensione. Possono essere applicati a tabelle e immagini. Si divideranno Year e Category Name.

Questa sezione non tratta tutte le operazioni possibili in Qlik NPrinting Designer. Per informazioni sulle funzionalità avanzate dei report PowerPoint, vedere: Report PowerPoint.

Nota: L'anteprima del report potrebbe risultare diversa dall'immagine riportata di seguito, a seconda della formattazione scelta. Alcuni oggetti potrebbero avere nomi leggermente diversi, a seconda dell'ordine nel quale sono stati selezionati.

Procedere come segue:

  1. Nel menu principale della console Web di Qlik NPrinting fare clic su Report.
  2. Nella schermata Report fare clic sul report.
  3. Fare clic su Modifica modello per aprire l'Editor modelli di Qlik NPrinting Designer.

  4. Si apre la Qlik NPrinting Designer. Dal momento che si sta creando un report PowerPoint, verrà visualizzata l'interfaccia standard di PowerPoint. Da questa interfaccia è possibile applicare al report la maggior parte delle opzioni di formattazione di PowerPoint.
  5. Immettere il titolo:
    1. Nella prima diapositiva immettere un titolo, ad esempio “Sales Trends by Product Category”.
    2. Immettere un sottotitolo o eliminare la casella di testo del sottotitolo.

      Suggerimento: Per modificare l'aspetto dei titoli è possibile utilizzare le opzioni di formattazione di PowerPoint. Ad esempio, è possibile modificare la dimensione e il colore dei caratteri.
  6. Aggiungere immagini:
    1. Nella barra degli strumenti di PowerPoint fare clic sulla scheda Inserisci.
    2. Fare clic sul pulsante Nuova diapositiva.
    3. Digitare un titolo, ad esempio "Top Selling Products". Eliminare la seconda casella di testo vuota.
    4. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Images (Immagini), quindi selezionare Add objects (Aggiungi oggetti).

    5. Si aprirà una nuova finestra. Selezionare Products e Sales by Category for 2014 vs 2013, quindi fare clic su OK.

      È possibile selezionare più opzioni tenendo premuto il tasto CTRL.

    6. Trascinare SH02 - Products sulla diapositiva.

    7. Nella barra degli strumenti di PowerPoint fare clic sulla scheda Inserisci.
    8. Fare clic sul pulsante Nuova diapositiva.
    9. Digitare un titolo, ad esempio "Sales by Category: 2013 vs 2014". Eliminare la seconda casella di testo vuota.
    10. Trascinare CH212 - Sales by Category for 2014 vs 2013 sulla diapositiva.

  7. Aggiungere una tabella:
    1. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Tables (Tabelle), quindi selezionare Add objects (Aggiungi oggetti).
    2. Si aprirà una nuova finestra. Selezionare Sales by Category: 2013 vs 2014. Fare clic su OK.

    3. Trascinare CH212_1 - Sales by Category for 2014 vs 2013 sulla diapositiva.

  8. Aggiungere un grafico nativo PowerPoint:
    1. Nella barra degli strumenti di PowerPoint fare clic sulla scheda Inserisci.
    2. Fare clic sul pulsante Nuova diapositiva.
    3. Digitare un titolo, ad esempio "Sales Trends:". Eliminare la seconda casella di testo vuota.
    4. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Tables (Tabelle), quindi selezionare Add objects (Aggiungi oggetti).

    5. Si aprirà una nuova finestra. Selezionare CH326 - Sales by YearMonthNum. Fare clic su OK.

    6. Nella barra degli strumenti di PowerPoint selezionare la scheda Inserisci.
    7. Nella sezione Illustrazioni fare clic su Grafico .
    8. Si aprirà una nuova finestra. Sotto Colonna selezionare il primo grafico a barre, quindi fare clic su OK.

    9. Verrà aperto un foglio di lavoro Excel. Questa è la sorgente dati del grafico.

      Sarà necessario inserire i tag di Qlik NPrinting in questo foglio e rimuovere alcuni dati non necessari.

    10. Nel riquadro sinistro dell'interfaccia di PowerPoint espandere il nodo CH326 - Sales by YearMonthNum.
    11. Selezionare i tag YearMonthNum e Sales.

      È possibile selezionare più opzioni tenendo premuto il tasto CTRL.

    12. Trascinare e rilasciare il tag Year MonthNum nel foglio di lavoro Excel, dentro la cella A1. In questo modo diventerà l'asse delle y. Trascinare i tag Sales nella cella B1. In questo modo diventerà l'asse delle x.

    13. Selezionare ed eliminare le colonne C e D.

      I numeri effettivi non sono necessari, poiché Qlik NPrinting utilizzerà i tag per creare il grafico.

    14. Selezionare ed eliminare le righe 3, 4 e 5.

    15. Chiudere Excel.

      Le modifiche verranno salvate automaticamente.

    16. Può essere necessario regolare le dimensioni del grafico per adattarlo alla diapositiva. È possibile utilizzare le frecce di ridimensionamento.

    17. Nel menu dell'editor di modelli di Qlik NPrinting fare clic sulla scheda File. Fare clic su Salva.
    18. Fare clic sulla scheda Modello, quindi sul pulsante Anteprima per visualizzare l'anteprima del report.

      Al momento, la presentazione ha quattro diapositive.

  9. Aggiungere pagine:
    1. Accedere alla diapositiva alla quale si vuole aggiungere la pagina. In questo caso, la quarta diapositiva.

      Le pagine sono applicate soltanto alla diapositiva corrente.

    2. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Pagina, quindi selezionare Aggiungi pagina al foglio attuale.
    3. Si aprirà una nuova finestra. Selezionare CategoryName. Fare clic su OK.

      Nota: Nota: se si aggiunge una seconda pagina ad una diapositiva, la pagina precedente verrà sovrascritta.
    4. Espandere il nodo CategoryName_Page - CategoryName. Trascinare il tag CategoryName sulla diapositiva.

      Questo tag dividerà i dati per categoria, con ogni categoria in una diapositiva a parte. Il testo <CategoryName> cambierà in modo da corrispondere alla categoria di ogni diapositiva. Invece di una diapositiva con il titolo "Sales Trends:", si avranno diverse diapositive con titoli univoci: "Sales Trends: Baby Clothes", "Sales Trends: Women's Shoes".

      Il tag <CategoryName> sarà visualizzato come nuova casella di testo. Se si taglia e incolla questo nuovo testo nella casella di testo del titolo, è possibile formattarlo più facilmente in modo corrispondente al titolo.

    5. Accedere alla seconda diapositiva, "Top Selling Products".
    6. Nel riquadro a sinistra fare clic con il pulsante destro del mouse su Pagina, quindi selezionare Aggiungi pagina al foglio attuale.
    7. Si aprirà una nuova finestra. Selezionare Year. Fare clic su OK.
    8. Espandere il nodo Year_Page - Year. Trascinare il tag Year sulla diapositiva.

      Il tag sarà visualizzato come nuova casella di testo. Se si taglia e incolla questo nuovo testo nella casella di testo del titolo, è possibile formattarlo più facilmente in modo corrispondente al titolo.

    9. Nella barra degli strumenti di PowerPoint fare clic sulla scheda Inserisci.
    10. Fare clic sul pulsante Numero diapositiva.
    11. Si aprirà una nuova finestra. Fare clic sulle caselle di controllo Data e ora, Numero diapositiva e Non mostrare nella diapositiva del titolo. Fare clic su Applica a tutti.

  10. Nel menu dell'editor di modelli di Qlik NPrinting fare clic sulla scheda File. Fare clic su Salva.
  11. Fare clic sulla scheda Modello, quindi sul pulsante Anteprima per visualizzare l'anteprima del report.

    Il caricamento dell'anteprima potrebbe richiedere diversi minuti, a seconda delle dimensioni del report.

    È stato così creato un report con 13 diapositive. Le diapositive con pagine applicate sono state espanse in nuove pagine con informazioni divise in base alle categorie di pagina applicate.

    In questo esempio, le diapositive 2-4 mostrano dati filtrati per Year e le diapositive 6-13 mostrano dati filtrati per CategoryName.

    Avviso: Le modifiche eseguite in modalità anteprima non saranno salvate.
  12. Per proseguire le modifiche, chiudere la finestra di anteprima e formattare il report nell'editor di modelli.
  13. Terminate le modifiche, fare clic su Salva e chiudi.

Il modello verrà salvato e sarà pronto per essere condiviso con altri utenti.

Pubblicazione in NewsStand e tramite email

I report devono essere pubblicati affinché gli utenti possano accedervi. Si procederà ora con la pubblicazione in NewsStand e tramite email.

NewsStand è un portale Web che consente agli utenti di visualizzare in anteprima e scaricare report, nonché di sottoscrivere ad aggiornamenti automatici. Vedere: Panoramica di NewsStand

Le email contengono i report come allegati. Il contenuto può essere personalizzato con l'aggiunta di testo e immagini. Vedere: Distribuzione di report tramite email.

Nota: È necessario configurare il server di posta SMTP per l'invio di email da Qlik NPrinting. Vedere: Configurare il server SMTP.

Procedere come segue:

  1. Nel menu principale della console Web di Qlik NPrinting fare clic su Attività, quindi selezionare Attività di pubblicazione.
  2. Fare clic sul pulsante Crea attività.

    1. Immettere un nome. Ad esempio: Publish Beginner's Tutorial NP PowerPoint.
    2. Selezionare l'app dall'elenco a discesa: Beginner's Tutorial NP App - QV.
    3. Mantenere i valori predefiniti per le altre opzioni. Fare clic su Crea.
  3. Fare clic sulla scheda Report.
    1. Fare clic sul pulsante Aggiungi report.

    2. Selezionare Beginner's Tutorial - NP PowerPoint dall'elenco a discesa Scegli report.
    3. Selezionare PPTX nell'elenco a discesa Formato di output.
    4. Verificare che le caselle di controllo Allega all'email e Abilitata siano selezionate.
    5. Fare clic su Aggiungi report.

  4. Fare clic sulla scheda Utenti/gruppi.
    1. Fare clic sul pulsante Aggiungi utente o gruppo.
    2. Selezionare un utente o un gruppo dall'elenco a discesa Scegli destinatario.

      Per apprendere come creare nuovi utenti, vedere: Creazione di utenti.

    3. Selezionare le caselle di controllo Abilitato, Destinazione NewsStand e Destinazione email.
    4. Fare clic su Aggiungi destinatario.
  5. Fare clic sulla scheda Destinazioni.
    1. Nella colonna NewsStand fare clic sulla casella di controllo Pubblica per tutti.
    2. Nella colonna Email fare clic sulla casella di controllo Pubblica per tutti.
    3. Fare clic su Salva.
  6. Si tornerà alla scheda Panoramica.
  7. Fare clic sul pulsante Esegui ora.

    Una volta completata l'attività, verrà visualizzato un messaggio di conferma nella parte superiore della pagina.

I destinatari potranno ora accedere a NewsStand nel browser e visualizzare il report. Riceveranno inoltre una copia via email.

Suggerimento: Nelle installazioni standard è possibile passare da Qlik NPrinting Web Console a NewsStand cambiando il numero di porta da 4993 a 4994 nella barra degli indirizzi del browser. Ad esempio, se Web Console è https://YourServerName:4993, NewsStand sarà https://YourServerName:4994.