Jauge

Quelques exemples de jauges

Les graphiques permettent de représenter les valeurs numériques. Vous pouvez passer d'une représentation à une autre pour un graphique existant en modifiant l'option Type de graphique sous l'onglet Propriétés du graphique : Général.

Les jauges sont utilisées pour afficher la valeur d'une seule expression sans dimensions.

Pour créer le plus rapidement possible une jauge, sélectionnez l'assistant Graphique instantané dans le menu Outils.

Si vous cliquez avec le bouton droit sur la jauge, le menu Jauge : Objet s'affiche. On peut également y accéder à partir du menu Objet, lorsque la jauge est l'objet actif.

Menu Objet

Un clic droit sur un graphique fait apparaître un menu contextuel. Ce menu est également accessible sous le menu Objet lorsque le graphique est actif.

Le menu contient les commandes suivantes :

Propriétés... Ouvre la boîte de dialogue Propriétés dans laquelle vous pouvez définir les paramètres du graphique.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Détacher Le texte « (Détaché) » est ajouté au titre du graphique et le graphique n'est plus mis à jour en fonction des sélections effectuées dans le document (bien qu'on puisse encore faire des sélections à partir du graphique). Cette commande n'est disponible que si le graphique est attaché. Effectuer une copie d'un graphique et le détacher permet d'effectuer des comparaisons directes entre la copie et l'original.
Attacher Attache un graphique détaché. Le graphique devient lié de façon dynamique aux données. Cette commande n'est disponible que si le graphique est détaché.
Définir comme référence En choisissant cette option, vous définissez une référence dans le graphique, c'est à dire un segment fixe basé sur les sélections actives. Si d'autres sélections sont faites dans le document, la référence sera conservée, grisée à l'arrière-plan. Les axes du graphique, entre autres, seront ajustés pour toujours inclure la plus grande partie possible des ensembles de données d'arrière-plan et actuel. L'ensemble de données actives est toujours affiché au-dessus du tracé de référence, autrement dit ce dernier peut être masqué par le tracé de l'ensemble des données actives. L'affichage de l'arrière-plan peut être défini via le paramètre Mode de référence disponible sous Propriétés du graphique : Général. L'affichage d'une référence est seulement possible sur quelques types de graphiques, comme les histogrammes, les courbes, les combinés, les radars, les nuages de points, les bulles et les jauges à aiguille. Il n'est pas possible de définir une référence de graphique contenant un groupe cyclique ou hiérarchique. La référence sera perdue à la fermeture du document ou au rechargement des données. Le nombre maximal d'objets pouvant être inclus est de 500 lorsque l'option Définir comme référence est utilisée.
Effacer la référence Cette commande est remplacée par la commande Définir comme référence lorsqu'une référence a été définie. En la choisissant, la référence sera effacée et le graphique sera affiché dans son mode initial.
Cloner Effectue une copie identique du graphique. Si un graphique détaché est cloné, le clone est attaché.
Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Imprimer... Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression.
Imprimer au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer les valeurs vers Excel Exporte les données sous-jacentes (l'équivalent en tableau simple du graphique) vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Le tableau apparaîtra dans une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.
Exporter... Ouvre une boîte de dialogue destinée à enregistrer une image du graphique dans un fichier. L'image peut être enregistrée au format png, jpg, bmp ou gif.
Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Valeurs
Copie les valeurs dans le Presse-papiers sous la forme d'un tableau.
Image
Copie une image de l'objet graphique dans le Presse-papiers. L'image inclut ou exclut la légende et la bordure de l'objet de feuille selon les paramètres définis dans la boîte de dialogue Préférences utilisateur : onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Propriétés du graphique : Général

À la page Général, vous pouvez définir des propriétés telles que le titre et le type de graphique. Il s'agit de la première page de l'assistant Graphique instantané et de la boîte de dialogue Propriétés du graphique.

Titre de la fenêtre

Titre à afficher dans l'en-tête de la fenêtre. Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Afficher le titre dans le graphique

Par défaut, le titre du graphique correspond à l'étiquette de la première expression définie. Désélectionnez cette case à cocher si vous préférez ne pas afficher de titre de graphique. Pour afficher le titre initial, il vous suffit de cocher la case. Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues. Le titre du graphique ne s'affiche pas dans les tableaux croisés dynamiques et les tableaux simples.

Syntaxe des expressions pour les formules calculées

Paramètres du titre Définissez les paramètres avancés du titre du graphique en cliquant sur le bouton Paramètres du titre.
Paramètres d'impression

En cliquant sur le bouton Paramètres d'impression, vous accédez à la boîte de dialogue Paramètres d'impression dans laquelle vous définissez les marges et le format des en-têtes et pieds de page. La boîte de dialogue Paramètres d'impression comprend deux onglets, Disposition et En-tête/Pied de page.

Imprimer : Disposition et Imprimer : En-tête/Pied de page

État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Pour les graphiques, l'ID commence par CH01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Interpréteur de macros interne

Détaché Si cette option est activée, le graphique sera détaché, ce qui signifie qu'il ne sera plus mis à jour de façon dynamique lorsque des sélections seront effectuées.
Lecture seule Si cette option est activée, le graphique est en lecture seule, c'est-à-dire que vous ne pouvez pas faire de sélections en cliquant sur le graphique ou en le balayant à l'aide de la souris.
Condition de calcul Saisir une expression dans cette zone de texte définit une condition qui doit être remplie pour que le graphique soit affiché. Si la condition n'est pas satisfaite, le texte « Condition de calcul non remplie » s'affiche dans le graphique. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.
Type de graphique Le groupe Type de graphique sert à sélectionner la disposition de base du graphique. Pour plus d'informations sur les différents types de graphiques, voir Types de graphiques.
Changement de type rapide Dans ce groupe, vous pouvez activer une icône à partir de laquelle l'utilisateur pourra changer de type de graphique sans avoir à passer par la boîte de dialogue de propriétés du graphique.
Types autorisés
Dans cette liste, vous pouvez sélectionner les types de graphique devant figurer dans la liste déroulante. Vous devez en choisir plusieurs pour que le changement de type rapide soit activé.
Position préférée de l'icône
Dans les graphiques, l'icône de changement de type rapide peut être placée soit à l'intérieur du graphique, soit dans la légende de l'objet de feuille. Pour les tableaux, la barre de titre est la seule possibilité.
Réinitialiser le dimensionnement Si vous cliquez sur ce bouton, tous les dimensionnements de légende, de titre, etc. effectués par l'utilisateur dans les diagrammes seront réinitialisés. Les éléments ancrés ne seront pas modifiés.
Réinitialiser l'ancrage Si vous cliquez sur ce bouton, tous les ancrages de légende, de titre, etc. effectués par l'utilisateur dans les diagrammes seront réinitialisés.
Messages d'erreur

Ouvre la boîte de dialogue Messages d'erreur personnalisés.

Messages d'erreur personnalisés

Mode de référence Les paramètres de configuration de l'arrière-plan de référencement doivent être tracés lors de l'utilisation de l'option Définir comme référence disponible dans le menu contextuel du graphique. Ce paramètre n'est valable que pour certains graphiques.

Propriétés du graphique : Dimensions

L'onglet Propriétés du graphique : Dimensions est accessible via un clic droit sur un graphique puis en choisissant Propriétés, ou en sélectionnant Propriétés dans le menu Objet lorsque le graphique est actif.

À la création d'un graphique, vous devez vous poser deux questions :

  • Qu'est-ce que vous voulez voir ? À quoi doit correspondre la taille des barres dans l'histogramme ? La réponse pourrait être la « somme des ventes », par exemple. On le détermine sous l'onglet Expressions.
  • Comment voulez-vous grouper ces données ? Quelles valeurs de champs voulez-vous utiliser comme étiquettes des barres de l'histogramme ? La réponse pourrait être « par pays », par exemple. On le détermine sous l'onglet Dimensions.

Un graphique peut afficher une ou plusieurs dimensions. La limite supérieure dépend du type de graphique actuel, de la complexité des données et de la mémoire disponible. Les graphiques de type secteurs, courbe et nuage de points peuvent afficher au maximum deux dimensions ; les graphiques de type histogramme, blocs et bulles, trois. Les radars et les entonnoirs ne peuvent afficher qu'une seule dimension, et les jauges n'utilisent aucune dimension. Toutes les autres dimensions seront ignorées.

Une dimension de graphique obtient ses valeurs à partir d'un champ indiqué sur la page Propriétés du graphique : Dimensions. Une dimension peut consister en un groupe de champs (voir Éditer les groupes ci-dessous) plutôt qu'en un seul champ.

Une dimension peut consister en un seul champ, un groupe ou une expression (dimension calculée). Il peut également s'agir d'une dimension créée synthétiquement.

Fonctions de dimension synthétique

Déplacez les champs en les sélectionnant (clic, Ctrl+ clic) et en utilisant les boutons Ajouter > ou < Supprimer, ou en double-cliquant directement sur vos sélections.

Les dimensions de graphique peuvent aussi être calculées à partir d'une expression.

Cet onglet sert à définir les dimensions.

Champs/groupes disponibles

Liste de tous les champs/groupes de champs utilisables comme dimensions (c'est-à-dire le long de l'axe des abscisses dans un histogramme classique). Les groupes de champs sont précédés d'une flèche verticale dans le cas de groupes hiérarchiques ou d'une flèche arrondie dans le cas de groupes cycliques. Les groupes sont définis via la page Propriétés du document : Groupes. Sélectionnez les éléments à utiliser/supprimer en cliquant dessus. Utilisez le bouton Ajouter > ou le bouton < Supprimer pour les déplacer vers la colonne voulue.
Le nombre de dimensions pouvant être affichées varie en fonction du type de graphique.
Tous les champs s'affichant dans plus d'une table interne sont précédés d'un symbole de clé. Les secteurs, les courbes et les nuages de points ne peuvent pas afficher plus de deux dimensions. Dans les histogrammes, vous pouvez montrer jusqu'à trois dimensions.

Propriétés du document : Groupes

Afficher les champs système Lorsque cette option est cochée, les champs système s'affichent dans la colonne Champs/groupes disponibles.
Afficher les champs de la table Ici, vous contrôlez les champs/groupes qui apparaissent dans la liste Champs/groupes disponibles. La liste déroulante affiche l'option Toutes les tables par défaut.
L'option Toutes les tables (qualifiées) affiche les champs qualifiés par le nom des tables dans lesquelles ils figurent. Autrement dit, les champs clés (de connexion) sont répertoriés plus d'une fois. (Cette option n'est utilisée qu'à des fins d'affichage et n'a rien à voir avec les champs Qualify dans le script de chargement.)
Il est aussi possible d'afficher les champs d'une seule table à la fois. À noter que les groupes disponibles apparaissent toujours dans la liste.
Éditer les groupes... Ce bouton ouvre directement l'onglet Propriétés du document : Groupes, permettant de définir les groupes de champs à utiliser comme dimensions.
Animer... Ouvre la boîte de dialogue Animation à partir de laquelle vous pouvez utiliser la première dimension du graphique à des fins d'animation. L'animation est seulement possible sur les graphiques de type image bitmap, à l'exclusion des graphiques en secteurs. Quelques fonctionnalités peuvent être limitées si les animations sont utilisées.
Schéma croisé... Ouvre la boîte de dialogue Paramètres du schéma croisé à partir de laquelle vous pouvez créer un tableau de graphiques basé sur la première dimension. Il est possible d'afficher tout type de graphique bitmap sous forme de schéma croisé.
Dimensions utilisées

Cette liste contient les dimensions actuellement sélectionnées pour le graphique. Le nombre de dimensions que l'on peut utiliser varie selon le type de graphique. Les dimensions superflues pour un type de graphique donné seront ignorées. Lorsque vous les utilisez dans les tableaux, vous pouvez formater les cellules de données de dimension de façon dynamique au moyen d'attributs. Dès qu'un attribut est spécifié pour une dimension, son icône en dégradé de gris s'affiche en couleur ou, comme dans le cas de l'attribut Format texte, elle passe du gris au noir. Ces paramètres sont prioritaires sur ceux du graphique. Cliquez sur l'icône de développement « + » située en regard de n'importe quelle dimension pour afficher les emplacements réservés ou l'attribut de la dimension.
Couleur d'arrière-plan
Double-cliquez sur Couleur d'arrière-plan pour saisir un attribut destiné à calculer la couleur d'arrière-plan de la cellule de dimension. L'expression utilisée doit renvoyer une représentation de couleur valide (un nombre représentant les composants rouge, vert et bleu tels qu'ils sont définis en Visual Basic). Pour ce faire, utilisez l'une des fonctions spéciales de couleur des graphiques. Si le résultat de l'expression n'est pas une représentation de couleur valide, le programme utilisera par défaut le noir.
Couleur du texte
Double-cliquez sur Couleur du texte pour saisir un attribut destiné à calculer la couleur du texte de la cellule de dimension. L'expression utilisée doit renvoyer une représentation de couleur valide (un nombre représentant les composants rouge, vert et bleu tels qu'ils sont définis en Visual Basic). Pour ce faire, utilisez l'une des fonctions spéciales de couleur des graphiques. Si le résultat de l'expression n'est pas une représentation de couleur valide, le programme utilisera par défaut le noir.

Fonctions de couleur

Format texte
Double-cliquez sur Format texte pour saisir un attribut destiné à calculer le style de police du texte dans la cellule de table pour chaque cellule de dimension. L'expression utilisée comme expression de format texte doit renvoyer une chaîne contenant un <B> pour le texte en gras, un <I> pour le texte en italique et/ou un <U> pour le texte souligné.

Utilisez les boutons Promouvoir et Abaisser pour trier les dimensions dans la liste Dimensions utilisées.

Ajouter une dimension calculée...

Ajoute une nouvelle dimension et ouvre la boîte de dialogue Édition d'une expression à des fins d'édition. Une dimension de graphique est souvent dans un seul champ, mais peut aussi être calculée de façon dynamique. Une dimension calculée consiste en une expression impliquant un ou plusieurs champs. On peut y utiliser toutes les fonctions standard. Il n'est pas possible d'utiliser les fonctions d'agrégation, mais vous pouvez inclure la fonction Aggr pour obtenir une agrégation simplifiée.

Syntaxe des expressions pour les formules calculées

Éditer... Ouvre la boîte de dialogue Éditer l'expression permettant d'éditer la dimension. Voir Ajouter une dimension calculée... ci-dessus pour plus de détails sur les dimensions calculées.
Paramètres de la dimension sélectionnée

Dans ce groupe, vous trouverez les paramètres des dimensions sélectionnées.
Activer la condition
Cocher cette case permet de masquer ou d'afficher la dimension de manière dynamique, selon la valeur d'une expression conditionnelle saisie, en cliquant sur le bouton ... de la zone d'édition ci-dessous.

Supprimer si la valeur est nulle
Si cette case est cochée, la dimension sélectionnée dans la liste Dimensions utilisées située au-dessus n'est pas affichée dans le graphique lorsque sa valeur est NULL.
Afficher toutes les valeurs
Cochez cette case pour afficher toutes les valeurs de dimensions indépendamment de la sélection. Étant donné que la valeur de l'expression est nulle pour les valeurs de dimensions exclues, l'option Supprimer les valeurs zéro de la page Présentation doit être désélectionnée pour que l'option Afficher toutes les valeurs fonctionne. L'option Afficher toutes les valeurs ne s'applique pas lorsque vous utilisez une expression comme dimension.
Afficher la légende
Lorsque l'option Afficher la légende est cochée, les « noms » des valeurs de champs s'affichent le long de l'axe des abscisses.
Étiquette
Si l'option Étiquette est cochée, le nom du champ est visible. Les étiquettes sont modifiables dans la zone de texte figurant en dessous. Une étiquette peut aussi être définie par une expression d'étiquette calculée pour une mise à jour dynamique du texte de l'étiquette. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Avancé...
Ce bouton ouvre la boîte de dialogue Paramètres de champ avancés qui contient des paramètres destinés à la représentation imagée des valeurs de champs et des options spéciales de recherche textuelle.

Advanced Field Settings

Commentaire
Champ de commentaire dans lequel la dimension sélectionnée peut être décrite. Le commentaire peut être saisi sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.
Sauts de page
Ce paramètre s'applique uniquement à l'emploi de sauts de page dans l'impression de tableaux croisés dynamiques ou de tableaux simples. Trois modes sont disponibles, avec les effets suivants :

Aucun saut de page
Insère uniquement les sauts de pages nécessaires au bas de chaque page.
Sauts conditionnels
Insère un saut de page, à moins que toutes les lignes contenant la valeur de dimension suivante puissent tenir sur la page actuelle.
Sauts forcés
Insère un saut de page à chaque fois que la valeur de la dimension change.

Propriétés du graphique : Limites dimensionnelles

Il est possible de définir des limites dimensionnelles pour des types de graphiques, sauf pour les jauges et les tableaux croisés dynamiques.

L'onglet Limites dimensionnelles contrôle le nombre de valeurs de dimension visibles dans un graphique donné.

Avant d'en arriver là, il est important de décrire l'effet produit par les trois options disponibles dans la liste déroulante. La liste déroulante contient trois valeurs : Première, Maximum et Minimum. Ces valeurs contrôlent la façon dont le moteur de calcul trie les valeurs qu'il renvoie au moteur de génération de graphiques. Si la dimension doit être restreinte, vous devez obligatoirement sélectionner l'une de ces options. Le tri est uniquement effectué sur la première expression, sauf dans les tableaux croisés dynamiques, lorsque le tri de la partie principale peut outrepasser le tri de la première dimension.

Cet onglet sert à définir les limites dimensionnelles. Chaque dimension du graphique est configurée séparément.

Limites

Limiter les valeurs affichées à l'aide de la première expression
Ces propriétés permettent de déterminer le nombre de valeurs de dimension à afficher dans le graphique d'après les paramètres définis ci-dessous.

Afficher uniquement
Sélectionnez cette option pour afficher le nombre x de valeurs visibles : Première, Maximum ou Minimum. Si cette option est définie sur 5, cinq valeurs seront visibles. Si l'option Afficher Autres est activée pour la dimension, le segment Autres sélectionne l'une des cinq valeurs d'affichage.

L'option Première renvoie les lignes en fonction des options sélectionnées sous l'onglet Trier de la boîte de dialogue des propriétés. Si le graphique est un tableau simple, les lignes sont renvoyées d'après l'ordre de tri principal actif. Autrement dit, un utilisateur peut modifier l'affichage des valeurs en double-cliquant sur n'importe quel en-tête de colonne et en définissant cette colonne comme ordre de tri principal.

L'option Maximum renvoie les lignes par ordre décroissant d'après la première expression figurant dans le graphique. Lorsqu'elles sont utilisées dans un tableau simple, les valeurs de dimension affichées restent cohérentes tout en permettant le tri interactif des expressions. Les valeurs des dimensions changent (ou peuvent changer) en cas de modification de l'ordre des expressions.

L'option Minimum renvoie les lignes par ordre croissant d'après la première expression figurant dans le graphique. Lorsqu'elles sont utilisées dans un tableau simple, les valeurs de dimension affichées restent cohérentes tout en permettant le tri interactif des expressions. Les valeurs des dimensions changent (ou peuvent changer) en cas de modification de l'ordre des expressions.

Saisissez le nombre de valeurs à afficher. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.

Afficher uniquement les valeurs :
Sélectionnez cette option pour afficher toutes les valeurs de dimension qui remplissent la condition spécifiée pour cette option. Sélectionnez pour afficher les valeurs basées sur un pourcentage du total ou sur un montant exact. L'option par rapport au total active un mode relatif semblable à l'option Relatif de l'onglet Expressions de la boîte de dialogue Propriétés. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.

Afficher uniquement les valeurs qui cumulent à :
Lorsque cette option est sélectionnée, toutes les lignes jusqu'à la ligne active sont cumulées et le résultat est comparé à l'ensemble de valeurs dans l'option. L'option par rapport au total active un mode relatif semblable à l'option Relatif de l'onglet Expressions de la boîte de dialogue Propriétés et compare les valeurs cumulées (basées sur les valeurs première, maximum et minimum) au total global. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression. Sélectionnez Inclure les valeurs limites pour inclure la valeur de dimension qui contient la valeur de comparaison.

Syntaxe des expressions pour les formules calculées

Remarque: Les valeurs négatives sont exclues du calcul de la somme de restrictions cumulées. Il est recommandé de ne pas appliquer de restrictions relatives à des champs contenant des valeurs négatives.
Remarque: Si vous ajoutez une limite à une dimension calculée dont les données sont triées, la limite dimensionnelle est appliquée avant l'ordre de tri.
Options Afficher Autres
Si cette option est activée, un segment Autres est généré dans le graphique. Toutes les valeurs de dimension ne répondant pas aux critères de comparaison des restrictions d'affichage sont regroupées dans le segment Autres. S'il existe des dimensions après celle qui est sélectionnée, l'option Réduire les dimensions internes permet de contrôler l'affichage des valeurs individuelles des dimensions ultérieures/suivantes sur le graphique.

Étiquette
Saisissez le nom que vous souhaitez afficher dans le graphique. Si aucun texte n'est saisi, l'étiquette reproduira automatiquement le texte de l'expression. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.

Afficher le total
Lorsque cette option est activée, le graphique affiche un total pour la dimension sélectionnée. Ce total se comporte différemment du total des expressions, lequel est toujours configuré sous l'onglet Expressions de la boîte de dialogue des propriétés.

Étiquette
Saisissez le nom que vous souhaitez afficher dans le graphique. Si aucun texte n'est saisi, l'étiquette reproduira automatiquement le texte de l'expression. La valeur peut être saisie sous forme de formule calculée. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression.

Mode de regroupement global
L'option s'applique uniquement aux dimensions internes. Lorsque cette option est activée, les restrictions sont calculées à partir de la dimension sélectionnée uniquement. Toutes les dimensions précédentes sont ignorées. Si l'option est désactivée, les restrictions sont calculées d'après toutes les dimensions précédentes.

Totaux des expressions comparés aux totaux des dimensions

Les totaux des dimensions sont calculés par le moteur de calcul et sont ensuite renvoyés au moteur de génération de graphiques sous forme de lignes séparées (ou valeurs de dimension). Ceci aura un impact sur les lignes Autres. La différence entre l'utilisation des totaux des expressions et des totaux des dimensions est la suivante.

Totaux des expressions et totaux des dimensions

Lorsque vous utilisez les totaux des dimensions, vous pouvez avoir des sous-totaux dans un tableau simple.

Propriétés du graphique : Expressions

Pour accéder à l'onglet Propriétés du graphique : Expressions, cliquez sur un graphique ou une table avec le bouton droit de la souris et choisissez Propriétés dans le menu Objet.

À la création d'un graphique, vous devez vous poser deux questions :

  • Que doit illustrer la taille des barres, etc. ? Il s'agit d'Expression(s) (par exemple, somme des Ventes nettes).
  • Comment les données doivent-elles être regroupées ? Il s'agit de Dimension(s) (par exemple, par Pays).
Remarque: L'onglet Expressions change en fonction du type de graphique ou de table. Si une option est grisée, elle n'est pas disponible pour le type de graphique ou de table sélectionné.
Liste des expressions

La liste des expressions affichée dans le volet supérieur gauche est un arbre complet avec de nombreuses options de contrôle.
En face de chaque expression (ou groupe d'expressions) une icône de développement (un « + ») s'affiche. Cliquer sur cette icône ouvre les sous-expressions ou les attributs sous-jacents. Elle est alors aussitôt remplacée par une icône de réduction (« - »). Certaines options de tracé utilisent des sous-expressions, c'est-à-dire un ensemble de deux expressions ou plus qui définissent ensemble le symbole du tracé (par exemple les options Cours de bourse ou Boîte à moustaches décrites ci-dessous).
Les données de l'expression peuvent aussi être formatées de manière dynamique au moyen d'attributs. Cliquez sur l'icône de développement devant n'importe quelle expression pour afficher les emplacements des attributs de la dimension. Il s'agit des emplacements suivants :

Couleur d'arrière-plan
Éditez l'expression Couleur d'arrière-plan par défaut pour créer l'attribut permettant de calculer la couleur de tracé du point de données. La couleur calculée prévaut sur la sélection de couleur par défaut de QlikView et doit constituer une représentation de couleur valide, obtenue à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le programme utilisera par défaut le noir. On peut créer par la même méthode une expression auxiliaire pour la Couleur du texte.

Fonctions de couleur

Couleur du texte
Il est possible de créer une expression auxiliaire pour l'attribut Couleur du texte à l'aide de la même méthode que celle appliquée à la couleur d'arrière-plan (voir ci-dessus).

Format du texte
Éditez l'expression Format du texte pour saisir un attribut permettant de calculer le style de police du texte associé au point de données (Pour les tables : le texte dans la cellule de la table pour chaque cellule de dimension. Le format du texte calculé prévaut sur le style de table défini sous Propriétés du graphique : Style. L'expression utilisée comme expression de format texte doit renvoyer une chaîne contenant un <B> pour le texte en gras, un <I> pour le texte en italique et/ou un <U> pour le texte souligné. Notez qu'un signe = doit précéder la chaîne.

Secteur éclaté
Cliquez sur Secteur éclaté pour saisir un attribut destiné à déterminer si le secteur associé au point de données doit être dessiné détaché des autres. Ce type d'attribut n'existe que pour les secteurs.

Décalage de barre
Cliquez sur Décalage de barre pour saisir un attribut destiné à calculer un décalage de la barre ou du segment de barre associé au point de données. Le décalage peut être positif ou négatif et déplace la barre ou le segment en conséquence. Cela se révèle utile par exemple quand on veut obtenir des graphiques en cascade. Ce type d'attribut n'existe que pour les histogrammes.

Style de ligne
Cliquez sur Style de ligne pour saisir un attribut destiné à calculer le style de la ligne ou du segment de ligne associé au point de données. Ce type d'attribut n'existe que pour les courbes, les combinés et les radars. Vous pouvez contrôler l'épaisseur relative de la ligne au moyen d'une balise <Wn> où n correspond à un coefficient multiplicateur à appliquer à l'épaisseur de ligne par défaut du graphique. Le nombre n doit être un réel compris entre 0,5 et 8. Exemple : <W2.5>. Vous pouvez contrôler le style de la ligne au moyen d'une balise <Sn> où n est un entier compris entre 1 et 4 indiquant le style à utiliser (1=continu, 2=à tirets, 3=pointillé, 4=tirets/pointillé). Exemple : <S3>. Les balises <Wn> et <Sn> peuvent être combinées librement, mais seule la première occurrence de chacune compte. Les balises doivent être placées entre guillemets simples.

Afficher la valeur
Cliquez sur Afficher la valeur pour saisir un attribut destiné à déterminer si le tracé du point de données doit être complété d'une « étiquette de données », même si l'option Valeurs sur des points de données n'est pas sélectionnée pour l'expression principale. Si l'option Valeurs sur des points de données est sélectionnée pour l'expression principale, l'attribut sera ignoré. Ce type d'attribut n'existe que pour les histogrammes, graphiques en courbes, graphiques en secteurs, entonnoirs et combinés.

Ajouter Pour créer de nouvelles expressions et sous-expressions, utilisez le bouton Ajouter. Cette option est également disponible dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions.
Supprimer Le bouton Supprimer permet de supprimer de la liste des expressions déjà créées. Cette option est également disponible dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions.
Copier L'option Copier n'est disponible que dans le menu contextuel apparaissant via un clic droit sur une expression ou une sous-expression/attribut dans la liste d'expressions. L'utilisation de cette commande sur une expression principale entraîne la copie des paramètres et données associés à l'expression (y compris les étiquettes) dans le Presse-papiers comme faisant partie du xml. L'expression peut ensuite être collée dans le même graphique ou dans un autre graphique QlikView, dans le même document ou dans un document différent. Si vous utilisez cette commande sur un attribut, seule la définition de l'attribut est copiée. L'attribut peut ensuite être collé sur n'importe quelle expression principale du même graphique ou d'un graphique différent.
Exporter... L'option Exporter ... n'est disponible que dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions. L'utilisation de cette commande sur une expression principale permet l'exportation des paramètres et données associés à l'expression (y compris les étiquettes) vers un fichier xml. L'expression peut ensuite être importée dans le même graphique ou dans un autre graphique QlikView, dans le même document ou dans un document différent. La commande ouvre la boîte de dialogue Exporter l'expression sous permettant de sélectionner la destination du fichier d'exportation. Le fichier portera l'extension Ex.xml.
Coller L'option Coller n'est disponible que dans le menu contextuel apparaissant via un clic droit sur une expression ou une sous-expression/attribut dans la liste d'expressions. Si une expression principale a été copiée dans le Presse-papiers, vous pouvez la coller dans une zone vide de la liste d'expressions. Vous créez alors une nouvelle expression identique à celle copiée. Si un attribut a été copié, vous pouvez le coller dans une expression principale.
Importer L'option Importer n'est disponible que dans le menu contextuel apparaissant via un clic droit dans une zone vide de la liste d'expressions. La commande ouvre une boîte de dialogue permettant de rechercher l'expression exportée. L'expression importée apparaît alors sous la forme d'une nouvelle expression dans le graphique.
Promouvoir
Abaisser
Si plusieurs expressions sont affichées, on peut les ordonner à l'aide des boutons Promouvoir et Abaisser. On change alors l'ordre dans lequel les colonnes, etc. apparaissent dans le graphique.
Grouper On peut utiliser le bouton Grouper pour grouper des expressions en un ou plusieurs cycles, à condition que deux expressions ou plus soient disponibles. Dans la disposition QlikView, vous pouvez sélectionner les expressions appartenant à un groupe en cliquant sur l'icône de cycle qui s'affiche sur le graphique (= Cycle). Effectuez un clic droit sur cette même icône pour obtenir une liste des expressions du groupe actuellement inutilisées, que vous pouvez sélectionner directement.
Remarque:

Ne confondez pas l'option Cycle avec les groupes cycliques !

Groupes non hiérarchiques (cycliques)

Dégrouper Sélectionner une expression appartenant à un groupe et cliquer sur Dégrouper extrait l'expression du groupe. S'il ne reste qu'une seule expression dans le cycle après extraction, elle est également extraite et le groupe est supprimé.
Activer L'expression devant être omise du graphique est définie en décochant cette case.
Relatif Cette case cochée, le graphique affiche le résultat en pourcentage plutôt qu'en nombres absolus. Cette option n'est pas disponible pour les tableaux croisés dynamiques.
Invisible Cocher cette case empêche le tracé de cette expression tout en gardant l'espace qui lui est réservé.
Conditionnel Lorsque cette case est cochée, vous pouvez définir une condition, basée sur la sélection active, qui détermine si l'expression doit être affichée ou masquée. Si la condition est évaluée comme VRAI ou NULL, l'expression est visible tandis que si elle est évaluée comme FAUX, l'expression ne s'affiche pas.
Étiquette Devant l'étiquette de l'expression, une ou plusieurs icônes servent à indiquer le type de graphique utilisé et/ou les Options d'affichage sélectionnées pour l'expression (voir ci-dessous).
Définition Affiche la composition de l'expression sélectionnée. On peut modifier l'expression directement dans cette zone. Le bouton ... permet d'ouvrir la boîte de dialogue Éditer l'expression complète.
Commentaire Il s'agit d'un champ de commentaire dans lequel le créateur de l'expression peut décrire l'objet et la fonction de l'expression.
Options d'affichage Ce groupe permet de modifier la façon dont les points de données sont tracés ou ce qui sera saisi dans les cellules d'expression des tables du graphique. Certaines options ne sont disponibles que pour certains types de graphiques, certaines ne peuvent être combinées et certaines utiliseront une ou plusieurs expressions supplémentaires afin de créer des tracés complexes.

Barre
Affiche les valeurs de l'expression sélectionnée sous forme de barres. Cette option est disponible uniquement pour les histogrammes et les combinés.

Symbole
Affiche les valeurs de l'expression sélectionnée sous forme de symboles. Cette option est disponible uniquement pour les courbes et les combinés. Choisissez l'un des différents symboles du menu déroulant.

Ligne
Affiche les valeurs de l'expression sélectionnée sous forme de ligne. Cette option est disponible uniquement pour les courbes et les combinés. Dans le menu déroulant, vous avez le choix entre Standard, Lisse et trois courbes de palier différentes.

Cours boursier
Cochez cette case pour tracer l'expression comme un cours boursier. L'expression sera précédée de sa propre icône dans la liste des expressions et apparaîtra comme un emplacement vide avec quatre sous-expressions. La première sous-expression servira à tracer un point élevé du cours boursier. La deuxième sous-expression servira de point bas. Ces deux sous-expressions doivent contenir des définitions valides pour que le cours boursier puisse être dessiné. La troisième sous-expression est facultative, mais peut servir à tracer le cours à la fermeture. La quatrième sous-expression est aussi facultative, mais peut servir à tracer le cours à l'ouverture. De nouvelles sous-expressions vides sont automatiquement créées lorsque la case Cours de bourse est sélectionnée pour l'expression. Lorsque la case Cours de bourse a été définie pour une expression, vous ne pouvez plus cocher les cases Barre, Ligne, Symbole, Boîte à moustaches ni Avec barres d'erreur pour la même expression. On ne peut pas sélectionner Cours de bourse pour une expression si l'une de ces options est déjà sélectionnée pour cette expression. Cette option n'est disponible que pour les combinés.

Boîte à moustaches
Cochez cette case pour tracer l'expression comme une boîte à moustaches, souvent utilisée pour afficher des données statistiques. L'expression sera précédée de sa propre icône dans la liste des expressions et apparaîtra comme un emplacement vide avec cinq sous-expressions. La première sous-expression servira à tracer une valeur haute de la boîte à moustaches. La deuxième sous-expression servira de valeur basse. Ces deux expressions doivent contenir des définitions valides pour que la boîte à moustaches puisse être dessinée. Les troisième à cinquième sous-expressions sont facultatives. Si elles sont utilisées, ces sous-expressions définissent une médiane, une moustache supérieure et une moustache inférieure. Les observations aberrantes sont une extension courante de la boîte à moustaches pour les valeurs extrêmes. Elles peuvent être obtenues en représentant des expressions séparées sous forme de symbole. De nouvelles sous-expressions vides sont automatiquement créées lorsque vous sélectionnez Boîte à moustaches pour l'expression principale. Lorsque vous avez sélectionné Boîte à moustaches, vous ne pouvez plus activer les options Barre, Ligne, Symbole, Cours de bourse ni Avec barres d'erreur pour la même expression. Il n'est pas possible de sélectionner Boîte à moustaches pour une expression si l'une de ces options est déjà sélectionnée pour l'expression. Cette option n'est disponible que pour les combinés.

Avec barres d'erreur
Cochez cette case pour utiliser une ou deux expressions après l'expression sélectionnée comme expressions auxiliaires pour les barres d'erreurs tracées par-dessus les points de données de l'expression principale. Si Symétrique est sélectionné, une seule expression auxiliaire sera utilisée et représentée symétriquement autour du point de données. Si Asymétrique est sélectionné, deux expressions auxiliaires seront utilisées et tracées respectivement au-dessus et en dessous du point de données. Les expressions de barre d'erreur doivent renvoyer des nombres positifs. Les expressions auxiliaires utilisées pour les barres d'erreurs sont précédées de leur propre icône (symétrique), (asymétrique haut) ou (asymétrique bas) dans la liste des expressions et ne peuvent pas être utilisées pour autre chose dans le graphique. Si aucune expression n'a été définie après l'expression sélectionnée, de nouvelles expressions auxiliaires test seront créées automatiquement. Cette option est disponible uniquement pour les histogrammes, les courbes et les combinés.

Valeurs sur des points de données
Cochez cette case pour que le résultat d'une expression soit écrit sous forme de texte au-dessus des points de données. Cette option est disponible uniquement pour les histogrammes, les courbes, les combinés et les secteurs. Lors d'une utilisation pour les secteurs, la valeur sera affichée à côté des secteurs.

Texte sur l'axe
Cochez cette case pour afficher le résultat d'une expression sous forme de texte à chaque valeur des abscisses, l'axe et les étiquettes de l'axe. Cette option est disponible uniquement pour les histogrammes, les courbes et les combinés.

Texte sous forme d'info-bulle
Cochez cette case pour que le résultat d'une expression s'affiche sous forme d'info-bulle qui apparaît lorsque vous pointez avec la souris sur un point de données d'un graphique dans la disposition. Il est possible d'utiliser cette option avec ou sans les autres options d'affichage. Il est ainsi possible qu'une expression n'apparaisse pas dans le graphique lui-même, mais uniquement sous forme de fenêtre contextuelle.
Options d'affichage

Représentation
Cette option est disponible uniquement pour les tableaux simples et les tableaux croisés dynamiques.

Texte
Les valeurs de l'expression sont toujours interprétées et affichées sous forme de texte.

Image
Lorsque cette option est activée, QlikView tente d'interpréter chaque valeur d'expression comme une référence à une image. La référence peut être le chemin d'un fichier image sur le disque (par exemple, C:\Monimage.jpg) ou dans le document qvw lui-même (par exemple qmem://<Nom>/<Pierre>). Si QlikView ne peut pas interpréter la valeur d'une expression comme référence d'image valide, il affichera la valeur elle-même, sauf si la case Masquer le texte quand l'image n'est pas disponible est cochée.

Jauge circulaire, Jauge linéaire, Jauge - Feux de signalisation, Jauge de type voyant
Quelle que soit l'option de jauge, le graphique correspondant figurera dans la cellule de tableau disponible sous forme d'image. Il est possible de modifier la disposition de la jauge via la boîte de dialogue Propriétés du graphique : Présentation, accessible via le bouton Paramètres de la jauge.

Mini graphique
Lorsque cette option est activée, QlikView affiche les valeurs des expressions sous forme d'histogramme ou de graphique en courbes. Le graphique est inclus dans la cellule de tableau disponible. Vous pouvez modifier les paramètres visuels du graphique en cliquant sur le bouton Paramètres du mini graphique. Cette option n'est disponible que pour les tableaux simples.

Mini chart settings

Remarque: Le mini graphique ne s'affiche pas lors de l'exportation vers Excel.

Lien
Sélectionnez cette option pour saisir une expression dans le champ Définition destiné à créer un lien activable par un clic dans la cellule de tableau. L'expression doit renvoyer un texte pouvant être interprété comme DisplayText<url>LinkText. Le texte DisplayText s'affiche dans la cellule de tableau et le texte LinkText correspond au lien qui s'ouvre dans une nouvelle fenêtre de navigateur. Si un lien est défini, la valeur figurant dans la cellule de tableau est soulignée. Si aucun lien n'est défini, la valeur n'est pas soulignée. Sachez qu'il n'est pas possible d'effectuer des sélections dans une cellule si Lien est défini comme mode d'affichage. Le bouton ... permet d'ouvrir la boîte de dialogue Éditer l'expression complète.
Exemples :
=Nom & '<url>' & Lien
=Nom & '<url>www.qlikview.com'
Nom et Lien sont des champs de table chargés dans le script.

Formatage d'image
Disponible uniquement quand l'option Image ci-dessus a été sélectionnée. Cette option est disponible uniquement pour les tableaux simples et les tableaux croisés dynamiques. Ce paramètre décrit comment QlikView formate l'image pour l'adapter à la cellule. Il y a quatre possibilités : 

Sans étirement
Si cette option est sélectionnée, l'image s'affiche telle quelle, sans aucun étirement. L'image peut donc être partiellement cachée ou ne remplir qu'une partie de la cellule.
Remplir
Si cette option est sélectionnée, l'image sera étirée et s'adaptera à la cellule sans conserver ses proportions.
Conserver les proportions
Si cette option est sélectionnée, l'image est étirée autant que possible pour remplir la cellule tout en conservant ses proportions.
Proportionnel
Si cette option est sélectionnée, l'image est étirée dans les deux sens pour remplir la cellule tout en conservant ses proportions. En général, cela entraîne le rognage de l'image dans un sens.
Cumul

En choisissant parmi les paramètres de ce groupe, vous déterminerez si les valeurs doivent être cumulées ou non dans le graphique. Dans un graphique cumulé, chaque valeur Y est ajoutée à la valeur Y de la valeur X suivante. Dans un histogramme cumulé montrant la somme des ventes par années, par exemple, la valeur de l'année 1996 est ajoutée à celle de l'année 1997. Si votre graphique contient plusieurs expressions, sélectionnez l'expression dont les valeurs doivent être cumulées dans la liste des expressions. Le cumul n'est pas disponible pour les tableaux croisés dynamiques.

Absence de cumul
Si cette option est sélectionnée, les valeurs Y de l'expression sélectionnée du graphique ne seront pas cumulées.

Cumul total
Si cette option est sélectionnée, chaque valeur Y cumulera toutes la valeurs Y précédentes de l'expression. Voir ci-dessus au paragraphe Cumul. L'option Cumul total ne peut pas s'appliquer à des dimensions contenant des valeurs de type null ou égales à 0.

Remarque: L'option Cumul total ne peut pas s'appliquer si le graphique de type schéma croisé est activé.

Cumuler n dernières valeurs
En saisissant un nombre dans cette zone, vous définissez le nombre de valeurs d'ordonnée de l'expression à cumuler. Voir ci-dessus au paragraphe Cumul.

Totaux

Ce groupe est activé pour l'expression sélectionnée pour les objets de type Graphique de tableau simple uniquement. Il existe trois paramètres possibles :

Pas de totaux
Les totaux ne sont pas calculés pour l'expression sélectionnée.
Total de l'expression
Le total de l'expression est évalué au niveau suivant. Par exemple, si une expression génère le salaire mensuel moyen pour un certain nombre d'employés, le Total de l'expression générera la moyenne totale de tous les salaires.
F(x) des lignes
Si cette option est sélectionnée, les valeurs individuelles de chaque point de données (chaque barre dans un histogramme, chaque ligne dans un tableau simple, etc.) pour l'expression sélectionnée seront agrégées à l'aide de la fonction d'agrégation sélectionnée dans cette liste déroulante (en général ajoutées).

Remarque: La valeur de Première chaîne ou Dernière chaîne est la valeur la plus élevée ou la plus basse, par ordre alphanumérique, identifiée dans la table. L'ordre de la séquence alphanumérique commence à 0 jusqu'à 9, suivi par A jusqu'à Z.
Largeur de bordure des barres Spécifie la largeur de la bordure qui entoure les barres correspondant à cette expression, dans les histogrammes ou les combinés. La valeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Expressions sous forme de légende Lorsque plusieurs expressions sont utilisées, cette option affiche à côté du graphique une légende présentant les expressions et les couleurs correspondantes.
Courbes de tendance

Dans certains graphiques QlikView, les tracés des expressions peuvent être complétés ou remplacés par des courbes de tendance statistiques. Les courbes de tendance ne peuvent être affichées que dans les nuages de points, les courbes et les histogrammes/combinés avec au maximum une dimension et une expression affichées sous forme de barres. Pour les autres types de graphiques, les paramètres du groupe Courbes de tendance ne sont pas disponibles et sont sans effet. Dans les nuages de points, les points de données sont traités comme si y=f(x). Pour les histogrammes, les courbes et les combinés, vous pouvez désélectionner toutes les options d'affichage et ajouter encore des courbes de tendance, qui seront alors tracées sans les points de données sous-jacents. Dans les histogrammes, les courbes et les combinés, les courbes de tendance peuvent être extrapolées en spécifiant un intervalle de projection et/ou de rétroprojection (page Axes). Les courbes extrapolées seront en pointillé. Dans les graphiques à axe des abscisses discret, les courbes de tendance seront affichées sous forme de lignes avec symboles. Sur un axe continu, seule la ligne sera visible.

Moyenne
La moyenne est tracée sous forme de ligne droite.
Linéaire
Trace une ligne de régression linéaire.
Polynomial du 2ème degré
Trace une courbe de tendance polynomiale du deuxième degré.
Polynomial du 3ème degré
Trace une courbe de tendance polynomiale du troisième degré.
Polynomial du 4ème degré
Trace une courbe de tendance polynomiale du quatrième degré.
Exponentiel
Trace une courbe de tendance exponentielle.
Afficher l'équation
Si cette case est cochée pour une expression donnée, les courbes de tendance de l'expression seront complétées par une équation de courbe de tendance affichée sous forme de texte dans le graphique.
Afficher R2
Si cette case est cochée pour une expression donnée, les courbes de tendance de l'expression seront complétées par le coefficient de détermination affiché sous forme de texte dans le graphique.

Régression linéaire dans les graphiques de table

Propriétés du graphique : Trier

L'onglet Propriétés du graphique : Trier est accessible via un clic droit sur le graphique puis en choisissant Propriétés dans le menu Objet.

C'est ici que vous choisirez l'ordre de tri des dimensions du graphique parmi les ordres de tri disponibles.

L'onglet Propriétés du graphique : Trier pour les tableaux simples comporte des options légèrement différentes.

Propriétés du graphique : Trier (Tableau simple)

La liste Dimensions contient les dimensions du graphique. Pour définir un ordre de tri, marquez une dimension et choisissez un ou plusieurs ordres de tri à droite.

Valeur d'ordonnée Les valeurs de dimensions seront triées selon la valeur numérique de l'axe des ordonnées. Cette option n'est pas disponible pour les dimensions calculées.
État Les valeurs de dimensions seront triées selon leur état logique, c'est-à-dire sélectionné avant les valeurs facultatives et avant les valeurs exclues.
Expression Les valeurs de dimensions seront triées selon l'expression saisie dans la zone de texte située sous cette option de tri.
Fréquence Les valeurs de dimensions seront triées selon le nombre d'occurrences dans la table.
Valeur numérique Les valeurs de dimensions seront triées selon leur valeur numérique.
Texte Les valeurs de dimensions seront triées selon l'ordre alphabétique.
Ordre de chargement Les valeurs de dimensions seront triées selon leur ordre de chargement initial.

Elles sont présentées hiérarchiquement de haut en bas, de sorte que quand des ordres de tri contradictoires sont sélectionnés, le premier aura priorité. L'ordre de tri sélectionné peut être inversé en sélectionnant Décroissant au lieu de Croissant, ou A -> Z au lieu de Z -> A.

Si vous cliquez sur le bouton Par défaut, les valeurs des dimensions sont définies sur la valeur par défaut configurée dans la boîte de dialogue Propriétés du document : Trier.

La case Outrepasser l'ordre du tri du groupe est uniquement disponible lorsqu'une dimension de groupe est sélectionnée dans la liste Dimensions. Normalement, l'ordre de tri d'un groupe de dimension est déterminé pour chaque champ du groupe via les propriétés du groupe. En activant cette option, vous pouvez outrepasser ces paramètres au niveau du groupe et appliquer un seul ordre de tri pour la dimension, quel que soit le champ actif dans le groupe.

Propriétés du graphique : Style

Dans cet onglet, vous pouvez déterminer un style de base pour le graphique. Toutes les caractéristiques listées ne sont pas disponibles pour tous les types de graphique.

Aspect Choisissez un des styles disponibles. Dans certains cas, cela peut modifier non seulement l'apparence du graphique, mais aussi sa fonctionnalité.
Orientation Définissez l'orientation du graphique : verticale ou horizontale.
Sous-type Dans ce groupe, le mode est défini soit sur Groupé soit sur Empilé pour les barres (Superposé ou Empilé pour les radars). Ce paramètre n'est pertinent que lorsque le graphique affiche deux dimensions ou une dimension et plus qu'une seule expression. Les valeurs négatives pour les histogrammes empilés sont empilées séparément sous l'axe des abscisses.

Pour la présentation des histogrammes avec plusieurs dimensions et expressions, les principes suivants s'appliquent :
  • Deux dimensions au maximum peuvent apparaître sur l'axe des X.
  • Une troisième dimension peut apparaître avec des barres empilées multicolores.
  • Seuls les graphiques des tables peuvent afficher plus de trois dimensions.
  • Lorsque deux expressions ou plus sont activées, les deux premières dimensions apparaissent sur l'axe des X et l'expression avec des barres empilées multicolores.
  • Lorsque deux expressions ou plus sont activées et que le sous-groupe est défini sur le mode empilé, toutes les expressions d'une même pile sont calculées en fonction d'un seul axe (par défaut, celui de gauche). Cela se produira même si vous avez défini une expression à calculer d'après l'axe de gauche et une autre d'après l'axe de droite.
 

La table suivante affiche le mode de présentation des sous-types comportant plusieurs dimensions et expressions.

Dimensions Expressions Sous-type
1 1 Barre unique
1 2 ou plus Les expressions sont groupées ou empilées
2 1 Les dimensions sont groupées ou empilées
2 2 ou plus Les dimensions sont groupées
3 1 Les première et deuxième dimensions sont groupées, tandis que la troisième est empilée
3 2 ou plus Les première et deuxième dimensions sont groupées, tandis que les expressions sont empilées
4 1 Les première et deuxième dimensions sont groupées, tandis que la troisième est empilée
4 2 ou plus Les première et deuxième dimensions sont groupées, tandis que les expressions sont empilées
Vue en 3D Les paramètres de ce groupe définissent l'angle à partir duquel le graphique est visualisé dans les modes 3D.
Angle supérieur
Définit l'angle vertical de la vue en 3D. La valeur doit correspondre à un entier compris entre 5 et 45.
Angle latéral
Définit l'angle latéral de la vue en 3D. La valeur doit correspondre à un entier compris entre 5 et 45.
Style de couleur du tracé Cette commande peut servir à imposer un style de couleur à toutes les couleurs de tracé du graphique. Lorsqu'un style est sélectionné dans la liste déroulante, toutes les couleurs sous Table des couleurs sont modifiées en conséquence sous la page Couleurs. La modification est instantanée, mais le paramètre ne sera pas enreg