Liste multiple

Avec son option unique permettant de trier les champs affichés par applicabilité (), la liste multiple offre une solution performante au problème de l'affichage d'un grand nombre de listes de sélection sur la même feuille. Cette option Trier par applicabilité est accessible via l'onglet Propriétés de la liste multiple : Général.

Cliquez avec le bouton droit de la souris dans la liste multiple pour afficher le menu Objet.

Menu Objet

Le menu Objet de la liste multiple présente trois versions différentes. Si on clique sur la barre de titre, ce menu contextuel contiendra les commandes applicables à toute la zone, tandis que si un champ se trouve sous le pointeur de la souris, le menu inclura en plus des commandes qui s'appliquent à ce champ spécifique. Enfin, si vous ouvrez d'abord un fichier, la disposition du menu contextuel sera encore différente. Les commandes combinées de ces menus sont :

Propriétés... Ouvre la boîte de dialogue Propriétés de la liste multiple vous permettant de définir plusieurs paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Voir  : Notes et commentaires

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet sur la valeur la plus élevée de toutes les valeurs des autres objets de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet sur la valeur la plus faible de toutes les valeurs des autres objets de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Rechercher

Ouvre la zone de recherche.

Voir  : Rechercher

Recherche partielle

Ouvre la boîte de recherche textuelle en mode recherche partielle.

Voir  : Recherche partielle

Recherche avancée

Ouvre la boîte de dialogue de recherche avancée. Cette boîte de dialogue permet de saisir des expressions avancées. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+Maj+F.

Voir  : Boîte de dialogue de recherche avancée

Sélectionner les valeurs possibles Toutes les valeurs non exclues du champ sont sélectionnées.
Sélectionner les valeurs exclues Toutes les valeurs exclues du champ sont sélectionnées.
Sélectionner tout Toutes les valeurs du champ sont sélectionnées.
Effacer toutes les sélections Efface toutes les sélections actives de la liste multiple.
Effacer Efface toutes les sélections actives du champ.
Effacer les autres champs Efface les sélections dans tous les autres objets de la feuille, y compris les sélections dans d'autres champs de la liste multiple active, tout en conservant les sélections de ce champ spécifique de la liste.
Verrouiller Verrouille la ou les valeurs sélectionnées du champ.
Verrouiller toutes les sélections Verrouille la ou les valeurs sélectionnées de la liste multiple.
Déverrouiller Déverrouille la ou les valeurs verrouillées du champ.
Déverrouiller toutes les sélections Déverrouille la ou les valeurs verrouillées de la liste multiple.
Imprimer...

Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression. Imprimer la liste multiple n'a de sens que si une seule valeur est affichée dans chaque champ (parce que c'est soit la seule valeur sélectionnée, soit la seule valeur associée).

Voir  : Imprimer : Général

Imprimer au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer vers Excel Exporte les valeurs possibles (y compris les valeurs sélectionnées) vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Les valeurs exportées apparaîtront dans une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur. Cette opération n'a de sens que si une seule valeur est affichée dans chaque champ (parce que c'est soit la seule valeur sélectionnée, soit la seule valeur associée).
Exporter...

Ouvre une boîte de dialogue où vous pouvez exporter la liste multiple sous forme de tableau vers un fichier de votre choix. Le fichier peut être enregistré dans l'un des formats suivants : Délimité par des virgules, délimité par des points virgules, délimité par des tabulations, hypertexte (HTML), XML et Excel (xls ou xlsx). Le format par défaut est *.qvo (QlikViewOutput), fichier séparé par des tabulations.

Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Données
Copie les lignes de données de la liste multiple dans le Presse-papiers.
Valeur de la cellule
Copie dans le Presse-papiers la valeur textuelle de la cellule de la liste multiple sur laquelle vous avez effectué un clic droit (pour ouvrir le menu Objet).
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur, sous l'onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher l'objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende d'un objet agrandi (si elle est visible) produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

Titre

Dans la fenêtre Titre, vous pouvez donner un nom à la liste multiple et il s'affichera dans la légende de la fenêtre.Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Voir  : Syntaxe des expressions pour les formules calculées

État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.

Champs disponibles

Dans cette colonne figurent les noms des champs de la source de données. Au départ, tous les champs (sauf les champs système) y apparaissent. Pour inclure les champs système, cochez la case Afficher les champs système.

Voir  : Champs système

Les champs clés sont indiqués avec un symbole de clé. Sélectionnez les éléments à utiliser/supprimer en cliquant dessus. Utilisez le bouton Ajouter > ou le bouton < Supprimer pour les déplacer vers la colonne voulue.

Champs affichés dans la liste multiple Dans cette colonne figurent les noms des champs sélectionnés dans la liste Champs disponibles à inclure à la liste multiple. Au départ, aucun champ n'apparaît dans la colonne.
Quand un champ est sélectionné dans cette liste, vous pouvez lui donner une Étiquette personnalisée dans la fenêtre d'édition.
Afficher les champs de la table Ici, vous contrôlez les champs qui apparaissent dans la liste Champs disponibles. La liste déroulante affiche l'option Toutes les tables par défaut.
L'option Toutes les tables (qualifiées) affiche les champs qualifiés par le nom des tables dans lesquelles ils figurent. Autrement dit, les champs clés (de connexion) sont répertoriés plus d'une fois. (Cette option n'est utilisée qu'à des fins d'affichage et n'a rien à voir avec les champs Qualify dans le script de chargement.)
Il est aussi possible d'afficher les champs d'une seule table à la fois.
Expression Ouvre la boîte de dialogue Éditer l'expression permettant de créer une expression pouvant alors être utilisée sous la forme d'un champ affiché dans une liste multiple.
Éditer... Ouvre la boîte de dialogue Éditer l'expression pour le champ sélectionné dans la colonne Champs affichés dans la liste multiple.
Promouvoir Déplace un champ vers le haut dans l'ordre d'affichage.
Abaisser Déplace un champ vers le bas dans l'ordre d'affichage.
Tri par fréquence Trie les champs de la colonne Champs affichés dans la liste multiple dans l'ordre numérique.
Ordre de chargement Trie les champs de la colonne Champs affichés dans la liste multiple dans l'ordre de chargement, c'est-à-dire l'ordre dans lequel ils sont lus à partir de la base de données.
Tri alphabétique Trie les champs de la colonne Champs affichés dans la liste multiple dans l'ordre alphabétique.
Trier par applicabilité Quand cette option est cochée, l'ordre de tri des Champs affichés dans la liste multiple est mis à jour de façon dynamique au cours des sélections, afin que les champs contenant des valeurs non exclues soient montés dans la liste, tandis que les champs sans valeurs possibles sont descendus. Cette option permettra bien souvent d'utiliser littéralement des centaines de champs dans une seule liste multiple.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Pour les listes multiples, l'ID commence par MB01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Voir  : Interpréteur de macros interne

Trier

L'onglet Trier est accessible par un clic droit sur un objet de feuille (liste de sélection, liste multiple, zone table, graphique ou objet curseur/calendrier), puis via l'option Propriétés du menu contextuel (ou via Objet, Propriétés dans le menu principal). Ici, vous pouvez définir l'ordre des valeurs dans l'objet. Il se peut que certaines options de tri ne soient pas disponibles pour tous les objets.

Trier par :

État Trie les valeurs de champ selon leur état logique (sélectionnée, facultative ou exclue).
Le paramètre Croissant automatique permet de trier la liste de sélection (ou, dans une liste multiple, la liste déroulante contenant les valeurs de champ) par État uniquement si la liste de sélection contient une barre de défilement verticale. Cependant, si vous agrandissez la liste de sélection pour afficher toutes les valeurs, l'ordre de tri État est complètement désactivé.
Expression

Trie les valeurs de champs selon l'expression saisie dans la zone de texte située sous cette option de tri. Si vous utilisez le tri par expression, un autre ensemble d'enregistrements doit être défini par une expression définie. Notez que, dans ce cas, le tri par expression fonctionne uniquement avec les champs numériques, et pas avec les champs textuels.

Voir  : Analyse d'ensembles et expressions d'ensemble

Fréquence Trie les valeurs de champs par fréquence (nombre d'occurrences dans la table).
Valeur numérique Trie les valeurs de champ par valeur numérique.
Texte Trie les valeurs des champs par ordre alphabétique.
Ordre de chargement Trie les valeurs de champs dans l'ordre de chargement initial.

Le bouton Par défaut définit l'ordre de tri par défaut.

L'ordre de priorité est État, Expression, Fréquence, Valeur numérique, Texte, Ordre de chargement. Chacun de ces critères de tri peut être défini sur Croissant ou Décroissant.

Présentation

L'onglet Propriétés de la liste multiple : Présentation est accessible d'un clic droit sur une liste multiple, puis via la commande Propriétés du menu Objet. Il permet d'ajuster la disposition des cellules de la liste multiple. On peut procéder à des ajustements indépendamment pour les différents champs de la liste multiple. Il est aussi possible d'ajuster la disposition de la liste multiple fermée.

Alignement Vous définirez ici l'alignement des valeurs de champs. L'alignement du Texte et des Nombres est défini séparément.
Paramètres multilignes Dans ce groupe, on peut décider que les cellules de champs de la liste multiple doivent afficher les valeurs sur plusieurs lignes, ce qui est utile pour les longues chaînes textuelles.
Renvoi auto. à la ligne
Cette option sélectionnée, une cellule affichera son contenu sur plus d'une ligne.
Hauteur de la cellule (en lignes)
Indiquez ici le nombre maximal de lignes de cellule de votre choix.
Fréquence Afficher
Détermine si la fréquence de la valeur de champ sélectionnée est affichée ou non. Par fréquence, on entend le nombre de combinaisons sélectionnables dans lesquelles la valeur figure.
En pourcentage
Détermine si la fréquence doit être indiquée en chiffres absolus ou en pourcentage du nombre total d'entrées.
Avancé Ce bouton ouvre la boîte de dialogue Paramètres de champ avancés qui contient des paramètres destinés à la représentation imagée des valeurs de champs et des options spéciales de recherche textuelle.
Colonne unique Cette option cochée, les valeurs de champs de la liste multiple seront toujours présentées en une seule colonne.
Supprimer la barre de défilement horizontale Cochez cette option pour supprimer la barre de défilement horizontale qui s'affiche normalement quand les valeurs de champs sont trop larges pour tenir dans la liste multiple. Les valeurs de champs seront alors tronquées au besoin.
Trier par colonne Dans les champs de la liste multiple à plus d'une colonne, les valeurs sont affichées en ligne dans l'ordre de tri spécifié. L'option Trier par colonne passe à un affichage en colonne.
Bordures de cellule Les valeurs de champs seront séparées par des lignes horizontales, comme les lignes d'une table. Les bordures de cellule sont automatiquement activées quand l'option Renvoi auto. à la ligne est cochée mais peuvent être désactivées ensuite.
Masquer les valeurs exclues Détermine si les valeurs de champs exclues doivent être affichées ou non. Les valeurs exclues ne peuvent plus être sélectionnées.
Lecture seule Cette case à cocher désactive les sélections effectuées directement dans ce champ particulier de la liste multiple, ce qui en fait un simple outil d'affichage.
Ignorer les valeurs nulles Les valeurs NULL ne sont pas prises en compte dans l'affichage des valeurs possibles d'un champ donné.
Remarque: Une utilisation incorrecte de cette option peut provoquer l'affichage de données non corrélées dans la liste multiple.
Outrepasser le verrouillage du champ Cette case à cocher autorise les sélections dans un champ donné de la liste multiple, même si ce champ est verrouillé. Le champ reste verrouillé pour des sélections effectuées ailleurs dans le document.
Style de grille Cette case à cocher change la disposition de la liste multiple et place chaque étiquette au-dessus du champ qui lui correspond.
Lecture seule Cette case à cocher désactive les sélections effectuées directement dans les champs de la liste multiple, ce qui en fait un simple outil d'affichage.
Couleur de liste fermée Définit la couleur des cellules de données d'une liste multiple fermée. Il peut s'agir d'une couleur unie ou d'un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre via un clic sur ce bouton.
Limiter le déroulement à n lignes Limite la longueur des listes de sélection déroulantes ouvertes dans la liste multiple. Saisissez dans la zone d'édition le nombre maximum de valeurs à afficher.
Style Choisissez entre les styles Bordures et Clair.
Arrière-plan... Ouvre la boîte de dialogue Paramètres d'arrière-plan.

Paramètres de champ avancés

Vous pouvez accéder à la boîte de dialogue Paramètres de champ avancés à partir des boîtes de dialogue Propriétés de la liste multiple : Présentation, Propriétés de la zone table : Présentation et Propriétés du graphique : Dimensions. Les options d'image décrites ci-dessous ne sont pas disponibles pour les graphiques bitmap.

Options d'image

Représentation Les options suivantes sont proposées :
Texte
Si vous sélectionnez cette option, les valeurs d'expression seront toujours interprétées et affichées comme du texte.
Image
Si vous sélectionnez cette option, QlikView tentera d'interpréter chaque valeur d'expression comme une référence à une image. La référence peut désigner le chemin d'accès à un fichier image sur le disque (par exemple, C:\Monimage.jpg) ou dans le document qvw (par exemple, qmem://<Nom>/<Pierre>). Si QlikView ne peut pas interpréter une valeur d'expression comme une référence d'image valide, il affichera la valeur elle-même.
Infos sous forme d'image
Si vous sélectionnez cette option, QlikView affiche les informations d'image liées à la valeur de champ à l'aide des instructions info load/select dans le script. Si aucune information d'image n'est disponible pour une valeur de champ, le programme affiche la valeur elle-même, sauf si la case Masquer le texte si l'image n'est pas disponible est cochée. Cette option est indisponible pour les graphiques bitmap.
Formatage d'image Disponible uniquement quand l'option image ci-dessus a été sélectionnée. Ce paramètre décrit comment QlikView formate l'image pour l'adapter à la cellule. Il existe quatre possibilités.
Sans étirement
Si cette option est sélectionnée, l'image s'affiche telle quelle, sans aucun étirement. L'image peut donc être partiellement cachée ou ne remplir qu'une partie de la cellule.
Remplir
Si cette option est sélectionnée, l'image est étirée de manière à s'adapter à la cellule sans nécessairement conserver ses proportions.
Conserver les proportions
Si cette option est sélectionnée, l'image est étirée autant que possible pour remplir la cellule tout en conservant ses proportions. En général, vous obtenez des zones sur les deux côtés ou en haut et en bas qui ne sont pas remplies par l'image.
Proportionnel
Si cette option est sélectionnée, l'image est étirée dans les deux sens pour remplir la cellule tout en conservant ses proportions. En général, cela entraîne le rognage de l'image dans un sens.
Masquer le texte si l'image n'est pas disponible Si cette option est sélectionnée, QlikView n'affichera pas le texte de la valeur de champ si son interprétation comme référence à une image échoue pour une raison ou pour une autre. La cellule sera donc laissée vide.
Forcer le style de sélection Lorsque des images apparaissent au lieu de texte, il peut être nécessaire d'utiliser un autre style de sélection que le style par défaut du document, de façon à ce que l'état logique des valeurs de champs reste visible. Utilisez la liste déroulante dans Forcer le style de sélection pour sélectionner un style de sélection approprié, par exemple Balise d'angle.

Options de recherche

Ce groupe vous permet de contrôler certains aspects de la recherche textuelle dans les tables, applicables aux listes multiples ouvertes et aux listes déroulantes.

Inclure les valeurs exclues dans la recherche Ce paramètre indique si les valeurs exclues doivent être incluses dans les recherches textuelles ou non. Les options suivantes sont disponibles :
<par défaut>
La valeur par défaut spécifiée sous Préférences utilisateur s'applique.
Oui
Les valeurs exclues sont toujours incluses dans la recherche textuelle.
Non
Les valeurs exclues ne sont jamais incluses dans la recherche textuelle tandis que les valeurs facultatives restent incluses comme prévu.
Mode de recherche par défaut Ce paramètre spécifie le mode de recherche par défaut initial dans les recherches textuelles. Le mode peut toujours être modifié directement en tapant * ou ~ dans la chaîne de caractères à rechercher. Les options suivantes sont disponibles :
<par défaut>
La valeur par défaut spécifiée sous Préférences utilisateur s'applique.
Recherche par caractères génériques
La chaîne de recherche initiale se compose de deux caractères génériques séparés par le curseur afin de faciliter ce type de recherche.
Recherche partielle
La chaîne de recherche initiale se compose d'un tilde (~) pour signaler une recherche partielle.
Recherche classique
Aucun caractère supplémentaire n'est ajouté à la chaîne de recherche. En l'absence de caractères génériques, c'est une recherche classique qui est effectuée.

Nombre

L'onglet Propriétés de la liste multiple : Nombre accessible d'un clic droit sur une liste multiple, puis via la commande Propriétés du menu contextuel.

Cet onglet fournit des paramètres de formatage pour tous les champs de la liste multiple. Vous pouvez définir le formatage des nombres pour chaque champ en en sélectionnant un ou plusieurs (clic, clic+Maj ou clic+Ctrl) dans la zone de texte Champs.

Chaque champ dispose d'un format de nombre par défaut qu'il est possible de définir sous l'onglet Propriétés du document : Nombre. Il est cependant possible d'utiliser un format de nombre distinct pour un objet donné. Pour ce faire, cochez l'option Outrepasser les paramètres du document et spécifiez un format de nombre dans le groupe ci-dessous. Cet onglet s'applique à l'objet actif et contient les options suivantes pour formater les valeurs :

Mixte À la fois des nombres et du texte. Les nombres sont affichés dans leur format d'origine.
Nombre Affiche des valeurs numériques dont le nombre de chiffres est défini dans la boîte fléchée précision.
Entier Affiche les valeurs numériques sous forme d'entiers.
Fixé à _ décimales Affiche des valeurs décimales dont le nombre de décimales est défini dans la boîte fléchée Décimales.
Monétaire Affiche les valeurs au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu. Le format par défaut est le format monétaire de Windows.
Date Affiche des valeurs qui peuvent être interprétées comme des dates au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Heure Affiche des valeurs qui peuvent être interprétées comme des heures au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Horodateur Affiche des valeurs qui peuvent être interprétées comme la date et l'heure au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Intervalle Affiche l'heure sous forme d'incrément de temps séquentiel (par exemple format = mm affiche la valeur en nombre de minutes depuis le début du calendrier, à savoir 1899:12:30:24:00).

Le bouton Afficher en pourcentage % concerne les formats suivants : Nombre, Entier et Fixé à.

Les séparateurs Décimal et De milliers peuvent être définis dans les zones d'édition du groupe Séparateurs.

Le bouton ISO utilise la norme ISO pour les formats date, heure et horodateur.

Le bouton Système applique les paramètres du système au format.

Le bouton Modifier le format du document ouvre l'onglet Propriétés du document : Nombre, qui permet d'éditer le format numérique par défaut de n'importe quel champ.

Police

On peut définir ici la Police, le Style de police et la Taille de police à utiliser.

On peut définir la police pour un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, les polices par défaut des nouveaux documents peuvent être définies dans l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Voir  : Fonctions de couleur

Les paramètres supplémentaires sont :

Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de la feuille. Spécifiez un type de bordure dans le menu déroulant.

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Voir  : Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de la feuille :

Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement visible lorsque la condition renvoie la valeur VRAI.

Voir  : Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Voir  : Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Voir  : Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Voir  : Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Bon nombre des commandes du menu Objet des objets de feuille peuvent être configurées comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Voir  : Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.