Menu Fichier

Le menu Fichier est un menu déroulant en haut de l'écran, qui contient les commandes suivantes :

Nouveau Ouvre une nouvelle fenêtre QlikView et vous permet de créer un nouveau fichier QlikView.
Ouvrir... Ouvre une nouvelle fenêtre QlikView et vous permet d'ouvrir un fichier QlikView ou un fichier de tables. L'ouverture d'un fichier de table lance automatiquement l'Assistant Fichier. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+O.
Ouvrir sur un serveur... Ouvre une boîte de dialogue où vous pouvez vous connecter à une instance de QlikView Server et rechercher un document à ouvrir en mode client.
Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+Maj+O.
Remarque: Lorsque vous ouvrez des documents en tant que client de QlikView Server, vous ne pouvez pas effectuer les mêmes opérations que sur des documents locaux. En tant que client, vous ne pouvez pas ajouter ou supprimer d'objets de feuille, selon la licence client utilisée et la prise en charge ou non de la collaboration par le document. Vous ne pouvez pas ajouter ou supprimer de feuilles. De plus, il n'est pas possible d'accéder à toutes les boîtes de dialogue de propriétés, de modifier les macros, d'ouvrir le script, de recharger les données ou d'enregistrer le document.
Actualiser le document Cette commande est seulement disponible sur les documents ouverts avec QlikView Serveur et lorsqu'il existe une nouvelle version du document sur le serveur. En exécutant une actualisation, vous aurez accès aux dernières données tout en conservant l'état de la disposition et les sélections faites dans votre session.
Ouvrir une URL... Ouvre la boîte de dialogue Ouvrir une URL. Dans cette boîte de dialogue, saisissez l'URL valide de n'importe quelle page web. La page web sera ouverte dans une fenêtre séparée dans QlikView. Cette fonctionnalité peut être utilisée, par exemple, pour QlikView Publisher AccessPoint ou pour des pages affichant des documents QlikView Server par le biais de clients AJAX. Les pages web ouvertes sont accessibles via le menu Fenêtre, à l'instar des fenêtres de document QlikView standard.
Ouvrir via FTP... Ouvre une nouvelle fenêtre QlikView, qui vous permet d'ouvrir un fichier QlikView ou un fichier de tables à partir d'un serveur FTP. L'ouverture d'un fichier de table lance automatiquement l'Assistant Fichier.
Fermer Ferme le fichier QlikView actif.
Raccourcis Ce menu en cascade contrôle la liste des documents favoris définis par l'utilisateur, gérés indépendamment de la liste des documents récemment utilisés (voir ci-dessous).
Enregistrer

Enregistre la configuration actuelle dans un fichier QlikView. Les données, le script et la disposition sont enregistrés. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+S.

Si vous souhaitez partager un document QlikView à l'aide de clients AJAX, le nom du fichier ne doit pas contenir de caractères dièse (#).

Enregistrer sous...

Enregistre la configuration actuelle dans un nouveau fichier QlikView sous un nouveau nom. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : F12.

Si vous souhaitez partager un document QlikView à l'aide de clients AJAX, le nom du fichier ne doit pas contenir de caractères dièse (#).

Enregistrer le lien... Enregistre un lien vers un document ouvert sur QlikView Server sous forme de fichier texte sur l'ordinateur local. Le fichier portera l'extension .qvw mais ne contiendra aucune donnée ni information de disposition. Lorsque vous ouvrez un document lié de ce type, QlikView tente de se reconnecter au serveur et d'ouvrir le document sur QlikView Server. Cette commande n'est pas disponible pour les documents locaux.
Envoyer en pièce jointe... Disponible uniquement lorsque vous travaillez avec un document local. Crée un courrier électronique avec une copie du document qvw actif en pièce jointe. Le destinataire pourra ouvrir le document qvw s'il dispose de QlikView et s'il a des droits d'accès au document (en cas d'utilisation de la sécurité d'accès de section). Cette commande fonctionne uniquement si un client de messagerie est configuré sur l'ordinateur.
Envoyer par courriel avec le favori en lien... Disponible uniquement lorsque vous travaillez avec un document QlikView Server. Crée un courrier électronique avec un lien (URL) vers le document actif du serveur. Un favori temporaire de serveur sera créé (comprenant l'état de la disposition) et codé dans l'URL. Le destinataire du courriel peut utiliser le lien URL pour ouvrir le document du serveur et afficher ce que vous voyez à l'écran à condition qu'il dispose des droits d'accès au document et aux données. Cette commande fonctionne uniquement si un client de messagerie est configuré sur l'ordinateur. QlikView Server doit être configuré pour autoriser les favoris.
Imprimer... Ouvre la boîte de dialogue Imprimer standard qui vous permet d'imprimer l'objet de feuille actif. Cette commande n'est pas disponible pour les listes de sélection. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+P.
Imprimer au format PDF... Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+Maj+P.
Imprimer les valeurs possibles... Ouvre la boîte de dialogue Imprimer standard qui vous permet d'imprimer les valeurs possibles (sélectionnées et facultatives) de la liste de sélection active. Cette commande n'est disponible que pour les listes de sélection.
Imprimer les valeurs possibles au format PDF... Cette commande doit être utilisée pour imprimer des listes de sélection et des listes multiples en PDF.
Imprimer la feuille... Ouvre la boîte de dialogue Imprimer, qui vous permet d'imprimer une image de la feuille active.
Aperçu avant impression... Affiche un aperçu des objets de feuille imprimables.
Contrôle de la source Paramètres
Définissez le système DLL du fournisseur MSSCCI (Microsoft Source Code Control Interface) à utiliser lors de l'ajout ou de l'obtention d'un projet à partir du contrôle de la source.

Ajouter un projet au contrôle de la source
Permet d'enregistrer le document QlikView ouvert et de créer automatiquement un dossier de projet et des fichiers de projet. Appelle le système de contrôle de la source pour ajouter le projet au contrôle de la source.

Récupérer le projet à partir du contrôle de la source
Permet de récupérer un projet depuis le contrôle de la source et de régénérer le document QlikView à partir des fichiers de projet. Les données QlikView ne sont pas stockées dans le contrôle de la source. Pour remplir le document avec les données, la commande Recharger doit être exécutée sur le document régénéré.

Récupérer la dernière version
Permet de récupérer la dernière version du document depuis le contrôle de la source et de régénérer le document QlikView.

Archiver les modifications en attente
Permet d'enregistrer le document QlikView et d'appliquer une opération d'archivage au système de contrôle de la source. Cette opération peut inclure quatre opérations différentes de contrôle de la source, chacune avec sa propre boîte de dialogue :
  • Ajout de fichiers récemment créés.
  • Annulation des fichiers retirés devant être supprimés du contrôle de la source.
  • Suppression des fichiers correspondant aux feuilles supprimées ou aux objets de feuille faisant partie du contrôle de la source.
  • Archivage des fichiers modifiés.

Si le document n'était pas à jour avant l'opération Archiver les modifications en attente, rouvrez-le pour charger les modifications du projet éventuellement introduites lors de la résolution des conflits.

 

Annuler les modifications en attente
Permet d'annuler les modifications effectuées. Si des fichiers modifiés localement ne sont pas retirés du système de contrôle de la source, ils le sont avant l'exécution de l'opération d'annulation du retrait. Cette opération régénère le document QlikView en supprimant des fichiers ajoutés et non archivés, et en restaurant les références aux fichiers dont la suppression est en attente.
Exporter Exporter le contenu...
Cette option est uniquement disponible lorsqu'un objet de feuille exportable est actif. Elle effectue alors l'opération d'exportation que l'on trouve dans le menu Objet de l'objet.

Exporter l'Image de la feuille...
Ouvre une boîte de dialogue destinée à enregistrer une image de la feuille active dans un fichier.

Exporter la disposition du document
Ouvre une boîte de dialogue permettant d'enregistrer la disposition au format de fichier XML. Les données du document ne sont pas enregistrées dans le fichier XML.

Exporter la disposition de la feuille...
Ouvre une boîte de dialogue permettant d'enregistrer la disposition de la feuille active dans un fichier XML. Les données du document ne sont pas enregistrées dans le fichier XML.
Importer Importer la disposition du document
Ouvre une boîte de dialogue permettant d'importer la disposition d'un autre document enregistré au format de fichier XML. Les données du fichier source ne sont pas importées.

Importer la disposition de la feuille
Ouvre une boîte de dialogue permettant d'importer la disposition d'une autre feuille enregistrée au format de fichier XML. Les données du fichier source ne sont pas importées.
Éditer le script... Ouvre la boîte de dialogue Éditer le script. Dans cette boîte de dialogue, on peut écrire et exécuter des scripts qui ouvrent des bases de données et s'y connectent.
Recharger Exécute le script de chargement actif et recharge les données dans le document QlikView ouvert. Il faut le faire si le contenu de la base de données a changé depuis le dernier rechargement. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+R.
Recharger partiellement Exécute le script de chargement actif (y compris toutes les commandes de script telles que Drop table) et recharge les données dans le document QlikView ouvert. Cependant, seules les tables dont les instructions load et select sont précédées du préfixe Replace ou Add sont rechargées. Les tables de données qui ne sont pas concernées par ce type d'instructions load ou select ne sont pas concernées par le rechargement partiel.Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+Maj+R.
Réduire les données Ouvre un menu comprenant les deux commandes suivantes :

Conserver les valeurs sélectionnées
Réduit la base de données QlikView en supprimant toutes les valeurs exclues.

Supprimer toutes les valeurs
Crée un modèle en supprimant toutes les valeurs de la base de données QlikView, mais en conservant sa structure et sa disposition.
Visionneur de tables... Ouvre la boîte de dialogue Visionneur de tables qui permet d'examiner la structure des données chargées dans une vue graphique des tables, des champs et des associations. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+T.
Liste des documents récemment utilisés Liste des derniers documents QlikView utilisés. Le nombre de documents affichés peut être défini dans la boîte de dialogue Paramètres : Préférences utilisateur. La valeur par défaut est 8. La sélection de l'un de ces documents équivaut à utiliser la commande Ouvrir.
Quitter Ferme les documents ouverts et quitte QlikView.