Accéder au contenu principal

Objet personnalisé

SUR CETTE PAGE

Objet personnalisé

L'objet personnalisé est un objet spécialement conçu pour personnaliser les contrôles de l'objet OCX.

Le menu Objet personnalisé : Objet est accessible à partir du menu Objet, lorsque l'objet personnalisé correspond à l'objet actif.

Les contrôles de remplacement sont des contrôles OCX sans fenêtre programmés par Qlik, vous-même ou des revendeurs tiers, qui respectent les spécifications de composants OCX de remplacement QlikView. Le composant OCX sera dessiné sur la feuille dans un rectangle correspondant à l'objet personnalisé. La communication entre le contrôle OCX et le document QlikView est assurée via l'interpréteur de macros interne.

Interpréteur de macros interne.

Menu Objet

Le menu Objet de l'objet personnalisé s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés du contrôle de remplacement...

Ouvre la boîte de dialogue Propriétés du contrôle de remplacement OCX utilisé. Elle est fournie avec le contrôle de remplacement OCX et peut être absente.

Propriétés...

Ouvre la boîte de dialogue Propriétés de l'objet personnalisé permettant de définir un certain nombre de paramètres.

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de feuille. Les numéros de couches possibles sont compris entre -128 et 127.

  • Mettre au premier plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Mettre à l'arrière-plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Avancer : Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.
  • Reculer : Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.

Copier dans le Presse-papiers

Ce menu contient les diverses options de copie de l'objet de feuille.

  • Image : Copie une image bitmap de l'objet personnalisé dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur, sous l'onglet Exporter.
  • Objet : Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.

Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.

  • Ajuster la position des objets liés : Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
  • Détacher cet objet/Détacher les objets : Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire

Réduit l'objet en icône. Un clic sur l'icône Minimize dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.

Agrandir

Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône Maximize dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.

Restaurer

Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double clic sur l'icône d'un objet réduit ou un clic sur l'icône Restore dans la légende d'un objet agrandi (si elle est visible) produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.

Aide

Ouvre l'aide de QlikView.

Supprimer

Supprime l'objet de feuille de la feuille.

Général

Pour ouvrir l'onglet Propriétés de l'objet personnalisé : Général, cliquez sur un objet personnalisé avec le bouton droit de la souris et choisissez la commande Propriétés dans le menu contextuel. On peut y configurer les paramètres du titre et de l'objet personnalisé.

Propriétés de l'objet personnalisé
Propriété Description
OCX sélectionné Nom de l'OCX sélectionné.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Pour les objets personnalisés, l'ID commence par CO01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Interpréteur de macros interne

Sélectionner un contrôle OCX de remplacement Cliquez sur ce bouton pour ouvrir la boîte de dialogue Insérer un objet où vous pouvez sélectionner ou modifier un contrôle de remplacement OCX.
Propriétés OCX Ouvre la boîte de dialogue Propriétés du contrôle de remplacement OCX utilisé. Cette boîte de dialogue est programmée par le fournisseur du contrôle de remplacement OCX et peut varier en apparence et en fonctionnalité. Elle peut aussi être indisponible pour certains contrôles.
État alternatif

Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.

  • Hérité : Les feuilles et les objets de feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
  • État par défaut : Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de feuille. Spécifiez un type de bordure dans le menu déroulant.

  • Intensité de l'ombre : Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets de feuille. L'option Aucune ombre est également possible.
  • Style de bordure : Les types de bordure prédéfinis suivants sont disponibles :
    • Continu : Bordure unie d'une seule couleur.
    • Enfoncé : Bordure donnant l'impression que l'objet de feuille est enfoncé par rapport à l'arrière-plan.
    • En relief : Bordure donnant l'impression que l'objet de feuille est surélevé par rapport à l'arrière-plan.
    • Mur : Bordure donnant l'impression d'un mur autour de l'objet de feuille.
  • Largeur de bordure : Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
  • Couleur : Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
  • Arc-en-ciel : Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet de feuille.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

  • Angles arrondis : Cette option rend les options d'angles arrondis disponibles.
  • Coins : Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
  • Angulosité : Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
  • Rayon de l'angle : Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

  • Inférieure : Un objet de feuille défini sur la propriété de couche Inférieure ne peut jamais masquer les objets de feuille placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
  • Standard : À leur création, les objets de feuille se trouvent sur la couche Standard (intermédiaire). Un objet de feuille placé sur la couche Standard ne peut jamais être masqué par des objets de feuille placés sur la couche Inférieure et ne peut jamais masquer des objets de feuille situés sur la couche Supérieure.
  • Haut : Un objet de feuille placé sur la couche Supérieure ne peut jamais être masqué par des objets de feuille des couches Standard et Inférieure. Seuls d'autres objets de feuille de la couche Supérieure peuvent être placés au-dessus.
  • Personnalisé : Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de feuille :

  • Toujours : L'objet de feuille est toujours affiché.
  • Conditionnel : L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence en fonction, par exemple, des sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

    Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet de feuille. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

  • Autoriser le déplacement et le dimensionnement : Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet de feuille.
  • Autoriser la copie/le clonage : Si cette option est désactivée, il sera impossible de faire une copie de l'objet de feuille.
  • Autoriser les informations : Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

    Info
  • Ajuster la taille aux données : Dans QlikView, les bordures entourant les objets de feuille de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet de feuille. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

  • Conserver la position de défilement : Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets. La position de défilement n'est pas conservée à la fermeture du document.
  • Boutons de défilement : Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
  • Arrière-plan : Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.
  • Largeur de la barre : Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
  • Style de barre : Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.
    L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

 

  • Appliquer à... : Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

  • Afficher la barre de titre : Lorsque cette option est cochée, une légende est dessinée en haut de l'objet de feuille. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
  • Texte du titre : Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet de feuille. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

  • Renvoi auto. à la ligne : Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
  • Hauteur de la légende (lignes) : Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet de feuille QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

  • Pos. X : Définit la position horizontale du côté gauche de l'objet de feuille par rapport au bord gauche de la feuille.
  • Pos. Y : Définit la position verticale du côté supérieur de l'objet de feuille par rapport au bord supérieur de la feuille.
  • Largeur : Définit la largeur de l'objet de feuille QlikView.
  • Hauteur : Définit la hauteur de l'objet de feuille QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

  • Horizontal : L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
  • Vertical : L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
  • Autoriser la réduction : Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet de feuille pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
  • Réduction automatique : Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de feuille de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
  • Autoriser l'agrandissement : Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet de feuille pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
  • Texte d'aide : Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.


    Syntaxe des expressions pour les formules calculées

    Saisissez par exemple une description de l'objet de feuille. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.