Accéder au contenu principal

Zone de sélections actives

SUR CETTE PAGE

Zone de sélections actives

Current selections box example

Dans la zone de sélections actives, les sélections sont listées par nom et par valeur de champ. Cet outil affiche les mêmes informations que la fenêtre de sélections actives flottante, mais il est positionné directement sur la feuille, comme n'importe quel autre objet. Les indicateurs permettent de distinguer les valeurs sélectionnées des valeurs verrouillées.

Lorsque vous cliquez sur une zone de sélections actives avec le bouton droit de la souris, le menu Zone de sélections actives : Objet s'affiche. Il est également accessible à partir du menu Objet, lorsque la zone de sélections actives est l'objet actif.

Remarque: Si vous effectuez une sélection dans un champ à l'aide de la fonction de recherche, la chaîne de recherche s'affiche sous forme de valeur de champ.

Menu Objet

Le menu Objet de la zone de sélections actives s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés...

Ouvre la boîte de dialogue Propriétés des sélections actives permettant de définir un certain nombre de paramètres.

Notes

Permet de créer et de partager des notes concernant l'objet actif.

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de feuille. Les numéros de couches possibles sont compris entre -128 et 127.

  • Mettre au premier plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Mettre à l'arrière-plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Avancer : Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.
  • Reculer : Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.

Détacher

Le texte « (Détaché) » est ajouté au titre du graphique et le graphique n'est plus mis à jour en fonction des sélections effectuées dans le document (bien qu'on puisse encore faire des sélections à partir du graphique). Cette commande n'est disponible que si le graphique est attaché. Effectuer une copie d'un graphique et le détacher permet d'effectuer des comparaisons directes entre la copie et l'original.

Attacher

Attache un graphique détaché. Le graphique devient lié de façon dynamique aux données. Cette commande n'est disponible que si le graphique est détaché.

Définir comme référence

En choisissant cette option, vous définissez une référence dans le graphique, c'est à dire un segment fixe basé sur les sélections actives. Si d'autres sélections sont faites dans le document, la référence sera conservée, grisée à l'arrière-plan. Les axes du graphique, entre autres, seront ajustés pour toujours inclure la plus grande partie possible des ensembles de données d'arrière-plan et actuel. L'ensemble de données actives est toujours affiché au-dessus du tracé de référence, autrement dit ce dernier peut être masqué par le tracé de l'ensemble des données actives. L'affichage de l'arrière-plan peut être défini via le paramètre Mode de référence disponible sous Propriétés du graphique : Général. L'affichage d'une référence est seulement possible sur quelques types de graphiques, comme les histogrammes, les courbes, les combinés, les radars, les nuages de points, les bulles et les jauges à aiguille. Il n'est pas possible de définir une référence de graphique contenant un groupe cyclique ou hiérarchique. La référence sera perdue à la fermeture du document ou au rechargement des données. Le nombre maximal d'objets pouvant être inclus est de 500 lorsque l'option Définir comme référence est utilisée.

Effacer la référence

Cette commande est remplacée par la commande Définir comme référence lorsqu'une référence a été définie. En la choisissant, la référence sera effacée et le graphique sera affiché dans son mode initial.

Cloner

Effectue une copie identique du graphique. Si un graphique détaché est cloné, le clone est attaché.

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de feuille. Les numéros de couches possibles sont compris entre -128 et 127.

  • Mettre au premier plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Mettre à l'arrière-plan : Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de feuille de la feuille active.
  • Avancer : Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.
  • Reculer : Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.

Sélectionner les valeurs possibles

Toutes les valeurs non exclues du champ sont sélectionnées.

Sélectionner les valeurs exclues

Toutes les valeurs exclues du champ sont sélectionnées.

Sélectionner tout

Toutes les valeurs du champ sont sélectionnées.

Effacer

Efface toutes les sélections actives du champ.

Effacer les autres champs

Efface les sélections dans tous les autres objets de feuille, y compris les sélections dans d'autres champs de la zone de sélections actives, tout en conservant les sélections de ce champ spécifique de la zone.

Verrouiller

Verrouille la ou les valeurs déverrouillées du champ.

Déverrouiller

Déverrouille la ou les valeurs verrouillées du champ.

Imprimer...

Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression.

Imprimer au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante Microsoft Print to PDF présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer les valeurs vers Excel

Exporte le texte vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Le texte s'affiche dans les cellules d'une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.

Exporter...

Ouvre une boîte de dialogue où vous pouvez exporter le contenu des sélections actives vers un fichier de votre choix. Le fichier peut être enregistré dans l'un des formats suivants : Délimité par des virgules, délimité par des points virgules, délimité par des tabulations, hypertexte (HTML), XML et Excel (xls ou xlsx). Le format par défaut est *.qvo (QlikViewOutput), fichier séparé par des tabulations.

Copier dans le Presse-papiers

Ce menu en cascade contient les diverses options de copie de l'objet.

  • Données : Copie les données (sélections) de la zone de sélections actives sélectionnée dans le Presse-papiers.
  • Valeur de la cellule : Copie dans le Presse-papiers la valeur textuelle de la cellule de la zone de sélections actives sur laquelle vous avez effectué un clic droit (pour ouvrir le menu Objet).
  • Image : Copie une image de la zone de sélections actives sélectionnée dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur, sous l'onglet Exporter.
  • Objet : Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.

Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.

  • Ajuster la position des objets liés : Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
  • Détacher cet objet/Détacher les objets : Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire

Réduit l'objet en icône. Un clic sur l'icône Minimize dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.

Agrandir

Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône Maximize dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.

Restaurer

Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double clic sur l'icône d'un objet réduit ou un clic sur l'icône Restore dans la légende d'un objet agrandi (si elle est visible) produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.

Aide

Ouvre l'aide de QlikView.

Supprimer

Supprime l'objet de feuille de la feuille.

Général

L'onglet Propriétés de la zone des sélections actives : Général s'ouvre d'un clic droit sur une zone des sélections actives, puis en sélectionnant la commande Propriétés du menu contextuel. Il permet de définir des paramètres généraux pour la zone des sélections actives.

Propriétés de la zone des sélections actives
Propriété Description
Titre

Texte de la barre de titre de la zone des sélections actives. Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

État alternatif

Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.

  • Hérité : Les feuilles et les objets de feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
  • État par défaut : Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Pour les zones de sélections actives, l'ID commence par CS01.

Interpréteur de macros interne

Dans le groupe Colonnes affichées, vous déterminerez si les colonnes d'état et/ou de valeurs doivent apparaître dans la zone des sélections actives.

  • État : Cochez cette case pour ajouter la colonne État avec un indicateur renvoyant à la zone des sélections actives.
  • Valeurs : Cochez cette case pour ajouter une colonne Valeurs à la zone des sélections actives et bénéficier ainsi de la liste des valeurs des champs sélectionnés.
  • Sélection par menu déroulant : Ce paramètre permet d'afficher une icône déroulante pour chaque champ dans la zone des sélections actives et, par conséquent, de modifier les sélections dans l'objet.
  • Effacer les icônes : Si cette case est cochée, une petite icône de suppression apparaîtra pour chaque ligne de champ de la zone des sélections actives. Cliquez sur cette icône de suppression pour effacer les sélections du champ. Aucune icône de suppression n'est affichée pour les champs verrouillés.
  • Verrouiller/Déverrouiller les icônes : Si cette case est cochée, une petite icône de verrouillage ou déverrouillage apparaîtra pour chaque ligne de champ de la zone des sélections actives. Cliquez sur cette icône pour verrouiller ou déverrouiller les sélections du champ.

Cocher la case Utiliser les étiquettes des colonnes active les paramètres suivants :

  • Champs : L'étiquette à afficher au-dessus de la colonne Champs peut être modifiée dans la zone de texte.
  • État : L'étiquette à afficher au-dessus de la colonne État peut être modifiée dans la zone de texte.
  • Valeurs : L'étiquette à afficher au-dessus de la colonne Valeurs peut être modifiée dans la zone de texte.

Dans le groupe Couleur, vous pouvez éditer les couleurs des différents composants de la zone des sélections actives.

  • Arrière-plan de l'étiquette : Définit la couleur d'arrière-plan de la ligne d'étiquette.
  • Couleur du texte de l'étiquette : Définit la couleur du texte de la ligne d'étiquette.
  • Couleur du texte : Définit la couleur du texte de la zone d'affichage.
  • Arrière-plan : Ouvre la boîte de dialogue Paramètres d'arrière-plan.

Police

Vous pouvez définir ici la Police, le Style de police et la Taille de police à utiliser.

Vous pouvez définir la police d'un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, il est possible de définir les polices par défaut des nouveaux documents sous l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Fonctions de couleur

Les paramètres supplémentaires sont :

  • Ombre portée : Si cette option est cochée, une ombre portée sera ajoutée au texte.
  • Souligner :Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de feuille. Spécifiez un type de bordure dans le menu déroulant.

  • Intensité de l'ombre : Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets de feuille. L'option Aucune ombre est également possible.
  • Style de bordure : Les types de bordure prédéfinis suivants sont disponibles :
    • Continu : Bordure unie d'une seule couleur.
    • Enfoncé : Bordure donnant l'impression que l'objet de feuille est enfoncé par rapport à l'arrière-plan.
    • En relief : Bordure donnant l'impression que l'objet de feuille est surélevé par rapport à l'arrière-plan.
    • Mur : Bordure donnant l'impression d'un mur autour de l'objet de feuille.
  • Largeur de bordure : Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
  • Couleur : Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
  • Arc-en-ciel : Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet de feuille.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

  • Angles arrondis : Cette option rend les options d'angles arrondis disponibles.
  • Coins : Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
  • Angulosité : Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
  • Rayon de l'angle : Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

  • Inférieure : Un objet de feuille défini sur la propriété de couche Inférieure ne peut jamais masquer les objets de feuille placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
  • Standard : À leur création, les objets de feuille se trouvent sur la couche Standard (intermédiaire). Un objet de feuille placé sur la couche Standard ne peut jamais être masqué par des objets de feuille placés sur la couche Inférieure et ne peut jamais masquer des objets de feuille situés sur la couche Supérieure.
  • Haut : Un objet de feuille placé sur la couche Supérieure ne peut jamais être masqué par des objets de feuille des couches Standard et Inférieure. Seuls d'autres objets de feuille de la couche Supérieure peuvent être placés au-dessus.
  • Personnalisé : Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de feuille :

  • Toujours : L'objet de feuille est toujours affiché.
  • Conditionnel : L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence en fonction, par exemple, des sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

    Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet de feuille. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

  • Autoriser le déplacement et le dimensionnement : Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet de feuille.
  • Autoriser la copie/le clonage : Si cette option est désactivée, il sera impossible de faire une copie de l'objet de feuille.
  • Autoriser les informations : Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

    Info
  • Ajuster la taille aux données : Dans QlikView, les bordures entourant les objets de feuille de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet de feuille. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

  • Conserver la position de défilement : Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets. La position de défilement n'est pas conservée à la fermeture du document.
  • Boutons de défilement : Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
  • Arrière-plan : Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.
  • Largeur de la barre : Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
  • Style de barre : Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.
    L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

 

  • Appliquer à... : Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

  • Afficher la barre de titre : Lorsque cette option est cochée, une légende est dessinée en haut de l'objet de feuille. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
  • Texte du titre : Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet de feuille. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

  • Renvoi auto. à la ligne : Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
  • Hauteur de la légende (lignes) : Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet de feuille QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

  • Pos. X : Définit la position horizontale du côté gauche de l'objet de feuille par rapport au bord gauche de la feuille.
  • Pos. Y : Définit la position verticale du côté supérieur de l'objet de feuille par rapport au bord supérieur de la feuille.
  • Largeur : Définit la largeur de l'objet de feuille QlikView.
  • Hauteur : Définit la hauteur de l'objet de feuille QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

  • Horizontal : L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
  • Vertical : L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
  • Autoriser la réduction : Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet de feuille pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
  • Réduction automatique : Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de feuille de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
  • Autoriser l'agrandissement : Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet de feuille pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
  • Texte d'aide : Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.


    Syntaxe des expressions pour les formules calculées

    Saisissez par exemple une description de l'objet de feuille. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.