Zone table

La zone table est un objet qui affiche plusieurs champs simultanément. Le contenu de chaque ligne est connecté logiquement. Vous pouvez aller chercher les colonnes dans différentes tables internes, ce qui permet à l'utilisateur de créer des tables à partir de toutes les combinaisons possibles de champs.

Cliquez sur la zone table avec le bouton droit de la souris pour afficher le menu Objet.

Remarque: Si vous ajoutez à une zone table de grandes quantités de données de champ provenant de tables de données non liées, QlikView crée des jointures cartésiennes pour résoudre la liaison requise, ce qui peut entraîner une forte mobilisation de la mémoire et d'autres problèmes de performances.

Utiliser la zone table

Tri

Vous pouvez trier la zone table par n'importe quelle colonne. Il suffit de cliquer avec le bouton droit sur la colonne et de choisir Trier dans le menu contextuel. Double-cliquez sur la légende de la colonne sur laquelle vous souhaitez effectuer le tri. Si vous sélectionnez Trier dans le menu contextuel ou double-cliquez sur la même légende de colonne, l'ordre de tri est inversé.

Changer l'ordre des colonnes

L'ordre des colonnes peut être modifié par la méthode du glisser-déposer. Pointez sur le titre de la colonne, puis maintenez le bouton de la souris enfoncé tout en faisant glisser la colonne vers l'emplacement voulu. Vous pouvez désactiver cette fonction en désélectionnant la case à cocher Autoriser le glisser-déposer de la page Propriétés de la zone table : Présentation.

Menu Objet

Le menu Objet de la zone table présente deux versions différentes. Si on clique sur la barre de titre, ce menu contextuel contiendra les commandes applicables à toute la zone, tandis que si un champ se trouve sous le pointeur de la souris, le menu inclura en plus des commandes qui s'appliquent à ce champ spécifique. Les commandes combinées de ces menus sont :

Propriétés... Ouvre la boîte de dialogue Propriétés de la zone table permettant de définir un certain nombre de paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Ajuster les colonnes aux données Ajuste la largeur de toutes les colonnes des tables en fonction des données les plus larges de chaque colonne. L'en-tête est inclus dans le calcul.
Appliquer la même largeur de colonne Définit la largeur de toutes les colonnes de la table sur celle que vous avez sélectionnée avec la souris.
Trier Trie les enregistrements par le champ sur lequel on clique.
Format de cellule personnalisé Ouvre la boîte de dialogue Format de cellule personnalisé, qui vous permet de formater les cellules de la colonne et de la bande sur lesquelles vous avez cliqué. Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée.
Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Modifier la valeur Disponible uniquement pour les colonnes de la zone table affichant des champs. Définit la cellule activée en mode d'entrée. Cette opération équivaut à cliquer sur l'icône de saisie dans la cellule.
Restaurer les valeurs Disponible uniquement pour les colonnes de la zone table affichant des champs. Ouvre un menu en cascade présentant les trois options suivantes :
Restaurer une seule valeur
Restaure la valeur par défaut du champ sélectionné à partir du script.
Restaurer les valeurs possibles
Rétablit les valeurs par défaut de toutes les valeurs de champ possibles à partir du script.
Restaurer toutes les valeurs
Rétablit les valeurs par défaut de toutes les valeurs de champ à partir du script.
Sélectionner les valeurs possibles Toutes les valeurs non exclues du champ sont sélectionnées.
Sélectionner les valeurs exclues Toutes les valeurs exclues du champ sont sélectionnées.
Sélectionner tout Toutes les valeurs du champ sont sélectionnées.
Effacer toutes les sélections Efface les sélections dans tous les champs affichés dans la zone Table.
Effacer Efface toutes les sélections actives du champ.
Effacer les autres champs Sélectionne toutes les valeurs possibles du champ actif, puis efface les sélections de tous les autres champs.
Verrouiller Verrouille la ou les valeurs sélectionnées du champ.
Déverrouiller Déverrouille la ou les valeurs verrouillées du champ.
Imprimer... Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression.
Imprimer au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer vers Excel Exporte les valeurs possibles (y compris les valeurs sélectionnées) vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Les valeurs exportées apparaîtront dans une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.
Exporter...

Exporte le contenu de la table vers un fichier de votre choix. Le fichier peut être enregistré dans l'un des formats suivants : Délimité par des virgules, délimité par des points virgules, délimité par des tabulations, hypertexte (HTML), XML et Excel (xls ou xlsx). Le format par défaut est *.qvo (QlikViewOutput), fichier séparé par des tabulations.

Les images contenues dans une zone table sont exclues lors de l'exportation au format HTML.

Copier dans le Presse-papiers

Ce menu en cascade contient les diverses options de copie de l'objet.
Table complète
Copie la table entière dans le Presse-papiers, avec les en-têtes et l'état des sélections.
Données de la table
Copie uniquement les valeurs de la table dans le Presse-papiers.
Valeur de la cellule
Copie dans le Presse-papiers la valeur textuelle de la cellule de liste de sélection sur laquelle vous avez cliqué avec le bouton droit de la souris (pour ouvrir le menu Objet).
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclut ou exclut la légende et la bordure de l'objet de feuille selon les paramètres définis dans la boîte de dialogue Préférences utilisateur : onglet Exporter. Les tables générées par la partie cachée du script ne seront pas représentées par un nom dans le champ système $Table.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Boîte de dialogue Format de cellule personnalisé

Cette boîte de dialogue vous permet de personnaliser le format d'un ou de plusieurs groupes de cellules de tableau. Vous pouvez l'ouvrir à partir des menus objet d'une zone table, d'un tableau simple ou d'un tableau croisé dynamique, à condition que la commande Grille de conception du menu Affichage soit activée ou que l'option Toujours afficher les éléments du menu Conception soit cochée sous Préférences utilisateur : Conception.

Le formatage est appliqué au groupe de cellules situé dans la partie du tableau dans laquelle vous cliquez avec le bouton droit de la souris pour appeler la commande. Un champ (normalement une colonne) d'une zone Table ou une expression/dimension d'un tableau croisé constitue le plus petit groupe de cellules qu'il est possible de formater. Si des bandes sont utilisées, chaque bande est formatée séparément.

À chaque fois que cette boîte de dialogue est utilisée pour personnaliser le format de n'importe quelle partie d'un tableau, le Style tel que défini dans l'onglet Style de la boîte de dialogue Propriétés est défini sur [Personnalisé]. Si vous rétablissez un des styles prédéfinis dans le paramètre Style, le formatage personnalisé est perdu.

Remarque: Les styles de table seront remplacés en général par le formatage des attributs.
Volet Aperçu de la table Le volet d'aperçu permet d'afficher les modifications de format apportées au(x) groupe(x) de cellules de table. Contrairement au petit aperçu situé à droite, Exemple de texte, il affiche les modifications en contexte et après l'application du formatage des indicateurs visuels et/ou des attributs.
Dans ce volet, il est possible de se déplacer dans le tableau et d'appliquer des formats aux différents groupes de cellules. Il suffit de cliquer dans une cellule pour déplacer la sélection du formatage.
Annuler Le bouton Annuler permet d'annuler une par une les modifications apportées dans la boîte de dialogue Personnaliser le format des cellules.
Une fois que vous avez fermé la boîte de dialogue Personnaliser le format des cellules, toutes les modifications apportées dans la boîte de dialogue peuvent être annulées en cliquant simplement sur le bouton Annuler de la barre d'outils principale.
Rétablir Le bouton Rétablir permet de rétablir une par une les modifications annulées à l'aide du bouton Annuler de la boîte de dialogue Format de cellule personnalisé.
Exemple de texte Il permet d'afficher un aperçu de cellule qui affiche les modifications apportées.
Couleur d'arrière-plan Définit la couleur d'arrière-plan de la cellule.
Couleur du texte Définit la couleur du texte de la cellule.
Bordure avant cellule Vous pouvez définir la bordure avant la cellule. Sélectionnez un élément dans le menu déroulant pour définir le style de la bordure et cliquez sur un bouton pour définir sa couleur. Les bordures de cellule sont fusionnées entre les cellules. Par conséquent, l'apparence réelle des bordures du tableau est différente de celle de l'aperçu.
Bordure après cellule Vous pouvez définir la bordure après la cellule. Sélectionnez un élément dans le menu déroulant pour définir le style de la bordure et cliquez sur un bouton pour définir sa couleur. Les bordures de cellule sont fusionnées entre les cellules. Par conséquent, l'apparence réelle des bordures du tableau est différente de celle de l'aperçu.
Paramètres de texte Dans ce groupe, vous pouvez définir plusieurs paramètres applicables au texte de la cellule.
Taille du texte
À l'aide du menu déroulant, modifiez la taille de la police générale utilisée dans le tableau.
Gras
Cochez cette case pour afficher le texte en gras.
Italique
Cochez cette case pour afficher le texte en italique.
Souligné
Cochez cette case pour souligner le texte.
Ombre portée
Cochez cette case pour afficher le texte avec une ombre portée.
Appliquer la modification à Les modifications sont uniquement appliquées à l'expression, à la dimension ou au champ (zones Table) dans laquelle vous avez cliqué avec le bouton droit de la souris pour accéder à la boîte de dialogue. À l'aide du menu déroulant, vous pouvez choisir de sélectionner le même formatage aux autres expressions, dimensions ou champs.

Général

L'onglet Propriétés de la zone table : Général est accessible d'un clic droit de la souris sur une zone table, puis par la commande Propriétés du menu contextuel, ou par l'option Propriétés du menu Objet lorsqu'une zone table est active.

Titre

Dans la fenêtre Titre, on peut donner un nom à la zone table, et il s'affichera dans la barre de titre de la fenêtre.Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Champs disponibles Dans cette colonne figurent les noms des champs de la source de données. Au départ, tous les champs (sauf les champs système) y apparaissent. Pour inclure les champs système, cochez la case Afficher les champs système. Sélectionnez les éléments à utiliser/supprimer en cliquant dessus. Utilisez le bouton Ajouter > ou le bouton < Supprimer pour les déplacer vers la colonne voulue.
Champs affichés dans la table Dans cette colonne figurent les noms des champs sélectionnés dans la liste Champs disponibles à inclure à la zone table. Au départ, aucun champ n'y apparaît.
Quand un champ est sélectionné dans cette liste, vous pouvez lui donner une Étiquette personnalisée dans la fenêtre d'édition.
Afficher les champs système Cochez cette case pour que les champs système apparaissent dans la colonne Champs disponibles.
Afficher les champs de la table Ici, vous contrôlez les champs qui apparaissent dans la liste Champs disponibles. La liste déroulante affiche l'option Toutes les tables par défaut. Si vous souhaitez que la liste affiche les champs d'une table en particulier, sélectionnez le nom de celle-ci dans la liste déroulante.
L'option Toutes les tables (qualifiées) affiche les champs qualifiés par le nom des tables dans lesquelles ils figurent. Autrement dit, les champs clés (de connexion) sont répertoriés plus d'une fois. (Cette option n'est utilisée qu'à des fins d'affichage et n'a rien à voir avec les champs Qualify dans le script de chargement.)
Promouvoir Déplace un champ vers le haut dans l'ordre d'affichage.
Abaisser Déplace un champ vers le bas dans l'ordre d'affichage.
Tri par fréquence Trie les champs de la colonne Champs affichés dans la table dans l'ordre numérique.
Ordre de chargement Trie les champs de la colonne Champs affichés dans la table dans l'ordre de chargement, à savoir l'ordre dans lequel ils sont lus à partir de la base de données.
Tri alphabétique Trie les champs de la colonne Champs affichés dans la table dans l'ordre alphabétique.
État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Pour les zones table, l'ID commence par TB01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Interpréteur de macros interne

Condition de calcul Spécifiez une condition de calcul qui doit être remplie pour que la zone table s'affiche. Tant que la condition n'est pas remplie, le message « Condition de calcul non remplie » s'affiche.
Messages d'erreur

Les messages d'erreur standard affichés dans les zones table (et les graphiques) peuvent être personnalisés dans la boîte de dialogue Messages d'erreur personnalisés, accessible via le bouton Messages d'erreur.

Messages d'erreur personnalisés

Trier

L'onglet Propriétés de la zone table : Trier est accessible par un clic droit sur une zone table, puis par la commande Propriétés du menu contextuel.

La liste Ordre de priorité du tri contient les champs de la zone table. L'ordre des champs détermine l'ordre de tri appliqué lorsque la commande Trier est exécutée. L'ordre des champs peut être modifié à l'aide des boutons Promouvoir et Abaisser. Pour chaque champ de la liste, on peut spécifier les critères à utiliser dans les procédures de tri. Les critères de tri sont décrits ci-dessous.

Trier par :

Expression Les valeurs de champs seront triées selon une expression arbitraire saisie dans la zone de texte située sous cette option de tri.
Fréquence Indique si le tri des valeurs doit se faire par la fréquence ou non.
Valeur numérique Indique si le tri des valeurs doit se faire par la valeur numérique ou non.
Texte Indique si le tri des valeurs doit respecter l'ordre alphabétique selon la norme ASCII ou non.
Ordre de chargement Indique si le tri des valeurs doit se faire dans l'ordre de chargement ou non.

Si plus d'un ordre de tri est spécifié, le tri se fera par expression, fréquence, valeur numérique, texte, ordre de chargement.

Présentation

L'onglet Propriétés de la zone table : Présentation est accessible par un clic droit sur une zone table, puis par la commande Propriétés du menu contextuel.

Cette boîte de dialogue sert à déterminer la disposition de la zone table.

Alignement Vous pouvez définir l'alignement par défaut des valeurs de champs séparément pour Texte et Nombre en sélectionnant le champ dans la liste Champs et l'option appropriée dans le groupe Alignement. Par défaut, les valeurs textuelles sont alignées à gauche et les valeurs numériques à droite.
Omettre les lignes si ce champ est nul Si cette case est cochée, les lignes contenant une valeur nulle (NULL) dans le champ sélectionné sont supprimées. Par NULL, on entend « aucune valeur ».
Sélection par menu déroulant Si cette case est cochée, une icône représentant une flèche est ajoutée à gauche de l'en-tête de la colonne du champ sélectionné. Cliquez sur cette icône pour accéder aux valeurs de champs dans une liste déroulante. Elle fonctionne exactement comme pour les sélections dans une liste multiple.
Avancé... Ce bouton ouvre la boîte de dialogue Paramètres de champ avancés qui contient des paramètres destinés à la représentation imagée des valeurs de champs et des options spéciales de recherche textuelle.
Paramètres multilignes Dans ce groupe, on peut décider que l'en-tête de la table et les cellules de données doivent afficher les valeurs sur plusieurs lignes, ce qui est utile pour les longues chaînes textuelles.
Renvoi auto. à la ligneHauteur d'en-tête n lignes
Cette option sélectionnée, l'en-tête affichera son contenu sur plus d'une ligne. Indiquez ici le nombre maximum de lignes d'en-tête de votre choix.
Renvoi auto. à la ligneHauteur de la cellule n lignes
Cette option sélectionnée, une cellule affichera son contenu sur plus d'une ligne. Indiquez ici le nombre maximum de lignes de cellule de votre choix.
Étiquettes verticales Si cette case est cochée, toutes les étiquettes de champ sont mises en position verticale.
Autoriser le glisser-déposer Si cette case est cochée, il est possible de trier les champs de la zone table en cliquant et en faisant glisser leur en-tête.
Indicateur de tri Si cette case est cochée, une icône d'indicateur de tri est ajoutée à droite de l'en-tête de la colonne du champ par lequel la zone table est triée. L'icône est inversée pour refléter l'ordre de tri ascendant ou descendant.
Indicateurs de sélection Si cette case est cochée, une icône d'indicateur de tri est ajoutée à droite de l'en-tête de la colonne du champ par lequel la zone table est triée. L'icône est inversée pour refléter l'ordre de tri ascendant ou descendant.
Supprimer la ligne d'en-tête Si cette case est cochée, la table s'affiche sans ligne d'en-têtes (étiquettes).

Style

Cette feuille de style s'applique à toutes les tables QlikView ainsi qu'aux zones table, tableaux simples et tableaux croisés dynamiques. Définissez ici les paramètres du style de formatage du tableau.

Style actif Choisissez un style de table approprié dans la liste déroulante. Si la valeur [Personnalisé] apparaît dans la liste déroulante, cela signifie qu'un style personnalisé a été appliqué à la table. Si vous rétablissez un des styles prédéfinis dans le paramètre Style, le formatage personnalisé est perdu.
Bandes toutes les _ lignes Vous pouvez indiquer s'il doit contenir des bandes ombrées et à quels intervalles.
Mode de mise en retrait Ce paramètre n'est valable que pour les tableaux croisés dynamiques. Quand cette option est cochée, on peut obtenir un style de tableau légèrement différent qui est particulièrement utile quand on a besoin de faire tenir un certain nombre d'étiquettes de dimension dans un tableau de largeur limitée.
Utiliser uniquement l'étiquette de la première dimension
Ce paramètre n'est disponible que pour les tableaux croisés dynamiques en mode de mise en retrait et permet de modifier davantage le style du tableau croisé dynamique.
Bordures verticales entre les dimensions Ce paramètre détermine si des bordures verticales doivent s'afficher pour les colonnes de dimensions.
Bordures verticales entre les expressions Comme l'option précédente, mais pour les colonnes d'expressions.
Bordure avant espacement

Vous pouvez modifier légèrement le style de table en cochant cette option, à condition qu'un espacement soit prévu dans la boîte de dialogue Paramètres de champ avancés.

Advanced Field Settings

Arrière-plan... Ouvre la boîte de dialogue Paramètres d'arrière-plan.
Transparence de la couleur d'arrière-plan de la cellule Si une couleur ou une image a été appliquée dans Paramètres d'arrière-plan, vous pouvez régler sa transparence dans l'arrière-plan de la cellule à cet endroit.
Transparence des bordures de cellule Indique si les bordures de cellule doivent être plus ou moins marquées.

Police

Vous pouvez définir ici la Police, le Style de police et la Taille de police à utiliser.

Vous pouvez définir la police d'un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, il est possible de définir les polices par défaut des nouveaux documents sous l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Fonctions de couleur

Les paramètres supplémentaires sont :

Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de la feuille. Spécifiez un type de bordure dans le menu déroulant.

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de la feuille :

Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.