Liste de sélection

La liste de sélection est l'objet le plus basique. Il contient une liste de toutes les valeurs possibles d'un champ donné. Chaque ligne de la liste peut représenter plusieurs enregistrements dans la table chargée, tous avec des valeurs identiques. Sélectionner une valeur peut ainsi revenir à sélectionner plusieurs enregistrements dans la table chargée.

Une liste de sélection peut aussi contenir un groupe cyclique ou hiérarchique. Avec un groupe hiérarchique, la liste de sélection passe au champ suivant du groupe lorsque vous sélectionnez une seule valeur dans la liste. Vous pouvez revenir en arrière en cliquant sur l'icône correspondante de la légende de la liste de sélection.

Si c'est un groupe cyclique qui est affecté à une liste de sélection, vous pouvez afficher le champ suivant du groupe en cliquant sur l'icône de cycle qui figure sur la légende de la liste. Vous pouvez aussi aller directement à un champ du groupe en utilisant l'option Cycle dans le menu Objet de la liste de sélection.

Cliquez avec le bouton droit de la souris dans la liste de sélection pour afficher le menu Objet.

Menu Objet

Le menu Objet de la liste de sélection s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés... Ouvre la boîte de dialogue Propriétés de la liste de sélection vous permettant de définir plusieurs paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Cycle

Disponible uniquement quand la liste de sélection doit afficher un groupe cyclique. Ouvre un menu en cascade avec les champs du groupe pour sélectionner directement les champs à afficher dans la liste de sélection.

Groupes non hiérarchiques (cycliques)

Rechercher

Ouvre la zone de recherche.

Rechercher

Recherche partielle

Ouvre la boîte de recherche textuelle en mode recherche partielle.

Recherche partielle

Recherche avancée

Ouvre la boîte de dialogue de recherche avancée. Cette boîte de dialogue permet de saisir des expressions avancées. Cette commande peut également être appelée à l'aide du raccourci clavier suivant : Ctrl+Maj+F.

Boîte de dialogue de recherche avancée

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Modifier la valeur Disponible uniquement pour les listes de sélection affichant des champs. En cliquant sur la cellule, celle-ci bascule en mode modification. Cette opération équivaut à cliquer sur l'icône de saisie dans la cellule.
Restaurer les valeurs Disponible uniquement pour les listes de sélection affichant des champs. Ouvre un menu en cascade présentant les trois options suivantes :
Restaurer une seule valeur
Restaure la valeur par défaut du champ sélectionné à partir du script.
Restaurer les valeurs possibles
Rétablit les valeurs par défaut de toutes les valeurs de champ possibles à partir du script.
Restaurer toutes les valeurs
Rétablit les valeurs par défaut de toutes les valeurs de champ à partir du script.
Sélectionner les valeurs possibles Toutes les valeurs non exclues dans la liste de sélection sont sélectionnées.
Sélectionner les valeurs exclues Toutes les valeurs exclues dans la liste de sélection sont sélectionnées.
Sélectionner tout Toutes les valeurs de la liste de sélection sont sélectionnées.
Effacer Efface toutes les sélections actives dans la liste de sélection active.
Effacer les autres champs Efface les sélections dans tous les autres objets de la feuille, tout en conservant celles de la liste de sélection active.
Verrouiller Verrouille la ou les valeurs sélectionnées dans la liste de sélection active. (Grisée si aucune sélection n'a été effectuée.)
Déverrouiller Déverrouille la ou les valeurs verrouillées dans la liste de sélection active. (Apparaît à la place de Verrouiller si des sélections ont été verrouillées.)
Créer un graphique instantané...

Ouvre l'assistant Graphique instantané qui vous aidera à créer un graphique rapidement et simplement.

Assistant Graphique instantané

Créer un graphique temporel...

Ouvre l'assistant Graphique temporel qui vous permet de créer un graphique dont une mesure (expression) doit être qualifiée et est généralement fonction d'une période de temps.

Assistant de création de graphique temporel

Créer une zone de statistiques Effectue plusieurs calculs statistiques sur les valeurs sélectionnées d'un champ (échantillon) et affiche les résultats dans une zone de statistiques.
Imprimer les valeurs possibles...

Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression. Toutes les valeurs non exclues de la liste de sélection active sont envoyées à l'imprimante.

Imprimer : Général

Imprimer les valeurs possibles au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer vers Excel

Exporte les valeurs possibles (y compris les valeurs sélectionnées) vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Les valeurs exportées apparaîtront dans une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.

Remarque: Les minis graphiques ne s'affichent pas lors de l'exportation vers Excel.
Exporter... Ouvre la boîte de dialogue Enregistrer sous dans laquelle vous pouvez indiquer le chemin, le nom de fichier et le type de fichier (de table) dans lequel les données exportées seront enregistrées.
Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Valeurs possibles
Copie les valeurs possibles (sélectionnées et facultatives) dans le Presse-papiers.
Valeur de la cellule
Copie dans le Presse-papiers la valeur textuelle de la cellule de liste de sélection sur laquelle vous avez cliqué avec le bouton droit de la souris (pour ouvrir le menu Objet).
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclut ou exclut la légende et la bordure de l'objet de feuille selon les paramètres définis dans la boîte de dialogue Préférences utilisateur : onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

L'onglet Propriétés de la liste de sélection : Général est accessible par un clic droit sur une liste de sélection, puis la commande Propriétés du menu contextuel. Il permet de définir des paramètres généraux pour la liste de sélection.

Titre

Texte de la légende de la liste de sélection. Le texte par défaut est le nom du champ sélectionné. Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Champ Sélectionnez un champ dans la liste. La liste de sélection contiendra les valeurs du champ sélectionné.
Une liste de sélection peut aussi afficher un groupe cyclique ou hiérarchique. Toutefois, un seul champ sera affiché à la fois. Ces groupes sont créés à partir de la boîte de dialogue Propriétés du document : Groupes et sont répertoriés avec les champs disponibles.
Avec un groupe hiérarchique, la liste de sélection passe au champ suivant du groupe lorsque vous sélectionnez une seule valeur dans la liste. On peut revenir en arrière en cliquant sur l'icône correspondante de la barre de titre de la liste de sélection.
Si un groupe cyclique est affecté à une liste de sélection, vous pouvez afficher le champ suivant du groupe en cliquant sur l'icône de cycle qui figure dans la légende de la liste de sélection. Vous pouvez aussi atteindre directement un champ du groupe en utilisant l'option Cycle-> disponible dans le menu Objet de la liste de sélection.
En outre, il est possible d'afficher un champ calculé dans une liste de sélection. Un champ calculé ne provient pas de l'exécution d'un script mais est défini à partir d'une expression. Les mêmes règles s'appliquent aux dimensions calculées. Si vous souhaitez utiliser un champ calculé dans la liste de sélection, sélectionnez <Expression> dans la liste déroulante pour ouvrir la boîte de dialogue Éditer l'expression dans laquelle vous pouvez définir l'expression décrivant le champ calculé.
Utiliser comme titre
Si vous cochez cette case, le nom du champ sera utilisé comme Titre. Le texte <utiliser le nom du champ> apparaîtra dans la zone d'édition Titre.
Éditer...
Ce bouton est disponible uniquement lorsque <Expression> est sélectionné comme nom de champ. Cela ouvre la boîte de dialogue Édition d'une expression dans laquelle vous définissez l'expression décrivant le champ calculé.
Remarque: Lorsqu'un champ calculé est utilisé, certaines fonctionnalités de la liste de sélection sont différentes de celles des listes de sélection de champ habituelles. Certaines options de propriété ne sont pas disponibles (voir ci-dessous). De plus, les zones de statistiques ne peuvent pas être créées à partir de telles listes de sélection.
Remarque: Un champ calculé doit toujours correspondre à une transformation d'un ou de plusieurs champs normaux. Les champs calculés entièrement synthétiques créés à l'aide des fonctions valuelist et valueloop ne sont pas autorisés. Lors des sélections dans un champ calculé, vous effectuez en réalité des sélections dans les champs normaux sous-jacents. Lorsque vous utilisez plus d'un champ comme base pour un champ calculé, les implications logiques des sélections dans les champs d'origine ou le champ calculé peuvent être assez complexes.  
Remarque: L'utilisation des champs calculés dans les listes de sélection peut entraîner des problèmes en termes de performances avec des ensembles de données extrêmement volumineux.
Remarque: Il n'est pas possible d'utiliser des champs de type MEASURE définis à l'aide de la fonction Direct Discovery dans une zone de sélection.
Mode AND

Les sélections multiples dans un champ doivent être de type AND ou OR. Par défaut, la sélection est de type OR. Cette commande change le mode logique des sélections multiples de valeurs. Cette option du menu est désactivée si le champ ne satisfait pas à certaines conditions. Cette option n'est pas disponible pour les champs calculés.

Afficher les alternatives Détermine si une sélection effectuée directement dans la liste de sélection active doit exclure ou non les autres valeurs du champ. Si la case Afficher les alternatives est cochée, toutes les valeurs à l'exception de la valeur sélectionnée seront affichées sous l'intitulé Facultatif, mais elles peuvent être exclues par association à des sélections dans d'autres champs. Sinon, toutes les autres valeurs sont considérées comme exclues par défaut. Cette option n'est pas disponible pour les champs calculés.
Masquer les valeurs exclues Détermine si les valeurs exclues du champ doivent être affichées ou non. Les valeurs exclues ne peuvent plus être sélectionnées.
Lecture seule Cocher cette option vous empêchera d'effectuer des sélections dans la liste de sélection. Elle continuera cependant à refléter les sélections effectuées ailleurs dans le document.
Toujours une valeur sélectionnée

Lorsqu'elle est cochée, cette option garantit qu'une seule valeur peut être sélectionnée à la fois, ce qui s'avère utile pour les documents dont les données n'ont de sens que lorsqu'une valeur est déjà sélectionnée, telle qu'un taux de change, etc. Cette option est activée une fois qu'une valeur a déjà été sélectionnée dans la liste de sélection. Cette option n'est pas disponible pour les champs calculés.

Remarque: L'activation de cette option modifie le modèle de données. De ce fait, les favoris existants risquent de ne plus fonctionner, même si vous conservez les noms des champs inchangés.
Outrepasser le verrouillage du champ Cocher cette option permet d'effectuer des sélections dans la liste de sélection, même si elle est verrouillée. La liste de sélection restera verrouillée pour des sélections effectuées ailleurs dans le document.
Afficher sous forme d'arborescence

Présente la liste de sélection sous forme d'arborescence. Cette option s'applique uniquement lorsque le champ présente la représentation du chemin de nœuds sous forme hiérarchique. Il est possible de générer un tel champ à l'aide du paramètre Chemin du préfixe Hiérarchie.

Affichage sous forme d'arbre d'une liste de sélection

Avec séparateur Définit le caractère qui devrait être interprété comme séparateur dans le chemin utilisé pour l'affichage sous forme d'arborescence.
Afficher la fréquence Détermine si la fréquence d'une valeur de champ est affichée ou non. Par fréquence, on entend le nombre de combinaisons sélectionnables dans lesquelles la valeur figure. Cette option n'est pas disponible pour les champs calculés.
En pourcentage Détermine si la fréquence doit être indiquée en chiffres absolus ou en pourcentage du nombre total d'entrées.
État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Nous vous recommandons d'utiliser exclusivement des caractères alphanumériques dans l'ID. Pour les listes de sélection, l'ID commence par LB01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Interpréteur de macros interne

Inclure les valeurs exclues dans la recherche Cette liste déroulante vous permet de choisir entre Oui, Non ou <par défaut> qui applique le paramètre par défaut spécifié sous Préférences utilisateur : Général.
Mode de recherche par défaut Spécifie le mode de recherche par défaut initial dans les recherches textuelles. Le mode peut toujours être modifié directement en tapant * ou ~ dans la chaîne de caractères à rechercher. Les options suivantes sont disponibles :
<par défaut>
La valeur par défaut spécifiée sous Préférences utilisateur s'applique alors.
Recherche par caractères génériques
La chaîne de recherche initiale se compose de deux caractères génériques séparés par le curseur afin de faciliter ce type de recherche.
Recherche partielle
La chaîne de recherche initiale se compose d'un tilde (~) pour signaler une recherche partielle.
Recherche classique
Aucun caractère supplémentaire n'est ajouté à la chaîne de recherche. En l'absence de caractères génériques, c'est une recherche classique qui est effectuée.
Recherche associative
La recherche associative est utilisée dans la zone de recherche.

Rechercher

Paramètres d'impression Vous pouvez définir ici les paramètres pour les tâches d'impression.
Imprimer toutes les valeurs Normalement, le programme imprime uniquement les valeurs possibles des listes de sélection. Cette case cochée, toutes les valeurs (y compris les valeurs exclues) seront imprimées.
Impression conforme à la disposition Cette case cochée, la liste de sélection sera imprimée telle qu'elle apparaît à l'écran en termes de colonnes multiples, de codage couleur des sélections dans les cellules, etc. Cette option peut s'avérer utile, par exemple, lorsque les listes de sélection sont incluses dans les rapports.

Expressions

Sous l'onglet Expressions, vous définissez les expressions à afficher dans la liste de sélection. Chaque expression est placée dans une nouvelle colonne de la liste de sélection. Le coin supérieur gauche de la boîte de dialogue contient une liste des expressions.

Les données de l'expression peuvent aussi être formatées de manière dynamique au moyen d'attributs. Cliquez sur l'icône de développement située devant une expression pour afficher les attributs correspondants.

Vous pouvez choisir d'utiliser autant d'attributs et de combinaisons d'attributs que vous le souhaitez pour une expression de base donnée. Le formatage défini au moyen d'un attribut remplace le formatage par défaut des points de données en termes de couleur, etc.

Ajouter En cliquant sur ce bouton, vous ouvrirez la boîte de dialogue Éditer les expressions, dans laquelle vous pourrez créer de nouvelles expressions. Cette option est également disponible dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions.
Supprimer Supprime l'expression sélectionnée. Cette option est également disponible dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions.
Copier Cette option n'est disponible que dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions. L'utilisation de cette commande sur une expression principale entraîne la copie des paramètres et données associés à l'expression (y compris les étiquettes) dans le Presse-papiers comme faisant partie du xml. L'expression peut ensuite être collée dans le même objet ou dans un autre objet QlikView, dans le même document ou dans un document différent. Si vous utilisez cette commande sur un attribut, seule la définition de l'attribut est copiée. L'attribut peut ensuite être collé sur n'importe quelle expression principale du même objet ou d'un objet différent.
Exporter... Cette option n'est disponible que dans le menu contextuel apparaissant via un clic droit sur une expression principale de la liste d'expressions. L'utilisation de cette commande sur une expression principale permet l'exportation des paramètres et données associés à l'expression (y compris les étiquettes) vers un fichier xml. L'expression peut ensuite être importée dans le même graphique ou dans un autre graphique QlikView, dans le même document ou dans un document différent. La commande ouvre la boîte de dialogue Exporter l'expression sous permettant de sélectionner la destination du fichier d'exportation. Le fichier est doté d'une extension, par exemple xml.
Coller Cette option n'est disponible que dans le menu contextuel apparaissant via un clic droit dans la liste d'expressions et seulement si une expression a d'abord été copiée dans le Presse-papiers. Si une expression principale a été copiée dans le Presse-papiers, vous pouvez la coller dans une zone vide de la liste d'expressions. Vous créez alors une nouvelle expression identique à celle copiée. Si un attribut a été copié, vous pouvez le coller dans une expression principale.
Importer... Cette option n'est disponible que dans le menu contextuel apparaissant via un clic droit dans une zone vide de la liste d'expressions. La commande ouvre une boîte de dialogue permettant de rechercher les expressions exportées. L'expression importée apparaît alors sous la forme d'une nouvelle expression principale dans le graphique.
Promouvoir Monte l'expression sélectionnée d'un cran dans la liste. Utilisez ce bouton si vous voulez modifier l'ordre des expressions.
Abaisser Abaisse l'expression sélectionnée d'un cran dans la liste. Utilisez ce bouton si vous voulez modifier l'ordre des expressions.
Symbole "Nul" Le symbole indiqué ici servira à afficher les valeurs NULL dans le tableau.
Symbole "Manquant" Le symbole indiqué ici servira à afficher les valeurs manquantes dans le tableau.
Activer Cocher cette case activera l'expression sélectionnée. Si la case n'est pas cochée, l'expression ne sera pas utilisée du tout.
Définition Affiche la composition de l'expression sélectionnée. On peut modifier l'expression directement dans cette zone. Le bouton ... permet d'ouvrir la boîte de dialogue Éditer les expressions complète.
Afficher Si l'option Toujours est sélectionnée, l'expression est visible en permanence dans une colonne supplémentaire figurant dans la liste de sélection. Si l'option Conditionnel est sélectionnée, l'expression sera affichée ou masquée dynamiquement en fonction de la valeur de l'expression conditionnelle saisie dans la zone d'édition de droite.
Alignement Dans ce groupe, vous pouvez définir l'alignement par défaut de vos expressions. Il est possible de définir l'alignement du texte et des nombres à gauche, au centre ou à droite.
Options d'affichage Ce groupe détermine les données figurant dans les cellules d'expression de la liste de sélection.
Représentation Les options suivantes sont proposées :
Texte
Si vous sélectionnez cette option, les valeurs d'expression seront toujours interprétées et affichées comme du texte.
Image
Si vous sélectionnez cette option, QlikView tentera d'interpréter chaque valeur d'expression comme une référence à une image. La référence peut désigner le chemin d'accès à un fichier image sur le disque (par exemple, C:\Monimage.jpg) ou dans le document qvw (par exemple, qmem://<Nom>/<Pierre>). Si QlikView ne peut pas interpréter une valeur d'expression comme une référence d'image valide, il affichera la valeur elle-même.
Jauge circulaire
Si vous sélectionnez cette option, QlikView affichera la valeur d'expression sous la forme d'une jauge de type compteur. La jauge sera incluse dans la cellule de table disponible. Vous pourrez modifier les paramètres visuels de cette jauge en cliquant sur le bouton Paramètres de la jauge.
Jauge linéaire
Si vous sélectionnez cette option, QlikView affichera la valeur d'expression sous la forme d'une jauge linéaire horizontale. La jauge sera incluse dans la cellule de table disponible. Vous pourrez modifier les paramètres visuels de cette jauge en cliquant sur le bouton Paramètres de la jauge.
Jauge - Feux de signalisation
Si vous sélectionnez cette option, QlikView affichera la valeur d'expression sous la forme d'une jauge de type feux de circulation. La jauge sera incluse dans la cellule de table disponible. Vous pourrez modifier les paramètres visuels de cette jauge en cliquant sur le bouton Paramètres de la jauge.
Jauge de type voyant
Si vous sélectionnez cette option, QlikView affichera la valeur d'expression sous la forme d'une jauge de type voyant. La jauge sera incluse dans la cellule de table disponible. Vous pourrez modifier les paramètres visuels de cette jauge en cliquant sur le bouton Paramètres de la jauge.
Mini graphique
Si vous sélectionnez cette option, QlikView affiche la valeur d'expression sous la forme d'un graphique miniature, l'expression étant placée sur une dimension supplémentaire. Le graphique est inclus dans la cellule de tableau disponible. La dimension du mini graphique peut être définie et les paramètres visuels modifiés via le bouton Paramètres du mini graphique (voir ci-dessous).
Remarque: Les mini graphiques ne s'affichent pas lors de l'exportation vers Excel.
Paramètres de la jauge Disponible uniquement quand l'une des options de jauge ci-dessus a été sélectionnée. Ouvre une boîte de dialogue destinée à définir les propriétés de la jauge. Cette boîte de dialogue équivaut pour l'essentiel à la boîte de dialogue Propriétés du graphique : Présentation réservée aux jauges.
Propriétés du mini graphique Disponible uniquement lorsque Mini graphique a été sélectionné comme option d'affichage pour une expression de la table. Ouvre une boîte de dialogue destinée à définir les propriétés du mini graphique.
Formatage d'image Disponible uniquement quand l'option image ci-dessus a été sélectionnée. Ce paramètre décrit comment QlikView formate l'image pour l'adapter à la cellule. Il existe quatre possibilités.
Sans étirement
Si cette option est sélectionnée, l'image s'affiche telle quelle, sans aucun étirement. L'image peut donc être partiellement cachée ou ne remplir qu'une partie de la cellule.
Remplir
Si cette option est sélectionnée, l'image est étirée de manière à s'adapter à la cellule sans nécessairement conserver ses proportions.
Conserver les proportions
Si cette option est sélectionnée, l'image est étirée autant que possible pour remplir la cellule tout en conservant ses proportions. En général, vous obtenez des zones sur les deux côtés ou en haut et en bas qui ne sont pas remplies par l'image.
Proportionnel
Si cette option est sélectionnée, l'image est étirée dans les deux sens pour remplir la cellule tout en conservant ses proportions. En général, cela entraîne le rognage de l'image dans un sens.
Masquer le texte quand l'image n'est pas disponible
Si cette option est sélectionnée, QlikView n'affichera pas le texte de la valeur de champ si son interprétation comme référence à une image échoue pour une raison ou pour une autre. La cellule sera donc laissée vide.

Propriétés du mini graphique

Disponible uniquement lorsque l'option Mini graphique a été sélectionnée dans la page Expressions de la boîte de dialogue Propriétés d'un tableau simple. Ouvre une boîte de dialogue destinée à définir les propriétés du mini graphique.

Dimension Choisissez la dimension pour laquelle l'expression doit être tracée.

Apparence

Mode Définissez le mini graphique sous forme de graphique sparkline, ligne avec points, points, barres ou boîte à moustaches.
Couleur Ouvre la boîte de dialogue Couleur de la zone dans laquelle vous pouvez définir la couleur du mini graphique.
Mettre en surbrillance la valeur maximale Cochez la case et cliquez sur le bouton coloré pour ouvrir la boîte de dialogue Couleur de la zone où la couleur de la valeur maximale peut être définie.
Mettre en surbrillance la valeur minimale Cochez la case et cliquez sur le bouton coloré pour ouvrir la boîte de dialogue Couleur de la zone où la couleur de la valeur minimale peut être définie.
Mettre en couleur les valeurs de début Cochez la case et cliquez sur le bouton coloré pour ouvrir la boîte de dialogue Couleur de la zone où la couleur des valeurs de début peut être définie. Non disponible pour les options Barres et Limites.
Mettre en surbrillance les valeurs de fin Cochez la case et cliquez sur le bouton coloré pour ouvrir la boîte de dialogue Couleur de la zone où la couleur des valeurs d'extrémité peut être définie. Non disponible pour les options Barres et Limites.
Configurer les couleurs par défaut Définit les couleurs des paramètres de surbrillance sur les couleurs par défaut de QlikView.
Forcer l'origine de l'échelle à zéro Fixe le bord inférieur du graphique à zéro sur l'axe. Non disponible pour l'option Limites.
Forcer une échelle partagée pour l'axe des Y Oblige l'ensemble des cellules de la colonne à utiliser la même échelle d'axe Y.

Trier

L'onglet Trier est accessible par un clic droit sur un objet (liste de sélection, liste multiple, zone Table, graphique ou objet curseur/calendrier), puis par l'option Propriétés dans le menu contextuel (ou Objet, Propriétés dans le menu principal). Ici, vous pouvez définir l'ordre des valeurs dans l'objet. Il se peut que certaines options de tri ne soient pas disponibles pour tous les objets.

Trier par :

État

Trie les valeurs de champ selon leur état logique (sélectionnée, facultative ou exclue).
Le paramètre Croissant automatique permet de trier la liste de sélection (ou, dans une liste multiple, la liste déroulante contenant les valeurs de champ) par État uniquement si la liste de sélection contient une barre de défilement verticale. Cependant, si vous agrandissez la liste de sélection pour afficher toutes les valeurs, l'ordre de tri État est complètement désactivé.

Remarque: Veillez à ne pas utiliser l'ordre Croissant automatique dans une liste de sélection figurant à l'intérieur d'un objet de type Conteneur.
Expression Trie les valeurs de champs selon l'expression saisie dans la zone de texte située sous cette option de tri. Si vous utilisez le tri par expression, un ensemble d'enregistrements alternatif doit être défini par une expression d'ensemble. En effet, l'expression est calculée sur les valeurs sélectionnées/possibles de la liste et le tri s'appliquerait uniquement aux valeurs sélectionnées/possibles de la liste.
Remarque: Le tri par expression fonctionne exclusivement avec les champs numériques, et pas avec les champs textuels.

Analyse d'ensembles et expressions d'ensemble

Fréquence Trie les valeurs de champs par fréquence (nombre d'occurrences dans la table).
Valeur numérique Trie les valeurs de champ par valeur numérique.
Texte Trie les valeurs des champs par ordre alphabétique.
Ordre de chargement Trie les valeurs de champs dans l'ordre de chargement initial.

Le bouton Par défaut définit l'ordre de tri par défaut.

L'ordre de priorité est État, Expression, Fréquence, Valeur numérique, Texte, Ordre de chargement. Chacun de ces critères de tri peut être défini sur Croissant ou Décroissant.

Présentation

L'onglet Propriétés de la liste de sélection : Présentation est accessible par un clic droit sur une liste de sélection, puis la commande Propriétés du menu contextuel. Il permet d'ajuster la disposition des cellules de la liste de sélection.

Dans le groupe Options d'image, vous pouvez faire interpréter une valeur de champ comprenant une référence à une image en mémoire ou sur le disque comme l'image en question :

Dans Représentation, vous pouvez choisir entre Texte (par défaut), Image et Informations comme image.

Lorsque vous sélectionnez Image, QlikView essaie d'interpréter chaque valeur de champ comme référence à une image. La référence peut être le chemin d'un fichier image sur le disque (par exemple, C:\Monimage.jpg) ou dans le document qvw lui-même (par exemple qmem://<Nom>/<Pierre>). Si QlikView ne peut pas interpréter une valeur de champ comme une référence d'image valide, il affiche la valeur elle-même, sauf si la case Masquer le texte quand l'image n'est pas disponible est cochée.

Lorsque vous sélectionnez Informations comme image, QlikView affiche les informations d'image liées à la valeur de champ à l'aide des instructions info load/info select dans le script. Si aucune information d'image n'est disponible pour une valeur de champ, le programme affiche la valeur elle-même, sauf si la case Masquer le texte quand l'image n'est pas disponible est cochée.

À partir du moment où une des options d'image est sélectionnée, vous pouvez utiliser les paramètres Formatage d'image pour ajuster l'image à la cellule.

Sans étirement L'image est affichée telle quelle et peut donc être en partie masquée.
Remplir L'image est étirée pour remplir la cellule, mais ses proportions ne sont pas respectées.
Conserver les proportions L'image est étirée autant que possible tout en conservant les bonnes proportions.
Proportionnel L'image est étirée autant que possible tout en conservant les bonnes proportions. Les zones non couvertes sont ensuite remplies à l'aide de morceaux de l'image.

Lorsque des images apparaissent au lieu de texte, il peut être nécessaire d'utiliser un autre style de sélection que le style par défaut du document, de façon à ce que l'état logique des valeurs de champs reste visible. Utilisez la liste déroulante dans Forcer le style de sélection pour sélectionner un style de sélection approprié, par exemple Balise d'angle.

Colonne unique Si cette option est cochée, les valeurs de champ de la liste de sélection seront toujours présentées en une seule colonne.
Supprimer la barre de défilement horizontale Cochez cette option pour supprimer la barre de défilement horizontale qui s'affiche normalement quand les valeurs de champs sont trop larges pour tenir dans la liste de sélection. Les valeurs de champs seront alors tronquées au besoin.
Nombre de colonnes fixe Cochez cette option pour définir un nombre fixe de colonnes pour la liste de sélection. Cette option n'est pas disponible quand la case Colonne unique est cochée.
Trier par colonne Dans les listes de sélection à plus d'une colonne, les valeurs sont affichées en ligne dans l'ordre de tri spécifié. L'option Trier par colonne passe à un affichage en colonne.
Bordures de cellule Les valeurs de champs seront séparées par des lignes horizontales, comme les lignes d'une table. L'option Bordures de cellule est automatiquement activée quand l'option Renvoi à la ligne du texte des cellules est cochée mais peut être désactivée ensuite.
Mettre en surbrillance la chaîne de
caractères recherchée
La chaîne de caractères à rechercher saisie dans un objet de recherche jusqu'à présent est en surbrillance dans les correspondances.
Arrière-plan... Ouvre la boîte de dialogue Paramètres d'arrière-plan.
Alignement Vous définirez ici l'alignement des valeurs de champs dans la liste de sélection. L'alignement du Texte et des Nombres est défini séparément.
Paramètres multilignes Dans ce groupe, on peut décider que les cellules de la liste de sélection doivent afficher les valeurs sur plusieurs lignes, ce qui est utile pour les longues chaînes textuelles.
Renvoi à la ligne du texte des cellules
Cette option sélectionnée, une cellule affichera son contenu sur plus d'une ligne.
Hauteur n Lignes
Vous pouvez indiquer ici le nombre maximum de lignes de cellule de votre choix.

Paramètres d'arrière-plan

Couleur Si ce paramètre est activé, l'arrière-plan de l'objet sera en couleur. Sélectionnez une couleur en cliquant sur le bouton Couleur.
Transparence de la couleur Disponible uniquement lorsque l'option de couleur est activée. Définit la transparence de la couleur d'arrière-plan.
Image Si ce paramètre est activé, l'arrière-plan de l'objet sera une image. Cliquez sur Parcourir pour choisir une image. Cliquez sur Supprimer pour la supprimer de l'arrière-plan.
Étirement de l'image Disponible uniquement lorsque l'option d'image est activée. Ce paramètre décrit comment QlikView formate l'image pour en adapter la taille.
Sans étirement
L'image s'affiche telle quelle, sans aucun étirement. L'image pourra donc être partiellement cachée ou ne remplir qu'une partie de l'arrière-plan.
Remplir
L'image sera étirée et s'adaptera à l'arrière-plan sans conserver ses proportions.
Conserver les proportions
L'image sera étirée autant que possible pour remplir l'arrière-plan tout en conservant ses proportions.
Proportionnel
Si cette option est sélectionnée, l'image est étirée dans les deux sens pour remplir l'arrière-plan tout en conservant ses proportions. En général, cela entraîne le rognage de l'image dans un sens.
Alignement horizontal Disponible uniquement lorsque l'option d'image est activée. Aligne l'image, à gauche, au centre ou à droite.
Alignement vertical Disponible uniquement lorsque l'option d'image est activée. Aligne l'image en Haut, Au centre ou en Bas.
Transparence de l'image Disponible uniquement lorsque l'option d'image est activée. Définit la transparence de l'image d'arrière-plan.

Nombre

La page Propriétés : Nombre est accessible par un clic droit sur un objet de feuille, puis par la commande Propriétés du menu contextuel.

Chaque champ dispose d'un format de nombre par défaut qu'il est possible de définir sous l'onglet Propriétés du document : Nombre. Il est cependant possible d'utiliser un format de nombre distinct pour un objet donné. Pour ce faire, cochez l'option Outrepasser les paramètres du document et spécifiez un format de nombre dans le groupe ci-dessous. Cet onglet s'applique à l'objet actif et contient les options suivantes pour formater les valeurs :

Mixte À la fois des nombres et du texte. Les nombres sont affichés dans leur format d'origine.
Nombre Affiche des valeurs numériques dont le nombre de chiffres est défini dans la boîte fléchée précision.
Entier Affiche les valeurs numériques sous forme d'entiers.
Fixé à Affiche des valeurs décimales dont le nombre de décimales est défini dans la boîte fléchée Décimales.
Monétaire Affiche les valeurs au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu. Le format par défaut est le format monétaire de Windows.
Date Affiche des valeurs qui peuvent être interprétées comme des dates au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Heure Affiche des valeurs qui peuvent être interprétées comme des heures au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Horodateur Affiche des valeurs qui peuvent être interprétées comme la date et l'heure au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Intervalle Affiche l'heure sous forme d'incrément de temps séquentiel (par exemple format = mm affiche la valeur en nombre de minutes depuis le début du calendrier, à savoir 1899:12:30:24:00).
Affichage en pourcentage (%) Cette case à cocher concerne les formats suivants : Nombre, Entier et Fixé.

Les séparateurs Décimal et De milliers peuvent être définis dans les zones d'édition du groupe Séparateurs.

Le bouton ISO utilise la norme ISO pour les formats de date, d'heure et d'horodateur.

Le bouton Système applique les paramètres du système au format.

Le bouton Modifier le format du document ouvre l'onglet Propriétés du document : Nombre, qui permet d'éditer le format numérique par défaut de n'importe quel champ.

Police

Vous pouvez définir ici la Police, le Style de police et la Taille de police à utiliser.

Vous pouvez définir la police d'un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, il est possible de définir les polices par défaut des nouveaux documents sous l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Fonctions de couleur

Les paramètres supplémentaires sont :

Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de la feuille. Spécifiez un type de bordure dans le menu déroulant.

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de la feuille :

Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.

Propriétés de légende et de bordure

La boîte de dialogue Propriétés de légende et de bordure vous permet de définir les objets du document auxquels les propriétés de légende et de bordure doivent s'appliquer.

Appliquer les propriétés à... Cochez cette case pour appliquer les paramètres aux autres objets que l'objet actif.
1. Choisissez l'une des options suivantes :
Objets de cette feuille
Applique uniquement les paramètres aux objets de la feuille active. Disponible uniquement lorsque cette boîte de dialogue est ouverte à partir de l'onglet Disposition d'un objet de feuille.
Objets de ce document
Applique les paramètres aux objets de tout le document.
2. Choisissez l'une des options suivantes :
Uniquement ce type d'objet
Applique les paramètres à tous les objets de ce type. Disponible uniquement lorsque cette boîte de dialogue est ouverte à partir de l'onglet Disposition d'un objet de feuille.
Tous les types d'objets
Applique les paramètres à tous les objets.
Définir par défaut pour les nouveaux objets de ce document Cochez cette case pour utiliser les paramètres comme valeurs par défaut pour tous les nouveaux objets du document actif. Disponible uniquement lorsque cette boîte de dialogue est ouverte à partir de l'onglet Disposition d'un objet de feuille.

Affichage sous forme d'arbre d'une liste de sélection

Si un champ contient des chemins d'accès à des nœuds dans une hiérarchie, par exemple Monde/Amérique du Nord/États-Unis/Californie/Vallée de Napa, une liste de sélection peut apparaître sous la forme d'une vue arborescente. L'affichage sous forme d'arbre présente les nœuds avec un retrait pour faciliter la navigation et permettre à l'utilisateur de réduire les nœuds pour qu'une ligne unique dans la liste de sélection représente une branche dans la hiérarchie plutôt qu'un nœud distinct.

Les sélections sont effectuées de la manière habituelle et les sélections multiples sur différents niveaux dans la hiérarchie sont naturellement acceptées.

Pour les nœuds étendus et les feuilles (nœuds inférieurs), le codage couleur standard de QlikView est utilisé. Cependant, les nœuds réduits peuvent contenir un mélange d'états différents. Dans ce cas, le nœud apparaît en vert uniquement si toutes les valeurs ont été sélectionnées, en gris si toutes les valeurs sont exclues et en blanc dans les autres cas. En outre, un petit signal indique l'état des nœuds masqués.

Procédure de création de listes de sélection et de zones table à l'aide de Direct Discovery

Listes de sélection

Vous avez la possibilité de créer des listes de sélection avec des champs de type DIMENSION et de type MEASURE. Lorsque vous utilisez un champ de type MEASURE dans une expression de liste de sélection, vous devez vous servir de la fonction aggr() pour afficher la valeur agrégée du champ MEASURE avec un champ DIMENSION. Les sélections effectuées avec des champs DIMENSION dans une liste de sélection génèrent des requêtes SQL sur la source de données en vue de créer la table associative dans la mémoire.

Les champs de type DETAIL ne sont pas disponibles dans les listes de sélection.

Remarque:

Étant donné que les listes de sélection affichent seulement les valeurs uniques d'un champ de type DIMENSION, la requête que QlikView génère pour afficher les données de liste de sélection emploie le mot-clé DISTINCT afin de récupérer les données dans la base de données. Cependant, certaines bases de données exigent l'utilisation d'une classe GROUP BY dans la requête au lieu du mot-clé DISTINCT. Si la table Direct Discovery provient d'une base de données nécessitant GROUP BY, utilisez la variable DirectDistinctSupport pour modifier le comportement par défaut des requêtes DIMENSION.

DirectDistinctSupport

Zones table

Les zones table permettent d'afficher les types de champ Direct Discovery et d'explorer en détail les enregistrements contenant des champs Direct Discovery. Les zones table sont les seuls objets QlikView dans lesquels il est possible d'utiliser les champs spécifiés comme de type DETAIL dans l'instruction Load Direct Query .

Lorsque des champs Direct Discovery sont utilisés dans une zone table, un seuil est défini en vue de limiter le nombre de lignes affichées. Le seuil par défaut est de 1 000 enregistrements. Il est possible de modifier le paramètre de seuil par défaut en définissant la variable DirectTableBoxListThreshold dans le script de chargement. Par exemple :

SET DirectTableBoxListThreshold=5000

Le paramètre de seuil s'applique uniquement aux zones table contenant des champs Direct Discovery. Les zones table comportant exclusivement des champs chargés en mémoire ne sont pas limités par le paramètre DirectTableBoxListThreshold .

Aucun champ n'est affiché dans la zone table tant que la sélection comporte un nombre d'enregistrements supérieur à la limite de seuil fixée.

Dans une zone table, il est possible de mélanger des champs Direct Discovery et des champs chargés en mémoire. Les zones table contenant uniquement des champs Direct Discovery doivent inclure un champ DIMENSION.

Les zones table comportant des données Direct Discovery affichent toutes les lignes sélectionnées, même si elles incluent des données identiques. En revanche, les zones table comportant des données chargées en mémoire affichent seulement l'une des lignes sélectionnées lorsque plusieurs lignes incluent les mêmes données.